Subject: [Anima] DNA

From: Brian E Carpenter <[email-masked]>
Date: Tue, 03 Mar 2015 13:32:22 +1300

Should we be considering the aims and mechanisms of the old
Detecting Network Attachment (DNA) work in the IETF, and
specifically the mechanisms standardised by RFC 4436 (v4)
and RFC 6059 (v6)?

At the least, should we be assuming that autonomic nodes
will use these mechanisms as a matter of course? Or is
that science fiction?

(Thanks to Brian Haberman for reminding me of this work.)

Regards
   Brian Carpenter

---

From: Ted Lemon <[email-masked]>
Date: Mon, 2 Mar 2015 21:04:05 -0500

> will use these mechanisms as a matter of course? Or is

Regular nodes seem to use them.   Why wouldn't autonomic nodes?

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 03 Mar 2015 15:45:48 +1300

> Regular nodes seem to use them.   Why wouldn't autonomic nodes?

I guess my question is whether we regard them as mandatory.

   Brian

---

From: Sheng Jiang <[email-masked]>
Date: Tue, 3 Mar 2015 03:23:11 +0000

>I guess my question is whether we regard them as mandatory.

Where can we make them mandatory? Yes, they are reasonable functions for autonomic nodes. But we do not have an integrated requirements for autonomic nodes, neither for autonomic network architecture. The only opinion I can think out is to redesign the mechanisms and try to embed them into ANIMA Protocols, for which I don't think is right thing to do.

Best regards,

Sheng

>   Brian
>
>_______________________________________________
>Anima mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/anima

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 03 Mar 2015 17:02:48 +1300

Regards
   Brian Carpenter
   http://orcid.org/0000-0001-7924-6182

On 03/03/2015 16:23, Sheng Jiang wrote:
>>>> At the least, should we be assuming that autonomic nodes will 
>>>> use these mechanisms as a matter of course? Or is that science
>>>>  fiction?
>>> 
> Where can we make them mandatory? Yes, they are reasonable functions
> for autonomic nodes. But we do not have an integrated requirements 
> for autonomic nodes, neither for autonomic network architecture. The
> only opinion I can think out is to redesign the mechanisms and try 
> to embed them into ANIMA Protocols, for which I don't think is right
> thing to do.

I agree, except that the ACP draft might say something about the need
to detect loss of connectivity. The issue could also be mentioned in the
reference-model draft, I guess.

It's also an example of existing autonomic behavior, so perhaps should
have been mentioned in the NMRG document.

Regards
   Brian

---

From: Ted Lemon <[email-masked]>
Date: Tue, 3 Mar 2015 07:51:03 -0500

> Where can we make them mandatory? Yes, they are reasonable functions for autonomic nodes. But we do not have an integrated requirements for autonomic nodes, neither for autonomic network architectu…

Why not make the ones that are dependable mandatory?   Do you think that layer 2 stuff shouldn't be mentioned in Anima documents?   DNA makes stacks' behavior a lot better in general, although occasionally it can result in unnecessary brief outages when a cable is unplugged and plugged back in to the same network, but for Anima devices isn't this kind of a non-problem?

---

From: Sheng Jiang <[email-masked]>
Date: Wed, 4 Mar 2015 00:38:44 +0000

>for autonomic nodes. But we do not have an integrated requirements for
>autonomic nodes, neither for autonomic network architecture. The only
>opinion I can think out is to redesign the mechanisms and try to embed them
>into ANIMA Protocols, for which I don't think is right thing to do.
>
>Why not make the ones that are dependable mandatory?   Do you think that
>layer 2 stuff shouldn't be mentioned in Anima documents?   

Of course, there is no any restriction that layer 2 stuff shouldn't be mentioned in Anima documents. My point was there is not a suitable document in our current plan deliverables to contain this mandatory. We do not have a document for requirements of ANIMA devices, neither for ANIMA architecture. Reference model may be a document to mention it, but it is an informational document, which cannot make any mandatory requirements.

Of course, we can have a new document for this and for other requirements of ANIMA devices. And we could make it milestone later with approval from the responsible Area Director or by re-chartering. But I don't think we have know enough to make a full requirements yet.

Best regards,

Sheng

>DNA makes
>stacks' behavior a lot better in general, although occasionally it can result in
>unnecessary brief outages when a cable is unplugged and plugged back in to
>the same network, but for Anima devices isn't this kind of a non-problem?
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 17 Mar 2015 14:38:22 +1300

Getting back to this:

It seems to me that while we have no plans to write an
Autonomic Node Requirements draft any time soon, the
expectation that nodes should run DNA belongs for now in
draft-behringer-anima-reference-model-00

Regards
   Brian