Subject: Re: [EToSat] [Masque] Call for MASQUE use cases

From: "Border, John" <[email-masked]>
Date: Tue, 3 Mar 2020 22:43:08 +0000

Here is another potential use case...

    There is a trend towards using satellite links in a multipath combination with a terrestrial technology (e.g. LTE).  The two paths provide redundancy for each other.  But, the big selling point is using QoS classification to send traffic which requires low latency (i.e. truly interactive traffic) via the terrestrial path and traffic which requires high throughput (so called bulk traffic) through the satellite path.  As I understand the Multipath QUIC proposal, the solution requires the end host to select the path to use (and is also oriented towards sending the same connection via multiple paths).  In the use cases we see, the end hosts are not cognizant of the multiple paths.  The edge router classifies traffic (perhaps with DSCP help from the end host) and selects the path.  The router also knows about path failures and degradations.   With QUIC, traffic classification is blocked.  Perhaps we can get end hosts to opt in and expose traffic classification via DSCPs.  But, that has the potential of being carried farther than necessary.  A proxy could be trusted with just enough information to do the classification while removing the evidence before forwarding the traffic.

    Does this fit?

John

-----Original Message-----
From: Masque <[email-masked]> On Behalf Of Christopher Wood
Sent: Thursday, February 20, 2020 10:13 PM
To: [email-masked]
Subject: [Masque] Call for MASQUE use cases

**EXTERNAL EMAIL** 

The core MASQUE protocol [1] describes a simple negotiation mechanism for various applications. However, it omits use cases for these applications. MASQUE obfuscation in support of a "hidden VPN" service is one use case [2]. Tunneling QUIC is another [3].

Given that MASQUE and the upcoming BoF will be successful insofar as it addresses important use cases, I think it'd be useful to discuss these application use cases in more detail before Vancouver. To that end, let's use this time before the meeting to discuss them!

I'd like to ask interested parties to please surface use cases they know of (and care about).

Thanks!
Chris

[1] https://urldefense.com/v3/__https://tools.ietf.org/html/draft-schinazi-masque-02__;!!Emaut56SYw!ndHvFl_nkRo6Zz30-n2TeXuQE-xZiA76PJMJYS7TiI0jYzGhoH1idXvNrFMXV8K-fA$
[2] https://urldefense.com/v3/__https://tools.ietf.org/html/draft-schinazi-masque-obfuscation-00__;!!Emaut56SYw!ndHvFl_nkRo6Zz30-n2TeXuQE-xZiA76PJMJYS7TiI0jYzGhoH1idXvNrFNUKdnP3g$
[3] https://urldefense.com/v3/__https://tools.ietf.org/html/draft-kuehlewind-quic-substrate-02__;!!Emaut56SYw!ndHvFl_nkRo6Zz30-n2TeXuQE-xZiA76PJMJYS7TiI0jYzGhoH1idXvNrFPmGZef8g$ 

--
Masque mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/masque__;!!Emaut56SYw!ndHvFl_nkRo6Zz30-n2TeXuQE-xZiA76PJMJYS7TiI0jYzGhoH1idXvNrFPynOxALg$

---

From: Ben Schwartz <[email-masked]>
Date: Wed, 4 Mar 2020 15:57:59 -0500

On Tue, Mar 3, 2020 at 5:43 PM Border, John <[email-masked]> wrote:

>     There is a trend towards using satellite links in a multipath
> combination with a terrestrial technology (e.g. LTE).  The two paths
> provide redundancy for each other.  But, the big selling point is using QoS
> classification to send traffic which requires low latency (i.e. truly
> interactive traffic) via the terrestrial path and traffic which requires
> high throughput (so called bulk traffic) through the satellite path.  As I
> understand the Multipath QUIC proposal, the solution requires the end host
> to select the path to use (and is also oriented towards sending the same
> connection via multiple paths).  In the use cases we see, the end hosts are
> not cognizant of the multiple paths.  The edge router classifies traffic
> (perhaps with DSCP help from the end host) and selects the path.  The
> router also knows about path failures and degradations.   With QUIC,
> traffic classification is blocked.  Perhaps we can get end hosts to opt in
> and expose traffic classification via DSCPs.  But, that ha
>  s the potential of being carried farther than necessary.  A proxy could
> be trusted with just enough information to do the classification while
> removing the evidence before forwarding the traffic.
>
>     Does this fit?
>

I think this is a good use case.  A simple deployment setup might say
"everything sent to the proxy goes over satellite", and let the client
decide which path each connection should take by whether it uses the proxy
or not.

> The core MASQUE protocol [1] describes a simple negotiation mechanism for
> various applications. However, it omits use cases for these applications.
> MASQUE obfuscation in support of a "hidden VPN" service is one use case
> [2]. Tunneling QUIC is another [3].
>
> Given that MASQUE and the upcoming BoF will be successful insofar as it
> addresses important use cases, I think it'd be useful to discuss these
> application use cases in more detail before Vancouver. To that end, let's
> use this time before the meeting to discuss them!
>
> [1]
> https://urldefense.com/v3/__https://tools.ietf.org/html/draft-schinazi-masque-02__;!!Emaut56SYw!ndHvFl_nkRo6Zz30-n2TeXuQE-xZiA76PJMJYS7TiI0jYzGhoH1idXvNrFMXV8K-fA$
> [2]
> https://urldefense.com/v3/__https://tools.ietf.org/html/draft-schinazi-masque-obfuscation-00__;!!Emaut56SYw!ndHvFl_nkRo6Zz30-n2TeXuQE-xZiA76PJMJYS7TiI0jYzGhoH1idXvNrFNUKdnP3g$
> [3]
> https://urldefense.com/v3/__https://tools.ietf.org/html/draft-kuehlewind-quic-substrate-02__;!!Emaut56SYw!ndHvFl_nkRo6Zz30-n2TeXuQE-xZiA76PJMJYS7TiI0jYzGhoH1idXvNrFPmGZef8g$
>
> --
> Masque mailing list
> [email-masked]
>
> https://www.ietf.org/mailman/listinfo/masque
>