Subject: Re: IAB comments on Green Paper

From: Peter Deutsch <[email-masked]>
Date: Tue, 24 Feb 1998 18:53:02 -0500

g'day all,

Folks, forgive me for butting in again, but I really am
having trouble here. I know this problem is important (it
must be, otherwise, why would so many smart people spend
so much time fretting about it?)  but the thing is, I just
couldn't understand why this was on the IETF list.

Now, I've chewed on it a bit, and guess "if you can't beat
'em, join 'em."

So, against my own better judgement, I've decided to see
if I am at least understanding the problem correctly.
Heck, even that might be a useful posting at this point.

So, bear with me while I see if I've got it right.

1) There is a group of people who believe that the top
   level domain name system should be privately run by
   free market forces. Some of these people want to be a
   part of this "industry" and feel that some others are
   standing in the way of this industry realizing its
   potential.

2) There is a group of people who believe that the top
   level domain name system should be run as a
   not-for-profit effort. Some of these people accept that
   to date it's the government (and in particular, the U.S.
   government) that has paid for things, but such people
   seem to think that continued government funding is
   no longer a good idea.

   From this seems to come suggestions that TLDNS by
   handed over to a consortium of the current IETF
   technical community (eg. IANA, IANA-lite,
   IANA-meets-Mothra, etc). 

Sure, there are complicated trademark questions, questions
of who owns the current database given the existing
contracts with NSI,, technology questions about how many
TLDNS servers we can have, etc but the heart of the matter
seems to be that some people want a for-profit TLDNS, and
some want a not-for-profit TLDNS.

Have I got it?

I suppose I should pause at this point and see if I'm even
understanding the problem correctly, but that wouldn't be
the Internet way. So, assuming that this is at least a
question that being debated (which appears to be true),
let me weigh in here a bit.

Now, on the Internet we don't vote, we hum. Those
proposing to change the way things are done can ask
Congress to vote, but I assume on this list it's more
appropriate to hum.

So, let's all hum for one of the above models.

If you hum for the private enterprise model, there's the
question of how can you guarantee the principle of private
property if you don't have some government guaranteeing
things for you? That implies getting governments to issue
Green Papers, write rules, issue contracts, write laws,
etc, all with the goal of forcing people to do things.

I don't want to be snarky about this, but one observation
I have is that, simply put, this doesn't work in our
environment. It certainly hasn't so far, and I suspect it
wouldn't work again here.

 What you can do is convince
people to go somewhere else. You can't force them to do
what you want.

On the other hand, if you hum for the commons model, you
have the problem of paying for things, if you forgoe the
government grants needed (and the apparent willingness of
the U.S.  government to move to model #1). From the
evidence so far, you also have some people fairly mad at
you, and they just don't trust you to run things on their
behalf. They trust the market more than they trust you.

Have I got it right?

[* Sorry if I'm oversimplifying. I rest assured that if
   I've got it wrong, I'll hear soon enough.. *]

Now, I'm sure that this is important, but from what I've
seen so far, this does seem to be something of an
intractible political/business/moral problem, with shades
of trademark law and the potential for found money from
government-guaranteed monopolies. What it does not seem to
be is primarily a technical problem.

So, here's a first observation. The IETF really hasn't
shown itself to date to have any particular competence in
solving intractible political or business problems. We
don't architect things particularly well, we don't operate
things particularly well, we don't solve *any* political,
business or moral problems particularly well.  And from
what I've seen so far, there is definitely a
political/business/moral problem here to be addressed, not
a technical one.

What this group does well is iterate technical arguments
until there is rough consensus and working code (or the
problem goes away... ;-)

Secondly, the way the IETF normally attacks a problem is
to spawn off a working group of interested parties,
leaving the announcement lists for announcements,
unsubscribe messages and calls for someone to write
filtering software so we don't have to see unsubscribe
messages. The working group builds a spec for a proposed
solution, interested parties build to this spec, and if
they're right, Darwinian selection does its thing and
we're all better off.

If the solution is wrong, nobody uses it. The rest of us
are better off for not having wasted time on the deadend
solution.

So, my first reaction is to ask whether this discussion
wouldn't be better off if it migrated to either a new
working group, or maybe just somewhere like com-priv,
leaving this list for technical announcements and
discussions? Can't we use our own problem solving system
to solve this problem?

But then I hesitate, since if this isn't a technical
problem, there's no existance proof that our system will
produce a usable solution acceptable to others. Also, like
most people I do have some underlying assumptions about
how I want my Internet run and would hate to see the
problem go away and come back to bite me later.

So, I accept that we have to discuss this here a bit, and
I understand that we may all be wasting our time. The
solution may exist elsewhere. But hey, we do owe it to the
net to try.

My next reaction is to tell all those people who want to
change things is to tell ask them to show me how their
system works and is better for me than what I have now?
Also, since one of the proposals above is that the
technical community continues to run things, then of
course this is a good place to find members of that
community when they're not plotting to take over the world
for IP.

So, like everyone else, I've spent a couple of minutes
thinking about it before posting. And here's what I've
come up with.

First, the axioms:

1) The entire Internet is an exercise in the Prisoner's
   Dilemma. If I cooperate with those who cooperate with
   me, things work fine. If I don't, things fall apart.

2) This model has worked to get us where we are so far,
   and where we are seems to be good enough to attract a
   lot of attention.

3) We all want things to continue to work in the future.

4) Nobody owes anybody a living.

Now, one driving assumption of the current debate seems to
be that things will not continue working in the future, at
least to build and run TLDs, unless there are major
changes.

Now, there are certainly trademark issues to address, but
clearly in an international medium, such as this, no
single government can solve the problem.

Some people are counting the number of people on the net,
multiplying it by $50 and getting excited. They want a
slice of that money, and will do some work (such as
setting up and operating a server), if they must, to
get it.

We should not let them do it.

The task of running a TLDNS server should be seen as an
obligation, not a license to print money. If anyone wants
to be granted access to the team that runs things, they
should be politely told that this is a cooperative
function, they need to show the commitment to doing it
right, and they will be granted the privilege of peering
with others who are currently exercising this privilege if
they join the club and play by the rules.

[ Lance Spitzner wrote: ]

}     o First, divorce TLDs from the technical community.  Allow the
} international business community to develop and implement
} its own solution, "what the market will bear".  This is a capitalistic
} approach, but then so is international business.

Actually, I don't see that the international business
community developed and implemented the trademark system.
That's basically run by governments around the world. Why
should things be different on the Internet?

}     o Once the TLD issue is resolved, the international technical community
} can maintain control of the technical issues (IP
} address blocks, port #, root servers, etc.).

this I agree with. These are technical issues and it will
take  a technical body to manage them.

-- 
------------------------------------------------------------------------------
     Peter Deutsch,                                   (514) 875-8611  (phone)
  Bunyip Information Systems Inc.                     (514) 875-8134  (fax)
    <[email-masked]>                               http://www.bunyip.com

"... When beetles fight these battles in a bottle with their paddles and the
bottle's on a poodle and the poodle's eating noodles... they call this a
muddle puddle tweedle poodle beetle noodle bottle paddle battle..."

----------------------------------------------------------------------------

---

From: [email-masked]
Date: Thu, 26 Feb 1998 02:58:47 -0500

>some want a not-for-profit TLDNS.

Not exactly . . .

The heart of the matter is that we have reached
a point in the evolution of the Internet where we 
need to decide who gets to decide the questions
that can only have a single answer on the Internet.

Domain Names just happen to be one of those things.
To retain a single, unified root, there must be a 
single decision making body.  The MOUvement and the 
US Government both have very different solutions
to this question.

The MOU puts a very small group of stakeholders
in charge of these decisions.  It features closed
meetings and discussion, no due process, has little 
if any representation, and is set up as a Swiss 
based cartel to avoid anti-trust considerations.

In addition, the IAHC process broke long standing
Internet tradions when it discarded draft postel, and 
it ignored existing working code.  It also included 
organizations like the ITU that were previously known 
to be hostile to the private networks that make up the 
Internet.

The Green Paper is an opportunity for the Internet
community to come up with something better.  We already 
know that we don't like the MoU.  Now, everyone has an
opportunity to help put in place something better.

Everything else is smoke and mirrors.  

FWIW & IMHO.

Regards,

Jay Fenello
President, Iperdome, Inc.  
404-250-3242  http://www.iperdome.com