Subject: OPEN LETTER TO ROOT NAME SERVER OPERATORS

From: Bob Allisat <[email-masked]>
Date: Wed, 7 Oct 1998 12:26:18 -0400 (EDT)

Let me broaden the questions to each and
 every operator of these Root servers. These
 are as reasonable questions as Mr. Vixie's
 original queries to NSI. He expects answers.
 so to do I. Thanks in advance Paul. I trust
 this is of interest to all my collegues, most
 especially in the Engineering community. - BA

I wrote:
> 1. Would you please include .FCN and
> other legitimate Top Level Domains such
> as .SEX .ART, .WEB, etc, in the Root
> Name Server you operate?
>
> 2. Do you consider your root server to
> be your personal intellectual property?
> How do you justify a private person
> such as yourself controlling significant
> International resources?
>
> 3. What safeguards and protections of
> civil liberties and right to equal access
> to the resources you control do you offer
> citizens and businesses of the Internet
> if any?

 Bob Allisat

 Free Community Network . [email-masked] . http://fcn.net

---

From: Bob Allisat <[email-masked]>
Date: Wed, 7 Oct 1998 12:26:18 -0400 (EDT)

Bob Allisat

---

From: Paul A Vixie <[email-masked]>
Date: Fri, 09 Oct 1998 21:46:56 -0700

i am removing:

	Bob Allisat <[email-masked]>
	[email-masked]
	[email-masked]

from the recipient list, since Bob's on the IETF list and I'm not on
either of the others.

> > as .SEX .ART, .WEB, etc, in the Root

not until the IANA or its designated successor asks me to do so.

> > be your personal intellectual property?

some of the software running on it, i.e., BIND, is the property of
an organization (ISC) that i'm a manager of.  otherwise, no.

> > such as yourself controlling significant

i agreed to run a root name server when several people suggested that
as the then-main author of BIND i ought to have direct operational
experience with a root name server.  the IANA concurred.  the rest is
history.  (F is now the busiest root nameserver after A.)

> > citizens and businesses of the Internet

i will publish the "." zone as i receive it from IANA or from IANA's
designated editors.  i do not add other zones to 192.5.5.1's name server
unless directed to do so by the IANA, since this would have a similar
(but far less reliable) effect as adding a delegation to the "." zone
and i will only produce that effect if asked to do so by the IANA.

thank you for giving me a perfect lead-in to clarify my position.  i
generally do not answer crazies but i actually agree in this one
instance that the above points needed to be made.

it appears as though ICANN will be IANA's designated successor.

---

From: Paul A Vixie <[email-masked]>
Date: Fri, 09 Oct 1998 21:46:56 -0700

i am removing:

---

From: Chris Rapier <[email-masked]>
Date: Sat, 10 Oct 1998 02:15:44 -0400

> instance that the above points needed to be made.

Go Paul go!

And in order to avoid making this a me too post.
It seems clear that some of the more vocal people on this mailing list have
taken the anarchy analogy so often applied to the internet (when it was but a
young lad) a little too much to heart. Having spent most of my life as a
rabble rousing punk rocker boy saying that the top down organization structure
enforced by the current root name server model is necessary make me feel like
a bit of a sellout. However, I do not think that wildcatting name servers is
the proper solution to unique name crunch. 

Also, in order to counter gruboresque arguments of secret cabals and the
like... The reason why some people have the 'power' that they have is because
during the nascent days of the network they were there. They volunteered to do
a job and they did it well. They continue to have influence because they
continue to do a good job. 

Hopefully that was apropos of something considering how tired I am.

chris rapier
network engineer
ncne

---

From: Chris Rapier <[email-masked]>
Date: Sat, 10 Oct 1998 02:15:44 -0400

Go Paul go!

chris rapier
network engineer
ncne

---

From: Bob Allisat <[email-masked]>
Date: Sat, 10 Oct 1998 09:25:50 -0400 (EDT)

>> as .SEX .ART, .WEB, etc, in the Root

Paul Vixie replied:
+ not until the IANA or its designated successor asks me to do so.

 Excellent. I have also posed these questions
 to the other 12 parties involved. I expect
 their answers will be in line with yours,
 god willing.

>> be your personal intellectual property?

Paul Vixie:
+ some of the software running on it, i.e., BIND, is the property
+ of an organization (ISC) that i'm a manager of.  otherwise, no.

 Supplemental questions: was BIND developed with
 public funding like NSI's registration code?
 Would you place BIND in the public domain if
 requested or if Root Server or BIND maintainance
 contracts are assigned to companies other than
 your own? Is the code "open source"?

> i agreed to run a root name server when several people suggested 
> that as the then-main author of BIND i ought to have direct 
> operational experience with a root name server.  the IANA 
> concurred.  the rest is history.  (F is now the busiest root 
> nameserver after A.)

 Congratulations. Supplemental questions: 
 Do you believe the current centralized 
 Root Name server architecture is both
 safe and efficient? Observing the other-
 wise dispersed nature of the Internet
 it is the opinion of many that one of
 the main failure points is the current
 13 root name servers. Should there be 
 more servers added (32, 64)? Should
 some other less disaster prone structure
 be developed whereby multiple or even
 so called "desktop" DNS occurs? 

 BTW did F-server participate in the IANA
 ordered diversion of traffic away from
 NSI's A server? If so can you justify
 your companies behaviour in light of
 recent criticisms of this action and
 negative reaction from the US Executive
 office? It seems unwise to run in front
 of a train with the sole justification
 being that IANA ordered you to do so...
 In other words if IANA ordered your
 server to break an agreement or bend
 one severely would you agree?

Paul Vixie:
+ thank you for giving me a perfect lead-in to clarify my position.  
+ i generally do not answer crazies but i actually agree in this
+ one instance that the above points needed to be made.

 For once I am in agreement. I generally
 do not question these unfortunate folk
 except when they control significant
 public resources. Here's hoping you're
 on you meds when the order comes down
 the pipe for F to turn on .FCN to the
 world. That's <http://fcn.net> for now.

 Cheers and thanks in advance for your
 reply to my supplementals. I have included
 other interested lists which you may feel
 free to strip from your reply.

 Bob Allisat

---

From: Bob Allisat <[email-masked]>
Date: Sat, 10 Oct 1998 09:25:50 -0400 (EDT)

Paul Vixie replied:

Paul Vixie:

Paul Vixie:

 Bob Allisat

---

From: Bob Allisat <[email-masked]>
Date: Sat, 10 Oct 1998 09:45:10 -0400 (EDT)

Chris Rapier wrote:
* ... Having spent most of my life as a rabble rousing punk rocker 
* boy saying that the top down organization structure enforced by 
* the current root name server model is necessary make me feel like 
* a bit of a sellout. However, I do not think that wildcatting name 
* servers is the proper solution to unique name crunch.

 This is an engineering discussion if
 I ever heard one. My take on this issue
 is simple... you have created a system
 that can survive nuclear war unless
 13 servers are knocked, disabled or
 otherwise become popularly unuseable.
 A great example of this is Eugene
 Kashpureff's recent political protest.
 in redirecting traffic to Alternic.
 A truely destructive person could
 have knocked out total network
 operations and wrought real havoc.

 I include in the list of potential
 disabling mechanisms the possibility
 that the organizing mechanism fails
 to adapt or adopt to emmerging trends
 and evolving demands. By that I mean
 IANA or ICANN ordering the servers
 into configurations that in some way
 block network functionings as they
 occur. The recent diversion of traffic
 away from the NSI A server by order
 of Jon Postel/IANA, in direct and
 clear opposition to normal net
 operations is the classic example.

 Concentrating so much influence in
 one organizational structure and
 focusing the entire Internet upon
 a baker's dozen machines is in my
 opinion both insecure and unwise.
 A decentralized, dispersed model
 must be seriously considered. It
 is my opinion that should this
 option be dismissed the various
 stakeholders and participants
 making up the Internet community
 will be forced to "work-around"
 a Root server structure that will
 become a blockage.

 Comments? Ideas? Solutions?

 Bob Allisat

---

From: Bob Allisat <[email-masked]>
Date: Sat, 10 Oct 1998 09:45:10 -0400 (EDT)

Chris Rapier wrote:

 Bob Allisat

---

From: Carl Malamud <[email-masked]>
Date: Sat, 10 Oct 1998 10:37:00 -0400 (EDT)

>  your own? Is the code "open source"?

Enough.  Go to www.isc.org and go look at the license
agreement.  RTFM.  Anybody who works for a living
knows that BIND is open source.

Paul is too modest to say this, but BIND has been
developed with a few contributions (and I do mean
few) from industry after it had been left to die.
We very much appreciated those contributions, but
the vast majority of the interested parties, such
as ISPs and others running BIND, got a free ride.

The majority of the resources have been contributed
by Paul personally.  By resources I mean money that
he contributed to pay programmers, huge amounts of
his time, computers he paid for, and bandwidth he
paid for.

Instead of spending his time on a spanish inquisition,
Paul rolled up his sleeves and made a substanative
contribution.  If we had fewer freeloaders and
more people cranking out code, the Internet would
be a better place.  

Let's turn this around: what code has Mr. Bob
contributed?  I am looking on my source tree
and I can't find a single piece of code.  You
earn your civil liberties by contributing to the
community you live in.  Do something to help your
fellow citizens and then start complaining.
Until then, you're just a carpetbagger.

Carl Malamud
former Chair, ISC

---

From: Carl Malamud <[email-masked]>
Date: Sat, 10 Oct 1998 10:37:00 -0400 (EDT)

Carl Malamud
former Chair, ISC

---

From: Bob Allisat <[email-masked]>
Date: Sat, 10 Oct 1998 11:01:28 -0400 (EDT)

> Until then, you're just a carpetbagger.

 I apologize for any errors in my
 understanding. Please address my
 other questions and, if you would
 like to maintain the appropriate
 topic, answer my prevous article
 addressing what myself and other
 citizens of the Internet consider
 to be the over-centralized and
 IMHO highly vulnerable to abuse
 root name server structure,
 including potentially harmful
 interferances by persons like
 Vixie, Kashpureff, Postel or
 others. These are very serious,
 on-topic issues worthy of
 consideration. 

 Bob Allisat

---

From: Bob Allisat <[email-masked]>
Date: Sat, 10 Oct 1998 11:01:28 -0400 (EDT)

Bob Allisat

---

From: Paul A Vixie <[email-masked]>
Date: Sat, 10 Oct 1998 14:19:21 -0700

i've said my piece.  i did my time.  i've answered a crazy.  the rest of
the thread will have to be handled by someone with thicker skin and a
stronger stomach than mine.

---

From: Paul A Vixie <[email-masked]>
Date: Sat, 10 Oct 1998 14:19:21 -0700

---

From: Bob Allisat <[email-masked]>
Date: Sun, 11 Oct 1998 08:23:02 -0400 (EDT)

Paul Vixie replied:
> i've said my piece.  i did my time.  i've answered a crazy.  the
> rest of the thread will have to be handled by someone with thicker
> skin and a stronger stomach than mine.

 Answer the damned questions Vixie.
 Or you leave me to do the work for
 you. It's that simple.

 Bob Allisat

---

From: Bob Allisat <[email-masked]>
Date: Sun, 11 Oct 1998 08:23:02 -0400 (EDT)

Bob Allisat

---

From: Carl Malamud <[email-masked]>
Date: Sun, 11 Oct 1998 11:08:06 -0400 (EDT)

>  Or you leave me to do the work for

That would be great Bob.  Send us a URL when you have
an implementation of any of these pieces.  An
open source implementation of DNS with particular
emphasis on doing DNSSEC would be great.  You
could be the next Paul Vixie.

---

From: Carl Malamud <[email-masked]>
Date: Sun, 11 Oct 1998 11:08:06 -0400 (EDT)

---

From: Paul A Vixie <[email-masked]>
Date: Sun, 11 Oct 1998 10:12:55 -0700

>  Or you leave me to do the work for

If you can get someone I respect to ask me what you want to know, I'll tell.
But as there are no facts among those answers whose publicity *I* care one way
or the other about, I find myself completely unmotivated by your questions.

Should the IANA publish a position or policy that bears on your questions, I
will, as always, support that statement in its entirety, regardless of its
content.  I am not a maker of root naming policy, I am an implementor only.

---

From: Paul A Vixie <[email-masked]>
Date: Sun, 11 Oct 1998 10:12:55 -0700