Subject: hourglass model

From: [email-masked] (Manuel Guenter)
Date: Wed, 25 Nov 1998 12:21:17 +0100

Hi everybody

several times I read/heart about the
'hourglass model' of the internet 
(IP as the center of an hourglass,
connecting a variety of higher- resp.
lower layer protocols).

Does anyone have an idea
who came up with that model
(which seems to be a general model
for network protocol stacks), and
in what article?

thanks

manuel guenter

---

From: John Day <[email-masked]>
Date: Wed, 25 Nov 1998 07:31:08 -0400

>for network protocol stacks), and
The first use was in relation to the OSI model about 1980 by John
Aschenbrenner of IBM now retuired.

---

From: John Day <[email-masked]>
Date: Wed, 25 Nov 1998 07:31:08 -0400

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 25 Nov 1998 14:04:57 +0000

Dave Clark. The flavour of it is in
   The Design Philosophy of the DARPA Internet Protocols,
   D.D.Clark, Proc SIGCOMM 88, ACM CCR Vol 18, Number 4, August 1988,
   pages 106-114 (reprinted in ACM CCR Vol 25, Number 1, January 1995,
   pages 102-111).
but it the actual phrase was more recent, in a report to the
US Govt I think.

  Brian Carpenter

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 25 Nov 1998 14:04:57 +0000

Brian Carpenter

---

From: Steve Goldstein <[email-masked]>
Date: Wed, 25 Nov 1998 10:10:24 -0500

> but it the actual phrase was more recent, in a report to the

"Realizing the Information Future: The Internet and Beyond"
Computer Science and Telecommunications Board
National Research Council
National Academy Press
Washington, D.C. 1994
ISBN 0-309-05044-8
Page 53: Figure 2.1 "A four-layer model for the Open Data Network"

---

From: Steve Goldstein <[email-masked]>
Date: Wed, 25 Nov 1998 10:10:24 -0500

---

From: Stephen Wolff <[email-masked]>
Date: Wed, 25 Nov 1998 10:36:58 -0500

>but it the actual phrase was more recent, in a report to the
 
"Realizing the Information Future: The Internet and Beyond" National Academy Press, 1994. This contains the most elaborated version, I believe, with supporting text.  -s

---

From: Stephen Wolff <[email-masked]>
Date: Wed, 25 Nov 1998 10:36:58 -0500