Subject: RE: Microsoft A leaked memo outlines the company's strategy again st Linux and open source software (and posible open internet standards ?: -)

From: "Marsh, Miles (Gene)" <[email-masked]>
Date: Thu, 5 Nov 1998 21:20:23 -0500

The same will and ingenuity that brought Linux and other OSS efforts this
far will counter any move Microsoft would foolishly make in this direction.

Gene Marsh
Diebold Incorporated

-----Original Message-----
From: Sascha Ignjatovic [mailto:[email-masked]]
Sent: Wednesday, November 04, 1998 12:28 PM
To: [email-masked]
Subject: Microsoft A leaked memo outlines the company's strategy against
Linux and open source software (and posible open internet standards ?:-)

http://www.salonmagazine.com/21st/rose/1998/11/04straight.html

Microsoft's Halloween scare 

A leaked memo outlines the company's strategy against Linux and open
source software.  

The Halloween Document's game plan for Microsoft?
"De-commoditize protocols & applications: OSS projects have
been able to gain a foothold in many server applications because
of the wide utility of highly commoditized, simple protocols. 
By extending these protocols and developing new protocols, we
can deny OSS projects entry into the market." 
English translation? Microsoft can fight open
source software by adopting its open standards and
protocols and then modifying them -- perhaps offering new
features, but mostly making the Microsoft versions incompatible with
the "free" versions. 

Sound familiar? This is the same strategy Microsoft has used
repeatedly in its long history to defend its market, most recently
in its move onto the Internet. The company calls it "embrace
and extend"; its opponents view it as more like "copy and corrupt."

---

From: "Marsh, Miles (Gene)" <[email-masked]>
Date: Thu, 5 Nov 1998 21:20:23 -0500

Gene Marsh
Diebold Incorporated

---

From: Thomas Dineen <[email-masked]>
Date: Thu, 5 Nov 1998 18:37:14 -0800 (PST)

So what's the problem?
   
   This sounds like normal competitive business to me!
   
   Why are we talking, or whining, about this for sooooo many days?
   
Thomas Dineen

---

From: Vernon Schryver <[email-masked]>
Date: Fri, 6 Nov 1998 09:11:27 -0700 (MST)

> From: [email-masked]

> There's a difference between building a better train that runs on
> standard-width tracks, and building one that uses tracks 2 inches
> wider and then convincing people that the fact that their trains
> won't work on your tracks because their trains are too narrow
> is their fault, not yours.
>
> There's a reason why track widths were standardized.
>
> There's a reason why protocols are standardized.
>
> It's the same reason, basically.

The reason track widths and protocols are standardized is not Government
or even Standards Organization fiat, good judgment, or arm twisting.  The
reason for standards is crass, commercial, self-interest, albeit long term
instead of shortsighted self-interest.

There have been cases where different track widths were chosen, and to
the advantage of the idiosyncratic, and not only in special cases such as
the U.S. Rocky Mountains where there might have been technical reasons.
E.g. at the edge of Eastern Europe during a big war or two.

Look at the history of the PPP BACP/BAP protocol for somethimg sillier
than anything Microsoft might hope to achieve.  BACP has no rational
technical justification.  It has never been and will ever be significantly
used, because it solves the wrong problem in the wrong way.  Still, a lot
of outfits claim to support it, and it is now an official IETF Standard.
BACP started as an abuse of LCP Configure-Request option #0, and then was
flogged into a wide widespread marketing competitive advantage.  Just how
might the IESG or the IANA have prevented the abuse of that assigned
number?  Why didn't the IETF notice the square wheels and refuse to jump
on the BACP bandwagon, the IETF's rehabilitation of the abuse of option #0?

Vernon Schryver    [email-masked]

---

From: Vernon Schryver <[email-masked]>
Date: Fri, 6 Nov 1998 09:11:27 -0700 (MST)

---

From: Ari Ollikainen <[email-masked]>
Date: Fri, 6 Nov 1998 09:27:30 -0800

At 9:45 AM 11/6/98, [email-masked] wrote:
>On Thu, 05 Nov 1998 18:37:14 PST, you said:
>>    So what's the problem?
>>
        Where?

        England where some private railsystems still run on narrow gauge?
        Russia whose gauge is wider than Europe?
        Spain whose gauge is wider than Europe?
        USA where narrowgauge railways still operate, and where
        rapid transit systems such as BART in the SF Bay Area use a
        wider track width? Where street rail systems have differing gauges?
        Australia (at least two widths) where trucks are changed
        on the railcars traversing the continent?
        South Africa where narrow gauge predominates?

        etc

>There's a reason why protocols are standardized.
        Yes...SNA for example.

>It's the same reason, basically.

        The reason is seldom technical...

      OLTECO                    Ari Ollikainen
      P.O. BOX 3688             Networking Technology and Architecture
      Stanford, CA              [email-masked]
      94309-3688                415.517.3519

---

From: Ari Ollikainen <[email-masked]>
Date: Fri, 6 Nov 1998 09:53:05 -0800

>        South Africa where narrow gauge predominates?

        DOH! [slapping forehead] How could I forget my homeland?

        Finland shares the Russian wider gauge...

      OLTECO                    Ari Ollikainen

---

From: Ari Ollikainen <[email-masked]>
Date: Fri, 6 Nov 1998 09:53:05 -0800

OLTECO                    Ari Ollikainen