Subject: hourglass model

From: [email-masked] (Manuel Guenter)
Date: Wed, 25 Nov 1998 12:21:17 +0100

Hi everybody

several times I read/heart about the
'hourglass model' of the internet 
(IP as the center of an hourglass,
connecting a variety of higher- resp.
lower layer protocols).

Does anyone have an idea
who came up with that model
(which seems to be a general model
for network protocol stacks), and
in what article?

thanks

manuel guenter

---

From: "John Ioannidis" <[email-masked]>
Date: Wed, 25 Nov 1998 07:59:55 -0500 (EST)

> for network protocol stacks), and

The idea has been around for ages. I had called it a "protocol funnel"
in my thesis, referring more to its function than its shape. The
earliest reference I have found calls it the "Stuttgart wineglass," and
is here:

@article{Bartik84,
        Author="J. Bartik",
        Title="{OSI: From model to prototype as commerce tries to keep
	pace}",
        Journal="Data Communications",
        Month="March",
        Year=1984,
        Volume=13,
        Number=3,
        Pages="307--319",
}

/ji

---

From: "John Ioannidis" <[email-masked]>
Date: Wed, 25 Nov 1998 07:59:55 -0500 (EST)

@article{Bartik84,
        Author="J. Bartik",

/ji

---

From: "Robert (Bob) J. Aiken" <[email-masked]>
Date: Wed, 25 Nov 1998 09:12:51 -0800

At 07:31 AM 11/25/98 -0400, John Day wrote:
>At 7:21 -0400 11/25/98, Manuel Guenter wrote:
>>Hi everybody
>>
>The first use was in relation to the OSI model about 1980 by John
>Aschenbrenner of IBM now retuired.

Yep- the 7 layer OSI model, but the US NRC/CTSB (which had many luminaries
on it) report - "Realizing the Information Future" 1994, , went on to
describe the concept of IP as the common bearer service with many "app like
things above" and many "media" below it. About the same time the DARPA
HPCC/NREN plan, I think it was also '94, said the hourglass was in 3 major
layers with the middle being
the transport layer (including IP and TCP- ie. an independent transport
service) with all apps above it and all media below it.  These 2 ideas were
very close
in the concept of a 3 layer hourglass model with IP being the focus of the
middleware level.

bob

CISCO SYSTEMS  Bob Aiken, Internet Business Development Manager
  :     :      Advanced Internet Initiatives Division, Office of CTO 
.:|:...:|:..  6519 Debold Rd., Sabillasville, Md. 21780,USA  
1-301-271-2919(v),1-800-365-4578(pager), [email-masked]
"Nec Temere, nec Timide" ( "Neither rashly or timidly")

---

From: "Robert (Bob) J. Aiken" <[email-masked]>
Date: Wed, 25 Nov 1998 09:12:51 -0800

bob

---

From: Noel Chiappa <[email-masked]>
Date: Wed, 25 Nov 1998 11:59:34 -0500

From: [email-masked] (Manuel Guenter)

    several times I read/heart about the 'hourglass model' of the internet
    (IP as the center of an hourglass, connecting a variety of higher- resp.
    lower layer protocols). Does anyone have an idea who came up with that
    model ... and in what article?

I don't know who came up with the name, but the *idea* of a single
low-function (i.e. no reliability, just best-effort) protocol which was
ubiquitous, which ran on a variety of lower levels, and on which a variety of
transport layers ran, was definitely already implicitly (and somewhat
explicitly, if memory from that far back serves) understood in the Internet
Working Group when I joined it in the fall of 1977.

Without checking, I'm pretty sure the first packet voice over IP work was
going on then, and it was either then, or within a few months, that Dave Reed
proposed the User Datagram Protocol, to go along with the stream protocol,
TCP.

I don't think this idea was implicit in the very first work on TCP, because
there was no separate IP layer. As I recall, the motivator for splitting out
the IP layer (which happened at about TCP version 2 or TCP version 3, I don't
recall) was to support packet voice (for which the retransmissions, etc of TCP
would be a positive hindrance). Danny Cohen could tell you more about that, I
suspect, as could Vint.

Something else you need to check into was the PUP work at Xerox PARC. PUP also
had the hourglass model, and may have had it before TCP/IP did. I know that
there were close technical ties betweeen the TCP people and the PUP people in
the early days of TCP, and design influences between the two, but not having
been there then, I can't say for sure - I'm pretty sure it was before 1977. It
may well be that the idea was imported into TCP/IP from PUP.

One source you might want to look at, and I'm afraid I don't know where a copy
I used to have is, is a presentation that Dave Clark prepared about 1977. It
was, for many years, until his "Design Philosophy of the DARPA Internet
protocols" paper came out in 1988, the only place I'd ever seen the
"fate-sharing" ideas written down, and it *may* have had something about the
dependency structure of the protocols, as well.

	Noel

---

From: Noel Chiappa <[email-masked]>
Date: Wed, 25 Nov 1998 11:59:34 -0500

Noel

---

From: [email-masked]
Date: Wed, 25 Nov 1998 10:40:12 -0800

*> From [email-masked] Wed Nov 25 04:22:12 1998
  *> Date: Wed, 25 Nov 1998 12:21:17 +0100
  *> From: [email-masked] (Manuel Guenter)
  *> To: [email-masked]
  *> Subject: hourglass model
  *> X-Sun-Charset: US-ASCII
  *> Content-Length: 348
  *> X-Lines: 18
  *> 
  *> Hi everybody
  *> 
  *> several times I read/heart about the
  *> 'hourglass model' of the internet 
  *> (IP as the center of an hourglass,
  *> connecting a variety of higher- resp.
  *> lower layer protocols).
  *> 
  *> Does anyone have an idea
  *> who came up with that model
  *> (which seems to be a general model
  *> for network protocol stacks), and
  *> in what article?
  *> 
  *> thanks
  *> 
  *> manuel guenter
  *> 
  *> 
It is very difficult to pin point the origin of many technical
ideas, which were "in the air" at the time.  But I suspect the
initial idea arose when TCP was split from IP in Version 2.5.
I have heard the idea ascribed to Dave Clark, but a number of
other Internet pioneers were certainly involved, including
Vint Cerf and Jon Postel.  I am fuzzy about the date, and
at the moment I cannot locate the IEN for version 2.5, but
it would have been about 1979, I believe.

Bob Braden

---

From: [email-masked]
Date: Wed, 25 Nov 1998 10:40:12 -0800

Bob Braden

---

From: Ari Ollikainen <[email-masked]>
Date: Wed, 25 Nov 1998 11:55:13 -0800

>it would have been about 1979, I believe.

        TCP Version 3 spec was published in January 1979

        references in IEN 151:

2.   Cerf. V., "Specification of Internet Transmission Control Program -
     TCP (Version 2)", March 1977

3.   Cerf. V., J. Postel (eds), "Specification of Internetwork
     Transmission Control Program - TCP (Version 3)", January 1978.

4.   J. Postel (ed), 'Transmission Control Protocol - TCP (Version 4)",
     February 1979.

6.   "Specification of Internetwork Transmission Control Program - TCP
     (Version 3.1)", July 1978.

7.   DARPA, "Transmission Control Protocol, Version 4", August 1979
     [edited by J. Postel].

      OLTECO                    Ari Ollikainen
      P.O. BOX 3688             Networking Technology and Architecture
      Stanford, CA              [email-masked]
      94309-3688                415.517.3519

---

From: Ari Ollikainen <[email-masked]>
Date: Wed, 25 Nov 1998 11:55:13 -0800

references in IEN 151:

      OLTECO                    Ari Ollikainen

---

From: Ari Ollikainen <[email-masked]>
Date: Wed, 25 Nov 1998 12:12:47 -0800

Earlier I wrote
>7.   DARPA, "Transmission Control Protocol, Version 4", August 1979

        I left out the original IP spec:

 IEN 28     Postel          Feb-78   Draft Internetwork Protocol
                                     Specification

      OLTECO                    Ari Ollikainen

---

From: [email-masked] (Manuel Guenter)
Date: Mon, 30 Nov 1998 13:41:05 +0100

Thanks everybody for your answers!

It seems that the idea/term of the hourglass
model floats around for quite some time.
From the many pointers you sent me I
can assume, that the term has become
common knowledge in the ietf community.
Therefore, like for e.g. "object oriented
programming" it is not really necessary
to refer to a source article
(Unless somebody is offended by not
being cited as the source).

<[email-masked]> (amongst others) pointed me to 
the following book which seems 
to contain a good explanation of the
general 'hourglass' concept (and a nice
picture of it, too :)

"Realizing the Information Future: The Internet and Beyond"
Computer Science and Telecommunications Board
National Research Council
National Academy Press
Washington, D.C. 1994
ISBN 0-309-05044-8
Page 53: Figure 2.1 "A four-layer model for the Open Data Network"

so thanks again

Manuel Guenter

p.s. a '94 reference does also look better in between
my other '97/'98 article refs than does a '78    ;-)

---

From: [email-masked] (Manuel Guenter)
Date: Mon, 30 Nov 1998 13:41:05 +0100

so thanks again

Manuel Guenter