Subject: Source Format of RFCs

From: "Stephen L. Favor" <[email-masked]>
Date: Sun, 29 Nov 1998 13:14:53 -0600

Could someone tell me what source formats are in use for writting RFCs?
Is it a DTD?  Are any standard tools/editors used? Etc.  Any info would
be helpful.  I'm in the midst if setting up a standards creating body
with a small company and I'd like to draw from IETF as much as possible
as I know it works.

---

From: "Dunlap, Randy" <[email-masked]>
Date: Mon, 30 Nov 1998 10:06:06 -0800

I have only submitted older RFCs (i.e. converted early paper RFCs
to electronic form).  The RFC Editor's office asked for these in
simple ASCII text form so that they could convert them to nroff
if I remember correctly.  I think that they will take nroff input
also.  ;)

~Randy

> -----Original Message-----
> From: Matt Crawford [mailto:[email-masked]]
> Sent: Monday, November 30, 1998 7:51 AM
> To: Stephen L. Favor
> Cc: [email-masked]
> Subject: Re: Source Format of RFCs 
> 
> 
> > be helpful.
> I may be hopelessly old-fashioned, but I use nroff to write
> internet-drafts.  I reckon the RFC editor is proficient at converting
> that format to the required RFC format.
> 
> I have developed quite a few nroff macros and supporting perl and C
> programs for use with i-d's.  You can get them all, in fair-to-
> middling states of documentation, at
> ftp://berserk.fnal.gov/pub/id-tools/id-tools.tar.
> 
> No promises, but they work for me.
> 
> 			Matt Crawford
>

---

From: "Dunlap, Randy" <[email-masked]>
Date: Mon, 30 Nov 1998 10:06:06 -0800

~Randy

---

From: [email-masked]
Date: Mon, 30 Nov 1998 10:58:30 -0800

Please see RFC 2223, "Instructions to RFC Authors".  If you
still have questions, please send email to [email-masked].

Bob Braden
Joyce Reynolds

---

From: [email-masked]
Date: Mon, 30 Nov 1998 10:58:30 -0800

Bob Braden
Joyce Reynolds

---

From: "Bruce Balden" <[email-masked]>
Date: Mon, 30 Nov 1998 11:47:58 -0800

A number of RFC's and drafts, such the ones regarding BGP, suffer negatively from the
text-only format. It would be nicer to have a richer format, especially since such
documents rarely originate in the text-only format, but are rendered into that format
by MS-Word, nroff, LaTeX or whatever.

Would it be asking too much for all RFC's too made available in some sort of rich
format, and in particular their source format since that doesn't require additional
work?

-----Original Message-----
From: Dunlap, Randy <[email-masked]>
To: [email-masked]' <[email-masked]>
Date: November 30, 1998 10:53 AM
Subject: RE: Source Format of RFCs

|I have only submitted older RFCs (i.e. converted early paper RFCs
|to electronic form).  The RFC Editor's office asked for these in
|simple ASCII text form so that they could convert them to nroff
|if I remember correctly.  I think that they will take nroff input
|also.  ;)
|
|~Randy
|
|
|> -----Original Message-----
|> From: Matt Crawford [mailto:[email-masked]]
|> Sent: Monday, November 30, 1998 7:51 AM
|> To: Stephen L. Favor
|> Cc: [email-masked]
|> Subject: Re: Source Format of RFCs
|>
|>
|> > Could someone tell me what source formats are in use for
|> writting RFCs?
|> > Is it a DTD?  Are any standard tools/editors used? Etc.
|> Any info would
|> > be helpful.
|>
|> I may be hopelessly old-fashioned, but I use nroff to write
|> internet-drafts.  I reckon the RFC editor is proficient at converting
|> that format to the required RFC format.
|>
|> I have developed quite a few nroff macros and supporting perl and C
|> programs for use with i-d's.  You can get them all, in fair-to-
|> middling states of documentation, at
|> ftp://berserk.fnal.gov/pub/id-tools/id-tools.tar.
|>
|> No promises, but they work for me.
|>
|> Matt Crawford
|>
|
|-
|This message was passed through [email-masked], which
|is a sublist of [email-masked]. Not all messages are passed.
|Decisions on what to pass are made solely by Harald Alvestrand.
|

---

From: "Tim Kehres" <[email-masked]>
Date: Tue, 1 Dec 1998 10:50:01 +0800

Keith,

My comments below:

>> A number of RFC's and drafts, such the ones regarding BGP, suffer
negatively
>> from the text-only format. It would be nicer to have a richer format,
>> especially since such documents rarely originate in the text-only format,
>> but are rendered into that format by MS-Word, nroff, LaTeX or whatever.
>>
>> Would it be asking too much for all RFC's too made available in some sort
>> of rich format, and in particular their source format since that doesn't
>> require additional work?
>
>You may be asking for far more than you realize.
>
>I agree with you that the ASCII-only RFC format is a bit restrictive.
>However, ASCII is amazingly flexible.  It is one of the few formats
>that can be reasonably viewed (or searched) on any computer, and
>printed on any printer.  Neither of these is true of the document
>formats associated with common word processors.  Also, since it is
>so simple, ASCII is a good choice for formatting documents that may
>need to be readable for many decades.  For comparison, word processor
>documents from the early 1980s are difficult to read today, and
>it's not difficult to imagine that today's word processor documents
>will be difficult to read ten or twenty years from now.
>
>(The more complex the document format, the less interoperable it is.
>There have been problems with PostScript RFCs because some tools
>produce PostScript that cannot be printed on some printers.
>Similarly, version X of FooWord may produce documents that cannot
>be read by version Y of FooWord.)

Certainly no arguments on the pro's of ASCII, however as has been pointed
out, it does make for the conveyence of graphic information problematic.
Another good alternative however is PDF, which is becoming a pretty
established standard around the Internet for the publishing of manuals,
product specifications, etc.   The advantages are that unlike postscript,
the viewers are freely available, it is a truely portable format, and the
text can be searched.  As long as the produced PDF file has not been locked,
it is also possible to perform copy and paste operations from within the
viewer.  It also has an added advantage that an index can be incorporated
into the pdf file, as well as links similar to HTML pointing to locations
either in the document or on the web making the navigation of the pdf file
very convenient.

>There are also problems with making RFCs available in multiple formats.
>One is that the RFC Editor and Internet-Drafts folks would then need
>to deal with a wider variety of tools.  Another is that multiple formats
>can make it more difficult to keep the various formats in sync.
>For instance the RFC Editor generally needs to be able to make minor
>changes to a document before publication, yet may not have the
>tools neded to modify the "source" document.  If the author is asked
>to make the changes, there is then a need to make sure that the
>author does not make other modifications to the work after it has
>been reviewed and approved by a working group and IESG.  Again,
>this generally requires special tools.

Agreed, however if the set of tools is well bounded, this should be a
solvable problem.

>Until a new format can supplant ascii text for all intents and purposes,
>there will continue to be a need to produce ascii text versions of RFCs.
>Many word processors do a very poor job of producing "RFC ASCII"
>(with margins that allow printing on both A4 and US-Letter paper,
>no overprinting, and so forth)  Documents written for a wysiwyg
>word processor are often difficult to read as ASCII, e.g. because
>the word processor will try to put too many words on a line, or too
>many characters in a column of a table. (I've seen various versions
>of this while reviewing RFCs for IESG.)

Adobe's PDF Viewer (Acrobat) allow for the automatic scaling of documents,
which lets you print letter on A4 or A4 on letter easily, with no noticible
changes to the document other than a minor scaling.

>Then there is a need to make sure that new RFC formats are adequately
>supported by all of the RFC and internet-drafts mirrors.

I'm not sure what you mean here.   Why can't rfcxxxx.txt also be published
as rfcxxxx.pdf as well, similar to how several of the postscript RFC's have
been?

>For some time I have been interested in exploring the use of HTML
>for RFCs and Internet-Drafts.  This would provide several advantages,
>including multifont and multi-faced text in a variety of sizes,
>hyperlinks, images, and ease of generation with many word processors.
>HTML is openly published and widely-used, and (provided a few restrictions
>are observed) one of the few formats which can be read on every platform
>(and is easily converted to plain text).

This is certainly another alternative, however HTML lacks the page layout
capabilities of PDF, which is why you see more product brochures and user
manuals on the web in this format.   Either way (PDF or HTML), I think
providing a framework in which we can come up with more readable RFC's would
be useful.

-- Tim

---

From: "Tim Kehres" <[email-masked]>
Date: Tue, 1 Dec 1998 10:50:01 +0800

Keith,

negatively

-- Tim

---

From: [email-masked]
Date: Mon, 30 Nov 1998 19:16:17 -0800

*> From [email-masked] Mon Nov 30 16:49:10 1998
  *> From: "Bruce Balden" <[email-masked]>
  *> To: "Dunlap, Randy" <[email-masked]>, <[email-masked]>
  *> Subject: Re: Source Format of RFCs 
  *> Date: Mon, 30 Nov 1998 11:47:58 -0800
  *> MIME-Version: 1.0
  *> Content-Type  *> :   *> text/plain  *> ;   *> charset="iso-8859-1"  *> 
  *> Content-Transfer-Encoding: 7bit
  *> X-Priority: 3
  *> X-MSMail-Priority: Normal
  *> X-Mailer: Microsoft Outlook Express 4.72.3110.5
  *> X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
  *> Content-Length: 2004
  *> X-Lines: 59
  *> 
  *> A number of RFC's and drafts, such the ones regarding BGP, suffer negatively from the
  *> text-only format. It would be nicer to have a richer format, especially since such
  *> documents rarely originate in the text-only format, but are rendered into that format
  *> by MS-Word, nroff, LaTeX or whatever.
  *> 
  *> Would it be asking too much for all RFC's too made available in some sort of rich
  *> format, and in particular their source format since that doesn't require additional
  *> work?
  *> 

This has been debated many times over the years, and the bottom line
has always been that (1) grep works only for ASCII text, and (2) people
want to be able to easily cut and paste bits of RFCs for many
purposes.

Bob Braden

---

From: [email-masked]
Date: Mon, 30 Nov 1998 19:16:17 -0800

Bob Braden