Subject: Desktop DNS Propogation/Supportability/Feasibility

From: "Mitch Denny" <[email-masked]>
Date: Thu, 21 Jan 1999 10:33:27 +1000

Bob,

Okay, we are making progress here.

To clarify from a technical stand
point.

a: multiple hierarchies operated by
   seperate organisations and
   commercial bodies.

b: data sets of these hierarchies
   are propogated at a high level
   to reduce the load of many
   to many database replication.

c: each body connected to the 
   global network poll their
   service provider, or another
   body to which they are subscribed.

d: this data set is then used on
   their corporate lan where
   various configurations may exist.

e: the configrations may consist
   of individual clients having
   light weight DNS solutions
   executing locally, or network
   clients using DNS as a shared 
   network resource.

So we have achieved a few things here,
first, we have introduced a level of
redundancy for such an important
resource.

Second, certain bodies will no longer
have a monopoly over the global
directory service.  It would have
to be discussed how the top
level registries would interact
and replicate their databases.
This is where the problem may
be, disparate costs etc.

This model isn't quite what you were
proposing earlier with each node
having its own DNS, this way is more
structured and lays down your concerns
about the centralisation of the
directory service.

The issue is, how many hops away
do you want to be from a complete
directory service reference.

I don't think we can rely on 
broadband solutions just yet, its
coming but its not widely implemented
enough, atleast not down to the 
desktop.

Remember, no DNS server currently
holds a complete record of all the
DNS information out there, it is a 
distributed database.

If you were to keep a complete
record of anything, all you could
feasibly keep would be a complete
copy of the root server zone files.

Keep on talking Bob, we are getting
somewhere.

Cheers,

Mitch Denny
[email-masked]

---

From: "James D. Wilson" <[email-masked]>
Date: Wed, 20 Jan 1999 17:43:35 -1000

We have weaned Bob off the VIC-20 40-character display, but I guess it
was infectious :-)

- -
James D. Wilson

"non sunt multiplicanda entia praeter necessitatem"
    William of Ockham (1285-1347/49)

- -----Original Message-----
From: Mitch Denny [mailto:[email-masked]]
Sent: Wednesday, January 20, 1999 2:33 PM
To: Bob Allisat
Cc: IETF-0000
Subject: Desktop DNS Propogation/Supportability/Feasibility

Bob,

---

From: "James D. Wilson" <[email-masked]>
Date: Wed, 20 Jan 1999 17:43:35 -1000

- -
James D. Wilson

Bob,