Subject: RE: No More Central Authority: Not NSI/ICAN! Not ORSC!

From: Adam Hewitt <[email-masked]>
Date: Tue, 19 Jan 1999 07:53:11 -0600

Bob,

Two questions:

1)	Are you talking about mom & pop maintaining there own dns or are you
saying maintain it at an ISP level? 

2)	And what is the problem with the current architecture? (Other than
the fact it has central authority?)

I could (in theory) see some advantages to an ISP maintaining, but not each
individual desktop. I am the first to jump up and scream at any central
authority, but I can't see any other way for this to work efficiently. 

As Rich points out:
"I feel that this system has had enough scrutiny as well as international
support to make it a stable and effective way to distribute this data (not
to mention cost effective for the consumer)".

______________________________________________
Adam Hewitt
[email-masked] <mailto:[email-masked]> 
USAA  IT Systems Analyst
210-456-5981

"It likes us well;  
And at our more consider'd time well read, 
Answer, and think upon this business. 
Meantime we thank you for your well-took labour..." 

KING CLAUDIUS
-Hamlet Act 2, Scene 2 

	-----Original Message-----
	From:	Richard Towle [SMTP:[email-masked]]
	Sent:	Tuesday, January 19, 1999 9:58 AM
	To:	thomas lakofski
	Cc:	Bob Allisat; [email-masked]
	Subject:	Re: No More Central Authority: Not NSI/ICAN! Not
ORSC!

	Hi Guys,

	I would like to add this thought. Who would pay and keep track of
addressing
	and name space without a central organization?

	When you establish a new site it take 24-72 hours for this
information to
	propagate across the Internet. I just plan for that time in any
project or
	site that I build.
	Once you have the root domain name registered, the rest is a
distributed
	system...i.e. you can make changes to your own site (except the main
domain
	name) without anyone else saying no.
	I feel that this system has had enough scrutiny as well as
international
	support to make it a stable and effective way to distribute this
data (not
	to mention cost effective for the consumer)

	Thanx
	Rich

	thomas lakofski wrote:

	> On Tue, 19 Jan 1999, Bob Allisat wrote:
	>
	> >  I see the advantages. But the current disadvatnages
	> >  out-weigh the positives in my opinion. A central DNS
	> >  authority is a critical failure point in an otherwise
	> >  pretty robust network. Decentralize that and it's one
	> >  step closer to what I believe will be a better and more
	> >  efficiently functioning net.
	>
	> Bob, much as I agree with you about the advantages of
decentralization,
	> please either:
	>
	> 1.  Show me the code and architecture that implements your
decentralized
	> DNS, or
	>
	> 2.  Go away.
	>
	> Thanks,
	>
	> TL
	>
	> ......
	> please forgive my abrupt ending hre - but my conection is
	> xtrememleyyhiclmelyey      BAD hiccuppy etc must sign off -
	> EF D8 33 68 B3 E3 E9 D2  C1 3E 51 22 8A AA 7B 98

---

From: Bob Allisat <[email-masked]>
Date: Tue, 19 Jan 1999 16:28:53 -0500 (EST)

Adam Hewitt wrote:
= Two questions:
=
= 1)      Are you talking about mom & pop maintaining there own dns or
= are you saying maintain it at an ISP level?
=
= 2)      And what is the problem with the current architecture? (Other
= than the fact it has central authority?)
=
= I could (in theory) see some advantages to an ISP maintaining, but not
= each individual desktop. I am the first to jump up and scream at any
= central authority, but I can't see any other way for this to work
= efficiently.
=
= As Rich points out:
= "I feel that this system has had enough scrutiny as well as
= international support to make it a stable and effective way to
= distribute this data (not to mention cost effective for the consumer)".

 I will answer your questions first and after discuss the
 various ramifications and evolutions of my ideas...

 I mean Desktop DNS as in every Computer on the Net 
 maintaining it's own virtual Domain Name Server. This
 places control in every computer *not* in external
 machines and structures.

 The critical problem with the current system is IMHO
 (In My Humble Opinion) the very fact of a central
 authority. This situation is quite counter to the
 highly dispersed nature of the medium and introduces
 a functional and regulatory bottle neck that basically
 controls everyone. This is unacceptable. It is also
 prone to potentially enormous failure risks and abuse.

 We are mature enough, as citizens, to control such a
 new vision of Domain Name Services. Updating our own
 Desktop DNS would be as simple as logging into our
 selected Network Information Centre and exchanging
 basic data. IWith connectivity, processor power, RAM
 and the entire infrastructure in possetion of average
 citizens increasing in power daily the capabilities
 exist. Now. It is time to realize the potential of
 truely controlling our own destinies and release us 
 from what I see as a peculiar form of high-tech
 fuedalism.

 Respectfully,

 Bob Allisat

 Free Community Network _ [email-masked]
 http://fcn.net _ http://fcn.net/allisat 
 [email-masked]

---

From: Bob Allisat <[email-masked]>
Date: Tue, 19 Jan 1999 16:28:53 -0500 (EST)

Adam Hewitt wrote:
= Two questions:
=

 Respectfully,

 Bob Allisat

---

From: "Mitch Denny" <[email-masked]>
Date: Wed, 20 Jan 1999 12:04:06 +1000

Bob,

I hate to resort to slander, but
you my friend are a dead-set twit!

Many of our collegues here will 
understand what I am talking about
when you are talking to someone
and all you want to do is grab them
by the neck and beat them around
the head a few times with a baseball
bat!

Argggh! Now that I have got that
off my chest, back to rational
thought.

Once again, we can all know your
point of view on a central
authorities.  However, you have yet
to provide us with a workable model
as an alternative.

Proposing distributing hosts lists
via CD or operating system is too
static, and honestly it points out
that you have little grasp over
the problems that have to dealt
with on a large network.

One issue you raised was the critical
point on the network that is introduced
by having root servers.

This is easily resolved by adding
redundancy, at seperate physical
locations on the larger internet
backbones.  It is sure as hell easier
than managing literally hundreds of
thousands of isolated DNS hosts.

Again, I am in the mood where I want
to make the imprint of a baseball bat
in your skull.

If you were serious about this stuff
and weren't just blowing hot air, you
would put forward a serious proposal
instead of trying to be a cyber-prophet
and really getting no where.

Bob, you are a fool.

P.S: Serious IETF'ers excuse me posting
this up, but I really want to know
if Bob has a serious solution in mind.

Cheers,

Mitch Denny
[email-masked]

---

From: "Mitch Denny" <[email-masked]>
Date: Wed, 20 Jan 1999 12:04:06 +1000

Bob,

Bob, you are a fool.

Cheers,

Mitch Denny
[email-masked]

---

From: Bob Allisat <[email-masked]>
Date: Wed, 20 Jan 1999 13:11:09 -0500 (EST)

Mitch Denny wrote:
? If you were serious about this stuff
? and weren't just blowing hot air, you
? would put forward a serious proposal
? instead of trying to be a cyber-prophet
? and really getting no where.
?
? Bob, you are a fool.
?
? P.S: Serious IETF'ers excuse me posting
? this up, but I really want to know
? if Bob has a serious solution in mind.

 Fred - I will not reply to this blatantly personal attack.
 I have considered your previous requests for me to stay on
 topic for this IETF mailing list. I regard the discussion
 of DNS to be supremely on-topic. Please tell me if I am
 wrong. I have attempted to integrate your comments into
 my behaviour.

 Such comments as wanting to apply a baseball bat to my
 head are disturbing. If the IETF has civil discourse
 guide-lines such behaviour should see a response in kind.
 While I may not agree with the majority of list members
 I am attempting to be civil and reasonable. And yet I am
 met with uncivil and unreasonable attacks.

 Please advise me as to what recourse I have in this instance.
 I try and work with you folks, to discuss issues on topic
 that I regard as critical. Only to be threatened with personal
 assault. Very sad. 

 Bob Allisat

---

From: Bob Allisat <[email-masked]>
Date: Wed, 20 Jan 1999 13:11:09 -0500 (EST)

Mitch Denny wrote:

 Bob Allisat

---

From: Fred Baker <[email-masked]>
Date: Wed, 20 Jan 1999 19:36:48 +0000

> Fred - I will not reply to this blatantly personal attack.

thanks, though I note that later in your email you discuss the attack.

> wrong. I have attempted to integrate your comments into

Technical discussions of how the DNS might be used or modified to solve an
engineering problem are on-topic. Political questions concerning how the
IETF might relate to the PSO or to some other organization that manages the
name space would be on topic. Political discussions of those organizations
themselves are off-topic, as they do not relate to the engineering of the
internet or to the IETF itself. There exist numerous lists for discussion
of the organizational issues, including IFWP, DNS-POLICY, etc.

> head are disturbing.

yes, and so are assertions that the IETF is a den of thieves. They are at
best off-topic.

> If the IETF has civil discourse

that's because people are seriously tired of you being told that the topics
you want to discuss are off-topic, and you coming back to discuss them.
Your topics are fine - in a forum devoted to them. Why is it so hard to go
to those fora for the discussion?

> Please advise me as to what recourse I have in this instance.

POISSON has discussed civil discourse rules, and not concluded with
something that I can implement. POISSON at the recent IETF also discussed
what to do about people who insist on posting about topics that are
off-topic. You can check the minutes for the outcome of that. In summary,
the outcome was that people agreed on what the topic of this list was, but
did not agree on an approach to forcibly removing off-topic traffic. As
soon as POISSON defines something I can implement, I will do it.

> that I regard as critical. Only to be threatened with personal

yes, and it's very sad from my end to hear myself and my colleagues
described as thieves and worse. You really cannot take a self-righteous
position here.

I would suggest that this mail thread has reached a new low, and should end.

---

From: Fred Baker <[email-masked]>
Date: Wed, 20 Jan 1999 19:36:48 +0000

---

From: "Mitch Denny" <[email-masked]>
Date: Thu, 21 Jan 1999 09:00:03 +1000

Bob,

I retract my earlier comments, my
comments were token and not physical.

Again, I challenge you to outline
a practicle workable model for what
you propose.

The system should ofcourse allow
for:

a: automatic propogation of directory
   service data.

b: enhanced supportability, ie, less
   wo/man hours to manage.

Again Bob, I challenge you to provide
us with a workable example.  Surely
you must have something in mind.

Cheers,

Mitch Denny
[email-masked]

> From: Bob Allisat [mailto:[email-masked]]
> Sent: Thursday, January 21, 1999 04:11
> To: Mitch Denny
> Cc: [email-masked]; [email-masked]
> Subject: Re: Bob Allisat: The Fool!
> 
> 
> 
> Mitch Denny wrote:

---

From: "Mitch Denny" <[email-masked]>
Date: Thu, 21 Jan 1999 09:00:03 +1000

Bob,

Cheers,

Mitch Denny
[email-masked]

---

From: Bob Allisat <[email-masked]>
Date: Wed, 20 Jan 1999 17:45:50 -0500 (EST)

Mitch Denny asked me to describe the following in my desktop
> b: enhanced supportability, ie, less

 a) Since realizing my ideas will not occur over night
 and since I believe we are all moving towards 24/7/365
 high speed connectivity propagation of data will be
 continuos. Much like one used to be able to update the
 system clock of one's computer by regularly logging
 into the Research Council signal. Updating would be
 much more efficient than the current 24-36 hours and
 could be virtually simultaneous. Note: I do not see
 this as a one "database fits all" solution which implies
 some fragmentation of the sacred root. Generally,
 however, the data will be globally similar... if only
 because too much varietation would render any particular
 alternative unuseable. Regulation of universality would
 not be by some central body but by simple usability.

 b) I see the software functioning similarly to system
 clocks. In the background, with a control panel of
 choices and set-up options. But otherwise a set if and
 forget it operation. We would have a choice of Network
 Information Centres to choose from. Some commercial,
 some not. Come censored for content (a la RBL) some not.

 Ease of use is not an issue I see as significant. Far
 more significant are taboo political issues which I will
 not discuss. In my opinion Desktop DNS is doable and
 offers significant network advantages in terms of robust-
 ness and decntralization of functinalities.

 Bob Allisat

---

From: Bob Allisat <[email-masked]>
Date: Wed, 20 Jan 1999 17:45:50 -0500 (EST)

Bob Allisat

---

From: Markus Peuhkuri <[email-masked]>
Date: Thu, 21 Jan 1999 09:32:21 +0200 (EET)

>>>>> "Bob" == Bob Allisat <[email-masked]> writes:

Bob> since I believe we are all moving towards 24/7/365 high speed
Bob> connectivity propagation of data will be continuos. Much like

	I must disagree with that.  I think more and more of Internet
access will be made with wireless PDA/PC/YNI.  In wireless world you
must converse energy and bandwidth; continuos data flow and large
memory (mostly never-used) capacity conflicts with that.

	Unless, of course you set up your own naming service on some
location with fixed connection -- assuming you have one.  In Finland
we have nowadays more mobile subscribers (>56/100inh) than POTS
subscribers.  Specially young people do not take POTS connection as
they move frequently (and are seldom home :-).  But anyway, I think
very few people do want to administrate their name space themselves.

-- 
Markus Peuhkuri        ! internet: [email-masked]
HUT/Telecomm. Tech.    ! http://www.iki.fi/puhuri/
P.O.Box 3000, 02015 HUT! tel: +358-9-451 2467 fax: +358-9-460224
Finland, EUROPE        ! gsm: +358-40-50 19683

---

From: Markus Peuhkuri <[email-masked]>
Date: Thu, 21 Jan 1999 09:32:21 +0200 (EET)

---

From: Bob Allisat <[email-masked]>
Date: Thu, 21 Jan 1999 05:28:39 -0500 (EST)

I wrote:
>... I believe we are all moving towards 24/7/365 high speed
> connectivity propagation of data will be continuos...

Markus Peuhkuri replied:
+        I must disagree with that.  I think more and more of Internet
+ access will be made with wireless PDA/PC/YNI.  In wireless world you
+ must converse energy and bandwidth; continuos data flow and large
+ memory (mostly never-used) capacity conflicts with that.
+
+        Unless, of course you set up your own naming service on some
+ location with fixed connection -- assuming you have one.  In Finland
+ we have nowadays more mobile subscribers (>56/100inh) than POTS
+ subscribers.  Specially young people do not take POTS connection as
+ they move frequently (and are seldom home :-).  But anyway, I think
+ very few people do want to administrate their name space themselves.

 If properly implimented maintenance of the Name Space
 will be as simple as setting the time or any other software
 preferances on your current computer. And as for the barious
 valid comments about the present limitations of wireless
 networking I suspect these are as temporary as those that
 once held the personal or home office computer to a snails
 pace for so long. In time 24/7/365 high speed access, enormous
 storage, RAM and procesing power will be portable eliminating
 the restrictions preventing palmtops or pocket processors
 from becoming full blown, independant Net servers in all
 respects. 

 Respectfully,

 Bob Allisat

---

From: Bob Allisat <[email-masked]>
Date: Thu, 21 Jan 1999 05:28:39 -0500 (EST)

Markus Peuhkuri replied:

 Respectfully,

 Bob Allisat

---

From: Richard Towle <[email-masked]>
Date: Thu, 21 Jan 1999 12:00:15 -0200

Bob Allisat wrote:
 >If properly implemented maintenance of the Name Space
 >preferances on your current

Net Time is hierarchical in nature, without one definitive source for
time, all the systems have timing problems and the network drops packets,
calls, etc.....
This system remains hierarchical and so must naming systems, in order to
keep clean and accurate data.

How it is delivered is the real TECHNICAL issue, not whether or not it is
hierarchical.

Rich

---

From: Richard Towle <[email-masked]>
Date: Thu, 21 Jan 1999 12:00:15 -0200

Rich

---

From: thomas lakofski <[email-masked]>
Date: Thu, 21 Jan 1999 13:09:04 +0000 (UTC)

> time, all the systems have timing problems and the network drops packets,

Sorry to go even more rampantly off-topic, but here's another
misconception.  Time (as we've defined it) has a single, definitive source
provided by (I think) the mean of 4 atomic clocks.  There may be disparate
sources of time on the Internet but they all derive their information from
this single source ultimately.  Fragmentation of the time `root' is
something last experienced before railways, IIRC.

......

---

From: thomas lakofski <[email-masked]>
Date: Thu, 21 Jan 1999 13:09:04 +0000 (UTC)

......