Subject: RE: No More Central Authority: Not NSI/ICAN! Not ORSC!

From: Adam Hewitt <[email-masked]>
Date: Tue, 19 Jan 1999 07:53:11 -0600

Bob,

Two questions:

1)	Are you talking about mom & pop maintaining there own dns or are you
saying maintain it at an ISP level? 

2)	And what is the problem with the current architecture? (Other than
the fact it has central authority?)

I could (in theory) see some advantages to an ISP maintaining, but not each
individual desktop. I am the first to jump up and scream at any central
authority, but I can't see any other way for this to work efficiently. 

As Rich points out:
"I feel that this system has had enough scrutiny as well as international
support to make it a stable and effective way to distribute this data (not
to mention cost effective for the consumer)".

______________________________________________
Adam Hewitt
[email-masked] <mailto:[email-masked]> 
USAA  IT Systems Analyst
210-456-5981

"It likes us well;  
And at our more consider'd time well read, 
Answer, and think upon this business. 
Meantime we thank you for your well-took labour..." 

KING CLAUDIUS
-Hamlet Act 2, Scene 2 

	-----Original Message-----
	From:	Richard Towle [SMTP:[email-masked]]
	Sent:	Tuesday, January 19, 1999 9:58 AM
	To:	thomas lakofski
	Cc:	Bob Allisat; [email-masked]
	Subject:	Re: No More Central Authority: Not NSI/ICAN! Not
ORSC!

	Hi Guys,

	I would like to add this thought. Who would pay and keep track of
addressing
	and name space without a central organization?

	When you establish a new site it take 24-72 hours for this
information to
	propagate across the Internet. I just plan for that time in any
project or
	site that I build.
	Once you have the root domain name registered, the rest is a
distributed
	system...i.e. you can make changes to your own site (except the main
domain
	name) without anyone else saying no.
	I feel that this system has had enough scrutiny as well as
international
	support to make it a stable and effective way to distribute this
data (not
	to mention cost effective for the consumer)

	Thanx
	Rich

	thomas lakofski wrote:

	> On Tue, 19 Jan 1999, Bob Allisat wrote:
	>
	> >  I see the advantages. But the current disadvatnages
	> >  out-weigh the positives in my opinion. A central DNS
	> >  authority is a critical failure point in an otherwise
	> >  pretty robust network. Decentralize that and it's one
	> >  step closer to what I believe will be a better and more
	> >  efficiently functioning net.
	>
	> Bob, much as I agree with you about the advantages of
decentralization,
	> please either:
	>
	> 1.  Show me the code and architecture that implements your
decentralized
	> DNS, or
	>
	> 2.  Go away.
	>
	> Thanks,
	>
	> TL
	>
	> ......
	> please forgive my abrupt ending hre - but my conection is
	> xtrememleyyhiclmelyey      BAD hiccuppy etc must sign off -
	> EF D8 33 68 B3 E3 E9 D2  C1 3E 51 22 8A AA 7B 98

---

From: "Finney, Mike" <[email-masked]>
Date: Tue, 19 Jan 1999 14:05:04 -0800

I sure am glad it is just your opinion, Bob. Sure DNS has a few problems,
but to go back to downloading hosts files seems like a cure worse than the
disease. I don't WANT my pc to run DNS services. I don't WANT to download a
new hosts file every time I connect. You do a good job advocating a new
system, but as yet I have seen NOTHING useful from you in a REAL WORLD
implementation of such a system. And I thought M$ had vaporware....

Mike Finney
[email-masked] <mailto:[email-masked]> 

	-----Original Message-----
	From:	Bob Allisat [SMTP:[email-masked]]
	Sent:	Tuesday, January 19, 1999 3:29 PM
	To:	Adam Hewitt
	Cc:	[email-masked]
	Subject:	RE: No More Central Authority: Not NSI/ICAN! Not
ORSC!

	Adam Hewitt wrote:
	= Two questions:
	=
	= 1)      Are you talking about mom & pop maintaining there own dns
or
	= are you saying maintain it at an ISP level?
	=
	= 2)      And what is the problem with the current architecture?
(Other
	= than the fact it has central authority?)
	=
	= I could (in theory) see some advantages to an ISP maintaining, but
not
	= each individual desktop. I am the first to jump up and scream at
any
	= central authority, but I can't see any other way for this to work
	= efficiently.
	=
	= As Rich points out:
	= "I feel that this system has had enough scrutiny as well as
	= international support to make it a stable and effective way to
	= distribute this data (not to mention cost effective for the
consumer)".

	 I will answer your questions first and after discuss the
	 various ramifications and evolutions of my ideas...

	 I mean Desktop DNS as in every Computer on the Net 
	 maintaining it's own virtual Domain Name Server. This
	 places control in every computer *not* in external
	 machines and structures.

	 The critical problem with the current system is IMHO
	 (In My Humble Opinion) the very fact of a central
	 authority. This situation is quite counter to the
	 highly dispersed nature of the medium and introduces
	 a functional and regulatory bottle neck that basically
	 controls everyone. This is unacceptable. It is also
	 prone to potentially enormous failure risks and abuse.

	 We are mature enough, as citizens, to control such a
	 new vision of Domain Name Services. Updating our own
	 Desktop DNS would be as simple as logging into our
	 selected Network Information Centre and exchanging
	 basic data. IWith connectivity, processor power, RAM
	 and the entire infrastructure in possetion of average
	 citizens increasing in power daily the capabilities
	 exist. Now. It is time to realize the potential of
	 truely controlling our own destinies and release us 
	 from what I see as a peculiar form of high-tech
	 fuedalism.

	 Respectfully,

	 Bob Allisat

	 Free Community Network _ [email-masked]
	 http://fcn.net _ http://fcn.net/allisat 
	 [email-masked]

---

From: "Finney, Mike" <[email-masked]>
Date: Tue, 19 Jan 1999 14:05:04 -0800

Mike Finney

	-----Original Message-----
	From:	Bob Allisat [SMTP:[email-masked]]
	Sent:	Tuesday, January 19, 1999 3:29 PM
	To:	Adam Hewitt
	Cc:	[email-masked]
	Subject:	RE: No More Central Authority: Not NSI/ICAN! Not
ORSC!

	Adam Hewitt wrote:
	= Two questions:
	=

	 Respectfully,

	 Bob Allisat