Subject: How the IETF Misses the Point...

From: "Jim Fleming" <[email-masked]>
Date: Sat, 13 Mar 1999 05:10:20 -0600

Just to show people how the IETF misses the point...
....below is a quote from James Dyson....I bet many people
who claim to be card-carrying IETF members would
agree with these views...all the IETF cares about is
protecting groups like the ICANN, ARIN, etc....in their
quest to do that...the IETF will stomp on people, censor
people, etc....partly because the IETF leaders have not
studied some of the views of people like JAMES DYSON...

JF

@@@@@@@ http://www.dyson.com/help/help_main.html#one

"I believe that an invention is a piece of creative art, like a book or a
song, and those don't require annual renewal fees. If I cannot afford an
annual renewal fee - which is simply some spod stamping a piece of paper -
why should the patent office be able to steal it from me? The legal
establishment argues that these fees are an incentive to stop people sitting
on technological breakthroughs. But that is patent rubbish. Quite literally.
The whole thing is clearly stacked in favour of the big companies, to whom
the fees mean relatively little, and against the small innovator.

This is, I believe, a human rights issue. And I am taking the DTI to the
European Court of Human Rights over it."

James Dyson ('Against the Odds', An Autobiography. Published by Orion
Books)"

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

---

From: "Jim Fleming" <[email-masked]>
Date: Sat, 13 Mar 1999 07:26:45 -0600

-----Original Message-----
From: [email-masked] <[email-masked]>
<snip>

>On Sat, 13 Mar 1999 02:23:33 CST, you said:
>> 4. In IPv16 we drop the entire 4-bit version field...it is not
needed...it
>> is wasteful...
>
>I breathlessly await actual code that implements an IPv8-IPv16
>gateway, that omits a check for the version field before gatewaying...
>

Short answer:
The IPv8 and IPv16 architecture is based on "services".

Long answer:
Raw packets do not flow from the IPv8 network to the
IPv16 network and vice versa. PKs that are connected
via the IPv16 network know that they are connected to
each other and therefore know that there is no version
field in the header. PKs can also talk to other PKs via
the IPv8 network that does have a version field and does
support options. There are no options after headers on
the IPv16 network. The first two bits are added to the
addressing bringing the address to a full 48 bits. The
IPv8 network only has a 47 bit address space. The IPv4
network(s) only have 32 bits of addressing. Many of those
networks will likely use RFC 1918 style address management.

[vPC]---{IPv4}---[GK]---{IPv8}---[PK]---{IPv16}---[PK]---{IPv8}---[GK]---{IP
v4}---[vPC]

The vPCs are hidden behind the GKs, just like PCs
behind machines that use "NAT". All traffic does not
flow through the IPv16 network. The GKs can direct
the PKs to route traffic directly between each other,
depending on the needs of the "service" involved.

"Services" go beyond protocols to platforms. In a platform
there is more emphasis on the APIs. If you look at the
entire IPv6 development, the protocol is not the critical
part, the changes to the UNIX API has been the hard part.
IPv8 and IPv16 will leverage off of those API changes.
Actual code is closer than you think, and is tied to IPv6,
unfortunately.

JF

---

From: "Jim Fleming" <[email-masked]>
Date: Sat, 13 Mar 1999 07:26:45 -0600

-----Original Message-----

needed...it

Short answer:

Long answer:

JF