Subject: (!) Vint Cerf designing network for solar system (!)

From: Bob Allisat <[email-masked]>
Date: Thu, 11 Mar 1999 11:47:50 -0500 (EST)

http://www.mercurycenter.com/svtech/news/breaking/merc/docs/011458.htm
> Current Cerf projects include setting up frameworks for
> intergalactic and intrasolar-system communications so that
> Earthlings colonizing other spheres can communicate with
> home bases. For example, Internet addresses may be set up
> by planet, so an Earthling conceivably could e-mail a
> friend at [email-masked].

 Poor Vint has his head in the spheres while
 things here on Earth go to the ICANN dogs.
 Could someone who knows this fellow inform
 him Rome is burning while he fiddles. As in
 somebody has entirely lost contact with what
 is euphemistically reffered to as reality.

 Bob Allisat

 Free Community Network _ [email-masked]
 http://fcn.net _ http://fcn.net/allisat
 http://robin.fcn.net

---

From: [email-masked] (Michael P DiGioia)
Date: Thu, 11 Mar 1999 12:40:50 -0500

Bob,

This is what happens when you are branded king of the network!

He is associated with having super powers and needs to focus his attention
on networking to mars before we have a crisis out there.

As you indicate, my only concern is that we could sure use his creative
energy here on earth with all the current problems.

/mpd

---

From: Bob Allisat <[email-masked]>
Date: Thu, 11 Mar 1999 13:29:48 -0500

At http://www.ietf.org/mail-archive/ietf/Current/msg04214.html
we see Vint's latest idea from the head in the clouds department:
>> ...Internet addresses may be set up by planet, so an Earthling 
>> conceivably could e-mail a friend at [email-masked].

Michael DiGioia comments:
+ This is what happens when you are branded king of the network!
+ 
+ He is associated with having super powers and needs to focus his 
+ attention on networking to mars before we have a crisis out there.
+ 
+ As you indicate, my only concern is that we could sure use his 
+ creative energy here on earth with all the current problems.

 Indeed. And the good owners of MARS.COM may not
 be too thrilled as well about Mr. Cerf's rather
 creative hijaking of their Domain Name. As in the
 chocolate bar, M&M's, Snickers, etc. Quoting our
 friends at <http://www.mars.com> :

= Welcome to the world of Mars, Incorporated!
= 
= Mars is a diversified multi-national company creating quality 
= products in five primary product groups including pet care, snack 
= foods, main meal, electronics, and drinks. Today Mars products are 
= enjoyed in over one hundred countries throughout five continents. 
= Our home page is a place where you can link to the wide variety of 
= information entertainment and services we provide on the Internet.
=

 Take your corners gentlemen! It's Mars verses
 Vint in the battle of the planets! All bets are
 off as the clash of the Titans is unleashed!
 Earth to Vint, come in Vint? Are you there????

 Bob Allisat

---

From: Bob Allisat <[email-masked]>
Date: Thu, 11 Mar 1999 13:29:48 -0500

Bob Allisat

---

From: "Fleischman, Eric W" <[email-masked]>
Date: Thu, 11 Mar 1999 11:09:38 -0800

I suspect that your true target is ICANN. If so, attacking Vint is off-target for you.

Regardless, I am very embarrassed to see a man of Vint Cerf's stature being publicly treated with such appalling disrespect. Vint is one of the true heroes of the Internet. I honor him as does virtually everyone else on these lists. We similarly regretted when similar abuse was poured out on another hero, Jon Postel. Please, let's honor these giants with the respect that they deserve while they are still alive and thereby demonstrate our gratitude for the Internet. One needn't agree with all of their positions. However, common decency demands that they be accorded the respect that they have earned.

> ----------
> From: 	Bob Allisat[SMTP:[email-masked]]
> Reply To: 	[email-masked]
> Sent: 	Thursday, March 11, 1999 10:29 AM
> To: 	[email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Cc: 	[email-masked]
> Subject: 	Re: (!) Vint Cerf designing network for solar system (!)
>

---

From: [email-masked]
Date: Thu, 11 Mar 1999 14:20:37 -0500

How will moons of the planets be treated, as sub-domains?

---

From: Lloyd Wood <[email-masked]>
Date: Thu, 11 Mar 1999 22:17:52 +0000 (GMT)

At 02:40 PM 3/11/99 -0500, John Lowry wrote:
>This is not as far out as it might seem.  One idea for
>exploring extra-solar bodies is to send self-replicating (perhaps)
>and self-organizing  network nodes to report back on what
>they find.

That would be a mixed crew of astronauts, right?

I can't think of better Von Neumann machines.

> An obvious testbed would be the solar system.
>
> Short of Warp drive this may be best way to go where 
> no-one has gone before.

Yup, _definitely_	 people.

L.

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>

---

From: Lloyd Wood <[email-masked]>
Date: Thu, 11 Mar 1999 22:17:52 +0000 (GMT)

L.

---

From: Bob Allisat <[email-masked]>
Date: Thu, 11 Mar 1999 18:54:21 -0500

Carl Malamud wrote:
- Vint points out that there are some fundamental protocol issues...

Dave "Crock" Crocker pontificates:
> As Carl cites, there are serious technical issues that the interplanetary 
> metaphor poses.  Solutions to those problems have real and immediate 
> application, for example for the crew of a marine research vessel whose 
> only link to the Internet is an outrageously expensive satellite channel, 
> or folks in developing countries who have, perhaps, a noisy 9.6kbps line 
> into the entire country.  The better we learn to deal with limited 
> bandwidth, severe signal distortion and large latency, the better the 
> overall performance of the net and the satisfaction of users will 
> be.  Folks are already realizing that the long-haul Internet really does 
> not perform well for true client/server exchanges.  We need to fix that.

 We ned to fix ICANN. The universe can wait.
 ICANN is not only busted it threatens to put
 all citizen's rights, freedoms and liberties
 in jeopardy. Your top down, pie in the sky,
 bullshit Star Trek nonsense expostulating is
 wasting our time. Focus on reality you freaking
 pompous, adolescent space cadets you!

 Bob Allisat

---

From: Bob Allisat <[email-masked]>
Date: Thu, 11 Mar 1999 18:54:21 -0500

Carl Malamud wrote:

 Bob Allisat

---

From: Bob Allisat <[email-masked]>
Date: Thu, 11 Mar 1999 19:06:03 -0500

> While the prospect of designing a "network" for the purpose of
> interplanetary packet transport is of arguable relevance/realism, 
> and at the risk of sounding like a Gore basher, it seems a bit 
> disconcerting to be comparing Dr. Cerf and Mr. Gore.
> 
> Not intending to take away from the work either gentleman has
> done is their respective capacities, I can't believe I'm even 
> reading such a thing.
> 
> With any semblance of a straight face, would we look to  
> politicians for the majority of the brainstorms leading to 
> research efforts anyway?  In a perfect world, for some initial 
> requirements definition MAYBE. 
> 
> Or for that matter, would we want Dr. Cerf meeting with Prime 
> Ministers? (OK.. that seems less horrible for some reason)
> 
> I guess the point (as invisible as it may be in my mail) is that 
> the charter of both of these men, with respect to their 
> backgrounds and obvious experience with the network(s) really are 
> apples and oranges.  If not, one of them (or both of them) would 
> be way off base.
> 
> With that said, I don't like the idea of either men being treated
> disrespectfully. Regardless of how much I may not agree with some 
> of their idealogies.

 They are both wildly off-base and phenominally
 bogus. Gore claims to have invented the Internet
 when he was no-where near the event. Totally nuts.
 Cerf is playing Babylon 5 assigning IP addresses
 and namespace to the moons of saturn while we here
 unfortunate enough to live on Earth can't even get 
 our own blessed TLDs into circulation. These two
 clowns deserve every bit of criticism and ridicule
 coming their way. They are arrogant, ignorant turds
 who lack even the shade of a clue nmot generated
 decades ago.

 And your collective despair at them being treated
 disrespectfully make me cry crocodile tears. And yet
 you have no problem eviscerating myself of Jim Fleming
 or anyone else who dares to dream or envision anything
 out of line with your enormously narrow imaginations! 
 What gall, waht puking, mewing, petulant pig-shite!!

 Bob Allisat

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Fri, 12 Mar 1999 10:22:31 -0500

In message <Pine.LNX.3.93.990312080533.13373A-100000@marietta>, Bob Allisat wri
tes:

> > Please drop this conversation as of now.
> 
>  No. In fact as of now I will assume a
>  leadership role in the blessed Internet
>  Community and tell you to drop your
>  attempts to stifle debate as of now.

You're quite welcome to assert any leadership you wish.  But do it on
your own mailing list, not ours.  You have no more right to abuse the
IETF list than you have to right to give a political speech during, say,
a theatrical performance.  We certainly would not deny you the right
to organize your own group or theatrical performance; you can then set its
policies, lead it, and see who -- if anyone -- follows.

---

From: Ronda Hauben <[email-masked]>
Date: Fri, 12 Mar 1999 10:41:55 -0500 (EST)

Bob Allisat <[email-masked]> wrote:

Fred Baker wrote:
>> Wouldn't you describe this as "ad hominem"? What about this discussion
>> is on-topic - the engineering of the internet, or the politics of the
>> IETF itself? What of this discussion has technical content?
>
>> Bob, what have you achieved in the discussion besides getting yourself
>> told - again - that your regime of invective is not well received by
>> the Internet community - that you represent nobody but yourself?
>

> Or risk losing any shred of credibility
> or openess to discussion you may still
> possess. These discussions are more
> than germaine - they are critical to
> the evolution of the Internet. Which,
> if you haven't been following events,
> is in severe risk of being sidelined
> by small group of companies and limited
> number of personalities. 

The Internet has been built on a principle
of welcoming all views. And this is for good
reason. The Internet is pioneering and to pioneer
one need to figure out problems that have never
been solved before. One can't solve problems by
restricting discussion, as then you stand likely
to cut out exactly the views that will help to 
identify or solve the problem.

(This was recognized by J.C.R. Licklider who had
the pioneering vision of the Net and also did
the work to make networking a reality. See chapter 8
of "Netizens")

Thus those who care for the Internet or for 
its forward development are those who support
and advocate the open discussion and debate
of *all* views.

The IETF was built on the shoulders of the Network
Working Group and RFC 3 which states:
"...we hope to promote the exchange and discussion of 
considerably less than authoritative ideas."

Furthermore it states: "Notes are encouraged to
be timely rather than polished. Philosophical positions
without examples,or other specifics, specific suggestions
or implementation techniques without introductory or 
background explication, and explicit questions
without any attempted answers are all acceptable."

(See RFC 3)

The issue of ICANN is not only *timely* but crucial
to the existence and development of the Internet,
and thus also to the existence and continued development
of the IETF.

Those on the ICANN interim board have been chosen because
they have a conflict of interest with the matters that
ICANN is to be deciding (called in their gentrified language
"stakeholder" interest)

They are people appointed by some unknown process and 
unknown people to fundamentally change the nature
and future of the Internet.

Thus this is an urgent, to say the least, issue for
*not* only those in the IETF but all those who are
part of the Internet or hope to ever be part of it.

Thus this is all a crucial question to be discussed
and all those trying to squelch the discussion (like
the Berkman Center folks) or anyone from IETF etc
are only showing that they have no concern for 
the present and future of the Internet.

Recently, on the IETF discussion list, someone asked
about scaling the Internet. He received one or two
serious replies and other jokes in response.

Yet the scaling the Internet is the burning question
on the table, and it is exactly the issue that ICANN
is being created to prevent from being publicly 
considered and determined.

Will the global people-to-people computer mediated
communication that the Internet makes possible be
available to all as a right or only to a few 
as a privilege?

This was an issue that J.C.R. Licklider, among others,
recognized had to be determined to be able to determine
what would happen in the development of computer networking.
He noted that if the to-be-developed network would be 
available to all as a "right", then it would be a great benefit
to society, while if it were to only be available to those
selected via a "privilege", its development would be harmful.
 
To make the Internet available to all as a right requires
a public process and public participation in the control
of the essential functions of the Internet like the 
names and protocols and ip numbers and root server
system. These have been under public and cooperative
ownership and control. ICANN is the effort to change that.

There are those who are respresentatives of companies
and other entities that want to grab the Internet
for their own self interested purposes.

They need to be stopped from their grab and only the
free and open discussion of the issues will help to 
clarify what is at stake and why there are those
trying to act in ways that are contrary to making
the Internet available to all for interactive 
and participatory global communication.

I have wondered why there are many in the technical community
who are not participating in figuring out what ICANN
is all about and what to do about it.

Now it becomes clear that the leadership of the IETF isn't
encouraging folks to get into the fray and figure out what
it is all about but instead is encouraging an attack on
those who recognize that the abuse by ICANN of the 
Internet community has to be understood and responded to.
And there are others like folks from ISOC including Vint 
Cerf who have taken on to try to deflect the discussion to
putting IP on Mars as a way to draw attention away from
the privatization of Internet public policy here on earth.

The principles on which the Internet has been built, i.e.
support for communication among autonomous networks and the 
cooperative effort to make that communciation function -- 
these principles are being fundamentally altered by
the creation and activity of ICANN. So if there is to be
an Internet, there must be an examination of what is happening
and why and what to do about it.

And unless this has to be done publicly. That is what Bob's
post is part of and that is why it needs to be welcomed
and encouraged, not attacked.

Is there still an IETF? There is a challenge to its existence
clearly and there are those trying to stifle any discussion
over this challenge.

Let the debate begin in the tradition of the Internet, not
behind closed doors or in private email, but openly and 
welcoming of all into the fray.

Ronda
[email-masked]

             Netizens: On the History and Impact
               of Usenet and the Internet
          http://www.columbia.edu/~hauben/netbook/
            in print edition ISBN 0-8186-7706-6 
          Published by the IEEE Computer Society Press

             See especially chapter 7
         "Behind the Net: The Untold Story of the ARPANET
          and Computer Science" and also RFC 3 in appendix

---

From: Vince Fuller <[email-masked]>
Date: Fri, 12 Mar 99 15:30:52 PST

[I'm probably going to regret this but at least there's some hope that use
 of a different email address will avoid my being added to yet another set
 of spammer lists...]

> It's quite simple.  And it all stems from the fact that we can never use
> address space in a dense fashion.  Remember that routing and addressing are
> inevitably tied.  If there is no structure to the address, then we have a
> flat network, which is clearly not scalable.  On the downside, as you
> structure the address, you lose efficiency.
> 
> You can see this today with an IPv4 prefix.  Utilization of a particular
> prefix can and historically has been quite poor.  You can find many numbers
> in the 10% to .1% range, depending on where you look.
> 
> Now, as you grow the network, the amount of state that you can support at
> any level is relatively constrained and must not outstrip Moore's Law.  It
> may be even more constrained if you want an economically viable solution.
> 
> So...  you need to have multiple levels of hierarchy, or what we know today
> as multiple levels of aggregation.  Each of these levels of aggregation is
> also, in turn, inefficient.  Note that this inefficiency is multiplicative
> with each level of aggregation that you perform.
> 
> Given these constraints, it's clear if the network is to scale, there needs
> to be many levels of aggregation, and that we're quickly looking at
> addressing efficiencies that are on the order of 10^-5 to 10^-12.  Sad but
> true.  

I'm surprised Noel hasn't already flagged this one - maybe he didn't want to
re-open this can of worms (though it is at least a technical can of worms,
unlike most of the recent flamage on this list...)

There is an unstated assumption in the above that "addresses" and any structure
that they have are relatively static objects. The "address" (at least in the
current IP architecture) serves two different purposes: one as an "endpoint
identifier" for host-to-host or application-to-application session definition
and one as a "locator" for describing where something is in the network
topology. By being forced to provide two very different functions, it does
neither particularly well. One could imagine separating these functions and
allowing more dynamic reconfiguration of the "locators" so that they map
exactly to the network topology. One might also imagine that such "locators"
could be relatively compact objects.
> 
> I think that it's clear that the next version of IP needs to be regarded as
> permanent infrastructure.  That means that it will be installed once, and
> persist indefinitely.  Like 120V 60Hz AC.  Like POTS.  
> 
> The problem with ubiquity is that it gives you a huge installed base
> problem.  And if there's no mechanism for incremental upgrades, you have no
> real hope of replacement.

Full agreement. This is why many people don't believe that IPv6 is the
right answer: it doesn't offer enough flexibility or enough of an improvement
over IPv4 to be a real, long-term solution. But you already know that...

	--Vince

---

From: Noel Chiappa <[email-masked]>
Date: Sun, 14 Mar 1999 01:16:00 -0500

> From: Vince Fuller <[email-masked]>

    > I'm surprised Noel hasn't already flagged this one - maybe he didn't
    > want to re-open this can of worms

Exactly. Been there, done that. I don't see any point to rearguing all these
points for the 17th time (especially on a list this size, with the number of
people who missed the last 16 iterations).

I do remain amused by the irony that if I hadn't pushed to get the host IP
layer changed to use a mask (in RFC-1122, IIRC, not worth the energy to look
it up) *even before we fully figured out how we were going to use it all yet*,
deploying CIDR (which is currently keeping the Internet afloat) would have
been far more of a pain.

However, the concept of adding generic mechanism intended to make your life
easier later, *once you figure out how to use it*, appears to be a lost idea
these days. (E.g. an endpoint<->locator binding table, with the binding from
one to the other fixed at connection open time for the moment, with hooks to
allow the binding to be changed once we have developed a *secure* mechanism
for so doing.)

It's always impressive how impossible things can be, once you've made up your
mind in advance that they are impossible.

	Noel