Subject: Suggested procedures for voting in IETF

From: Jacob Palme <[email-masked]>
Date: Tue, 16 Mar 1999 13:31:06 +0100

Suggested addition to the next edition of RFC 2418: IETF
Working Group Guidelines and Procedures. S. Bradner.
September 1998.

    Voting in IETF working groups
    -----------------------------

    Decisions in IETF working groups are not taken by majority
    voting. However, straw votes are sometimes used in order to
    check the status of opinions among working group members.
    Sometimes, only active implementors are allowed to
    participate in such a straw vote, or only those who have
    read the latest draft.

    Before a straw vote starts, the chairman should enumerate
    all the choices, and allow participants to check that the
    list of choices is complete.

    During a straw vote, participants may be asked to select
    the best choice. But when the number of choices is more
    than two, it might be better to ask, separately for each
    choice, how many think that this choice is good or bad,
    since more than one of the choices may be good, and in that
    case rougue consensus may be reached by finding a choice
    which most participants find good, rather than a choice
    which most participants prefer.

Here is the rationale  for the above statement: Rough
consensus means finding a solution which most think
is good, not a solution which most think is best.

Example, suppose the choices are A, B and C. And suppose
that 39% think A is best, but most of them think that
B is almost as good as A, and 37 % think B is best,
but most of them think that A is almost as good as B,
and 24 % think that C is best, but most of them think
that B is almost as good as C. The outcome of a
vote might then be:

     Outcome of      Outcome of
     good/bad-vote   most liked-vote

     Good   Bad      Most liked

A    73%    27%      39%
B    95%     5%      37%
C    24%    76%      24%

The outcome in the example is fully possible, and shows
that even though the most liked choice is A, this
choice does not have rough consensus, while there
is instead rough consensus on choice B.

If someone wants to know how I computed the table
above, see the Excel spreadsheet at
  http://www.dsv.su.se/~jpalme/ietf/IETF-voting-example.xls
------------------------------------------------------------------------
Jacob Palme <[email-masked]> (Stockholm University and KTH)
for more info see URL: http://www.dsv.su.se/~jpalme

---

From: Dave Crocker <[email-masked]>
Date: Tue, 16 Mar 1999 10:08:59 -0800

>is good, not a solution which most think is best.

Jacob,

What is the problem that your proposed text is intended to fix?  There is 
already text in the relevant IETF documents about the nature and details of 
the rough consensus process.  Is there a procedural problem that is 
occurring in a number of working groups that your text is intended to fix?

d/

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Dave Crocker                                         Tel: +1 408 246 8253
Brandenburg Consulting                               Fax: +1 408 273 6464
675 Spruce Drive                             <http://www.brandenburg.com>
Sunnyvale, CA 94086 USA                 <mailto:[email-masked]>

---

From: Dave Crocker <[email-masked]>
Date: Tue, 16 Mar 1999 10:08:59 -0800

Jacob,

d/

---

From: "Theodore Y. Ts'o" <[email-masked]>
Date: Tue, 16 Mar 1999 15:29:44 -0500 (EST)

Date: Tue, 16 Mar 1999 10:08:59 -0800
   From: Dave Crocker <[email-masked]>

I have observed a number of working groups where the chairs or the
speakers have not been careful about how they word their straw polls.
The most common probem is that those folks holding the straw polls do
not list all of the alternatives ahead of time before asking people to
raise their hands, and especially adding a third alternative after
asking people to chose between tween two major alternatives.

Usually what happens is that people object, and the speaker or working
group chair retries the whole straw poll process in response to the
complaints.

I think that this is a worthwhile subject for the working group chair
training session, but not necessarily something to standardize in an
RFC.

						- Ted

---

From: "Theodore Y. Ts'o" <[email-masked]>
Date: Tue, 16 Mar 1999 15:29:44 -0500 (EST)

- Ted

---

From: Dave Crocker <[email-masked]>
Date: Tue, 16 Mar 1999 12:52:07 -0800

At 03:29 PM 3/16/99 -0500, Theodore Y. Ts'o wrote:
>...

>training session, but not necessarily something to standardize in an

Yes, I have seen that too.  It is one of the most quickly-corrected working 
group chair process errors I can imagine.  As you note, participants are 
pretty forceful about making clear that the survey isn't clear.

d/

---

From: Dave Crocker <[email-masked]>
Date: Tue, 16 Mar 1999 12:52:07 -0800

d/