Subject: Suggested procedures for voting in IETF

From: Jacob Palme <[email-masked]>
Date: Tue, 16 Mar 1999 13:31:06 +0100

Suggested addition to the next edition of RFC 2418: IETF
Working Group Guidelines and Procedures. S. Bradner.
September 1998.

    Voting in IETF working groups
    -----------------------------

    Decisions in IETF working groups are not taken by majority
    voting. However, straw votes are sometimes used in order to
    check the status of opinions among working group members.
    Sometimes, only active implementors are allowed to
    participate in such a straw vote, or only those who have
    read the latest draft.

    Before a straw vote starts, the chairman should enumerate
    all the choices, and allow participants to check that the
    list of choices is complete.

    During a straw vote, participants may be asked to select
    the best choice. But when the number of choices is more
    than two, it might be better to ask, separately for each
    choice, how many think that this choice is good or bad,
    since more than one of the choices may be good, and in that
    case rougue consensus may be reached by finding a choice
    which most participants find good, rather than a choice
    which most participants prefer.

Here is the rationale  for the above statement: Rough
consensus means finding a solution which most think
is good, not a solution which most think is best.

Example, suppose the choices are A, B and C. And suppose
that 39% think A is best, but most of them think that
B is almost as good as A, and 37 % think B is best,
but most of them think that A is almost as good as B,
and 24 % think that C is best, but most of them think
that B is almost as good as C. The outcome of a
vote might then be:

     Outcome of      Outcome of
     good/bad-vote   most liked-vote

     Good   Bad      Most liked

A    73%    27%      39%
B    95%     5%      37%
C    24%    76%      24%

The outcome in the example is fully possible, and shows
that even though the most liked choice is A, this
choice does not have rough consensus, while there
is instead rough consensus on choice B.

If someone wants to know how I computed the table
above, see the Excel spreadsheet at
  http://www.dsv.su.se/~jpalme/ietf/IETF-voting-example.xls
------------------------------------------------------------------------
Jacob Palme <[email-masked]> (Stockholm University and KTH)
for more info see URL: http://www.dsv.su.se/~jpalme

---

From: Dan Kohn <[email-masked]>
Date: Tue, 16 Mar 1999 07:46:56 -0800

I strongly suggest you review Kenneth Arrow's Impossibility Theorem,
which proves (given some very reasonable assumptions) the impossibility
of using voting to fairly represent a group's views.

The Impossibility Theorem is actual proof that, as Churchill said,
"Democracy is the worst possible form of government except -- all the
others that have been tried.".  It is also yet another argument for
"rough consensus and working code".

		- dan

http://www2.inow.com/~conover/correspondence/981219161210.22322.html

    Paul Samuelson ... put it this way: "The search of
    the great minds of recorded history for the perfect democracy, it
    turns out, is the search for a chimera, for logical
    self-contradiction. New scholars all over the world-in
    mathematics, politics, philosophy, and economics-are trying to
    salvage what can be salvaged from Arrow's devastating discovery
    that is to mathematical politics what Kurt Godel's 1931
    impossibility-of-proving-consistency theorem is to mathematical
    logic."

http://www.nrao.edu/~jogle/TORG/arrow.txt

-----Original Message-----
From: Jacob Palme [mailto:[email-masked]]
Sent: Tuesday, 1999-03-16 04:31
To: IETF general mailing list
Cc: Scott Bradner
Subject: Suggested procedures for voting in IETF

     Outcome of      Outcome of

     Good   Bad      Most liked

A    73%    27%      39%
B    95%     5%      37%
C    24%    76%      24%

---

From: Dan Kohn <[email-masked]>
Date: Tue, 16 Mar 1999 07:46:56 -0800

- dan

-----Original Message-----
From: Jacob Palme [mailto:[email-masked]]
Sent: Tuesday, 1999-03-16 04:31
To: IETF general mailing list
Cc: Scott Bradner
Subject: Suggested procedures for voting in IETF

     Outcome of      Outcome of

     Good   Bad      Most liked

A    73%    27%      39%
B    95%     5%      37%
C    24%    76%      24%