Subject: In IETF We Trust

From: "Rahmat M. Samik-Ibrahim" <[email-masked]>
Date: Tue, 04 May 1999 05:27:30 +0000

Hello:

I am not sure about to whom I should post this, and therefore:

                  "To Whom It May Concern". 

I am writing in regard of the introduction of BCP-9[(c)1996 ISOC]:
   "The Internet Standards process is an activity of the 
    Internet Society that is organized and managed on behalf 
    of the Internet community by the Internet Architecture 
    Board (IAB) and the Internet Engineering Steering Group 
    (IESG)."

------------------------------------------------------------------
1. "The Internet Standard process is an activity of the Internet
    Society"; A cross check with ISOC's Mission Statement
    <http://www.isoc.org/isoc/mission/> [(c) 1999 ISOC]:

      "To assure the beneficial, open evolution of the global 
       Internet and its related internetworking technologies 
       through leadership in standards, issues, and education."

    Basically, this must be a good idea, and I do not have
    problem with it.

-------------------------------------------------------------------
2.  "that is organized and managed"

     Thank you very much for this effort, ISOC: I appreciate this! 
     (note: I am not an ISOC member).

-------------------------------------------------------------------
3.   "on behalf of the Internet community"

     I assume that the "Internet community" in a broad sense is 
     "anyone who uses or supports the Internet". Therefore, it 
     also include anyone's mom who uses the Internet. However, 
     there is a problem with the "on behalf" part. The issue here 
     is not whether anyone's mom is interested or not in the 
     Internet Standard Process, but the consequence of "acting 
     on behalf of anyone else" itself.

     First, the "on behalf" assertion above has been deliberately 
     as well as openly(TE) written(TE) in a document. I assume 
     that the ISOC really mean it, and it is the truth, the whole 
     truth, and nothing but the truth.

     Second, by acting "on behalf", there should be a way for
     "the Internet community" for monitoring about what has been
     done "on behalf" of the community. I assume that 
     "IETF-ANNOUNCE" plays the role of "informing the Internet 
     community", i.e. anyone who would like to follow the 
     Internet, should regularly browse:

          <http://www.ietf.org/maillist.html>. 

     Therefore, anything that is not announced in 
     "IETF-ANNOUNCE", means that it is not announced to the 
     "Internet Community"  (e.g. appointment of the NOMCOM 
     chair, appointment of the RFC-ED, etc.).

     Third, there is a need for a feedback mechanism from the
     Internet community in regard of the Internet Standard 
     Process. The closest "publicly recorded feedback mechanism" 
     that I know is this "IETF" list. Writing a feedback to the  
     IAB or IESG or ISOC itself nowadays has been shown not
     effective. Apparently, they think that they have right 
     remain silent/ ignoring the Internet community. Therefore, 
     if this IETF list is not appropriate for posting public 
     feedbacks, there should be created a new one. See also
     <http://www.egroups.com/> for hassle free solutions
     (cf. the ol' Major Domo).

-------------------------------------------------------------------
4.  "by the Internet Architecture Board (IAB) and the Internet 
     Engineering Steering Group (IESG)."

     Apparently, "IETF" is a generic name for "IAB", "IESG",
     "Working Groups", "IANA", "RFC-ED", et.al. No wonder,
     that until now, the IETF has not been chartered.

-------------------------------------------------------------------
Bottom Line:

There is a need for a publicly recorded feedback mechanism for
the Internet Standard Process. Whether there will be a follow
up or not to a feedback is not discussed here.

tabe,

-- 
Rahmat M.Samik-Ibrahim VLSM-TJT http://www.geocities.com/Tokyo/6825
*OK,so you run the internet?THAT DON'T IMPRESS ME MUCH!Shania Twain

---

From: "Ace Meataku " <[email-masked]>
Date: Tue, 4 May 1999 14:42:27 +0800

Rahmat,

I enjoyed reading your comments.

I am a Internet Society member and i do trust that that is a need for a
setup of a so called "Internet Users Task Force" (IUTF) to better address
social issues, internet content issues, and many many more sensative issues
available on the net and transmitted via the net.

-A regular "voting" from IUTF members to address all kinds of issues. Be it
technical or non technical issues. 
-A regular "surveys" on all kinds of issues from  IUTF members as well as
non-members to particiapte to keep track of the voice of the Netizens.

just a thought.
rgrds
WM Phan

----------
> From: Rahmat M. Samik-Ibrahim <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]; MILIS gnM-DICK <[email-masked]>
> Subject: In IETF We Trust
> Date: Tuesday, May 04, 1999 1:27 PM
> 
> 
> Hello:
>

---

From: Scott Bradner <[email-masked]>
Date: Tue, 4 May 1999 07:22:59 -0400 (EDT)

> the Internet Standard Process. 

such a process is also described in BCP 9 - it is the IETF Last-Call
process

Scott

---

From: Scott Bradner <[email-masked]>
Date: Tue, 4 May 1999 07:22:59 -0400 (EDT)

Scott

---

From: "Robert G. Ferrell" <[email-masked]>
Date: Tue, 4 May 1999 08:35:02 -0500 (CDT)

> Also, remember that an *incredible* fraction (probably 95% or more)
> of the "Internet community" neither knows of the IETF/ISOC nor cares.
> They just know that the Web "just works", and e-mail attachments
> "just work".

I have to agree with this point.  I should also like to add that anyone may 
participate in the IETF merely by signing up for one or more mailing lists.  
There's no "secret handshake" or any other exculsionary process that I'm aware 
of.  It's more efficient to provide input during the development of a particular 
standard or protocol, rather than after it has been drafted and semi-finalized. 
While I certainly think that the general Internet-using public has a right to 
express their views on what the IETF does, I must also stress that the IETF 
cannot, in my opinion, respond to each and every comment or suggestion.  The 
IETF is a volunteer organization of people trying to make some sense out of the 
most heterogeneous, patched-together technological system ever devised by the 
Human race, not some sort of power-seeking consortium.  Standards developed here 
are not forced on anyone, except by concensus of the engineers, sysadmins, 
developers, and others who keep the Internet running.  In light of this, I don't 
think that language which seems to suggest that the IETF is an elitist group who 
foist their standards on an unwitting Internet community is really appropriate.  
Forgive me if that sentiment was not intended by the original poster, but that's 
what I got out of it, and in an ASCII-only social interaction such as this, 
interpretation is just about everything.

Robert G. Ferrell
Internet Technologist
National Business Center
US Dept. of the Interior

---

From: "Robert G. Ferrell" <[email-masked]>
Date: Tue, 4 May 1999 08:35:02 -0500 (CDT)

Robert G. Ferrell
Internet Technologist
National Business Center
US Dept. of the Interior

---

From: "Juan del Villar" <[email-masked]>
Date: Tue, 4 May 1999 09:53:50 -0400

Phan:

I don't know exactly who to address this to, so I'm going to include
everybody.

I think that web content is one of the biggest issues facing the internet
community these days.
An "Internet User Task Force" sounds like a good mechanism to be able to
manage such
a big demand for on-line information distribution.

One thing that comes to mind though is the people that should participate
in this IUTF.
There are so many people involved on internet content and security that I
feel some of the
proposals that may come out of the IUTF just go down the tubes.

It is necessary to come up with a well defined set of standards
(objectives) that this IUTF
needs  in order to accomplish its mission.

Just a thought.

Regards;

Juan Del Villar
Software Engineer
Tekelec, NC
Phone: (919)380-3890
mail: [email-masked]

---

From: "Juan del Villar" <[email-masked]>
Date: Tue, 4 May 1999 09:53:50 -0400

Phan:

Just a thought.

Regards;

Juan Del Villar
Software Engineer
Tekelec, NC
Phone: (919)380-3890