Subject: BOF proposal announcement: Complexity of Implementing Differentiated Services

From: Jon Crowcroft <[email-masked]>
Date: Thu, 13 May 1999 15:59:26 +0200

Dear IETF, and esp. diff-serv folks,
we're requesting a schedule slot for the following Transport Area
BOF relating to the diff-serv WG, for the Oslo (45th IETF) meeting:

this is a call for input...although if we don't get enough interest,
or involvement, we will postpone.

I guess it has the natural short name CIDS
--------------------------------------------------->

Proposal for BOF 
on
Complexity of Implementing Differentiated Services (CIDS)

Motivation.

The IETF WG on Differentiated Services (diff-serv) has been meeting now for 
over a year now and has made excellent progress. The framework, architecture, 
DS Field definition, and format for traffic conditoners document, and most
importantly , two PHB definitions have been specified.

So what is the problem?

The Integrated Services WG (int-serv) (with its related groups such as 
ISSLL and RSVP and others), has also defined a set of protocols and 
mechanisms for enhanced services in the Internet. The difference between the 
int-serv and diff-serv approaches is that int-serv (at least the Guaranteed 
and Controlled Load services) is amenable to analysis. Effective bandwidth 
calcualations, and the thesis by Parekh shows how the admission tests for leaky
bucket characterised traffic and delay bound for the path can be
calculated. The difficulty with IS has been in designing
implementations that scale (hence a great deal of work in state
aggregation in RSVP, and in fast generalized port specification
classifiers, as well as  the work on efficient queue data structures
and insert/retrieve algorithms, such as WF2Q and approximations such
as SFQ). Indeed, there are network QoS calculi (by Rene Cruz and also
by Jean-Yves le Boudec).

Meanwhile, with diff-serv, the difference is that there can be no
obvious analytic theory of diff-serv. A path can be constructed out of
a sequence of hops each with a PHB and some associated SLA. However,
the service (and provisioning of service) necessarily depend on the
actual network topology and traffic conditions that prevail.

This is a positive aspect of diff-serv, since it gives providers (and
router vendors) a lot of design freedom in how they deploy actual
services (and associated tarrif structures).

However, to evaluate a diff-serv PHB is now a complex task, and
requires simulation or measurement. To date, only modest simulations
and measurements have been carried out.

[Aside: of course the exact same argument
applies to figuring out call blocking
probabilities in int-serv type networks]

Objectives.

To prepare a document that outlines evaluation framework for PHBs by
suggesting realistic topologies and traffic patterns for measurement
or simulation work. Note that there is a health warning associated
with simualtion - see reference [2] below.

Reading

1/ http://www.cs.columbia.edu/~hgs/internet/traffic.html

2/ Paxson, V., and Floyd, S., Why We Don't Know How To Simulate The
Internet, Proceedings of the 1997 Winter Simulation Conference,
December 1997. at
http://www.aciri.org/floyd/papers/wsc97.ps

very outline draft agenda

Draft agenda for CIDS BOF
 
Problem Statement (see the Document) - 15 mins
 
Potential Strawman Topologies - various - 30 mins
 
Potential Traffic Scenerios - various speakers 1 hour
 
Applicability Discussion - All 30 mins
 
Wrapup and Output Decisions -

---

From: "Noriko Hata" <[email-masked]>
Date: Thu, 20 May 1999 20:23:09 +0200

Please note that DIS has already proposed a WG Bof for Differentiated
Internet Services Cost Operations (DISCO) to the Transport area Directors
back in --November 98 (11/98)--. The DISCO WG had been intentionally
established for the discussion of Services and Implementations of Diffserv
(with alignment to Diffserv, Intserv, Rap, RSVP and MPLS WGs).

The DISCO WG inherently includes the "Complexity Implementations" as a part
of the Global Services and Implementations discussion described in DISCO.

I see no use to form two different IETF WGs dealing with Services and
Implementations. CIDS proposers, Please contact me to work on the alignment
of the two WGs.

Contributions and assessments to DISCO can be directed to Kai Yokohama
[email-masked] as DIS in charge personnel for maintaining the DISCO WG and
finalizing the WG establishment procedures,

To subscribe to DISCO:

General Discussion : [email-masked]
To Subscribe: [email-masked]
In Body: subscribe

Regards,

Noriko
--
Noriko Hata
Digital Intelligence Systems.

----- Original Message -----
From: Jon Crowcroft <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Thursday, May 13, 1999 3:59 PM
Subject: BOF proposal announcement: Complexity of Implementing
Differentiated Services

---

From: "Noriko Hata" <[email-masked]>
Date: Thu, 20 May 1999 20:23:09 +0200

To subscribe to DISCO:

Regards,

Noriko

----- Original Message -----
From: Jon Crowcroft <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Thursday, May 13, 1999 3:59 PM
Subject: BOF proposal announcement: Complexity of Implementing
Differentiated Services

---

From: "Noriko Hata" <[email-masked]>
Date: Wed, 26 May 1999 20:39:34 +0200

Jon,

The DISCO WG indeed includes the evaluations of the proposed schemes before
discussing their implementations in the "real life" operation.

Regarding the BoF, we don't mind having a BoF in Oslo. But, If indeed, a
strong support in the BoF will be evident for a WG formation, we do insist
that DISCO will be the WG to be formed.

DISCO already has more than 100 subscribers,

A charter of DISCO can be found at www.eye-tech.com/ietf-disco/charter.htm

Noriko

----- Original Message -----
From: Jon Crowcroft <[email-masked]>
To: Noriko Hata <[email-masked]>
Cc: Kai Yokohama <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Tuesday, May 25, 1999 9:43 AM
Subject: Re: BOF proposal announcement: Complexity of Implementing
Differentiated Services

>
>In message <003201bea48d$f4abdb00$529c44d4@euronet>, Noriko Hata typed:
>
>
> >>Are there any other proposers to CIDS interested in more information ?
>
> Noriko,
>
>I think there are significant difference between our
>two proposals - firstly I am
>not proposing a WG, jsut a BOF; but more importantly, we
>are interested in evluation of proposed schemes, not evalusation of
>implemenations of proposed schemes - i.e.  I think the BOF i am
>proposing is to look at a stage much _earlier_ in the process of
>getting diff-serv out there than the WG you propose - so i hope yo
>udon;'t mind, but I think I will proceed with this BOF anyhopw (after
>all, it is just one meeting in Oslo, not a whole work plan - in fact,
>i am fairly sure that it will NOT lead to a WG, so I think it has
>quite a different lifecycle!)
>
>
>regards
> >>--
> >>Noriko Hata
> >>Digital Intelligence Systems
> >>
> >>
> >>
> >>To: Noriko Hata <[email-masked]>
> >>Cc: Kai Yokohama <[email-masked]>; Ofer Avineri <[email-masked]>;
Yoram
> >>Bernet <[email-masked]>; Brian E Carpenter
<[email-masked]>;
> >>Kathleen Nichols <[email-masked]>; diff-serv <[email-masked]>;
jtw
> >><[email-masked]>; Fred Baker <[email-masked]>; Vern Paxson
> >><[email-masked]>; Scott Bradner <[email-masked]>;
> >><[email-masked]>
> >>Sent: Friday, May 21, 1999 8:19 AM
> >>Subject: Re: BOF proposal announcement: Complexity of Implementing
> >>Differentiated Services
> >>
> >>
> >>>
> >>>In message <005601bea2ee$077cfb20$43be75c0@euronet>, Noriko Hata typed:
> >>>
> >>>i can';t tell if there is duplication or not - can you send me the
> >>>agenda/outline of what you are addressing in DISCO please.
> >>>
> >>> >>[email-masked] as DIS in charge personnel for maintaining the
DISCO WG
> >>and
> >>>is there a web page describing the proposed work?
> >>>
> >>>regards
> >>>
> >>>jon
> >>>
> >>
>
> cheers
>
>   jon
>
>