Subject: Re: question??

From: Guangsheng Liu <[email-masked]>
Date: Thu, 06 May 1999 11:10:47 -0400

Hi, Ari:
  Yes. I know there is a RFC describe the requirement of Router
implementation. 
The point is how many percent of routers in the market support Router
Discovery 
Protocol as described in RFC1256. 
  Router Discovery seems more difficult than I originally thought. There
are lots
of old router (RIPv1). There are issues to address in order to make sure a
host 
can find a default router if a router doesn't support Router Discovery
protocol.

  1. Broadcast or Multicast ( RIP v1 - broadcast, RIP v2 & OSPF - multicast )
     We can try both. 
  2. Router can be configured to "don't send (Routing packet)" per interface. 
     This will prevent a method to work on listening the routing traffic. 
     I think most network administrator will disable routing packet
advertise on 
     the network if there is only one router connect with it. 
  
  To make sure a host can find a default router, another way is the host
can check
the packets (traffic generated by other hosts) and find the default
gateway's MAC,
then may use RARP to find the gateway's IP address. 
  
  The worst case is the router doesn't advertise and there is no traffic on
the
wire. 
  
  Guangsheng Liu

At 07:27 AM 5/6/99 -0700, you wrote:
>>Hi, Ari:
>>  Thank you very much.
>>
>        You're very welcome...I just hope it helped. I'm very interested
>        in knowing whether you were aware of the existence of RFC1812
>        prior to my citing it?
>
>        I have an ongoing discussion with Fred Baker (the editor of RFC1812)
>        on its utility...
>
>
>
>      OLTECO                    Ari Ollikainen
>      P.O. BOX 3688             Networking Architecture and Technology
>      Stanford, CA              [email-masked]
>      94309-3688                415.517.3519                          
>
>
>
>

---

From: Guangsheng Liu <[email-masked]>
Date: Thu, 06 May 1999 11:10:47 -0400

Hi, Ari:

  
  
  Guangsheng Liu

---

From: Fred Baker <[email-masked]>
Date: Thu, 06 May 1999 11:22:00 -0700

At 11:10 AM 5/6/99 -0400, Guangsheng Liu wrote:
>There are lots of old router

I wonder how many there will be a year from now? How many of these will be
upgraded to current technology to address Y2K concerns?

---

From: Fred Baker <[email-masked]>
Date: Thu, 06 May 1999 11:22:00 -0700

---

From: Bill Manning <[email-masked]>
Date: Fri, 7 May 1999 10:41:54 -0700 (PDT)

> upgraded to current technology to address Y2K concerns? 

O'dells law applies

-- 
--bill

---

From: Bill Manning <[email-masked]>
Date: Fri, 7 May 1999 10:41:54 -0700 (PDT)

O'dells law applies

-- 
--bill