Subject: ISO Documents

From: "Al Costanzo" <[email-masked]>
Date: Thu, 1 Jul 1999 22:22:16 -0500

Hello Everyone!
Does anyone know if these documents exist anywhere online?
I looked at the ISO website to no avail.
They are:

[ISO3166-1] ISO 3166-1:1997 Codes for the representation of names of
countries and their subdivisions -- Part 1: Country codes.

[ISO3166-2] ISO/DIS 3166-2 Codes for the representation of names of
countries and their subdivisions -- Part 2: Country subdivision code.

Thanks 

al

[email-masked]

---

From: Michael Mealling <[email-masked]>
Date: Thu, 1 Jul 1999 23:07:56 -0400 (EDT)

> countries and their subdivisions -- Part 1: Country codes.

http://www.din.de/gremien/nas/nabd/iso3166ma/codlstp1.html

Note that ISO making something like this publicly available is very rare.

> countries and their subdivisions -- Part 2: Country subdivision code.

I've been talking to the 3166 Maintenance Agency and they have no
immediate intention of making 3166-2 available online. There are
also no electronic versions available at all. I'm talking to 
someone at ANSI about the rumored existence of a PDF version but
so far nothing substantive has been found. 

Does anyone have any suggestions for how to try and convince ISO
to make 3166-2 available as well?

-MM

-- 
--------------------------------------------------------------------------------
Michael Mealling	|      Vote Libertarian!       | www.rwhois.net/michael
Sr. Research Engineer   |   www.ga.lp.org/gwinnett     | ICQ#:         14198821
Network Solutions	|          www.lp.org          |  [email-masked]

---

From: Michael Mealling <[email-masked]>
Date: Thu, 1 Jul 1999 23:07:56 -0400 (EDT)

-MM

---

From: John Day <[email-masked]>
Date: Fri, 2 Jul 1999 10:26:35 -0400

>to make 3166-2 available as well?
This is something that ISO has never understood.  The primary reason is
that ISO gets most of their income from selling documents, unlike ITU which
gets most of their income from the phone companies.  In general, if the
committee responsible for the standard asks ISO to make the document
available on-line, they will.  I know that it has been done for some
standards, especially those like X.500 which have lots of ASN and
electronic versions avoid transcription errors.  This might take some time.
However, JTC1 has been slowly trying to be more responsive, so they may
have procedures in place that will make it easier.  I haven't kept up with
all their changes.

I suggest that you contact ANSI.  In particular, you should ask for the
Secretariat of the committee responsible for the work.  Start with, Lisa
Rajchel, the Secretariat of JTC1 which is the parent for all of the IT
committees.

Take care,
John Day

---

From: John Day <[email-masked]>
Date: Fri, 2 Jul 1999 10:26:35 -0400

Take care,
John Day

---

From: John C Klensin <[email-masked]>
Date: Fri, 02 Jul 1999 11:15:51 -0400

John,

(And anyone else interested)

Some quibbles, but no basic disagreement, with John's comments.
However, 3166 is particularly problematic:

     -- the exceptions to permit online availability at the
     request of various committees that John refers to exist
     within ISO/IEC JTC1.  Unless things have changed while I
     wasn't looking, they aren't even available except in a very
     restricted experimental way to other ISO TCs (outside the
     information technology area).
     
     -- IS 3166 belongs to ISO TC46 on Information and
     Documentation.  TC46 is a full-fledged TC -- i.e., it is
     parallel to JTC1 in the structure, not a subsidiary of it
(and not an "IT committee").
     DIN is the Secretariat.  So, while I expect Lisa would be
     helpful (she almost always is) she has little real leverage
     or authority in this area.

Please don't kill any of the messengers here.

--john

----------------------------
 
--On Friday, 02 July, 1999, 10:26 -0400 John Day <[email-masked]>
wrote:

> >> [ISO3166-1] ISO 3166-1:1997 Codes for the representation of
> names of >> countries and their subdivisions -- Part 1:
> Country codes. >
> >Note that ISO making something like this publicly available
> is very rare. >
> >> [ISO3166-2] ISO/DIS 3166-2 Codes for the representation of
> names of >> countries and their subdivisions -- Part 2:
> Country subdivision code. >
> >I've been talking to the 3166 Maintenance Agency and they
> have no >immediate intention of making 3166-2 available
> online. There are >also no electronic versions available at
> all. I'm talking to >someone at ANSI about the rumored
> existence of a PDF version but >so far nothing substantive has
> been found.
> >
> >Does anyone have any suggestions for how to try and convince
> ISO >to make 3166-2 available as well?
> >
> This is something that ISO has never understood.  The primary
> reason is that ISO gets most of their income from selling
> documents, unlike ITU which gets most of their income from the
> phone companies.  In general, if the committee responsible for
> the standard asks ISO to make the document available on-line,
> they will.  I know that it has been done for some standards,
> especially those like X.500 which have lots of ASN and
> electronic versions avoid transcription errors.  This might
> take some time. However, JTC1 has been slowly trying to be
> more responsive, so they may have procedures in place that
> will make it easier.  I haven't kept up with all their changes.
> 
> I suggest that you contact ANSI.  In particular, you should
> ask for the Secretariat of the committee responsible for the
> work.  Start with, Lisa Rajchel, the Secretariat of JTC1 which
> is the parent for all of the IT committees.
> 
> Take care,
> John Day
>

---

From: John C Klensin <[email-masked]>
Date: Fri, 02 Jul 1999 11:15:51 -0400

John,

     

--john

---

From: John Day <[email-masked]>
Date: Fri, 2 Jul 1999 15:20:59 -0400

>     or authority in this area.
My understanding with the documents I had contact with was that that if
they were made available electronically, they were generally available,
unlike the ITU web site.  I know that for several of the standards with
lots of ASN.1 that were used outside the immediate committee there was a
resolution passed in JTC1 that allowed it.  We also went to great lengths
to make the ISO copyright apply only to the body of the document and not
the appendices with all of the ASN.1 so that you wouldn't violate the
copyright by downloading it and feeding it into your compiler.

However, as you point out the Secretariat for that particular document is
DIN (I don't even know what committee that is) but they have never been
terribly open about these sorts of things.  However, I would start with
Lisa and see what kind of advice or help she can give you.

Take care,
John

---

From: John Day <[email-masked]>
Date: Fri, 2 Jul 1999 15:20:59 -0400

Take care,
John

---

From: Pete Loshin <[email-masked]>
Date: Fri, 02 Jul 1999 19:21:20 -0400

>unlike the ITU web site.  I know that for several of the standards with

Maybe a couple of years ago I went looking for X.500/X.509 specifications
and could only find them for about US$20 or so worth of Swiss francs from
the ITU site. Have things changed? Where can I get ITU specifications for
nothing? I'd *really* like to know...

Thanks!
-pl

+-------------------------------------------------------------+
| Pete Loshin         <[email-masked]>       +1 781/646-6318 |
|                                                             |
| _IPv6 Clearly Explained_ Morgan Kaufmann January 1999       |
| _TCP/IP Clearly Explained_ 3rd ed Morgan Kaufmann June 1999 |
|                                                             |
+-------------------------------------------------------------+

---

From: Pete Loshin <[email-masked]>
Date: Fri, 02 Jul 1999 19:21:20 -0400

Thanks!
-pl

---

From: Simon Leinen <[email-masked]>
Date: 06 Jul 1999 12:38:44 +0200

>>>>> "jd" == John Day <[email-masked]> writes:
> However, as you point out the Secretariat for that particular
> document is DIN (I don't even know what committee that is) [...]

DIN (Deutsches Institut fuer Normung) is more or less the German
equivalent of ANSI.
-- 
Simon.

---

From: Simon Leinen <[email-masked]>
Date: 06 Jul 1999 12:38:44 +0200

---

From: John Day <[email-masked]>
Date: Tue, 6 Jul 1999 10:11:25 -0400

>DIN (Deutsches Institut fuer Normung) is more or less the German

Right, Simon, I know what DIN is, which is why I made the comment about it
being unlikely that they would put *anything* online.  Their reputation is
well known.  I still don't know what *committee* it is.  (DIN is not a
committee, it is a National Body.)

---

From: John Day <[email-masked]>
Date: Tue, 6 Jul 1999 10:11:25 -0400

---

From: James Aldridge <[email-masked]>
Date: Tue, 06 Jul 1999 16:39:43 +0200

> countries and their subdivisions -- Part 2: Country subdivision code.

These are unlikely to be available in full on the Internet as are big
documents which the national standards bodies like to charge a lot of money
for providing in hard-copy.  For example, from the BSI online catalogue
(http://www.bsi.org.uk/bsis/index.htm):

| BS EN ISO 3166-1:1998
| 
| Codes for the representation of names of countries and their subdivisions.
| Country codes
| 
| Price: GBP50.00 to subscribing members of BSI, GBP100.00 to non-members 74
| page(s)
| 
| Committee: IDT/2/11

and
                                                 
| BS ISO 3166-2:1998
| 
| Codes for the representation of names of countries and their subdivisions.
| Country subdivision code.
| 
| Codes for the identification of names of principal administrative divisions,
| or similar areas, of the countries etc. included in BS EN ISO 3166-1.
| 
| Price: GBP62.00 to subscribing members of BSI, GBP124.00 to non-members
| 118 page(s)
| 
| Committee: IDT/2

James

----- ___                       - James Aldridge, Senior Network Engineer,
---- /    /   /  ___  ____ _/_ -- EUnet Communications Services BV
--- /--- /   / /   / /___/ /  --- Singel 540, 1017 AZ Amsterdam, NL
-- /___ /___/ /   / /___  /_ ---- Tel: +31 20 530 5327; Fax: +31 20 625 5913
-                           ----- 24hr emergency number: +31 20 421 0865

---

From: James Aldridge <[email-masked]>
Date: Tue, 06 Jul 1999 16:39:43 +0200

| BS EN ISO 3166-1:1998
| 

and
                                                 
| BS ISO 3166-2:1998
| 

James

---

From: John C Klensin <[email-masked]>
Date: Tue, 06 Jul 1999 11:09:52 -0400

> Right, Simon, I know what DIN is, which is why I made the
> comment about it being unlikely that they would put *anything*
> online.  Their reputation is well known.  I still don't know
> what *committee* it is.  (DIN is not a committee, it is a
> National Body.)

Sorry, thought I had answered that already.  TC46.  IS3166 is
"under the direct responsibility of the TC Secretariat"

http://www.iso.ch/meme/TC46.html

     john

---

From: John C Klensin <[email-masked]>
Date: Tue, 06 Jul 1999 11:09:52 -0400

john

---

From: Mark Needleman <[email-masked]>
Date: Tue, 6 Jul 1999 11:21:44 -0500 (CDT)

James

if you go to 

http://www.din.de/gremien/nas/nabd/iso3166ma/index.html

you can find a pointer to the 3166-1 codes

Mark H Needleman
Product Development Specialist - Standards
Data Research Associates, Inc.
1276 North Warson Road
P.O. Box 8495
St Louis, MO 63132-1806
USA

Phone: 800 325-0888 (US/Canada)
       314 432-1100 x318
Fax: 314 993-8927
 
Email: [email-masked]

---

From: Mark Needleman <[email-masked]>
Date: Tue, 6 Jul 1999 11:21:44 -0500 (CDT)

James

if you go to 

Mark H Needleman

---

From: Lloyd Wood <[email-masked]>
Date: Tue, 6 Jul 1999 17:37:54 +0100 (BST)

On Tue, 6 Jul 1999, James Aldridge wrote:
> for providing in hard-copy.

Yesyesyes. Big deal.

Go to http://www.altavista.com/

enter ISO3166 as your search query.

Reassemble the important information contained in the document from
the results that come back. For example, this returns:

http://209.51.193.25/iso3166.asp

which lists all country code updates to 1997, matching the print
versions you're after. Country codes are a doddle.

The important parts of a useful standard will always become
available in the public domain. Otherwise the standard isn't useful,
or hasn't been widely adopted as a real standard.

L.

and _that's_ my theory on why the ISO OSI model, ATM signalling, and
the Macintosh were doomed from the start.

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>

---

From: Lloyd Wood <[email-masked]>
Date: Tue, 6 Jul 1999 17:37:54 +0100 (BST)

Yesyesyes. Big deal.

L.

---

From: Rama Putcha <[email-masked]>
Date: Tue, 06 Jul 1999 12:44:30 -0400

Can someone guide me as to where I can find the general directions and
rules for obtaining ISO 9002 certification? I believe there are 22
Elements or so deecribed in that document.
Rama Pucha
Product Manager
Fujitsu Nexion Inc.
289 Great Road
Acton,  MA 01720
Ph: (978) 266-3497

---

From: Rama Putcha <[email-masked]>
Date: Tue, 06 Jul 1999 12:44:30 -0400