Subject: RE: Working documents repository

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Thu, 19 Aug 1999 20:44:10 +0100

This is the last, I promise :)

> > You make very good points, but it happens
> > to a lot of the people engaged in fora such as this one
> > not to have time to devote to moving their expired
> > good ideas to a non std track RFC. 
> > It just happens that they may be in a rush to get
> > their product shipped, or in a rush for other
> > reasons. 
> 
> I accept that.  In many cases, reasons like "get the product
> shipped and never get around to coming back and finishing the
> doc" represents a decision that the idea really wasn't
> important.  
> 
However it's my opinion that this decision 
should not limit other individuals in deciding 
that reading what was written in an ID 5 or 10 
years ago is worthwhile.

> As I-D authors, they ought to be able to make that
> decision. 
>  I've let a lot of things I thought were good ideas
> slip into obscurity over the years, and regret some of it.  But
> one makes decisions about these things and lives with them and
> I'm not certain that having others decide that everything I do
> gets archived in a readily-accessible way -- and hence, that I'd
> better prepare every writing to publication/archival quality--
> helps me, the world, or the IETF.
> 
I understand that somebody may bear some 
repentance on what what she/he wrote in 
some ID. But so what? Probably knowing 
that one ID is going to be recorded as 
a "life-time prosecutor" (sounds really 
threatening!) may rate-limit bad ideas 
submissions.In this sense archiving working
documents may help the IETF;).

Anyway, it appears we have some volunteers
providing the repository, so this is becoming
a non issue.

Alessio

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 19 Aug 1999 15:30:23 -0500

Casati, Alessio (Alessio) wrote:
...
> providing the repository, so this is becoming

Hardly. It's a matter of policy that I-Ds expire, because
that is their nature. They are *drafts*, they are
*working documents*, they should not be cited except as
work in progress, so making them permanently available
is completely inappropriate.

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 19 Aug 1999 15:30:23 -0500

Brian

---

From: Leslie Daigle <[email-masked]>
Date: Thu, 19 Aug 1999 18:57:58 -0400

Borrowing from a bumper sticker I once saw, 

	It's time somebody's karma ran over this dogma.

> is completely inappropriate.

Most work (in the world at large) is accomplished through the
judicious use of drafts and versions.  Responsible version control
is an issue, but it isn't often handled by destroying old records
lest they be mistaken for current thinking.  In many organizations,
that's actually frowned upon by those responsible for ensure 
auditability.  (Certainly, it's an approach that has produced
some of our more interesting historical events).

An unending recycling & churn of old ideas and draft documents
is a Bad Thing.

A responsible, managed repository of this organization's work,
accessible enough that unearthing prior art to put down specious
patent claims doesn't rely on the memories, good will, and private
archives of technologists who happened to be involved in an effort,
could be a Good Thing, and well within the scope of work of 
a responsible organization.

Clinging to the "drafts expire & are expunged in 6 months; mailing
lists archives go away" line sounds like (and I hope it isn't, but
_merely_ sounds like) a tactic to avoid the Bad Thing, in the fear
that we cannot implement a compromise that both avoids the Bad Thing
and achieves the Good Thing.

Whether or not a repository is ever sanctioned, I hope we haven't
gotten to the point where we are that fearful about our ability
to evolve successfully.  But there has been an _awful_ lot of "that's
not how we do it around here" lately.

Leslie.

-- 

------------------------------------------------------------------------

"Reality:                                        Leslie Daigle
   yours to deconstruct."                        [email-masked]
            -- ThinkingCat

------------------------------------------------------------------------

---

From: Leslie Daigle <[email-masked]>
Date: Thu, 19 Aug 1999 18:57:58 -0400

Leslie.

-- 

"Reality:                                        Leslie Daigle