Subject: Re: Normative vs. non-normative references

From: Scott Bradner <[email-masked]>
Date: Thu, 26 Aug 1999 20:09:03 -0400 (EDT)

"Larry Masinter" <[email-masked]> suggests:

> In recent attempts to coordinate with ITU over Internet Fax, it was
> suggested that RFCs separate out, in the 'references' section, those
> references that are normative from those that are not.
> 
> This puts a burden on RFC authors and the RFC editor, but since the
> evaluation of the maturity level of documents depends on knowing this,
> anyway, perhaps this could be done for future standards-track documents?

I think this would be a good idea (have two subsections in the references
section of RFCs- one for normative and one for non-normative references)

I think it would help clarify the author's intentions and make the
IESG & RFC Editor's tasks more reliable (if it helps make RFCs more 
acceptable to other standards organizations that's a definite plus,
it is far better if they reference IETF technology than if they decide to
make their own and wind up confusing the marketplace)

Scott

---

From: "Larry Masinter" <[email-masked]>
Date: Thu, 26 Aug 1999 19:15:17 PDT

I'd suggest that we make this part of the instructions for
RFC authors, i.e., put the burden on the document author
of a standards-track document.

- It usually clearer to the authors than the reviewers 
 which references are intended to be normative.
- It makes the standards clearer and easier to understand.
- The reviewers need to decide whether the proposed references
  are normative or not, anyway.
- This will aid in the determination of the requirements of
   RFC 2026 for normative references.
- It would make the clearer the constraints on updating a protocol
  (if there are normative references to it, then changes might
  affect some other standards-track document).
- For those who are not native English speakers, it makes
  it clearer what documents have to be translated.

The cost is relatively small; RFC authors would just move around
the references in the 'References' section of the document; maybe
we could just ask that they just mark the normative references
with "[Normative]" in the references section.

It would be nice if there were then an index that would reflect
this information (and perhaps provide it for the current crop
of RFCs), but that's a separate topic.

Larry
-- 
http://www.parc.xerox.com/masinter

---

From: "Larry Masinter" <[email-masked]>
Date: Thu, 26 Aug 1999 19:15:17 PDT

Larry

---

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Thu, 26 Aug 1999 23:59:14 -0400

All of this procedureal discussion, especially when it gets to his
detailed a recommendation, should be on the POISSON WG mailing list.

Donald

From:  "Larry Masinter" <[email-masked]>
To:  "Scott Bradner" <[email-masked]>
Cc:  <[email-masked]>
Date:  Thu, 26 Aug 1999 19:15:17 PDT
Message-ID:  <[email-masked]>
Content-Type:  text/plain;
	      	charset="iso-8859-1"
Content-Transfer-Encoding:  7bit
X-MSMail-Priority:  Normal
Importance:  Normal
X-MimeOLE:  Produced By Microsoft MimeOLE V4.72.3110.3
In-Reply-To:  <[email-masked]>
Content-Transfer-Encoding:  7bit
Content-Transfer-Encoding:  7bit

---

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Thu, 26 Aug 1999 23:59:14 -0400

Donald

---

From: Dave Crocker <[email-masked]>
Date: Thu, 26 Aug 1999 21:32:30 -0700

>of a standards-track document.

There is benefit in the loose style to IETF documents, but it does 
periodically result in people not be clear about text (and references) that 
are specification, versus text (and references) that are discussion.

In addition to making the distinction for references, should we not also 
make it for content?

d/

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Dave Crocker                                         Tel: +1 408 246 8253
Brandenburg Consulting                               Fax: +1 408 273 6464
675 Spruce Drive                             <http://www.brandenburg.com>
Sunnyvale, CA 94086 USA                 <mailto:[email-masked]>

---

From: Dave Crocker <[email-masked]>
Date: Thu, 26 Aug 1999 21:32:30 -0700

d/

---

From: "Larry Masinter" <[email-masked]>
Date: Fri, 27 Aug 1999 13:44:51 PDT

> In addition to making the distinction for references, should we not also 

BCP 14 (RFC 2119), "Key words for use in RFCs to Indicate Requirement Levels."
This thread is just about extending the practice to the references.

---

From: "Larry Masinter" <[email-masked]>
Date: Fri, 27 Aug 1999 13:44:51 PDT