Subject: Re: Working documents repository

From: "R. Lizardo" <[email-masked]>
Date: Mon, 16 Aug 1999 17:53:51 +0800

How about online library to keep these expired drafts. At least they are the
perfect place to keep archives. And a link from ietf to these archives.

Ranil Lizardo
ISSD- Applications Development, Telephony
Piltel
========================
     "Who hacks the hacker?"
========================
Get your free e-mail: http://ranil.zzn.com

-----Original Message-----
From: Casati, Alessio (Alessio) <[email-masked]>
To: [email-masked]' <[email-masked]>
Date: Monday, August 16, 1999 5:30 PM
Subject: Working documents repository

>It happens quite often that working documents
>like the one  this folk is looking for get
>forgotten simply because the standard process
>works this way.
>
>Still, there may be some interest (at least
>for historians:) to preserve documents that
>otherwise would disappear.
>
>Sometimes good ideas disappear with them.
>
>Is it possible the IETF will keep a repository
>of expired working documents? or is it a non
>affordable cost?
>
>
>I just note that in order to prevent the loss
>of the "Two bits differentiated services architecture"
>the authors submitted it as a non std track RFC.
>
>Alessio
>
>PS  there was an article about working documents
>getting lost on an issue of IEEE Networks,
>and I share the concerns of its author.
>
>> ----------
>> From: G. Ensuque[SMTP:[email-masked]]
>> Reply To: [email-masked]
>> Sent: 16 August 1999 09:46
>> To: [email-masked]
>> Subject: [MOBILE-IP] Wanted: old hierarchical FA draft
>>
>> Hi all again
>>
>> I would be extremely grateful if someone could send me the now expired
>> draft
>> by Charlie Perkins on Hierarchical Foreign Agents
>> (draft-ietf-mobileip-hierfa-00) as I cannot
>>
>> Thanks in advance
>>
>> Guilhem Ensuque
>>
>> Mobility Futures Unit                           [email-masked]
>> B55-131B
>> BT Advanced Communications Technology Centre
>> Adastral Park, Martlesham Heath
>> IPSWICH IP5 3RE                              Tel: +44 1473 645 232
>> UK                                                   Fax: +44 1473 646
885

---

From: Randy Bush <[email-masked]>
Date: Mon, 16 Aug 1999 04:14:15 -0700 (PDT)

> How about online library to keep these expired drafts.

it is not an accident that drafts expire.

randy

---

From: Randy Bush <[email-masked]>
Date: Mon, 16 Aug 1999 04:14:15 -0700 (PDT)

randy

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 16 Aug 1999 09:34:12 -0500

> it is not an accident that drafts expire.

Far from it, in fact. Please read the words at the front of
every I-D; they expire because they are working documents.
If they have lasting value, they get updated or turned into
RFCs.

As far as proof-of-publication for intellectual property disputes
is concerned, the IETF Secretariat can always provide that.

  Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 16 Aug 1999 09:34:12 -0500

Brian

---

From: Peter Deutsch <[email-masked]>
Date: Mon, 16 Aug 1999 15:46:08 -0400

g'day all,

Brian E Carpenter wrote:
.  .  . 
> is concerned, the IETF Secretariat can always provide that.

You might think so, but they don't. And in fact, I doubt they could, on
their own.

As someone who has consulted a couple of times on intellectual
property/patent disputes, I can state that in the cases I was involved
in you're not just looking for "the one paper" containing the exact same
claim as that made in a particular patent application. In fact, what
you're generally trying to do is "go back in time" to understand what
the generally accepted state of the world was at the time in question.
Even a repository of expired drafts isn't what you want here, since
you're probably faced with more than one claim and need to put together
a whole picture to understand things properly.

In the cases I've been involved in what we really wanted to know was
whether certain information was "generally known, or would be obvious to
someone experienced in the field" (my words, not the words of a lawyer).
For that, I've found the most useful tool was the appropriate working
group mailing lists. Drafts tend to appear on the list (duh...) but the
whole context for the draft is there, as well. From the postings you can
also find additional expert witnesses, pointers to other sources of
info, etc.

And having said this, I would also point out that the Intellectual
Property dispute issue is actually only one of a class of such uses for
"historical" material. Without trying to enumerate them all, I can
confidently predict that we can't confidently predict what new uses
people might find for such material in the future.

Now, you might think that the IETF has no role to play in "preserving
institutional/corporate memory" in this way, but I for one think that
this is an area where we've been quite remiss in the past. And some of
the steps we could take are pretty simple. As an obvious first
suggestion, why doesn't the IETF simply provide an archive of the
mailing list for each official working group? It can't be a cost issue
(there's a server on the net, we're talking a few hundred dollars in
diskspace, and the IETF already operates the needed software). No,
failing to provide a record is a statement in itself. It's probably not
a bad time to ask what this statement says about us.

The question then becomes "does it do more harm to preserve this
material than to let it go away?" Personally, I'd hum for
preservation...

				- peterd

---

From: Peter Deutsch <[email-masked]>
Date: Mon, 16 Aug 1999 15:46:08 -0400

g'day all,

Brian E Carpenter wrote:
.  .  . 

				- peterd