Subject: RE: extension agent problem need help!!

From: Meena Palvannan <[email-masked]>
Date: Fri, 29 Oct 1999 09:04:20 -0400

Hi,
Thanks for your response.
>>Since an empty row doesn't signal the end, something else does.

Can you tell me how to signal the end, as we are unable to retrieve the data
even using getbulk
It stops at the empty row.
Thanks
Meena
Apart from missing items after an empty row, retrieving data this way is
very
inefficient. Find out what data is there, and ask for it in chunks, naming
each
variable instance explicitly, multiple items per query to improve
efficiency.
At a certain point, you'll exceed the packet length or burden the managed
device, but an optimum number of variables to retrieve at once should be in
excess of 10, thereby reducing traffic load by that factor.

----- Original Message -----
From: Meena Palvannan <[email-masked]>
To: <[email-masked]>
Sent: Thursday, October 28, 1999 1:52 PM
Subject: extension agent problem need help!!

> Hi,
> We have a table which has some sparse entry on some columns
>
> for example
>
> index     Column1
>
>   1        data1
>
>   2          *
>
>   3         data3
>
>   4         data4
>
>
> When we try to walk or get next
>
> it sees the empty column and assumes that is the end of the mib
> and comes out with end of mib message
> Can you tell me how do we change the agent, so that it skips that empty
rows
> and goes down to get me row 3 and etc
>
> Thanks
> Meena
>
>
>
>
>
> -
> This message was passed through [email-masked], which
> is a sublist of . Not all messages are passed.
> Decisions on what to pass are made solely by Harald Alvestrand.
>

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 29 Oct 1999 16:02:05 +0200

>It stops at the empty row.

If it's an SNMPv3 implementation, that's a bug.
The end is signalled by being returned a variable that's lexically later 
than the range you wanted; the SNMP agent never knows where you intended to 
stop.

>excess of 10, thereby reducing traffic load by that factor.

Get-next should be able to get through.

Perhaps you should contact the SNMPv3 group to discuss the problem.
[email-masked] - it is considered polite to join the group before 
asking questions, instructions can be found on the WG page.

              Harald A

--
Harald Tveit Alvestrand, Maxware, Norway
[email-masked]

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 29 Oct 1999 16:02:05 +0200

Harald A