Subject: BayStack 650 driver for FreeBSD3.3+PAO

From: Atsushi Onoe <[email-masked]>
Date: Tue, 9 Nov 1999 21:50:55 +0900 (JST)

I've just ported Bill Sommerfeld's NetBSD driver ('awi') for BayStack 650
to FreeBSD 3.3+PAO.
Though it is just very alpha port not to be released (in particular
name and directory of source files must be changed), it might be
helpful for FreeBSD notebook users.

ftp://onoe2.sm.sony.co.jp/pub/awi-991109a.tar.gz

you have to add .c files to "files.i386" and put "device awi0"
line into your config file.
and, add contents of "pccard.conf.add" file to /etc/pccard.conf

Restrictions
	file name must be changed to solve conflict with ux driver.
	only works with PAO
	much more should comes here...

Atsushi Onoe

---

From: Dirk-Willem van Gulik <[email-masked]>
Date: Tue, 9 Nov 1999 08:29:04 -0500 (EST)

My compliments; it works out of the box; on FreeBSD 3.2 and 3.3
with PAO.

Dw (from the Embassador room ;-)

---

From: Dirk-Willem van Gulik <[email-masked]>
Date: Tue, 9 Nov 1999 08:29:04 -0500 (EST)

---

From: Atsushi Onoe <[email-masked]>
Date: Tue, 9 Nov 1999 10:43:12 -0500 (EST)

For those who are not reading [email-masked],

> I've just ported Bill Sommerfeld's NetBSD driver ('awi') for BayStack 650

Please note that this version of driver does not handle roaming correctly.
Since there are so high density APs in the IETF hotel,
you will experience loss of connectivety sooner or later with
"no recent beaconf from xxxx; rescanning" message.

Power off the PC-card and power on again through "pccardc power" command,
or re-insertion of the card might help you :-)

Atsushi

---

From: Atsushi Onoe <[email-masked]>
Date: Tue, 9 Nov 1999 10:43:12 -0500 (EST)

Atsushi

---

From: Robert Watson <[email-masked]>
Date: Tue, 9 Nov 1999 12:56:26 -0500 (EST)

Would love to hear if someone gets it to work out of the box on -RELEASE
instead of PAO :-).  My port is still in its infancy, I'm afraid.

On Tue, 9 Nov 1999, Dirk-Willem van Gulik wrote:

> To Unsubscribe: send mail to [email-masked]
> with "unsubscribe freebsd-mobile" in the body of the message
> 

  Robert N M Watson 

[email-masked]              http://www.watson.org/~robert/
PGP key fingerprint: AF B5 5F FF A6 4A 79 37  ED 5F 55 E9 58 04 6A B1
TIS Labs at Network Associates, Safeport Network Services

---

From: Robert Watson <[email-masked]>
Date: Tue, 9 Nov 1999 12:56:26 -0500 (EST)

Robert N M Watson

---

From: Randy Bush <[email-masked]>
Date: Tue, 09 Nov 1999 15:04:39 -0500

> or re-insertion of the card might help you :-)

is there a simple method/recipe which does not drive dhcpd and routing nuts?

randy

---

From: Randy Bush <[email-masked]>
Date: Tue, 09 Nov 1999 15:04:39 -0500

randy

---

From: Atsushi Onoe <[email-masked]>
Date: Tue, 9 Nov 1999 15:35:11 -0500 (EST)

Sorry for bothering you again,

> is there a simple method/recipe which does not drive dhcpd and routing nuts?

comment out "insert pccard_ether $device" line from your pccard.conf
and run manually dhcp once.

and there is a newer version of the driver updated by Bill
which is much more stable.
ftp://onoe2.sm.sony.co.jp/pub/awi-991109b.tar.gz

Atsushi

---

From: Atsushi Onoe <[email-masked]>
Date: Tue, 9 Nov 1999 15:35:11 -0500 (EST)

Atsushi

---

From: Atsushi Onoe <[email-masked]>
Date: Tue, 9 Nov 1999 15:35:11 -0500 (EST)

Atsushi

---

From: Atsushi Onoe <[email-masked]>
Date: Tue, 9 Nov 1999 15:35:11 -0500 (EST)

Atsushi

---

From: Atsushi Onoe <[email-masked]>
Date: Tue, 9 Nov 1999 15:35:11 -0500 (EST)

Atsushi

---

From: Atsushi Onoe <[email-masked]>
Date: Tue, 9 Nov 1999 15:35:11 -0500 (EST)

Atsushi