Subject: RE: IP network address assignments/allocations information?

From: "Fleischman, Eric W" <[email-masked]>
Date: Mon, 29 Nov 1999 08:47:16 -0800

A few questions for the list:
1) If we effectively ran out of addresses when RFC 1597 was published, has running out of addresses hurt us in any way? 
2) Originally we had anticipated using IPv6 to save us from IPv4 address depletion. What's the status of IPv6? How does IPv6 traffic compare in volume with IPv4 traffic? Do non-IPv6-supporting vendors (e.g., Microsoft) have plans to eventually support IPv6?
3) Given the current situation of corporations using private addresses internally and a smaller set of global IPv4 addresses on their periphery, and a global IPv4 internet, one should theoretically be able to say how many public IPv4 addresses have been assigned and therefore how many remain unassigned and by so doing estimate how long until consumption. Why is this not possible in practice?

> ----------
> From: 	Brian E Carpenter[SMTP:[email-masked]]
> Sent: 	Friday, November 26, 1999 1:35 PM
> To: 	Randy Bush
> Cc: 	Bill Manning; Pete Loshin; [email-masked]
> Subject: 	Re: IP network address assignments/allocations information?
> 
> Well, let's not focus on Bill's data. Frankly, I haven't seen any data
> on this topic from any source that really convinces me that it
> means much. All I know is that we have thousands of sites using
> private address space, which completely falsifies any real data and
> makes it impossible to attach any real meaning to concepts such as
> "running out of addresses". My personal opinion is that we ran out
> of addresses in practical terms around about when RFC 1597 was published.
> 
>   Brian
> 
> Randy Bush wrote:
> > 
> > > www.isi.edu/~bmanning/in-addr-audit.html
> > >       It does not cover specific /16 & /24 delegations, it just looks at
> > > all of the SOA entries. Still, it does give a representation of how much
> > > space is delegated.
> > 
> > uh, as these data appear to be the statistics of an attempt to walk the
> > dns in-addr.arpa tree what confidence is there that this fairly represents
> > address space assignment/allocation?
> > 
> > e.g. there are 153 /16 announcements in 133.0.0.0 and the table at
> > http://www.isi.edu/~bmanning/in-addr-data.html shows one in-addr.arpa
> > allocation entries.
> > 
> > e.g. there are 166 announcements (of 175 /16 equivalents of space) in
> > 147.0.0.0 and the table at http://www.isi.edu/~bmanning/in-addr-data.html
> > shows 193 in-addr.arpa entries.
> > 
> > so how can the data at www.isi.edu/~bmanning/in-addr-audit.html be
> > interpreted to give a useful representation of how much space is
> > assignmed/allocated?
> > 
> > randy
>

---

From: [email-masked]
Date: Mon, 29 Nov 1999 12:12:27 -0500

On Mon, 29 Nov 1999 08:47:16 PST, "Fleischman, Eric W" said:

> 3) Given the current situation of corporations using private
> addresses internally and a smaller set of global IPv4 addresses on
> their periphery, and a global IPv4 internet, one should theoretically
> be able to say how many public IPv4 addresses have been assigned and
> therefore how many remain unassigned and by so doing estimate how long
> until consumption. Why is this not possible in practice?

Well, because it's a moving target.

If it takes 3 weeks to get the data together, and your growth
rate is high enough that there's a measurable change over 3 weeks,
you then have to apply a correction factor to your estimate.
Given that you don't know the growth rate exactly, this gets
more than a tad interesting....

I seem to remember the ZEALOT(?) project, which at one time posted
an estimate of the DNS size every 3 months, and one of the last
postings mentioned that it was taking well over a week to do
the survey.  And that was a while ago.

Added in to that is the difficulty in computing how many IPv4
addresses are actually assigned - you can get a *vast* over-estimate
by counting up the CIDR blocks visible to the core routers.
However, in the case of Virginia Tech, you'll see the 128.173/16
and 198.82/16 netblocks advertised - but we're nowhere near 128K
addresses actually allocated (I think the actual number is closer
to 20K or so).  

Most of the router gurus I've talked to don't think the actual
number of addresses is an issue - the issue is allocating them
such that a "small enough" number of CIDR aggregations covers them
(as 30K poorly allocated IPv4 addresses and 300M well-allocated will
both take 30K routing table entries...)

				Valdis Kletnieks
				Operating Systems Analyst
				Virginia Tech

---

From: [email-masked]
Date: Mon, 29 Nov 1999 12:12:27 -0500

Valdis Kletnieks

---

From: Keith Moore <[email-masked]>
Date: Mon, 29 Nov 1999 13:08:15 -0500

> 1) If we effectively ran out of addresses when RFC 1597 was published, 
> has running out of addresses hurt us in any way? 

absolutely.  partially as a result of (perceived or actual) address scarcity,
people have deployed NATs everywhere, and this has had an large adverse
effect on the Internet's ability to support certain types of applications - 
particularly distributed applications (multi-party conferencing, games,
simulations, distributed computations) and applications where the "user"
end needs to be able to accept incoming traffic which is initiated
from "outside".  NATs also impair the reliability of the network because 
they can discard address mappings for connections that are still being 
used by applications.

Keith

---

From: Keith Moore <[email-masked]>
Date: Mon, 29 Nov 1999 13:08:15 -0500

Keith

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 29 Nov 1999 13:54:10 -0600

Eric,

> 1) If we effectively ran out of addresses when RFC 1597 was published, has running out of addresses hurt us in any way?

I believe so, as discussed in 
 draft-carpenter-transparency-04.txt
 draft-ietf-iab-ntwlyrws-over-01.txt
 draft-iab-nat-implications-04.txt
 draft-ietf-nat-protocol-complications-01.txt
among others.

> 2) Originally we had anticipated using IPv6 to save us from IPv4 address depletion. What's the status of IPv6? 

Pretty good, in terms of standards and preliminary code. Only just starting,
in terms of deployment.

> How does IPv6 traffic compare in volume with IPv4 traffic? 

Negligible so far.

> Do non-IPv6-supporting vendors (e.g., Microsoft) have plans to eventually support IPv6?

Ask them.

> 3) Given the current situation of corporations using private addresses internally and a smaller set of global IPv4 addresses on their periphery, and a global IPv4 internet, one should theoretically…

It's entirely possible, but the answer depends on which curve you choose to fit
to the data. That's why the answers given at the July IAB workshop ranged from
2 to 20 years. But whatever the answer is, it obscures the real problems
described in the above documents.

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 29 Nov 1999 13:54:10 -0600

Eric,

Negligible so far.

Ask them.

   Brian

---

From: Pete Loshin <[email-masked]>
Date: Mon, 29 Nov 1999 17:08:00 -0500

As the original instigator of this thread, I want to thank everyone for
their assistance, as well as for the thought-provoking discussions that
have ensued. They have all been very helpful.

As a sort of follow-on question, I've been scrutinizing the delegations
listed here:

http://www.isi.edu/in-notes/iana/assignments/ipv4-address-space

One of the things I'm interested in is the geographic distribution of
allocated IPv4 space. I realize that parts of the former Class B/Class
space was assigned to non-US networks prior to RIPE-NCC and APNIC being
established to assign addresses; however, since then, peices of IPv4
address space have been delegated to the RIRs. Some of those chunks are
explicitly identified, e.g.:

061/8           APNIC - Pacific Rim

However, there are two entries on the table:

128-191/8       Various Registries
192/8           Various Registries - MultiRegional

that are more puzzling. How can I figure out which registries have gotten a
piece of these particular chunks? Is there an online resource tucked away
somewhere that lists all this? I'm not interested so much in how much of
these allocations have been used as in which registries now control them.

Any pointers are again much appreciated.

Thanks!
-pl

+-------------------------------------------------------------+
| Pete Loshin                    http://Internet-Standard.com |
|                                                             |
| _IPv6 Clearly Explained_ Morgan Kaufmann January 1999       |
| _TCP/IP Clearly Explained_ 3rd ed Morgan Kaufmann June 1999 |
|                                                             |
+-------------------------------------------------------------+

---

From: Pete Loshin <[email-masked]>
Date: Mon, 29 Nov 1999 17:08:00 -0500

Thanks!
-pl

---

From: <[email-masked]>
Date: Mon, 29 Nov 1999 14:44:18 -0800 (PST)

> 128-191/8       Various Registries

128/3 is the traditional "Class B" space.  Allocations were done on a
request basis before their were regional registries.  About the time RR's
came about there was an emphasis to move from assigning 128/3 space to
assigning blocks of /24's from 192/4.  this was accomplished by giving RR
charge of /8s from the 192-223 range.  Read RFC 1466 for some details.

> 192/8           Various Registries - MultiRegional

In a similar manner, old "Class C's" were assigned from 192/8 as requested
with no thought to regional boundaries.  Remember that these were done
long before the days of routing aggregation and CIDR.

--->  Phil

---

From: <[email-masked]>
Date: Mon, 29 Nov 1999 14:44:18 -0800 (PST)

--->  Phil