Subject: Re: Last Call: Telnet Authentication Option to Proposed Standard

From: Jeffrey Altman <[email-masked]>
Date: Tue, 23 Nov 99 9:06:40 EST

> The IESG <[email-masked]> writes:
> 
> > o Telnet Encryption: DES3 64 bit Cipher Feedback 
> > 	<draft-altman-telnet-enc-des3-cfb-01.txt> 
> > o Telnet Encryption: DES3 64 bit Output Feedback 
> > 	<draft-altman-telnet-enc-des3-ofb-01.txt> 
> 
> Do these make sense at all? Do they provide any better security than
> single des?
> 
> I haven't seen any discussion.
> 
> /Johan
> 

I'm not sure that I understand the motivation behind the question.
You are questioning the use of Triple DES but not the use of
CAST-128.  Both are stronger ciphers than single DES but only if you
have enough available key info.

When using the current Kerberos implementations there is only enough
key info a single DES key which is used in both directions.  Other
authentication methods provide enough key info for the 3DES to use
6 different DES keys with a Triple DES implementation (3 in each
direction). 

    Jeffrey Altman * Sr.Software Designer * Kermit-95 for Win32 and OS/2
                 The Kermit Project * Columbia University
              612 West 115th St #716 * New York, NY * 10025
  http://www.kermit-project.org/k95.html * [email-masked]

---

From: Jeffrey Altman <[email-masked]>
Date: Tue, 23 Nov 99 10:23:13 EST

> Jeffrey Altman <[email-masked]> writes:
> 
> > CAST-128.
> I'm questioning the use of DES3 in anything but EDE on outer CBC
> mode. There is a paper by Eli Biham about other combinations, which
> basically says that most of them are not much better than single DES.
> 
> Even though this paper doesn't talk about this specific use, it's not
> obvious that it's more secure to use DES3 to generate random numbers
> than it is to use single DES.
> 
> Has this case been analysed by anyone?
> 
> /Johan
> 

Thanks for explaining.  The answer is that I don't know.  I am not 
qualified to make that analysis.

---

From: Jeffrey Altman <[email-masked]>
Date: Tue, 23 Nov 99 10:23:13 EST

---

From: "Othon Kamariotis" <[email-masked]>
Date: Tue, 23 Nov 1999 16:52:55 -0000

It is safer to use 3-DES than single Des because we use a 128-bit key
instead of a 64-bit key, so the number of possible keys is much bigger. Also
it has been reported that a method called 'match in the middle' could
penetrate the single -DES but not the 3-DES.

-----Original Message-----
From: Jeffrey Altman <[email-masked]>
To: Johan Danielsson <[email-masked]>
Cc: [email-masked] <[email-masked]>;
[email-masked] <[email-masked]>
Date: Tuesday, November 23, 1999 4:24 PM
Subject: Re: Last Call: Telnet Authentication Option to Proposed Standard

---

From: "Othon Kamariotis" <[email-masked]>
Date: Tue, 23 Nov 1999 16:52:55 -0000