Subject: whois?

From: Ray Yang <[email-masked]>
Date: Mon, 13 Dec 1999 12:40:15 -0500

Hi:
	I'm just wondering -- my whois command doesn't turn up contact information
for domains anymore. What's going on? I get a registrar's name instead ....

Ray

---

From: "Michael Park" <[email-masked]>
Date: Mon, 13 Dec 1999 13:00:24 -0500

that is because, there are now several competitive and
accredited tld registrars. see www.internic.net for more info.

so.. just do:

whois -h whois.networksolutions.com domain.name

whois.networksolutions.com can obviously be substituted with
another registrar's whois server.

m

---

From: "Michael Park" <[email-masked]>
Date: Mon, 13 Dec 1999 13:00:24 -0500

so.. just do:

m

---

From: "Michael H. Warfield" <[email-masked]>
Date: Mon, 13 Dec 1999 13:38:17 -0500

> for domains anymore. What's going on? I get a registrar's name instead ....

	First off...  Whois merely dumps the data returned from the whois
server that you've contacted, so the change is at the server end.

	Looks like this is part of the reorg for expanded and diversified
TLD's (WAG on my part).

	If I do a whois wittsend.com (my domain) I get the following:

] [root@alcove mhw]# whois wittsend.com
] [rs.internic.net]
] Whois Server Version 1.1
] Domain names in the .com, .net, and .org domains can now be registered
] with many different competing registrars. Go to http://www.internic.net
] for detailed information.
]    Domain Name: WITTSEND.COM
]    Registrar: NETWORK SOLUTIONS, INC.
]    Whois Server: whois.networksolutions.com
]    Referral URL: www.networksolutions.com
]    Name Server: EHECATL.ISS.NET
]    Name Server: NS.COMMANDCORP.COM
] >>> Last update of whois database: Mon, 13 Dec 99 00:41:08 EST <<<
] The Registry database contains ONLY .COM, .NET, .ORG, .EDU domains and
] Registrars.
] [root@alcove mhw]# 

	OK...

	That tells me that the "whois server" for the specified registrar
is "whois.networksolutions.com".  So I follow up with that...

] [root@alcove ]# whois [email-masked]
] [whois.networksolutions.com]
] The Data in Network Solutions' WHOIS database is provided by Network
] Solutions for information purposes, and to assist persons in obtaining
] information about or related to a domain name registration record.
] Network Solutions does not guarantee its accuracy.  By submitting a
] WHOIS query, you agree that you will use this Data only for lawful
] purposes and that, under no circumstances will you use this Data to:
] (1) allow, enable, or otherwise support the transmission of mass
] unsolicited, commercial advertising or solicitations via e-mail
] (spam); or  (2) enable high volume, automated, electronic processes
] that apply to Network Solutions (or its systems).  Network Solutions
] reserves the right to modify these terms at any time.  By submitting
] this query, you agree to abide by this policy.
] 
] Registrant:
] Thaumaturgy & Speculums Technology (WITTSEND-DOM)
]    1220 Kelvington Way
]    Lilburn, Georgia 30247-2059
]    US
] 
]    Domain Name: WITTSEND.COM
] 
]    Administrative Contact, Technical Contact, Zone Contact:
]       Warfield, Michael H  (MHW9)  [email-masked]
]       770 985-6132 770 985 6132 (FAX) 770 395-1972
]    Billing Contact:
]       Warfield, Michael H  (MHW9)  [email-masked]
]       770 985-6132 770 985 6132 (FAX) 770 395-1972
] 
]    Record last updated on 20-Feb-1997.
]    Record created on 01-Feb-1995.
]    Database last updated on 11-Dec-1999 05:43:31 EST.
] 
]    Domain servers in listed order:
] 
]    NS.COMMANDCORP.COM           130.205.70.10
]    EHECATL.ISS.NET              208.21.0.7

	Which is what use to be returned from a simple whois (which merely
defaults to rs.internic.net).

	You just have an extra level of indirection to go through.  Just
like when they moved all the IP address allocations over to ARIN, you
then had to do a whois @arin.ne to get at the information that us to be
at rs.internic.net.

> Ray

	Mike
-- 
 Michael H. Warfield    |  (770) 985-6132   |  [email-masked]
  (The Mad Wizard)      |  (770) 331-2437   |  http://www.wittsend.com/mhw/
  NIC whois:  MHW9      |  An optimist believes we live in the best of all
 PGP Key: 0xDF1DD471    |  possible worlds.  A pessimist is sure of it!

---

From: "Michael H. Warfield" <[email-masked]>
Date: Mon, 13 Dec 1999 13:38:17 -0500

OK...

	Mike

---

From: John Stracke <[email-masked]>
Date: Tue, 21 Dec 1999 13:18:49 -0500

> for domains anymore. What's going on? I get a registrar's name instead ....

I got tired of following the redirects, so I hacked up a wrapper script (/bin/sh) to
do it for me.  If anybody's interested, it's at <http://www.thibault.org/whois2>.
GPL.  By default, it expects fwhois, but it can handle whois; just comment out the
FWHOIS= line and uncomment the WHOIS= line.

--
/==============================================================\
|John Stracke    | http://www.ecal.com |My opinions are my own.|
|Chief Scientist |=============================================|
|eCal Corp.      |Solipsists have all the fun.                 |
[email-masked]|                                             |
\==============================================================/

---

From: John Stracke <[email-masked]>
Date: Tue, 21 Dec 1999 13:18:49 -0500