Subject: Crypto Advocate Under FBI Investigation (For Treason)

From: "Dr. Jai Maharaj" <[email-masked]>
Date: Tue, 30 Nov 1999 19:12:44 -1000

Crypto Advocate Under FBI Investigation

Windows NT Magazine

Tuesday, November 30, 1999 - We recently published a
story regarding cryptography and IPv6, where somseone at
the Department of Justice accused Scott Bradner,

http://www.ntsecurity.net/go/2c.asp?f=/news.asp?IDF=167&TB=news

Internet Engineering Task Force (IETF) area coordinator,
of an anti-social act by trying to get encryption
inserted into the new protocol. Later, at an IETF meeting
where votes were taken for IPv6 encryption inclusion,
Fore System's Brian Rosen brazenly claimed that
regardless of any encryption inclusion, Fore systems
would proceed by including back doors

http://www.ntsecurity.net/go/2c.asp?f=/news.asp?IDF=177&TB=news

into any included encryption technology. But the
harrassment of the IETF doesn't stop there.

Just how far will our federal government go towards
controlling strong encryption? Apparently, very far. And
this isn't a new effort by any means. We learned that
William Allen Simpson, a Detroit-based computer
consultant who was on the IETF staff, has been
investigated by the federal government for treason
charges. Simpson was the person that argued loudly for
encryption to be included in the PPP protocol when it was
still in design phases. That push landed Simpson in hot
whatever with federal officials. Simpson learned through
friends that he was under investigation for treason --
the FBI had been interviewing his friends and associates.

Simpson obtained 54 pages of documents from the
government under the Freedom of Information act, however
the documents were heavily censored, including the
bureau's basis for the investigation. According to a ZDTV
report,

http://www.zdnet.com/zdtv/cybercrime/chaostheory/story/0,3700,2398590,00.html

Simpson did learn that the FBI had accused him of
"challenging authority and laws that may impinge upon his
activities."

Wait a second! Isn't that part of what the Constitution
is all about--the means to peacefully object to the laws
of the land? I think so. And if that's true, then that
certainly positions the FBI in a bad light since it would
appear their actions are counter to the Consitutional
rights. It not against the law to develop strong
cryptography, but it is against the law to export that
technology outside of proper governmental controls. The
PPP protocol did not have encryption at the time--it was
only a suggested inclusion--so why investigate a person
for doing something completely legal?

The IETF is an open public standards body that conducts
its business in clear public view. They help stear
standards that better ensure compatibility and
interoperability. So why would the FBI investigate an
IETF member just because that person suggested in a
public meeting that strong encryption be included in a
standard wide-spread protocol such as PPP?

Source - http://www.ntsecurity.net/go/2c.asp?f=/news.asp?IDF=186&TB=news

Not for commercial use. Solely to be fairly used for
the educational purposes of research and open discussion.

Jai Maharaj
[email-masked]
Om Shanti

---

From: "Robert G. Ferrell" <[email-masked]>
Date: Thu, 2 Dec 1999 09:29:59 -0600 (CST)

>The other thing to keep in mind was this was back in 1991, when it
>wasn't quite so obvious to all concerned that the attempts by the NSA
>and FBI to restict encryption was as misguided and as futile as it is
>now.  So what is obviously stupid and ridiculous behaviour on the FBI's
>part in 1999 might not have been so ridiculous eight years ago.  As I
>recall, back then the FBI was still trying to figure out how to spell
>"Internet", let alone figure out what it meant.

Folks,

I realize that FBI-bashing is _de rigeur_ these days, and I'll admit that I find 
that a certain (small) percentage of what I've seen in print is justified, but 
I'd also like to state for the record that I'm quite familiar with the average  
rank-and-file FBI Special Agent, and know the overwhelming majority of them to 
be decent, honest, hard-working folks who have an amazing variety of crap dumped 
on them every day from a lot of different directions.  It's true that only now 
are they starting to get a decent comprehension of the vast jungle that is the 
Internet, but if you'll look at what Congress allocates them to use to pay 
salaries, you'll understand one of the reasons that FBI Agent is not high on 
most CS majors' list of prospective careers (being shot at on a regular basis 
and called every name in the book by people who think all federal law 
enforcement is evil are high on the list, as well).  In the field offices, a lot 
of the day-to-day cybercrime stuff is handled by accountants and other 
white-collar crime investigators who came to work one day and found themselves 
assigned as computer crime cops.  If they're lucky, they might be able to talk 
HQ into giving them some training.  Eventually.  Of course, they still have to 
take turns on SWAT and other special duties, as well (and you don't get "combat 
pay" in the FBI).  My response to this situation has been to volunteer to help 
educate them whenever possible, and answer questions they have if I can.  You'd 
be surprised how much difference you can make, if you try.

While I think that continuing constructive critical dialogue is essential to the 
health of the nation and its government, I also think that acknowledging the 
fact that most FBI agents do the very best they can with what they have is 
important, as well.  It's satisfying and entertaining to criticize cops and call 
them stupid, but my guess is that we'd be a lot worse off without them...

Just my opinion, of course.

RGF

Robert G. Ferrell
Internet Technologist
National Business Center, US DoI
[email-masked]