Subject: Re: IP network address assignments/allocations information?

From: Sean Doran <[email-masked]>
Date: Wed, 8 Dec 1999 06:57:25 +0100 (CET)

| 1. if IPv6 allocation policies aren't a fair amount more liberal
|    than IPv4 ones in how much address space is doled out, they're
|    broken.  there's still a need to aggregate addresses for routing
|    purposes, but there's no need to be stingy about doling them out.

We are agreed that there is absolutely a need to aggregate
addresses for routing purposes, whether we are talking IPv4
or IPv6.

So, how many /20s are there in IPv6?

	Sean.

---

From: Bill Manning <[email-masked]>
Date: Tue, 7 Dec 1999 22:40:48 -0800 (PST)

% So, how many /20s are there in IPv6?
% 
% 	Sean.

The same as IPv4.  Oh, you mean the number of prefixs that
carry the same number of end-node addresses as an IPv4 /20?
That would equate to the number of /116's in IPv6 parlance.

--bill

---

From: Bill Manning <[email-masked]>
Date: Tue, 7 Dec 1999 22:40:48 -0800 (PST)

--bill

---

From: Robert Elz <[email-masked]>
Date: Wed, 08 Dec 1999 20:23:56 +1100

Date:        Wed, 8 Dec 1999 06:57:25 +0100 (CET)
    From:        Sean Doran <[email-masked]>
    Message-ID:  <[email-masked]>

  | So, how many /20s are there in IPv6?

As Bill Manning said, potentially exactly the same number as there
are potentially in IPv4.

But there are a hell of a lot more /40's in IPv6 than in IPv4.   And
I know that a /40 will be way too big for my University, a /48 will be
just fine... (on the other hand, we could never survive with an IPv4 /20).

kre

---

From: Robert Elz <[email-masked]>
Date: Wed, 08 Dec 1999 20:23:56 +1100

kre

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 08 Dec 1999 11:52:44 -0600

The point is that even conservative policies could easily allow a /64
per household.

  Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 08 Dec 1999 11:52:44 -0600

Brian

---

From: Sean Doran <[email-masked]>
Date: 09 Dec 1999 15:47:09 +0100

> That would equate to the number of /116's in IPv6 parlance.

So how many /20s or how many /116s will fit into a routing table?

Alternatively -- if we take Harald Alvestrand's numbers,
and assume everyone who wants one gets an IPv6 /48,
leaving 16 bits for subnetting before the "flat space" --
can we try to quantify the consumption of critical
resources in routers with this as an explicit goal?

(I think it's fair to make assumptions that we will
continue with BGP and the iBGP hack, and known mitigations
of the n**2 iBGP problem.  I think it'd also be
fair to consider time/space tradeoffs in the BGP
data structures and the data structures associated with
the actual forwarding of packets.)

        Sean.

---

From: Sean Doran <[email-masked]>
Date: 09 Dec 1999 15:47:09 +0100

Sean.

---

From: "Perry E. Metzger" <[email-masked]>
Date: 09 Dec 1999 10:25:07 -0500

> So how many /20s or how many /116s will fit into a routing table?

I think you are asking the wrong question.

Assuming we do agregation the way we do now, the difference v6 makes
is not that it lets you have more network numbers to put into the
global routing tables, but that it lets a provider give an end user
enough addresses for their whole home or business instead of just one
or a few.

Perry

---

From: "Perry E. Metzger" <[email-masked]>
Date: 09 Dec 1999 10:25:07 -0500

Perry

---

From: Bill Manning <[email-masked]>
Date: Thu, 9 Dec 1999 07:41:59 -0800 (PST)

% Bill Manning <[email-masked]> writes:
% 
% So how many /20s or how many /116s will fit into a routing table?
% 
% Alternatively -- if we take Harald Alvestrand's numbers,
% and assume everyone who wants one gets an IPv6 /48,
% leaving 16 bits for subnetting before the "flat space" --
% can we try to quantify the consumption of critical
% resources in routers with this as an explicit goal?
% 
% (I think it's fair to make assumptions that we will
% continue with BGP and the iBGP hack, and known mitigations
% of the n**2 iBGP problem.  I think it'd also be
% fair to consider time/space tradeoffs in the BGP
% data structures and the data structures associated with
% the actual forwarding of packets.)
% 
%         Sean.

Raw numbers of prefxies are pretty impressive.  A IPv4 /20 is 4k "host"
addresses. An IPv6 /116 is the same sized "chunk" so, the total number of

/20s in the IPv4 world:  1024000     (stuff that into your router)
/116s in a /48 chunk:    34359738368 (is that right?)

Haralds numbers are actually pretty easy.  16 bits of delegtion. Seems
like a routing table that would roughly be the size of a IPv4's /16
in host routes or 'prox what we have in todays table. Minus the transition
routes of course, and the more specifics, and the odd bits on the edge that
don't quite fit the model, and ...

--bill

---

From: Bill Manning <[email-masked]>
Date: Thu, 9 Dec 1999 07:41:59 -0800 (PST)

--bill

---

From: Christian Huitema <[email-masked]>
Date: Thu, 09 Dec 1999 10:59:16 -0500

>resources in routers with this as an explicit goal?

Sean, the appropriate answer to your question is RTFM (as in, read the
manual.) The top 48 bits of IPv6 addresses are anything but flat. The flat
space is initially limited to the top 16 bits, 3 of which are used as a
format prefix, leaving a "flat space" table size of 8K entries. These
entries are supposed to be assigned to "top level" providers -- the
equivalent of v4's default-free ISPs. There is indeed a concern that 8K may
not be enough in the long run, which has lead to place the next 8 bits in
reserve. Each of these "top level" prefixes thus contains 24 bits of
address space for organization or delegation by the provider. 
-- Christian Huitema

---

From: Christian Huitema <[email-masked]>
Date: Thu, 09 Dec 1999 10:59:16 -0500

---

From: Francis Dupont <[email-masked]>
Date: Thu, 09 Dec 1999 18:19:55 +0100

In your previous mail you wrote:

   
=> the power of 2 arithmetics gives:
/20s: 2^20: 1048576
/116s in a /48: 2^(116-48): 295147905179352825856
(34359738368 is 2^35)

but I am afraid this thread has become so boring than this will be
filtered out almost everywhere (:-)...

[email-masked]

---

From: Francis Dupont <[email-masked]>
Date: Thu, 09 Dec 1999 18:19:55 +0100

[email-masked]

---

From: Bill Sommerfeld <[email-masked]>
Date: Thu, 09 Dec 1999 13:51:43 -0500

> /116s in a /48 chunk:    34359738368 (is that right?)

that looked a little small to me, so i had a nearby scheme interpreter
do the math:

> (expt 2 20)
1048576
> (expt 2 (- 116 48))
295147905179352825856
> (expt 2 40)
1099511627776
> (expt 2 128)
340282366920938463463374607431768211456

One thing worth noting is that anyone out there who has a *single*
ipv4 address has a /48 in ipv6 space already, thanks to the 6to4
mechanism..

It seems obvious to me that the only way routing can scale with
addresses this large is with very aggressive aggregation.

The only way multihoming can work when aggressive aggregation is in
place is if hosts end up with multiple addresses (one from each
prefix) and know how to use them intelligently... and, if we can
manage to get that to work well, it has the advantage that end sites
-- even very small ones -- will be able to multihome merely by buying
service from multiple providers..

It does make life interesting for mid-level providers which want to
multihome, though.

					- Bill

---

From: Bill Sommerfeld <[email-masked]>
Date: Thu, 09 Dec 1999 13:51:43 -0500

1048576
295147905179352825856
1099511627776

					- Bill