Subject: Re: IP network address assignments/allocations information?

From: Brian E Carpenter <[email-masked]>
Date: Wed, 01 Dec 1999 10:50:54 -0600

Bob,

Bob Braden wrote:
> 
>    *>
>   *> The problem is not to make applications "NAT aware" or "NAT friendly".  The
>   *> problem is to make applications "IP address unaware".  What is an
>   *> application doing exchanging and using names for things 2 layers below it?
>   *> Sounds like a design for trouble if I ever heard of one.
> 
> I don't believe this argument, John.  The IP address is (part of) the
> transport layer end point address, something that an application can
> reasonably be expected to know about in the existing Internet
> architecture.

Unfortunately the existing Internet is no longer an implementaion
of the existing Internet architecture. That's why we have a problem.

  Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 01 Dec 1999 10:50:54 -0600

Bob,

  Brian

---

From: John Day <[email-masked]>
Date: Wed, 1 Dec 1999 12:29:36 -0500

>of the existing Internet architecture. That's why we have a problem.
That may be the best observation I have seen on this topic!

Take care,
John

---

From: John Day <[email-masked]>
Date: Wed, 1 Dec 1999 12:29:36 -0500

Take care,
John