Subject: Re: To address or NAT to address?

From: Walt Lazear <[email-masked]>
Date: Mon, 06 Dec 1999 10:39:04 -0500

At 09:40 PM 12/02/1999 -0800, Bill Manning wrote:
>> My point was that suggesting that reliance
>> should not be placed on the DNS has been, is, and most likely will be
contrary
>> to what happens in the real world.
>> 
>> Rgds,
>> -drc
>
>Someone who used to work here at ISI had a saying, "There are no urgent
>DNS problems."  I did not believe then and am finding less reason to
>do so as time progresses.  An interesting viewpoint is espoused in the
>recent draft by Akien et.al. on Middleware.  According to that draft,
>we are headed into an Infrastructure that will not work w/o available
>support services e.g. policy db, CA/key servers, DHCP/DNS, ad.nausea.
>
>
>-- 
>--bill
>

The Army's efforts to use COTS Internet technology in a tactical
environment has run straight into the critical support services
issues.  Without the functioning servers that Bill mentions, 
the network of applications is hung.  Funny, they don't use cell
phones because you have to build an infrastructure, but we 
keep trying to use fixed-plant technology for data networking.

For the public Internet, it seems that we're building a set
of critical services that, if attacked and disrupted, could 
crpple e-commerce, phone service, and other applications
dependent on the 'Net.

This came up in a discussion of "convergence" of voice,
video, and data.  Someone woke up to the fact that if we put
all those services on one LAN infrastructure, then that LAN
MUST BE UP all the time.  What is the cost to keep up all
the infrastructure pieces 7x24 and never let them go down?
Remember, you can't even call the Help Desk if the LAN is 
down (assuming phone service depends on it)! 

The anti-convergence part of me remembers when Richmond, VA
had an ice storm that took out electricity for a week last 
Xmas.  It was very interesting to note that we still had 
phone service, natural gas delivery, and water pressure.  
Each infrastructure piece had separate delivery mechanisms 
and their own backup apparatus.  The loss of any one had
almost no effect on the others.  Is this what convergence
would get us?

Careful what you wish for...  :-)

	Walt

---

From: "Perry E. Metzger" <[email-masked]>
Date: 06 Dec 1999 13:41:13 -0500

> down (assuming phone service depends on it)! 

Most of my clients have been building networks with zero or near zero
permissible downtime for years. International banks have this funny
problem that there is virtually no time of day or night when something
doesn't need the network to be up.

This is hardly a new problem. The infrastructure costs to do this are
quite manageable, although certainly non-negligible.

This is even ignoring the fact that other related industries (such as
our friends in the telco industry) have been providing even more
reliable service for many, many years.

Perry

---

From: "Perry E. Metzger" <[email-masked]>
Date: 06 Dec 1999 13:41:13 -0500

Perry

---

From: Bill Manning <[email-masked]>
Date: Tue, 7 Dec 1999 07:19:30 -0800 (PST)

% > all those services on one LAN infrastructure, then that LAN
% > MUST BE UP all the time.  What is the cost to keep up all
% > the infrastructure pieces 7x24 and never let them go down?
% > Remember, you can't even call the Help Desk if the LAN is 
% > down (assuming phone service depends on it)! 
% 
% Most of my clients have been building networks with zero or near zero
% permissible downtime for years. International banks have this funny
% problem that there is virtually no time of day or night when something
% doesn't need the network to be up.
% 
% This is hardly a new problem. The infrastructure costs to do this are
% quite manageable, although certainly non-negligible.
% 
% This is even ignoring the fact that other related industries (such as
% our friends in the telco industry) have been providing even more
% reliable service for many, many years.
% 
% Perry

	Ah, but the point here is that we may be on the cusp of a fundamental
	change in how the Internet operates.  A basic assumption that I
	grew up with is that IP based networks presume that the endnodes
	have all the information they need, impressed on them at build time.
	there is no -requirement- that they communicate with intermediaries
	before talking w/ other nodes on the network.  
	We are building networks that have required infrastructure support
	before the end nodes can be usefully deployed, e.g. CA/Key servers,
	DHCP/DynamicDNS, policy servers, etc. 
	
	Its not that we can't build them, its that it is a change in
	a fundamental IP precept.  Just a thought.

--bill

---

From: Bill Manning <[email-masked]>
Date: Tue, 7 Dec 1999 07:19:30 -0800 (PST)

--bill