Subject: RE: IP network address assignments/allocations information?

From: Ian King <[email-masked]>
Date: Mon, 6 Dec 1999 22:22:51 -0800

Can we take this off the IETF list?  This sounds like a perfect argument for
the NAT list, rather than the general IETF list.  This has been going on for
days, and this single subject keeps overflowing my inbox....  -- Ian 

-----Original Message-----
From: Josh Duffek [mailto:[email-masked]]
Sent: Monday, December 06, 1999 4:05 PM
To: Josh Duffek; Polinsky, Steven; [email-masked]
Cc: 'Perry E. Metzger'; J. Noel Chiappa; [email-masked]
Subject: RE: IP network address assignments/allocations information?

Classles routing rather :)

Josh

> -----Original Message-----
> From: Josh Duffek [mailto:[email-masked]]
> Sent: Monday, December 06, 1999 5:44 PM
> To: Polinsky, Steven; [email-masked]
> Cc: 'Perry E. Metzger'; J. Noel Chiappa; [email-masked]
> Subject: RE: IP network address assignments/allocations information?
>
>
> In a perfect world with proper network design I would have to
> disagree with
> you.  I believe that properly subnetted the private address space
> allocated
> would be enough.  Classful routing and VLSM should take care of this
> problem.
>
> But in the real world, with not so great network design I have seen many
> cases where more space is needed.
>
> Josh
> [email-masked]
>
> > -----Original Message-----
> > From: Polinsky, Steven [mailto:[email-masked]]
> > Sent: Monday, December 06, 1999 5:20 PM
> > To: [email-masked]'
> > Cc: 'Perry E. Metzger'; J. Noel Chiappa; [email-masked]
> > Subject: RE: IP network address assignments/allocations information?
> >
> >
> > I'm not advocating one technology over another. I am claiming
> that in the
> > IPV4/Private/Public/NAT world, a bigger pool of Private space
> > would be a big
> > help to many organizations.
> >
> > Steven
> >
> > Steven M. Polinsky
> > Vice President, Information Technology
> > Goldman, Sachs & Co.
> > 180 Maiden Lane
> > New York, NY 10038
> > 212-902-3669
> >
> >
> > -----Original Message-----
> > From: Jeffrey Altman [mailto:[email-masked]]
> > Sent: Monday, December 06, 1999 6:08 PM
> > To: Polinsky, Steven
> > Cc: 'Perry E. Metzger'; J. Noel Chiappa; [email-masked]
> > Subject: RE: IP network address assignments/allocations information?
> >
> >
> > > To me the biggest problem here, is the common situation such that
> > companies
> > > have separate (and necessary) Internet and Remote Access firewalls. RA
> > > firewalls exist in multiple global locations within an enterprise.
> > >
> > > Multiple instances of the same Private addresses would enter
> > (or exit) the
> > > enterprise network via Private lines from different companies
> if not for
> > > careful configuration management across and negotiation between "NAT
> > > Administrators", within the enterprise, and between
> > enterprises. The most
> > > difficult part is the negotiation with client/vendor site NAT
> > Admins as to
> > > who should NAT which addresses into which addresses. We often need to
> > > negotiate between 3 RA connected companies. Not only is this
> > painful, but
> > > one can never sleep comfortably, knowing that a NAT Admin at a
> > 3rd company
> > > will not make a mistake and connect someone new at our NATed address.
> > >
> > > There are not enough Private Addresses to go around.
> >
> > This sounds to me like more of an argument why private addresses
> > should be used on networks connected to public networks.  It is not
> > an argument for more private networks but for the move to IPv6 and
> > the banning of NATs.
> >
> >
> >     Jeffrey Altman * Sr.Software Designer * Kermit-95 for Win32 and OS/2
> >                  The Kermit Project * Columbia University
> >               612 West 115th St #716 * New York, NY * 10025
> >   http://www.kermit-project.org/k95.html *
> > [email-masked]
> >
>

---

From: Matt Holdrege <[email-masked]>
Date: Tue, 07 Dec 1999 08:46:58 -0800

I don't quite agree. The NAT WG list is primarily for achieving the 
milestones of the NAT WG. The IETF list is for discussing overall IETF 
issues which is what we are (mostly) doing. The discussion which is taking 
place among some very well experienced IETF'ers, crosses several working 
groups. And at least some of the messages are very useful for the community 
as a whole.

-Matt - NAT WG co-chair

At 10:22 PM 12/6/99 -0800, Ian King wrote:
>-
>This message was passed through [email-masked], which
>is a sublist of [email-masked]. Not all messages are passed.
>Decisions on what to pass are made solely by Harald Alvestrand.

---

From: Matt Holdrege <[email-masked]>
Date: Tue, 07 Dec 1999 08:46:58 -0800

-Matt - NAT WG co-chair

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 07 Dec 1999 13:18:34 -0600

Actually not. The NAT WG is trying to write down information to make the use
of NAT as relatively painless as is possible. I think *this* is exactly the right
topic for the main IETF list - what we are talking about is the survival of
the Internet. Maybe we should ban all other topics for a while.

  brian

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 07 Dec 1999 13:18:34 -0600

brian

---

From: Randy Bush <[email-masked]>
Date: Tue, 07 Dec 1999 12:23:47 -0800

> what we are talking about is the survival of the Internet. 

you forgot the news at 11 part

randy

---

From: Randy Bush <[email-masked]>
Date: Tue, 07 Dec 1999 12:23:47 -0800

randy

---

From: "Perry E. Metzger" <[email-masked]>
Date: 07 Dec 1999 16:14:35 -0500

> you forgot the news at 11 part

Actually, to a large extent, the "internet" as "transparent end to end
catanet" *is* dead. It has been dead ever since the average company
was forced to use private addressing. Maintaining the pseudo-internet
we've got left is costing us a lot of money and manpower, and neither
is an unlimited resource. It will make people very happy if we can
give them an internet back again.

-- 
Perry Metzger		[email-masked]

---

From: "Perry E. Metzger" <[email-masked]>
Date: 07 Dec 1999 16:14:35 -0500