Subject: Re: To address or NAT to address?

From: Pyda Srisuresh <[email-masked]>
Date: Thu, 2 Dec 1999 12:39:41 -0800 (PST)

--- Brian E Carpenter <[email-masked]> wrote:
> "David R. Conrad" wrote:
> > 
> > Christian,
> > 
> > > Increasing our reliance on the DNS is definitely not a good idea.
> > 
> > Hmmm.  This would appear to be the exact opposite of what the IETF has done
> > with IPv6.
> > 
> > Rgds,
> > -drc
> 
> Well now. There is some truth in that (A6 records are quite complex...)
> but NAT has generated some serious and complex dependencies on DNS too,
> not to mention various load sharing techniques.
> 
>   Brian

Brian, 

I am aware of the problems DNS-ALG has w.r.t. DNSSEC. But, what are the DNS 
Load-sharing problems you are refering to here? 

regards,
suresh 

__________________________________________________
Do You Yahoo!?
Thousands of Stores.  Millions of Products.  All in one place.
Yahoo! Shopping: http://shopping.yahoo.com

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 02 Dec 1999 16:13:22 -0600

Hi,

I didn't mean the case of load sharing via NAT. I meant the technique of a DNS server
that operates a round-robin (or even a heuristic) to return different IP addresses
for the same FQDN, so that successive clients get different servers. This is a 
pretty common hack, and another case where we are overloading DNS functionality.

  Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 02 Dec 1999 16:13:22 -0600

Hi,

  Brian