Subject: Re: IP network address assignments/allocations information?

From: "J. Noel Chiappa" <[email-masked]>
Date: Fri, 3 Dec 1999 12:46:23 -0500

> From: "Perry E. Metzger" <[email-masked]>

    > The situation right now is really horrible. People are pretending it
    > isn't, but the pretense really has to end. The End to End model isn't
    > just a "nice idea" -- its actually needed for people to manage and
    > maintain networks cost effectively. Its effectively dead a the moment,
    > and frankly, I'd like the internet back again, instead of this kludge
    > we're using instead these days.

Perry, one other thing I'm curious about (based on your messages in
particular, from this thread), and perhaps you can enlighten me.

While I'm not saying that NAT's are a Great Thing, I do wonder if people are
experiencing a bit of "grass is greener on the other side" syndrome here.
NAT's are in wide-spread use, and lots of people (e.g. you :-) are being
forced to struggle with their manifold downsides on a daily basis. In dealing
with this (and wishing they didn't have to deal with these problems :-), I
wonder if people are assuming (perhaps incorrectly) that the alternative is
relatively pain-free?

(My examination of some of the transition strategies indicates to me, as my
previous email alluded to, that perhaps they are going to suffer from many
of the same root causes that makes NAT painful too.)

So my question is: do you know of any site, one which has a lot of interaction
with the rest of the Internet, which has actually converted to the
alternative, for use on an ordinary daily basis, for the bulk of their
activity? (This is, after all, the stress level we're subjecting NAT boxes to,
these days.)

If so, it would be interesting to hear of their experience, so we can find
out to what degree the results of a conversion are any "greener".

	Noel

---

From: "Perry E. Metzger" <[email-masked]>
Date: 03 Dec 1999 13:00:28 -0500

> wonder if people are assuming (perhaps incorrectly) that the alternative is

If you mean "globally addressable IP addresses", I think that the
specific pain in question would go away, yes.

> So my question is: do you know of any site, one which has a lot of
> interaction with the rest of the Internet, which has actually
> converted to the alternative,

What do you mean by "the alternative"?

If you mean "gotten large blocks of global v4 addresses", the answer
is no one *can* at the moment.

If you mean v6, obviously not -- v6 isn't in real commercial
deployment yet (although it is now at the stage where we could
commercially deploy). If people were to start deploying v6, it would
probably initially be no less painful than NAT -- it would only have
the promise of being less painful down the road.

If you mean RSIP, RSIP is even further from deployment than
v6. Indeed, I'd say that RSIP is a clever but utterly dead end idea.

Perry

---

From: "Perry E. Metzger" <[email-masked]>
Date: 03 Dec 1999 13:00:28 -0500

Perry

---

From: Daniel Senie <[email-masked]>
Date: Fri, 03 Dec 1999 16:10:09 -0500

> v6. Indeed, I'd say that RSIP is a clever but utterly dead end idea.

I too would rather see effort put into IPv6... if it's going to happen,
let's get going, though... it's been in the oven too long.

There's one scenario about IPv6 which worries me, and which may well
make RSIP and NAT in a pure IPv6 world a reality. Today we have LOTS of
folks using NAT(NAPT really) for connecting to cable modems and DSL
lines. Some folks are doing this for dialups too. It's the model for
"home networking" today. Will ISPs be willing to assign a block of
addresses in the future to home networks? What does that mean when the
access is a dialup?

Sooner or later, we'll have providers handing out a single IPv6 address
to any home user customer, just as is done today with IPv4 addresses. It
is for this user population that RSIP will likely be a real issue.

One of the things to think about is that while there is use of various
NAT flavors in corporate environments, it is or will be nearly
ubiquitous in the home market. Linux and Windows both include credible,
functional NAPT solutions today. Is it ugly? Sure. Is there any chance
it'll stop being attractive to the home user? Unlikely.

-- 
-----------------------------------------------------------------
Daniel Senie                                        [email-masked]
Amaranth Networks Inc.            http://www.amaranthnetworks.com

---

From: Daniel Senie <[email-masked]>
Date: Fri, 03 Dec 1999 16:10:09 -0500

---

From: John Stracke <[email-masked]>
Date: Fri, 03 Dec 1999 16:52:01 -0500

Daniel Senie wrote:

> Some folks are doing this for dialups too.  It's the model for

> addresses in the future to home networks?

Today, they are not, because they want to make that a premium service.
However, one day, they may realize that the reason their customers aren't
buying that premium service is that they don't need it; they're using NATs
instead.  If IPv6 becomes common, and ISPs don't have to hoard addresses,
offering subnets as part of the basic service could become a good point of
competition.

--
/==============================================================\
|John Stracke    | http://www.ecal.com |My opinions are my own.|
|Chief Scientist |=============================================|
|eCal Corp.      |"She gets kidnapped. He gets killed. But it  |
[email-masked]|turns out okay." -- _Princess Bride_ poster  |
\==============================================================/

---

From: John Stracke <[email-masked]>
Date: Fri, 03 Dec 1999 16:52:01 -0500

---

From: "mark.paton" <[email-masked]>
Date: Fri, 3 Dec 1999 22:03:02 -0000

Daniel,
Surely you cannot conceive a time when the IP
address' are the domain of everyone.  The growth
of the Internet / Networking within the last 5
years shows you that our current addressing schema
is inadequate for the future demand, if you
extrapolate the current growth in line the growth
in births and longevity of folks then this says in
itself that we can expect an addressing schema
aimed at the "man on the street" and another one
for business and a third for the backbone and a
fourth for the hell of it.

A single IP address' combined with the mobility
factor will make it a very attractive future, why
not get involved and start the WG for it now.  The
future is not that far away.

Regards

Mark Paton CEO/DIR. Internet Network Eng
Mercury Network Systems Limited
+44 585 649051
http://www.mnsl.org

"Mercury Network Systems - The Unstoppable Force"

This e-mail is intended only for the addressee
named above. As this e-mail may contain
confidential or privileged information if you are
not, or suspect that you are not, the named
addressee or the person responsible for delivering
the message to the named addressee, please
telephone us immediately. Please note that we
cannot guarantee that this message or any
attachment is virus free or has not been
intercepted and amended. The views of the author
may not necessarily reflect those of the Company.

-----Original Message-----
From: Daniel Senie [mailto:[email-masked]]
Sent: 03 December 1999 21:10
To: Perry E. Metzger
Cc: J. Noel Chiappa; [email-masked]
Subject: Re: IP network address
assignments/allocations information?

> v6. Indeed, I'd say that RSIP is a
clever but utterly dead end idea.

I too would rather see effort put into
IPv6... if it's going to happen,
let's get going, though... it's been in
the oven too long.

There's one scenario about IPv6 which
worries me, and which may well
make RSIP and NAT in a pure IPv6 world a
reality. Today we have LOTS of
folks using NAT(NAPT really) for
connecting to cable modems and DSL
lines. Some folks are doing this for
dialups too. It's the model for
"home networking" today. Will ISPs be
willing to assign a block of
addresses in the future to home networks?
What does that mean when the
access is a dialup?

Sooner or later, we'll have providers
handing out a single IPv6 address
to any home user customer, just as is
done today with IPv4 addresses. It
is for this user population that RSIP
will likely be a real issue.

One of the things to think about is that
while there is use of various
NAT flavors in corporate environments, it
is or will be nearly
ubiquitous in the home market. Linux and
Windows both include credible,
functional NAPT solutions today. Is it
ugly? Sure. Is there any chance
it'll stop being attractive to the home
user? Unlikely.

--
------------------------------------------
-----------------------
Daniel Senie
          [email-masked]
Amaranth Networks Inc.
http://www.amaranthnetworks.com

---

From: "mark.paton" <[email-masked]>
Date: Fri, 3 Dec 1999 22:03:02 -0000

Daniel,

Regards