Subject: Question re: an Internet-Draft and testing/deployment

From: [email-masked]
Date: Wed, 16 Feb 2000 10:49:32 -0500

Noticed this one this morning:

--- start excerpt
A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: Compatible Internationalized Domain Names Using 
                          Compression
	Author(s)	: P. Hoffman
	Filename	: draft-hoffman-idn-cidnuc-02.txt
	Pages		: 12
	Date		: 15-Feb-00
	
This protocol describes a transformation method for representing non-
ASCII characters in domain names in a fashion that is completely
compatible with the current DNS. It meets the many requirements for
internationalization of domain names.

Note: this protocol is quite experimental and should not be deployed in
the Internet until it reaches standards track in the IETF.
--- end excerpt

Regarding the Note: - is there any coherent plan regarding testing/deployement
in regards to moving this from Experimental to Standards Track?

-- 
				Valdis Kletnieks
				Operating Systems Analyst
				Virginia Tech

---

From: Bill Manning <[email-masked]>
Date: Wed, 16 Feb 2000 09:03:32 -0800 (PST)

% --- start excerpt
% A New Internet-Draft is available from the on-line Internet-Drafts directories.
% 
% 
% 	Title		: Compatible Internationalized Domain Names Using 
%                           Compression
% 	Author(s)	: P. Hoffman
% 	Filename	: draft-hoffman-idn-cidnuc-02.txt
% 	Pages		: 12
% 	Date		: 15-Feb-00
% 	
% This protocol describes a transformation method for representing non-
% ASCII characters in domain names in a fashion that is completely
% compatible with the current DNS. It meets the many requirements for
% internationalization of domain names.
% 
% Note: this protocol is quite experimental and should not be deployed in
% the Internet until it reaches standards track in the IETF.
% --- end excerpt
% 
% Regarding the Note: - is there any coherent plan regarding testing/deployement
% in regards to moving this from Experimental to Standards Track?
% 
% -- 
% 				Valdis Kletnieks
% 				Operating Systems Analyst
% 				Virginia Tech

I hope not, This will be the first IETF where this WG meets. This is -one-
of several methods being discussed. We haven't even reached closure on
the appropriate scope. This draft is an attempt to walk one vector of 
the problem space. 

-- 
--bill

---

From: Bill Manning <[email-masked]>
Date: Wed, 16 Feb 2000 09:03:32 -0800 (PST)

% --- start excerpt

-- 
--bill

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 16 Feb 2000 12:05:18 -0500

>in regards to moving this from Experimental to Standards Track?

- this is an individual submission, not a idn wg draft
- this is interesting work that is currently discussed in idn wg mailing 
list, while the current charter do not cover new protocols. the wg charter 
is currently on requirements and documenting current implementations.
- while there is a wide interest and rough concensus (my own opinion) that 
an idn solution has to be engineered and deployed, it is premature at this 
stage to identify which proposal(s) is going to be on standards 
track.  And, unless the IESG would accept that individual submission and 
put it on standard track, the proposal who will go on standard track should 
be discussed in a wg (my own opinion), since the impact of deploying idn 
will be important. The idn wg is probably today the only one in the IETF 
related to that topic.
- I would suggest you to join our wg mailing list:  [email-masked]

Marc, co-chair of idn wg.

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 16 Feb 2000 12:05:18 -0500

---

From: Paul Hoffman / IMC <[email-masked]>
Date: Wed, 16 Feb 2000 09:57:45 -0800

>in regards to moving this from Experimental to Standards Track?

As the draft author, let me assure you that it is far from being an 
Experimental RFC. I put these words in so that, if someone tripped across 
the draft and said "hey, let's implement this", they wouldn't think anyone 
else was. As others have said, there are a variety of IDN proposals at this 
time, and it would be downright silly for anyone to assume which, if any, 
of them will even look like the one that might be chosen down the line.

The note shouldn't be needed, given the definition of an Internet Draft, 
but it appears that many folks have forgotten that definition.

--Paul Hoffman, Director
--Internet Mail Consortium

---

From: Paul Hoffman / IMC <[email-masked]>
Date: Wed, 16 Feb 2000 09:57:45 -0800

--Paul Hoffman, Director

---

From: Dave Crocker <[email-masked]>
Date: Wed, 16 Feb 2000 10:42:28 -0800

>the appropriate scope. This draft is an attempt to walk one vector of

Not just "discussed".  Tin Tan Wee has been working on this publicly for a 
couple of years and now has a well-supported, fully operational service.

d/

=-=-=-=-=
Dave Crocker  <[email-masked]>
Brandenburg Consulting  <www.brandenburg.com>
Tel: +1.408.246.8253,  Fax: +1.408.273.6464
675 Spruce Drive,  Sunnyvale, CA 94086 USA

Gong Xi Fa Cai   /  Selamat Tahun Baru Cina

---

From: Dave Crocker <[email-masked]>
Date: Wed, 16 Feb 2000 10:42:28 -0800

d/

=-=-=-=-=

---

From: [email-masked]
Date: Wed, 16 Feb 2000 13:59:51 -0500

> but it appears that many folks have forgotten that definition.

Ahh.. <enlightment occurs>.  I was reading it as being even *more*
cautionary than the usual paranoia that should be created just from
its I-D status.  If the intent was just to remind people "Hey, it's
just an I-D, don't do this unless you're testing it", that's another
story.

/Valdis

---

From: [email-masked]
Date: Wed, 16 Feb 2000 13:59:51 -0500

/Valdis

---

From: Bill Manning <[email-masked]>
Date: Wed, 16 Feb 2000 12:11:07 -0800 (PST)

% At 09:03 AM 2/16/2000 -0800, Bill Manning wrote:
% >I hope not, This will be the first IETF where this WG meets. This is -one-
% >of several methods being discussed. We haven't even reached closure on
% >the appropriate scope. This draft is an attempt to walk one vector of
% >the problem space.
% 
% Not just "discussed".  Tin Tan Wee has been working on this publicly for a 
% couple of years and now has a well-supported, fully operational service.
% 
% Dave Crocker  <[email-masked]>

	I am very aware of the APNG work on iDNS. However within the
	context of the IETF and the IDN wg, there remain a number of
	methods under discussion, including Tin Tan Wee's work. 

-- 
--bill

---

From: Bill Manning <[email-masked]>
Date: Wed, 16 Feb 2000 12:11:07 -0800 (PST)

-- 
--bill

---

From: Keith Moore <[email-masked]>
Date: Wed, 16 Feb 2000 16:45:08 -0500

> couple of years and now has a well-supported, fully operational service.

which doesn't even begin to address a large number of problems.

anyone who believes they have running code for iDNS is deluding themselves.

Keith

---

From: Keith Moore <[email-masked]>
Date: Wed, 16 Feb 2000 16:45:08 -0500

Keith

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 17 Feb 0 6:48:38 JST

Dave;

> couple of years and now has a well-supported, fully operational service.

The problem is that the problem to be solved (or discussed) is not
well defined.

You can still have well-supported, fully operational, but, purposeless
services.

							Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 17 Feb 0 6:48:38 JST

Dave;

							Masataka Ohta