Subject: MGCP: Gateways start-up

From: [email-masked] (Lorenzo Boffelli)
Date: Thu, 12 Jul 2001 10:39:00 -0700

Hi everybody,

my problem is understand how the communication between a generic Call Agent (CA)
and a generic Gateway (GW) start up.

Does the protocol works in the following mode ?

CA knows which GWs it must control because they are configured in the CA. When
CA     receives a RSIP message from these GWs it responds, otherwise if it
receives a RSIP from GWs that are not configured, CA does not responds.
This ways need a DataBase in CA in which store the GWs that must be controlled.

Is it correct?
Are there any other mode?
Are there any mode in which GW sends a message to CA for "register" itself (GW
says to CA that CA has to control it)?

In draft-andreasen-mgcp-rfc2705bis-01.txt I do not found anything for the
moment.

Thanks
Lorenzo

___________________________________________

Lorenzo Boffelli
STRE Engineer
European R&D Center

Allied Telesis K.K.
Head Office / 4F TOC Bldg, 7-22-17 Nishi-Gotanda,
Shinagawa-ku, Tokyo Japan, 141-8635
European Office: Via Pier della Francesca, 26
20090 Trezzano sul Naviglio (MI) - Italy
Tel: +39 (0)2 48463525 Fax: +39 (0)2 48463581
Email: [email-masked]
___________________________________________

---

From: Abhishek <[email-masked]>
Date: Fri, 13 Jul 2001 10:53:41 +0530

Hi,

	CA must be always having a "list" of Gateways which it is
monitoring. A new gateway can be added at anytime in the "list" of Gateways
of the  Call agent ONLY by the OWNER of the softswitch as a "persistent
event". For this reason, a database can be suggested with a CA to contain
this "list" of gateways.   

	If a gateway is not present in the configured "list" of gateways of
the CA, then, the RSIP send by this gateway will be   returned by negative
ack, containing the return code of 500 <tid> ok. This return code suggests
the endpoint is unknown.  This is a permanent error. 

	Always rememeber that MGCP is a master-slave protocol and Gateways
are always expected to execute the commands send by the CA (page5-6 in the
draft). Reverse is "not always" true. 

hope that it works,

regards,

abhishek mishra

Sr. Software Engineer
Ind-Telesoft Pvt. Ltd.
No.104, 5th Block
Koramangala
bangalore-95 (INDIA)

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]
Sent: Thursday, July 12, 2001 11:09 PM
To: [email-masked]
Subject: MGCP: Gateways start-up

Hi everybody,

my problem is understand how the communication between a generic Call Agent
(CA)
and a generic Gateway (GW) start up.

CA knows which GWs it must control because they are configured in the CA.
When
CA     receives a RSIP message from these GWs it responds, otherwise if it
receives a RSIP from GWs that are not configured, CA does not responds.
This ways need a DataBase in CA in which store the GWs that must be
controlled.

Is it correct?
Are there any other mode?
Are there any mode in which GW sends a message to CA for "register" itself
(GW
says to CA that CA has to control it)?

Thanks
Lorenzo

Lorenzo Boffelli
STRE Engineer
European R&D Center

Allied Telesis K.K.