Subject: Re: networksorcery.com spam

From: [email-masked] (Steve Conner)
Date: Fri, 20 Jul 2001 09:48:11 -0700

Hi folks,

I guess it is time to come out of the shadows. As many of you know, Network Sorcery maintains a mirror site with the RFCs. Three years ago we started maintaining home pages for RFC authors so we could collect a listing of contact info, publications they have written and whatever bio info they want to reveal. The contact info gets stale over time.

Yes it is true, we actually try to contact authors using the contact info in their latest RFC. It is also true that I send out a form letter requesting the info. Why would I want to compose the same letter over and over again? If we wanted to spam the largest number of authors this would be the group to send it to. I have tried to be descrete but I guess someone took offence at actually trying to contact him.

It would certainly make my life easier if the IETF would provide a directory that the authors could update themselves. I have volunteered in the past to share this info with the IETF.

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 20 Jul 2001 15:06:53 -0400

At 09:48 AM 7/20/2001 -0700, Steve Conner wrote:

>It would certainly make my life easier if the IETF would provide a 
>directory that the authors could update themselves. I have volunteered in 
>the past to share this info with the IETF.

Perhaps this is something to bring up at the Plenary.  Most likely in the 
IAB's RFC Editor report!

I bet they are getting a bunch of hits right now as we all find out how BAD 
the info is.

The address for me has not worked for 4 years.  And THIS one is NOT what I 
would want in such a directory.

---

From: Michael Mealling <[email-masked]>
Date: Fri, 20 Jul 2001 16:01:52 -0400

> Perhaps this is something to bring up at the Plenary.  Most likely in the 

I'm not sure how many people use it but I've often wanted a database
like this for authors where the output was in Marshall's RFC 2629 XML
format. Then between the bibliography stuff he has xml.resource.org
I could have everything but the content be generated...

Now if I could just automagically create the content... hmmm....

-MM

-- 
--------------------------------------------------------------------------------
Michael Mealling	|      Vote Libertarian!       | urn:pin:1
[email-masked]      |                              | http://www.neonym.net

    Democracy gives an aura of legitimacy to acts that 
    would otherwise be deemed tyranny.
					 -- Walter Williams

---

From: Jon Crowcroft <[email-masked]>
Date: Sat, 21 Jul 2001 12:23:31 +0100

is the database of rfc authors declared under the Data Protection Act
in the UK, with the reasons and uses?

if not, i am afraid this is illegal. if you visit the IETF in london,
you might be in for a surprise

otherwise, fine and good luck and it seems like a sensible service...

In message <0c5901c1113b$c32d8ed0$6601a8c0@CHIMERA>, Steve Conner typed:

 >>This is a multi-part message in MIME format.
 >>
 >>------=_NextPart_000_0C55_01C11101.169641B0
 >>Content-Type: multipart/alternative;
 >>	boundary="----=_NextPart_001_0C56_01C11101.169641B0"
 >>
 >>
 >>------=_NextPart_001_0C56_01C11101.169641B0
 >>Content-Type: text/plain;
 >>	charset="Windows-1252"
 >>Content-Transfer-Encoding: quoted-printable
 >>
 >>
 >>Hi folks,
 >>
 >>I guess it is time to come out of the shadows. As many of you know, =
 >>Network Sorcery maintains a mirror site with the RFCs. Three years ago =
 >>we started maintaining home pages for RFC authors so we could collect a =
 >>listing of contact info, publications they have written and whatever bio =
 >>info they want to reveal. The contact info gets stale over time.
 >>
 >>Yes it is true, we actually try to contact authors using the contact =
 >>info in their latest RFC. It is also true that I send out a form letter =
 >>requesting the info. Why would I want to compose the same letter over =
 >>and over again? If we wanted to spam the largest number of authors this =
 >>would be the group to send it to. I have tried to be descrete but I =
 >>guess someone took offence at actually trying to contact him.
 >>
 >>It would certainly make my life easier if the IETF would provide a =
 >>directory that the authors could update themselves. I have volunteered =
 >>in the past to share this info with the IETF.
 >>
 >>------=_NextPart_001_0C56_01C11101.169641B0
 >>Content-Type: text/html;
 >>	charset="Windows-1252"
 >>Content-Transfer-Encoding: quoted-printable
 >>
 >><!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
 >><HTML><HEAD>
 >><META content=3D"text/html; charset=3Dwindows-1252" =
 >>http-equiv=3DContent-Type><BASE=20
 >>href=3D"file://G:\Program Files\Common Files\Microsoft =
 >>Shared\Stationery\">
 >><STYLE>BODY {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>P.msoNormal {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>LI.msoNormal {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>PRE {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>BLOCKQUOTE {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>A {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>MENU {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>DD {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>UL {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>DT {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>DIR {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>ADDRESS {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>H1 {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>H2 {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>H3 {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>H4 {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>H5 {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>H6 {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >>HR {
 >>	COLOR: #000000; FONT-FAMILY: "Arial"; FONT-SIZE: 12pt; MARGIN-BOTTOM: =
 >>0em; MARGIN-TOP: 0em
 >>}
 >></STYLE>
 >>
 >><META content=3D"MSHTML 5.00.2920.0" name=3DGENERATOR></HEAD>
 >><BODY background=3Dcid:0c5401c1113b$c2ebf1f0$6601a8c0@CHIMERA =
 >>bgColor=3D#c8e0d8>
 >><DIV>&nbsp;</DIV>
 >><DIV>Hi folks,</DIV>
 >><DIV>&nbsp;</DIV>
 >><DIV>I guess it is time to come out of the shadows. As many of you know, =
 >>Network=20
 >>Sorcery maintains a mirror site with the RFCs. Three years ago we =
 >>started=20
 >>maintaining home pages for RFC authors so we could collect a listing of =
 >>contact=20
 >>info, publications they have written and whatever bio info they want to =
 >>reveal.=20
 >>The contact info gets stale over time.</DIV>
 >><DIV>&nbsp;</DIV>
 >><DIV>Yes it is true, we actually try to contact authors using the =
 >>contact info=20
 >>in their latest RFC. It is also true that I send out a form letter =
 >>requesting=20
 >>the info. Why would I want to compose the same letter over and over =
 >>again? If we=20
 >>wanted to spam the largest number of authors this would be the group to =
 >>send it=20
 >>to. I have tried to be descrete but I guess someone took offence at =
 >>actually=20
 >>trying to contact him.</DIV>
 >><DIV>&nbsp;</DIV>
 >><DIV>It would certainly make my life easier if the IETF would provide a=20
 >>directory that the authors could update themselves. I have volunteered =
 >>in the=20
 >>past to share this info with the IETF.</DIV></BODY></HTML>
 >>
 >>------=_NextPart_001_0C56_01C11101.169641B0--
 >>
 >>------=_NextPart_000_0C55_01C11101.169641B0
 >>Content-Type: image/gif;
 >>	name="tech.gif"
 >>Content-Transfer-Encoding: base64
 >>Content-ID: <0c5401c1113b$c2ebf1f0$6601a8c0@CHIMERA>
 >>Content-Transfer-Encoding: base64
 >>Content-Transfer-Encoding: base64
 >>
 >>R0lGODlhFAAUAPcAAP//////zP//mf//Zv//M///AP/M///MzP/Mmf/MZv/MM//MAP+Z//+ZzP+Z
 >>mf+ZZv+ZM/+ZAP9m//9mzP9mmf9mZv9mM/9mAP8z//8zzP8zmf8zZv8zM/8zAP8A//8AzP8Amf8A
 >>Zv8AM/8AAMz//8z/zMz/mcz/Zsz/M8z/AMzM/8zMzMzMmczMZszMM8zMAMyZ/8yZzMyZmcyZZsyZ
 >>M8yZAMxm/8xmzMxmmcxmZsxmM8xmAMwz/8wzzMwzmcwzZswzM8wzAMwA/8wAzMwAmcwAZswAM8wA
 >>AJn//5n/zJn/mZn/Zpn/M5n/AJnM/5nMzJnMmZnMZpnMM5nMAJmZ/5mZzJmZmZmZZpmZM5mZAJlm
 >>/5lmzJlmmZlmZplmM5lmAJkz/5kzzJkzmZkzZpkzM5kzAJkA/5kAzJkAmZkAZpkAM5kAAGb//2b/
 >>zGb/mWb/Zmb/M2b/AGbM/2bMzGbMmWbMZmbMM2bMAGaZ/2aZzGaZmWaZZmaZM2aZAGZm/2ZmzGZm
 >>mWZmZmZmM2ZmAGYz/2YzzGYzmWYzZmYzM2YzAGYA/2YAzGYAmWYAZmYAM2YAADP//zP/zDP/mTP/
 >>ZjP/MzP/ADPM/zPMzDPMmTPMZjPMMzPMADOZ/zOZzDOZmTOZZjOZMzOZADNm/zNmzDNmmTNmZjNm
 >>MzNmADMz/zMzzDMzmTMzZjMzMzMzADMA/zMAzDMAmTMAZjMAMzMAAAD//wD/zAD/mQD/ZgD/MwD/
 >>AADM/wDMzADMmQDMZgDMMwDMAACZ/wCZzACZmQCZZgCZMwCZAABm/wBmzABmmQBmZgBmMwBmAAAz
 >>/wAzzAAzmQAzZgAzMwAzAAAA/wAAzAAAmQAAZgAAMwAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
 >>AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
 >>AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAACwAAAAAFAAUAEAIQwBJCBxI
 >>sKBBAAgTKlyYUCDDhwsdQpwoceLDihYjksh4cSNHjR9BhmzocSQAjCFRflTJkWVGlxZhUiw5UiZE
 >>gzhzBgQAOw==
 >>
 >>------=_NextPart_000_0C55_01C11101.169641B0--
 >>

 cheers

   jon

---

From: Robert Elz <[email-masked]>
Date: Sat, 21 Jul 2001 19:36:12 +0700

Date:        Sat, 21 Jul 2001 12:23:31 +0100
    From:        Jon Crowcroft <[email-masked]>
    Message-ID:  <[email-masked]>

  | is the database of rfc authors declared under the Data Protection Act
  | in the UK, with the reasons and uses?

For what it is worth, the UK seems to have gotten on exactly the
right track in killing spam (and other similar abuses).

It isn't the e-mail that is really the evil, that's just a symptom
of the true problem, which is misuse of personal data for purposes other
than which it was originally given.

Fix that problem, which a few more countries introducing legislation
along the UK lines would do (one in particular...) and the vast majority
of the spam will simply go away.

kre

---

From: Francis Dupont <[email-masked]>
Date: Sat, 21 Jul 2001 17:10:02 +0200

=> I talked with Harald Alvestrand about this issue (to have transient
contact infos in documents is not a good thing) at the last RIPE meeting
so I agree we should bring up this at the Plenary but this is not so easy
to solve (two ideas : a directory with the actual mail address, a special
mail address for RFC authors: something like [email-masked]).

Thanks

[email-masked]