Subject: Re: Re: [Hist Trivia] IP Protocol Layers

From: [email-masked]
Date: Tue, 17 Jul 2001 19:03:06 -0400

Vint spoke on this very topic as the dinner speaker for the TCP/IP Interoperability Forum in Monterey (the pre-Interop interop conference).  As I recall from his comments, the decision to split the two came about as a mutual epiphany between him and Dave Clark as they were trying to figure out some way around some of the stupidity in NCP. As I recall, the document cited below had a lot of this history... I seem to also remember that it was published as an IEEE or some such document in addition to being an IEN.  I believe TCP v3 was the last version that was unitary and that was published in Jan of 78 (IEN21).  In Feb of 78 Jon Postel published the first draft of an IP (IEN28)

IEN48     Cerf            Jul-78   The Catenet Model for Internetworking

Mike

I'll leave to Vint to clarify and correct...

Dave Crocker <[email-masked]> wrote:
> At 02:19 PM 7/17/2001, Radia Perlman - Boston Center for Networking wrote:>I think TCP and IP were all one layer at one point. It's possible
>the old IEN's, (which I'd heard would be on-line "soon" if

That is my understanding, too:  In the beginning there was only TCP.

During on-going discussions between the ARPA research and the Xerox PARC 
research folks, the need for separating out IP functionality became apparent.

I don't know the dates for this architectural transition.

d/

ps.  FWIW:

>         Application
>         Transport (TCP, UDP)
>         Internet (IP, etc.)
>         Network Interface (LAN and WAN technologies).

         The idea of intermediate "upper" layers has periodically been 
played with in the Internet realm, such as with XDR and RPC, and again more 
recently with BEEP. A range of efforts that standardize on an application 
infrastructure, such as with XML, encourage viewing this as a real 
architectural enhancement. Hence we probably need to wedge a layer between 
transport and applications.  I prefer to call it session; others will 
likely prefer presentation.

----------
Dave Crocker  
Brandenburg InternetWorking  
tel +1.408.246.8253;  fax +1.408.273.6464

---

From: Stephen Casner <[email-masked]>
Date: Tue, 17 Jul 2001 23:21:09 -0700 (PDT)

On Tue, 17 Jul 2001 [email-masked] wrote:

> Vint spoke on this very topic as the dinner speaker for the TCP/IP
> Interoperability Forum in Monterey (the pre-Interop interop
> conference).  As I recall from his comments, the decision to split
> the two came about as a mutual epiphany between him and Dave Clark
> as they were trying to figure out some way around some of the
> stupidity in NCP.

I believe Danny Cohen was one of the primary instigators for the
split, motivated by the desire to support packet transmission of
voice.  I recall a presentation Danny made in which he talked about
TCP's reliability function R which was not appropriate for
delay-sensitive voice communication.  He suggested that we could apply
another layer to implement an R^-1 function, but that it might be more
efficient to split TCP so that a different (transport) protocol could
be implemented without the reliability function.
							-- Steve

---

From: vint cerf <[email-masked]>
Date: Wed, 18 Jul 2001 09:38:51 -0400

Danny had a very big influence on the split - he had a great
analogy between milk and wine - it was ok for wine packets
to be delayed (they got better with age) but milk was something
else. That led to UDP for real-time stuff, especially voice
packets - yeah, we were doing packet voice as far back as 1975.

vint

---

From: "Jim Fleming" <[email-masked]>
Date: Wed, 18 Jul 2001 09:37:05 -0500

----- Original Message -----
From: "vint cerf" <[email-masked]>
To: "Stephen Casner" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, July 18, 2001 8:38 AM
Subject: Re: Re: [Hist Trivia] IP Protocol Layers

> packets - yeah, we were doing packet voice as far back as 1975.

IPv4, IPv6, IPv8, IPv16....people are learning...

Most people, when asked what the Internet is, think it is 2D WEB Services.
People can read the archives about what 2D graphics work was like in the
mid 70's. In many respects, it has not changed much, the protocols have
just besome more inefficient, because people perceive that bandwidth is
infinite.

Others view the Internet as the Name Space. That has been a human travesty
in the way that has been managed. Fortunately, a new generation of netizens
are breaking down the barriers, similar to the way the Berlin Wall fell.

Wide-Spread Support is Important for TLDs.
Our .BIZ is a good example.
Who would have thought that it would survive and now find its way into all
the roots ?

Jim Fleming
Why gamble with a .BIZ Lottery?, get the real .BIZ
http://www.DOT-BIZ.com
http://www.BIZ.Registry
0:212 - BIZ World

---

From: Mahadevan Iyer <[email-masked]>
Date: Wed, 18 Jul 2001 08:49:34 -0700

vint cerf wrote:

> else.

Hmm, so ftp-packets get better with age?
:)

---

From: vint cerf <[email-masked]>
Date: Wed, 18 Jul 2001 14:31:08 -0400

no but they are better if the all get there as opposed to only some of them

vint

---

From: Stephen Casner <[email-masked]>
Date: Wed, 18 Jul 2001 15:25:24 -0700 (PDT)

The milk vs wine description applies best to the decision about which
packets to drop from a queue.  For ftp packets you want to drop the
newest and send the oldest (wine) so that the ACK sequence number can
advance.  This is normal tail drop.  But for voice packets, you want
to drop the oldest and send the newest (milk) because packets that are
delayed too long won't be played anyway.
							-- Steve