Subject: Re: Datagram? Packet? (was : APEX)

From: Masataka Ohta <[email-masked]>
Date: Sat, 5 Oct 2002 07:38:51 +0859 ()

Valdis;

> > In this thread, as Noel said:
> > : It's easy to imagine an ATM-like system
> > : in which circuit ID's are global in scope.
> > 
> > the circuit ID does not neccessarily imply special routing.
> 
> If you're not routing based on circuit ID, why are you bothering to have one?

I'm routing based on circuit ID. Current RSVP does not.

RSVP is bothering to have one for prioritized queueing.

> > However, you should also be aware that RSVP is virtually useless
> > without QoS routing.
> 
> Yes, a protocol to tweak the control of an underlying XYZ is pretty useless
> if there isn't an XYZ to tweak...
> 
> You're overlooking the basic distinction between a circuit and RSVP - if
> something happens along the way to break the previously established circuit,
> the circuit is *BROKEN*, and nothing moves until it is either re-established or
> re-negotiated.

You misunderstand the problem.

The problem is that a protocol to tweak the control of an underlying
bandwidth allocation is pretty useless if there isn't enough bandwidth
to tweak.

You can't reserve 1Gbps on the best effort path with T1 circuit, even
if the T1 circuit is not broken.

						Masataka Ohta

---

From: [email-masked]
Date: Sat, 05 Oct 2002 23:50:59 -0400

> I'm routing based on circuit ID. Current RSVP does not.

Like I said - RSVP is *NOT* circuit based.

> You misunderstand the problem.

Not in the slightest.  I understand RSVP - what I objected to was the
statement that RSVP is circuit based.

> bandwidth allocation is pretty useless if there isn't enough bandwidth

I'm aware of that.

> if the T1 circuit is not broken.

Old news. The following has been .sig fodder since at least 13 Feb 1990:

***> 		 NETWORK PLANNING CONSTRAINT OF THE MONTH:
***> 	      "You can't send bits over a non-existent link."
***> 		--Valdis Kletnieks <[email-masked]>

---

From: Masataka Ohta <[email-masked]>
Date: Sun, 6 Oct 2002 17:56:10 +0859 ()

Valdis;

> Like I said - RSVP is *NOT* circuit based.

You don't have to make the confusion on terminology even worse  by
insisting on youres.

Circuit ID is introduced by Noel w.r.t. ATM and you can use
your favourite wording for RSVP.

> statement that RSVP is circuit based.

As Noel said:

: It's easy to imagine an ATM-like system
: in which circuit ID's are global in scope.A

we are discussing on circuit-ID-like things of ATM-like systems.

In RSVP terminology, flows are identified by addresses and port numbers,
which is the circuit-ID-like thing.

That RSVP does not have circuit-like thing is fine, as long as there
is circuit-ID-like thing.

> > bandwidth allocation is pretty useless if there isn't enough bandwidth

Then, there is no reason to insist on detailed terminology of useles
protocols such as ATM and RSVP.

							Masataka Ohta