Subject: RE: Palladium (TCP/MS)

From: TOMSON ERIC <[email-masked]>
Date: Mon, 21 Oct 2002 16:18:59 +0200

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 

On Mon, 21 Oct 2002 15:09:10 +0200, TOMSON ERIC said:

> Please read the 2 following links, then answer 2 simple questions :
> - Is Palladium (TCP/MS) a real/serious threat?
A real/serious threat to whom?

To the Internet community. All users connected to the Internet. You and me. How could the Internet still be "for everyone" if it actually belongs to "one"?

> - Do we have to be afraid of it?
Who is "we"?

All the Internet users. Companies, organizations, corporate users, home users.

My personal take is that it's a serious threat, but not in the IETF venue. There are plenty of lists already discussing it, bring the topic up there...

The IETF is explicitly named in one of the 2 links. And suppose that the majority of PC users connected to the Internet stop using TCP/IP and replace it with TCP/MS... What would be the role of the IETF in such a picture? What kind of influence would the IETF have on µ$oft? What if TCP/IP just disappears? Don't WE have to be afraid of an Internet under one private monopolistic control?

---

From: "Bill Cunningham" <[email-masked]>
Date: Mon, 21 Oct 2002 10:44:40 -0400

----- Original Message -----
From: "TOMSON ERIC" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Monday, October 21, 2002 10:18 AM
Subject: RE: Palladium (TCP/MS)

> To the Internet community. All users connected to the Internet. You and
me. How could the Internet still be "for everyone" if it actually belongs to
"one"?
> My personal take is that it's a serious threat, but not in the IETF venue.
There are plenty of lists already discussing it, bring the topic up there...
>
> The IETF is explicitly named in one of the 2 links. And suppose that the
majority of PC users connected to the Internet stop using TCP/IP and replace
it with TCP/MS... What would be the role of the IETF in such a picture? What
kind of influence would the IETF have on µ$oft? What if TCP/IP just
disappears? Don't WE have to be afraid of an Internet under one private
monopolistic control?
It *is* the IETF's concern. It is the Internet Society's concern. TCP/IP
*must* be able to compete and that is IETF and IESG's responsibility.

---

From: [email-masked]
Date: Mon, 21 Oct 2002 10:54:37 -0400

On Mon, 21 Oct 2002 16:18:59 +0200, TOMSON ERIC said:
>  And suppose that the majority of PC users connected to the Internet stop
> using TCP/IP and replace it with TCP/MS...

I'll leave it as an exercise for the reader as to just how fast users will
bail on Microsoft if they install TCP/MS and then find they can't reach AOL,
Google, Yahoo, or Amazon, or any Cisco-powered site.

Equally as critical - how fast the average IS director will ditch Microsoft
once he/she discovers that TCP/MS won't talk to the Oracle database on the
Solaris box...

If it interoperates with TCP/IP, it's not an issue for us.  And if it doesn't
interoperate, it will resolve itself due to market forces.

Not A Problem.

-- 
				Valdis Kletnieks
				Computer Systems Senior Engineer
				Virginia Tech

---

From: "Bill Cunningham" <[email-masked]>
Date: Mon, 21 Oct 2002 11:31:39 -0400

----- Original Message -----
From: <[email-masked]>
To: "TOMSON ERIC" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Monday, October 21, 2002 10:54 AM
Subject: Re: Palladium (TCP/MS)

I hope your right Valdis. MS has as much right as anyone to design a network
protocol. It's just that TCP/IP is a symbol of freedom, open standards and
the Internet.
Novell's protocols, ISO's protocols are just their protocols. I rant about
this so much because I feel a strong conviction that it is IETF's
responsibilty for TCP/IP's future for better or worse. When TCP/IP was
rolled out in '83 I think, that was the beginning of the Inernet. DoD
standard, Vint's standard, call it what you will it *is* the Internet.
    End Rant.

---

From: "Stephen Sprunk" <[email-masked]>
Date: Mon, 21 Oct 2002 13:20:27 -0500

Thus spake "TOMSON ERIC" <[email-masked]>
> it with TCP/MS... What would be the role of the IETF in such a picture?
> What kind of influence would the IETF have on µ$oft? What if TCP/IP just

Do not mistake the computers for the networks that connect them.  Microsoft
doesn't have much control over the Internet.  Heck, even the IETF doesn't have
much control over the Internet based on how few ISPs follow the BCPs :)

MSN is just a speedbump on the info superhighway compared to a behemoth like
AOL.  And do note that AOL has been moving away from its proprietary systems and
protocols in favor of open standards -- at/below the network layer.

Palladium is a potentially scary future, but that is unrelated to IP.

S

---

From: "Haren Visavadia" <[email-masked]>
Date: Mon, 21 Oct 2002 19:51:59 +0100

> Microsoft doesn't have much control over the Internet.  

Well, Microsoft has some reponsiblity since they produce some the server
software and client software.

---

From: Einar Stefferud <[email-masked]>
Date: Mon, 21 Oct 2002 13:02:08 -0700

>software and client software.

I certainly assume that MSN has control of its products and the quality there-of, and so bears responsibility "to its customers" for the bad behavior of what it sells.  

The fact that MSN has bought a majority mind share is critical here.
Certainly, no non-market entity has much of any control over MSN stuff.

So, the real problem is that the market is accepting the stuff that MSN sells, including the declarations of "customer beware" regarding any faults (including bad design choices) that the MSN "stuff" might contain.

This includes massive propagation of the original IBM PROFS Christmas Virus type facilitation from back in the 1980's, where-in the PROFS mail system was given the privilege of allowing incoming messages run programs that can mail copies of themselves to everyone in the recipient's address book.  I assumed back then that the lesson would be learned and the market would cure the design problem.  But, my assumption was dead wrong.

That "FEATURE"  was stupid then and it is still utterly stupid, especially after almost two decades of network experience and $billions of wasted expense for the users of such stupid systems.  A whole industry has grown up to deal with this one deliberate design flaw.

But still, the rule is very simple:  "You Get What You Pay For!"

The main culprits are those large fortune 1000 companies that accept those strange terms of sale, which disclaim all responsibility for everything bad (and all he credit for all the good).  

They provide MSN with a substantial base market with huge influence over what everyone else needs to buy to interwork with them.  Why else do you suppose MSN coddles them, and focuses support on them.  Many of them are privileged to participate in beta testing, and no doubt receive superior technical support.  In a way, they are being bought off.  In any case, those beta testers seem not to be noticing that the basic deigns are bad!

So, in my own small way, as a single individual, I refuse to actually use any MSN systems that deal with any Internet Protocols, such as mail or the web.  If more people took such actions -- (instead of just using MSN stuff while complaining about it) -- the behavior of MSN might change.

Indeed, you can get along very well without OE or IE, if you choose to.

In my case, I simply forgo access to Internet stuff that requires MSN tools.  If the provider does not want me to see what they mount for public viewing, it is fine with me, and thus it is their problem, and not mine!

Of course, I know that MSN can hardly care less what I do, so I am only doing this to protect myself from their careless product designs.  Even when I consulted for them for fee, they did not care what I wanted, and generally sent my checks to the wrong place, against the terms of my contract.

As Herb Simon pointed out many years ago, and I paraphrase here: "If you can figure out what is the incentive structure of a situation, you are a long way toward understanding what you can do about it".

In my case, I simply cancelled my contract and went my own way.

For some reason there is a massive desire (e.g., incentive) in MSN customer's minds to buy bad stuff, and this fact governs the outcome.  

If enough corporate Internet Users were to stop using MSN's bad stuff, their customers would soon enough notice their target audience's absence and mend their careless ways.

My point is that we should ALL put our money where our mouth is;-)...

The IETF is not in this loop, and cannot have any influence, therefore.
It is simply not the IETF's mission to save the free world from itself.

So, the IETF is not a party to the MSN Follies!  
The market is in control!
So, go talk to the market!

Cheers...\Stef