Subject: RE: TCP/IP Terms

From: "Michel Py" <[email-masked]>
Date: Sun, 6 Oct 2002 16:29:09 -0700

Mastaka / Bill,

>> Michel Py wrote:
>> In terms of design, if you do TCP/IP *only* design, the TCP/IP model
is
>> probably enough. However, the Internet is not only TCP/IP. Carriers,
for
>> example, don't care much if their fiber transports TCP/IP or IPX or
>> voice or video or GigE.

> Masataka Ohta wrote:
> No.
> Anything at or above transport layer is a layer internal to
> end systems and has nothing to do with networking or network
> protocols. Seperation of transport and application layers is
> a overkill for a best effort network, though it may help
> standardize the internal design of end systems such that
> anything supported by kernel belong the transport layer. You
> can check the reality that application and transport areas
> of IETF are now almost identical, though, historically,
> trasnsport area was working on protocols likely to be
> implemented in kernel. In addition, defining a thin transport
> layer may be useful over a hypothetical port-number-aware
> network such as that supporting RSVP. However, forcibly
> defining a session-layer-aware network is a layer violation.

I don't disagree for the upper part of the model, but all the examples I
have used in this thread were about the lower part of the model.

>> Michel Py wrote:
>> And, there are complex multi-protocol networks that a) don't
>> use only TCP/IP and b) would not be able to use the TCP/IP
>> model anyway because it's too simple.

> Bill Cunnigham wrote:
> * Would not be able to use TCP/IP.*
> How can that be changed?

If I had to design a model it would be:

    Michel's           TCP/IP                OSI
      model             model               model
+--------------+  +---------------+  +---+--------------+
!              !  !               !  ! 7 ! Application  !
!              !  !               !  +---+--------------+
! Application  !  ! Application   !  ! 6 ! Presentation !
!              !  !               !  +---+--------------+
!              !  !               !  ! 5 ! Session      !
+--------------+  +---------------+  +---+--------------+
! Transport    !  ! Transport     !  ! 4 ! Transport    !
+--------------+  +---------------+  +---+--------------+
! Network      !  ! Internet      !  ! 3 ! Network      !
+--------------+  +---------------+  +---+------+-------+
! Logical Link !  !               !  !   ! Data ! LLC   !
+--------------+  ! Network       !  ! 2 ! Link +-------+
! Media Access !  ! Interface     !  !   !      ! MAC   !
+--------------+  !               !  +---+------+-------+
! Physical     !  !               !  ! 1 ! Physical     !
+--------------+  +---------------+  +---+--------------+

I understand that people that have used the TCP/IP model don't care much
of what's inside the Network Interface layer, but there is a bunch of
stuff there that could use layering. That's why, short of having my very
own model drawn above, I keep using the OSI one for
explanatory/educational purposes.

Michel.

---

From: "vinton g. cerf" <[email-masked]>
Date: Sun, 06 Oct 2002 22:16:39 -0400

Michel,

your drawing of TCP/IP is NOT the model I used in the design of TCP/IP.

At the time Bob Kahn and I were working on this design, there were
three networks being used to support the Internet: ARPANET, Packet
Radio net and Packet Satellite net. These networks were packet switched
and they had physical and link layers as well as network layers. 

so we had IP/network/link/physical layers 
IP was a layer above the nominal "network" layer.

Things got more complex as routers were implemented that ran IP over
dedicated links rather than servings as gateways between packet nets.
However, even with routers operating at IP layer primarily, there were
lower layer networks such as frame relay, ATM, over which IP operated. 
If there was any confusion, it was that packet radio, arpanet and packet
satellite networks had both layer two and layer three elements while
Frame Relay and ATM tended to be characterized as layer 2 networks.

vint

>If I had to design a model it would be:

Vint Cerf
SVP Architecture & Technology
WorldCom
22001 Loudoun County Parkway, F2-4115
Ashburn, VA 20147
703 886 1690 (v806 1690)
703 886 0047 fax