Subject: Re: Last Call: Using XML-RPC in BEEP to Proposed Standard

From: Ward Harold <[email-masked]>
Date: Thu, 10 Oct 2002 13:08:32 -0500

Timur, my responses to your questions follow:

1. The "uri" attribute associated with a "start" message's "profile"
element is equivalent to an XML namespace name. It is a URI that uniquely
identifies a BEEP profile; it is just an identifier and does not
necessarily point to anything on the Web.

2. The methodCall, methodResponse, and associated parameter encodings are
all defined by the XML-RPC specification: http://www.xmlrpc.com/spec. The
draft explains how to use BEEP to transfer XML-RPC encoded messages between
peers not how to actually do the encoding.

3. Grace and beauty are in the eye of the beholder; regarding brevity it is
no doubt possible to define a more compact encoding, even using XML, but in
this case the XML-RPC authors defined what they defined.

... WkH

                      Timur Shemsedinov
                      <[email-masked]        To:       Ward Harold/Austin/IBM@IBMUS
                      pi.kiev.ua>               cc:       [email-masked]
                                                Subject:  Re: Last Call: Using XML-RPC in BEEP to Proposed Standard
                      10/10/2002 12:08
                      PM
                      Please respond to
                      Timur Shemsedinov

> http://www.ietf.org/internet-drafts/draft-harold-beep-xmlrpc-00.txt
There are some questions concerning xmlrpc and some,
most probably, even beep.

1. How it can work in local networks if IANA is not accessible and
profiles can be received neither from the client nor from the server
of such network? Or they are placed locally, if so why URL refers to
iana.org ? I believe that it works, but how? It is not clearly
documented by BEEP specification and is not considered in
mentioned draft.

  C: <start number='1' serverName='stateserver.example.com'>
  C:     <profile uri='http://iana.org/beep/transient/xmlrpc'>
  C:         <![CDATA[<bootmsg resource='/NumberToName' />]]>
  C:     </profile>
  C: </start>

2. Few examples are given in the document, it is difficult to
get complete understanding of the complex structured
parameters representation.

3. Looking on the following example, any person can have idea,
whether it is impossible to represent a call briefly and
gracefully even using XML?

I: MSG 1 1 . 0 364
I: Content-Type: application/xml
I:
I: <?xml version="1.0"?>
I:   <methodCall>
I:     <methodName>examples.getStateName</methodName>
I:     <params>
I:       <param>
I:         <value><i4>41</i4></value>
I:       </param>
I:     </params>
I:   </methodCall>
I: END

L: RPY 1 1 . 201 100
L: Content-type: application/xml
L:
L: <?xml version="1.0"?>
L:   <methodResponse>
L:     <params>
L:       <param>
L:         <value><string>South Dakota</string></value>
L:       </param>
L:     </params>
L:   </methodRespose>
L: END

--
Best regards,
 Timur                            mailto:[email-masked]

---

From: Timur Shemsedinov <[email-masked]>
Date: Fri, 11 Oct 2002 11:38:47 +0300

Ward,
thanks for explanations and references. I have one more question.
XMLRPC is similar to SOAP in abilities and applications,
as I understand. But on my personal opinion, if to compare,
XMLRPC has much more winning data representation. "Envelope" is
terrible itself. Here question, whether is necessary to have two
realizations of the RPC using XML? I think that it is not profits
integration and compatibility. It seems to me that it is necessary
to seek cooperation between developers for establishing of the
trade-off decision.

---

From: John Stracke <[email-masked]>
Date: Fri, 11 Oct 2002 09:09:40 -0400

Timur Shemsedinov wrote:

>Here question, whether is necessary to have two
>realizations of the RPC using XML?
>  
>
Again, it's not up to the IETF; XML-RPC already exists.  And, in fact, 
it predates SOAP.

-- 
/===============================================================\
|John Stracke      [email-masked]                      |
|Principal Engineer|http://www.centivinc.com                    |
|Centiv            |My opinions are my own.                     |
|===============================================================|
|If you're going to walk on thin ice, you might as well *dance*!|
\===============================================================/