Subject: Re: STRN (was Re: Internet Draft Guidelines Require Precise Formatting?)

From: "Sabahattin Gucukoglu" <[email-masked]>
Date: Sat, 19 Apr 2003 00:55:38 +0100

On 18 Apr 2003 at 13:00, Alexey Melnikov pronounced thusly:

> > Hi all,
> >
> > I at some point in the (near, hopefully) future wish to submit an
> > internet draft - STRN, ESMTP extension for secure client-server role
> > exchange
> 
> On a slightly different topic touched by your email: check ATRN
> (authenticated TURN) extention before you decide to right STRN. I can try
> to find the RFC number for it if you are interested.

If by some miraculous chance you should prove luckier than I. :-(  So far 
M$ are the only folks I've seen implement ATRN, whatever the blasted thing 
is.  I only came across it accidentally when my server communicated with 
an Exchange server and it was listed in their ESMTP capabilities, and I 
have not found an I-D or RFC.

Now may be a good time anyway to explain my ideas in brief... STRN does in 
fact appear to have significant likeness to this ATRN, with the idea being 
that STRN should provide a mechanism for specification of authentication 
method by which a change of role can occur, after which the authentication 
procedure is begun, independantly of, but not unlike, any other form of 
ESMTP authentication used for mail delivery (RFC3554).  Secure doesn't 
represent confidentiality in this context, it is simply meant as a more 
solidly foolproof turn without disadvantages commonly presented by ETRN.  
It may therefore end up as an updating RFC rather than a complete 
specification.

Yes, if you do find the RFC please let me know where it is.  

> Cheers,
> Alexey Melnikov

Cheers,
Sabahattin

- -- 

Thought for the day:
    Concerto (n): a fight between a piano and a pianist.

Latest PGP Public key?  Click:
<mailto:[email-masked]>
and send that message as is.

Sabahattin Gucukoglu
Phone: +44 (0)20 7,502-1615
Mobile: +44 (0)7986 053399
http://www.sabahattin-gucukoglu.com/
E-mail or MSN Messenger: <[email-masked]>

---

From: Chris Newman <[email-masked]>
Date: Fri, 18 Apr 2003 18:55:12 -0700

<http://www.apps.ietf.org/rfc/rfc2645.html>

                - Chris

begin quotation by Sabahattin Gucukoglu on 2003/4/19 0:55 +0100:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> -----BEGIN PGP SIGNATURE-----
> Version: PGP 8.0 -- QDPGP 2.70
> Comment: Previous public key for ID <[email-masked]>
> revoked due to invalidated primary address.
>
> iQA/AwUBPqCQeyNEOmEWtR2TEQJixwCfVW6VzJQH8pOTSl0yzf+F2uTlregAnR3f
> DthhaT4rMt4S7+a+N2EKL6cS
> =1XIC
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> This message was passed through [email-masked], which is
> a sublist of [email-masked]. Not all messages are passed. Decisions on what to
> pass are made solely by Raffaele D'Albenzio.