Subject: Re: Thinking differently about the site local problem (was: RE: site local addresses (was Re: Fw: Welcome to the InterNAT...))

From: John C Klensin <[email-masked]>
Date: Mon, 31 Mar 2003 14:37:52 -0500

--On Monday, 31 March, 2003 09:01 -0800 Bill Manning 
<[email-masked]> wrote:

> 	Is may be worth noting that RIRs have -NEVER- made
> presumptions 	on routability of the delegations they make.

I believe that, although I remember some arguments within ARIN 
back when I was on the AC about whether it was legitimate or 
rational to make allocations that were believed to be 
unroutable.   But I've gotten several private notes that lead me 
to believe that a lot of the community doesn't believe this or, 
more specifically, believes that everyone will fall into line 
and route any delegation that an RIR makes directly and, hence, 
that any RIR allocation will, de facto, become routable.

     john

---

From: Bill Manning <[email-masked]>
Date: Tue, 1 Apr 2003 11:27:34 -0800 (PST)

% 
% 
% --On Monday, 31 March, 2003 09:01 -0800 Bill Manning 
% <[email-masked]> wrote:
% 
% > 	Is may be worth noting that RIRs have -NEVER- made
% > presumptions 	on routability of the delegations they make.
% 
% I believe that, although I remember some arguments within ARIN 
% back when I was on the AC about whether it was legitimate or 
% rational to make allocations that were believed to be 
% unroutable.   But I've gotten several private notes that lead me 
% to believe that a lot of the community doesn't believe this or, 
% more specifically, believes that everyone will fall into line 
% and route any delegation that an RIR makes directly and, hence, 
% that any RIR allocation will, de facto, become routable.
% 
%      john

	Mass Delusion is just that. Witness the 69/8 debacle.
	presumptions of routability are in the eye of the 
	router configuration.

--bill
Opinions expressed may not even be mine by the time you read them, and
certainly don't reflect those of any other entity (legal or otherwise).

---

From: Jaap Akkerhuis <[email-masked]>
Date: Tue, 01 Apr 2003 21:52:20 +0200

During this discussion I've seen references to the "69/8 debacle".
Can anybody explain what the debacle is/was? Is this a magic phrase
for real insiders? Is is something that happened only on a local
net? If not, why don't you explain to the rest of the world? What
IS the argument hinted to with mentioning the "69/8 debacle".

	jaap

---

From: Bill Manning <[email-masked]>
Date: Tue, 1 Apr 2003 12:01:03 -0800 (PST)

%     	Mass Delusion is just that. Witness the 69/8 debacle.
%     
% During this discussion I've seen references to the "69/8 debacle".
% Can anybody explain what the debacle is/was? Is this a magic phrase
% for real insiders? Is is something that happened only on a local
% net? If not, why don't you explain to the rest of the world? What
% IS the argument hinted to with mentioning the "69/8 debacle".
% 
% 	jaap

	So sorry. Its an ARIN "insider" story.
	The IANA recently delegated 69.0.0.0/8 to ARIN.
	ARIN started subdelegations to its members from this space.
	A number of ISPs, some of whom are recognized as significant
	transit providers, had this address space filtered, e.g.
	drop all packets in this prefix range.  ARINs members 
	fussed and asked ARIN for routable space.  ARIN reiterated
	that the address blocks they delegate have no inherent
	routability.  Members continued to fuss and argue that
	things like major search engines and TLD/root nameservers
	be periodically renumbered into "new" ranges to encourage
	ISPs to adjust their filters. 

	This is not the first time, nor will it be the last that
	ISPs are unwilling to do for themselves. Unfortunately, the
	RIRs can not enforce routablity, -UNLESS- every ISP 
	of their own freewill and volition, transfer all circuits,
	routers and other IP transmission infrastructure to the
	RIRs, thus giving the RIRs total control of both the
	addressing and transmission of all IP datagrams.

--bill

---

From: Randy Bush <[email-masked]>
Date: Tue, 1 Apr 2003 12:31:06 -0800

> IS the argument hinted to with mentioning the "69/8 debacle".

idiot isps who configured route filters but did not bother to maintain
them.  darwin at work.  the subject is uninteresting, as the study
of stupidity is an exceedingly target-rich environment.

randy

---

From: "Eric A. Hall" <[email-masked]>
Date: Tue, 01 Apr 2003 17:26:45 -0600

on 3/31/2003 11:01 AM Bill Manning wrote:
> 	Is may be worth noting that RIRs have -NEVER- made presumptions
> 	on routability of the delegations they make.

Probably more accurate to say that they have never guaranteed routability.

They make all kinds of presumptions about routability. One of the reasons
they claim to refuse (say) private /24 is that it isn't going to be widely
routable. By default, this implies that larger delegations are presumed to
be routable, or else they wouldn't assign them either.

-- 
Eric A. Hall                                        http://www.ehsco.com/
Internet Core Protocols          http://www.oreilly.com/catalog/coreprot/

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 02 Apr 2003 08:27:19 +0200

> of stupidity is an exceedingly target-rich environment.

for those of us who are endlessly fascinated by watching evolution in 
action - what was the previous usage of 69/8 that led to those filters 
being installed?

(parenthesis: similar things have reportedly happened to people using .info 
for email - there turns out to be a number of MTAs in the world who have 
hardcoded all the non-2-letter TLDs, assuming "there will be no more", and 
routinely toss mail from/to the newer ones. They, too, deserve the pain 
they get; unfortunately they, like the route filterers, don't get all the 
pain they cause.)

                  Harald

---

From: Pekka Savola <[email-masked]>
Date: Wed, 2 Apr 2003 09:57:14 +0300 (EEST)

> action - what was the previous usage of 69/8 that led to those filters 

No such use.

Some folks just consider blocking *all* unallocated address ranges a good
idea to try reduce DoS attacks which forge addresses and the like.

An incredibly bad idea if you don't maintain them properly, really..

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: John C Klensin <[email-masked]>
Date: Wed, 02 Apr 2003 07:55:05 -0500

--On Wednesday, 02 April, 2003 08:27 +0200 Harald Tveit 
Alvestrand <[email-masked]> wrote:

>>...
>> idiot isps who configured route filters but did not bother to
>> maintain them.  darwin at work.  the subject is
>> uninteresting, as the study of stupidity is an exceedingly
>> target-rich environment.
>
> for those of us who are endlessly fascinated by watching
> evolution in action - what was the previous usage of 69/8 that
> led to those filters being installed?
>
> (parenthesis: similar things have reportedly happened to
> people using .info for email - there turns out to be a number
> of MTAs in the world who have hardcoded all the non-2-letter
> TLDs, assuming "there will be no more", and routinely toss
> mail from/to the newer ones. They, too, deserve the pain they
> get; unfortunately they, like the route filterers, don't get
> all the pain they cause.)

See draft-klensin-name-filters-00.txt for a longer explanation 
of this issue and some cases other than mail-tossing.   I'm 
working on a version that fills in the empty sections and 
clarifies anything that I can find that isn't clear;  comments 
and suggestions welcome.

The evolutionary implications of this one are, however, somewhat 
less clear than those of the 69/8 case.  In the 69/8 case, the 
ISPs who did the filtering were ultimately subject to attack by 
their own customers who, presumably, would sooner or later go 
elsewhere (or cause other harm to the ISP) if the problem wasn't 
fixed.  An MTA-operator whom I'm paying to receive and deliver 
my mail is (or should be) subject to roughly the same pressures. 
But, in the TLD case, the victims are mostly those who have 
registered in the new domains and the help desks of registrars 
and unrelated servers, neither of whom have significant leverage 
on the offending ISPs in the non-MTA cases.

It might also be part of a good case for not creating new gTLDs 
except where they are needed for technical reasons (pretty much 
a null set), but please hold any discussion on that subject on 
the whining-at-ICANN list of your choice.  Spending excessive 
time on that one of course leads to another example of evolution 
in action :-(.

    john