Subject: RE: myth of the great transition (was US Defense Department forma lly adopts IPv6)

From: "Christian Huitema" <[email-masked]>
Date: Tue, 24 Jun 2003 05:24:47 -0700

>> Aren't Microsoft already "standardizing" this with their Universal Plug and
>> Play (UPnP) architecture?
>
> That's just midcom, which the IETF is standardizing.  We
> started before they did but Microsoft got there first and
> worst (there's even midcom language in their documents).  So
> that's something that was started in the IETF and
> expropriated.  Note that it still handles incoming
> connections pretty badly.

The UPNP "Internet Gateway Device" working group and the MIDCOM WG effort started at about the same time, but the UPNP specification was published about 2 years ago, while MIDCOM is not quite finished yet. Looks like an interesting case study for the "problem statement" working group... 
 
I don't quite get the point on the handling of incoming connections -- basically, the UPNP/IGD specification has functions for reserving port mappings, that allow a host behind a NAT to listen on an external port number. The host can definitely receive incoming connections.
 
The UPNP/IGD approach has limitations: it is designed for a "home  network" rather than an enterprise network, and it will not work if there are two "stacked NAT". However, it does solve a large fraction of the problem.
 
By the way, while Microsoft certainly contributed to the fundation of the UPNP Forum, the UPNP/IGD is not exactly a Microsoft specification.
 
-- Christian Huitema

---

From: Keith Moore <[email-masked]>
Date: Tue, 24 Jun 2003 12:03:08 -0400

> The UPNP "Internet Gateway Device" working group and the MIDCOM WG effort
> started at about the same time, but the UPNP specification was published
> about 2 years ago, while MIDCOM is not quite finished yet. Looks like an
> interesting case study for the "problem statement" working group... 

producing bad stuff more quickly is not what I would regard as a useful goal.