Subject: Re: myth of the great transition (was US Defense Department forma lly adopts IPv6)

From: Bob Braden <[email-masked]>
Date: Thu, 19 Jun 2003 10:37:48 -0700 (PDT)

*> 
  *> So, on the one hand, we have the actual behavior of millions of people.
  *> On the other hand we have Keith Moore's opinion about what they ought
  *> to prefer. I don't have any trouble figuring out which one I believe.
  *> 
  *> -Ekr
  *> 

Erik,

Errr, let's see if I understand your argument.  You advocate boxes that
have the effect of disallowing a large class of services.  We all
understand that such boxes are in fact in heavy use in today's
Internet, so there is a large set of users who cannot use any of the
services from this class.  So, your argument is that you can
demonstrate that users don't want any of these blocked services,
because they aren't using them today.

Huh?

Repeating this argument endlessly and fervently does not make
it any less a contradiction.  Can we move on to something more useful?

Bob Braden

---

From: "Theodore Ts'o" <[email-masked]>
Date: Thu, 19 Jun 2003 14:51:37 -0400

On Thu, Jun 19, 2003 at 11:10:03AM -0700, Eric Rescorla wrote:
> Users aren't physically handcuffed to their Internet connections.
> They have choices as to who to purchase connectivity from. Those
> users, if they chose, could purchase connectivity with static IP
> addresses and no NAT. They by and large don't do so. Therefore, it's
> reasonable to conclude that they don't in fact want them. Or, to put
> it more precisely, that the marginal disutility of getting rid of NAT
> exceeds the marginal utility of these new services.

And to make things even more specific, in the suburb of Boston where I
live, I have a couple of different options:

$230/month	DSL.net 400kbps SDSL, with 30 IP addresses (/28)
$ 99/month	Speakeasy.net, 768kbps down, 384kbps up, with 2 
			static addresses
$ 44/month	Comcast 640kbps down, 256 kbps up, with dynamic addresses

So 30 static IP addresses, with a slower service, is over *five* times
more expensive, and over twice as expensive as faster service with
only 2 static IP addresses.  

As much as I hate NAT, from an aesthetic perspective, using two static
IP addresses and a NAT box was the expedient solution.  We could I
suppose blame the ISP's for their charging policies, but these
economic pressures are going to drive people in certain directions,
and as Ekr as pointed out, saying that people are either misinformed
or non-rationale isn't going to help matters.

(Put another way, sure, Voice over IP would be nice.  But if I have to
pay 2x or 5x a month to an ISP in order to not have a NAT box so I can
use VoIP, wouldn't it be much more rational to stick with a wired POTS
line?)

I'm not defending the current system; I certainly wish I could have a
/22 all to myself, and not have to play NAT games.  (And I'm kicking
myself for not simply registering one back when they were essentially
free for the asking.)  But the reality is that NAT boxes are here to
stay, and we have lost that battle for IPv4.  It would be nice not to
lose that battle for IPv6, but I suspect the jury is still out on that
point; and burying our heads in the sand about why people chose NAT's
is not going to help us assure a NAT-free world for IPv6.

						- Ted

---

From: Michael Thomas <[email-masked]>
Date: Thu, 19 Jun 2003 11:59:39 -0700 (PDT)

Eric Rescorla writes:
 > P.S. And btw, I'm not advocating NAT. What I'm advocating is that
 > we stop behaving as if we think that anyone who uses NAT is obviously
 > an idiot.

I don't think that I've seen anybody say that.
Most people who use NAT have no clue one way or
the other about NAT any more than they possess
clue about, oh say, 8086 instruction sets on
modern day processors. They aren't "idiots"
because they aren't claiming any (deep) knowledge
about the subject. They're merely ignorant and
just trying to get by with limited knowledge.

However, it's quite a leap to go from general
ignorance about the inner workings of computers
and networks to divining user's True Intents based
on their purchasing habits. I doubt that many
people go out with the intent of getting cancer
when they buy a pack of ciggies, but that is often
the end result. And people today have far more
clue about smoking than they do about NAT's. 
People use NAT's for all kinds of perfectly
good reasons (I agree with Noel's analysis too,
btw), but it doesn't mean that cancer isn't an end
result there too. Voice is a great example of the
malignant chickens coming home to roost.

So I just don't see what the value is in
introducing the Voice of the Masses as indicative
of anything one way or the other about NAT. They
have requirements, and NAT's provide solutions for
some of those requirements, in much the same way
that smoking provides teenagers with a solution to
the requirement to be cool. Our job, however, is
to look at the *all* of the requirements and see
if they are best served with a given set of
technology. That's because we're paid to
understand this stuff and look out for the long
term health of the net. Which isn't to say that
we're infallible or incapable of indulging in
religious fervor, but we're at least semi informed
unlike the great unwashed masses.

Thus, I think it's *far* more productive to
actually limit the arguments to not whether NAT is
good or bad, but what requirements are we not
fulfilling which is leading people to NAT's as an
acceptible alternative (cf Noel's post). Some
people have obviously throw in the towel and would
like to have NAT's/ALG's to replace or augment the
end to end principle. Others aren't ready to give
up on end to end. I think it's premature to
declare the latter dead though. Some of the
requirements have simply not been hashed out to
any great degree. Fred's draft on operational
renumbering is a great example of something for
which there is more handwaving on our part than
actual experience. That doesn't mean that it's a
dead end though. All it means that it's something
that still needs to be dealt with. After all of
that is done can we actually have an intelligent
argument about what the right path is. This is,
IMO, quite literally a race.

	   Mike

---

From: Eric Rescorla <[email-masked]>
Date: 19 Jun 2003 11:10:03 -0700

>   *> to prefer. I don't have any trouble figuring out which one I believe.
Eric.

> it any less a contradiction.  Can we move on to something more useful?
Instead, maybe we should start by you taking the time to understand 
the argument properly.

Now, the situation is a little different when we're talking about
people who are on corporate networks, but I view the corporation,
not the users, as the customer here and so the same logic applies.
If the corporation wished the users to have those services enough
to disable NAT, then they would do so.

-Ekr

-- 
[Eric Rescorla                                   [email-masked]]
           Web Log: http://www.rtfm.com/movabletype