Subject: US Defense Department formally adopts IPv6

From: Richard Shockey <[email-masked]>
Date: Fri, 13 Jun 2003 20:47:34 -0400

Significant news of note..

Vendors must be compliant by Oct 1

http://www.washingtonpost.com/wp-dyn/articles/A55558-2003Jun13.html?nav=hptoc_tn

Richard Shockey, Senior Manager, Strategic Technology Initiatives
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
Voice +1 571.434.5651 Cell : +1 703.593.2683,  Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or <mailto:richard.shockey(at)neustar.biz>
  <http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

---

From: Randy Bush <[email-masked]>
Date: Fri, 13 Jun 2003 18:45:20 -0700

hyperbole alert!

> http://www.washingtonpost.com/wp-dyn/articles/A55558-2003Jun13.html?nav=hptoc_tn

that's not what is says at all.  what is says is

"The evolution toward the new standard must be taken into account for all
purchases starting Oct. 1"

which, if you have played in that game, means little beyond powerpoint
and promises.

randy

---

From: "Anthony Atkielski" <[email-masked]>
Date: Sat, 14 Jun 2003 04:15:13 +0200

Didn't the DoD officially adopt Ada about 20 years ago?

----- Original Message -----
From: "Richard Shockey" <[email-masked]>
To: <[email-masked]>
Sent: Saturday, June 14, 2003 02:47
Subject: US Defense Department formally adopts IPv6

> Vendors must be compliant by Oct 1
http://www.washingtonpost.com/wp-dyn/articles/A55558-2003Jun13.html?nav=hpto
c_tn

---

From: Dave Crocker <[email-masked]>
Date: Fri, 13 Jun 2003 20:02:54 -0700

Richard,

RS> Significant news of note..

RS> Vendors must be compliant by Oct 1

RS> http://www.washingtonpost.com/wp-dyn/articles/A55558-2003Jun13.html?nav=hptoc_tn

So, let's see.  The guys says that the problems with IPv4 are:

     1) security

     2) data loss
   
     3) telephone-like numbering

and that IPv6 will fix them.

Are there enhancements in IPv6 that we haven't been hearing about?

d/
--
 Dave Crocker <mailto:[email-masked]>
 Brandenburg InternetWorking <http://www.brandenburg.com>
 Sunnyvale, CA  USA <tel:+1.408.246.8253>, <fax:+1.866.358.5301>

---

From: Margaret Wasserman <[email-masked]>
Date: Sat, 14 Jun 2003 08:11:40 -0400

>purchases starting Oct. 1"

The U.S. DoD's actual press release (included below) says:

"A key element of the transition minimizes future transition
costs by requiring that, starting in October 2003, all network
capabilities purchased by DoD be both IPv6-capable and
interoperable with the department's extensive IPv4 installed
base."

I have not yet seen the actual policy memorandum -- I'm
still trying to get a copy.  So, I'm not sure how "IPv6-
capable" is defined.

Margaret

NEWS RELEASE from the United States Department of Defense
No. 413-03
IMMEDIATE RELEASE
Jun 13, 2003
(703)697-5131(media)
(703)428-0711(public/industry)

Next-Generation Internet Protocol to Enable Net-Centric Operations

Implementation of the next-generation Internet protocol that will
bring the Department of Defense closer to its goal of net-centric
warfare and operations was announced today by John P. Stenbit,
assistant secretary of defense for networks and information
integration and DoD chief information officer.

The new Internet protocol, known as IPv6, will facilitate integration
of the essential elements of DoD's Global Information Grid -- its
sensors, weapons, platforms, information and people. Secretary Stenbit
is directing the DoD-wide transition.

The current version of the Internet's operating system, IPv4, has been
in use by DoD for almost 30 years. Its fundamental limitations, along
with the world-wide explosion of Internet use, inhibit net-centric
operations. IPv6 is designed to overcome those limitations by expanding
available IP address space, improving end-to-end security, facilitating
mobile communications, enhancing quality of service and easing system
management burdens.

Enterprise-wide deployment of IPv6 will keep the warfighter secure and
connected in a fast-moving battlespace, Secretary Stenbit said. Achievement
of net-centric operations and warfare depends on effectively implementing
the transition.

Secretary Stenbit signed a policy memorandum on June 9 that outlines a
strategy to ensure an integrated, timely and effective transition. A key
element of the transition minimizes future transition costs by requiring
that, starting in October 2003, all network capabilities purchased by
DoD be both IPv6-capable and interoperable with the department's extensive
IPv4 installed base.

[Web Version: http://dod.mil/releases/2003/nr20030613-0097.html]
-- News Releases: http://www.defenselink.mil/news/releases.html
-- DoD News: http://www.defenselink.mil/news/dodnews.html
-- Subscribe/Unsubscribe:
http://www.defenselink.mil/news/dodnews.html#e-mail
-- Today in DoD: http://www.defenselink.mil/today

---

From: Vernon Schryver <[email-masked]>
Date: Sat, 14 Jun 2003 07:36:45 -0600 (MDT)

> From: Margaret Wasserman <[email-masked]>

> ...

> ...

We're using TCP/IP today, despite most of a decade of GOSIP
requirements requiring the switch to the ISO OSI protocol suite.

Vernon Schryver    [email-masked]

---

From: John C Klensin <[email-masked]>
Date: Sat, 14 Jun 2003 09:43:59 -0400

While this type of procurement announcement is certainly not bad 
news for IPv6 --almost independent of how the details are 
interpreted-- anyone planning to get really excited about it 
(positively or negatively) should examine RFC 942 and related 
documents and consider the impact of a previous time the DoD 
made one of these sweeping policy/procurement announcements 
related to the Internet.

      john

--On Saturday, 14 June, 2003 08:11 -0400 Margaret Wasserman 
<[email-masked]> wrote:

>> "The evolution toward the new standard must be taken into
>> account for all purchases starting Oct. 1"
>
> Implementation of the next-generation Internet protocol that
> will bring the Department of Defense closer to its goal of
> net-centric warfare and operations was announced today by John
> P. Stenbit, assistant secretary of defense for networks and
> information integration and DoD chief information officer.
>
> The new Internet protocol, known as IPv6, will facilitate
> integration of the essential elements of DoD's Global
> Information Grid -- its sensors, weapons, platforms,
> information and people. Secretary Stenbit is directing the
> DoD-wide transition.
>
> The current version of the Internet's operating system, IPv4,
> has been in use by DoD for almost 30 years. Its fundamental
> limitations, along with the world-wide explosion of Internet
> use, inhibit net-centric operations. IPv6 is designed to
> overcome those limitations by expanding available IP address
> space, improving end-to-end security, facilitating mobile
> communications, enhancing quality of service and easing system
> management burdens.
>
> Enterprise-wide deployment of IPv6 will keep the warfighter
> secure and connected in a fast-moving battlespace, Secretary
> Stenbit said. Achievement of net-centric operations and
> warfare depends on effectively implementing the transition.
>
> Secretary Stenbit signed a policy memorandum on June 9 that
> outlines a strategy to ensure an integrated, timely and
> effective transition. A key element of the transition
> minimizes future transition costs by requiring that, starting
> in October 2003, all network capabilities purchased by DoD be
> both IPv6-capable and interoperable with the department's
> extensive IPv4 installed base.
>
> [Web Version:
> http://dod.mil/releases/2003/nr20030613-0097.html] -- News
> Releases: http://www.defenselink.mil/news/releases.html -- DoD
> News: http://www.defenselink.mil/news/dodnews.html --
> Subscribe/Unsubscribe:

---

From: Richard Shockey <[email-masked]>
Date: Sat, 14 Jun 2003 11:05:07 -0400

>which, if you have played in that game, means little beyond powerpoint

perhaps but you read the transcript

http://www.dod.gov/transcripts/2003/tr20030613-0274.html

---

From: Paul Ebersman <[email-masked]>
Date: Fri, 13 Jun 2003 20:04:10 -0700

richard> Vendors must be compliant by Oct 1

richard> http://www.washingtonpost.com/wp-dyn/articles/A55558-2003Jun13.html?nav=hptoc_tn

For those of us around to remember ADA:

  phase 1: *ALL* coding for DOD/GOv must be done in ADA

  phase 2: Gee, no compliant ADA compilers and not enough ADA
    coders. Ok, Must be ADA (or C).

  phase 3: What's ADA?

Let's also stroll down memory lane and think about TP4/CLNS with
CMIP. How many governments are running it as their exclusive backbone?

>From the article above:

  "The evolution toward the new standard must be taken into account for
  all purchases starting Oct. 1, Stenbit, assistant secretary of defense
  for networks and information integration, told the armed services in a
  memo."

"must be taken into account"

"Gee, we can't buy what we need in IPv6 only. Guess we'll still use IPv4
and use IPv6 where it works."

The more things change...