Subject: RE: myth of the great transition (was US Defense Department forma lly adopts IPv6)

From: "Putzolu, David" <[email-masked]>
Date: Wed, 18 Jun 2003 15:21:03 -0700

The IAB has talked about NAT.  A WG has produced a bunch of
RFCs about NAT.  NAT is very widely deployed and comes in
10 different flavors.  NAT has a bunch of architectural 
ugliness and technical problems.  So?

How about some lemonade?  An Internet draft that says 
something new about NATs would be a lot more helpful than 
rehashing the same old arguments.

Cheers,
David

> I think we often end up talking about NATs because NATs are a symptom
> that our architecture has fundamental unsolved problems that we so far
> have failed to address (or that the market has failed to adopt, but
> it's closer to the former, I think.)
> 
> The SPAM problem is another one of those recurring discussions that
> never seems to be resolved, for similar reasons.
> 
> If we had a workable solution in hand for either problem, 
> there would be
> little point in our talking about them.  As it is, we keep revisiting
> them in the hope that some new idea will emerge, or that some bit of
> denial about those problems will go away.
> 
> Keith
>

---

From: Keith Moore <[email-masked]>
Date: Wed, 18 Jun 2003 18:44:08 -0400

> RFCs about NAT.  

the WG ended up being full of NAT vendors trying to legitimize NAT
(and grossly exceeding the bounds of their charter in the process)

> rehashing the same old arguments.

for one attempt to make lemonade, see RFC 3056.
for another, see draft-ietf-ngtrans-shipworm-08.txt
for another, see draft-moore-nat-tolerance-recommendations-00.txt
(it's expired - look in http://www.cs.utk.edu/~moore/I-D/ )

but looking for a way to magically turn NATs into something that works
well that doesn't require both significant infrastructure investment and
significant changes to the endpoints and apps is tantamount to wishing
for magic pixie dust.

Keith