Subject: RE: [Sipforum-discussion] RE: Collecting media statistics for SIP calls?

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Tue, 2 Nov 2004 12:56:06 +0200

Henry,

I believe that's a perception issue, and I would invite you and other folks to a more attentive read of the RAQMON documents. They are actually in WGLC, so it's a good moment, and comments are very welcome. 

RAQMON has nothing to do with network elements like routers or similar. Endpoints report in real-time information about the QoS of applications to RAQMON collectors, which expose an SNMP MIB interface (the RAQMON MIB). RAQMON supports the concepts of concurrent applications, session information, and session history - which were at the core of the original question. It is complementary to other performance monitoring methods like RTCP-XR, which focuses on media monitoring for IP telephony. 

Regards,

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Henry Sinnreich
> Sent: 01 November, 2004 8:00 PM
> To: Siddiqui, Anwar A (Anwar); Romascanu, Dan (Dan); 
> [email-masked]; 'Madabhushi Pramod'; 
> [email-masked]; 
> [email-masked]; [email-masked]
> Subject: RE: [Sipforum-discussion] RE: Collecting media 
> statistics for SIP calls?
> 
> 
>  Folks,
> 
> >Thats what RAQMON doesin a media gnostioc fashion.
> 
> RAQMON is an excellent approach for network elements
> 
> The media statistics for SIP calls are intended at the 
> application level in
> endpoints, such as when using an Instant Messenger client for 
> voice or a
> soft phone, or a SIP phone, or a game with VoIP. 
> 
> Let's not be dogmatic and force techniques that have been designed for
> network elements such as routers, gateways or servers on to 
> the application
> level in endpoints, where many good practical reasons have 
> shown the RTCP
> extensions to be the better approach. Live and let live!
> 
> Thanks, Henry
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of 
> Siddiqui, Anwar
> A (Anwar)
> Sent: Monday, November 01, 2004 8:01 AM
> To: Romascanu, Dan (Dan); [email-masked]; Madabhushi Pramod;
> [email-masked]; 
> [email-masked];
> [email-masked]
> Subject: [Sipforum-discussion] RE: Collecting media statistics for SIP
> calls?
> 
> Like you point out its not SIP specific but there are certain 
> aspects of SIP
> that we need to take care of and RAQMON does that. let me 
> clarify; Since it
> is SIP the session monitoring is media agnostic and need to 
> accomodate that.
> 
> Thats what RAQMON doesin a media gnostioc fashion.
> Voice Over IP, Video over IP or Fax over IP and many other 
> apps fit into the
> Framework. See it helps you.
> 
> Since it is in WG LAst call, would be very happy to see what 
> kind of needs
> you have and ensure that it serves the purpose.
> 
> Anwar
> 
> -----Original Message-----
> From: Romascanu, Dan (Dan)
> Sent: Monday, November 01, 2004 2:36 AM
> To: [email-masked]; Madabhushi Pramod;
> [email-masked];
> [email-masked]; [email-masked]
> Cc: Siddiqui, Anwar A (Anwar)
> Subject: RE: Collecting media statistics for SIP calls?
> 
> 
> I agree. This is not a SIP domain specific issue. See my 
> previous answer
> pointing to the real-time application QoS monitoring (RAQMON) 
> work in the
> RMON MIB WG. 
> 
> Regards,
> 
> Dan
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On 
> > Behalf Of Thomas Gal
> > Sent: 31 October, 2004 11:00 PM
> > To: 'Madabhushi Pramod'; 
> > [email-masked]; 
> > [email-masked]; [email-masked]
> > Subject: RE: Collecting media statistics for SIP calls?
> > 
> > 
> > 	I don't think that's really a SIP domain issue, though 
> > this may have
> > been adressed somewhere that I'm not aware of. 
> > 	If you're using RTP to carry the audio than these statistics are
> > derived from the RTP stream in the context of the sender 
> > (with you being the
> > receiver) and the sender sends SR (Sender Report) RTCP packets with
> > interarrival jitter included. Packet count, fraction lost, 
> > and cumulative
> > number of packets lost are also transmitted in these packets. 
> > Latency would
> > probably be derived from the NTP timestamp if anything and is 
> > not directly
> > addressed in RTP to my knowledge. So if you wanted this data 
> > after the fact
> > the server would have to maintain that information, and it 
> > would probably be
> > a query at the application level, not really anything to do 
> with SIP.
> > 
> > -Tom
> > 
> > [email-masked]  
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] On 
> > > Behalf Of Madabhushi Pramod
> > > Sent: Friday, October 29, 2004 4:09 PM
> > > To: [email-masked]; 
> > > [email-masked]; [email-masked]
> > > Subject: Collecting media statistics for SIP calls?
> > > 
> > > Is there any way by which I call query a SIP endpoint for 
> > > media statictics after call termination. I would like to know 
> > > details like Jitter, latency, packet loss, packets received, 
> > > packets sent etc.
> > > 
> > > Thanks in advance.
> > > 
> > > Pramod Madabhushi
> > > ShoreTel communications.
> > > 
> > > =====
> > > Pramod Madabhushi
> > > email: [email-masked],
> > >        [email-masked]
> > > Phone:001-408-204-8077
> > > 
> > > 
> > > 		
> > > __________________________________
> > > Do you Yahoo!?
> > > Y! Messenger - Communicate in real time. Download now. 
> > > http://messenger.yahoo.com
> > > 
> > > _______________________________________________
> > > Ietf mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/ietf
> > > 
> > 
> > 
> > _______________________________________________
> > Ietf mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ietf
> > 
> ------
> To unsubscribe from the Sipforum-discussion mailing list visit
> https://mbox.su.se/mailman/listinfo/sipforum-discussion
> 
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Madabhushi Pramod <[email-masked]>
Date: Tue, 2 Nov 2004 12:18:05 -0800 (PST)

I am one more question on SIP REGISTER mechanism.

1) The phone sends REGISTER to say server1. Can
register1 send 302 response to the phone asking the
phone to register with server2?

2) Can sip server force the phone to re-register?
Meaning, can the server1 ask the phone to register
with a new server2?

Thanks
Pramod

--- "Romascanu, Dan (Dan)" <[email-masked]> wrote:

> Henry,
> 
> I believe that's a perception issue, and I would
> invite you and other folks to a more attentive read
> of the RAQMON documents. They are actually in WGLC,
> so it's a good moment, and comments are very
> welcome. 
> 
> RAQMON has nothing to do with network elements like
> routers or similar. Endpoints report in real-time
> information about the QoS of applications to RAQMON
> collectors, which expose an SNMP MIB interface (the
> RAQMON MIB). RAQMON supports the concepts of
> concurrent applications, session information, and
> session history - which were at the core of the
> original question. It is complementary to other
> performance monitoring methods like RTCP-XR, which
> focuses on media monitoring for IP telephony. 
> 
> Regards,
> 
> Dan
> 
> 
> 
=== message truncated ===

=====
Pramod Madabhushi

__________________________________ 
Do you Yahoo!? 
Check out the new Yahoo! Front Page. 
www.yahoo.com