Subject: RE: IPv4 consumption statistics and extrapolations

From: "Christian Huitema" <[email-masked]>
Date: Sat, 6 Nov 2004 17:15:15 -0800

By the way, I must apologize. I had a bug in the spreadsheet that I used, and the numbers that I quoted are goofy. The consumption did increase during the last year, but not quite that fast. Let's say that, depending on which number you pick, the consumption per year is between 4 and 10 blocks, which means an exhaustion in 10 to 15 years if the rates continue. But it also mean that we are de facto in the upper size of the S curve, because we have passed the 50% capacity point.

________________________________________
From: Soliman, Hesham [mailto:[email-masked]] 
Sent: Saturday, November 06, 2004 3:11 PM
To: Christian Huitema; Bob Braden; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: IPv4 consumption statistics and extrapolations

I think Christian made very important points. 
I'd like to add one point that I'm sure will sound like a broken record to some 
people. Mobile mobile mobile! There are more mobile devices today than IPv4
can handle, period. Everyone is using NATs to build their mobile networks. The question
here is will NATs survive the types of services that operators want to provide? 
>From where I'm looking, the problems are profound and extremely difficult to solve. 
 
I think the reason this hasn't been more widely understood is that we're still not close
to seeing those mobile peer to peer services over IP. But when that happens (no speculation
from me here), I think operators will realise what they're in for. This is especially true 
for large operators.
 
So, there is more to this than simply looking at the remaining address space and 
the rates of allocation.
 
Hesham
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Christian Huitema
Sent: Saturday, November 06, 2004 5:06 PM
To: Bob Braden; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: IPv4 consumption statistics and extrapolations
> Some 10 years ago, every IETF plenary meeting had a soothsayer session,
> projecting how soon we would run out of IPv4 addresses.  Has anyone
> looked to see how today's data extrapolates from the predictions then?
> Was it as "S" curve, after all??
There are two kinds of S curves, depending on what creates the asymptote. You may have an S curve that flattens when everybody is served (e.g. everybody on earth has a TV set), and another that flattens when the resource is exhausted (e.g. the last cod has been fished). Whether the address allocation falls in one or the other category will certainly be debated...
 
As for extrapolating IANA assignment of /8 addresses, it is an interesting game. The data is available for everybody to look at http://www.iana.org/assignments/ipv4-address-space. If you sort allocations by date, you see three phases:
 
- an initial allocation phase that ends in May 1993 when addresses start to be allocated by RIR using the CIDR policy. At the end of May 93, 94 prefixes are allocated or otherwise reserved.
- a relatively slow growth from May 93 to April 04, during which 50 new prefixes are allocated
- a recent spurt of activity causing 20 allocations between April and November 04.
 
Depending over which period you average, we can argue that the allocation rate is:
- 6.8 per year between 1981 and 2004 (163 blocks divided by 24 years)
- 4.5 per year between May 1993 and April 2004 (50 blocks divided by 11)
- 6 per year between May 1993 and November 2003 (70 divided by 11.5)
- 34 per year lately (20 blocks over the course of 7 months)
I can assume that different soothsayers will pick different values, depending on whether they want to tell us that the sky is falling, or on the contrary that we should not worry.
 
Another point of debate is how many blocks are actually available. Right now, 163 are in use, out of a total of 256, so we may assume that 93 are available. However, 16 of these blocks fall in the former "class E" category, and may or may not be easy to use...
 
-- Christian Huitema

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Sun, 07 Nov 2004 07:49:25 -0500

--On 6. november 2004 17:15 -0800 Christian Huitema 
<[email-masked]> wrote:

> By the way, I must apologize. I had a bug in the spreadsheet that I used,
> and the numbers that I quoted are goofy. The consumption did increase
> during the last year, but not quite that fast. Let's say that, depending
> on which number you pick, the consumption per year is between 4 and 10
> blocks, which means an exhaustion in 10 to 15 years if the rates
> continue. But it also mean that we are de facto in the upper size of the
> S curve, because we have passed the 50% capacity point.

your remark reminds me of the red-and-black chart of allocated and routed 
addresses that someone (KC?) showed at an IETF plenary some years back.

Other people called it "proof that there is no problem".

I called it "halfway to Hell".