Subject: RE: How the IPnG effort was started

From: "Peter Ford" <[email-masked]>
Date: Mon, 8 Nov 2004 10:57:26 -0800

Noel,
 
In the interest of completeness I would note that at the time the size of the global Internet routing table was also a very high concern and core to at least one session at each IETF meeting at the time.  Pre-cidr we were at risk of running out of class B addresses and thus causing a blowout in allocation of class Cs.   In short, the IP layer was in need of some "firming up", on multiple fronts. (too bad we didn't go farther ...)
 
As a co-chair of the TUBA (tcp/udp with Big Addresses) wg that recommended the use of CLNP I would note most people in the TUBA wg supported the use of CLNP because:
 
0) CLNP satisfied the requirement for a globally unique huge address space and CLNP and IPv4 were fairly comparable from an architecture perspective (thanks to several people ( Dave Oran, Ross Callon, Lyman Chapin, Dino Farinacci, Tony Hain, Yakov Rekhter, Radia Perlman, Tony Lauck, Brian Carpenter, Richard Colella, etc.) who spanned the IETF and ISO/OSI worlds  )
1) there were ample existence proofs of CLNP in router and host software that were shipping at the time
1a) several independent implementors successfully moved TCP/UDP on top of CLNP along with  several apps (email, telnet, ftp)  on several platforms in a super short period of time (BSD, DOS, etc.)
2) there were existing, working, and deployed routing protocols on a global basis (ES-IS, IS-IS) - e.g. no tunneling to prove "it works"
3) CLNP supported autoconfiguration of host addresses (ES-IS) (best feature of IPv6!)
4) it was felt that at the time it would be the "quickest" transition, since time was of the essence!
5) CLNP also allowed for short addresses via variable length addressing (e.g. use of IPng in private supercomputer clusters, etc.)
6) the address space had a natural delegation architecture which could suit the needs of a variety of parties at the time.
 
Many of these same reasons were held to be true by people who worked prior to TUBA in the pre-IPNG discussions/debates.
 
Christian is correct in that several people felt the answer of CLNP was "THE answer" and thus were over-zealous in pushing in that direction and aligned the discussions of IPng with other discussions re: CLNP.   (keen time observers will note that the TUBA effort and the Kobe "stuff" were unaligned.   Several people who supported CLNP did not believe they needed help from the IAB, especially in light of the IETF's political climate at the time regarding the IAB, the NSF, the funding of the IETF and NIC, etc., etc.)
 
In most ways, IPv6 has replicated all of the properties enumerated above and thus, it is now clear that we do not need to transition to CLNP.  
 
regards, peterf

 

________________________________

From: [email-masked] on behalf of Noel Chiappa
Sent: Sun 11/7/2004 7:46 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: How the IPnG effort was started

    > From: "Christian Huitema" <[email-masked]>

    > The issue of IP address exhaustion had already been debated on several
    > occasions.
    > ...
    > The proposal in 1992 to base an IPng on CLNP was pretty much a
    > continuation of these discussions, and it did indeed come in quite
    > early in the process.

Yes, and the chief "selling point" people were using to push CLNP was....
larger addresses. And when the IETF wasn't thrilled about adopting OSI
protocols, they set up the IPng process, which picked.... IPv6.

So I think my orginal messages (that IPv6 exists because of a previous round
of concern about IPv4 address exhaustion, which was used by the proponents of
yet another protocol that was going to "replace" IPv4 to push for their
protocol's adoption) was right on target.

        Noel

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Jon Allen Boone <[email-masked]>
Date: Thu, 11 Nov 2004 12:27:16 -0500

On Nov 08, 2004, at 13:57, Peter Ford wrote:

> In the interest of completeness I would note that at the time the size 
> of the global Internet routing table was also a very high concern and 
> core to at least one session at each IETF meeting at the time.   

   I'd like to confirm this.  When I first got active in IETF in 1992, 
one of the first issues that was brought to my attention was the IPv4 
address space exhaustion.  There was an amazing (to me) presentation 
showing the address space exhaustion - along with a discussion of the 
use of NAT to mitigate that threat.  The presenter went on to show that 
even with the use of NAT to preclude address space exhaustion, the 
global routing tables were growing at a phenomenal rate and stressing 
the routing core incredibly, thus the need for CIDR, as it would allow 
a reduction in the rate of growth and offered the hope of an actual 
decrease in the overall table size.  The presentation was given, iirc, 
by Tony Li, then of Cisco.

   FWIW, some folks thought that CIDR was not a good idea, but was 
"forced" on us due to short-sidedness on the part of Cisco in designing 
the memory capacity of their core routers.  I still recall people 
advocating a "throw memory at it" solution.

   In the subsequent 12 years, most of the predictions for address space 
exhaustion have failed to materialize, thanks largely to NAT.

   High speed memory on core routers has increased so overall table size 
isn't the omnipresent threat it was then, unless you run gear from the 
mid 1990s.

   IPv6 has failed to make any large impact on the Internet, other than 
providing a near-endless source of inspiration for features to 
"back-port" to IPv4 (like DHCP).

   Where is the incentive to move to IPv6 going to come from?    All of 
the Mac OS X and Linux machines I have at home support it.  The core 
infrastructure of the Internet has the ability to support it.  But why 
should we go to the trouble of enabling it?  Where's the benefit?

--jon
written from behind a NAT'd Cable-modem broadband connection

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 16 Nov 2004 11:59:25 +0100

Jon Allen Boone wrote:
...
> should we go to the trouble of enabling it?  Where's the benefit?

Jon,

There is no doubt that the Internet has, as usual, routed around damage,
i.e. the objective shortage of IPv4 addresses for end users, but
unfortunately the work-around (ambiguous addresses and NATs) really
only works for a limited subset of applications, apparently including
those you use at home. There is a quite excellent article that describes the
gory details at:
http://www.cisco.com/en/US/about/ac123/ac147/archived_issues/ipj_7-3/anatomy.html

For those who want to innovate, or for those countries whose ISPs are
already forced to run multiple levels of NAT, and in particular for
countries with on the order of a billion citizens, there simply isn't
any doubt that this mess cannot continue. It's a strategic issue, not
one that can be understood with our industry's traditional 3 month
forward look.

I too run behind a NAT when I have to. And I can run a few good old
fashioned client/server applications. But it isn't 10% of what I
could do on a real transparent Internet.

     Brian

---

From: Jon Allen Boone <[email-masked]>
Date: Tue, 16 Nov 2004 10:07:21 -0500

Brian,

   Thanks for you kind note.

On Nov 16, 2004, at 05:59, Brian E Carpenter wrote:

> but unfortunately the work-around (ambiguous addresses and NATs) really
> those you use at home.

   yeah, not even everything I'd like to do at home works.  :-(  But,  
I've learned to live with it.

> There is a quite excellent article that describes the gory details at:

   Thanks, I'll review it in detail to see what I can learn from it.  It  
seems like STUN isn't exactly a great choice of a name for the  
protocol, though, given that it's already used for Serial TUNnelling.   
:-(

> one that can be understood with our industry's traditional 3 month

   I don't disagree that it seems like things will have to change  
eventually.  I just can't see far enough into the future to see how the  
change will occur.  After unsuccessfully trying to predict these types  
of changes for the last decade+, I've given up.  :-(

   I was hoping someone else had some bright ideas that could provide  
some inspiration.

> could do on a real transparent Internet.

   I've just lost track of the bright-eyed future that I had a clear  
vision of back in 1992.  In my experience, if a technology hasn't been  
readily adopted within a decade of it's creation, it's not going to be.  
  It appears that time is rapidly approaching for IPv6.

   I dearly wish someone could rejuvenate my imagination in this area.

--jon