Subject: Re: IPv4 consumption statistics and extrapolations

From: Bob Braden <[email-masked]>
Date: Sat, 6 Nov 2004 12:16:53 -0800 (PST)

*> 
  *> At this rate the central pool will exhaust in 2018, some 14 years hence. 
  *> i.e. some 168 months hence. Allowing for an accelerating consumption rate 
  *> at an exponential rate brings this forward to 10 years, or 120 months. 
  *> (details of the analysis are at http://bgp.potaroo.net/ipv4/)
  *> 
  *> (Of course you should consult your favourite oracle, mystic, soothsayer or 
  *> whatever for your own preferred version of the future.)
  *> 
  *> regards,
  *> 
  *>     Geoff
  *> 
  *> 

Some 10 years ago, every IETF plenary meeting had a soothsayer session,
projecting how soon we would run out of IPv4 addresses.  Has anyone
looked to see how today's data extrapolates from the predictions then?
Was it as "S" curve, after all??

Just wondering...

Bob Braden

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 06 Nov 2004 23:10:58 +0100

> Was it as "S" curve, after all??

Bob, if you constrain a resource, it will inevitably follow an S curve.
The fact that we have collectively strongly constrained the supply
of IPv4 addresses for the last ten years automatically produces the
results Geoff observes. Tony Hain makes the real point - if we don't
remove that constraint, we will (continue to) constrain innovation
and expansion of the Internet. I think that would be immoral. Yes,
immoral - we should grow the Internet to be big enough for the whole
world population; anything less is selfishness.

    Brian (maybe a bit tired with jet lag - I don't normally get
           so steamed up about this)

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sat, 06 Nov 2004 17:44:31 -0500

That's the point, IPv6 is no longer about (only) more addresses, but about
innovation. And innovation means freedom as well.

I even think that it will be possible to recover, slowly, some IPv4 pools
when IPv6 is extensively deployed, but who will care then ?

Regards,
Jordi

> De: Brian E Carpenter <[email-masked]>
> Organización: IBM
> Responder a: [email-masked]
> Fecha: Sat, 06 Nov 2004 23:10:58 +0100
> Para: Bob Braden <[email-masked]>
> CC: [email-masked]
> Asunto: Re: IPv4 consumption statistics and extrapolations
> 
> Bob Braden wrote:
>>   *>