Subject: RE: [Sipforum-discussion] RE: Collecting media statistics for SIP calls?

From: Madabhushi Pramod <[email-masked]>
Date: Mon, 1 Nov 2004 11:46:04 -0800 (PST)

I would like to thank every one for their responses.

Pramod Madabhushi 

--- Henry Sinnreich <[email-masked]> wrote:

>  Folks,
> 
> >Thats what RAQMON doesin a media gnostioc fashion.
> 
> RAQMON is an excellent approach for network elements
> 
> The media statistics for SIP calls are intended at
> the application level in
> endpoints, such as when using an Instant Messenger
> client for voice or a
> soft phone, or a SIP phone, or a game with VoIP. 
> 
> Let's not be dogmatic and force techniques that have
> been designed for
> network elements such as routers, gateways or
> servers on to the application
> level in endpoints, where many good practical
> reasons have shown the RTCP
> extensions to be the better approach. Live and let
> live!
> 
> Thanks, Henry
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On
> Behalf Of Siddiqui, Anwar
> A (Anwar)
> Sent: Monday, November 01, 2004 8:01 AM
> To: Romascanu, Dan (Dan); [email-masked];
> Madabhushi Pramod;
> [email-masked];
> [email-masked];
> [email-masked]
> Subject: [Sipforum-discussion] RE: Collecting media
> statistics for SIP
> calls?
> 
> Like you point out its not SIP specific but there
> are certain aspects of SIP
> that we need to take care of and RAQMON does that.
> let me clarify; Since it
> is SIP the session monitoring is media agnostic and
> need to accomodate that.
> 
> Thats what RAQMON doesin a media gnostioc fashion.
> Voice Over IP, Video over IP or Fax over IP and many
> other apps fit into the
> Framework. See it helps you.
> 
> Since it is in WG LAst call, would be very happy to
> see what kind of needs
> you have and ensure that it serves the purpose.
> 
> Anwar
> 
> -----Original Message-----
> From: Romascanu, Dan (Dan)
> Sent: Monday, November 01, 2004 2:36 AM
> To: [email-masked]; Madabhushi Pramod;
> [email-masked];
> [email-masked]; [email-masked]
> Cc: Siddiqui, Anwar A (Anwar)
> Subject: RE: Collecting media statistics for SIP
> calls?
> 
> 
> I agree. This is not a SIP domain specific issue.
> See my previous answer
> pointing to the real-time application QoS monitoring
> (RAQMON) work in the
> RMON MIB WG. 
> 
> Regards,
> 
> Dan
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked]
> [mailto:[email-masked]]On 
> > Behalf Of Thomas Gal
> > Sent: 31 October, 2004 11:00 PM
> > To: 'Madabhushi Pramod'; 
> > [email-masked]; 
> > [email-masked]; [email-masked]
> > Subject: RE: Collecting media statistics for SIP
> calls?
> > 
> > 
> > 	I don't think that's really a SIP domain issue,
> though 
> > this may have
> > been adressed somewhere that I'm not aware of. 
> > 	If you're using RTP to carry the audio than these
> statistics are
> > derived from the RTP stream in the context of the
> sender 
> > (with you being the
> > receiver) and the sender sends SR (Sender Report)
> RTCP packets with
> > interarrival jitter included. Packet count,
> fraction lost, 
> > and cumulative
> > number of packets lost are also transmitted in
> these packets. 
> > Latency would
> > probably be derived from the NTP timestamp if
> anything and is 
> > not directly
> > addressed in RTP to my knowledge. So if you wanted
> this data 
> > after the fact
> > the server would have to maintain that
> information, and it 
> > would probably be
> > a query at the application level, not really
> anything to do with SIP.
> > 
> > -Tom
> > 
> > [email-masked]  
> > 
> > > -----Original Message-----
> > > From: [email-masked]
> [mailto:[email-masked]] On 
> > > Behalf Of Madabhushi Pramod
> > > Sent: Friday, October 29, 2004 4:09 PM
> > > To: [email-masked]; 
> > > [email-masked]; [email-masked]
> > > Subject: Collecting media statistics for SIP
> calls?
> > > 
> > > Is there any way by which I call query a SIP
> endpoint for 
> > > media statictics after call termination. I would
> like to know 
> > > details like Jitter, latency, packet loss,
> packets received, 
> > > packets sent etc.
> > > 
> > > Thanks in advance.
> > > 
> > > Pramod Madabhushi
> > > ShoreTel communications.
> > > 
> > > =====
> > > Pramod Madabhushi
> > > email: [email-masked],
> > >        [email-masked]
> > > Phone:001-408-204-8077
> > > 
> > > 
> > > 		
> > > __________________________________
> > > Do you Yahoo!?
> > > Y! Messenger - Communicate in real time.
> Download now. 
> > > http://messenger.yahoo.com
> > > 
> > > _______________________________________________
> > > Ietf mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/ietf
> > > 
> > 
> > 
> > _______________________________________________
> > Ietf mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ietf
> > 
> ------
> To unsubscribe from the Sipforum-discussion mailing
> list visit
>
https://mbox.su.se/mailman/listinfo/sipforum-discussion

=====
Pramod Madabhushi
email: [email-masked],
       [email-masked]
Phone:001-408-204-8077

__________________________________ 
Do you Yahoo!? 
Check out the new Yahoo! Front Page. 
www.yahoo.com 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Siddiqui, Anwar A \(Anwar\)" <[email-masked]>
Date: Mon, 1 Nov 2004 09:01:04 -0500

Like you point out its not SIP specific but there are certain aspects of SIP
that we need to take care of and RAQMON does that. let me clarify;
Since it is SIP the session monitoring is media agnostic and need to accomodate that. 
Thats what RAQMON doesin a media gnostioc fashion.
Voice Over IP, Video over IP or Fax over IP and many other
apps fit into the Framework. See it helps you.

Since it is in WG LAst call, would be very happy to see what kind of needs you have and ensure 
that it serves the purpose.

Anwar

-----Original Message-----
From: Romascanu, Dan (Dan) 
Sent: Monday, November 01, 2004 2:36 AM
To: [email-masked]; Madabhushi Pramod;
[email-masked];
[email-masked]; [email-masked]
Cc: Siddiqui, Anwar A (Anwar)
Subject: RE: Collecting media statistics for SIP calls?

I agree. This is not a SIP domain specific issue. See my previous answer pointing to the real-time application QoS monitoring (RAQMON) work in the RMON MIB WG. 

Regards,

Dan

> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Thomas Gal
> Subject: RE: Collecting media statistics for SIP calls?
> 
> 
> 	I don't think that's really a SIP domain issue, though 
> this may have
> 	If you're using RTP to carry the audio than these statistics are
> derived from the RTP stream in the context of the sender 
> (with you being the
> receiver) and the sender sends SR (Sender Report) RTCP packets with
> interarrival jitter included. Packet count, fraction lost, 
> and cumulative
> number of packets lost are also transmitted in these packets. 
> Latency would
> probably be derived from the NTP timestamp if anything and is 
> not directly
> addressed in RTP to my knowledge. So if you wanted this data 
> after the fact
> the server would have to maintain that information, and it 
> would probably be
> a query at the application level, not really anything to do with SIP.
> 
> -Tom
> 
> [email-masked]  
> 
> > From: [email-masked] [mailto:[email-masked]] On 
> > Subject: Collecting media statistics for SIP calls?
> > 
> > Is there any way by which I call query a SIP endpoint for 
> > media statictics after call termination. I would like to know 
> > details like Jitter, latency, packet loss, packets received, 
> > packets sent etc.
> > 
> > Thanks in advance.
> > 
> > Pramod Madabhushi
> > ShoreTel communications.
> > 
> > =====
> > Pramod Madabhushi
> > Y! Messenger - Communicate in real time. Download now.

---

From: Henry Sinnreich <[email-masked]>
Date: Mon, 01 Nov 2004 12:00:23 -0600

Folks,

The media statistics for SIP calls are intended at the application level in
endpoints, such as when using an Instant Messenger client for voice or a
soft phone, or a SIP phone, or a game with VoIP. 

Let's not be dogmatic and force techniques that have been designed for
network elements such as routers, gateways or servers on to the application
level in endpoints, where many good practical reasons have shown the RTCP
extensions to be the better approach. Live and let live!

Thanks, Henry

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Siddiqui, Anwar
A (Anwar)
Sent: Monday, November 01, 2004 8:01 AM
To: Romascanu, Dan (Dan); [email-masked]; Madabhushi Pramod;
[email-masked]; [email-masked];
[email-masked]
Subject: [Sipforum-discussion] RE: Collecting media statistics for SIP
calls?

Like you point out its not SIP specific but there are certain aspects of SIP
that we need to take care of and RAQMON does that. let me clarify; Since it
is SIP the session monitoring is media agnostic and need to accomodate that.

Thats what RAQMON doesin a media gnostioc fashion.
Voice Over IP, Video over IP or Fax over IP and many other apps fit into the
Framework. See it helps you.

Since it is in WG LAst call, would be very happy to see what kind of needs
you have and ensure that it serves the purpose.

Anwar

-----Original Message-----
From: Romascanu, Dan (Dan)
Sent: Monday, November 01, 2004 2:36 AM
To: [email-masked]; Madabhushi Pramod;

I agree. This is not a SIP domain specific issue. See my previous answer
pointing to the real-time application QoS monitoring (RAQMON) work in the
RMON MIB WG. 

Regards,

Dan

> > email: [email-masked],
------
To unsubscribe from the Sipforum-discussion mailing list visit
https://mbox.su.se/mailman/listinfo/sipforum-discussion