Subject: RE: Collecting media statistics for SIP calls?

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Mon, 1 Nov 2004 09:31:07 +0200

See the RAQMON framework and RAQMON MIB, now in WGLC in the RMON MIB WG. 

http://www.ietf.cnri.reston.va.us/internet-drafts/draft-ietf-rmonmib-raqmon-framework-07.txt
http://www.ietf.cnri.reston.va.us/internet-drafts/draft-ietf-rmonmib-raqmon-pdu-07.txt
http://www.ietf.cnri.reston.va.us/internet-drafts/draft-ietf-rmonmib-raqmon-mib-05.txt

Regards,

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Madabhushi Pramod
> Sent: 30 October, 2004 1:09 AM
> To: [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Collecting media statistics for SIP calls?
> 
> 
> Is there any way by which I call query a SIP endpoint
> for media statictics after call termination. I would
> like to know details like Jitter, latency, packet
> loss, packets received, packets sent etc.
> 
> Thanks in advance.
> 
> Pramod Madabhushi
> ShoreTel communications.
> 
> =====
> Pramod Madabhushi
> email: [email-masked],
>        [email-masked]
> Phone:001-408-204-8077
> 
> 
> 		
> __________________________________
> Do you Yahoo!?
> Y! Messenger - Communicate in real time. Download now. 
> http://messenger.yahoo.com
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Mon, 1 Nov 2004 09:36:14 +0200

I agree. This is not a SIP domain specific issue. See my previous answer pointing to the real-time application QoS monitoring (RAQMON) work in the RMON MIB WG. 

Regards,

Dan

> Behalf Of Thomas Gal
> Sent: 31 October, 2004 11:00 PM
> To: 'Madabhushi Pramod'; 
> [email-masked]; 
> Subject: RE: Collecting media statistics for SIP calls?
> 
> 
> 	I don't think that's really a SIP domain issue, though 
> this may have
> been adressed somewhere that I'm not aware of. 
> 	If you're using RTP to carry the audio than these statistics are
> derived from the RTP stream in the context of the sender 
> (with you being the
> receiver) and the sender sends SR (Sender Report) RTCP packets with
> interarrival jitter included. Packet count, fraction lost, 
> and cumulative
> number of packets lost are also transmitted in these packets. 
> Latency would
> probably be derived from the NTP timestamp if anything and is 
> not directly
> addressed in RTP to my knowledge. So if you wanted this data 
> after the fact
> the server would have to maintain that information, and it 
> would probably be
> a query at the application level, not really anything to do with SIP.
> 
> -Tom
> 
> [email-masked]  
> 
> > From: [email-masked] [mailto:[email-masked]] On 
> > Sent: Friday, October 29, 2004 4:09 PM
> > Is there any way by which I call query a SIP endpoint for 
> > media statictics after call termination. I would like to know 
> > details like Jitter, latency, packet loss, packets received, 
> > packets sent etc.
> > 
> > Thanks in advance.
> > 
> > Pramod Madabhushi
> > ShoreTel communications.
> > 
> > =====
> > Pramod Madabhushi