Subject: Re: New Last Call: 'Tags for Identifying Languages' to BCP

From: Bruce Lilly <[email-masked]>
Date: Sun, 12 Dec 2004 15:20:55 -0500

>  Date: 2004-12-12 13:00
>  From: "Mark Davis" <[email-masked]>
>  To: [email-masked], [email-masked]
>  CC: [email-masked]

> Your claim that the RFC 3066 ABNF itself has a restriction in length is also
> clearly false. I will quote that again since you seem somehow not to have
> seen it:

I made no such claim; indeed it was I who pointed out
that RFC 3066 *theoretically* permits an infinite-
length tag.  On that basis alone (even if you missed
the fact that I am an implementor of RFC 3066
language tags) you can be sure that I am well aware
of the RFC 3066 ABNF.

> Both documents establish many further limitations on the contents of
> language tags in the text of each document. Ignoring those stated
> limitations will, in both documents, result in nonconformant language tags.

Are you claiming that

sr-CS-891-boont-gaulish-guoyu-boont-gaulish-guoyu-boont-gaulish-guoyu

is nonconformant per some specification in the draft
proposal?  It is certainly too long to be used in an
RFC 2047/2231 encoded-word.  It is much longer than
any registered RFC 3066 language tag, and the draft
proposes removing full tag registration procedure
restrictions as well as decoupling use from registration
that would combine to permit such an abomination.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Mark Davis" <[email-masked]>
Date: Sun, 12 Dec 2004 14:34:56 -0800

> proposal?

Clearly not. But

  x-sr-CS-891-boont-gaulish-guoyu-boont-gaulish-guoyu-boont-gaulish-guoyu

is already absolutely conformant with the current RFC 3066. And the current
RFC 3066 clearly permits the registration of something as long as

(although of course this particular combination would certainly never get
in).

Inutile d'aller plu loin...

There is no use to trying to declare a difference in conformant lengths
between these two documents when one doesn't exist. If you want to do
something productive, you should make a practical suggestion for a change in
the current text of the new draft. If the new draft is to backward
compatible, then it has to be worded carefully. I haven't thought it through
at length, but would need to be something like:

- A conformant implementation need not support the storage of language tags
which exceed a specified length. However, such a limitation must be clearly
documented, including the disposition of any longer tags (for example,
whether an error value is generated or the language tag is truncated -- and
if so, how it is to be truncated).

‎Mark

----- Original Message ----- 
From: "Bruce Lilly" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Sunday, December 12, 2004 12:20
Subject: Re: New Last Call: 'Tags for Identifying Languages' to BCP

> Ietf-languages mailing list
> [email-masked]
> http://www.alvestrand.no/mailman/listinfo/ietf-languages
>

---

From: "Mark Davis" <[email-masked]>
Date: Sun, 12 Dec 2004 14:34:56 -0800

Clearly not. But

‎Mark