Subject: The Font top-level MIME type registration I-D

From: Dave Singer <[email-masked]>
Date: Thu, 23 Dec 2004 13:53:52 -0800

<http://www.ietf.org/internet-drafts/draft-singer-font-mime-00.txt>

This was posted a while back and hasn't received much comment.  I 
suspect that it is not so much the quality of the writing as the fact 
that many haven't noticed it...

It proposes registering a top-level font/ MIME type for font formats. 
Note that it is font formats, just like image formats, that we 
propose registering;  I understand that in the past there has been 
some confusion that it might be fonts themselves (e.g. font/courier) 
that would be registered.  That would be like having image/mona-lisa 
or audio/beethoven5th, of course. Rather, we propose font/opentype 
(for example).

This was modelled on another recent top-level MIME type definition.

All comments are gratefully received, of course.

Best of the season to you all.
-- 
David Singer
Apple Computer/QuickTime

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: John C Klensin <[email-masked]>
Date: Thu, 23 Dec 2004 18:57:39 -0500

Dave,

The third paragraph of your introduction starts --but only
starts-- to answer the obvious questions of "why not use
application/ ?" and "why do you need a top-level type?"
Assuming we accept your explanation for the first, it seems to
me that the second is still a little dicey. You've defined two
subtypes and I can think of a handful, but only a handful, of
others.   Unless there will be far more subtype registrations
than that suggests, creating a top-level type doesn't feel
right.   

So, let me ask you, and anyone else who is inclined to think
about this, a question: are there other things than fonts which
could use a top-level type and whose needs are similar (as
described in your introduction)?  Is there a more general
problem that we can solve here?  Is  the XML- precedent useful
in any way?

best,
   john

--On Thursday, 23 December, 2004 13:53 -0800 Dave Singer
<[email-masked]> wrote:

> This was posted a while back and hasn't received much comment.
> I suspect that it is not so much the quality of the writing as
> the fact that many haven't noticed it...
> 
> It proposes registering a top-level font/ MIME type for font
> formats. Note that it is font formats, just like image
> formats, that we propose registering;  I understand that in
> the past there has been some confusion that it might be fonts
> themselves (e.g. font/courier) that would be registered.  That
> would be like having image/mona-lisa or audio/beethoven5th, of
> course. Rather, we propose font/opentype (for example).
>