Subject: Re: New Last Call: 'Tags for Identifying Languages' to BCP

From: Bruce Lilly <[email-masked]>
Date: Sat, 18 Dec 2004 12:33:27 -0500

> Date: Fri, 10 Dec 2004 18:22:53 -0800
> From: "Mark Davis" <[email-masked]>
> Subject: Fw: New Last Call: 'Tags for Identifying Languages' to BCP
> To: <[email-masked]>, <[email-masked]>
> Cc: [email-masked]
> Message-ID: <[email-masked]>

> I am somewhat sympathetic to the idea of having some 
> total limit (except for the late date for the proposed change).

Earlier feedback would have been had if there had been
some announcement of the proposed considerable changes
on the ietf-822 mailing list, or via an IETF WG
charter.

> However, we 
> got considerable pushback on having RFC 3066bis make any previously valid
> RFC3066 tag be invalid

Entirely appropriate.  And the proposed draft would
invalidate the meaning of the valid RFC 3066 language
tag "sr-CS", which is currently in use.

> and any length restriction would do that.

If it makes you happy, you can exclude private-use
tags from an explicit limit.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: [email-masked]
Date: Sat, 18 Dec 2004 15:40:58 -0800 (PST)

> on the ietf-822 mailing list, or via an IETF WG

This sort of thing is exactly why we last call non-WG documents for four weeks
rather than two. Less review is assumed to have occured and this may well mean
the document is in some sense "less done".

So, while I know of no problems caused by inordinantly long language tags, now
that the issue has been brought up using this opportunity to add a max length
restriction seems like a very reasonable thing to do.

> tags from an explicit limit.

I would only suggest doing this if it helps us reach consensus.

				Ned

---

From: "Addison Phillips [wM]" <[email-masked]>
Date: Sat, 18 Dec 2004 16:48:47 -0800

We (Mark and I) welcome the last call process and timelines and the feedback these generate. That's the whole point of having a Last Call.

The -CS subtag issue doesn't strike me as a technical issue with the draft. The draft stabilizes the meaning of subtags. There is a process in the draft for setting the initial (and thus stable) meaning of the -CS subtag. While it probably matters which value (Czechoslovakia or Serbia and Montenegro) that is selected, it is only of editorial interest to the draft itself... unless what Bruce is trying to prove is that stabilizing the meaning of the subtags is a Bad Idea, which I don't think is his point.

I'm willing to entertain a debate about which meaning ought to be selected. But really it ought to be recognized as not an editorial issue with the draft and not a technical objection.

Best Regards,

Addison

Addison P. Phillips
Director, Globalization Architecture
http://www.webMethods.com

Chair, W3C Internationalization Working Group
http://www.w3.org/International

Internationalization is an architecture. 
It is not a feature.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of 
> [email-masked]
> Sent: 2004年12月18日 15:41
> To: Bruce Lilly
> Cc: [email-masked]; [email-masked]
> Subject: Re: New Last Call: 'Tags for Identifying Languages' to BCP
> 
> 
> Ietf-languages mailing list
> [email-masked]
> http://www.alvestrand.no/mailman/listinfo/ietf-languages

---

From: "Addison Phillips [wM]" <[email-masked]>
Date: Sat, 18 Dec 2004 17:33:11 -0800

Hmm...

That's "as an editorial issue and not a technical issue".

Addison

Addison P. Phillips

> [mailto:[email-masked]]On Behalf Of Addison
> Phillips [wM]
> Sent: 2004年12月18日 16:49
> To: [email-masked]; Bruce Lilly
> Subject: RE: New Last Call: 'Tags for Identifying Languages' to BCP
> 
> 
> We (Mark and I) welcome the last call process and timelines and 
> the feedback these generate. That's the whole point of having a Last Call.
> 
> The -CS subtag issue doesn't strike me as a technical issue with 
> the draft. The draft stabilizes the meaning of subtags. There is 
> a process in the draft for setting the initial (and thus stable) 
> meaning of the -CS subtag. While it probably matters which value 
> (Czechoslovakia or Serbia and Montenegro) that is selected, it is 
> only of editorial interest to the draft itself... unless what 
> Bruce is trying to prove is that stabilizing the meaning of the 
> subtags is a Bad Idea, which I don't think is his point.
> 
> I'm willing to entertain a debate about which meaning ought to be 
> selected. But really it ought to be recognized as not an 
> editorial issue with the draft and not a technical objection.
> 
> Best Regards,
> 
> Addison
> 
> Addison P. Phillips

---

From: Bruce Lilly <[email-masked]>
Date: Mon, 20 Dec 2004 09:06:30 -0500

>  Date: 2004-12-18 20:33
>  From: "Addison Phillips [wM]" <[email-masked]>
>  To: [email-masked], [email-masked], "Bruce Lilly" <[email-masked]>
>  CC: [email-masked], [email-masked]
>  Reply to: [email-masked]
>  
> Hmm...
> 
[...]
> > editorial issue with the draft and not a technical objection.

I believe that it's more than an editorial issue, and that
there are both technical and non-technical matters involved.
While I wouldn't say "that stabilizing the meaning of the
subtags is a Bad Idea", I do believe that the particular
approach taken raises some disturbing issues, and I suspect
that there are process-related considerations that could have
avoided them.  Jefsey Morfin and Vernon Schryver have touched
on procedural issues; I plan to discuss my specific concerns
and suggestions, but it make take a few days due to the
impending holidays and other work for me to collect and
organize my thoughts on those matters.