Subject: RE: Proper WG chairs (Re: Voting (again))

From: "John Loughney" <[email-masked]>
Date: Mon, 9 May 2005 21:38:41 +0200

Harald,

you forgot one:

 - willingness to continue working as a chair, long after their day job has moved onto new topics.

In this business, most folks change tasks, if not jobs, sooner than the average half-life of wgs in the IETF.
 
John
 
====================
The good thing about mobile email is that t9 forces you to be brief.

--- original message ---
Subject:	Proper WG chairs (Re: Voting (again))
Sender:	Harald Tveit Alvestrand <[email-masked]>
Date:		05/09/2005 1:56 pm

--On 8. mai 2005 23:54 +0200 Julian Reschke <[email-masked]> wrote:

>> ISTR a case of a WG that got replaced its chair by the IESG, and told to
>>  do its work differently, two or three times - and *every* time, the new
>>  chair stopped posting to the list after a short time. (The last time, I
>>  think he came back after a significant timeout.)
>>
>> That's a recipe for exhaustion if ever I saw one. I might even call it
>> active sabotage.
>
> I don't know about ISTR, but similar things have happened to the WEBDAV
> working group in the last two years (no, I'm not saying it's intentional;
> but fact is we got two new chairs who did not / do not seem to be very
> interested in the current WG work).

My immediate reaction is "who were the available candidates for chair"....
In contentious groups, the requirement list is roughly (not in priority 
order):

- Knows enough of the technology to understand the issues
- Knows enough about the IETF process to steer the group correctly
- Respected enough by the groups of people involved
- Not strongly identified with any of the camps of contention
- Has time enough available (and an employer or family that will allow them 
to spend that time)
- Has the personal qualities needed to get people to come to consensus
- Is known enough to the AD that he/she is comfortable working with that 
person
- ....and I'm sure there are things I've forgotten.....

And since the intersection of all those qualities is frequently the null 
set, chair candidates tend to be lacking in one or more of these qualities. 
In the cases cited, the "time enough available" may be the factor that 
changed - I don't know the specifics.

I see two possibilities when a chair fails to work out:

- The AD made a bad choice, and there was someone else who could have done 
a better job. Solution: AD needs help in picking chairs.

- There was no better candidate at the time (all the other candidates being 
more obviously the wrong person for the job). Solution: The chairs need 
help in calling for help earlier when they're unable to perform, and the AD 
needs to be more proactive in replacing chairs who aren't doing what they 
should (again going back to the candidate pool).

I suspect that the latter happens more often than the former - but as I 
said, I don't know those specific cases.

                Harald

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Mon, 09 May 2005 20:49:34 +0200

> average half-life of wgs in the IETF.

Yup - I'm impressed with the number of people who are willing to stick with 
work far beyond the original schedule and employer's interest - 
effectively, people are *really* volunteering their time and effort.

And being wildly optimistic about when their day job will permit them to 
get back to the WG-chair stuff is, I'm afraid, quite normal - I know it far 
too well from my own experience. We (all of us) should be better at calling 
for help early!

---

From: John C Klensin <[email-masked]>
Date: Mon, 09 May 2005 15:22:59 -0400

--On Monday, 09 May, 2005 20:49 +0200 Harald Tveit Alvestrand
<[email-masked]> wrote:

>> In this business, most folks change tasks, if not jobs,
>> sooner than the average half-life of wgs in the IETF.
> 
> Yup - I'm impressed with the number of people who are willing
> to stick with work far beyond the original schedule and
> employer's interest - effectively, people are *really*
> volunteering their time and effort.
> 
> And being wildly optimistic about when their day job will
> permit them to get back to the WG-chair stuff is, I'm afraid,
> quite normal - I know it far too well from my own experience.
> We (all of us) should be better at calling for help early!

On the other hand, that sequence of events -- WG takes longer
than expected, day job moves on, Chair no longer has time and/or
interest --  is probably another reason why WGs should be very
intensively reviewed, at least by the AD and Chair(s), when they
miss benchmarks.  The charter may need updating, the chair may
need replacing as an act of realism and/or mercy, or a simple
benchmark update may be all that is needed.  But, in any case,
unless there is a serious and careful review, the tendency is
for things to drift until obvious problems develop.

     john