Subject: Re: More pretty graphs

From: Bruce Lilly <[email-masked]>
Date: Tue, 17 May 2005 05:58:49 -0400

>  Date: 2005-05-16 13:15
>  From: Bill Fenner <[email-masked]>

> These graphs show inter-document dependencies(*) of
> all I-Ds that are working group documents, and one "hop" forwards and
> back - for example, if a foowg document depends on
> draft-fenner-great-stuff, then the individual draft shows up, but not
> *that* document's dependencies.  The two graphs are <wgname>.pdf,
> which includes relationships that my script could determine are not
> normative, and <wgname>-norm.pdf which does not.  Sometimes when the
> full graph is too much, the -norm graph is still readable.
> 
> It's an interesting way to see what relationships exist, and what
> other groups / documents may be referencing a given WG's work.
> 
> http://rtg.ietf.org/~fenner/ietf/deps/viz/
> 
> Each page includes a key for what the shapes and colors mean. 
> Feedback is welcome.

Interesting, but the key could be clarified; when I first looked at it,
what I saw was "straight edge = Normative, curved = Informative", which
isn't the case (Blue = Normative, Green = Informative, Orange = ???)
[I had to peek at the dot source to figure it out].

More about the orange off-list.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Bill Fenner <[email-masked]>
Date: Wed, 18 May 2005 11:08:21 -0700

On 5/17/05, Bruce Lilly <[email-masked]> wrote:
> Interesting, but the key could be clarified

I've tried to clarify the key, and have added a red diamond for
"nonexistent I-D" (which was previously confusingly represented as an
individual expired document).

  Bill