Subject: Re: Last Call: 'Definitions of Managed Objects for Remote Ping, Traceroute, and Lookup Operations' to Proposed Standard

From: Randy Presuhn <[email-masked]>
Date: Sat, 25 Feb 2006 11:30:07 -0800 (GMT-08:00)

Hi -

>From: "Tom.Petch" <[email-masked]>
>Sent: Feb 25, 2006 3:18 AM
>To: iesg <[email-masked]>, ietf <[email-masked]>
>Subject: Re: Last Call: 'Definitions of Managed Objects for Remote Ping,	Traceroute, and Lookup Operations' to Proposed Standard 
>
>I find the following unclear and would like to see it spelt out in detail
>
>"traceRouteHopsHopIndex
><snip>
>           MUST start at 1 and increase monotonically."
>
>Recent discussions on the ietf main list identified two meanings for
>'monotonically' - a sequence where each value is greater than or equal to its
>predecessor, or a sequence where each value is strictly greater than its
>predecessor - and I am unsure whether this means either or neither.
...

Since this is an INDEX in a MIB, reading it as "nondecreasing" makes no sense,
so I think there is no ambiguity.

Randy

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Randy Presuhn <[email-masked]>
Date: Sat, 25 Feb 2006 11:45:33 -0800 (GMT-08:00)

Hi -

>From: Sam Hartman <[email-masked]>
>Sent: Feb 25, 2006 10:29 AM
>To: "Tom.Petch" <[email-masked]>
>Cc: iesg <[email-masked]>, ietf <[email-masked]>
>When you combine increase with monotonically you rule out the
>possibility that it is equal.
>
>However I'd expect for an index you want increasing by one, which is
>more strict than monotonically increasing.
...

For most integer-indexed tables, the interval between index values is irrelevant.
The values just need to be different.  The GetNext and GetBulk operations used
to retrieve information from tables just rely on a notion of greater-than.
Gaps appearing in the sequence of values seen as indexes in retrieved data
may occur for many reasons, including the application of access control policy,
so a management application that relied on them having an interval of 1 would
be asking for trouble.  A robust management application won't even assume that
table entries will come back in the correct order, since some SNMP agent
implementations get this wrong for some cases.

Randy