Subject: Weekly posting summary for [email-masked]

From: Thomas Narten <[email-masked]>
Date: Fri, 24 Feb 2006 09:37:04 -0500

Total of 131 messages in the last 7 days through midnight EST,
Thursday, February 23.

    Messages   |      Bytes        | Who
--------+------+--------+----------+------------------------
  8.40% |   11 |  8.21% |    66509 | [email-masked]
  5.34% |    7 |  4.80% |    38846 | [email-masked]
  4.58% |    6 |  4.88% |    39568 | [email-masked]
  5.34% |    7 |  4.03% |    32613 | [email-masked]
  4.58% |    6 |  4.06% |    32848 | [email-masked]
  3.82% |    5 |  3.95% |    32014 | [email-masked]
  3.05% |    4 |  3.98% |    32254 | [email-masked]
  2.29% |    3 |  4.54% |    36738 | [email-masked]
  3.82% |    5 |  2.80% |    22674 | [email-masked]
  2.29% |    3 |  3.80% |    30776 | [email-masked]
  3.05% |    4 |  3.02% |    24432 | [email-masked]
  3.05% |    4 |  2.52% |    20448 | [email-masked]
  3.05% |    4 |  2.51% |    20360 | [email-masked]
  2.29% |    3 |  2.88% |    23299 | [email-masked]
  2.29% |    3 |  2.48% |    20077 | [email-masked]
  2.29% |    3 |  2.35% |    19063 | [email-masked]
  2.29% |    3 |  2.08% |    16856 | [email-masked]
  2.29% |    3 |  1.85% |    14954 | [email-masked]
  1.53% |    2 |  2.01% |    16304 | [email-masked]
  1.53% |    2 |  1.88% |    15249 | [email-masked]
  1.53% |    2 |  1.74% |    14058 | [email-masked]
  1.53% |    2 |  1.67% |    13488 | [email-masked]
  1.53% |    2 |  1.62% |    13144 | [email-masked]
  1.53% |    2 |  1.59% |    12903 | [email-masked]
  1.53% |    2 |  1.59% |    12857 | [email-masked]
  1.53% |    2 |  1.56% |    12622 | [email-masked]
  1.53% |    2 |  1.42% |    11495 | [email-masked]
  0.76% |    1 |  2.02% |    16375 | [email-masked]
  1.53% |    2 |  1.17% |     9460 | [email-masked]
  1.53% |    2 |  1.13% |     9174 | [email-masked]
  0.76% |    1 |  1.19% |     9636 | [email-masked]
  0.76% |    1 |  1.16% |     9411 | [email-masked]
  0.76% |    1 |  0.90% |     7267 | [email-masked]
  0.76% |    1 |  0.84% |     6829 | [email-masked]
  0.76% |    1 |  0.78% |     6285 | [email-masked]
  0.76% |    1 |  0.71% |     5737 | [email-masked]
  0.76% |    1 |  0.67% |     5443 | [email-masked]
  0.76% |    1 |  0.67% |     5428 | [email-masked]
  0.76% |    1 |  0.66% |     5324 | [email-masked]
  0.76% |    1 |  0.65% |     5274 | [email-masked]
  0.76% |    1 |  0.64% |     5209 | [email-masked]
  0.76% |    1 |  0.63% |     5141 | [email-masked]
  0.76% |    1 |  0.60% |     4892 | [email-masked]
  0.76% |    1 |  0.59% |     4818 | [email-masked]
  0.76% |    1 |  0.58% |     4695 | [email-masked]
  0.76% |    1 |  0.56% |     4554 | [email-masked]
  0.76% |    1 |  0.56% |     4541 | [email-masked]
  0.76% |    1 |  0.55% |     4459 | [email-masked]
  0.76% |    1 |  0.53% |     4284 | [email-masked]
  0.76% |    1 |  0.52% |     4245 | [email-masked]
  0.76% |    1 |  0.50% |     4015 | [email-masked]
  0.76% |    1 |  0.47% |     3826 | [email-masked]
  0.76% |    1 |  0.46% |     3739 | [email-masked]
  0.76% |    1 |  0.44% |     3543 | [email-masked]
--------+------+--------+----------+------------------------
100.00% |  131 |100.00% |   810053 | Total

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 24 Feb 2006 16:25:50 -0000

Thomas,

Fascinating though I find these summaries to be, I wonder:
- what relevance is there to the ordering in the list?
- how do you pick which weeks to publish summaries for?

[copy of your message snipped to keep down my byte count :-)]

Adrian

---

From: Rob Austein <[email-masked]>
Date: Fri, 24 Feb 2006 14:28:37 -0500

> - what relevance is there to the ordering in the list?

rank[user] = messages[user]/total_messages + bytes[user]/total_bytes.

---

From: Marshall Eubanks <[email-masked]>
Date: Fri, 24 Feb 2006 14:34:05 -0500

Based on my experience, it will tend to discourage value adding posters,
and encourage others. That may or may not be the desired response.

Regards
Marshall

---

From: Thomas Narten <[email-masked]>
Date: Mon, 27 Feb 2006 09:42:12 -0500

> - what relevance is there to the ordering in the list?

As Rob says,

> rank[user] = messages[user]/total_messages + bytes[user]/total_bytes.

BTW, the script that does this can be found at:

http://www.hactrn.net/hacks/mh-list-traffic/mh-list-traffic

It has been in use for quite some time on at least multi6 and ipv6.

> - how do you pick which weeks to publish summaries for?

Intention is every week, but I haven't automated it, and was unable to
get to it last two weeks in a timely fashion. :-(

> and encourage others. That may or may not be the desired response.

My feeling/experience is different. Obviously, YMMV. If someone has
some measurable data to show for or against, that would be
helpful. Otherwise, I suspect we could speculate until the cows come
home.

I did receive a few "thank you, thank you" type resposes, so it would
seem at least a few others think this is useful.

Oh, and another comment was:

> I think that's great. We used to do this on usenet and people would
> actually compete to have the cleanest content by standard there.

We should be so lucky. :-)

Harald Tveit Alvestrand <[email-masked]> writes:

> I'd like to have one more piece (don't you love it when people ask
> for someone else to do the programming): Total number of posters for
> the week.... this gives an idea of the number of people who "talk"
> in any given week, and long-term might give an idea whether the
> number of active participants on the IETF list is increasing,
> decreasing or varying proportional to the number of messages.

When I posted the first round of stats, I received quite a lot of
suggestions for possible improvements. Suggestions included:

  - include a metric for "IETF Contribution" against each name too
    (e.g., number of co-authored RFCs, current WG chair or IESG
    positions held, etc)

  - You might think about adding "quoted pct" vs. original content as
    well.

  - consoldate posters using different posting addresses...

  - rank new threads vs. followups differently

There were other suggestions sent to the IETF as well.

IMO, the current setup probably achieves something like 80% of the
ideal. So from a cost/benefit perspective, close enough, IMO.
Additional attempts to weigh "quoted" vs. "new" text, etc., are likely
to be subjective in the end anyway, so going in that direction may
just lead us to arguing about the appropriatness of particular
weighting criteria rather than having posters actually pause and
consider whether they are making good use of their and other's time.

Indeed, the ranking metric I'd like to see is one based on giving
points for usefulness of content communicated and for minimizing the
time needed by reader to read/understand the posting.

Thomas