Subject: RE: I-D ACTION: draft-ash-alt-formats-01.txt

From: "Yaakov Stein" <[email-masked]>
Date: Thu, 2 Feb 2006 15:50:34 +0200

> OK, yeah, we got that part. The question is, will the use of this
format prevent people from starting with the plain text in an ID?

The idea is to have normative equations and diagrams.

Probably at first people will leave SOME text in the pure ASCII version,
but as time goes on and we get used to using diagrams more and more,
the text will probably vestigial.

> The ID you published is in both txt and pdf, so if someone wanted to
start with the plain text in your ID, they could just start with the txt
format. 

Absolutely, although it would be harder for them to understand the point
without seeing the real diagrams and equations.

Y(J)S

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Gray, Eric" <[email-masked]>
Date: Thu, 2 Feb 2006 12:38:26 -0500

Yaakov,

	While I support the general idea behind the experiment 
advocated in this draft, in fairness, your statement below is
just your version of what John said.

	To see how complex a set of equations might be easily
shown in text, see http://www.ksc.nasa.gov/facts/faq04.html.
Rocket science, I believe they call it.  :-)

	So your statement boils down to "extremely inelegant"
which is just another way to say "uglier."

--
Eric

--> -----Original Message-----
--> From: [email-masked] [mailto:[email-masked]] 
--> On Behalf Of Yaakov Stein
--> Sent: Thursday, February 02, 2006 3:34 AM
--> To: John Levine; [email-masked]
--> Subject: RE: I-D ACTION: draft-ash-alt-formats-01.txt
--> 
-->  
--> > If the goal is to allow prettier output while still 
--> maintaining the
--> stability and reusability of plain text, that practically demands an
--> input format that is plain text underneath 
--> 
--> No, the goal (as stated in the ID) is to enable normative 
--> drawings and
--> equations that are
--> not possible or extremely inelegant in plain text.
--> 
--> Y(J)S
--> 
--> _______________________________________________
--> Ietf mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/ietf
-->

---

From: "Yaakov Stein" <[email-masked]>
Date: Thu, 2 Feb 2006 20:00:45 +0200

Eric, 

The equations you link to are so simple 
that linearizing them is no problem.

However, there are equations somewhat harder to linearize
that x = x0 + vt + 1/2 a t^2.

As I have said before, a few years back I was attempting to write an ID
on 
packet loss concealment for TDMoIP.  

After trying a few integral signs and matrices I gave up (and the work
was never disclosed to the WG).

We put a much simpler equation into the text of the ID,
but even is unwieldly in linearized form.

Yes, I guess it is always POSSIBLE to write every equation and diagram, 
e.g. by telling the user to spread out the next 25 pages as a 5 by 5
rectangle 
and then to stand on a ladder to view the result, but I don't see the
point in so doing. 

At some point "impractical" becomes "impossible for all intents and
purposes",
and "ugly" becomes "meaningless".

Y(J)S