Subject: RE: 'monotonic increasing'

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 20 Feb 2006 09:23:47 -0800

The best solution to this problem is to avoid the use of technical
vocabulary and use plain English and unambiguous formulas. 

It is quite easy to see how the term 'strictly monotonic' gets
abreviated to 'monotonic' when used by non-mathematicians.

I am pretty sure that if we started using the terms 'surjection',
'bijection' &ct. instead of 'one to one', 'one to many' we would end up
with similar confusion.

> -----Original Message-----
> From: Tom.Petch [mailto:[email-masked]] 
> Sent: Monday, February 20, 2006 9:44 AM
> To: Yaakov Stein
> Cc: ietf
> Subject: Re: 'monotonic increasing'
> 
> ----- Original Message -----
> From: "Yaakov Stein" <[email-masked]>
> To: "Tom.Petch" <[email-masked]>; "Elwyn Davies"
> <[email-masked]>
> Cc: "ietf" <[email-masked]>
> Sent: Sunday, February 19, 2006 7:10 AM
> Subject: RE: 'monotonic increasing'
> 
> 
> Actually, even mathematicians don't agree on the wording here.
> 
> In analysis we commonly talk about monotonic functions, which 
> can be either monotonically increasing ( x <= y  =>  f(x) <= 
> f(y) ) or monotonically decreasing ( x <= y  =>  f(x) >= f(y) ).
> Since analysis deals with continuous entities, the 
> distinction of nondecreasing vs. increasing is usually not 
> important, and thus not worried about. However physicists 
> tend to make the distinction by saying "nondecreasing".
> 
> In dealing with sequences, the distinction is almost 
> universally made between nondecreasing  ( x_n <= x_n+1) and 
> increasing (x_n < x_n+1) although the European school prefers 
> stressing the difference by using the word "strictly" instead.
> 
> To make things more confusing, in order theory (where you 
> would expect the wording to be the tightest) the wording used 
> is monotone (for "increasing") and antitone (for "decreasing").
> Of course there the distinction between nondecreasing and 
> increasing is not important since the description is of a 
> (partial) order relation, and if that relation includes 
> equality as a special case than you get one variety, while if 
> not you get the other.
> 
> Y(J)S
> 
> Beautiful (as mathematics always is).
> 
> But just to be clear, if you saw a reference to 'monotonic 
> increasing' in an American journal, say of applied 
> mathematics, would you be sure you understood what was meant?
> 
> And if so, would that be S_i+1 >=  S_i U+2200 i or S_i+1 > 
> S_i U+2200 i?
> 
> Tom Petch
> 
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 21 Feb 2006 10:07:29 +0100

Hallam-Baker, Phillip wrote:

> I am pretty sure that if we started using the terms
> 'surjection', 'bijection' &ct. instead of 'one to one',
> 'one to many' we would end up with similar confusion.

Yes, but at least there's only one definition, unlike
"montonic increasing" with more common definitions.  For
the case here replacing "monotonic" by "strictly" should
be good enough, otherwise add a (the) simple definition,
it's a one-liner.
                          Bye, Frank

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 21 Feb 2006 08:18:46 -0500

It seems to me that the real question here is, should there
be a RFC-2119 type RFC to define mathematical terms ?

Otherwise this thread is unlikely to do much to change the
situation.

Regards
Marshall Eubanks

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 21 Feb 2006 15:57:43 +0100

Marshall Eubanks wrote:

> a RFC-2119 type RFC to define mathematical terms ?

Maybe more like some glossaries (Internet, security,
I18N, ...), informational RFCs.  But I think that's
unnecessary.  There are online math. dictionaries, 
authors can provide references for unlear terms, or
say what they mean.
 
> Otherwise this thread is unlikely to do much to
> change the situation.

It highlights why "clear" terms in RFC are good,
defined by reference or inline.  In some groups
saying 'header' instead of 'header field', 'byte'
instead of 'octet', or 'charset' instead of IIRC
'encoded character repertoire' is enough to start
a thread.  And 'monotonic increasing' instead of
'strictly (monotonic) increasing' is apparently a
similar issue.
                      Bye, Frank

---

From: "Tom.Petch" <[email-masked]>
Date: Wed, 22 Feb 2006 21:49:43 +0100

----- Original Message -----
From: "Frank Ellermann" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, February 21, 2006 3:57 PM
Subject: Re: 'monotonic increasing'

> 'strictly (monotonic) increasing' is apparently a

What I see from this thread is that there are two common interpretations to
the phrase 'monotonic increasing', either a sequence in which each number is
greater than or equal to its predecessor, or one in which each number is
strictly greater than its predecessor, with the former meaning having somewhat
the greater support (at least amongst those with access to text books): which,
of itself, makes it a risky term to use in a specification.

I still think that it is sometimes used in RFC and I-D in a
third sense, of a sequence of integers increasing by one each time, not a
meaning anyone has supported. But only the editor can know what is really
intended.

So, the next time I see it used, perhaps in a Last Call of a pkix, kink or secsh
I-D, I will seek further clarification.

Tom Petch