Subject: RE: 'monotonic increasing'

From: "Yaakov Stein" <[email-masked]>
Date: Mon, 20 Feb 2006 18:11:59 +0200

> But just to be clear, if you saw a reference to 'monotonic increasing'
in an American journal, 
> say of applied mathematics, would you be sure you understood what was
meant?

That would depend on the subject matter.
If the article was on real analysis (where the domain is
nondenumerable), 
then it would most probably mean >=.
If the article's subject matter was "concrete mathematics" (i.e.
discrete values)
then "increasing" would probably mean > and only "nondecreasing" would
mean >=.

So in the case you raise, monotonic increasing would usually be strictly
interpreted as x_n > x_n-1,
and if you want to include the case where the sequence doesn't actually
increase
you should say "nondecreasing" .

However, since the Godel failure of Principia Mathematica
even mathematicians have lost faith in consistent definitions   :>

Y(J)S

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Gray, Eric" <[email-masked]>
Date: Mon, 20 Feb 2006 15:04:35 -0500

Tom/Yaakov,

	Getting back to the slightly related field of specification
of standard protocols, the term "monotonically increasing" is used
in many cases because that is all that really needs to be said.

	This is because the intent in the specification is to allow
implementations to detect a "roll-over" or "restart" event by the
simple process of checking to see if a new value is less than a
prior value.

	Since this is the test that the implementations actually 
need to be able to perform in many cases, it is often sufficient
to say exactly "monotonically increasing" and not necessary to
say more than that.

--
Eric

--> -----Original Message-----
--> From: Yaakov Stein [mailto:[email-masked]] 
--> Sent: Monday, February 20, 2006 11:12 AM
--> To: Tom.Petch
--> Cc: ietf
--> Subject: RE: 'monotonic increasing'
--> 
-->  
--> 
--> > But just to be clear, if you saw a reference to 
--> 'monotonic increasing'
--> in an American journal, 
--> > say of applied mathematics, would you be sure you 
--> understood what was
--> meant?
--> 
--> 
--> That would depend on the subject matter.
--> If the article was on real analysis (where the domain is
--> nondenumerable), 
--> then it would most probably mean >=.
--> If the article's subject matter was "concrete mathematics" (i.e.
--> discrete values)
--> then "increasing" would probably mean > and only 
--> "nondecreasing" would
--> mean >=.
--> 
--> So in the case you raise, monotonic increasing would 
--> usually be strictly
--> interpreted as x_n > x_n-1,
--> and if you want to include the case where the sequence 
--> doesn't actually
--> increase
--> you should say "nondecreasing" .
--> 
--> However, since the Godel failure of Principia Mathematica
--> even mathematicians have lost faith in consistent definitions   :>
--> 
--> Y(J)S
--> 
--> _______________________________________________
--> Ietf mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/ietf
-->

---

From: "Gray, Eric" <[email-masked]>
Date: Wed, 22 Feb 2006 18:06:26 -0500

Tom,

	I'm sorry to disagree, but I feel that the term "monotonic" has
a much better defined meaning than most terms in general (including -
for example - the term "term").

	There are definitely applications for the phrase "monotonically
increasing" where the terminology is exactly correct and very hard to
"word-smith" around.

	There are also cases in which the appropriate phrase might have
been "strictly monotonically increasing", and for one reason or another
the word "strictly" was omitted.  In such cases, it either was clear
what was meant at the time, or it has become clear in the mean time.

	I really do not see why we need to get quite so retentive about
terminology when we have the ability to ask questions about anything
we don't understand completely.  Nor do I believe that there is any
way that we could avoid the need to ask questions strictly as a result
of using perfect terminology (or phraseology).

--
Eric

--> -----Original Message-----
--> From: Tom.Petch [mailto:[email-masked]] 
--> Sent: Wednesday, February 22, 2006 3:50 PM
--> To: ietf; Frank Ellermann
--> Subject: Re: 'monotonic increasing'
--> 
--> ----- Original Message -----
--> From: "Frank Ellermann" <[email-masked]>
--> To: <[email-masked]>
--> Sent: Tuesday, February 21, 2006 3:57 PM
--> Subject: Re: 'monotonic increasing'
--> 
--> > Marshall Eubanks wrote:
--> >
--> > > a RFC-2119 type RFC to define mathematical terms ?
--> >
--> > Maybe more like some glossaries (Internet, security,
--> > I18N, ...), informational RFCs.  But I think that's
--> > unnecessary.  There are online math. dictionaries,
--> > authors can provide references for unlear terms, or
--> > say what they mean.
--> >
--> > > Otherwise this thread is unlikely to do much to
--> > > change the situation.
--> >
--> > It highlights why "clear" terms in RFC are good,
--> > defined by reference or inline.  In some groups
--> > saying 'header' instead of 'header field', 'byte'
--> > instead of 'octet', or 'charset' instead of IIRC
--> > 'encoded character repertoire' is enough to start
--> > a thread.  And 'monotonic increasing' instead of
--> > 'strictly (monotonic) increasing' is apparently a
--> > similar issue.
--> >                       Bye, Frank
--> >
--> 
--> What I see from this thread is that there are two common 
--> interpretations to
--> the phrase 'monotonic increasing', either a sequence in 
--> which each number is
--> greater than or equal to its predecessor, or one in which 
--> each number is
--> strictly greater than its predecessor, with the former 
--> meaning having somewhat
--> the greater support (at least amongst those with access to 
--> text books): which,
--> of itself, makes it a risky term to use in a specification.
--> 
--> I still think that it is sometimes used in RFC and I-D in a
--> third sense, of a sequence of integers increasing by one 
--> each time, not a
--> meaning anyone has supported. But only the editor can know 
--> what is really
--> intended.
--> 
--> So, the next time I see it used, perhaps in a Last Call of 
--> a pkix, kink or secsh
--> I-D, I will seek further clarification.
--> 
--> Tom Petch
--> 
--> 
--> _______________________________________________
--> Ietf mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/ietf
-->