Subject: RE: Guidance needed on well known ports

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Sat, 18 Mar 2006 23:16:42 +0200

> All that aside, the IANA has a distinction (based on history) 
> between ports below 1024 and those above.  And whne asking 
> for a port number assignment, one specifies which range one 
> wants.  I had least can not find a coherent strategy for what 
> should be on one side or the other of that boundary.
> 
> Yours,
> Joel
> 

Do we need one? 

Or maybe all this distinction is historical?

Dan

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 20 Mar 2006 09:53:38 -0800

Joe Touch wrote on Monday 20 March 2006:
> 
> Hallam-Baker, Phillip wrote:
> >> From: Joe Touch [mailto:[email-masked]] 
> > 
> >> And with what port would I reach this magical DNS that would 
> >> provide the SRV record for the DNS itself?
> > 
> > You use fixed ports for the bootstrap process and only for 
> the bootstrap
> > process.
> 
> Which means that the DNS port needs to be well-known or fixed 
> in advance.
> 
> Some other issues to be considered:
> 
> 	- this change would make the DNS required for proper Internet
> 	operation, whereas it is currently optional (i.e., only for
> 	finding the IP address).]
> 

Zeroconf (which is widely deployed for ad-hoc networking and
SOHO networks) depends entirely on the premise that there is
NO available/configured DNS service.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.385 / Virus Database: 268.2.5/284 - Release Date: 3/17/2006

	[email-masked]
Date: Mon, 20 Mar 2006 09:53:38 -0800
Cc: 
Subject: RE: Guidance needed on well known ports

Joe Touch wrote on Monday 20 March 2006:
> 
> Hallam-Baker, Phillip wrote:
> >> From: Joe Touch [mailto:[email-masked]] 
> > 
> >> And with what port would I reach this magical DNS that would 
> >> provide the SRV record for the DNS itself?
> > 
> > You use fixed ports for the bootstrap process and only for 
> the bootstrap
> > process.
> 
> Which means that the DNS port needs to be well-known or fixed 
> in advance.
> 
> Some other issues to be considered:
> 
> 	- this change would make the DNS required for proper Internet
> 	operation, whereas it is currently optional (i.e., only for
> 	finding the IP address).]
> 

Zeroconf (which is widely deployed for ad-hoc networking and
SOHO networks) depends entirely on the premise that there is
NO available/configured DNS service.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.385 / Virus Database: 268.2.5/284 - Release Date: 3/17/2006

---

From: Stuart Cheshire <[email-masked]>
Date: Thu, 23 Mar 2006 21:40:06 -0800

Noel Chiappa <[email-masked]> wrote:

>Yes. Architecturally speaking, it's somewhat dubious that information
>which really only needs to be localized to the host (application<->port
>binding) has to be sent to the DNS.
>
>It would be easy to run a tiny little USP "binding" server that took in
>an application name (yes, we'd have to register those, but string-space
>is infinite), and returned the port.

You may be interested to know that this is the direction we took with 
Multicast DNS and DNS-based Service Discovery (what Apple calls 
"Bonjour").

Every machine runs a little process called 'mdnsd' that answers 
peer-to-peer SRV queries.

The registry of "application names" (i.e. protocol names) is currently 
maintained at:

<http://www.dns-sd.org/ServiceTypes.html>

Right now there are a couple of hundred application-layer protocols 
implemented that work this way. They bind to zero, get a random port 
assigned by the OS, and then register that port with the local 'mdnsd' 
service.

The 'mdnsd' service also offers a workaround for the limitations of NAT. 
If you have a NAT gateway that speaks NAT-PMP (or the UPnP equivalent), 
then when the application registers its port with the local 'mdnsd' 
service, mdnsd talks to the NAT gateway, gets a public-to-private inbound 
port mapping created, and then mdnsd writes an SRV record into your DNS 
server (requires permission to update a DNS subdomain where Secure DNS 
Update is enabled) giving the *PUBLIC* IP address and port for your 
service.

The result of this is that when you turn on Personal File Sharing on your 
Mac at home behind a NAT gateway, then if you want to, you can advertise 
that service globally. The port number won't be the usual well-known port 
for Apple Personal File Sharing, but as long as the client looks up the 
service via SRV record, it will find the correct port to connect to. 
Details are given at:

<http://www.dns-sd.org/ClientSetup.html>

Stuart Cheshire <[email-masked]>
 * Wizard Without Portfolio, Apple Computer, Inc.
 * www.stuartcheshire.org