Subject: Re: Guidance needed on well known ports

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 20 Mar 2006 04:13:02 -0800

Refusing new registrations is what I meant by closing the registry.

Of course it is not possible to change the way deployed systems work retrospectively.

The question was about a new protocol.

We are about to see several thousand new web services protocols being developed per year. A port each would be idiotic. Expecting UDDI deployment is at this point futile.

The solution that people are going to turn to is to use the existing dns as deployed. Fortunately windows 2k uses srv extensively.

We should also promote the use of srv for existing protocols for configuration. _pop3._tcp.example.com can only advertise the location of the pop server. Why not use it and save me debugging mail config for friends and familly?

 -----Original Message-----
From: 	Stephane Bortzmeyer [mailto:[email-masked]]
Sent:	Mon Mar 20 03:06:23 2006
To:	Hallam-Baker, Phillip
Cc:	[email-masked]
Subject:	Re: Guidance needed on well known ports

On Sat, Mar 18, 2006 at 02:09:47PM -0800,
 Hallam-Baker, Phillip <[email-masked]> wrote 
 a message of 163 lines which said:

> The Internet has a signalling layer, the DNS. Applications should
> use it.  The SRV record provides an infinitely extensible mechanism
> for advertising ports.

I agree here but this means we should keep at least one well-known
port, 53.
 
> IANA should be told to close the well known ports
> registry. Applications should use DNS SRV records for service
> location.

I agree with that rule for the *future* protocols. But it does not
help with current (and widely deployed) protocols. So, asking IANA to
refuse new registrations in the well-known ports registry is one
thing, shutting down the registry is another.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Spencer Dawkins" <[email-masked]>
Date: Mon, 20 Mar 2006 06:35:52 -0600

Re: Guidance needed on well known portsTwo points here.

First, I totally agree with Phillip that closing the registry is the right direction to head. It would be lovely if this became a consideration in new protocol work at the IETF. I'm not sure how quickly we can actually close it, but having a chosen and stated direction that points somewhere else seems very appropriate for new protocol work. Please note how long it is taking to kill the classful addressing terminology. If you want to change directions on port number interpretation, please start soon..

Second, as long as the current mechanism is "widely used" (and, with the rise of HTTP-as-transport and port-agile protocols, it's less widely used every day anyway), people try to use the current mechanism to understand and characterize traffic on their networks (you may laugh, and it is getting funnier every day, but they do exactly this with firewall rules, protocol analyzers - and the good ones DON'T use port numbers much any more - and traffic monitors).

The definition of an application port is what the two ends of the application think it is. If I think that port 25 is a good port, you do, too, and we never use it for anything else, why is this wrong? It seems to me that saying, "if you want to understand what the traffic on this network looks like, our direction is that you'll need to check SRV records most of the time in the future" seems to give people who do firewalls, traffic monitors, etc. the right signal as well.

Thanks,

Spencer

   -----Original Message-----
  From:   Stephane Bortzmeyer [mailto:[email-masked]]
  Sent:   Mon Mar 20 03:06:23 2006
  To:     Hallam-Baker, Phillip
  Cc:     [email-masked]
  Subject:        Re: Guidance needed on well known ports

------------------------------------------------------------------------------

---

From: Keith Moore <[email-masked]>
Date: Mon, 20 Mar 2006 08:13:14 -0500

> Refusing new registrations is what I meant by closing the registry.

This would be a disaster.  It would mean that application designers 
would just pick ports at random (some do this already) and there would 
be no mechanism for preventing conflicts.

Regarding SRV, it's not acceptable to expect that as a condition of 
deploying a new application, every user who wishes to run that 
application be able to write to a DNS zone.  Most users do not have DNS 
zones that they can write to.

Furthermore it's increasingly necessary that applications be able to 
work in environments that do not use DNS - such as ad hoc networks or 
networks that become isolated.

> We should also promote the use of srv for existing protocols for 
> configuration. _pop3._tcp.example.com can only advertise the location of 
> the pop server. Why not use it and save me debugging mail config for 
> friends and familly?

Because it will degrade interoperability and cause inconsistent behavior 
between different mail clients.

Keith

---

From: Eliot Lear <[email-masked]>
Date: Mon, 20 Mar 2006 07:21:42 -0800

In general I agree with Phillip but not in this case due to the risks of
circular dependencies.

Eliot