Subject: Re: Guidance needed on well known ports

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 20 Mar 2006 09:02:44 -0800

The idea of requiring a privillege to access certain ports can have utility.

The idea of requiring root in a monolithic two level system like unix is a very bad one indeed. Http and smtp servers should not run as root. Forcing them to is bad o/s design.

 -----Original Message-----
From: 	Andy Bierman [mailto:[email-masked]]
Sent:	Mon Mar 20 05:57:34 2006
To:	Stephane Bortzmeyer
Cc:	Ned Freed; [email-masked]
Subject:	Re: Guidance needed on well known ports

Stephane Bortzmeyer wrote:
> On Sun, Mar 19, 2006 at 12:42:17PM -0800,
>  Ned Freed <[email-masked]> wrote 
>  a message of 35 lines which said:
>
>   
>> The privileged port concept has some marginal utility on multiuser
>> systems where you don't Joe-random-user to grab some port for a well
>> known service.
>>     
>
> "had", not "has". The concept was invented at a time where multi-users
> machines were rare and expensive monsters. So, a request coming from
> source port 513 probably was "serious". Today, any highschool student
> is root on his PC and therefore this protection is almost useless.
>   

But does that student have access to the root account on servers which
are part of the networking infrastructure?   Who cares if Joe User
blows up his own config. on a PC that nobody else depends on but Joe?

I find the argument flawed -- that because Joe User can be root on his 
own PC,
the concept of privileged access to shared system-critical infrastructure is
somehow obsolete.

Andy

>
>
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
>
>
>   

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Peter Dambier <[email-masked]>
Date: Mon, 20 Mar 2006 21:14:11 +0100

Hallam-Baker, Phillip wrote:
> The idea of requiring root in a monolithic two level system like unix is 
> a very bad one indeed. Http and smtp servers should not run as root. 
> Forcing them to is bad o/s design.

Bind is chrooted into directory /usr/lib/named and runs as user named.
Apache is chrooted into /usr/lib/www and runs as user wwwrun.
Exim is chrooted into /usr/lib/exim and runs as user exim.
...

There are even systemcalls in all flavours of unix for doing this.
There is (almost) no need to run anything as root.

Bernstein too has ideas too, how not to run things as root ...
Works under all flavours of unix, including MAC OS-X. I guesstimate
that works for some 70% of all servers.

-- 
Peter and Karin Dambier
The Public-Root Consortium
Graeffstrasse 14
D-64646 Heppenheim
+49(6252)671-788 (Telekom)
+49(179)108-3978 (O2 Genion)
+49(6252)750-308 (VoIP: sipgate.de)
mail: [email-masked]
mail: [email-masked]
http://iason.site.voila.fr/
https://sourceforge.net/projects/iason/