Subject: RFC Editor and 2006 timeline

From: Leslie Daigle <[email-masked]>
Date: Thu, 16 Mar 2006 18:04:37 -0500

The IAB and IAOC have put together the following proposed
plan for clarifying the RFC Editor function and running through
a contract review process this year.

The key pieces of this proposed process are:

	. getting agreement on a basic RFC Editor charter

	. completing TechSpec to describe requirements for
	  IETF technical specification publication

	. developing analogous components for independent
	  submissions, IRTF documents, etc.  (Not all yet on
	  the timeline).

Comments welcome.

Draft timeline/division of labour
=================================

Responsible parties in "[]", where "IASA" is IAD or IAOC as
appropriate.

Mar 14 2006  [IAB]  
	Draft RFC Editor charter out for public comment.

Mar 20 2006 [TechSpec/IETF] 
	TechSpec meeting
Mar 20 2006 [IAB/IETF]   
	Discuss RFC Editor charter

Apr 15 2006 [TechSpec]  
	Target reasonable consensus document.
Apr 15 2006 [IETF]
	Start of 4 week last call of TechSpec document
Apr 15 2006 [IAB] 
	Revised RFC Editor charter.

May 7 2006[IASA]     
	Request for Vendor Expressions of Interest
May 15 2006
	Close of last call of TechSpec document

Jun 1 2006[IASA]     
	Vendor Expressions of Interest Due

Jul 15 2006[IASA]    
	RFP(s) Issued

Sep 1 2006[IASA]     
	Bids Due
Sep 2006[IASA]       
	Contract Negotiation
Sep 25 2006[IAB]   
	IAB review

Oct 1 2006[IASA]      
	Contract(s) Awarded

Oct – Dec[IASA]        
	Transition Period

Jan 1 2007       
	Contract term begins

Leslie Daigle.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Jari Arkko <[email-masked]>
Date: Sat, 18 Mar 2006 15:11:59 +0200

Hi Leslie, and thanks for working on this. I also believe that this
process is important and beneficial for everyone who either
uses or produces (IETF, IAB, IRTF, individuals) RFCs.

Overall, the timeline looks fine. I have a few comments and questions

>	  submissions, IRTF documents, etc.  (Not all yet on
Do we know exactly what the missing components are? And
for those components, what is the delta that is really needed
beyond techspec, charter, and existing RFCs? For instance,
the techspec draft talks about indexing and search services
which would presumably apply to all RFCs, including individual
submissions and April 1 RFCs. And we already have some
material on individual RFC submission in RFC 2026 and RFC
3932.

We also have some work-in-progress, such as draft-irtf-rfcs-00.txt
that may help for the IRTF document parts.

>	Close of last call of TechSpec document
Close of last call isn't necessarily the same as having a
final document ready. Should the latter also be placed
in the timeline?

--Jari