Subject: RE: draft-santesson-tls-ume Last Call comment

From: "Stefan Santesson" <[email-masked]>
Date: Thu, 16 Mar 2006 12:14:59 -0000

I agree,

We should provide better guidance on encoding of the UPN.

This should map with the format of UPN when provided in a certificate.
The reference to the preferred name syntax is thus inherited from RFC
3280. This is how RFC 3280 restricts labels in the dNSName subject alt
name.

I will come back with a proposal on new text later today.

Stefan Santesson
Program Manager, Standards Liaison
Windows Security

-----Original Message-----
From: Mark Andrews [mailto:[email-masked]] 
Sent: den 8 mars 2006 04:23
To: Eric A. Hall
Cc: Kurt D. Zeilenga; [email-masked]
Subject: Re: draft-santesson-tls-ume Last Call comment 

> 
> On 3/7/2006 8:16 PM, Mark Andrews wrote:
> 
> > 	* Hostnames that are 254 and 255 characters long cannot be
> > 	expressed in the DNS.
> 
> Actually hostnames are technically defined with a maximum of 63
characters
> in total [RFC1123], and there have been some implementations of
/etc/hosts
> that could not even do that (hence the rule).

	RFC 1123

      Host software MUST handle host names of up to 63 characters and
      SHOULD handle host names of up to 255 characters.

	63 is not a maximum.  It is a minumum that must be supported.
 
> But even ignoring that rule (which you shouldn't, if the idea is to
have a
> meaningful data-type), there is also a maximum length limit inherent
in
> SMTP's commands which make the maximum practical mail-domain somewhat
> smaller than the DNS limit. For example, SMTP only requires maximum
> mailbox of 254 octets, but that includes localpart and @ separator.
The
> relationship between these different limits is undefined within SMTP
> specs, but its there if you know about the inheritance.
> 
> When it is all said and done, max practical application of mailbox
address
> is 63 chars for localpart, "@" separator, 63 chars for domain-part.
> Anything beyond that runs afoul of one or more standards.
> 
> </pedantry>
> 
> -- 
> Eric A. Hall
http://www.ehsco.com/
> Internet Core Protocols
http://www.oreilly.com/catalog/coreprot/
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
--
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Stefan Santesson" <[email-masked]>
Date: Mon, 20 Mar 2006 22:50:01 -0000

I'm not disagreeing with anything in this discussion.

However I don't think we need to address this in the discussed document.
The username in the defined domain hint is an account name and not
necessarily a host name. Name restrictions in this case are thus
governed by user name restrictions for the accessed system.

Stefan Santesson

> From: Eric A. Hall [mailto:[email-masked]]
> Sent: den 7 mars 2006 21:06
> To: Mark Andrews
characters
/etc/hosts
have a
in
The
address
http://www.ehsco.com/