Subject: Re: Guidance needed on well known ports

From: [email-masked] (Noel Chiappa)
Date: Mon, 20 Mar 2006 13:03:36 -0500 (EST)

> From: "Steven M. Bellovin" <[email-masked]>

    >> Another option, now that I think about it, though, is a TCP option
    >> which contained the service name - one well-known port would be the
    >> "demux port", and which actual application you connected to would
    >> depend on the value in the TCP option.

    > Like tcpmux, port 1, RFC 1078?

You know, as I was typing that, I was thinking "I'll bet someone has something
that does this, and I just don't know about it, and I'm going to look dumb as
toast"... Sigh... :-)

Which leaves us the obvious question: why aren't more people using TCPMux, if
it already exists?

	Noel

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Michael Thomas <[email-masked]>
Date: Mon, 20 Mar 2006 10:09:03 -0800

> Which leaves us the obvious question: why aren't more people using TCPMux, if

Because port 80 exists?

		Mike

---

From: Joe Touch <[email-masked]>
Date: Thu, 23 Mar 2006 20:40:13 -0800

> Which leaves us the obvious question: why aren't more people using TCPMux, if

Because it relies on data and reply is passed in-band. It means that the
application ends up thinking the connection is established even if it
would have failed.

Putting the info in an option is a better solution, since the SYN-ACK
can depend on whether the port resolution was successful.

Joe