Subject: RE: IPv6 vs. Stupid NAT tricks: false dichotomy? (Was: Re:StupidNAT tricks and how to stop them.)

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 28 Mar 2006 12:37:35 -0800

> From: Markku Savela [mailto:[email-masked]] 

> > From: "Hallam-Baker, Phillip" <[email-masked]>
> 
> > The other side of the coin is the fact that many devices will 
> > effectively require no more than a /128 because of the way they 
> > connect up to the network. For example cell phones will be 
> serviced on 
> > plans where the subscription fee is per device. Verizon, T-mobile, 
> > cingular need no more than one /64 each to service those networks.
> 
> Uhh...
> 
> - I thought they actually do (should) give /64 per phone, so that
>   standar IPv6 address configuration works (you get IPv6 link local
>   and global addresses from RA).
> 
> - phone can use more that one address if you use the phone connection
>   to link your local network to the global internet without NAT,
>   (needs some "nasty" ND-proxy hacks though..)
> 
> All Symbian phones have full IPv4/IPv6 dual stack on them already.

My point was that even if we do run out of /64s at some point the last few
remaining /64s can be made to go one heck of a long way.

Even if we do eventually exhaust the address space we can fix up the
problems easily enough at the internetwork level. 
_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Anthony G. Atkielski" <[email-masked]>
Date: Wed, 29 Mar 2006 05:42:43 +0200

Hallam-Baker, Phillip writes:

> My point was that even if we do run out of /64s at some point the
> last few remaining /64s can be made to go one heck of a long way.

So the address space will ultimately be managed in crisis mode,
because it was so badly mismanaged to begin with.  Why does that sound
familiar.

> problems easily enough at the internetwork level. 

Why not just do things right to begin with?