Subject: RE: RFC 4612 - historic status

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 14 Aug 2006 07:18:15 -0700

If what I am reading is correct it sounds like the real design mistake here was putting semantics into content types in the first place.

A code point registration should be just that, registration of a unique identifier to prevent confusion. Once people start adding semantics into the identifier the choice of name starts to have consequences.

At one point there were people arguing that it should be application/html. They were wrong and they were (rightly) ignored. But the arguments made then demonstrated that the taxonomic scheme for the semantics was bogus. 

> -----Original Message-----
> From: Harald Alvestrand [mailto:[email-masked]] 
> Sent: Monday, August 14, 2006 9:48 AM
> To: Paul E. Jones
> Cc: [email-masked]; 'Eliot Lear'; [email-masked]
> Subject: Re: RFC 4612 - historic status
> 
> Paul E. Jones wrote:
> > Brian,
> >
> > The problem with using "image" is that it would mean that a gateway 
> > would have to do one of:
> > 1) Close the audio session and open an image session
> > 2) Open a second "image" session during mid-call
> > 3) Open both an audio session and image session at the outset
> The real underlying problem was that the idea of an "audio 
> session" was a design mistake.
> 
> Practice has shown that sessions consist of multiple media.
> 
> Unfortunately the IETF hasn't fixed that design mistake, so 
> the ITU has kluged around it with things like "audio/t34".
> 
> My opinion. And yes, the discussion of how to recover from 
> that mistake belongs in the RAI area.
> 
>                     Harald
> 
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Ned Freed <[email-masked]>
Date: Mon, 14 Aug 2006 09:00:57 -0700 (PDT)

> If what I am reading is correct it sounds like the real design mistake here
> was putting semantics into content types in the first place.

No, the mistake is in reading more into the very limited semantics of top level
types than was ever intended. As Harald says, the way SDP uses top level types
is at odds with their intent. And we have two choices: Fix that mistake or
continue to kludge around it.

I also agree with Harald that it is up to the RAI area to deal with the
mistake. Perhaps the right choice is to continue kludging, but if so the
approach at least needs to be justified a bit better than it has been in the
past.

> A code point registration should be just that, registration of a unique
> identifier to prevent confusion. Once people start adding semantics into the
> identifier the choice of name starts to have consequences.

The choice of a name has consequences ab initio. It is a name, after all, and
we attach significance and meaning to names independent of any contexual
semantics.

Now, you could argue that media types should be assigned numbers, not names, or
even better a meaningless string of characters. This would avoid the both the
semantics associated with names as well as any  semantics attachment issue. But
it comes at the expense of readability, and at the time the system was set up
it was felt that having readable type names had benefits well worth the costs.

Similarly, the very limited semantics associated with the top level type name
were felt to be sufficiently useful to include. And even if I were convinced
this choice was wrong (and I'm a long way away from that), it's a done deal
now.

> At one point there were people arguing that it should be application/html.
> They were wrong and they were (rightly) ignored. But the arguments made then
> demonstrated that the taxonomic scheme for the semantics was bogus.

No, it demonstrated that it is a weak scheme. Which is all it was ever intended
to be.

				Ned