Subject: RE: Now there seems to be lack of communicaiton here...

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Sat, 2 Sep 2006 19:24:01 -0700

Actually the scheme I propose does not depend on pre-announcement of the list, only providing a proof of registration.
 
I have not worked out exactly to avoid every attack but there is certainly no need to publish everyone's email address - although it is odd that you would mention that as the IETF is currently publishing my telephone number I gave when registering for a previous IETF. Certainly every selected member of NOMCON has to be reachable by email.
 
All you require is a unique identifier. It could be the participant's name. If a person is registered twice and this is detected then you use the name that occurs first in some cannonical ordering.
 
The registration mechanism could be a Web form that you fill in that causes a receipt to be sent to the email address specified. That way a registrant has a proof that they registered and can use that to challenge the list.

________________________________

	From: Eastlake III Donald-LDE008 [mailto:[email-masked]] 
	Sent: Saturday, September 02, 2006 6:39 PM
	To: IETF-Discussion
	Subject: RE: Now there seems to be lack of communicaiton here...

	Depends what you mean by "it". The overall process may have broke in this case but the "it" referred to in the message you were responding to is the "cryptographic" part of the process. The one in RFC 3797 depends on pre-announcement of the ordered list of volunteers. The one you suggested depends on pre-announcement of the email address of every volunteer. Neither is any more robust than the other against a failure to make all the information necessary for public verification available in advance, including the specification of the source of future randomness.
	 
	Donald

________________________________

	From: Hallam-Baker, Phillip [mailto:[email-masked]] 
	Sent: Saturday, September 02, 2006 10:00 AM
	To: John C Klensin; Ned Freed; Eastlake III Donald-LDE008
	Cc: IETF-Discussion
	Subject: RE: Now there seems to be lack of communicaiton here...

	If it ain't broke? How much more evidence of being broke do we need?
	
	The bug here is that the process is insufficiently robust under operator error.
	
	That is broke.
	
	The underlying problem here is the lack of auditability in the process.
	
	There is a simple fix here, eliminate the dependency on the list ordering and the system does not have such a critical dependence on the operator.
	
	Again nobody is claiming anything dishonest has happened here. The concern is that the accident could be repeated on purpose in the future to exclude undesirable candidates. Having spent part of last month watching this attempted in Alabama it is a real concern.
	
	When something is broke admit the fact. Prattling on about not fixing what aint broke only makes people angry.

	Sent from my GoodLink Wireless Handheld (www.good.com)

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "todd glassey" <[email-masked]>
Date: Mon, 4 Sep 2006 07:49:46 -0700

RE: Now there seems to be lack of communicaiton here...Its time to talk about term limits for NOMCOM appointments. Two or maybe three terms at most are enough. If the IETF cannot bring in fresh management blood then it has become unnecessary and a vehicle through which only those initiatives approved by the sitting management ever get undertaken.

Its time for some reform.

Todd Glassey
  ----- Original Message ----- 
  From: Hallam-Baker, Phillip 
  To: Eastlake III Donald-LDE008 ; IETF-Discussion 
  Sent: Saturday, September 02, 2006 7:24 PM
  Subject: RE: Now there seems to be lack of communication here...

  All you require is a unique identifier. It could be the participant's name. If a person is registered twice and this is detected then you use the name that occurs first in some canonical ordering.

----------------------------------------------------------------------------
    From: Eastlake III Donald-LDE008 [mailto:[email-masked]] 
    Sent: Saturday, September 02, 2006 6:39 PM
    To: IETF-Discussion
    Subject: RE: Now there seems to be lack of communicaiton here...

    Donald

----------------------------------------------------------------------------

    That is broke.

------------------------------------------------------------------------------

---

From: "Bill Fenner" <[email-masked]>
Date: Mon, 4 Sep 2006 22:04:23 -0400

On 9/4/06, todd glassey <[email-masked]> wrote:
> Its time to talk about term limits for NOMCOM appointments. Two or maybe
> three terms at most are enough.

Todd,

  Given that there are no standing IESG appointees that have served
for three terms, what exactly would making such a rule change?

Arkko, Jari     0.2
Callon, Ross     0.2
Carpenter, Brian        0.7
Dusseault, Lisa         0.2
Eggert, Lars    0.2
Fenner, Bill    2.5
Hardie, Ted     1.7
Hartman, Sam    0.8
Housley, Russ   1.7
Jennings, Cullen        0.2
Kessens, David  1.3
Peterson, Jon   1.7
Romascanu, Dan  0.2
Townsley, Mark  0.7
Westerlund, Magnus      0.2

(This is "AD" and "number of terms served", where "numbers of terms
served" is counted by adding up the number of IETFs the AD is listed
under at http://www.ietf.org/iesg_mem.html and dividing by 6)

  Bill

[to be fair, 2 of the above positions didn't exist until their holders
were appointed 0.2 terms ago]

---

From: "todd glassey" <[email-masked]>
Date: Tue, 5 Sep 2006 06:11:17 -0700

I originally said two...and would prefer that.

What I am saying is that there should be a total of two or three instances
as a NOMCOM candidate and that is a much different statement than figuring
who is in office now and who is eligible...As to what it prevents-career
Internet Standards jockey's.

And since the purpose is to keep the IETF honest, I want the same term
limits for any and all IETF positions, including the TRUST as well.

By the way - has anyone seen a Business Plan for the TRUST and what it is
supposed to do? I don't mean some fictional set of ideas - I mean the
business plan. I want to see exactly what the Trust is responsible for and
how its to be measured,

Todd

----- Original Message ----- 
From: "Bill Fenner" <[email-masked]>
To: "todd glassey" <[email-masked]>
Cc: "IETF-Discussion" <>
Sent: Monday, September 04, 2006 7:04 PM
Subject: Re: NOMCOM term limits... Re: Now there seems to be lack of
communicaiton here...

---

From: Andrew Newton <[email-masked]>
Date: Tue, 05 Sep 2006 10:02:32 -0400

> limits for any and all IETF positions, including the TRUST as well.

Including working group chairs and secretaries and directorate members?

-andy

---

From: John C Klensin <[email-masked]>
Date: Tue, 05 Sep 2006 10:16:12 -0400

--On Tuesday, September 05, 2006 6:11 AM -0700 todd glassey 
<[email-masked]> wrote:

> What I am saying is that there should be a total of two or
> three instances as a NOMCOM candidate and that is a much
> different statement than figuring who is in office now and who
> is eligible...As to what it prevents-career Internet Standards
> jockey's.
>
> And since the purpose is to keep the IETF honest, I want the
> same term limits for any and all IETF positions, including the
> TRUST as well.
>
> By the way - has anyone seen a Business Plan for the TRUST and
> what it is supposed to do? I don't mean some fictional set of
> ideas - I mean the business plan. I want to see exactly what
> the Trust is responsible for and how its to be measured,

Todd,

Term limit ideas for IESG, IAB, and others, and even a 
suggestion that no one should be able to serve on consecutive 
Nomcoms, have been floated multiple times and have gone nowhere. 
I believe the latest attempt was as part of 
draft-klensin-nomcom-term-01.txt, which appears to be going 
nowhere as well.

If you have a proposal here, I recommend that you make it in the 
form of an Internet Draft that is specific enough that people 
can actually comment on, or respond to, it.    And, since 
proposals that have been fairly strongly motivated haven't even 
progressed to a WG review or IETF Last Call, I recommend that 
you justify your preferences in someone more detail than saying 
"I want".  In this area, there is clear evidence that no one 
cares about what you want or, for that matter, what I want.

Just my opinion.
    john

---

From: "todd glassey" <[email-masked]>

IEEE or the ABA. Those are also volunteer organizations.

> -----Original Message-----
> From: todd glassey [mailto:[email-masked]]
> Sent: Tuesday, September 05, 2006 9:11 AM
> To: Bill Fenner; [email-masked]
> Subject: Re: NOMCOM term limits... Re: Now there seems to be
> lack ofcommunicaiton here...
>
> different statement than figuring who is in office now and
> who is eligible...As to what it prevents-career Internet
> Standards jockey's.
>
> same term limits for any and all IETF positions, including
> the TRUST as well.
>
> By the way - has anyone seen a Business Plan for the TRUST
> and what it is supposed to do? I don't mean some fictional
> set of ideas - I mean the business plan. I want to see
> exactly what the Trust is responsible for and how its to be measured,
>
> Todd
>
> Subject: Re: NOMCOM term limits... Re: Now there seems to be
> lack of communicaiton here...
>
>

---

From: "todd glassey" <[email-masked]>
Date: Tue, 5 Sep 2006 07:34:42 -0700

YES
----- Original Message ----- 
From: "Andrew Newton" <[email-masked]>
To: "todd glassey" <[email-masked]>
Cc: "Bill Fenner" <[email-masked]>; <[email-masked]>
Sent: Tuesday, September 05, 2006 7:02 AM
Subject: Re: NOMCOM term limits... Re: Now there seems to be lack of
communicaiton here...

[email-masked]>
	<[email-masked]>
Date: Tue, 5 Sep 2006 07:34:42 -0700
Cc: Bill Fenner <[email-masked]>, [email-masked]
Subject: Re: NOMCOM term limits... Re: Now there seems to be lack
	of	communicaiton here...

YES
----- Original Message ----- 
From: "Andrew Newton" <[email-masked]>
To: "todd glassey" <[email-masked]>
Cc: "Bill Fenner" <[email-masked]>; <[email-masked]>
Sent: Tuesday, September 05, 2006 7:02 AM
Subject: Re: NOMCOM term limits... Re: Now there seems to be lack of
communicaiton here...

---

From: Michael Thomas <[email-masked]>
Date: Tue, 05 Sep 2006 08:35:11 -0700

>limits for any and all IETF positions, including the TRUST as well.
I usually route around ietf political damage as much as possible, but the
real life experience at least here in California is that this is a load 
of hooey.
Term limits don't do any of these things, they just rearrange the deck 
chairs.
There will always be "Internet-Standards-Jockeys", it's just a question 
of whether
the power they wield is transparent or not. Making them move to the 
shadows --
as power brokers always do when they can't be in power themselves -- changes
the dynamic, but it doesn't do what you claim. The one thing that it *does*
do is create clue scarcity when that wasn't a necessary outcome before. 
Which
of course benefits the power brokers, not the process or constituency.

But if you really want to prevent "career Internet Standards Jockey's", why
not go to the root of the problem: IETF participation in general. Why 
wouldn't
it be a good idea to prevent people who've been participating for, oh say, 5
years to participate anymore? That would really clear out the dead wood.

       Mike

---

From: Michael Thomas <[email-masked]>
Date: Tue, 05 Sep 2006 08:35:11 -0700

Mike

---

From: "todd glassey" <[email-masked]>
Date: Tue, 5 Sep 2006 09:20:59 -0700

John - the problem, is that management doesn't want either of us to gain any
traction on reform or process with real oversight, and actually for all my
ssssssssssssssssssssssssscreaming into the wind all I really want is a
process that actually is fair and open.

Again - I think the answer is a cafeteria style standardization process
where the IETF nor IESG are responsible for the actual promotion of
proposed standard to standard status ...

Todd

----- Original Message ----- 
From: "John C Klensin" <[email-masked]>
To: "todd glassey" <[email-masked]>
Cc: "Bill Fenner" <[email-masked]>; <[email-masked]>
Sent: Tuesday, September 05, 2006 7:16 AM
Subject: Re: NOMCOM term limits... Re: Now there seems to be lack of
communicaiton here...

---

From: John C Klensin <[email-masked]>
Date: Tue, 05 Sep 2006 14:50:33 -0400

--On Tuesday, September 05, 2006 9:20 AM -0700 todd glassey 
<[email-masked]> wrote:

> John - the problem, is that management doesn't want either of
> us to gain any traction on reform or process with real
> oversight, and actually for all my
> ssssssssssssssssssssssssscreaming into the wind all I really
> want is a process that actually is fair and open.
>
> Again - I think the answer is a cafeteria style
> standardization process where the IETF nor IESG are
> responsible for the actual promotion of proposed standard to
> standard status ...

Todd,

I think you are describing no standardization process at all. 
Maybe it would be a specification-publishing process, but 
perhaps anyone could do that with a few web pages and an ability 
to shout "people should pay attention to me" and then see if 
anyone listens.

Again, if you have a proposal that is specific enough to stand 
careful review and scrutiny, then write it up as a well-formed 
I-D and get it posted.    At the moment, my assumption is that 
even your definition of "fair and open" differs from the general 
consensus of the IETF community _and_ that of the implementer/ 
user community.  No amount of mailing list posting will reverse 
that assumption, only a proposal that is specific enough to 
really evaluate.

Without such a proposal, you are doing little more than 
screaming "I don't like the way it works, you are required to 
change it" over and over again.   That is not persuasive. 
Indeed, "screaming" may be the wrong metaphor wrt what you are 
doing into the wind.

    john

p.s. If I felt that there were a management conspiracy against 
openness or fairness around here, I'd just quietly go somewhere 
else and try to encourage others --including vendors and 
implementers-- to follow.  The IETF is really not that 
important; the development work, products, and the Internet are.