Subject: RE: SRV records considered dubious (was: Re: DNS Choices: Was: [ietf-dkim] Re: Last Call: 'DomainKeys)

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 22 Nov 2006 06:36:46 -0800

> From: John C Klensin [mailto:[email-masked]] 

> And, to add one more observation to Keith's list, unless one 
> is extremely careful, especially when considering using SRV 
> to add support for protocols that were defined without it, 
> one also risks recreating all of the problems that caused WKS 
> to be deprecated.  In other words, 
> 
> 	* If there is no SRV record present, can I assume the
> 	service is not supported?   (No)
> 	
> 	* If there is an SRV record present, can I assume the
> 	server is supported and available? (No, not that either).

As in the case of email and MX this is only the case for legacy protocols that do not have mandatory support for SRV required. MX records do not guarantee the existence of a service but that's not their function so why hold it up as a defect?

We are currently seeing an explosion of new protocol development using Web Services. It is long past time to declare UDDI a failure and recognize that it isn't going to happen. But Web Services are predicated on the existence of a signaling infrastructure. 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Keith Moore <[email-masked]>
Date: Wed, 22 Nov 2006 09:54:50 -0500

> We are currently seeing an explosion of new protocol development
> using Web Services. It is long past time to declare UDDI a failure
> and recognize that it isn't going to happen. But Web Services are
> predicated on the existence of a signaling infrastructure.

if SRV works well for Web Services, fine, but that doesn't mean SRV is 
appropriate for everything.  and as far as I can tell, DNS is poorly 
suited to be an application signaling infrastructure.

Keith