Subject: RE: SRV records considered dubious (was: Re: DNS Choices: Was: [ietf-dkim] Re: Last Call: 'DomainKeys)

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 22 Nov 2006 17:42:35 -0800

> From: [email-masked] [mailto:[email-masked]] 

> 	Note it is possible to upgrade the DNS servers and *still*
> 	have active directory support.

You lose the coupling of AD and DNS.

That seriously impair the DKIM/MARID value proposition. It is a major infrastructure change.

> 	A compentent system administator would use all the 
> tools available
> 	to them.

No a competent admin looks at the cost / benefit. 

> 	The fact that you seem to want to restrict the solution space
> 	to only Microsoft Windows servers on a Windows box is what has
> 	clouded your judgement.

No, the fact that I do not choose to force the products of your employer down people's throats is not an error of judgement on my part.

In my space failing to take account of the largest server provider is a deployment issue. 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: David Conrad <[email-masked]>
Date: Wed, 22 Nov 2006 21:17:38 -0800

> You lose the coupling of AD and DNS.

Why do you say this?  There are at least two DNS server  
implementations that I know of that implement Microsoft compatible AD  
support.

> No, the fact that I do not choose to force the products of your  
> employer down people's throats is not an error of judgement on my  
> part.

There are several other servers than ISC's that support unknown RRs.   
In fact, I suspect Microsoft is one of the few (perhaps even only)  
current DNS server software implementers that still does not support  
unknown RRs in one way or another.

> In my space failing to take account of the largest server provider  

IMHO, not supporting unknown RRs at this day and age is a bug and it  
should be treated as such.

Rgds,
-drc