Subject: RE: Something better than DNS?

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 28 Nov 2006 13:37:13 -0800

> From: Stephane Bortzmeyer [mailto:[email-masked]] 

> On Tue, Nov 28, 2006 at 08:57:08AM -0800,  Hallam-Baker, 
> Phillip <[email-masked]> wrote  a message of 31 lines which said:
> 
> > If GoDaddy and TuCows both attempt to register the same name at the 
> > same time they may well submit their orders through 
> separate machines. 
> > Ultimately there is a mechanism for resolving the potential 
> conflict 
> > of course
> 
> The important point is that, for ".com", all these machines 
> are under the same organization. It makes a huge difference.

True it makes a difference. It is much simpler, much more reliable if the resolution mechanism does not need to deal with Byzantine agreements. 

What you absolutely cannot get away from is a mechanism to ensure joint action. 

The reason the distinction matters is that the idea of changing the existing DNS to work differently is pure fantasy. There are however circumstances where the established business relationships are rather different and any infrastructure proposal must take account of that fact.

In case folk missed it the point of the exercies here is to meet the needs of the Internet users, not solve cute academic puzzles for the sake of arbitrary ideological goals.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 28 Nov 2006 18:07:35 -0800

It is technically possible for the United States and Europe to switch from driving on the wrong side of the road to the left. That does not mean that proposing to do so is anything other than idiotic.

What I said was that these proposals amount to distinction without a difference. The switching costs are huge, the end result indistinguishable except to the extent that you have multiplied the number of failure modes drastically.

> -----Original Message-----
> From: Emin Gun Sirer [mailto:[email-masked]] 
> Sent: Tuesday, November 28, 2006 7:32 PM
> To: Stephane Bortzmeyer
> Cc: Patrick Vande Walle; [email-masked]
> Subject: Re: Something better than DNS?
> 
> Stephane & Phillip,
> 
> I'm thinking of writing a short report that summarizes the 
> invaluable discussion here and beefing up the system sketch. 
> I think we now agree that it is possible to have multiple 
> operators manage names in a single, shared namespace without 
> recourse to a centralized super-registry. 
> 
> >Do you think it fits well in Hallam-Baker, Phillip's 
> "logical registry"
> >model?
> 
> Yes, the registrars together implement a logical registry 
> without any centralized component.
> 
> > * how does it scale? 
> 
> The protocol I sketched was for just two parties; it can be 
> generalized, but let's take that discussion offline. It's 
> certainly possible to do it, but something that'll work fast 
> and with participants that will trigger timeouts might 
> require quorums, a slightly different approach.
> 
> > * DNS registration is not binding a name to an IP! (See 
> Edward Lewis'
> > good description). It is binding a name to an entity which is often 
> > fuzzily defined (see whois' output). How do you address this?
> 
> One can use a protocol like that to just serialize the events, i.e.
> establish order, regardless of what the events that comprise 
> a registration are.
> 
> >What you absolutely cannot get away from is a mechanism to 
> ensure joint 
> >action.
> 
> True. The question was whether the mechanism necessarily had 
> a centralized component.
> 
> >the point of the exercies here is to meet the needs of the Internet 
> >users, not solve cute academic puzzles for the sake of arbitrary 
> >ideological goals.
> 
> For one, I am totally agnostic on this issue. It's possible 
> and maybe even practical to delegate a space to multiple 
> operators without a super-registry, and neither I nor the 
> workings of CoDoNS care whether we do that or not.
> 
> As an Internet user, I wonder about two things in the long term:
> 	- why is it so expensive to register a name?
> 	- what can we do to keep SiteFinderJr from happening?
> 
> In the short term, I think we have bigger issues to worry about (e.g.
> current DNS's vulnerability to denial-of-service attacks).
> 
> Gun.
> 
> 
>

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 29 Nov 2006 08:49:19 -0800

> From: Harald Alvestrand [mailto:[email-masked]] 

> Emin Gun Sirer wrote:
> what do you think of as "expensive"?
> 
> I can register a name for a year for the price of 2 beers 
> (ok, beer in Norway is expensive too...)
> 
> There are very few components of setting up something useful 
> on the Internet that cost less.

I don't want to address the current cost, but I will point out that there are people who are proposing ideas that would make names cost very much more by requiring domain name holders to be authenticated.

I don't like this idea despite the obvious advantages for control of Internet crime should it succeed. Running a serious authentication process with global scope has significant costs. I don't want to have to pay the cost of an EV SSL certificate just to own a domain name. Nor I suspect do most domain name owners.

The core DNS is the one component of the Internet that has to be there for an Internet service to function. You can implement multiple redundancy, get drops from multiple ISPs etc. but if core DNS is down you are down. People could argue that maybe VeriSign has built out for one or two 9s more than is absolutely essential, that the Internet only needs to be Internet grade reliable not significantly better than carrier grade. That is an interesting conversation to have, I don't think that there will be many people in the policy community who are receptive to the argument though.
_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 29 Nov 2006 17:19:58 -0800

> From: Edward Lewis [mailto:[email-masked]] 
> At 11:42 -0500 11/29/06, Emin Gun Sirer wrote:
> 
> >Let's not torque the discussion off topic. Free market 
> economics does 
> >not come to bear on the issue because there is no free 
> market to speak 
> >of for registries.
> 
> What did I say about frictionless surfaces?

Edward, assume frictionless surfaces is what a physicist says to an engineer. This is economics, a consensual delusion on a much grander scale.

We did not merely assume the surface to be frictionless: by making the assumption we caused the surface to become frictionless.

Having assumed a free market we have caused the market to become free of all defects such as time delay, liquidity, imperfect knowledge and all the other real world effects without which Wall Street would make no money.

Having assumed that people behave as perfect evaluators of their narrow self interest and act in strict accord with those interests we have turned the entire population into selfish bastards who can calculate their best interest to three decimal places.