Subject: RE: Something better than DNS?

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 28 Nov 2006 08:57:08 -0800

> From: Emin Gun Sirer [mailto:[email-masked]] 

> Stephane,
> 
> > It is not artificial, it is the way it has to work. You cannot have 
> > multiple registries for one TLD, period. No more than you can have 
> > perpetual motion.
> 
> Be careful about making statements about impossibility 
> without an associated impossibility proof. History is full of 
> people who look sort of funny in retrospect. Protocols for 
> serialization and agreement with byzantine participants are 
> well-established. This is kind of like saying 
> "heavier-than-air machines cannot fly," in 2006.

There must be a single logical registry even if the physical realization of that registry is achieved through multiple machines under control of multiple parties.

ATLAS contains more than one machine today. We talk about the 'J-root' even though that is in fact multiple independent machines.

If you look at the registrar interface there are multiple machines there. If GoDaddy and TuCows both attempt to register the same name at the same time they may well submit their orders through separate machines. Ultimately there is a mechanism for resolving the potential conflict of course but this is also a logical function that may be realized by different physical machines depending on the precise state of the constelation at the time.

You cannot guarantee uniqueness of the names registered without some form of communication between the registrars. Ergo there must be a single logical registry even if the functions are distributed.

And regardless of what situation might be considered 'best' any change that is proposed to the status quo must provide a sufficient benefit to justify the costs of any transition.

The registry/registrar interface is not the principle cost center in the core DNS infrastructure. There are substantial development costs but the proposal made would only increase these. Transfering these costs from the registry to the registrars as is proposed does not in any way improve the economics of core DNS. 

The costs in core DNS are due to the distribution side of the equation. OC-48s and OC-192s cost serious amounts of money. There are non-trivial investments in hardware, software and process. The registrars do not want to invest in these areas. There is an argument to be made that we do not want registrars to be competing on the basis of the reliability of their resolution services.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 28 Nov 2006 22:19:08 +0100

On Tue, Nov 28, 2006 at 08:57:08AM -0800,
 Hallam-Baker, Phillip <[email-masked]> wrote 
 a message of 31 lines which said:

> If GoDaddy and TuCows both attempt to register the same name at the
> same time they may well submit their orders through separate
> machines. Ultimately there is a mechanism for resolving the
> potential conflict of course 

The important point is that, for ".com", all these machines are under
the same organization. It makes a huge difference.

.org (Postfix, from userid 1000)
	id B4C50113D4; Tue, 28 Nov 2006 22:19:08 +0100 (CET)
Date: Tue, 28 Nov 2006 22:19:08 +0100
From: Stephane Bortzmeyer <[email-masked]>
To: "Hallam-Baker, Phillip" <[email-masked]>
Cc: [email-masked]
Subject: Re: Something better than DNS?

On Tue, Nov 28, 2006 at 08:57:08AM -0800,
 Hallam-Baker, Phillip <[email-masked]> wrote 
 a message of 31 lines which said:

> If GoDaddy and TuCows both attempt to register the same name at the
> same time they may well submit their orders through separate
> machines. Ultimately there is a mechanism for resolving the
> potential conflict of course 

The important point is that, for ".com", all these machines are under
the same organization. It makes a huge difference.