Subject: Re: I-D ACTION:draft-farah-adntf-adns-guidelines-02.txt

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 21 Dec 2006 10:40:27 +0100

On Wed, Dec 20, 2006 at 06:50:01PM -0500,
 [email-masked] <[email-masked]> wrote 
 a message of 107 lines which said:

> 	Title		: Guidelines for an Arabic Domain Name System (ADNS)
> 	Author(s)	: M. Farah, et al.
> 	Filename	: draft-farah-adntf-adns-guidelines-02.txt,.ps,.pdf

The text is so full of mistakes that I suggest it should receive
little consideration. The worst mistake:

>	The Domain Name System (DNS) only recognizes ASCII characters
>	A-Z, 0-9 and '-'.

Another one is the systematic confusion between language and writing
system (the fact that the ICANN does the same error is not an excuse).
 
The most funny mistake is:

>        Further to this, the uniqueness of an Arabic Domain Name on
>        the Internet is currently not guaranteed; so two entities/persons can
>        register the same name on two different registries!

What, it is possible for two different persons to register
bortzmeyer.ch and bortzmeyer.fr? :-)

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 21 Dec 2006 16:42:20 +0100

--On 21. desember 2006 10:40 +0100 Stephane Bortzmeyer <[email-masked]> 
wrote:

>>        the Internet is currently not guaranteed; so two entities/persons
>>        can register the same name on two different registries!
>

No, it means that you can register bortzmeyer.ch on <rogue root 1>, and 
someone else can register bortzmeyer.ch on <rogue root 2>.

There are multiple roots serving TLDs having Arabic script names, but ICANN 
doesn't.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 21 Dec 2006 16:57:03 +0100

On Thu, Dec 21, 2006 at 04:42:20PM +0100,
 Harald Alvestrand <[email-masked]> wrote 

> There are multiple roots serving TLDs having Arabic script names, but ICANN 

Ah, OK, thanks for the explanation. But it is not specific to Arabic,
it is a general problem of competing roots. 

The fact that they refer to competing roots is not obvious at all from
the draft. It could as well be a reference to two encoding systems (as
if Punycode and RACE were both in use).