Subject: RE: adoption times (was Re: DNS Choices)

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 11 Dec 2006 11:10:37 -0800

The Web was designed for deployment from the start. 

Its success was not pre-ordained. There were many rival hypertext schemes that were stillborn. 

I do find it rather ironic though people use the example of the Web to argue that we should not bother with design for deployment. IM is still a network application, it is not an inter-network application yet.

> -----Original Message-----
> From: Dave Crocker [mailto:[email-masked]] 
> Sent: Monday, December 11, 2006 11:33 AM
> To: David Morris
> Cc: [email-masked]
> Subject: adoption times (was Re: DNS Choices)
> 
> 
> 
> David Morris wrote:
> > It isn't a trivial technical problem to revise the 
> electronic message 
> > infrastructure to arrange for payment of postage but to 
> assert that it 
> > can't be done or wouldn't be deployed flys in the face of the 
> > relatively short time frame for adoption of the WWW or IM.
> adoption
> 
> I suspect you already know this, given your language, above, 
> but its possible to confuse a distinction yo imply:
> 
> There is a fundamental difference between adopting a new 
> service, versus revising an existing one.  WWW and IM were 
> new.  No concern over protecting the installed base.
> 
> It is one of the reasons that successful revision efforts 
> which take a shorter time attempt to do so in a way that 
> emulates adopting a new one.
> 
> MIME is a particularly successful version of that.  No 
> changes to the infrastructure.  Didn't break recipient 
> software that didn't support it.  And delivered a message 
> that was still moderately readable for the non-supporting 
> recipient.  (Oh, and the recipient could incorporate MIME, 
> later, and be able to enjoy its features.)
> 
> d/
> -- 
> 
>    Dave Crocker
>    Brandenburg InternetWorking
>    bbiw.net
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Edward Lewis <[email-masked]>
Date: Thu, 14 Dec 2006 17:53:06 -0500

>Its success was not pre-ordained. There were many rival hypertext schemes

Yep.  I wrote a MS thesis on a hypertext system about 5 years before 
the WWW as we know it today took off.  Even by then I had an 
extensive list of references to include.  The oldest was an article 
from 1945 "As We May Think." 
(http://www.theatlantic.com/doc/194507/bush)

Perhaps we should say that "Bush Invented the Web", not Al Gore. ;)
-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Edward Lewis                                                +1-571-434-5468
NeuStar

Dessert - aka Service Pack 1 for lunch.

---

From: John Levine <[email-masked]>
Date: 14 Dec 2006 23:18:57 -0000

>extensive list of references to include.

Hi.  Any chance I could get a copy of it?  I'm collecting prior art for
a likely patent case related to early web technology.  Tnx.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Information Superhighwayman wanna-be, http://www.johnlevine.com, Mayor
"More Wiener schnitzel, please", said Tom, revealingly.

PS: In case anyone asks, Neustar isn't a party.