Subject: RE: Last Call: draft-ietf-v6ops-natpt-to-historic (Reasons to Move NAT-PT to Historic Status) to Informational RFC

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 28 Feb 2007 12:40:18 -0800

Is there a document that describes a deployment plan under a two stack transition?

I am somewhat uncomfortable moving documents to historic just because they contain ideas we find unpleasant. And in particular I would rather see documents that say 'this is how to solve a problem' rather than 'this is why this solution sucks'.

> -----Original Message-----
> From: David Conrad [mailto:[email-masked]] 
> Sent: Wednesday, February 28, 2007 2:36 PM
> To: Sam Hartman
> Cc: Hallam-Baker, Phillip; [email-masked]; [email-masked]
> Subject: Re: Last Call: draft-ietf-v6ops-natpt-to-historic 
> (Reasons to Move NAT-PT to Historic Status) to Informational RFC
> 
> Sam,
> 
> On Feb 28, 2007, at 8:37 AM, Sam Hartman wrote:
> > I think it is
> > more like we have existing NAT mechanisms; we have strategies for 
> > making them work.  Dual stack nodes is a better way forward than 
> > creating a new NAT mechanism to move from IPV6 to IPV4 and 
> trying to 
> > make that (with a different set of problems than traditional NAT) 
> > work.
> 
> Doesn't dual stack rely on the assumption that IPv4 is available?
> 
> Based on current projections, in a smallish number of years 
> (more than 2, less than 10), the free pool for IPv4 will be 
> exhausted.  I have some skepticism, perhaps unjustified, that 
> IPv6 will be ubiquitous in that timeframe.  As such, it would 
> appear there needs to be some sort of solution that will 
> allow IPv6-only sites to talk to IPv4-only sites.  What is 
> the IETF suggesting?
> 
> Thanks,
> -drc
> 
> 
> 
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Fred Baker <[email-masked]>
Date: Wed, 28 Feb 2007 14:00:30 -0800

> Is there a document that describes a deployment plan under a two  

Well, I can't say they are exacty what you're looking for, but you  
might glance at:

http://www.ietf.org/rfc/rfc2767.txt
2767 Dual Stack Hosts using the "Bump-In-the-Stack" Technique (BIS).
      K. Tsuchiya, H. Higuchi, Y. Atarashi. February 2000. (Format:
      TXT=26402 bytes) (Status: INFORMATIONAL)

http://www.ietf.org/rfc/rfc3338.txt
3338 Dual Stack Hosts Using "Bump-in-the-API" (BIA). S. Lee, M-K.
      Shin, Y-J. Kim, E. Nordmark, A. Durand. October 2002. (Format:
      TXT=34480 bytes) (Status: EXPERIMENTAL)

http://www.ietf.org/rfc/rfc3750.txt
3750 Unmanaged Networks IPv6 Transition Scenarios. C. Huitema, R.
      Austein, S. Satapati, R. van der Pol. April 2004. (Format:  
TXT=48153
      bytes) (Status: INFORMATIONAL)

http://www.ietf.org/rfc/rfc3974.txt
3974 SMTP Operational Experience in Mixed IPv4/v6 Environments. M.
      Nakamura, J. Hagino. January 2005. (Format: TXT=22729 bytes)  
(Status:
      INFORMATIONAL)

http://www.ietf.org/rfc/rfc4038.txt
4038 Application Aspects of IPv6 Transition. M-K. Shin, Ed., Y-G.
      Hong, J. Hagino, P. Savola, E. M. Castro. March 2005. (Format:
      TXT=69727 bytes) (Status: INFORMATIONAL)

http://www.ietf.org/rfc/rfc4215.txt
4215 Analysis on IPv6 Transition in Third Generation Partnership
      Project (3GPP) Networks. J. Wiljakka, Ed.. October 2005. (Format:
      TXT=52903 bytes) (Status: INFORMATIONAL)

http://www.ietf.org/rfc/rfc4241.txt
4241 A Model of IPv6/IPv4 Dual Stack Internet Access Service. Y.
      Shirasaki, S. Miyakawa, T. Yamasaki, A. Takenouchi. December 2005.
      (Format: TXT=20580 bytes) (Status: INFORMATIONAL)

http://www.ietf.org/rfc/rfc4779.txt
4779 ISP IPv6 Deployment Scenarios in Broadband Access Networks. S.
      Asadullah, A. Ahmed, C. Popoviciu, P. Savola, J. Palet. January  
2007.
      (Format: TXT=188511 bytes) (Status: INFORMATIONAL)