Subject: RE: Last Call: draft-klensin-net-utf8 (Unicode Format for Network Interchange) to Proposed Standard

From: Bob Braden <[email-masked]>
Date: Wed, 9 Jan 2008 09:14:42 -0800 (PST)

*> Upon reciept, the following SHOULD be seen as at least line ending
  *> (or line separating), and in some cases more than that: 
  *> 
  *> LF, CR+LF, VT, CR+VT, FF, CR+FF, CR (not followed by NUL...),
  *> NEL, CR+NEL, LS, PS

I don't know whether you regard this as relevant, but I believe that in
the ARPAnet/early Internet days, FF was not regarded as ending a line.
FF only moved the platen one line at the current character position.  I
believe that this was a formalization of the mechanical operation of a
teletype machine.  This interpretation was also, I believe,
incorporated by Jon Postel in the rules for NVT and for RFC
formatting.

I can't believe I am reopening this old topic... ;-(

Bob Braden

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Kent Karlsson" <[email-masked]>
Date: Wed, 9 Jan 2008 23:30:04 +0100

> -----Original Message-----
> From: Bob Braden [mailto:[email-masked]] 
> Sent: Wednesday, January 09, 2008 6:15 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: Last Call: draft-klensin-net-utf8 (Unicode 
> Format for NetworkInterchange) to Proposed Standard
> 
> teletype machine.

Yes, but hardly relevant these days. Note that that interpretation
is similar to "raw" LF. Still, in many systems LF by itself is line
ending ("cooked LF" if you like). Likewise CR, by itself, is line
ending in some systems. Note that CR+FF is listed above as a
single line end, or rather a single line separator (cmp. LF).
(So this is "cooked mode" for LF and FF, for those who remember
the lpr command...; or even still use it...)

See section 5.8 of http://www.unicode.org/versions/Unicode5.0.0/ch05.pdf.
XML also (for conversion reasons) regards CR+NEL as a single line end.

B.t.w. many programs (long ago) had a bug that deleted the last
line if if was not ended with a LF. As an additional comment,
I think that the Net-UTF-8 document should state that the
last line need not be ended by CR+LF (or any other line
end/separator), though it should be. This is just as a matter of
normalising the line ends for Net-UTF8, not for UTF-8 in general.

	/kent k

>  This interpretation was also, I believe,