Subject: Re: Last Call: draft-ietf-imapext-sort (INTERNET MESSAGE ACCESS PROTOCOL - SORT AND THREAD EXTENSIONS) to Proposed Standard

From: Alexey Melnikov <[email-masked]>
Date: Mon, 03 Mar 2008 11:22:14 +0000

The IESG wrote:

>The IESG is considering the following document again now that 
>important dependencies are ready:
>
>- 'INTERNET MESSAGE ACCESS PROTOCOL - SORT AND THREAD EXTENSIONS'
>   <draft-ietf-imapext-sort-19.txt> as a Proposed Standard
>  
>
Hi Mark,
I've just reread section 7 of -19 and found some relatively minor things 
that need fixing:

> 7. Internationalization Considerations
>
>     As stated in the introduction, the server SHOULD support the
>     [IMAP-I18N] COMPARATOR extension and follow its rules to perform
>     collations in the SORT and THREAD extensions.

As per your recent suggestion in the IMAPEXT WG, the COMPARATOR 
extension was renamed to I18NLEVEL=2.
The last sentence in section 1 needs to be updated as well.

>     If the server does not support COMPARATOR, strings MUST be collated
>     according to the i;unicode-casemap collation described in
>     [UNICASEMAP].

I think you also mean that support for at least I18NLEVEL=1 is REQUIREd.

>     As described in [IMAP-I18N], strings in charsets other than US-ASCII
>     and UTF-8 MUST be converted to UTF-8 and compared in ascending order
>     according to the selected or active collation algorithm.  If the
>     server does not support the [IMAP-I18N] COMPARATOR extension, the
>     collation algorithm used is the "en;ascii-casemap" collation
>     described in [COMPARATOR].

The last sentence contradict the second paragraph quoted above. I think 
you forgot to delete it in -19.
If for some reason you want to keep it, then please change 
"en;ascii-casemap" to "i;ascii-casemap", as "en;ascii-casemap" is invalid.

I can recommend some replacement text, if you want.

_______________________________________________
IETF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Mark Crispin <[email-masked]>
Date: Mon, 3 Mar 2008 10:27:16 -0800 (PST)

I agree and will/have address[ed] these in AUTH48.

On Mon, 3 Mar 2008, Alexey Melnikov wrote:
> The IESG wrote:
>
>> The IESG is considering the following document again now that important 
>> dependencies are ready:
>> 
> I've just reread section 7 of -19 and found some relatively minor things that 
> need fixing:
>
> As per your recent suggestion in the IMAPEXT WG, the COMPARATOR extension was 
> renamed to I18NLEVEL=2.
> The last sentence contradict the second paragraph quoted above. I think you 
> forgot to delete it in -19.
> If for some reason you want to keep it, then please change "en;ascii-casemap" 
> to "i;ascii-casemap", as "en;ascii-casemap" is invalid.
>

-- Mark --

http://panda.com/mrc
Democracy is two wolves and a sheep deciding what to eat for lunch.
Liberty is a well-armed sheep contesting the vote.
_______________________________________________
IETF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf