Subject: Query

From: "Gupta, Kapil" <[email-masked]>
Date: Tue, 25 Mar 2008 18:46:03 +0530

Good Day All,

I have a question. Did any one try to register any port for his/their
application/service through IANA?

Please help.

Thank You,

Kapil

The information contained in this electronic mail transmission 
may be privileged and confidential, and therefore, protected 
from disclosure. If you have received this communication in 
error, please notify us immediately by replying to this 
message and deleting it from your computer without copying 
or disclosing it.

_______________________________________________
IETF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: David Conrad <[email-masked]>
Date: Tue, 25 Mar 2008 12:15:40 -0700

Lots of people have.

See http://www.iana.org/protocols/apply/

Regards,
-drc

On Mar 25, 2008, at 6:16 AM, Gupta, Kapil wrote:

> Good Day All,
>
> I have a question. Did any one try to register any port for his/ 
> their application/service through IANA?
>
> Please help.
>
> Thank You,
> Kapil
>
>

---

From: Michelle Cotton <[email-masked]>
Date: Tue, 25 Mar 2008 12:24:33 -0700

Yes.

For ports specifically see
http://www.iana.org/assignments/port-numbers

Most registrations with individuals listed as the contact applied directly to IANA.
Other registrations were made through publication of RFCs.

Let us know if you have any further questions.

Thank you,

Michelle Cotton
IANA

On 3/25/08 6:16 AM, "Gupta, Kapil" <[email-masked]> wrote:

Good Day All,

I have a question. Did any one try to register any port for his/their application/service through IANA?

Please help.

Thank You,
Kapil

---

From: "Gupta, Kapil" <[email-masked]>
Date: Wed, 26 Mar 2008 09:07:05 +0530

Thanks a lot Michelle.

I have a question related. How long it take to register a port for an
application? Is there any monetary policy?

Thank you

Kapil

________________________________

From: Michelle Cotton [mailto:[email-masked]] 
Sent: Wednesday, March 26, 2008 12:55 AM
To: Gupta, Kapil; [email-masked]
Subject: Re: Query

Yes.

Most registrations with individuals listed as the contact applied
directly to IANA.
Other registrations were made through publication of RFCs.

Thank you,

Michelle Cotton
IANA

Good Day All,

Please help.
 
Thank You,
Kapil

---

From: "Gupta, Kapil" <[email-masked]>
Date: Wed, 26 Mar 2008 09:57:08 +0530

Hi Michelle,

 I have few questions more:

1)       Is port registration is platform dependent? We have our
services running on Windows, Linux and Mac OS (obviously different
binaries to server different OS's). Does registering one port for all
the service (For example: port 7001 for windows, Linux and Mac services)
will suffice all requirements or it will require to submit three
applications/forms for each binary/Platform?

2)       What is the validity period for the registered port? Do we need
to renew the port registration process if it is valid for some fix
amount of time or it is valid for life long?

Regards,

Kapil

From: Michelle Cotton [mailto:[email-masked]] 
Sent: Wednesday, March 26, 2008 9:15 AM
To: Gupta, Kapil
Subject: Re: Query

There is no fee.
It can be done as quickly as a few days if the application form is
complete and there is sufficient information to show the need for a
unique assigned port number.

Best regards,

Michelle Cotton
IANA

On 3/25/08 8:37 PM, "Gupta, Kapil" <[email-masked]> wrote:

Thanks a lot Michelle.

Thank you
Kapil

From: Michelle Cotton [mailto:[email-masked]]
<mailto:[email-masked]%5d>  
Sent: Wednesday, March 26, 2008 12:55 AM
To: Gupta, Kapil; [email-masked]
Subject: Re: Query

Yes.

Thank you,

Michelle Cotton
IANA

 
Please help.
 
Thank You,
Kapil