Subject: RE: I-D Action:draft-rfc-image-files-01.txt

From: "Stephen Nadas" <[email-masked]>
Date: Thu, 25 Sep 2008 12:37:28 -0500

Hi Bob, John,  

I have read this draft and I support this (imho) very good idea. I don't
think there were any comments on -00.  An unmentioned added advantage of
this approach is that the figures in the image files will not be broken
by page breaks as sometimes happens. 

I think I understand from this that it is possible to have a figure
without any corresponding ASCII art version (discussed end section 4.2)
- perhaps it is a good idea to have the example fig list cover this
case, i.e.,  "Figure 8: Foo .... *89"?  

A future version, imho, would be enhanced by some well placed MUSTs (eg
sect 6, point 2 where the capitalized DO NOT appears, possibly other
places.)  

In section 6 points 2 & 6. Re the placeholder discussion: I'd like to
hear what ietf tools people (e.g. xml2rfc) think about the bundling
question.   As this proposes at most 1 extra file/rfc (or draft), I
think bundling is  overkill. 

I think it's worth considering whether to add a
"draft-rfc-image-files-xx.img.pdf" as an example and as a way to check
the tools changes (although I think there is a chicken and egg issue as
to how exactly to do this.)  This image file could contain figures that
are hard to do in ASCII.       

I have some other minor comments:

1) last sentence of 4.2, i think there is a typo.  Consider s/need
have/need not have/ i.e., "Note that very simple ASCII artwork need not
have corresponding material in the image file."

2) in section 6 point 2 i think there is some extraneous text
"vspace/>[[anchor10:" in mid paragraph

3) section 9. i think there is some extraneous text "[[anchor14:"

Thanks, 
Steve 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Thursday, September 25, 2008 12:45
> To: [email-masked]
> Subject: I-D Action:draft-rfc-image-files-01.txt 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> 
> 	Title           : Images in RFCs
> 	Author(s)       : R. Braden, J. Klensin
> 	Filename        : draft-rfc-image-files-01.txt
> 	Pages           : 13
> 	Date            : 2008-09-25
> 
> Documents in the RFC series normally use only plain-text 
> ASCII characters and a fixed-width font.  However, there is 
> sometimes a need to supplement the ASCII text with graphics 
> or picture images.
> The historic solution to this requirement, allowing secondary 
> PDF and Postscript files, is seldom used because it is 
> awkward for authors and publisher.  This memo sugests a more 
> convenient scheme for attaching authoritative diagrams, 
> illustrations, equations or other graphics to RFCs.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-rfc-image-files-01.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail 
> reader implementation to automatically retrieve the ASCII 
> version of the Internet-Draft.
> 
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 26 Sep 2008 10:14:48 -0700

At 12:37 PM -0500 9/25/08, Stephen Nadas wrote:
>think there were any comments on -00.

There was a great deal of discussion about this last month when the 
first draft was posted. See (currently) 
<http://www.ietf.org/mail-archive/web/ietf/current/mail11.html>

In particular, please see my comment at 
<http://www.ietf.org/mail-archive/web/ietf/current/msg53066.html>, in 
which I make a counter-proposal that makes no changes to the current 
Internet Draft format and gives more flexibility in the output.

--Paul Hoffman, Director
--VPN Consortium

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 27 Sep 2008 13:30:27 +0100

> Internet Draft format and gives more flexibility in the output.

Yes. I (and I recall others) also supported Paul's simpler approach.
IMO draft-rfc-image-files-00 is over complex.

Stephen.