Subject: draft-crocker-rfc-media-00.txt (was: Re: Publishing RFCs in PDF Formal)

From: John C Klensin <[email-masked]>
Date: Wed, 24 Sep 2008 09:29:26 -0400

Dave,

I've been waiting to respond to your draft until there was more
discussion on the list but, apparently, either the draft or
other circumstances killed that discussion.   During that time,
I've been deliberating whether to send a private note to you or
to post this to the list.  Given that your considerable
experience and length of service to the IETF suggests that
others might follow your behavior as a model, I've reluctantly
concluded that the latter is appropriate.

I found the posting of this draft very disappointing.  I believe
we make progress in the IETF (and elsewhere) by building
explicitly on each other's work and by open discussion of
changes.   Introduction of competing drafts is worthwhile when
those drafts really represent different strategies and models.
But your draft doesn't do that: not only is the original model
(in draft-rfc-image-files-00.txt) preserved, but you used almost
all of the text of that document.  At best, that does not
encourage cumulation -- it just creates confusion about which of
two very similar documents one should be discussing.

I believe that there are only two substantive differences
between your draft-crocker posting and the original (your
document would have been much more constructive, IMO, had you
made those differences, and the reasons for them, clear, but see
below).  

	(1) You have added a few goals.  Had you chosen to raise
	those modifications on the list and gotten some
	consensus for them, we would have happily incorporated
	them into the original.   On the other hand, you might
	have gotten some pushback.  The decision to keep the
	goals quite limited and focused was deliberate and
	resulted from some discussion.
	
	(2) You have eliminated some, perhaps all, of the
	details.  Without those details, the proposal is reduced
	to a general concept that cannot be implemented.
	Perhaps you intended that the RFC Editor would sort the
	details out and just report them to the community.
	However, as we have seen in the reorganization proposal
	discussions on the rfc-interest list, many people in the
	community do not believe that the RFC Editor should make
	such decisions without community review, so eliminating
	those details --rather than making them specific and
	debating them-- is worse than useless.

Finally and FWIW, by stripping the acknowledgments from the
original document and not indicating the source for the text you
used, it appears that you have violated the IPR requirements for
I-D postings.

So, what did you intend to accomplish?

     john

_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Dave CROCKER <[email-masked]>
Date: Wed, 24 Sep 2008 22:22:08 -0400

John, et al,

John C Klensin wrote:
> other circumstances killed that discussion.   

I, too, waited to comment on it and see what the reception was. However I 
produced the usual set of html/pdf formats and rfcdiff versions that I'm 
producing these days. This set is at:

    <http://bbiw.net/recent.html#rfcmedia>

and have no idea why I didn't post the information, and do apologize for failing 
to distribute the link.

Given that there had been some diligent group conversation which prompted my 
draft, it was a bit of a surprise to see the topic simply dropped.  In fact my 
draft was prompted by suggestions by others to expand the scope of your draft a bit.

> changes.   

Well, I have the same model of making progress.

So the disparity, in this case, is with the tactics I chose for seeking 
incremental change, rather than in my seeking to promote a "competing" drafts.

My draft is -- and states in the Abstract and the Introduction that it is -- a 
direct mutation of yours, with as few changes as I could get away with.

While yes, my document is separate from yours, I intended it as a basis for 
discussion, rather than intending to press for "my" draft to "replace" yours. 
(FWIW, I also intentionally crippled mine by leaving out required portions.)

One view is that any time someone posts a suggestion for change, they have 
created "competition" about what will finally be published.  We don't tend to 
think of it that way, but it really what any normal revision process entails.

While I do understand the tendency to think that putting forward an entire draft 
automatically makes it "competing", this was intended as a vehicle for prompting 
discussion about an integrated set of changes, to alter the document's scope and 
tone.  The usual form of disjoint suggested changes fails to communicate an 
integrated reading of the results.  For changes in direction or scope, this can 
be problematic.  (And, besides, I think rfcdiff does quite a good job of 
highlighting the pieces of change; again I apologize for failing to send a point 
to it.)

> (in draft-rfc-image-files-00.txt) preserved, but you used almost

Actually, the model is changed significantly.  That it could be accomplished 
with relatively few changes was serendipitous.

Few, but not small.  The entire "Goals" section, for example, changes things 
quite a bit.

> 	(1) You have added a few goals.  Had you chosen to raise

Eleven.  Eleven goals.

> 	details.  Without those details, the proposal is reduced

My reading is that I added details.

> used, it appears that you have violated the IPR requirements for

Abstract:

      "This proposal is based on
    draft-rfc-image-files-00, by Braden and Klensin, and revises it as
    little as possible, while expanding the goals of the effort."

Introduction:

      "   This proposal is based on draft-rfc-image-files-00, by Braden and
    Klensin, and revises it as little as possible.  As an expedient, the
    References section has been omitted from this initial version of the
    draft."

By the way, have I apologized for failing to post the diffs?

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Bob Braden <[email-masked]>
Date: Thu, 25 Sep 2008 11:03:40 -0700

>    <http://bbiw.net/recent.html#rfcmedia>

Reminder: issues of (people/document) protocol aside, I believe that any 
discussion of Dave's draft and of John's and my draft 
(draft-rfc-image-files-01.txt) should be on the rfc-interest list 
([email-masked]).

Bob Braden