Subject: RFC 2141 - URN Syntax

From: Julian Reschke <[email-masked]>
Date: Mon, 06 Oct 2008 14:31:07 +0200

Hi,

I was looking at <http://tools.ietf.org/html/rfc2141> (URN syntax) and 
noticed that it's only a proposed standard. There do not seem to be any 
errata recorded (<http://www.rfc-editor.org/errata_search.php?rfc=2141>).

Would there be any objections if I tried to update the stuff that needs 
to be updated (references, ABNF), and submit as Draft Standard?

BR, Julian
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 06 Oct 2008 13:44:01 +0100

Julian Reschke wrote:

> noticed that it's only a proposed standard. There do not seem to be 
> any errata recorded 
> (<http://www.rfc-editor.org/errata_search.php?rfc=2141>).
>
> Would there be any objections if I tried to update the stuff that 
> needs to be updated (references, ABNF), and submit as Draft Standard?

This seems sensible.
Have you tried to ping the original author?

---

From: "Rémi Denis-Courmont" <[email-masked]>
Date: Mon, 6 Oct 2008 15:54:06 +0300

> to be updated (references, ABNF), and submit as Draft Standard?

As far as I know, there is no need to resubmit a new version of the document 
to advance its standard status. See RFC2026. What matters is, it's in 
Standards Tracks in the first place.

Unless there are non-editorial corrections/updates to be made, this looks like 
a waste of time to me.

-- 
Rémi Denis-Courmont
Maemo Software, Nokia Devices R&D
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Julian Reschke <[email-masked]>
Date: Mon, 06 Oct 2008 14:55:01 +0200

> Have you tried to ping the original author?

Yes, but at the same time I wrote the mail above.

BR, Julian

---

From: Julian Reschke <[email-masked]>
Date: Mon, 06 Oct 2008 15:10:41 +0200

> Unless there are non-editorial corrections/updates to be made, this looks like 

Well, it has normative references to things that have been obsoleted 
since and it doesn't use ABNF, so I *do* think it needs a minor freshup.

BR, Julian

---

From: Ted Hardie <[email-masked]>
Date: Mon, 6 Oct 2008 08:39:46 -0700

>since and it doesn't use ABNF, so I *do* think it needs a minor freshup.

Having reviewed a lot of URN nid requests over the years, I can't say
I've ever seen a syntax error that derives from 2141 using something other
than ABNF (which is *not* required, simply available).  Following the
chains to the current version of the URI syntax etc. is also not that hard,
so I don't see the need for a change here.  If you would like to see it
progress, I am sure I can help you find the requisite interoperable
implementations to report upon, but, honestly, it seems to be working
fine as-is.
			regards,
				Ted
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Leslie Daigle <[email-masked]>
Date: Tue, 07 Oct 2008 03:54:29 -0400

+1

Leslie.

-- 

-------------------------------------------------------------------
"Reality:
      Yours to discover."
                                 -- ThinkingCat
Leslie Daigle
[email-masked]
-------------------------------------------------------------------
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf