Subject: Publication track for IBE documents (Was Second Last Call...)

From: Tim Polk <[email-masked]>
Date: Tue, 21 Oct 2008 17:18:26 -0400

Okay, I fat fingered this one.  The S/MIME WG actually forwarded  
these documents
with a recommendation that they be published as Informational.  I  
intended to respect
that consensus, but for one reason or another, they ended up in the  
Tracker marked
for Standards track.

It is clear that the WG got this one right, and I have changed the  
intended status on
both documents to Informational.

Thanks,

Tim Polk

> Harald wrote:
>
>> SM wrote:
>>
>>
>>> At 05:37 20-10-2008, The IESG wrote:
>>> This is a second last call for consideration of the following  
>>> document
>>> from the S/MIME Mail Security WG (smime):
>>>
>>> - 'Using the Boneh-Franklin and Boneh-Boyen identity-based  
>>> Encryption
>>>    Algorithms with the Cryptographic Message Syntax (CMS) '
>>>    <draft-ietf-smime-bfibecms-10.txt> as a Proposed Standard
>>>
>>> Technical issues raised in IETF Last Call and IESG evaluation  
>>> have been
>>> resolved.  However, there have been substantive changes in the  
>>> relevant
>>> IPR disclosures statements since the review process was initiated.
>>> Specifically, IPR disclosure statement #888,
>>>            (see https://datatracker.ietf.org/ipr/888/)
>>> was replaced by PR disclosure statement #950,
>>>            (see https://datatracker.ietf.org/ipr/950/)
>>>
>>> This Last Call is intended to confirm continued community support in
>>> light of the new IPR disclosure statement.  Given the limited  
>>> scope of
>>> this Last Call, an abbreviated time period has been selected.
>>>
>>
>>
>> Disclosure statement #888 mentions draft-martin-ibcs-08. That I-D  
>> was published as RFC 5091 in December 2007. Disclosure #950  
>> submitted in May 2008 mentions new licensing terms for RFC 5091.  
>> That disclosure mentions that draft-ietf-smime-bfibecms-10 is on  
>> the Informational Track whereas it is on the Standards Track.
>>
>> As there seems to be only one implementation and very little  
>> public discussion about the draft, I don't see why it should be on  
>> the Standards Track.
>>
>
>
> With licensing terms like these, I would want to see a compelling  
> argument for why the community needs it standardized to put it on  
> the standards track.
>
> Let it be informational.
>
>                  Harald
>

_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 22 Oct 2008 01:00:53 +0100

So while I don't strongly object to these as informational RFCs,
I do wonder why, if only one implementation is ever likely, we
need any RFC at all. Its not like these docs describe something
one couldn't easily figure out were there a need, given that
the (elegant but not especially useful) crypto has been around
for a while without finding any serious applications.

Stephen.

Tim Polk wrote:
> Okay, I fat fingered this one.  The S/MIME WG actually forwarded these
> documents
>>>> This is a second last call for consideration of the following document
>>>> - 'Using the Boneh-Franklin and Boneh-Boyen identity-based Encryption
>>>> Technical issues raised in IETF Last Call and IESG evaluation have been
>>>> resolved.  However, there have been substantive changes in the relevant
>>>> light of the new IPR disclosure statement.  Given the limited scope of
>>> Disclosure statement #888 mentions draft-martin-ibcs-08. That I-D was
>>> published as RFC 5091 in December 2007. Disclosure #950 submitted in
>>> May 2008 mentions new licensing terms for RFC 5091. That disclosure
>>> mentions that draft-ietf-smime-bfibecms-10 is on the Informational
>>> Track whereas it is on the Standards Track.
>>>
>>> As there seems to be only one implementation and very little public
>>> discussion about the draft, I don't see why it should be on the
>>> Standards Track.
>>>
>>
>>
>> argument for why the community needs it standardized to put it on the
>> standards track.
>>
>> Let it be informational.
>>
>>                  Harald
>>
> 
> 
> 
> 
> 
> 
>

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 22 Oct 2008 16:51:23 +0200

> for a while without finding any serious applications.
My personal opinion is that Informational documents should have a low 
bar for publication.

Thus, in the absence of compelling other information (such as a claim 
that the technology is incompetently described, or can't be implemented 
from the specs), I'd favour publication.

(That said, the RFC Editor's work on these will cost the IETF a known 
amount of dollars. The bar shouldn't be TOO low.)

                        Harald

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 23 Oct 2008 11:24:27 +0200

On Wed, Oct 22, 2008 at 04:51:23PM +0200,
 Harald Alvestrand <[email-masked]> wrote 
 a message of 23 lines which said:

> (That said, the RFC Editor's work on these will cost the IETF a
> known amount of dollars.

Known by who? How an ordinary IETF participant could find out "The
Real True Cost of a RFC"?
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 23 Oct 2008 11:40:26 +0200

> Real True Cost of a RFC"?
IETF homepage -> IASA -> Budget and Finance -> Budget -> 2008

Expenses: RFC Editor/Edit Svcs: 737.800 dollars.

I don't have the "RFCs per year" number in my head just now.

                      Harald

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 23 Oct 2008 16:53:28 +0200

On Thu, Oct 23, 2008 at 11:40:26AM +0200,
 Harald Alvestrand <[email-masked]> wrote 

> IETF homepage -> IASA -> Budget and Finance -> Budget -> 2008

I prefer RFC 3986 :-) <http://iaoc.ietf.org/documents/2008_Budget_Final.pdf>

> I don't have the "RFCs per year" number in my head just now.

321 RFC in 2007, so this is around 2,300 US dollars per RFC... Not
including the editors and WG members' work, of course.

---

From: "TS Glassey" <[email-masked]>
Date: Sun, 26 Oct 2008 17:56:39 -0700

There must be some financial models available from the proposal stage of the 
Editor Selection process, chair?

Todd Glassey

----- Original Message ----- 
From: "Stephane Bortzmeyer" <[email-masked]>
To: "Harald Alvestrand" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, October 23, 2008 2:24 AM
Subject: Re: Publication track for IBE documents (Was Second Last Call...)

> Real True Cost of a RFC"?

--------------------------------------------------------------------------------

No virus found in this incoming message.
Checked by AVG - http://www.avg.com
Version: 8.0.175 / Virus Database: 270.8.2/1741 - Release Date: 10/23/2008 
7:54 AM

---

From: Russ Housley <[email-masked]>
Date: Mon, 27 Oct 2008 11:07:01 -0400

This thread has already pointed to the financial statements that show 
how much is paid for RFC Editor services.

Russ

At 08:56 PM 10/26/2008, TS Glassey wrote:
>There must be some financial models available from the proposal 
>stage of the Editor Selection process, chair?
>
>Todd Glassey
>
>----- Original Message ----- From: "Stephane Bortzmeyer" <[email-masked]>
>Version: 8.0.175 / Virus Database: 270.8.2/1741 - Release Date: 
>10/23/2008 7:54 AM
>