Subject: RE: References to Redphone's "patent"

From: [email-masked] (Noel Chiappa)
Date: Fri, 13 Feb 2009 14:06:30 -0500 (EST)

> From: "Lawrence Rosen" <[email-masked]>

    > the previous IPR WG .. refused even to discuss a patent policy for IETF.

I thought the IETF sort of had one, though (see RFC mumble)?

I definitely agree that the IETF could use some sort of permanent legal IPR
consulting board that WG's could go to and say 'we have this IPR filing, what
does it mean, and what is the likely impact on our work'. And of course that
board would have to have people with professional expertise in IPR on it (i.e.
patent attorneys) - although IMO I think it would be more effective if it were
not _just_ attorneys, but also included some engineers with experience with
the IPR world (e.g. as expert witnesses), to help interface between the two
cultures! :-)

Just briefly, what are the problems you see with the existing IETF patent
policy (other than not having such an consulting board)?

	Noel

---

From: Thomas Narten <[email-masked]>
Date: Fri, 13 Feb 2009 15:30:41 -0500

> I definitely agree that the IETF could use some sort of permanent
> legal IPR consulting board that WG's could go to and say 'we have
> this IPR filing, what does it mean, and what is the likely impact on
> our work'.

Please don't go there.

IPR consultation is all about risk analysis. And risk to the IETF
vs. risk to me personally vs. risk to my employer vs. risk to somebody
else's employer, etc. All are VERY different things.

I don't see an IPR consulting board as being helpful at all. It will
still come down to someone else trying to tell *me* (or you) that I
(or you) shouldn't worry about something, yet it might well be *my*
(or your) skin if things go awry.

The IETF absolutely and fundamentally needs stay out of evaluating the
merits of potential IPR and what the associated risks are. This is
fundamentally an individual decision that every implementor needs to
make on their own.

This principle has been a bedrock of the IETF's IPR policy for a very
long time, and for good reason.

Oh, and another important point, even when we have IPR disclosures,
they are often for patent applications, which are not public, nor have
they been issued (so they are only potential patents). In such cases,
there is precious little an advisory board could tell us, other than
"we don't know"...

Thomas

---

From: "Powers Chuck-RXCP20" <[email-masked]>
Date: Fri, 13 Feb 2009 15:36:01 -0500

+1 

That is a legal quagmire that the IETF (like all good standards
development groups) must avoid.

Regards, 
Chuck 
------------- 
Chuck Powers, 
Motorola, Inc 
phone: 512-427-7261
mobile: 512-576-0008

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Thomas Narten
> Sent: Friday, February 13, 2009 2:31 PM
> To: Noel Chiappa
> Cc: [email-masked]
> Subject: Re: References to Redphone's "patent"
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Scott Brim <[email-masked]>
Date: Fri, 13 Feb 2009 16:08:53 -0500

> else's employer, etc. All are VERY different things.

We tried the idea and came to those conclusions.  All the board could
do would be to utter platitudes.

---

From: "Lawrence Rosen" <[email-masked]>
Date: Fri, 13 Feb 2009 13:14:55 -0800

> development groups) must avoid.

Chuck is not alone in saying that, as you have just seen.

These are the very people who refused to add "patent policy" to the charter
of the previous IPR WG, and who controlled "consensus" on that point last
time.

Shall we ask the FSF members of IETF also to comment on the need for IETF to
develop a comprehensive policy toward patents so that encumbrances to
Internet standards can be understood and avoided in the future?

/Larry

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Powers Chuck-RXCP20
> Sent: Friday, February 13, 2009 12:36 PM
> To: Thomas Narten; Noel Chiappa
> Cc: [email-masked]
> Subject: RE: References to Redphone's "patent"
> 
> +1
>

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 13 Feb 2009 13:42:36 -0800

No, please do not go there.

You do not want negotiating flexibility in this type of situation. Instead of looking how to arrive at a deal, the IETF needs to think about structuring the incentives so that there is no gain for a patent troll.

-----Original Message-----
From: [email-masked] on behalf of Thomas Narten
Sent: Fri 2/13/2009 3:30 PM
To: Noel Chiappa
Cc: [email-masked]
Subject: Re: References to Redphone's "patent"

Please don't go there.

Thomas

---

From: "Contreras, Jorge" <[email-masked]>
Date: Fri, 13 Feb 2009 20:54:20 -0500

> Internet standards can be understood and avoided in the future?

IETF does have a patent policy.  It is at RFC 3979.  It may not be to
everyone's liking, but it does exist.

---

From: "Lawrence Rosen" <[email-masked]>
Date: Sat, 14 Feb 2009 09:35:34 -0800

> else's employer, etc. All are VERY different things.

I mean this in a polite way, but bull....! IPR consultation is mostly about
the facts, the evidence, knowledge of the law, and understanding the role of
intellectual property in technology products and services.

Risk analysis is what businesses do every day, and all parts of those
businesses--including the engineers and the lawyers--should contribute to
that analysis.

> In such cases,

Apparently there is precious little an advisory board could tell you since
your company has a very large and very talented IPR advisory group in its
legal department, but that's no excuse for IETF not to have one for the rest
of the community.

/Larry

Lawrence Rosen
Rosenlaw & Einschlag, a technology law firm (www.rosenlaw.com)
3001 King Ranch Road, Ukiah, CA 95482
707-485-1242 * cell: 707-478-8932 * fax: 707-485-1243
Skype: LawrenceRosen

> Thomas Narten
> Sent: Friday, February 13, 2009 12:31 PM
> To: Noel Chiappa
> Cc: [email-masked]

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 16 Feb 2009 14:10:15 +0100

> of the previous IPR WG, and who controlled "consensus" on that point last
To be precise: "Last time" was at the San Francisco IETF meeting, March 
16-22 2003, and I was the one "controlling consensus".

The minutes (at http://www.ietf.org/proceedings/03mar/132.htm ) show 
this conclusion, after much discussion:

> 1. do you wish this group to recharter to cdhange the IETF's IPR policy
>     hum for (some)
>     hom anti (more)
>    fairly clear consensus against rechartering.  anyone disagree?
>
> harald: will verified on mailing list, will lead to some debate.  if
> consensus is reached against rechartering... the IETF will not consider
> proposals to create or reactivate IPR wg before people with
> compelling arg to do so.  those should be different than what
> prevented so far.
>
Despite the abysmal spelling quality, it was pretty clear at the time 
that the arguments presented were not compelling. I haven't seen 
significant new arguments in the meantime; that doesn't mean they don't 
exist, just that I haven't seen them.

                  Harald

---

From: "Lawrence Rosen" <[email-masked]>
Date: Mon, 16 Feb 2009 14:11:26 -0800

> >    fairly clear consensus against rechartering.  anyone disagree?

Hi Harald,

Let's forget the past; I acknowledge we lost that argument then among those
few who bothered to hum. 

But are the 1,000 or so emails in recent days from the FSF campaign not a
loud enough hum to recognize that our IPR policy is out of tune? This is not
the first such open source campaign either. IETF needs a more sturdy process
to deal with IPR issues. Please consider the suggestions now on the table.

Best regards,

/Larry

Lawrence Rosen

> From: Harald Alvestrand [mailto:[email-masked]]
> Sent: Monday, February 16, 2009 5:10 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Previous consensus on not changing patent policy (Re: References
> to Redphone's "patent")
> 
> Lawrence Rosen wrote:
> > Chuck Powers wrote:
> >
> >> +1
> >>

---

From: John Levine <[email-masked]>
Date: 16 Feb 2009 23:07:41 -0000

>But are the 1,000 or so emails in recent days from the FSF campaign
>not a loud enough hum to recognize that our IPR policy is out of
>tune?

Are you really saying that all it takes is a mob motivated by an
misleading screed to make the IETF change direction?

>From the sample of the FSF letters I read, many of the people writing
didn't know the difference between Redphone and Red Hat, and if as
many as two of them had even looked at the draft or IPR disclosure in
question, it'd be a lot.

The FSF's absolutist position on patents was set in stone 20 years
ago.  I don't see why we should be impressed if they occasionally
throw a handful of pebbles at us.

R's,
John

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 16 Feb 2009 15:19:30 -0800

>Let's forget the past; I acknowledge we lost that argument then among those

Many of us have heard this in various technical working groups when people who didn't get their way come back later. Such reconsiderations, particularly on topics of a non-protocol nature, are rarely embraced. We are humans with limited time and energy and focus.

>loud enough hum to recognize that our IPR policy is out of tune?

No, it is a statement that a group of people who are not active in the IETF want us to spend our time and effort to fix a problem they feel that they have.

> This is not

Where? I see no Internet Draft, nor any significant group of people who have said they are willing to work on the problem. Seriously, if this is a significant issue for this motivated group of people, they can do some research and write one (or probably more) Internet Drafts.

The IETF has never been swayed by blitzes of a mailing list asking for us to do someone else's technical work; we should not be swayed by similar blitzes asking us to do their policy work. We are, however, amazingly (and sometime painfully) open to discussing worked-out solutions of either a technical or policy nature. In this case, "worked-out" means a document that describes the the current solution, the advantages and disadvantages of it, a proposal for a new solution, and a transition plan.

--Paul Hoffman, Director
--VPN Consortium

---

From: [email-masked]
Date: Mon, 16 Feb 2009 15:09:40 -0800 (PST)

> misleading screed to make the IETF change direction?

I certainly hope not because, as you said previously, think what advantage
large companies would be able to take of it.

> didn't know the difference between Redphone and Red Hat,

Yeah, that was briefly amusing, as was the ones that wanted to stop "the
standardization of TLS" because of this patent.

Amusing at first, that is, then quite annoying.

> and if as

I think I spotted five that seemed to be somewhat informed. But even those
didn't do any sort of analysis of the disclosure or the patent application to
back up their assertions.

> throw a handful of pebbles at us.

More to the point, the IETF IPR policy may be spot on or it may be a steaming
pile of crap, but this mail bombardment by the FSF proves nothing either way.

FWIW, I'm not happy with the current policy, but most of the sketches of
alternatives I've seen don't seem like changes for the better. Perhaps if they
were fully worked out in the form of a draft and all the loose ends were tied
off I'd change my mind.

				Ned

---

From: "Lawrence Rosen" <[email-masked]>
Date: Mon, 16 Feb 2009 16:49:40 -0800

Paul Hoffman wants:
> In this case, "worked-out" means a document
> that describes the the current solution, the advantages and disadvantages
> of it, a proposal for a new solution, and a transition plan.

Paul, I'm not sure what more you're asking for at this stage. This list is
lively with suggestions, convincing me that IPR issues continue to dominate
the IETF airwaves. A "worked-out" document would be premature in this
context. 

One suggestion, now a specific topic on this list if you care to respond
directly, is for the creation of an IETF IPR Advisory Board to help people
everywhere--including thousands of disaffected FSF campaigners--to
understand why certain patents (including the Redphone "patent") are not
worth worrying about.

The charter would be: "Answer IPR questions that are posed by other IETF
working groups." The quality of its answers, as with any IETF working group,
will be at least partly a function of the quality of its participants.

This suggestion is perhaps the most important currently before us, because
an IETF IPR Advisory Board will be able to stop FSF campaigns and other
distractions before they start with facts instead of fiction. What would YOU
suggest for a charter for such an Advisory Board to keep it from crossing
into any forbidden areas? 

Or is it every man and woman for themselves in these patent-infested waters?

/Larry

Lawrence Rosen

> From: Paul Hoffman [mailto:[email-masked]]
> Sent: Monday, February 16, 2009 3:20 PM
> To: [email-masked]; [email-masked]
> Subject: RE: Previous consensus on not changing patent policy (Re:
> References to Redphone's "patent")
> 
> Many of us have heard this in various technical working groups when people
> who didn't get their way come back later. Such reconsiderations,
> particularly on topics of a non-protocol nature, are rarely embraced. We
> are humans with limited time and energy and focus.
> 
> No, it is a statement that a group of people who are not active in the
> IETF want us to spend our time and effort to fix a problem they feel that
> they have.
> 
> > This is not
> Where? I see no Internet Draft, nor any significant group of people who
> have said they are willing to work on the problem. Seriously, if this is a
> significant issue for this motivated group of people, they can do some
> research and write one (or probably more) Internet Drafts.
> 
> The IETF has never been swayed by blitzes of a mailing list asking for us
> to do someone else's technical work; we should not be swayed by similar
> blitzes asking us to do their policy work. We are, however, amazingly (and
> sometime painfully) open to discussing worked-out solutions of either a
> technical or policy nature. In this case, "worked-out" means a document
> that describes the the current solution, the advantages and disadvantages
> of it, a proposal for a new solution, and a transition plan.
> 
> --Paul Hoffman, Director
> --VPN Consortium

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 16 Feb 2009 17:22:24 -0800

At 4:49 PM -0800 2/16/09, Lawrence Rosen wrote:
>Paul, I'm not sure what more you're asking for at this stage.

You removed the part where I said exactly what I was asking for:

>Where? I see no Internet Draft, nor any significant group of people who have said they are willing to work on the problem. Seriously, if this is a significant issue for this motivated group of peopl…

This is how things get done in the IETF.

>This list is
>the IETF airwaves.

This is not how things get done in the IETF.

> A "worked-out" document would be premature in this
>context.

We fully disagree.

>understand why certain patents (including the Redphone "patent") are not

That's silly.

- Many patents are worth worrying about. No one has claimed any different.

- If there are "thousands of disaffected FSF campaigners", this should be the FSF IPR Advisory Board. You have yet to explain why the aggrieved party is not willing to do the work to make themselves happy.

- The IETF does not create advisory boards, so we would need to spend even more time on IETF process before doing this.

You are, again, volunteering other people's time to do work you want done. Imagine what the response from rational busy people will be.

--Paul Hoffman, Director
--VPN Consortium

---

From: Michael Dillon <[email-masked]>
Date: Tue, 17 Feb 2009 15:14:49 +0000

> - If there are "thousands of disaffected FSF campaigners", this should be the FSF IPR Advisory Board. You have yet to explain why the aggrieved party is not willing to do the work to make themselve…

There is the germ of a good idea here. History has shown that the FSF
is very concerned
with how the IETF standardisation process deals with patent issues.
This is a reasonable
concern given the FSF's raison d'etre.

Therefore, why not proactively consult the FSF on any standards track
document that
makes use of patented material? Proactively drive the dialogue by
getting the FSF
involved at an early stage, and by providing a separate mailing list
(ietf-comments)
for discussing the IPR issues. Over time, the FSF folks will better
understand how
the IETF deals with IPR and will see that there is rarely the
possibility of a serious
problem.

Some of the time, an issue won't be resolvable in a brief email
discussion and in
that case the IETF should ask the FSF to collect their thoughts and write an
Internet draft that explains why the proposed plan of action is bad, and why the
IETF should take some other plan of action. That draft can then go to the WG
and get resolved before a new protocol ever reaches RFC status.

If we do this, then there are unlikely to be flurries of activity
during last-call.

In addition, more dialogue with FSF members should prove to be useful in
resolving some of the open questions about IPR, copyrights, licencing and
so on.

--Michael Dillon

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 17 Feb 2009 07:33:26 -0800

At 3:14 PM +0000 2/17/09, Michael Dillon wrote:
>makes use of patented material?

Because we don't know which of them do. For instance, the document that kicked off the message barrage that preceded thread does not, as far as anyone knows, "make use of patented material". One company that has a patent *application* that they think (and probably hope) will get granted says that they think (and probably hope) applies to the protocol has informed the IETF of that fact. Their patent might not be granted. It might be granted, but limited in a way that clearly does not apply to the protocol. It might be granted and two intelligent people looking at the patent and the protocol could disagree about where it applies.

> Proactively drive the dialogue by
>getting the FSF
>for discussing the IPR issues.

Why single out the FSF? Patent-encumbered protocols affect commercial vendors to the same extent as they affect FSF members (and possibly moreso).

>resolving some of the open questions about IPR, copyrights, licencing and

This is the opposite of what Larry wanted: he wanted lawyers to give advice. You are wanting non-lawyers to give legal advice. We already have an abundance of the latter.

--Paul Hoffman, Director
--VPN Consortium

---

From: TSG <[email-masked]>
Date: Tue, 17 Feb 2009 07:58:15 -0800

> The IETF has never been swayed by blitzes of a mailing list asking for us to do someone else's technical work; we should not be swayed by similar blitzes asking us to do their policy work. We are,…
You mean solutions which amuse or are acceptable to the parties directly 
managing the IETF today, rather than to the IETF's victims, err members.
> --VPN Consortium
The IETF needs a licensing irrelevant model for creating 
interoperability standards for networking models of all types. If fact 
if people want to create a IETF standard why should anyone here want to 
stop them except to prevent that protocol from coming to use, which 
means that the IETF has become a political entity serving to prevent 
some entities from being able to productize their efforts meaning that 
the actions of the IETF itself become adversarial to anyone outside of 
those that the Standards Trolls want to allow through the IETF.

Settlement proposal -

---

From: Thierry Moreau <[email-masked]>
Date: Tue, 17 Feb 2009 12:07:00 -0500

Michael Dillon wrote:
> 
> Some of the time, [...]
>          the IETF should ask the FSF to collect their thoughts and write an

Under the rule that "the IETF will make no determination about the 
validity of any particular IPR claim" (BCP79), the WG chair(s) would 
simply object to discussions about such a draft (apparently no matter 
who authored the draft, but sometimes some IETF participants are more 
equal than others, so I'm not 100% sure).

If you want to change this rule, e.g. "the IETF may collect evidence 
useful to the determination of a particular IPR claim validity and/or 
scope" then you were challenged to come up with a detailed proposal.

My point in this discussion was that the IETF processes are increasingly 
inefficient because *at the participant level*, under the current rules, 
insufficient investigation and analyses are being made. But that's an 
incomplete diagnostic of the current situation, and I have no solution 
to propose.

-- 

- Thierry Moreau

CONNOTECH Experts-conseils inc.
9130 Place de Montgolfier
Montreal, Qc
Canada   H2M 2A1

Tel.: (514)385-5691
Fax:  (514)385-5900

web site: http://www.connotech.com
e-mail: [email-masked]

---

From: "Michael B. Einschlag" <[email-masked]>
Date: Mon, 16 Feb 2009 18:15:39 -0800

Hi,

I am a new speaker on the "IETF airwaves," but I felt I could not resist the
urge to comment.  Although I am head of IP at VMware, I can only speak for
myself and not for the company.

It seems to me that people arguing to establish an IPR Advisory Board have
the better argument.  I understand that lawyers are loath to opine on issues
because they are afraid their opinions might be relied upon, and, in this
litigious society, that might somehow result in liability to themselves.
Despite that, however, there are ways of providing information that can be
useful.  In addition, there are economies to be had by everyone's putting
their resources together.

I have read e-mails from people who advocate that IETF ought not to get
involved and, instead, ought to let "users" fend for themselves.  These
people apparently have resources to deal with all such issues unilaterally.
However, in my opinion, even such people are wasting funds for their
companies by going it alone on each issue.  My experience is that,
especially in these financially troubling times, wise use of resources is
always a good thing to do.  In addition to spreading the expense, there is
an additional benefit of taping into the technical resources of many, and
using the "eyes of many" to improve the reliability of technical and legal
analyses much in the way open source improves software.

If nothing else, information provided by such analyses provides a basis for
understanding a potential problem.  Benefit results, for example, since
identifying a bogus problem, enables development to progress unimpeded.
Similarly, by identifying a real problem, development may, if people wish,
be directed to ways around the problem.

It seems to me that a standards group should not merely be a forum to
develop a standard, but that it should provide a standard that can be used
commercially by at least the group that helped to develop it.  That means
developing a standard which will not exclude those not having sufficient
resources to perform their own IP analysis (and presumably not shared for
legal reasons).  Otherwise, why work to develop a standard that only the
"well heeled" can use confidently.

Mike Einschlag    
 
-----Original Message-----
From: Lawrence Rosen [mailto:[email-masked]] 
Sent: Monday, February 16, 2009 4:50 PM
To: [email-masked]
Subject: Proposal to create IETF IPR Advisory Board

/Larry

Lawrence Rosen

---

From: TSG <[email-masked]>
Date: Tue, 17 Feb 2009 14:42:21 -0800

> misleading screed to make the IETF change direction?
Yes  - exactly that.

---

From: John Levine <[email-masked]>
Date: 17 Feb 2009 23:22:08 -0000

>It seems to me that people arguing to establish an IPR Advisory Board
>have the better argument.

Well, OK.  We're looking forward to the draft describing what such a
board's charter is, how its members are selected and what their
qualifications would be, where its operations fit into the IETF
process, what the appeal process will be for people unhappy with its
conclusions, what if any budget it would need, and all the other
details needed to create and run it.

R's,
John

---

From: "Doug Ewell" <[email-masked]>
Date: Wed, 18 Feb 2009 07:03:37 -0700

Michael Dillon <wavetossed at googlemail dot com> wrote:

> document that makes use of patented material? Proactively drive the 
> dialogue by getting the FSF involved at an early stage, and by 
> providing a separate mailing list (ietf-comments) for discussing the 
> IPR issues. Over time, the FSF folks will better understand how the 
> IETF deals with IPR and will see that there is rarely the possibility 
> of a serious problem.

This is unlikely to result in a workable compromise, since the FSF has a 
fundamental belief that software patents are never acceptable, and the 
IETF has taken the position that in certain situations they are 
acceptable.

This is the sort of roadblock faced by international diplomats trying to 
negotiate peaceful coexistence between two nations, one of whom has a 
fundamental belief that the other has no right to exist.

--
Doug Ewell  *  Thornton, Colorado, USA  *  RFC 4645  *  UTN #14
http://www.ewellic.org
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ

---

From: Michael Dillon <[email-masked]>
Date: Wed, 18 Feb 2009 22:07:48 +0000

> FSF is very well intentioned; don't understand me to say otherwise. That
> said, I think their view on IPR is pretty extreme - "no IPR is acceptable".

Perhaps that is their view as an organization, but if the IETF engages
with the FSF to get individuals involved in the IPR discussions, I
think you will find more flexibility of viewpoint.

If the IETF chooses to ignore the FSF, I don't think that strategy will work.

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 18 Feb 2009 14:17:55 -0800

Do you think that the IETF has changed direction though?

Methinks not.

This is one of those issues where there is a faction that will defend the status quo regardless of the flaws that are revealed. They will wait till the end of the discussion and announce that there is no consensus to do anything differently so they must win.

I really do not understand the justification for not allowing a WG to state the IPR policy that will apply during the charter process. If we are going to have people volunteer time an effort to create a standard they have the right to know at the start whether the result will be encumbered or if one particular party gets to set up a toll booth.

In fact there are two very different status quos. There is the defacto status quo and there is the de jure status quo. And it is rather interesting that on every one of my pet IETF peeves, my position is the defacto status quo and it is only the official status quo that is out of line.

Officially a working group does not need to set an IPR standard up front.
In practice every working group in any part of the IETF I participate in has to deliver a standard that is compliant with the W3C policy that every essential part of the spec be implementable without using encumbered technology. Attempts to do otherwise are totally futile.

I guess it is possible that things are different outside the security, applications and operations side, but I find it very hard to believe that a necessary to implement technology at the Internet level could be encumbered without creating a blogstorm of slashdot proportions.

Officially the specs are in the obsolete text format
In practice they are written in XML and the engineers implementing them use either the HTML version or buy the O'Rielly nutshell book.

Officially there are three stages in the standards process
In practice there are two stages.

I really wish it was possible to have a discussion on this topic without getting condescending lectures as to why it is absolutely unthinkable to change the official status quo when folk are already doing exactly what I have been suggesting for five years or more.

-----Original Message-----
From: [email-masked] on behalf of TSG
Sent: Tue 2/17/2009 5:42 PM
To: John Levine
Cc: [email-masked]
Subject: Re: Previous consensus on not changing patent policy (Re: Referencesto Redphone's "patent")
 
Yes  - exactly that.

---

From: "Powers Chuck-RXCP20" <[email-masked]>
Date: Wed, 18 Feb 2009 17:32:38 -0500

One problem I see with that approach would be the inevitable replay of
TLS-auth -> a working group agrees up front that there is
patent-encumbered technology that is too useful to not include in the
spec (which has happened in the IETF in the past), that group would
therefore agree to follow that model, and then when they were done, a
firestorm of FSF folks who had not even read the material, much less
were aware of how the original decision had been reached, would assail
the IETF with "the sky is falling" emails about how the world will come
to an end if the IETF publishes the specification.
 
Apart from that, it would likely be a total rats nest to try and track
what work was done under what IPR agreement; allowing IPR policy
decisions to be made on a WG by WG basis would, IMO, be a nightmare,
except for the lawyers.

Regards, 
Chuck 
------------- 
Chuck Powers,
Motorola, Inc
phone: 512-427-7261
mobile: 512-576-0008 

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Hallam-Baker, Phillip
	Sent: Wednesday, February 18, 2009 4:18 PM
	To: TSG; John Levine
	Cc: [email-masked]
	Subject: RE: Previous consensus on not changing patent policy
(Re:Referencesto Redphone's "patent")

	Methinks not.
	
	This is one of those issues where there is a faction that will
defend the status quo regardless of the flaws that are revealed. They
will wait till the end of the discussion and announce that there is no
consensus to do anything differently so they must win.
	
	I really do not understand the justification for not allowing a
WG to state the IPR policy that will apply during the charter process.
If we are going to have people volunteer time an effort to create a
standard they have the right to know at the start whether the result
will be encumbered or if one particular party gets to set up a toll
booth.

	In fact there are two very different status quos. There is the
defacto status quo and there is the de jure status quo. And it is rather
interesting that on every one of my pet IETF peeves, my position is the
defacto status quo and it is only the official status quo that is out of
line.

	Officially a working group does not need to set an IPR standard
up front.
	In practice every working group in any part of the IETF I
participate in has to deliver a standard that is compliant with the W3C
policy that every essential part of the spec be implementable without
using encumbered technology. Attempts to do otherwise are totally
futile.
	
	I guess it is possible that things are different outside the
security, applications and operations side, but I find it very hard to
believe that a necessary to implement technology at the Internet level
could be encumbered without creating a blogstorm of slashdot
proportions.

	Officially the specs are in the obsolete text format
	In practice they are written in XML and the engineers
implementing them use either the HTML version or buy the O'Rielly
nutshell book.

	I really wish it was possible to have a discussion on this topic
without getting condescending lectures as to why it is absolutely
unthinkable to change the official status quo when folk are already
doing exactly what I have been suggesting for five years or more.

	-----Original Message-----
	From: [email-masked] on behalf of TSG
	Sent: Tue 2/17/2009 5:42 PM
	To: John Levine
	Cc: [email-masked]
	Subject: Re: Previous consensus on not changing patent policy
(Re: Referencesto Redphone's "patent")
	
	Yes  - exactly that.

---

From: John Levine <[email-masked]>
Date: 18 Feb 2009 22:51:42 -0000

>If the IETF chooses to ignore the FSF, I don't think that strategy will work.

It's worked for the past 20 years.  What's different now?

R's,
John

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 18 Feb 2009 15:21:21 -0800

Chuck,

The current situation is that the IPR policy is set by the WGs.

My view is that the only interesting IPR out there is the almost negligible proportion that describes something that can only be done in one particular way. The only IPR in the technology space that I am aware of that presents a genuinely compelling cost/benefit today is DRM technology.

The complaint about the licensing terms would be the least of our FSF problems...

But why should we care? If Lyndon LaRouche or L Ron Hubbard decide to take up an IETF cause, are we obligated to comply with the demands of their minions? I think not. 

-----Original Message-----
From: Powers Chuck-RXCP20 [mailto:[email-masked]]
Sent: Wed 2/18/2009 5:32 PM
To: Hallam-Baker, Phillip; TSG; John Levine
Cc: [email-masked]
Subject: RE: Previous consensus on not changing patent policy (Re:Referencesto Redphone's "patent")
 
One problem I see with that approach would be the inevitable replay of TLS-auth -> a working group agrees up front that there is patent-encumbered technology that is too useful to not include in the spec (which has happened in the IETF in the past), that group would therefore agree to follow that model, and then when they were done, a firestorm of FSF folks who had not even read the material, much less were aware of how the original decision had been reached, would assail the IETF with "the sky is falling" emails about how the world will come to an end if the IETF publishes the specification.
 
Apart from that, it would likely be a total rats nest to try and track what work was done under what IPR agreement; allowing IPR policy decisions to be made on a WG by WG basis would, IMO, be a nightmare, except for the lawyers.

Regards, 
Chuck 
------------- 
Chuck Powers,
Motorola, Inc
phone: 512-427-7261
mobile: 512-576-0008 

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Hallam-Baker, Phillip
	Sent: Wednesday, February 18, 2009 4:18 PM
	To: TSG; John Levine
	Cc: [email-masked]
	Subject: RE: Previous consensus on not changing patent policy (Re:Referencesto Redphone's "patent")

	Methinks not.

	

	
	-----Original Message-----
	From: [email-masked] on behalf of TSG
	Sent: Tue 2/17/2009 5:42 PM
	To: John Levine
	Cc: [email-masked]
	Subject: Re: Previous consensus on not changing patent policy (Re: Referencesto Redphone's "patent")
	
	Yes  - exactly that.

---

From: TSG <[email-masked]>
Date: Wed, 18 Feb 2009 18:16:53 -0800

> think you will find more flexibility of viewpoint.
Yes but their control is narrow so derivatives are freely made. That's 
not the license everyone wants for their standard but it serves FSF 
users. So we should do something that allows any type of standard (open 
use, open-source, proprietary/controlled use) to be done with the same 
standards development and validation framework. To do that maybe the 
licensing needs to be rethought...
> If the IETF chooses to ignore the FSF, I don't think that strategy will work.
Which brings us back to the idea that the party managing the standard 
development effort should define the licensing model rather than the 
model being uniform to the IETF. Seriously think this through - how 
about we modify the standards process so that the WIG Development effort 
selects the specific licensing model for that effort. In fact you may 
have several efforts implementing the same services side by side, except 
with separate licensing's.

I think that the licensing model should be totally linked to the 
standard effort so everyone gets what they want...

You guys want ultimate control - so take it - move the licensing process 
into the Project Definition and allow people to select those models 
already in place or specify something different. This means that the 
issue of negotiating this goes away and we can get back to more 
important topics.

We also will in one fell swoop open the IETF to totally open-sourced 
standards models and proprietary ones too. Imagine that - if the 
licensing model is just moved into the standard itself from the boiler 
plate housed in the BCP's.

Todd Glassey

---

From: Theodore Tso <[email-masked]>
Date: Mon, 16 Feb 2009 17:30:12 -0500

> to deal with IPR issues. Please consider the suggestions now on the table.

Given how badly misinformed the FSF and their 1,000 blind followers
were --- no, it's not even a hum.  More like the sound of a Concord
taking off if an IETF meeting happened to be located in a hotel which
was unfortunately located too close to an airport's runways.  "Full of
sound and jury, signifying nothing..."  :-)

							- Ted