Subject: Re: Last Call: draft-ietf-mpls-tp-oam-requirements (Requirements for OAMin MPLS Transport Networks) to Proposed Standard

From: "Sadler, Jonathan B." <[email-masked]>
Date: Mon, 5 Oct 2009 08:12:12 -0500

To the IETF area directors, MPLS and PWE3 working group chairs, document authors and IETF community,

I've recently started looking at the MPLS-TP drafts and only this past week have had an opportunity to review the OAM requirements draft for MPLS-TP.  I realize the IESG has requested Last Call comments for this draft, and am sensative that these comments would have been better received earlier.  That said, these comments are not trivial and should be considered before progressing the draft.

ITU-T SG15 has a history of OAM protocol development for transport technologies.  This expertise has led to development of an OAM methodology and definition approach as documented in G.806.  Two key characteristics exist in this document that I don't see being reflected in the OAM requirements draft:

- A requirement for consistancy in OAM approach with other transport technology layers.

This characteristic is necessary to enable existing transport network management systems to easily integrate new transport technologies.  It further enables existing Methods and Procedures to be easily adapted for new technologies.  Considering the familiarity that exists with existing transport OAM approaches, deviation should only be considered after receiving significant input from transport network operators.  Please be aware that transport network operators typically participate in the work of the ITU, not the IETF and therefore many are not aware of this work.

- A requirement for OAM interactions between transport technology layers.

This characteristic is key when a network utilizes multiple transport technology layers to carry customer traffic.  This is very common in Transport networks. G.806 provides a framework for this interaction.  An example embodiment  can be found in G.782 and its definition of OAM interactions between the RS and MS layers, as well as the MS and Path layers.  MPLS-TP is not an island of technology -- it runs over other transport layers (e.g. OTN/DWDM, Ethernet layers) and other transport layers are targeted to run on top of it (e.g. Ethernet over PseduoWire, SONET/SDH over PseudoWire).   The OAM mechanisms used in the layers found in Transport networks were developed with G.806 in mind.  Interactions between the OAM indications from lower layers and MPLS-TP as well as between MPLS-TP and higher layers must be handled as described in G.806 when considering the design for MPLS-TP OAM.

The work of IETF and ITU-T has endevored to meet many different requirements for MPLS-TP Networks.  Many good results have come from this process.  And the process allows for comments like these to be made to avoid key areas from being overlooked.  I appreciate the opportunity to provide them to the IETF community and IESG as the MPLS-TP OAM Requirements document is considered.

Thanks,

Jonathan Sadler

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 05 Oct 2009 17:29:37 +0100

Sadler, Jonathan B. wrote:
> ITU-T SG15 has a history of OAM protocol development for transport 
> technologies.  This expertise has led to development of an OAM 
> methodology and definition approach as documented in G.806.
Jonathan

Unfortunately the latest version of G.806 is showing up as 
pre-published, only available for purchase at a cost of 64CHF, please 
can you make a copy of this available to the IETF so that we can review 
the relevant content in order to consider this as input to this last 
call process.

Regards

Stewart

---

From: Adrian Farrel <[email-masked]>
Date: Tue, 06 Oct 2009 11:45:02 +0100

Jon,

> Please be aware that transport network operators typically participate
> in the work of the ITU, not the IETF and therefore many are not aware
> of this work.

I'm not sure how to interpret this note!

The (now-just-closed) MEAD team included active participants from Verizon, 
BT, at&t, NTT, and FT. They were involved in the development of the MPLS-TP 
requirements documents and were part of the detailed review of this 
document.

Of course, the MPLS-TP list contains participants from a larger number of 
carriers, and they all took part in the working group last call.

You say that "...deviation should only be considered after receiving 
significant input from transport network operators." That is surely wrong. 
If no-one comments against a proposed technical solution then that must mean 
it is accepted.

So, when this draft was liaised to the ITU-T for review during the WG last 
call, the ITU-T responded by saying that:

              The ITU-T SG15 experts support approval of the current draft 
including the
              minor editorial fixes received during IETF WG last call as 
documented in
              draft-ietf-mpls-tp-oam-requirements-03.txt

I think we can conclude that the operator input you talk about has been 
taken.

Anyway, I think we should probably focus on the technical content of your 
email.

Thanks,
Adrian