Subject: Re: Last Call: draft-hammer-oauth (The OAuth Core 1.0 Protocol) to Informational RFC

From: Cullen Jennings <[email-masked]>
Date: Tue, 27 Oct 2009 15:11:40 +0100

I'm very confused about the relationship of this draft and the work  
the OAUTH WG is doing. Can you explain?

On Oct 9, 2009, at 15:38 , The IESG wrote:

> The IESG has received a request from an individual submitter to  
> consider
> the following document:
>
> - 'The OAuth Core 1.0 Protocol '
>   <draft-hammer-oauth-03.txt> as an Informational RFC
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send substantive comments to  
> the
> [email-masked] mailing lists by 2009-11-06. Exceptionally,
> comments may be sent to [email-masked] instead. In either case, please
> retain the beginning of the Subject line to allow automated sorting.
>
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-hammer-oauth-03.txt
>
>
> IESG discussion can be tracked via
> https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=17736&rfc_flag=0
>
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Tue, 27 Oct 2009 08:44:47 -0700

This draft is the original community specification created outside the IETF. It was this work that inspired the creation of the OAUTH WG and is explicitly set as the initial draft for the WG in its charter. The draft is submitted as an informational RFC to document existing deployment and practices. It is not a WG product.

EHL

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Cullen Jennings
> Sent: Tuesday, October 27, 2009 7:12 AM
> To: IESG IESG
> Cc: IETF Discussion
> Subject: Re: Last Call: draft-hammer-oauth (The OAuth Core 1.0
> Protocol) to Informational RFC
> 
> 
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Stephan Wenger <[email-masked]>
Date: Tue, 27 Oct 2009 11:09:45 -0700

I understand this as the documentation of what has been specified by the
original oAuth crowd, known as oAuth 1.0, which is out there and deployed.
AFAIK, the oAuth group is working on improvements and additions to this base
specification.  From the charter:

"
[...]
This specifically means that as a starting point for the
working group OAuth 1.0 (i.e., draft-hammer-oauth),
which is a copy of the original OAuth specification in IETF
draft format, is used and the available extension points
are going to be utilized. In completing its work to update
OAuth 1.0 to become OAuth 1.1, the group will strive to
retain backwards compatibility with the OAuth 1.0
specification. 
[...]
"

Stephan

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 28 Oct 2009 09:36:45 -0600

Correct. The idea is to publish an informational RFC so that people have
a stable reference for the "OAuth 1.0" technology as we continue to move
forward with "OAuth 1.1" in the WG.

On 10/27/09 9:44 AM, Eran Hammer-Lahav wrote:
> This draft is the original community specification created outside
> the IETF. It was this work that inspired the creation of the OAUTH WG
> and is explicitly set as the initial draft for the WG in its charter.
> The draft is submitted as an informational RFC to document existing
> deployment and practices. It is not a WG product.
> 
> EHL
> 
>> -----Original Message----- From: [email-masked]
>> [mailto:[email-masked]] On Behalf Of Cullen Jennings Sent:
>> Tuesday, October 27, 2009 7:12 AM To: IESG IESG Cc: IETF Discussion
>>> consider the following document:
>>> 
>>> - 'The OAuth Core 1.0 Protocol ' <draft-hammer-oauth-03.txt> as
>>> an Informational RFC
>>> 
>>> The IESG plans to make a decision in the next few weeks, and
>>> solicits final comments on this action.  Please send substantive
>>> comments to the [email-masked] mailing lists by 2009-11-06.
>>> Exceptionally, comments may be sent to [email-masked] instead. In
>>> either case, please retain the beginning of the Subject line to
>>> allow automated sorting.
>>>