Subject: Re: Last Call: draft-ietf-idnabis-bidi (Right-to-left scripts for IDNA) to Draft Standard

From: Simon Josefsson <[email-masked]>
Date: Thu, 01 Oct 2009 12:42:56 +0200

I object to publishing these IDNA documents as a Draft Standard.  I
don't view IDNA2008 as a revision of the earlier IDNA2003 protocol.  The
design goals have changed since the first IDNA version.  Finally, there
have been little implementation experience with the new protocol.

I would support publication as Proposed Standard.

/Simon

The IESG <[email-masked]> writes:

> The IESG has received a request from the Internationalized Domain Names 
> in Applications, Revised WG (idnabis) to consider the following document:
>
> - 'Right-to-left scripts for IDNA '
>    <draft-ietf-idnabis-bidi-06.txt> as a Draft Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send substantive comments to the
> [email-masked] mailing lists by 2009-10-13. Exceptionally, 
> comments may be sent to [email-masked] instead. In either case, please 
> retain the beginning of the Subject line to allow automated sorting.
>
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-ietf-idnabis-bidi-06.txt
>
> Implementation Report can be accessed at
> http://www.ietf.org/iesg/implementation.html
>
>
> IESG discussion can be tracked via
> https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=17284&rfc_flag=0

The IESG <[email-masked]> writes:

> The IESG has received a request from the Internationalized Domain Names 
> in Applications, Revised WG (idnabis) to consider the following document:
>
> - 'Internationalized Domain Names for Applications (IDNA): Definitions 
>    and Document Framework '
>    <draft-ietf-idnabis-defs-11.txt> as a Draft Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send substantive comments to the
> [email-masked] mailing lists by 2009-10-13. Exceptionally, 
> comments may be sent to [email-masked] instead. In either case, please 
> retain the beginning of the Subject line to allow automated sorting.
>
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-ietf-idnabis-defs-11.txt
>
> Implementation Report can be accessed at
> http://www.ietf.org/iesg/implementation.html
>
>
> IESG discussion can be tracked via
> https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=17772&rfc_flag=0

The IESG <[email-masked]> writes:

> The IESG has received a request from the Internationalized Domain Names 
> in Applications, Revised WG (idnabis) to consider the following document:
>
> - 'Internationalized Domain Names in Applications (IDNA): Protocol '
>    <draft-ietf-idnabis-protocol-16.txt> as a Draft Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send substantive comments to the
> [email-masked] mailing lists by 2009-10-13. Exceptionally, 
> comments may be sent to [email-masked] instead. In either case, please 
> retain the beginning of the Subject line to allow automated sorting.
>
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-ietf-idnabis-protocol-16.txt
>
> Implementation Report can be accessed at
> http://www.ietf.org/iesg/implementation.html
>
>
> IESG discussion can be tracked via
> https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=17268&rfc_flag=0

The IESG <[email-masked]> writes:

> The IESG has received a request from the Internationalized Domain Names 
> in Applications, Revised WG (idnabis) to consider the following document:
>
> - 'The Unicode code points and IDNA '
>    <draft-ietf-idnabis-tables-07.txt> as a Draft Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send substantive comments to the
> [email-masked] mailing lists by 2009-10-13. Exceptionally, 
> comments may be sent to [email-masked] instead. In either case, please 
> retain the beginning of the Subject line to allow automated sorting.
>
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-ietf-idnabis-tables-07.txt
>
> Implementation Report can be accessed at
> http://www.ietf.org/iesg/implementation.html
>
>
> IESG discussion can be tracked via
> https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=17234&rfc_flag=0

---

From: Lisa Dusseault <[email-masked]>
Date: Thu, 1 Oct 2009 08:23:18 -0700

> I would support publication as Proposed Standard.
You are absolutely correct and this is a pilot error on my part.  I
didn't notice the documents were automatically listed as going for
Draft Standard in the tracking tools when I issued the Last Call.  SM
pointed out that the Last Call announcement mentioned implementation
reports but I didn't realize what caused that error. I will look into
fixing this and reissuing the Last Call announcements.

Lisa

---

From: SM <[email-masked]>
Date: Thu, 01 Oct 2009 08:51:14 -0700

Hi Lisa,
>fixing this and reissuing the Last Call announcements.

The Last-Call announcements for the following I-Ds mentioned "Draft Standard":

  draft-ietf-idnabis-bidi-06
  draft-ietf-idnabis-defs-11
  draft-ietf-idnabis-protocol-16
  draft-ietf-idnabis-tables-07

The Intended Status for draft-ietf-idnabis-mappings-04 is "Standard 
Track" according to the draft.  The announcement (and datatracker) 
mentioned "Informational RFC".

Regards,
-sm

---

From: Simon Josefsson <[email-masked]>
Date: Thu, 01 Oct 2009 19:22:13 +0200

> fixing this and reissuing the Last Call announcements.

Thanks -- I didn't read the discussion on the mailing list about the
mistake until now, and I assumed the intention really was to go for
Draft Standard.  I am happy that it was just a mistake and I am sorry if
my comment felt confrontational.

/Simon