Subject: What is this with these confirmation messages?

From: Christian Huitema <[email-masked]>
Date: Thu, 24 Dec 2009 21:22:58 +0000

All IETF mailing list seem to now require this &%!$# confirmation procedure. This particular message was rather ironic; I was sending a request to "[email-masked]"! Who decided to implement this filtering, and why did they do such a poor job of it?

Whose

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, December 24, 2009 1:20 PM
To: Christian Huitema
Subject: Confirm: [email-masked]:phQqLmSzPbBA:BttiZVJDKqxGAJxkqjzyRLPoJnA_T9FrS9ksVw

Confirmation of list posting -- confirmation ID: phQqLmSzPbBA

The ietf.org mailing-list server has received a list posting from 
[email-masked] to [email-masked] with the subject 
'Why am I receieving this message?'

As the sender address isn't subscribed to the list, and has not been
confirmed earlier, we have to request a confirmation of the address.
To confirm the address, send a message to [email-masked],
with the same subject line as this message.

(Simply sending a 'reply' to this message should work from most email
interfaces, since that usually leaves the subject line in the right
form.  The reply's additional "Re:" is ok.)

If you do not wish your posting to the list to go through, simply
disregard this message.  Questions to [email-masked].

---

From: Michael Richardson <[email-masked]>
Date: Sat, 26 Dec 2009 14:25:45 -0500

>>>>> "Christian" == Christian Huitema <[email-masked]> writes:
    Christian> All IETF mailing list seem to now require this &%!$#
    Christian> confirmation procedure. This particular message was
    Christian> rather ironic; I was sending a request to
    Christian> "[email-masked]"! Who decided to implement this
    Christian> filtering, and why did they do such a poor job of it?

  I think it's an attempt to deal with spam from "non-subscribers"
  What I would prefer is that the list of acceptable posters to all IETF
lists was formed by:
      cat * >all-posts

  i.e. if you are subscribed to any IETF list, you can post to any list.
(And I'd also be quite happy if this was enabled only for OpenPGP or
S/MIME signed emails, and yes, I do mean that IETF should run a CA)

- -- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.