Subject: Re: [rfc-i] Important: do not publish "draft-iab-streams-headers-boilerplates-08" as is!

From: Julian Reschke <[email-masked]>
Date: Fri, 18 Dec 2009 11:05:11 +0100

Julian Reschke wrote:
> Bob Braden wrote:
>> Jim,
>>
>> Understood, but the RFC Editor does care how it flows.  We would like to 
>> get it as nearly right as possible, going out of the gate.
>>
>> Bob Braden
>> ...
> 
> For tracking purposes, I just published draft-reschke-hab-00 
> (<http://greenbytes.de/tech/webdav/draft-reschke-hab-00.html>), which 
> contains the headers and boilerplates for the 19 cases Sandy has 
> identified. Note that the contents for these cases is auto-generated by 
> the experimental version of rfc2629.xslt.
> 
> I plan to update rfc2629.xslt and this draft as the RFC Editor 
> fine-tunes the text for draft-iab-streams-headers-boilerplates. This 
> will give us easy-to-read diffs on tools.ietf.org.
> ...

In the meantime, draft-iab-streams-headers-boilerplates is in AUTH48, 
and I have updated my document with the current changes; see 
<http://tools.ietf.org/html/draft-reschke-hab-01>, in particular 
<http://tools.ietf.org/html/draft-reschke-hab-01#appendix-A.1> (change 
list) and <http://tools.ietf.org/rfcdiff?url2=draft-reschke-hab-01.txt> 
(diffs).

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Tue, 22 Dec 2009 10:26:45 +0100

> list) and <http://tools.ietf.org/rfcdiff?url2=draft-reschke-hab-01.txt> 

I just heard that the RFC 5741-to-be is not going to be fixed with 
respect to the stutter in the boilerplate, such as in:

-- snip --
3.1.6.2. Text of 'Status Of This Memo'

    This document is not an Internet Standards Track specification; it is
    published for the historical record.

    This document defines a Historic Document for the Internet community.
    This document is a product of the Internet Engineering Task Force
    (IETF).  It has been approved for publication by the Internet
    Engineering Steering Group (IESG).  Not all documents approved by the
    IESG are candidate for any level of Internet Standards; see Section 2
    of RFC 5741.

    Information about the current status of this document, any errata,
    and how to provide feedback on it may be obtained at
    http://www.rfc-editor.org/info/rfc9999.
-- snip --

(see <http://tools.ietf.org/html/draft-reschke-hab-01#section-3.1.6.2>).

This problem was reported over three weeks ago. Are we really incapable 
to fix something simple like that within three weeks?

Best regards, Julian

---

From: Olaf Kolkman <[email-masked]>
Date: Tue, 22 Dec 2009 11:50:45 +0100

Julian,

> to fix something simple like that within three weeks?

We are at a point where making trivial changes to headers and boilerplates leads to discussion about more substantive matters and causes even more delay, folk wanted it done. It is unfortunate that the stutter (I agree its there and that its ugly) remains in the document. 

Headers and boilerplates lives on this tangent between community wishes, RFC oversight, and RFC Editor series continuity and style. Having learned from getting H&B done, I believe that in the future such efforts should be pulled by the RSE, with IAB oversight and not by the IAB with RFC-Editor input.

FWIW, the document allows the RFC editor  some headway in maintaining the language in the style guide.

--Olaf

[top-post, full context below.]

On Dec 22, 2009, at 10:26 AM, Julian Reschke wrote:

> _______________________________________________
> rfc-interest mailing list
> [email-masked]
> http://mailman.rfc-editor.org/mailman/listinfo/rfc-interest

________________________________________________________ 

Olaf M. Kolkman                        NLnet Labs
                                       Science Park 140, 
http://www.nlnetlabs.nl/               1098 XG Amsterdam

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 23 Dec 2009 08:23:14 +1300

> FWIW, the document allows the RFC editor  some headway in maintaining the language in the style guide.

Maybe we^H^Hthe IAB should have aimed at full delegation of the boilerplate,
exactly as for the Trust-maintained boilerplate.

For now, there are indeed weasel words such as:
  "However, this is not
   intended to specify a single, static format.  Details of formatting
   are decided by the RFC Editor."

  "These paragraphs will need to be
   defined and maintained as part of RFC stream definitions.  Initial
   text, for current streams, is provided below."

I think this gives the RSE, in conjunction with the tools maintainers,
reasonable flexibility.

I also note:

  "The changes introduced by this memo should be implemented as soon as
   practically possible after the document has been approved for
   publication."

which is presumably intended to allow the tools some time to catch up,
again requiring RSE/tools coordination.

Regards
   Brian Carpenter

On 2009-12-22 23:50, Olaf Kolkman wrote:
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Russ Housley <[email-masked]>
Date: Tue, 22 Dec 2009 15:08:32 -0500

Dave:

I agree with Birain's assessment. The RFC Editor can handle this 
issue without delaying publication of the document.

Russ

At 02:39 PM 12/22/2009, Dave CROCKER wrote:
>Brian,
>
>This seems worth being a bit pedantic about, to make sure we all 
>share the same
>understanding:  I take your interpretation to mean that the RFC 
>Editor can, on
>their own initiative, fix the problem(s) that Julan has raised and 
>that it does
>not require changes to the about-to-be-published document.
>
>Is that correct?  Do others agree?  (I hope so.)
>
>d/
>
>On 12/22/2009 11:23 AM, Brian E Carpenter wrote:
> >> FWIW, the document allows the RFC editor  some headway in 
> maintaining the language in the style guide.
>...
>--
>    Dave Crocker
>    Brandenburg InternetWorking
>    bbiw.net

---

From: Bob Hinden <[email-masked]>
Date: Tue, 22 Dec 2009 12:41:07 -0800

On Dec 22, 2009, at 12:08 PM, Russ Housley wrote:

> Dave:
> 
> I agree with Birain's assessment. The RFC Editor can handle this issue without delaying publication of the document.

+1

Bob

---

From: Jari Arkko <[email-masked]>
Date: Wed, 23 Dec 2009 09:06:46 +0200

All,

>> I agree with Birain's assessment. The RFC Editor can handle this issue without delaying publication of the document.

Me too. Publish the RFC. Please.

Jari

---

From: Olaf Kolkman <[email-masked]>
Date: Wed, 23 Dec 2009 10:00:02 +0100

On Dec 22, 2009, at 8:39 PM, Dave CROCKER wrote:

> Brian,
> 
> This seems worth being a bit pedantic about, to make sure we all share the same understanding:  I take your interpretation to mean that the RFC Editor can, on their own initiative, fix the problem(s) that Julan has raised and that it does not require changes to the about-to-be-published document.
> 
> 

FWIW, I do. As long as those changes are stylistic, editorial, and not so substantive that they cause the various streams to be uneasy with those changes.

> exactly as for the Trust-maintained boilerplate.

That is what I intended with:  I believe that in the future such efforts should be pulled by the RSE, with IAB oversight and not by the IAB with RFC-Editor input

--Olaf (personal title)

---

From: "Jim Schaad" <[email-masked]>
Date: Tue, 22 Dec 2009 19:45:56 -0800

I have long held this view

Jim

> -----Original Message-----
> From: [email-masked] [mailto:rfc-interest-
> [email-masked]] On Behalf Of Bob Hinden
> Sent: Tuesday, December 22, 2009 12:41 PM
> To: Russ Housley
> Cc: Olaf Kolkman; [email-masked]; IETF discussion list;
> Bob Hinden; [email-masked]; [email-masked]
> Subject: Re: [rfc-i] Important: do not publish "draft-iab-streams-
> headers-boilerplates-08" as is!
> 
>