Subject: Re: wanted: your old NAT home router

From: Lars Eggert <[email-masked]>
Date: Wed, 2 Jun 2010 18:36:42 +0300

Hi,

FYI, a first report with test results for 34 devices is available athttp://fit.nokia.com/lars/tmp/2010-hgw-study.pdf. Slides that summarize the results are at http://fit.nokia.com/lars/tmp/2010-hgw-study-slides.pdf.

We have received another 30-odd devices as donations, which we'll add to the testbed and include in a follow-up study.

If you have an unused, spare home gateway to donate to this effort, please contact us at [email-masked]. We're also interested in obtaining a DSLAM and a CMTS.

Thanks,
Lars

On 2010-4-29, at 12:34, Lars Eggert wrote:
> Hi,
> 
> for a measurement study done together with Markku Kojo's team at the University of Helsinki, we're looking to collect as many different NAT home routers as possible. If you have an old clunker lying around somewhere, please contact me off-list. I'll cover shipping via DHL. Feel free to forward this email as you see fit.
> 
> The boxes will find a permanent home at the University of Helsinki. Study results will be published openly. The intent is that this collection become a resource for the community to be shared for future studies. 
> 
> Caveat: The boxes should NAT between Ethernet interfaces - we don't have DSL or cable access equipment in the lab setup at the moment.
> 
> Thanks,
> Lars

---

From: Yoav Nir <[email-masked]>
Date: Thu, 3 Jun 2010 10:53:20 +0300

Hi Lars

Great study. Looking forward to seeing more devices there.

Two tests I would add to this:

1. TCP segment size negotiation - have a low-MTU link somewhere between the NAT box and the server, and see if the MSS gets adjusted like it should.

2. IKE/IPsec - IKE was supposed to go from port 500 to port 500. Some older routers made heroic efforts to translate the traffic so that the source port remains 500, which may have killed more sessions than it saved. These days, NAT Traversal makes this easier. I suggest connecting some IKE/IPsec client (like the Microsoft or Mac OS L2TP client) to some server through the NAT.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lars Eggert
Sent: Wednesday, June 02, 2010 6:37 PM
To: [email-masked] Discussion
Cc: [email-masked]
Subject: Re: wanted: your old NAT home router

Hi,

Thanks,
Lars

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 3 Jun 2010 04:28:23 -0400

It would be really nice to get one of the consumer PC rags to pick up this story - an easy-to-interpret compliance label would be even better. If the consumer rags would refuse to recommend a non-compliant box, maybe vendors have some incentive to read the RFCs.

I assume IPv6 tests are planned?

This illustrates that the Internet experience will be increasingly driven by the laziness of equipment vendors, rather than anything the IETF can standardize. There does not appear to be any functioning feedback loop to accelerate convergence to reasonable behavior.

Henning

On Jun 3, 2010, at 3:53 AM, Yoav Nir wrote:

> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>