Subject: RE: [dispatch] VIPR - proposed charter version 3

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 30 Jun 2010 12:42:54 +0200

> The VIPR WG will address this problem by developing a peer to 
> peer based approach to finding domains that claim to be 
> responsible for a given phone number and validation protocols 
> to ensure a reasonable likelihood that a given domain 
> actually is responsible for the phone number. 

Hi,

Clarification question. What exactly means 'peer to peer based approach'
and what kind of approaches are excluded by having this in the charter.
Does 'approach' mean solution? If so why does a specific type of
solution need to be agreed in the charter, while all we have at hand at
this point are individual contribution I-Ds that describe the 'problem
statement and some possible starting points for solutions'?

Thanks and Regards,

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Mary Barnes
> Sent: Monday, June 28, 2010 8:38 PM
> To: DISPATCH
> Subject: [dispatch] VIPR - proposed charter version 3
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 30 Jun 2010 12:47:57 +0200

Hi Mary,

I also think that listing the deliverables should be independent from mentioning the existing initial contributions. The existing contributions could be listed as well, but they should not preclude other contributions on the same items after the WG is formed. 

Regards,

Dan

> Sent: Monday, June 28, 2010 9:00 PM
> To: DRAGE, Keith (Keith)
> Cc: DISPATCH
> Subject: Re: [dispatch] VIPR - proposed charter version 3
> 
> Hi Keith,
> 
> That's a valid concern and we can rewrite the deliverables as 
> functional descriptions as we have done for other WG charters 
> even in cases where documents existed (e.g., overload).  The 
> current text is trying to say that these documents map to 
> deliverables and can be used as WG documents, although as it 
> notes these should be considered starting points (i.e., it's 
> understood the proposed WG has change control), but certainly 
> the current text is somewhat misleading.
> 
> Thanks,
> Mary.
> 
> On Mon, Jun 28, 2010 at 12:43 PM, DRAGE, Keith (Keith) 
> <[email-masked]> wrote:
> > I have a major issue with including "which shall form the 
> bases of the WG documents" into the charter. To me this is 
> confusing the charter discussion with the working group that 
> might eventually result deciding what its deliverables, and 
> their contents, shall be.
> >
> > regards
> >
> > Keith
> >
> >> Sent: Monday, June 28, 2010 6:38 PM
> >> To: DISPATCH
> >> Hi all,
> >> Below, please find version 3 of the VIPR proposed charter.
> >> It's been updated to reflect ML feedback, in particular 
> VAP has been 
> >> added and clarifications have been made with regards to impacts 
> >> (i.e., none) on existing PSTN interfaces.
> >>
> >> Regards,
> >> Mary
> >> (DISPATCH WG co-chair)
> >>
> >> ============================================
> >> VIPR Charter Proposal (Version 3)
> >>
> >> WG Name:  Verification Involving PSTN Reachability (VIPR)
> >>
> >> There are two globally deployed address spaces for communications 
> >> used by more than a billion people daily - phone numbers and DNS 
> >> rooted address such as web servers and email addresses. The 
> >> inter-domain signaling design of SIP is primarily designed 
> for email 
> >> style addresses yet a large percentage of SIP deployments 
> mostly use 
> >> phone numbers for identifying users. The goal of this 
> working group 
> >> is to enable inter-domain communications over the the 
> Internet, using 
> >> protocols such as SIP, while still allowing people to use phone 
> >> numbers to identify the person with whom they wish to communicate.
> >>
> >> The VIPR WG will address this problem by developing a peer to peer 
> >> based approach to finding domains that claim to be 
> responsible for a 
> >> given phone number and validation protocols to ensure a reasonable 
> >> likelihood that a given domain actually is responsible for 
> the phone 
> >> number. In this context, "responsible" means an administrative 
> >> domain, which is at least one of the domains, to which a 
> PSTN call to 
> >> this phone number would be routed. Once the domain responsible for 
> >> the phone number is found, existing protocols, such as SIP, can be 
> >> used for inter-domain communications.
> >>
> >> Some validation protocols may be based on knowledge 
> gathered around a 
> >> PSTN call; for example, the ability to prove a call was 
> received over 
> >> the PSTN based on start and stop times.
> >> Other validation schemes, such as examining fingerprints or 
> >> watermarking of PSTN media to show that a domain received a 
> >> particular PSTN phone call, may also be considered by the working 
> >> group. This validation will be accomplished using publicly 
> available 
> >> open interfaces to the PSTN, so the validation can be performed by 
> >> any domain wishing to participate.  The WG will select and 
> >> standardize at least one validation scheme.
> >>
> >> The validation mechanism requires a domain to gather and maintain 
> >> information related to PSTN calls.  This information is 
> used by call 
> >> agents such as phones, SBCs and IP PBXs to route calls.  
> The WG will 
> >> define a client-server protocol between these call agents and the 
> >> entity within a domain that maintains the information.
> >>
> >> To help mitigate SPAM issues when using SIP between 
> domains, the WG 
> >> will define a mechanism to enable one domain to check that 
> incoming 
> >> SIP messages are coming from a validated phone number.  A phone 
> >> number is considered validated if it is coming from a 
> domain to which 
> >> the calling domain had previously successfully placed a 
> PSTN call.  
> >> The working group will define new SIP headers and option tags, as 
> >> necessary, to enable this.
> >>
> >> The essential characteristic of VIPR is establishing 
> authentication 
> >> by PSTN reachability when it is not possible to use a direct 
> >> reference to ENUM databases or other direct assertions of 
> PSTN number 
> >> ownership. Elements such as public ENUM easily coexist 
> with VIPR but 
> >> no direct interaction with ENUM will be required.  The 
> solution set 
> >> defined by this WG will be incrementally deployable using only 
> >> existing interfaces to the PSTN.  No changes will be required to 
> >> existing PSTN capabilities, no new database access is 
> needed nor is 
> >> any new support from PSTN service providers required.
> >>
> >> The problem statement and some possible starting points 
> for solutions 
> >> are further discussed in the following internet drafts which shall 
> >> form the bases of the WG documents:
> >>
> >> draft-rosenberg-dispatch-vipr-overview
> >> draft-rosenberg-dispatch-vipr-reload-usage
> >> draft-rosenberg-dispatch-vipr-pvp
> >> draft-rosenberg-dispatch-vipr-sip-antispam
> >> draft-rosenberg-dispatch-vipr-vap
> >>
> >> The working group will carefully coordinate with the 
> security area, 
> >> O&M area, as well as the appropriate RAI WGs such as sipcore and 
> >> p2psip.
> >> _______________________________________________
> >> dispatch mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/dispatch
> >>
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 30 Jun 2010 17:33:24 +0200

It looks to me that one can imagine 'centralized' solutions which are
also based on reusing SIP related functionality developed in RAI. I
would rather not close such an option and allow the WG a window of
opportunity in which alternate solutions that could meet the same goals
can be presented.  

Dan

> From: Mary Barnes [mailto:[email-masked]] 
> Sent: Wednesday, June 30, 2010 6:24 PM
> To: Romascanu, Dan (Dan)
> Cc: DISPATCH; IETF-Discussion list
> Hi Dan,
> The term peer to peer is intended to exclude mechanisms that 
> would use a central repository for the information:  This was 
> discussed in an earlier thread:
> http://www.ietf.org/mail-archive/web/dispatch/current/msg02027.html
> 
> In one sense it is a solution, however, in another sense it 
> is reusing SIP related functionality defined in RAI and thus 
> is in a similar vein as specifying the use of SIP in a charter.
> 
> Thanks,
> Mary.
> 
> On Wed, Jun 30, 2010 at 5:42 AM, Romascanu, Dan (Dan) 
> <[email-masked]> wrote:
> >> number.
> > solution need to be agreed in the charter, while all we 
> have at hand 
> > at this point are individual contribution I-Ds that describe the 
> > 'problem statement and some possible starting points for solutions'?
> >
> > Thanks and Regards,
> >
> > Dan
> >
> >

---

From: "Roni Even" <[email-masked]>
Date: Wed, 30 Jun 2010 19:03:59 +0300

Mary,
When I read the charter it is not clear why from the first paragraph you
deduct the second paragraph.
If the first paragraph will say
" The goal of this working group is to enable inter-domain communications
over the Internet, using protocols such as SIP, while still allowing people
to use the called person assigned circuit switch phone number for
identifying the person with whom they wish to communicate. " 
It may look clearer.

Still this is based on the assumption that using other ways to assign and
authenticate SIP phone numbers using central databases is not catching up
because the carriers object to implement it and not due to any other reason
like preferences of enterprises IT to use PSTN for calls because of better
quality of service and manageability.

Roni Even

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Mary Barnes
> The term peer to peer is intended to exclude mechanisms that would use
> a central repository for the information:  This was discussed in an
> earlier thread:
> In one sense it is a solution, however, in another sense it is reusing
> SIP related functionality defined in RAI and thus is in a similar vein
> as specifying the use of SIP in a charter.
> 
> Thanks,
> Mary.
>