Subject: Re: wanted: your old NAT home router

From: Lars Eggert <[email-masked]>
Date: Fri, 9 Jul 2010 10:15:16 +0300

Hi,

a quick status update. We now have received over 100 donated home gateways, plus a DSLAM. The students are on their summer break, after which we'll start running a significantly expanded set of tests over this much larger population of devices.

Many of yo have donated boxes and suggested more experiments and better ways of performing our current tests - thank you!

In case you are attending IETF-78 in Maastricht and would like to donate a home gateway, simply bring it. (Or contact me now for shipping details; no cost to you.)

We're especially interested in devices from outside the EU and North America, or any other model we may not have yet (see http://fit.nokia.com/lars/tmp/2010-hgw-study-devices.txt). And we're still lacking a CMTS for testing cable modems...

See you in Maastricht,
Lars

On 2010-6-2, at 18:36, Lars Eggert wrote:
> Hi,
> 
> FYI, a first report with test results for 34 devices is available at http://fit.nokia.com/lars/tmp/2010-hgw-study.pdf. Slides that summarize the results are at http://fit.nokia.com/lars/tmp/2010-hgw-study-slides.pdf.
> 
> We have received another 30-odd devices as donations, which we'll add to the testbed and include in a follow-up study.
> 
> If you have an unused, spare home gateway to donate to this effort, please contact us at [email-masked]. We're also interested in obtaining a DSLAM and a CMTS.
> 
> Thanks,
> Lars
> 
> On 2010-4-29, at 12:34, Lars Eggert wrote:
>> Hi,
>> 
>> for a measurement study done together with Markku Kojo's team at the University of Helsinki, we're looking to collect as many different NAT home routers as possible. If you have an old clunker lying around somewhere, please contact me off-list. I'll cover shipping via DHL. Feel free to forward this email as you see fit.
>> 
>> The boxes will find a permanent home at the University of Helsinki. Study results will be published openly. The intent is that this collection become a resource for the community to be shared for future studies. 
>> 
>> Caveat: The boxes should NAT between Ethernet interfaces - we don't have DSL or cable access equipment in the lab setup at the moment.
>> 
>> Thanks,
>> Lars
>

---

From: Lars Eggert <[email-masked]>
Date: Thu, 22 Jul 2010 08:50:26 +0300

Hi,

On 2010-7-20, at 21:00, Yuchung Cheng wrote:
> This is very interesting study! it provides many useful information for the TCP research at Google.

thanks! Let's chat at the IETF if there are any tests we can do that would make the results even more relevant for you guys?

> The queuing and processing delays on slide 12 (or figure 9 in the paper) are mostly <50ms, but the following paper
> "Characterizing residential broadband networks"  published in IMC 2007 measures much higher queuing length ranging from 100ms to a few secs (http://portal.acm.org/citation.cfm?id=1298306.1298313 figure 13).
> 
> Any idea about the differences?

We haven't looked into the details much. One factor may be that the delay numbers we measured where taken at the same time we did the bulk throughput measurements, and they only used a single connection up and/or down. And IIRC we measured the delay experience by that connection and not the delay experienced by other connections through the box at the time. It may also be that our population is home gateways is newer (= better?) than the one measured by the IMC paper. We'll attempt to look into this more deeply during the next phase of the study.

Lars

> 
> Thanks,
> 
> Yuchung
> 
> On Fri, Jul 9, 2010 at 12:15 AM, Lars Eggert <[email-masked]<mailto:[email-masked]>> wrote:
> Hi,
> 
>> If you have an unused, spare home gateway to donate to this effort, please contact us at [email-masked]<mailto:[email-masked]>. We're also interested in obtaining a DSLAM and a CMTS.
>> 
>> Thanks,
>> Lars
>> 
> _______________________________________________
> 78attendees mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/78attendees
> 
>

---

From: Yuchung Cheng <[email-masked]>
Date: Tue, 20 Jul 2010 11:00:24 -0700

Hi Lars,

This is very interesting study! it provides many useful information for the
TCP research at Google.

The queuing and processing delays on slide 12 (or figure 9 in the paper) are
mostly <50ms, but the following paper
"Characterizing residential broadband networks"  published in IMC 2007
measures much higher queuing length ranging from 100ms to a few secs (
http://portal.acm.org/citation.cfm?id=1298306.1298313 figure 13).

Thanks,

Yuchung

On Fri, Jul 9, 2010 at 12:15 AM, Lars Eggert <[email-masked]> wrote:

> Hi,
>
> a quick status update. We now have received over 100 donated home gateways,
> plus a DSLAM. The students are on their summer break, after which we'll
> start running a significantly expanded set of tests over this much larger
> population of devices.
>
> Many of yo have donated boxes and suggested more experiments and better
> ways of performing our current tests - thank you!
>
> In case you are attending IETF-78 in Maastricht and would like to donate a
> home gateway, simply bring it. (Or contact me now for shipping details; no
> cost to you.)
>
> We're especially interested in devices from outside the EU and North
> America, or any other model we may not have yet (see
> http://fit.nokia.com/lars/tmp/2010-hgw-study-devices.txt). And we're still
> lacking a CMTS for testing cable modems...
>
> See you in Maastricht,
> Lars
>
> > FYI, a first report with test results for 34 devices is available at
> http://fit.nokia.com/lars/tmp/2010-hgw-study.pdf. Slides that summarize
> the results are at http://fit.nokia.com/lars/tmp/2010-hgw-study-slides.pdf
> .
> >
> > We have received another 30-odd devices as donations, which we'll add to
> the testbed and include in a follow-up study.
> >
> > If you have an unused, spare home gateway to donate to this effort,
> please contact us at [email-masked]. We're also interested in
> obtaining a DSLAM and a CMTS.
> >
> > Thanks,
> > Lars
> >
> >> for a measurement study done together with Markku Kojo's team at the
> University of Helsinki, we're looking to collect as many different NAT home
> routers as possible. If you have an old clunker lying around somewhere,
> please contact me off-list. I'll cover shipping via DHL. Feel free to
> forward this email as you see fit.
> >>
> >> The boxes will find a permanent home at the University of Helsinki.
> Study results will be published openly. The intent is that this collection
> become a resource for the community to be shared for future studies.
> >>
> >> Caveat: The boxes should NAT between Ethernet interfaces - we don't have
> DSL or cable access equipment in the lab setup at the moment.
> >>
> >> Thanks,
> >> Lars
> >
>
>
> [email-masked]