Subject: Ad Hoc BOFs

From: Fred Baker <[email-masked]>
Date: Thu, 29 Jul 2010 22:00:44 +0200

The IETF list is often a place for rants and raves. I have a concern that I want to raise, but I also want to be constructive about it. I'm hoping my colleagues will play ball with that.

I am really happy to see the interest and conversation that has been happening at IETF-77 and IETF-78 regarding potential new work and topics of interest, aka "Bar BOFs". The infusion of new work and discussions of topics of interest is a good thing.

I want to talk about "how it is done". I have a concern. The concern is in essence a lack of regard for people's health and time. For me, IETF-78 started on Sunday afternoon and has proceeded until now (9:33 Thursday evening) with seven breaks - a social event, a private social event, nights in which I have gone to my hotel and collapsed for five or six hours, and this afternoon when I did the same. The entire remaining time has been consumed in meetings - meals, IETF WG and BOF meetings, receptions and plenaries, and various ad hoc conversations. Many of these have been so-called "Bar BOFs". By the way, I am far from alone. At IETF-77, people complained that leadership (IESG/IAB/etc) didn't show up at their "Bar BOFs". For those people, the IETF is a far busier meeting. When I was IETF Chair, I scheduled potty breaks, and I couldn't cross a room to get a glass of wine or cup of coffee without being stopped several times by someone who needed to chat with me. Our leaders are generally happy to be helpful any way they can, but they deserve our respect for the incredible time and work commitment that they make.

Let me explain what a Bar BOF is, and what it is not. Our formal BOFs are scheduled with an AD, and are generally for formalizing a charter. The assumption is that a prior ad hoc process, usually on a mailing list or via telephone or conferencing systems has happened, and a work item has matured to the point that we have interested people, proto-specifications or at least problem statements, and so on.

The initiation point of that is often-but-not-always a handful of people talking over a meal or in a bar on a topic, often having convened mere moments before. Sketches might be drawn on napkins, and people that are hungry or thirsty have a waiter/waitress at hand to deal with that. A Bar BOF, as such small gatherings are called, is *not* a full-blown meeting of perhaps hundreds of people placed at a mealtime but in a place that prevents them from eating. It does not require powerpoint, and is not a catered event. It is not ten minutes stolen from some other subject. Key concept: we respect each other and each other's time, and so we meet in a place that has food and drink, and we have an intimate conversation among people who will be interested to carry on some work item.

Another way that conversations that lead to eventual working group formation are initiated tends to be ad hoc meetings. These might be similarly carried out over dinner, but they usually happen at a time that the participants have no other plan - the key attendees are not in any other meeting and so are free, or perhaps they planned in advance to meet Sunday afternoon or on the Saturday following. Meetings of this type may happen at IETF meetings, but they are planned weeks in advance, soon after the IETF agenda is finalized. If IETF rooms are available, so be it; often, companies that want to have these meetings provide a room of their own.

BOFs are necessary. Ad Hoc meetings happen, although they can be a pain to include in one's schedule. Bar BOFs, the kind that happen in bars and are a small number of co-conspirators, are part of the fabric of which the IETF is woven. Ad Hoc meetings that jerk the secretariat around and are disrespectful of people's biology and health are a problem.

If we're going to continue this avalanche of ad hoc meetings that we call "Bar BOFs", I would recommend that the Secretariat provide a web page for requesting them. The title of the web page should be "Poorly Planned Meetings" or something like that.

---

From: Dave CROCKER <[email-masked]>
Date: Thu, 29 Jul 2010 22:47:56 +0200

On 7/29/2010 10:00 PM, Fred Baker wrote:
> If we're going to continue this avalanche of ad hoc meetings that we call
> "Bar BOFs", I would recommend that the Secretariat provide a web page for
> requesting them. The title of the web page should be "Poorly Planned
> Meetings" or something like that.

In other words, let's make unofficial, ad hoc meetings be formal and scheduled.

Fred, like you, I'm delighted to see the activity.  However just because there 
is interest in having formal, scheduled activities that are not qualified to be 
BOFs, we do not need to have IETF administration support them with extra 
services.  Let's let these self-initiated efforts remain what they are.  If they 
can garner attendees, that's fine.  If they can't, better luck next time.  Even 
with the excellent title you suggest, the web page will move these activities 
down the slippery slope of formality.

The way to make a more rational schedule for the week is to schedule less, not more.

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 29 Jul 2010 23:43:54 +0200

Just saying ... too late.

http://trac.tools.ietf.org/bof/trac/wiki/BarBofsIETF78 and predecessors have 
been "out there" for at least a couple of IETFs (like you guys, I'm 
exhausted, and in my case, too exhausted to check how many IETFs we've had 
such pages, but I know we had a list in Anaheim).

I'm also too exhausted to think of a way to contribute to this conversation, 
but in a week or two, it might be helpful to resume a conversation Lars 
started with http://tools.ietf.org/html/draft-eggert-successful-bar-bof-00, 
submitted late in the week during IETF 77, and which Fred contributed 
helpful comments to (below).

I'm sure the nice people who are bringing bar BOFs to the IETF would 
appreciate guidance that tells them how to best accomplish their goals ... 
so it is probably worth providing guidance, as best we can. The successful 
BOFs RFC (http://tools.ietf.org/html/rfc5434) was very helpful, and a 
companion document on bar BOFs would likely be helpful as well.

Thanks,

Spencer, who is going to bed earlier tonight than he has, since last Friday 
:D

> Fred, like you, I'm delighted to see the activity.  However just because 
> there is interest in having formal, scheduled activities that are not 
> qualified to be BOFs, we do not need to have IETF administration support 
> them with extra services.  Let's let these self-initiated efforts remain 
> what they are.  If they can garner attendees, that's fine.  If they can't, 
> better luck next time.  Even with the excellent title you suggest, the web 
> page will move these activities down the slippery slope of formality.
>
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 30 Jul 2010 09:50:00 +1200

On 2010-07-30 08:47, Dave CROCKER wrote:
> what they are.  If they can garner attendees, that's fine.  If they
> can't, better luck next time.  Even with the excellent title you
> suggest, the web page will move these activities down the slippery slope
> of formality.
> 

I learned a lesson in, now where was it?, oh yes, Anaheim. I decided to
have a Bar BOF, decided that the Hilton bar really wasn't convenient,
borrowed a room from Marcia, invited a few people, was asked to advertise
it on the wiki, and ended up with every seat taken in quite a big room.
The discussion was good, but not overwhelmingly successful, and a lot
of people just sat there quietly. (Admittedly, there was very little
else to do in Anaheim for those over ten years old.)

I wish it had just been six of us at the bar.

    Brian

---

From: Melinda Shore <[email-masked]>
Date: Thu, 29 Jul 2010 14:05:06 -0800

> I wish it had just been six of us at the bar.

 From the BOFettes I participated in in Anaheim, I
got the general impression that the intent of the
get-together was to build support for turning
<whatever> into a working group - to create "yes"
votes (like it or not we've turned into a voting
organization) and to create interest rather than
sort through issues and answer questions.  The
most extreme example was the clouds thing, where
they wanted a working group before they even had
anything to work on.  So I think whether six people
at the bar is the right structure or a room with
meeting chairs and speakers and slides is the right
structure depends on whether the group is trying to
solve a technical problem or a political problem.

Melinda

---

From: Scott Brim <[email-masked]>
Date: Fri, 30 Jul 2010 00:28:13 +0200

Fred: I had the same experience -- I guess many of us did.  Last night I 
was at one until 9:20, when I left early to go quickly to another one 
where I was able to get a little food while we had a meeting.  I quit at 
11:45 and it was still going.  Tonight I managed to get a slice of pizza 
before heading off to a BarBOF.

But all of the BOFs that I have been at this week have been worthwhile 
for me.  Sometimes there were conflicts and I wished I could cover more 
than one.  Yes there were presentations but presentations are a good way 
to explain ideas.  There is always a lot of technical discussion that 
can't fit into the IETF schedule.  Apparently we are at a point where 
some of that technical discussion is appropriately done in bigger 
groups.  I wasn't in any huge ones like you -- mine varied from 15 to 50 
-- but I was glad to went to all of them.

So I can't complain about the get-togethers of any sort, just that there 
wasn't enough time for them.  I would like to encourage the use of IETF 
tools to announce ad hoc discussions using good teleconferencing tools, 
e.g. video, whiteboard, and queue management.

---

From: Fred Baker <[email-masked]>
Date: Fri, 30 Jul 2010 06:53:00 +0200

On Jul 30, 2010, at 12:28 AM, Scott Brim wrote:

> So I can't complain about the get-togethers of any sort, just that there wasn't enough time for them.  I would like to encourage the use of IETF tools to announce ad hoc discussions using good teleconferencing tools, e.g. video, whiteboard, and queue management.

And that's the point I'm trying to get to. They have all been valuable. I do very much wish that those promoting them had done a better job of fitting them into the schedule rather than simply dropping them atop it, and in some cases remote conferencing tools will be useful choices.

---

From: Jelte Jansen <[email-masked]>
Date: Fri, 30 Jul 2010 10:16:19 +0200

> And that's the point I'm trying to get to. They have all been valuable. I do very much wish that those promoting them had done a better job of fitting them into the schedule rather than simply drop…

but if they were al nicely scheduled alongside each other, you might feel forced
to attend even more meetings...

In fact, I was quite surprised to find the Bar Bof announcement page, which kind
of seems to go against the whole idea of it (eg you don't want to exclude
anyone, but you certainly don't want too many people to show up)

I held an unofficial meeting this week, and hope to have a real BoF next IETF,
but I did not put it on the announcement page (on purpose), and in fact i kind
of felt forced to call it a 'pre-bar-bof-meeting' because bar-bof already feels
too official.

IMHO, if you make it more official, you'll only extend the process, which will
result in another level of meetings, and even fuller schedules.

Jelte

---

From: Jari Arkko <[email-masked]>
Date: Fri, 30 Jul 2010 14:54:16 +0200

Fred,

I have mixed feelings about this. I had a tough week, particularly with 
lunches and dinner times packed with more meetings than usual. I already 
complained to Ray that they had made the system too efficient. You could 
now get lunch sandwich from the cafeteria in five minutes, making it 
possible to join a meeting during lunch break. Please be sure to include 
"only slow restaurants" in the meeting selection criteria for future 
meetings, so that we can have our lunch break back :-) Other problems 
that I saw during the week with the ad hoc BOFs include people 
consistently referring to the meetings as "BOFs", without making a 
distinction between a real BOF and an unofficial side meeting, some ADs 
worrying about conflicts and lack of scheduling for the ad hoc meetings, 
and some repetition of same proposals from the previous IETF without 
apparent progress.

That being said, in this meeting I saw more new things than I have seen 
for a while. I also felt that while I was busy and tired, I had made the 
right personal scheduling choices. For the record, I only participated 
three out of eight possible Internet area related side meetings, due to 
lack of time/other meetings and in few cases because I felt I needed to 
give myself some rest.

But we should also think about this a bit more than provide anecdotes. 
Lets think about the effect of the having side meetings to begin with, 
make a list of these meetings public, the location, and leadership 
participation separately. I think we all agree that having such meetings 
is great. That is how IETF gets the next wave of interesting topics to 
work on. We absolutely need the ability for hallway conversations, bar 
meetings, and the like.

I was responsible for making the list of meetings public. For the record 
I still do have mixed feelings about this. I have heard many people 
state that we should rather have smaller meetings and that its the 
public part of these meetings that drives up the participant count and 
makes the meeting more formal. Maybe so. I will point out, however, that 
one function of the public listing is to find a similarly interested 
discussion partner. Some people in the IETF are very well connected and 
may not need that, but I'm not sure that's true of everyone.

The location. I personally like having food in a small gathering, in a 
nice environment. That being said, the only real bar BoF that I attended 
was horrible in terms of being able to hear what the other people said. 
We had a dozen people, and I could not hear what the other end of the 
table said, multiple sets of people talked in parallel, etc. In the 
meetings that happened at the meeting rooms I was always able to 
understand what others were saying (though maybe not what their idea was 
:-) In general, I think one of the biggest values of the IETF is that we 
can put people together. I have no problem asking the secretariat to 
give one of our unused rooms for some ad hoc meeting if the participants 
believe it makes them move things forward.

Participation. As you can tell from above, I do not feel capable (or 
even obliged) of attending all these meetings. I try to make the most 
important ones, but you are on your own if you organizing an unofficial 
meeting. Just like you have always been. I know some other ADs have 
worried about scheduling conflicts with directorates and actual 
meetings. I'm not sure I want to see these meeting scheduled in any 
particular manner. If someone wants me to be somewhere, they better make 
sure I know when it is, why I should be there, and that I have no 
conflicts at that time. I do think that we should not schedule 
unofficial meetings against working group meetings. Looking at the bar 
BOF wiki, it does not seem that this was happening too much.

Jari

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 30 Jul 2010 15:29:39 +0200

On 30 jul 2010, at 14.54, Jari Arkko wrote:

> Participation. As you can tell from above, I do not feel capable (or even obliged) of attending all these meetings.

I just hope everyone understand you and other busy people are indeed busy, and need a break now and then. And that non-participation does not imply non-interest or anything even remotely in that direction. It is most certainly the other way around.

If you dislike something, then I am 100% you WILL show up and say so ;-)

   Patrik

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 30 Jul 2010 10:45:57 -0400

I think it may be important to better emphasis the difference between 
formal  BoFs and informal promotional meetings.
While Formal BoFs are not absolutely necessary for process purposes, 
they are usually a good idea to help the IAB and IESG judge interest.
Process-wise, these informal barBoFs have no meaning.
Also, while we have procedures for trying to ensure IAB members and 
relevant ADs attend BoFs, our leadership is NOT "expected" or required 
to attend these informal sessions.  (I would almost suggest banning them 
from attending, except that once in a while they attend because the 
topic is interesting to them personally interested in the topic.)  One 
person's note mentioned that som barBoFs complained because the relevant 
AD did not attend.  I would almost declare an extra meeting delay in 
formation for any group that made such a complaint.  We place plenty of 
demands on our leadership.  This should not be one of them.

Yours,
Joel

Patrik Fältström wrote:
> ------------------------------------------------------------------------
>

---

From: Yoav Nir <[email-masked]>
Date: Fri, 30 Jul 2010 20:14:36 +0300

I think there are really two issues here.

First is people who have an idea they want to present, but that idea either doesn't fit the charter of any particular working group (or they don't know about such a working group), or else said working group's schedule is too full with existing work. The only way they can do this, is to "schedule" some bar bof, and hope the right people come and listen. For these people, the larger the audience, the better.

The other kind is people with just a topic they think something should be done about. In that case, they really want to find a small group of people who may be passionate about the topic, and think of ideas about what the IETF can do here.

The second group are the candidates for the classic bar BoF, whether it is held in an actual bar, in the hallways of the meeting venue, or in a meeting room but the classroom-style arrangement of the chairs there is not so great. I think the best way to schedule one of those is to send a message to the attendee list (or the IETF list) saying "I'd like to get together to talk about this-or-that. Anybody who's interested, please email me off-line". Requiring an email sets the bar for participation just high enough that the people who just want to read their email won't come. Then this organizer can see how many people are interested, and find the appropriate venue based on that, informing them by private email.

What we really should be thinking about, is what to do with the first group. They are likely to have a presentation, so they need a meeting room, and they do want a large audience (so maybe someone there says, "I think we can do this at so-and-so WG".  One idea may be to allocate a fair-sized room for this purpose (something like Berlin in the MECC) and allocate the time there in 30-minute chunks, of which no more than half is the presentation, and the rest is time for questions. The list of topics would not be moderated, unless there are so many of them, that they won't fit, and the list, including a timetable can be published, with slots taken on a first-come-first-served basis. This way, the presenter can avoid having conflicts between their presentation and some session where all the people they want are attending.

Just a thought. There are probably other ways to do this.

---

From: Melinda Shore <[email-masked]>
Date: Fri, 30 Jul 2010 09:32:55 -0800

Yoav Nir wrote:
> First is people who have an idea they want to present, 
 > but that idea either doesn't fit the charter of any
 > particular working group (or they don't know about such a
 > working group), or else said working group's schedule
 > is too full with existing work.

The way that's traditionally done is with an internet draft.
The implication that there needs to be a session, with a room
and slides and humans sitting in chairs, kind of suggests that
people who want to participate in the IETF have to attend
meetings.  I can see that being the case for administrative
and organizational efforts like nomcom but question whether
that should be true for technical work.

Melinda

---

From: Yoav Nir <[email-masked]>
Date: Fri, 30 Jul 2010 22:07:15 +0300

> The way that's traditionally done is with an internet draft.

True.

> that should be true for technical work.

There doesn't need to be, but that is one way to do things. There are hundreds of drafts posted every week. We all ignore most of them. A short presentation might get enough people interested to start a discussion on some mailing list.

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 31 Jul 2010 08:52:57 +0200

>The way that's traditionally done is with an internet draft.

Bingo. The number of scheduled-but-ad-hoc BoFs that had fleshed-out ideas but no drafts was distressing. One of the big lessons learned from the current situation: people have forgotten that writing initial drafts is both easy and non-committal. If you're worried about writing a draft that turns out to be a bad idea, just write something humorous and self-deprecating about that in the abstract.

>meetings.

"participate" is too strong a word. Scheduled-but-ad-hoc BoFs now have the same unfortunate properties of many WGs, namely that 80+% of the people there are only there to listen, not help. A true bar BoF eliminates most of them due to the intimacy.

--Paul Hoffman, Director
--VPN Consortium

---

From: "Peter Saint-Andre" <[email-masked]>
Date: Sat, 31 Jul 2010 05:00:08 -0600 (MDT)

> "participate" is too strong a word. Scheduled-but-ad-hoc BoFs now have the
> same unfortunate properties of many WGs, namely that 80+% of the people
> there are only there to listen, not help.

Double bingo. The number of WG sessions (which are ostensibly scheduled
for the purpose of "working") in which folks have not read the drafts or
otherwise prepared themselves to actively contribute is also distressingly
high. Perhaps we all simply have too much work to do, or perhaps many
drafts are written in such a way that folks can't easily grok the problem
and its proposed solution. Regarding the latter, one of the WGs I advise
held a small "tutorial" session in a side room on Friday morning and that
turned out to be quite useful because it forced some of the key
contributors (in this case the chairs) to clearly explain the core
concepts behind the protocol under development within the WG, and I think
that effort will pay off in the form of a much clearer and more readable
specification.

Peter

---

From: Yoav Nir <[email-masked]>
Date: Sun, 1 Aug 2010 09:00:44 +0300

On Jul 31, 2010, at 2:00 PM, Peter Saint-Andre wrote:

> high. 

Who's "folks"? A lot of people come to an IETF meeting, and are only following one or two of the working groups. That does not mean that they sit in their hotel rooms for the rest of the meeting. Instead, they pick what looks like interesting meetings, and go there, with the hope of catching something interesting. 

So yes, they do make it seem like the "working group" is not interested, but lots of times, they're not even on the mailing list, So it's hard to tell which of the people in the room are actually "the working group", and I don't think we have a good definition of who belongs or doesn't belong to "the working group".

---

From: Melinda Shore <[email-masked]>
Date: Sat, 31 Jul 2010 22:45:08 -0800

Yoav Nir wrote:
> Who's "folks"? A lot of people come to an IETF meeting, and are 
 > only following one or two of the working groups. That does not mean
 > that they sit in their hotel rooms for the rest of the meeting.
 > Instead, they pick what looks like interesting meetings, and go
 > there, with the hope of catching something interesting.

That's a really good point, actually.  I've also made a
point in the past of attending at least one session
completely unrelated to what I'm working on, in hopes of
learning something or getting new ideas or new associations
or something.  But still, it seems to me that there are
two somewhat but not quite orthogonal questions here: 1)
whether or not the increasing formalization of the bar
BOF reflects an increased expectation of attendance in
order to participate/advance work in the IETF, and 2) what
a working group meeting is.

Melinda