Subject: tools location

From: Iljitsch van Beijnum <[email-masked]>
Date: Sun, 25 Jul 2010 14:19:28 +0200

Why?

---

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 25 Jul 2010 20:34:43 +0800

> Why?

This is the venue map page: http://tools.ietf.org/rooms ?

The reason is so that it can display where you are on the map.

Critically, this is a failure on the part of the page.  As with any such page, it should make a clear case for why you should hit "allow".

--Martin

p.s. UI design doesn't seem to be a strong point here - modal notifications are an annoyance.  Firefox 4.0 gets it almost right, but the dialog appearance and usability suck.

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Sun, 25 Jul 2010 14:38:41 +0200

> The reason is so that it can display where you are on the map.

Right. I had opened this page in a background tab so I didn't make the connection.

Safari on the Mac doesn't seem to be able to find its location at all, though. And as there's no GPS reception indoors (certainly not without any windows) I doubt _any_ system could provide a location that is accurate enough to be usable here.

> p.s. UI design doesn't seem to be a strong point here - modal notifications are an annoyance.  Firefox 4.0 gets it almost right, but the dialog appearance and usability suck.

A popup is ok if it's a reaction to a user action, not so much immediately upon loading the page. As long as we're providing constructive criticism: on the little program booklet the maps are tiny but still mostly readable, but on the web page the text is too small to be deciphered.

---

From: DM Abreu <[email-masked]>
Date: Sun, 25 Jul 2010 08:45:11 -0400

It did come up on my mobile and ask me to use my location

But I did not see a map of where I was ; only of the floor plans of meeting room etc 

Sent from my mobile

On Jul 25, 2010, at 8:38 AM, Iljitsch van Beijnum <[email-masked]> wrote:

> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Lars Eggert <[email-masked]>
Date: Sun, 25 Jul 2010 14:45:30 +0200

> Why?

You've made it onto the IAB watch list. They like to geo-track the troublemakers.

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 25 Jul 2010 14:58:18 +0200

> But I did not see a map of where I was ; only of the floor plans of meeting room etc 

The functionality may be broken.  It was introduced and tested a few years ago,
but haven't been verified lately at all.  I'm taking this out for now, till we
can both verify functionality and consider the other points made earlier in this
thread.

Thanks for the feedback!

Best,

	Henrik

---

From: Scott Brim <[email-masked]>
Date: Sun, 25 Jul 2010 15:29:22 +0200

> The reason is so that it can display where you are on the map.

Are we resurrecting that marvelous app that shows where you are based on 
wifi?

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Sun, 25 Jul 2010 15:37:23 +0200

On 25 jul 2010, at 15:29, Scott Brim wrote:

> Are we resurrecting that marvelous app that shows where you are based on wifi?

Yes. The Google streetview + wifi snooping truck should make its round through the MECC shortly, please don't stand in its way.

---

From: Joel Jaeggli <[email-masked]>
Date: Sun, 25 Jul 2010 15:44:34 +0200

Geoip says you're in fremont ca, how's that for anonymity?

Joel's iPad

---

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 25 Jul 2010 22:02:37 +0800

> Safari on the Mac doesn't seem to be able to find its location at all,
> though. And as there's no GPS reception indoors (certainly not without
> any windows) I doubt _any_ system could provide a location that is
> accurate enough to be usable here.

The system is actually there based on an old GEOPRIV experiment that did exactly this.  We identified where you were based on the AP.  If you had HELD enabled in your browser, it would work (Firefox 4.0 includes a HELD client that you can enable in about:config).

(The lesson, don't assume that GPS == location.)
 
> A popup is ok if it's a reaction to a user action, not so much
> immediately upon loading the page.

Precisely.  Asking first, and tying the action to a button click would be safest for this sort of application.

One problem with location-enabled web is that we haven't yet established user expectations.  And browsers have inconsistent UI, which compounds the problem.

--Martin