Subject: Re: Nomcom 2010-2011: Results of Random Selection

From: "Jiankang YAO" <[email-masked]>
Date: Fri, 16 Jul 2010 10:48:24 +0800

is it possible to record this process?

we will only know the result after selection, but not know the acutal process.

Jiankang Yao
----- Original Message ----- 
From: "Thomas Walsh" <[email-masked]>
To: <[email-masked]>
Sent: Friday, July 16, 2010 5:59 AM
Subject: FW: Nomcom 2010-2011: Results of Random Selection 

> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of NomCom Chair
> Sent: Thursday, July 15, 2010 2:56 PM
> To: IETF Announcement list
> Subject: Nomcom 2010-2011: Results of Random Selection 
> 
> 
> Hi all,
> 
> The following is the list of 10 nomcom volunteers selected randomly from
> this list: https://datatracker.ietf.org/ann/nomcom/2395/
> 
> 87.  Huub van Helvoort, Huawei Technologies;
> 25.  Dorothy Gellert, InterDigital Communications;
> 14.  Gregory Cauchie, France Telecom  Orange;
> 46.  Suresh Krishnan, Ericsson;
> 79.  Pete St. Pierre, Oracle;
> 31.  Tony Hansen, AT&T Labs;
> 75.  Jan Seedorf, NEC Laboratories Europe;
> 91.  Rolf Winter, NEC Labs Europe;
> 47.  Dirk Kroeselberg, Nokia Siemens Networks;
> 23.  Mehmet Ersue, Nokia Siemens Networks;
> 
> This begins the one week community review of the selection - please let
> me know ASAP if you see any problems with the selections. The challenge
> period will close at 17:00 PDT (24:00 UTC) on Thursday, July 22, 2010.
> 
> I am in the process of contacting the individuals to confirm they are
> still able to serve on the Nomcom.
> 
> The details for the selection are listed below.
> 
> Seed Values:
> The seed values used in selecting the committee members are follows:
> 
> The National Lottery: Daily Play: Thursday, July 15, 2010 Results:
>  https://www.national-lottery.co.uk/player/p/results/dailyplay.ftl
>  (7 numbers from 1-27)
> Value: 01 08 09 14 17 20 23
> 
> US National debt ("Debt Held by the Public"), published by the
> Treasury department as of Wednesday, July 14, 2010
> (Published on July 15, 2010)
>  http://www.treasurydirect.gov/NP/BPDLogin?application=np 
>  Last 8 digits, ignore the commas and periods
> Value: 76998828
> 
> US National debt ("Intragovernmental Holdings"), published by the
> Treasury department as of Wednesday, July 14, 2010
> (Published on July 15, 2010)
>  http://www.treasurydirect.gov/NP/BPDLogin?application=np 
>  Last 8 digits, ignore the commas and periods
> Value: 79622755
> 
> Massachusetts Lottery Powerball Drawing: Wednesday, July 14, 2010 Results
> (11:20 PM EDT draw on July 14, 2010):
>  http://www.masslottery.com/games/lottery/powerball.html
>  (5 numbers from 1-59 and 1 Power Ball number from 1-39)
> Value: 20 21 23 38 42 6
> 
> 
> With the selection algorithm results are based on RFC 3797 as follows:
> $ ./selection.exe
> Type size of pool:
> (or 'exit' to exit) 101
> Type number of items to be selected:
> (or 'exit' to exit) 15
> Approximately 58.1 bits of entropy needed.
> 
> Type #1 randomness or 'end' followed by new line.
> Up to 16 integers or the word 'float' followed by up
> to 16 x.y format reals.
> 01 08 09 14 17 20 23
> 1 8 9 14 17 20 23
> Type #2 randomness or 'end' followed by new line.
> Up to 16 integers or the word 'float' followed by up
> to 16 x.y format reals.
> 76998828
> 76998828
> Type #3 randomness or 'end' followed by new line.
> Up to 16 integers or the word 'float' followed by up
> to 16 x.y format reals.
> 79622755
> 79622755
> Type #4 randomness or 'end' followed by new line.
> Up to 16 integers or the word 'float' followed by up
> to 16 x.y format reals.
> 20 21 23 38 42 6
> 6 20 21 23 38 42
> Type #5 randomness or 'end' followed by new line.
> Up to 16 integers or the word 'float' followed by up
> to 16 x.y format reals.
> end
> Key is:
> 1.8.9.14.17.20.23./76998828./79622755./6.20.21.23.38.42./
> index        hex value of MD5        div  selected
> 1  D092CC19DF2C1FEEB24AAC2AB125F55A  101  -> 87 <-
> 2  7FB953E77CA8324A610E79E913AD0190  100  -> 25 <-
> 3  2371D3F40C93DB58353C0293210E7761  99  -> 14 <-
> 4  388238514EE702E862D627B202DF05CD  98  -> 46 <-
> 5  007A2D4BB6183716D28D5B800676F115  97  -> 79 <-
> 6  B12DF65CFF27EB958643B7622E1CA75C  96  -> 31 <-
> 7  C307E04AB485B8ACDF1D6188F97780F5  95  -> 75 <-
> 8  C8B42FE23BD3FFE011DB7CC5275B71C1  94  -> 91 <-
> 9  545AEF5C89368BF992E93447B4381787  93  -> 47 <-
> 10  BB39831C989C6249ECF3E3D4890B3DA9  92  -> 23 <-
> 11  8F82F9BDFC95D405BD756BBB2B5F2BE2  91  -> 16 <-
> 12  1F3FCE8A3D82CF8FBB72AE1945249478  90  -> 60 <-
> 13  2A18B179BFC4D53F5ED295BC61D8F1B9  89  -> 92 <-
> 14  F4C656521040602854F0808A605D3145  88  -> 89 <-
> 15  AA8545B3E2728947D721670FD6440951  87  -> 19 <-
> 
> Done, type any character to exit.
> 
> Regards,
> Thomas Walsh
> [email-masked]
> [email-masked]
> 
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Marshall Eubanks <[email-masked]>
Date: Fri, 16 Jul 2010 15:56:32 -0400

Can't you repeat it yourself ? It is supposed to be a deterministic  
process (once the inputs are obtained).

RFC 2777

A method such that public information will enable any person to verify  
the randomness of the selection meets this criterion. This document  
gives an example of such a method.

Regards
Marshall

---

From: "WORLEY, Dale R (Dale)" <[email-masked]>
Date: Fri, 16 Jul 2010 16:49:38 -0400

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Marshall Eubanks [[email-masked]]

RFC 2777

Ah, yes, but if you re-read the announcement of the selection, it starts:

> From: [email-masked] [mailto:[email-masked] On Behalf Of NomCom Chair

You have to read well down into the message to be told that the process is based (somehow) on RFC 3797.  It's a typical problem around here -- messages that should be stand-alone announcements aren't written carefully, and the authors forget how much background knowledge they are assuming.  (Would this announcement be comprehensible to someone who was unaware of RFC 3797/2777?)  A better start would be:

> The following is the list of 10 nomcom volunteers selected randomly by the process of RFC 3797 from this list [URL].  The input data to the RFC 3797 algorithm is detailed below.

Dale