Subject: text versions of ID and RFCs

From: Yaakov Stein <[email-masked]>
Date: Thu, 11 Nov 2010 03:26:10 +0000

When retrieving IDs or RFC from the tools.ietf.org or datatracker.ietf.org the file has only LFs
rather than CR+LF.

Yes, it is easy enough to convert this for simple reading on Windows machines,
but it is inconvenient to have to do this every time.

Could it be possible to change the default here ?

Y(J)S

---

From: Tony Hansen <[email-masked]>
Date: Thu, 11 Nov 2010 00:05:02 -0500

Use ftp to retrieve them. Set ASCII mode. Your line ending problems 
will be solved.

     Tony

On 11/10/2010 10:26 PM, Yaakov Stein wrote:
>
> When retrieving IDs or RFC from the tools.ietf.org or 
> datatracker.ietf.org the file has only LFs
>
> rather than CR+LF.
>

---

From: Yaakov Stein <[email-masked]>
Date: Thu, 11 Nov 2010 08:33:07 +0000

Sure I can ftp. But usually I search for the draft I want using my browser,
and it would be clumsier to have to shift to ftp instead of clicking.

It is easier to retrieve them from any of the mirror sites
that download them via my browser in CR-LF format.
Only the official site gives me in "Unix" format.

It would be great to enable choosing the format desired by right-clicking.

Y(J)S

From: Tony Hansen [mailto:[email-masked]]
Sent: Thursday, November 11, 2010 07:05
To: Yaakov Stein
Cc: [email-masked]
Subject: Re: text versions of ID and RFCs

Use ftp to retrieve them. Set ASCII mode. Your line ending problems will be solved.

    Tony

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Thu, 11 Nov 2010 08:43:10 +0000

> It would be great to enable choosing the format desired by right-clicking.

Given the Secretariat announced they would start digitally signing I-Ds from 8th Nov and that RFC5485 states "In accordance with the NVT standard, the <CRLF> sequence MUST be used to denote the end of a line of text" [for text/XML formats], I suspect the problem you are facing may go away naturally?

Ben