Subject: Re: watersprings.org archive of expired Internet Drafts

From: "t.petch" <[email-masked]>
Date: Fri, 7 Oct 2011 11:36:01 +0200

I had been waiting a while for a quiet moment on the list to express my regret
at the passing of Watersprings - R.I.P.

Apart from I-D announcements that made to a WG list I track, then watersprings
was my primary source for all I-D, simply because the web site was so good,
probably as close to perfection as I will ever see.

No thousands of .gif to spend ages downloading, no Megabytes of XML that take
half an hour to process, no https that locks up the workstation more often than
not, no need for a user manual to explain how to do what; just a simple,
self-evident interface, as simple as it could be but no simpler (a paragon of
engineering design) taking me to exactly what I needed, almost every time (no
irtf, but I learnt to live with that).

watersprings, you are sorely missed.

Tom Petch

----- Original Message -----
From: "Dan Wing" <[email-masked]>
To: "'Tony Finch'" <[email-masked]>; <[email-masked]>
Sent: Friday, September 30, 2011 6:58 PM
Subject: RE: watersprings.org archive of expired Internet Drafts

> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf Of
> > Tony Finch
> > Sent: Friday, September 30, 2011 7:34 AM
> > To: [email-masked]
> > Subject: watersprings.org archive of expired Internet Drafts
> >
> > I have been using the watersprings.org archive of internet drafts
> > http://www.watersprings.org/pub/id/ to obtain copies of drafts that
> > are no longer available from http://www.ietf.org/internet-drafts/
> > However the domain watersprings.org has disappeared. Does anyone know
> > what
> > has happened to it and/or if it is likely to come back, or if there are
> > alternative archives elsewhere?
>
> http://tools.ietf.org/html/DRAFTNAME works very well, and has everything
> near as I can tell.  It also does partial matches on DRAFTNAME, so
> you can do http://tools.ietf.org/id/draft-*behave* to see everything
> with "behave" in the name.  The HTML-ized version shows the history,
> provides clickable diff's, shows if it turned into an RFC, clickable
> Errata, Obsoleted By:, and so on.
>
> -d
>
>
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Joel jaeggli <[email-masked]>
Date: Fri, 07 Oct 2011 14:59:51 -0700

> irtf, but I learnt to live with that).

the tools.ietf.org webpage weighs in at whole 46KB gifs included.

the draft I'm currently editing as rendered by it is 4KB.

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 8 Oct 2011 00:32:11 +0200

On 7 October 2011 11:36, t.petch wrote:

> No thousands of .gif to spend ages downloading, no Megabytes of XML
> that take half an hour to process, no https that locks up the
> workstation more often than not, no need for a user manual to
> explain how to do what; just a simple, self-evident interface, as
> simple as it could be but no simpler (a paragon of engineering
> design) taking me to exactly what I needed, almost every time (no

> watersprings, you are sorely missed.
[...]

>> http://tools.ietf.org/html/DRAFTNAME works very well

E.g. <http://tools.ietf.org/html/draft-lear-iana-timezone-database>

IMO it is brilliant:  It always lists all versions with relevant
links (including tracker and various diffs) in *simple* XHTML, no
thousands of GIFs, no https overhead, a minimal amount of CSS for
its minimalistic approach to show drafts as near to the TXT form
as possible (the colour-coded status gimmick is acceptable, e.g.,
it caused no visible trouble with a HTML 3.2 browser).

If that is still not yet minimalistic enough for you check out:
<URL:http://tools.ietf.org/id/draft-lear-iana-timezone-database>

That's plain text.  You can omit -nn.txt in DRAFTNAME for version
nn to get the latest plain text version.  Including IRTF drafts.

Sadly the IETF announce list still does not offer links for this
repo.  If somebody here has a simple "favlet" or "bookmarklet"
(= Javascript URL) to transform the announce list datatracker
locations into tools.ietf.org locations please share it.

@Joel:  There is only one rel="icon" PNG in the rfcmarkup HTML
for an I-D, size about 1KB.  Is your 46 KB observation about the
tools.ietf.org page with the search form?  If your browser can
handle OpenSearch description documents like most modern browsers
I could create an OSDD for you, with input DRAFTNAME as described
above and output = send corresponding HTTP GET to tools.ietf.org.

-Frank

---

From: Joel jaeggli <[email-masked]>
Date: Fri, 07 Oct 2011 15:56:17 -0700

On 10/7/11 15:32 , Frank Ellermann wrote:
> for an I-D, size about 1KB.

right my obervation about 4KB was the sum total retrived (by in this
case firefox) which I did not find painful.

>  Is your 46 KB observation about the
> tools.ietf.org page with the search form?

yes

I note I have zero complaints about the performance envelope of a 46KB
page icons and all.

> If your browser can

---

From: "t.petch" <[email-masked]>
Date: Sat, 8 Oct 2011 09:20:44 +0200

---- Original Message -----
From: "Frank Ellermann" <[email-masked]>
To: "t.petch" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Saturday, October 08, 2011 12:32 AM
> it caused no visible trouble with a HTML 3.2 browser).

Frank

Yeeeee sss  ..... If that is what I wanted; but I don't:-)

I want an I-D and I know fairly accurately what it is called although my
reference might be to an out-of-date version, or perhaps to a version that is
yet to be adopted by a WG with a consequent name change.

The brilliance of watersprings was I could go click, click, click and be there,
with a list of close relatives, all on one page, NOTHING TO TYPE.  The curse of
WIMPS is having to move between mouse and keyboard.  All keyboard is a pain, I
can never remember when to use Ctl-Alt-back arrow etc.  All mouse is a dream,
and watersprings gave me that.

With the current flavour of the IETF web site, I usually go via charters - WG -
I-D list and then find 103 I-Ds in an order I cannot divine, give up and accept
that I will have to type in
d r a f t - i e t f - w g etc etc. Another waste of my time along with gif
download, xml processing etc oh, did I mention all the javascripts that try to
out think me and get in the way?  mutter mutter

I loved watersprings.

Tom Petch
(on a wet Saturday morning)

---

From: Fred Baker <[email-masked]>
Date: Sat, 8 Oct 2011 07:47:46 -0400

To make my own mirror of such on my laptop, I
    rsync -avz rsync.tools.ietf.org::tools.id /Users/fred/all-drafts/id

I maintain an RFC mirror, a "current draft" mirror, and an "expired draft" mirror for my own use.

On Sep 30, 2011, at 10:34 AM, Tony Finch wrote:

> However the domain watersprings.org has disappeared. Does anyone know what
> Tony.
> -- 
> f.anthony.n.finch  <[email-masked]>  http://dotat.at/
> Bailey: Southwesterly 5 to 7, decreasing 4 at times in east. Rough or very
> rough. Showers. Moderate or good.

---

From: Julian Reschke <[email-masked]>
Date: Sat, 08 Oct 2011 15:07:49 +0200

On 2011-10-08 09:20, t.petch wrote:
> ...
> ...

If I'm looking for an internet draft where I only know parts of the name 
I usually use a search engine; that's what they are for.

> ...

What does XML have to do with all of this?

Best regards, Julian

---

From: Michael Richardson <[email-masked]>
Date: Sun, 09 Oct 2011 11:36:45 -0400

>>>>> "Fred" == Fred Baker <[email-masked]> writes:
    Fred> To make my own mirror of such on my laptop, I rsync -avz
    Fred> rsync.tools.ietf.org::tools.id /Users/fred/all-drafts/id

I further sort the IDs by author... and since I forget to unlink them, I
wind up with an archive.  I don't think consider_linking_rfc works anymore.

#!/usr/bin/perl

chdir('/corp/ietf');

if(@ARGV == 0) {
  system("/corp/ietf/newRFCs.sh");

  system("rsync -avz optimus.ietf.org::internet-drafts ftp.ietf.org/internet-drafts");
  system("cd html.charters; wget -r -l 1 -nv -np -nd -nc http://www.ietf.org/html.charters/");
} else {
  print "SKIPPING RSYNC (@ARGV) \n";
}

opendir(DRAFTS,"ftp.ietf.org/internet-drafts");
@drafts=readdir(DRAFTS);
closedir(DRAFTS);

sub consider_linking_rfc {
  local($dir, $draft) = @_;

  open(DRAFT, "$draft") || warn "can not open $draft: $!\n";
  #print "Searching $draft\n";

  my $line=0;
  while(<DRAFT>) {
  #while(<DRAFT>) {
    last if ($line > 9);
    #print "line: $line $_";
    chop;
    #    This Internet-Draft was published as a Proposed Standard, RFC 3664
    if(/This Internet\-Draft was published .*RFC (\d+)/) {
      $rfc=$1;
      print "rfc$rfc -> $dir/rfc$rfc.txt\n";
      link("ftp.ietf.org/rfc/rfc$rfc.txt", "$dir/rfc$rfc.txt");
      #unlink($draft);
      close(DRAFT);
      return;
    }
    $line++;
  }
  close(DRAFT);
}

foreach $draft (@drafts) {
    next if ($draft =~ /^\./);
    $draft =~ m,draft-([^-]*)-([^-]*)-(.*),;
    
    if($1 eq "ietf") {
	$dir = "id/$1/$2";
	$base= $3;
    } else {
	$dir = "id/$1";
	$base ="$2-$3";
    }

    next if (length($base) < 1);
    next if (-f "$dir/$base");
    
    print "$draft -> $dir/$base\n";
    system("mkdir -p $dir") unless (-d "$dir");
    link("ftp.ietf.org/internet-drafts/$draft","$dir/$base");
    &consider_linking_rfc($dir, "$dir/$base");
}

---

From: Warren Kumari <[email-masked]>
Date: Thu, 13 Oct 2011 17:47:26 -0400

> at the passing of Watersprings - R.I.P.

Well, you will probably be glad to hear that it is in the process of being resurrected.

It was down to save power after the tragic tsunami in Japan.

Noritoshi is updating scripts to run under Linux, so it is not fully up / up to date...

W

> Subject: [IETF] RE: watersprings.org archive of expired Internet Drafts
> 
>