Subject: RE: Gen-ART Telechat review of draft-ietf-vrrp-unified-mib-10

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 3 Oct 2011 19:09:46 +0100

Hi Ben,

Thanks for the review.

> Minor issues:
> 
> -- Section 7,  first paragraph: "During the review of this document, It
emerged
> that there are different possible interpretations of [RFC5798]. The Authors of
> that document and the VRRP working group were unable to reach consensus on
> which interpretation is correct."
> 
> That's rather unfortunate, since that RFC specifies the protocol this MIB is
_for_. I
> wish we could do better. From my limited knowledge here, I am agnostic as to
> whether the disagreement would make a substantive difference in the MIB. I put
> this in the "minor" section in hopes that it does not--but people more versed
in
> the protocol should think about this.

Yes, this is really unfortunate.

The WG (now closed) was unable to reach any firm conclusion. The authors of the
original spec were a bit vague and indecisive. 

We were left with no option other than for the authors of this document to:
- pick the interpretation they thought was most likely
- document the fact
- move on

My feeling is that the lack of decisiveness in the WG for an established
protocol (not widely deployed, but reasonably well implemented and deployed)
showed that this was not an important function in the protocol. In practice, it
did not matter which choice was made in the MIB module because no-one seemed to
care which choice was made in the protocol.

Thus, if VRRP was being advance on the protocol ladder, I would look for the
feature to be removed rather than for the issue to be resolved.

Cheers,
Adrian

---

From: Ben Campbell <[email-masked]>
Date: Mon, 3 Oct 2011 11:02:50 -0500

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document: draft-ietf-vrrp-unified-mib-10	
Reviewer: Ben Campbell	
Review Date: 2011-10-03
IESG Telechat date: 2011-10-06

Summary: This draft may be ready for publication as a draft standard. All of the substantive comments from my last call review have been addressed either in the draft or in email. I do have one new concern below, but I am agnostic on whether that should affect publication.

Major issues: None

Minor issues: 

-- Section 7,  first paragraph: "During the review of this document, It emerged that there are different possible interpretations of [RFC5798]. The Authors of that document and the VRRP working group were unable to reach consensus on which interpretation is correct." 

That's rather unfortunate, since that RFC specifies the protocol this MIB is _for_. I wish we could do better. From my limited knowledge here, I am agnostic as to whether the disagreement would make a substantive difference in the MIB. I put this in the "minor" section in hopes that it does not--but people more versed in the protocol should think about this.

Nits/editorial comments:

-- definition of "vrrpv3StatisticsRefreshRate"

s/milli-seconds/milliseconds

---

From: Ben Campbell <[email-masked]>
Date: Mon, 3 Oct 2011 13:18:38 -0500

Thanks, Adrian--that makes sense.

Ben.

On Oct 3, 2011, at 1:09 PM, Adrian Farrel wrote:

> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art