Subject: Re: Re: watersprings.org archive of expired Internet Drafts

From: "t.petch" <[email-masked]>
Date: Mon, 10 Oct 2011 11:23:38 +0200

---- Original Message -----
From: "Julian Reschke" <[email-masked]>
To: "t.petch" <[email-masked]>
Cc: "Frank Ellermann" <[email-masked]>; <ietf@
ietf.org>
Sent: Saturday, October 08, 2011 3:07 PM

>
> On 2011-10-08 09:20, t.petch wrote:
>
> If I'm looking for an internet draft where I only know parts of the name I
> usually use a search engine; that's what they are for.
> With the current flavour of the IETF web site, I usually go via charters -
WG -
> I-D list and then find 103 I-Ds in an order I cannot divine, give up and
accept
> that I will have to type in
> d r a f t - i e t f - w g etc etc. Another waste of my time along with gif
> download, xml processing etc oh, did I mention all the javascripts that try to
> out think me and get in the way?  mutter mutter
> ...
>
> What does XML have to do with all of this?

Julian

On a thread on this list some time ago, IANA reported progress in converting
their web site to XML and at the same time, apologised for how long it now takes
to access the Port Registry.  Having accessed it - a good chance to complete The
Times crossword! - I found an XML file in excess of 1Mbyte on my workstation.
Making a wild leap of imagination, I guessed that the time it took to access the
web page was due, at least in part, to these multi-megagbytes of XML, but I
could be wrong.

Tom Petch
> Best regards, Julian

---

From: Elwyn Davies <[email-masked]>
Date: Mon, 10 Oct 2011 15:17:05 +0100

Hi.

I don't know who was responsible for the Watersprings archive, but I 
think we should send whoever it was a vote of thanks for providing this 
(free) resource during all the years that the IETF was not able or 
willing to provide it.

So THANK YOU!  It was extremely useful.

But I am now quite happy with the IETF draft archive and I have a couple 
of customized Firefox search entries that minimize the amount of typing 
needed.

Regards,
Elwyn

On 10/10/2011 10:23, t.petch wrote:
> From: "Julian Reschke"<[email-masked]>
> To: "t.petch"<[email-masked]>
> Cc: "Frank Ellermann"<[email-masked]>;<ietf@
> ietf.org>
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

-- 
The Cambridge Oxfam Walk 2011 has happened. There will be another walk next year.  In the meantime please donate to Oxfam.
For more information, see http://www.oxfam.org.uk/get_involved/fundraise/walk/ and follow us on Twitter at http://twitter.com/CambOxfamWalk.

---

From: Julian Reschke <[email-masked]>
Date: Mon, 10 Oct 2011 17:35:01 +0200

> web page was due, at least in part, to these multi-megagbytes of XML, but I

Yes, that does load slow. The reason is not XML per se, but apparently 
the fact that the HTML table that get's generated client-side doesn't 
render until the transformation is finished.

And yes, if the server sends XML + XSL, this is what ends up on your 
machine. Otherwise it would have been HTML or TXT. That's by design.

Anyway, nothing of this applies to the tools.ietf.org thingy.

Best regards, Julian

---

From: Doug Barton <[email-masked]>
Date: Mon, 10 Oct 2011 11:46:55 -0700

> of customized Firefox search entries that minimize the amount of typing

https://addons.mozilla.org/en-US/firefox/addon/ietf-doc-fetch-73306/

You can type in an RFC number, or all/part of an I-D name.

-- 

	Nothin' ever doesn't change, but nothin' changes much.
			-- OK Go

	Breadth of IT experience, and depth of knowledge in the DNS.
	Yours for the right price.  :)  http://SupersetSolutions.com/

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 10 Oct 2011 15:25:35 -0400

Very nice, thanks!!!!!!

---

From: Elwyn Davies <[email-masked]>
Date: Mon, 10 Oct 2011 22:16:42 +0100

On 10/10/2011 20:25, Andrew G. Malis wrote:
> Very nice, thanks!!!!!!
>
> On Mon, Oct 10, 2011 at 2:46 PM, Doug Barton<[email-masked]>  wrote:
There are five more specific search/get plugins in an email I just sent 
to the tools discuss mailing list.
It should be in the archive real soon now:
https://www.ietf.org/mailman/listinfo/tools-discuss

/Elwyn

---

From: Jean-Michel Combes <[email-masked]>
Date: Tue, 11 Oct 2011 00:31:30 +0200

Not used to send replies on the IETF ML but clearly for this one: +1 :)

watersprings.org was a real great help for me! Thanks!!!

Best regards.

JMC.

2011/10/10 Elwyn Davies <[email-masked]>:
> Hi.
>
> I don't know who was responsible for the Watersprings archive, but I think
> we should send whoever it was a vote of thanks for providing this (free)
> resource during all the years that the IETF was not able or willing to
> provide it.
>
> But I am now quite happy with the IETF draft archive and I have a couple of
> customized Firefox search entries that minimize the amount of typing needed.
>
> Regards,
> Elwyn
>
> The Cambridge Oxfam Walk 2011 has happened. There will be another walk next
> year.  In the meantime please donate to Oxfam.
> For more information, see
> http://www.oxfam.org.uk/get_involved/fundraise/walk/ and follow us on
> Twitter at http://twitter.com/CambOxfamWalk.
>

---

From: Joel jaeggli <[email-masked]>
Date: Mon, 10 Oct 2011 23:39:42 -0700

> Times crossword! - I found an XML file in excess of 1Mbyte on my workstation.

It's in excess of a bit more than a megabyte.

Zorch:Desktop jjaeggli$ du -h service-names-port-numbers.xml
3.8M	(as rendered using the xsl) service-names-port-numbers.xml
3.0M	(bare) service-names-port-numbers.xml

> web page was due, at least in part, to these multi-megagbytes of XML, but I

when we make dogfood, we can be expected to eat it from time to time.

just maybe a flat file of structured data isn't the best way to render
9125 registerd ports and 4330 people for the web.

---

From: Joe Touch <[email-masked]>
Date: Wed, 12 Oct 2011 09:57:33 -0700

Updating the subject line to address a separate question that was raised:

FWIW, it's 1 MB of data in a 3.8 MB XML file.

I suspect that the delay is because it may be generated on-the-fly, but 
haven't been able to confirm that. It may just be network transfer delay.

Joe

...

---

From: Simon Perreault <[email-masked]>
Date: Wed, 12 Oct 2011 13:28:42 -0400

> haven't been able to confirm that. It may just be network transfer delay.

As Julian said, what's slow is the browser rendering the HTML. More
precisely, it's two things:
1. HTML parsing, especially in Safari
2. table layout rendering.

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Joe Touch <[email-masked]>
Date: Wed, 12 Oct 2011 10:44:51 -0700

> 2. table layout rendering.

Emperically:

opening the file from disk = 30 seconds

downloading the file from the net = 33 seconds

I.e., they're both part of the problem.

Joe

---

From: Simon Perreault <[email-masked]>
Date: Wed, 12 Oct 2011 13:58:33 -0400

> I.e., they're both part of the problem.

Turning on gzip transfer encoding in the web server config would reduce
download time by a factor of ~10.

Modulo compression, XML is about as large as any other plain text format.

Simon

---

From: Joe Touch <[email-masked]>
Date: Wed, 12 Oct 2011 11:07:25 -0700

> download time by a factor of ~10.

Thanks - I'll forward that suggestion.

If anyone has any suggestions on how to speedup the rendering part, 
please do let me know either on-list of off-list.

Joe

---

From: "John Levine" <[email-masked]>
Date: 13 Oct 2011 02:54:14 -0000

>please do let me know either on-list of off-list.

Break up the version that you get by normal web browsing into multiple
interlinked smaller pages, keep the big page available at a fixed
address for people who want to download it and parse it for other
purposes.

Parsing giant web pages is just slow, and not likely to get faster
since most sites break big pages up precisely to avoid the slow
rendering.

R's,
John

---

From: "t.petch" <[email-masked]>
Date: Thu, 13 Oct 2011 12:41:37 +0200

Joe

When I access it, I see a 3.08Mbyte .xml file in temporary storage.
Interestingly, the text variant is still 2.7Mbyte.

My access time is variable.  When I first used the xml file, the access time was
always in minutes, time to make a coffee, come back and continue waiting.  Now
it is variable.  On a good day, I get a page I can scroll in 35 second, other
times it is over 2 minutes.  I don't see any reason why and my network and PC
have not changed that I know of.  I am on Windows and Internet Explorer.

Interestingly, if I download a .pdf, I can track the download by looking at the
size in temporary storage; I can do the same with the .txt, but not with the
.xml, not sure what it means, perhaps that the processing is concurrent with the
download, and that only the end result gets written to disk.  The disk file is
.xml and not .htm(l).

Tom Petch

Tom Petch

---

From: Joel jaeggli <[email-masked]>
Date: Thu, 13 Oct 2011 12:28:03 -0700

> download, and that only the end result gets written to disk.  The disk file is

no mystery...

What's been downloaded is the data, what's being saved is what the
browser renders using the DTD.

you're downloading structured data totalling  some 15000 records and the
browser is rendering it in a conveniently human readable form.

---

From: Joe Touch <[email-masked]>
Date: Thu, 13 Oct 2011 12:32:49 -0700

Hi, all,

Again, thanks for the suggestions.

I'll work with IANA to see if we can make things a bit more useful.

Joe

On 10/13/2011 12:28 PM, Joel jaeggli wrote:
>> From: "Joe Touch"<[email-masked]>
>> To: "Simon Perreault"<[email-masked]>
>> Cc:<[email-masked]>