Subject: IPv6 support in hotel contract?

From: "George, Wes" <[email-masked]>
Date: Thu, 20 Oct 2011 09:01:09 -0400

My last message caused something else to occur to me - there has been a lot of discussion both here and at NANOG about hotels being woefully underprepared for the internet (and address) use that their guests generate when a conference full of geeks and their multiple devices per person descend upon them. Sometimes the IETF is successful at convincing the hotel to let them take over the internet service in the guest rooms, sometimes not.

Perhaps we can kill two birds with one stone by starting to require IPv6 service in the guest rooms when we enter into negotiations with hotels. If they don't have it, we'll be happy to temporarily take over the internet service, or assist them in getting it enabled permanently in their existing network, and if neither of those options are acceptable, it provides negotiating leverage on other things. This also has the net effect of starting to make it clear to hotel management that IPv6 is going to start being mandatory for some subset of their guests before too much longer.

I realize that having something in the contract doesn't mean that we're any more likely to get it. But the fact that it's in the contract makes a statement in and of itself. IAOC, any reason why this couldn't be added, especially given how far in advance you're negotiating with venues?

Thanks,

Wes George

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: TJ <[email-masked]>
Date: Thu, 20 Oct 2011 09:17:55 -0400

+1 ... Whether it works or not, it's atleast worth the effort!

/TJ
On Oct 20, 2011 8:07 AM, "George, Wes" <[email-masked]> wrote:

>  My last message caused something else to occur to me – there has been a
> lot of discussion both here and at NANOG about hotels being woefully
> underprepared for the internet (and address) use that their guests generate
> when a conference full of geeks and their multiple devices per person
> descend upon them. Sometimes the IETF is successful at convincing the hotel
> to let them take over the internet service in the guest rooms, sometimes
> not.****
>
> ** **
>
> Perhaps we can kill two birds with one stone by starting to require IPv6
> service in the guest rooms when we enter into negotiations with hotels. If
> they don’t have it, we’ll be happy to temporarily take over the internet
> service, or assist them in getting it enabled permanently in their existing
> network, and if neither of those options are acceptable, it provides
> negotiating leverage on other things. This also has the net effect of
> starting to make it clear to hotel management that IPv6 is going to start
> being mandatory for some subset of their guests before too much longer. **
> **
>
> ** **
>
> I realize that having something in the contract doesn’t mean that we’re any
> more likely to get it. But the fact that it’s in the contract makes a
> statement in and of itself. IAOC, any reason why this couldn’t be added,
> especially given how far in advance you’re negotiating with venues?****
>
> ** **
>
> Thanks,****
>
> ** **
>
> Wes George****
>
> ** **
>
> ------------------------------
> This E-mail and any of its attachments may contain Time Warner Cable
> proprietary information, which is privileged, confidential, or subject to
> copyright belonging to Time Warner Cable. This E-mail is intended solely for
> the use of the individual or entity to which it is addressed. If you are not
> the intended recipient of this E-mail, you are hereby notified that any
> dissemination, distribution, copying, or action taken in relation to the
> contents of and attachments to this E-mail is strictly prohibited and may be
> unlawful. If you have received this E-mail in error, please notify the
> sender immediately and permanently delete the original and any copy of this
> E-mail and any printout.
>
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>
>

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Thu, 20 Oct 2011 11:50:44 -0400

> From: George, Wes [[email-masked]]
> 
> Perhaps we can kill two birds with one stone by starting to require
> IPv6 service in the guest rooms when we enter into negotiations with
> hotels.

At least, we should start *trying* to get IPv6 service from hotels.
We may have a very hard time getting it, but the fact that customers
are starting to *ask* for it will help make hotels aware of IPv6.

Dale

---

From: Joel jaeggli <[email-masked]>
Date: Thu, 20 Oct 2011 10:54:33 -0700

> are starting to *ask* for it will help make hotels aware of IPv6.

I see no pointing in asking for something that a hotel agent is going to
not be able to respond to.

if you want a brown M & M's crontract you're going to actually have to
work with an agent that can grok and then meet your requirements.

---

From: "George, Wes" <[email-masked]>
Date: Thu, 20 Oct 2011 14:22:00 -0400

> From: Joel jaeggli [mailto:[email-masked]]

> work with an agent that can grok and then meet your requirements.

[WEG]] Joel, I think this is a spurious line of logic. We already have plenty of "brown M&Ms" requirements. We bring in our own internet access (sometimes by running new fiber into the building). We ask for the ability to take over the hotel's guest room wireless network or at least the uplink. If we get told no, we try (I hope) to ask about their abilities to cope with an extremely high amount of simultaneous internet usage, we ask lots of questions about the technical logistics of putting on a conference of this size, including using their power and cabling to provide wireless in common areas, interacting with their PA system, using their equipment, etc, and the "hotel agent" either answers them directly or finds someone who can.
We don't generally work with "Roscoe's Motor Lodge" whose internet service is a single residential AP managed by "my brother Darrel." These are international hotel chains, usually with contracts to national/international corporations to professionally manage their guest internet services. If we ask, the response is likely to be "well, no one's ever asked for that before..." but that should be followed with "...but we'll find out..."

Wes George

---

From: David Morris <[email-masked]>
Date: Thu, 20 Oct 2011 11:59:49 -0700 (PDT)

On Thu, 20 Oct 2011, George, Wes wrote:

> > I see no pointing in asking for something that a hotel agent is going
> > to not be able to respond to.
> >
> [WEG]] Joel, I think this is a spurious line of logic. We already have 
> plenty of "brown M&Ms" requirements. We bring in our own internet access 
...
> professionally manage their guest internet services. If we ask, the 
> response is likely to be "well, no one's ever asked for that before..." 
> but that should be followed with "...but we'll find out..."

+1 ... and asking will raise awareness of the issue.

Of course, as has been mentioned many times in other threads, we
negotiate meeting venues a long time in advance. There may even
be an IT support plan to add IPV6 before we arrive..

---

From: Alejandro Acosta <[email-masked]>
Date: Thu, 20 Oct 2011 17:25:31 -0430

> +1 ... and asking will raise awareness of the issue.

+1  we always should try

---

From: Robinson Tryon <[email-masked]>
Date: Thu, 20 Oct 2011 18:35:27 -0400

> be an IT support plan to add IPV6 before we arrive..

I think that it's great if they say they have a plan to add IPv6
support, but plans (especially about IPv6) seem to have a weird habit
of being delayed. It seems prudent to put it in the signed contract so
that there are no surprises from either the hotel/venue side or from
the conference organizers' side.

--R

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 20 Oct 2011 22:57:58 -0600

We just failed to manager to find a venue in Asia because there was no venue that meant all the constraints. I'd rather not add more constraints to the hotel selection. I love the taste of dog food, but v6 in the hotel is not something that I find critical to accomplish the task I come to IETF to get done. 

On Oct 20, 2011, at 7:01 AM, George, Wes wrote:

> My last message caused something else to occur to me – there has been a lot of discussion both here and at NANOG about hotels being woefully underprepared for the internet (and address) use that their guests generate when a conference full of geeks and their multiple devices per person descend upon them. Sometimes the IETF is successful at convincing the hotel to let them take over the internet service in the guest rooms, sometimes not.
>  
> Perhaps we can kill two birds with one stone by starting to require IPv6 service in the guest rooms when we enter into negotiations with hotels. If they don’t have it, we’ll be happy to temporarily take over the internet service, or assist them in getting it enabled permanently in their existing network, and if neither of those options are acceptable, it provides negotiating leverage on other things. This also has the net effect of starting to make it clear to hotel management that IPv6 is going to start being mandatory for some subset of their guests before too much longer.
>  
> I realize that having something in the contract doesn’t mean that we’re any more likely to get it. But the fact that it’s in the contract makes a statement in and of itself. IAOC, any reason why this couldn’t be added, especially given how far in advance you’re negotiating with venues?
>  
> Thanks,
>  
> Wes George
>  
>

---

From: Andrew Allen <[email-masked]>
Date: Fri, 21 Oct 2011 12:26:33 +0000

+1

We can put all kinds of wonderful constraints on hotels if we want to - make sure they are enviromental friendly, non discriminatory in their hiring practices, donate to save whales and all kinds of other worthy causes and do things such as transitioning to IPv6 plus be really cheap and be in interesting and cheap to get to locations - then we will likely never be able to meet anywhere.

IF IPv6 really requires IETF to use its business to influence hotels to adopt it then its a technolgy that deserves to go the way of the DoDo. IPv6 will be adopted because it is needed and brings commerical benefits to those that deploy it.

----- Original Message -----
From: Cullen Jennings [mailto:[email-masked]]
Sent: Thursday, October 20, 2011 11:57 PM
To: George, Wes <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: IPv6 support in hotel contract?

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: "George, Wes" <[email-masked]>
Date: Fri, 21 Oct 2011 09:06:59 -0400

> From: Andrew Allen [mailto:[email-masked]]
> We can put all kinds of wonderful constraints on hotels if we want to -
> [snip] - then we will likely never be able to meet anywhere.
>
[WEG] I am not suggesting that this be a deal-breaker constraint. We have quite a number of "nice to have" items that we will ask for, but not necessarily take our business elsewhere if we do not get. The sense I get from IAOC is that dates, capacity, and cost are the constraints. IPv6 support is window dressing (or deck chairs, depending on your perspective).

> IF IPv6 really requires IETF to use its business to influence hotels to
> adopt it then its a technolgy that deserves to go the way of the DoDo.
> IPv6 will be adopted because it is needed and brings commerical
> benefits to those that deploy it.

[WEG] This is not an attempt to force *whether* IPv6 will be deployed, but when. Hotels are sort of an extension of the consumer space - right now, they don't know/care what IPv6 is, nor see a reason why it's necessary. It is quite unlikely that your average person will walk to the counter and say, "your internet service is partially broken because it doesn't support IPv6." It is even less likely that this will happen enough times that they say, "gosh, perhaps we need to look into this eye pee vee six thing..." IETF has some leverage, and by definition should be on the early adopter curve, so I'm simply suggesting that they use it to accelerate the timeline a bit.

> I love the taste of dog food, but v6 in the hotel is not something that I find critical to accomplish the
> task I come to IETF to get done.

[WEG] We're working contracts for hotel venues 3+ years out at this point. How long are you willing to assume that IPv6 will not be critical to tasks that you need to do at IETF and that the IPv4 service in the hotel will be an acceptable alternative?

Wes George

---

From: Andrew Allen <[email-masked]>
Date: Fri, 21 Oct 2011 13:47:04 +0000

George

I think its fine to sell them on the advantages of transitioning but some others were advocating to have it in the contract.

Any additional costs you place on the hotel will inevitably be reclaimed (with interest) in the room charges, cost of breaks, etc - there is no such thing as a free lunch!

----- Original Message -----
From: George, Wes [mailto:[email-masked]]
Sent: Friday, October 21, 2011 08:06 AM
To: Andrew Allen; [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: RE: IPv6 support in hotel contract?

Wes George

---

From: Cameron Byrne <[email-masked]>
Date: Fri, 21 Oct 2011 07:01:23 -0700

On Oct 21, 2011 6:07 AM, "George, Wes" <[email-masked]> wrote:
> [WEG] I am not suggesting that this be a deal-breaker constraint. We have
quite a number of "nice to have" items that we will ask for, but not
necessarily take our business elsewhere if we do not get. The sense I get
from IAOC is that dates, capacity, and cost are the constraints. IPv6
support is window dressing (or deck chairs, depending on your perspective).

There is no harm in putting it in as a "nice to have", and this is the type
of thing makes a good tie-breaker and puts ipv6 on the radar.

If the ietf cannot even make this simple request (not even a requirement),
we are in a sad sad state.

Cb

> [WEG] This is not an attempt to force *whether* IPv6 will be deployed, but
when. Hotels are sort of an extension of the consumer space - right now,
they don't know/care what IPv6 is, nor see a reason why it's necessary. It
is quite unlikely that your average person will walk to the counter and say,
"your internet service is partially broken because it doesn't support IPv6."
It is even less likely that this will happen enough times that they say,
"gosh, perhaps we need to look into this eye pee vee six thing..." IETF has
some leverage, and by definition should be on the early adopter curve, so
I'm simply suggesting that they use it to accelerate the timeline a bit.
> [WEG] We're working contracts for hotel venues 3+ years out at this point.
How long are you willing to assume that IPv6 will not be critical to tasks
that you need to do at IETF and that the IPv4 service in the hotel will be
an acceptable alternative?

---

From: Ross Callon <[email-masked]>
Date: Fri, 21 Oct 2011 14:46:56 -0400

I agree with Cullen (except that I don't love the taste of dog food). Asking for IPv6 might be a good idea, but the full group of IETF participants as a group aren't the right people to negotiate hotel contracts, and finding a hotel that is reasonably priced and has the capacity to host an IETF appears to be hard enough as it is. 

Ross