Subject: meeting slots

From: Mark Andrews <[email-masked]>
Date: Wed, 12 Oct 2011 13:41:19 +1100

In deciding whether to attend a IETF meeting or not it would
	be useful to know if chairs have requested a meeting slot
	or have decided not to meet or are still undecided.

	This information is known well before a actual agenda is
	drawn up.  Why is it, effectively, hidden until the agenda
	is published?

	Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE:	+61 2 9871 4742		         INTERNET: [email-masked]

---

From: Margaret Wasserman <[email-masked]>
Date: Wed, 12 Oct 2011 08:54:25 -0400

+1

It would also be good to expose the conflict lists that the chairs have provided ahead of time, so that WG participants can point out (hopefully to the chairs) potential conflicts that the chairs may have omitted. 

Margaret

On Oct 11, 2011, at 10:41 PM, Mark Andrews wrote:

> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Dave CROCKER <[email-masked]>
Date: Wed, 12 Oct 2011 10:06:16 -0700

> It would also be good to expose the conflict lists that the chairs have provided ahead of time, so that WG participants can point out (hopefully to the chairs) potential conflicts that the chairs m…

While this sounds intuitively very appealing, it seems likely to set an 
expectation that the folks trying to schedule meeting times will juggle the 
conflicts of all attendees.  That doesn't sound like something that can scale. 
(My impression is that the current scale of the task is at a limit.)

Even if it could, it dramatically increases the number of conflicts and, 
therefore, the number of conflicts that cannot be resolved well.  So, while 
reasonable and well-intentioned, this seems likely to greatly increase staff 
workload and greatly increase community unhappiness.  All in all, not an 
appealing outcome.

In contrast, publishing the requests for slots seems an easy and scalable task. 
  Since requests are usually satisfied -- that is, those asking for a meeting 
slot usually get them -- it helps attendee "macro" planning, without getting 
into the finer-grained day-of-week and time-of-day debates.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Margaret Wasserman <[email-masked]>
Date: Wed, 12 Oct 2011 13:27:22 -0400

I was not picturing everyone adding their own conflicts.  However, I thought this might help us avoid some of the issues we've had in the past, where obvious group-level conflicts are omitted, and meetings have to be rescheduled at the last moments.  

Margaret

On Oct 12, 2011, at 1:06 PM, Dave CROCKER wrote:

> While this sounds intuitively very appealing, it seems likely to set an expectation that the folks trying to schedule meeting times will juggle the conflicts of all attendees.  That doesn't sound like something that can scale. (My impression is that the current scale of the task is at a limit.)
> 
> Even if it could, it dramatically increases the number of conflicts and, therefore, the number of conflicts that cannot be resolved well.  So, while reasonable and well-intentioned, this seems likely to greatly increase staff workload and greatly increase community unhappiness.  All in all, not an appealing outcome.
> 
> In contrast, publishing the requests for slots seems an easy and scalable task.  Since requests are usually satisfied -- that is, those asking for a meeting slot usually get them -- it helps attendee "macro" planning, without getting into the finer-grained day-of-week and time-of-day debates.
> 
> d/
> 
> 
> -- 
> 
>  Dave Crocker

---

From: Dave CROCKER <[email-masked]>
Date: Wed, 12 Oct 2011 11:11:15 -0700

> I was not picturing everyone adding their own conflicts.  However, I thought this might help us avoid some of the issues we've had in the past, where obvious group-level conflicts are omitted, and…

I'll suggest a more distributed model:

Chairs circulate among their wg, the conflicts they believe should be avoided. 
When that discussion settles down, the chairs submit their set to ietf staff. 
IETF staff and ietf main list are thereby spared the effort, but each set gets 
review beyond the chairs.

d/
-- 

   Dave Crocker

---

From: Michael Richardson <[email-masked]>
Date: Wed, 12 Oct 2011 20:54:58 -0400

>>>>> "Dave" == Dave CROCKER <[email-masked]> writes:
    >> It would also be good to expose the conflict lists that the
    >> chairs have provided ahead of time, so that WG participants can
    >> point out (hopefully to the chairs) potential conflicts that the
    >> chairs may have omitted.

    Dave> While this sounds intuitively very appealing, it seems likely
    Dave> to set an expectation that the folks trying to schedule
    Dave> meeting times will juggle the conflicts of all attendees.
    Dave> That doesn't sound like something that can scale. (My
    Dave> impression is that the current scale of the task is at a
    Dave> limit.)

If it reduces the demand for meeting slots, because a chair realizes
that nobody is coming to their WG, due to a conflict, then that's good
news.

We have too many slots.

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: John C Klensin <[email-masked]>
Date: Wed, 12 Oct 2011 21:53:07 -0400

--On Wednesday, October 12, 2011 11:11 -0700 Dave CROCKER
<[email-masked]> wrote:

>> I was not picturing everyone adding their own conflicts.
>> However, I thought this might help us avoid some of the
>> issues we've had in the past, where obvious group-level
>> conflicts are omitted, and meetings have to be rescheduled at
>> the last moments.
> 
> Chairs circulate among their wg, the conflicts they believe
> should be avoided. When that discussion settles down, the
> chairs submit their set to ietf staff. IETF staff and ietf
> main list are thereby spared the effort, but each set gets

Of course, some WGs / Chairs have been doing this, or variations
on it. for some years now.   I'd venture that it works better in
some WGs than others... much like many other things.

   john

---

From: Robert Sparks <[email-masked]>
Date: Thu, 13 Oct 2011 12:02:35 -0500

I understand Dave's concern, but I think it would be valuable to make it easy to see
what has been requested. Any changes to the conflict list would still have to come 
through the chairs, encouraging that distributed work model.

I've entered this as an idea that someone might pick up for work at a codesprint:
<http://trac.tools.ietf.org/tools/ietfdb/ticket/710>

RjS