Subject: DKIM delays

From: "t.petch" <[email-masked]>
Date: Fri, 21 Oct 2011 09:06:46 +0200

I notice that e-mail via this ietf list is being delayed with respect to mail to
a working group list at or around the time of DKIM processing.

Thus to the mpls list, the mail travels at the speed of light

Received: from ietfa.amsl.com (localhost [127.0.0.1]) by ietfa.amsl.com
 (Postfix) with ESMTP id 9417311E80A5; Wed, 19 Oct 2011 13:49:06 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1;
<snip>

whereas to the ietf list, it is delayed by the best part of a day.

Received: from ietfa.amsl.com (localhost [127.0.0.1]) by ietfa.amsl.com
 (Postfix) with ESMTP id 16B1B21F8C11; Thu, 20 Oct 2011 08:15:17 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ietf.org; s=ietf1;
<snip>

It does make following a thread challenging, getting the answers the day before
the question, when some use the WG list and others do not.  Is this another
benefit of DKIM:-)

Tom Petch

---

From: Hector <[email-masked]>
Date: Fri, 21 Oct 2011 04:37:25 -0400

You should compare this against using a different list member 
subscriber account.

When I use my [email-masked] account, it can take DAYS to get 
posted here.

Using my [email-masked], a hour or less.

PS: santronics.com mail is DKIM signed as well.

Go figure.

t.petch wrote:
> X-Original-To: [email-masked]
> Delivered-To: [email-masked]
> Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix)
>  with ESMTP id 5F60B11E8098; Wed, 19 Oct 2011 13:49:05 -0700 (PDT)
> 
> X-Original-To: [email-masked]
> Delivered-To: [email-masked]
> Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix)
>  with ESMTP id 5F60B11E8098; Wed, 19 Oct 2011 13:49:05 -0700 (PDT)
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
> 
>

---

From: Alessandro Vesely <[email-masked]>
Date: Mon, 24 Oct 2011 19:03:28 +0200

>  with ESMTP id 5F60B11E8098; Wed, 19 Oct 2011 13:49:05 -0700 (PDT)

I can see the latter snippet features a very long delay.  However,
you snipped those signatures one field too soon.  From the header
of the message you wrote I get

This is only a few seconds delay, but applying epoch logic, i.e.,
0x4ea129e8 = 1319184872 = 2011-10-21T01:14:32+07:00, I can see DKIM
contribution.  IIRC, opendkim gets the time(&now) for that timestamp
at end-of-header, before beginning to compute the body hash.

hth

---

From: Russ Housley <[email-masked]>
Date: Mon, 24 Oct 2011 21:59:13 -0400

Alessandro:

> Received: from ietfa.amsl.com (localhost [127.0.0.1])
> 	by ietfa.amsl.com (Postfix) with ESMTP id 33A1F21F8AFD;
> 	Fri, 21 Oct 2011 01:14:32 -0700 (PDT)
> 	t=1319184872; <snip>
> Received: from localhost (localhost [127.0.0.1])
> 	by ietfa.amsl.com (Postfix) with ESMTP id 9FCD921F85B5
> 	for <[email-masked]>; Fri, 21 Oct 2011 01:14:28 -0700 (PDT)
> 

The long delays are not due to DKIM.  These happen when a message to a mail list gets held for moderation.

Russ

---

From: "t.petch" <[email-masked]>
Date: Tue, 25 Oct 2011 09:38:21 +0200

----- Original Message -----
From: "Russ Housley" <[email-masked]>
To: "Alessandro Vesely" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, October 25, 2011 3:59 AM
Subject: Re: DKIM delays

Russ

I did consider that, but had got the impression in the past that moderation on
the main IETF list was much lighter than that on a WG list, so that those
responding to a Last Call who were subscribed to the WG but not to the main IETF
list would not have their delayed substantially if at all.

Tom Petch