Subject: From Pandoc To RFC

From: Olaf Kolkman <[email-masked]>
Date: Sat, 29 Oct 2011 12:58:10 +0200

Folk,

My friend Miek Gieben just demonstrated the use of Pandoc that in combination with Make and XSLT scripting to can produce internet-drafts in XML format from plain text input.

The plain text only needs a few formatting conventions, more or less like wiki markup.

See: http://www.miek.nl/blog/archives/2011/09/28/pandoc_to_rfc/index.html

--Olaf 

________________________________________________________ 

Olaf M. Kolkman                        NLnet Labs
http://www.nlnetlabs.nl/

(I am posting this as an individual, specifically not with an RFC Editor hat).

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 29 Oct 2011 14:13:06 +0200

On Oct 29, 2011, at 12:58, Olaf Kolkman wrote:

> Pandoc that in combination with Make and XSLT scripting to can produce internet-drafts in XML format

Nice!

There also is kramdown-rfc2629.
See the example at https://github.com/cabo/kramdown-rfc2629 (the stupid.mkd there is the source for an actual I-D).

The main feature that kramdown-rfc2629 seems to have beyond Miek's pandoc-based solution is support for (markdown extended syntax) tables.
I also did some automatics for fetching/caching RFC/I-D references from xml.resource.org.
I do like Miek's approach to properly using markdown's reference syntax -- I invented my own instead, but might want to add support for Miek's syntax as well.

Grüße, Carsten

---

From: Russ Housley <[email-masked]>
Date: Sat, 29 Oct 2011 14:51:57 -0400

I just think we need a volunteer to take over maintenance of the existing page.

Russ

On Oct 29, 2011, at 2:44 PM, John C Klensin wrote:

> Olaf,
> 
> It would be really nice to have a web page somewhere that listed
> these tools and provided links to them, regardless of whether
> they are supported or not.
> 
> The old Tools "RFC authoring" page,
> http://tools.ietf.org/inventory/author-tools, which used to do
> that job, now shows "This page is not being actively
> maintained." in red at the top.
> 
> I don't think that developing and keeping such a page needs to
> be a big deal and wonder whether you would be inclined to put on
> your ARSE hat and just make it happen as an RFC Editor activity.
> 
>     best,
>      john
> 
> 
> --On Saturday, October 29, 2011 12:58 +0200 Olaf Kolkman
> <[email-masked]> wrote:
> 
>> 
>> 
>> Folk,
>> 
>> My friend Miek Gieben just demonstrated the use of Pandoc that
>> in combination with Make and XSLT scripting to can produce
>> internet-drafts in XML format from plain text input.
>> 
>> See:
>> http://www.miek.nl/blog/archives/2011/09/28/pandoc_to_rfc/inde
>> x.html
> 
> 
> 
> 
> _______________________________________________
> rfc-interest mailing list
> [email-masked]
> https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Marshall Eubanks <[email-masked]>
Date: Sat, 29 Oct 2011 16:28:01 -0400

> I just think we need a volunteer to take over maintenance of the existing
I would be willing to do that. Presumably we could discuss it in Taipei.

Regards
Marshall

> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: John C Klensin <[email-masked]>
Date: Sat, 29 Oct 2011 20:23:01 -0400

> I just think we need a volunteer to take over maintenance of

That would be fine (and I noticed that Marshall volunteered, for
which I'm grateful), but part of my hope was that we could
institutionalize that page or something like it, e.g., make sure
that someone was responsible for being sure that there was a
volunteer.

    john

---

From: Michael Richardson <[email-masked]>
Date: Mon, 31 Oct 2011 09:18:51 -0400

>>>>> "Olaf" == Olaf Kolkman <[email-masked]> writes:
    Olaf> My friend Miek Gieben just demonstrated the use of Pandoc that
    Olaf> in combination with Make and XSLT scripting to can produce
    Olaf> internet-drafts in XML format from plain text input.

    Olaf> The plain text only needs a few formatting conventions, more
    Olaf> or less like wiki markup.

Could it turn existing RFCs into XML as well?

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 31 Oct 2011 15:06:12 +0100

It is mostly straightforward to obtain markdown format from an existing RFC or similar formatted text, and I have used this to manually compile input from various sources into one I-D.

Doing this in a fully automatic way would probably need some more heuristics, e.g., for cross-reference management.  We already have some of these heuristics in the programs we use to display RFCs in web pages.

Exercise left to the reader ;-)

Grüße, Carsten

---

From: Eric Burger <[email-masked]>
Date: Mon, 31 Oct 2011 12:08:05 -0400

Any reason not to go the Wiki route and just make sure it doesn't get corrupted?

---

From: Miek Gieben <[email-masked]>
Date: Sat, 29 Oct 2011 14:39:26 +0200

[ Quoting <[email-masked]> at 14:13 on Oct 29 in "Re: From Pandoc To R..." ]
> > Pandoc that in combination with Make and XSLT scripting to can produce internet-drafts in XML format

Thanks.

> The main feature that kramdown-rfc2629 seems to have beyond Miek's pandoc-based solution is support for (markdown extended syntax) tables.

I since added that too, so that also works :) The github readme
https://github.com/miekg/pandoc2rfc/blob/master/README.mkd
is more up to date.

> I do like Miek's approach to properly using markdown's reference syntax -- I invented my own instead, but might want to add support for Miek's syntax as well.

 grtz,

-- 
    Miek

---

From: John C Klensin <[email-masked]>
Date: Sat, 29 Oct 2011 14:44:15 -0400

Olaf,

     best,
      john