Subject: "class E" (was: Consensus Call: draft-weil-shared-transition-space-request)

From: Frank Ellermann <[email-masked]>
Date: Mon, 5 Dec 2011 18:46:18 +0100

On 5 December 2011 04:27, Cameron Byrne wrote:

  [they = the IETF]
>> they underscored that point by not rejecting various past attempts at
>> expanding private ipv4 space like 240/4.

> Sorry. S/not rejecting/rejecting/

ACK.  The last state I'm aware of is that the 240/4 addresses minus one
were and still are (RFC 5735) reserved for IETF experiments, did I miss
some newer IETF consensus about this?

-Frank

<http://omniplex.blogspot.com/2008/06/lost-found-268435455-free-ips.html>

---

From: David Conrad <[email-masked]>
Date: Mon, 5 Dec 2011 10:00:34 -0800

Frank,

On Dec 5, 2011, at 9:46 AM, Frank Ellermann wrote:
> The last state I'm aware of is that the 240/4 addresses minus one
...
> <http://omniplex.blogspot.com/2008/06/lost-found-268435455-free-ips.html>

Does it actually matter?  What RFCs say (or don't say) about 240/4 means precisely nothing to the deployed, non-field-upgradable CPE that I understand is driving the interest draft-weil.

Regard,
-drc

---

From: Cameron Byrne <[email-masked]>
Date: Mon, 5 Dec 2011 10:19:05 -0800

> <http://omniplex.blogspot.com/2008/06/lost-found-268435455-free-ips.html>

Hi,

The addresses, AFAIK, are still in a "no mans" land.

I went on a short-lived quest to make these addresses usable in 2008,
because in 2008, they were not usable and i needed addresses.
Meaning, Linux, FreeBSD, Windows would not accept these addresses in
configuration and Juniper and Cisco router would not only not accept
these addresses as part of their configuration, they would not route
the addresses in transit.  Some of this may have changed, but not
enough to make this a clear win.

I was told, by a large vendor of network gear, an IETF direction must
be made to define a purpose for these addresses, like:

http://tools.ietf.org/html/draft-wilson-class-e-02

http://tools.ietf.org/html/draft-fuller-240space-02

Both failed to gain support (i assume), and thus nothing happened.  My
assumption is these drafts were killed as "IPv4 life support"

RFC 5735 leaves the use of 240/4 undefined ... it could be used for
public, private, multicast, some future use we never thought of,
carrier pigeons ...

Thus, my feeling is that the IETF implicitly said "no ipv4 life
support by expanding private addresses, the cost of ipv4 will go
higher and higher, we can all see it like a slow moving train wreck,
make your strategies wisely".  Making this allocation for draft-weil
is changing the rules, slowing the train wreck, going backwards of
previous guidance(IPv6 is the answer to IPv4 exhaust),  while at the
same time increasing the amount of of damage.

cb

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 5 Dec 2011 13:21:07 -0500

> Does it actually matter?  What RFCs say (or don't say) about 240/4 means precisely nothing to the deployed, non-field-upgradable CPE that I understand is driving the interest draft-weil.

That IMO is the rock that proposals to use Class E have floundered on.
There is a lot of gear out there that will not be able to
deal with any Class E internetworking protocol, little prospect that
that will be changed any time soon, and a general feeling that it is
unwise to spend limited resources changing this.

Regards
Marshall

Regards
Marshall

>
> Regard,
> -drc
>
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Bob Hinden <[email-masked]>
Date: Mon, 5 Dec 2011 10:41:52 -0800

Marshall,

> unwise to spend limited resources changing this.

While all of that is true to use the Class E space for general purpose usage, the current proposal for using it for the CGN is different.  As far as I can tell, it would only require the CPE router, CGN's, and routers between the CPE and CGN's to support it.  It would not require any support by the customer behind the CPE or the rest of the Internet.  That the reason why several people have suggested it.

I think it's reasonable for the ISPs who want to deploy this CGN gear to the deal with upgrading the CPE routers of their customers.   They get the "benefit", they should incur the costs.  The proposal to use some of the remaining public IPv4 space for this, IMHO has everyone else incur the costs.

Bob

---

From: Mark Andrews <[email-masked]>
Date: Tue, 06 Dec 2011 09:03:41 +1100

In message <CAJNg7V+wxN_hsqGA_hQOr0Yc3Xyf1dqJQmaCDjzRu-zGCf_-=[email-masked]>
, Marshall Eubanks writes:
> > Does it actually matter? =A0What RFCs say (or don't say) about 240/4 mean=
> s precisely nothing to the deployed, non-field-upgradable CPE that I unders=
> tand is driving the interest draft-weil.
> 

The annoying thing here is that the IETF has already spent more
time arguing over whether to do this that it would have taken to
do it.

Add some signaling to PPP/DHCP that you are happy to receive a Class
E address and it could have been done incrementally.  ISP would
have turned it on when there equipment supported it.  The latest
Windows and MacOS builds would have supported it.  Similarly the
laters Linus and *BSD builds would have supported it (some already
do, sans signalling).  CPE vendors would have turned it on.

Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]