Subject: Re: Last Call: <draft-arkko-ipv6-only-experience-04.txt> (Experiences from an IPv6-Only Network) to Informational RFC

From: Bob Hinden <[email-masked]>
Date: Sun, 11 Dec 2011 13:10:20 +0200

I support publishing this document.  It is covers an important topic that is useful to the community.

Bob

On Dec 10, 2011, at 12:33 AM, The IESG wrote:

> 
> The IESG has received a request from an individual submitter to consider
> the following document:
> - 'Experiences from an IPv6-Only Network'
>  <draft-arkko-ipv6-only-experience-04.txt> as an Informational RFC
> 
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2012-01-06. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
> 
> Abstract
> 
> 
>   This document discusses our experiences from moving a small number of
>   users to an IPv6-only network, with access to the IPv4-only parts of
>   the Internet via a NAT64 device.  The document covers practical
>   experiences as well as road blocks and opportunities for this type of
>   a network setup.  The document also makes some recommendations about
>   where such networks are applicable and what should be taken into
>   account in the network design.  The document also discusses further
>   work that is needed to make IPv6-only networking applicable in all
>   environments.
> 
> 
> 
> 
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-arkko-ipv6-only-experience/
> 
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-arkko-ipv6-only-experience/
> 
> 
> No IPR declarations have been submitted directly on this I-D.
> 
> 
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: "George, Wes" <[email-masked]>
Date: Fri, 16 Dec 2011 08:18:22 -0500

I support the work behind this document, but I do have a concern that gives me pause regarding publishing it as an RFC in its current form.

I worry that it will serve as a disincentive for people to attempt IPv6-only deployments. This is not because of the way that it's written, nor a commentary on the quality of the document itself. I think that it does a good job of noting that it is a snapshot and that things will continue to improve, etc. but it runs afoul of the limitations of the IETF's document process- a static document reporting "current" test findings is almost instantly obsolete. This is a much larger problem than this draft, but it is something to consider when thinking about the content of this draft and how it will be interpreted, the audience, etc.

If the draft were to focus strictly on things which the *IETF* must fix in order to resolve outstanding problems with IPv6-only operation, those would be clearly actionable and new drafts written to resolve those issues could "update" this one, so that it's clear to future readers when something materially changes. In its current form, most of the noted "broken" things are related to specific implementations and therefore largely beyond the IETF's control (eg Skype, video game consoles, mobile phone stacks, etc). Unless it is updated with bis versions periodically when those issues are found to be resolved, it has the potential to mislead people as a source of information that they might use to determine if they should even consider trying this. Some of that information perhaps is better suited to a curated wiki, since it is easier to update it as the situation improves. FWIW, draft-donley-nat444-impacts has similar problems - very useful information, but not well-suited to static documents.

I don't know if that's enough to block the document, and I'm not going to be upset if it's published as-is, but I thought it was something that IESG should consider in their evaluation of the document. Perhaps it's a matter of delaying it for a bit and touching the document with updates to keep it active until we feel like we've reached an equilibrium after a bit more IPv6 deployment over the next 6-12 or even 18 months.

Thanks,

Wes George

> -----Original Message-----
> From: [email-masked] [mailto:ietf-announce-
> [email-masked]] On Behalf Of The IESG
> Sent: Friday, December 09, 2011 5:34 PM
> To: IETF-Announce
> Subject: Last Call: <draft-arkko-ipv6-only-experience-04.txt>
> (Experiences from an IPv6-Only Network) to Informational RFC
>
>

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Jari Arkko <[email-masked]>
Date: Fri, 16 Dec 2011 17:00:14 +0200

Wes: I understand your concern, and it certainly has given us pause when speaking about these results in different forums.

But at the end of the day, I think running code, real world situation, and useful information for the reader trump such concerns. I think we should be open about the issues, and mark the document clearly as a snapshot. Perhaps highlight this aspect even in the section that talks about, e.g., games. But I think it would take away from the value of this document if we didn't report the issues. And I'm the guy who wants IPv6-only to succeed and who sells gear for it. If I'm ready to talk about this, I think the IETF should be able to publish an RFC about it, too.

(Also, waiting is not a real option because we can't necessarily keep repeating tests all the time, and because there will always be some things that are broken. When all the widely used things are up and running there will be some less widely used things that no one bothered to fix. When those are up and running there will be some rarely used things that will never be upgraded and which might not even be used. And so on. And no, this is not a problem because there will always be breakage in the internet. There are plenty of web sites that cannot be contacted even on IPv4, plenty of software that no longer works even on the IPv4 Internet because it can't deal with NATs, etc.)

Jari

---

From: Stephan Wenger <[email-masked]>
Date: Fri, 16 Dec 2011 07:48:27 -0800

If the information presented in the document is "historic" the minute its
posted (because its a snapshot), why not post the doc as "historic"?
Stephan

On 12.16.2011 07:00 , "Jari Arkko" <[email-masked]> wrote:

>Wes: I understand your concern, and it certainly has given us pause when
>speaking about these results in different forums.
>
>But at the end of the day, I think running code, real world situation,
>and useful information for the reader trump such concerns. I think we
>should be open about the issues, and mark the document clearly as a
>snapshot. Perhaps highlight this aspect even in the section that talks
>about, e.g., games. But I think it would take away from the value of this
>document if we didn't report the issues. And I'm the guy who wants
>IPv6-only to succeed and who sells gear for it. If I'm ready to talk
>about this, I think the IETF should be able to publish an RFC about it,
>too.
>
>(Also, waiting is not a real option because we can't necessarily keep
>repeating tests all the time, and because there will always be some
>things that are broken. When all the widely used things are up and
>running there will be some less widely used things that no one bothered
>to fix. When those are up and running there will be some rarely used
>things that will never be upgraded and which might not even be used. And
>so on. And no, this is not a problem because there will always be
>breakage in the internet. There are plenty of web sites that cannot be
>contacted even on IPv4, plenty of software that no longer works even on
>the IPv4 Internet because it can't deal with NATs, etc.)
>
>Jari
>
>Ietf mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ietf

---

From: Randy Bush <[email-masked]>
Date: Fri, 16 Dec 2011 21:38:23 -0800

> and useful information for the reader trump such concerns. 

the truth shall make you free

randy

---

From: Joel jaeggli <[email-masked]>
Date: Sat, 17 Dec 2011 10:59:18 -0800

On 12/16/11 05:18 , George, Wes wrote:
> I support the work behind this document, but I do have a concern that
> gives me pause regarding publishing it as an RFC in its current
> form.
> 
> I worry that it will serve as a disincentive for people to attempt
> IPv6-only deployments. This is not because of the way that it's
> written, nor a commentary on the quality of the document itself. I
> think that it does a good job of noting that it is a snapshot and
> that things will continue to improve, etc. but it runs afoul of the
> limitations of the IETF's document process- a static document
> reporting "current" test findings is almost instantly obsolete. This
> is a much larger problem than this draft, but it is something to
> consider when thinking about the content of this draft and how it
> will be interpreted, the audience, etc.
> 
> If the draft were to focus strictly on things which the *IETF* must
> fix in order to resolve outstanding problems with IPv6-only
> operation, those would be clearly actionable and new drafts written
> to resolve those issues could "update" this one, so that it's clear
> to future readers when something materially changes. In its current
> form, most of the noted "broken" things are related to specific
> implementations and therefore largely beyond the IETF's control (eg
> Skype, video game consoles, mobile phone stacks, etc). Unless it is
> updated with bis versions periodically when those issues are found to
> be resolved, it has the potential to mislead people as a source of
> information that they might use to determine if they should even
> consider trying this. Some of that information perhaps is better
> suited to a curated wiki, since it is easier to update it as the
> situation improves. FWIW, draft-donley-nat444-impacts has similar
> problems - very useful information, but not well-suited to s tatic
> documents.
> 
> I don't know if that's enough to block the document, and I'm not
> going to be upset if it's published as-is, but I thought it was
> something that IESG should consider in their evaluation of the
> document. Perhaps it's a matter of delaying it for a bit and touching
> the document with updates to keep it active until we feel like we've
> reached an equilibrium after a bit more IPv6 deployment over the next
> 6-12 or even 18 months.

given that poeple are still noodling with ipv4 even now, I don't think
there's anymore danger of us being done in 18 months. I guess what I
would observe about documents like this is that people read them mostly
to the extent that they are germain to the problems that they have. at
some point the information here will be obsolecent, and if it's
important enough someone will undertake a new document, but maybe it
won't be.

> Thanks,
> 
> Wes George
> 
> 
>> -----Original Message----- From: [email-masked]
>> [mailto:ietf-announce- [email-masked]] On Behalf Of The IESG 
>> Sent: Friday, December 09, 2011 5:34 PM To: IETF-Announce Subject:
>> Last Call: <draft-arkko-ipv6-only-experience-04.txt> (Experiences
>> from an IPv6-Only Network) to Informational RFC
>> 
>> 
>> The IESG has received a request from an individual submitter to 
>> consider the following document: - 'Experiences from an IPv6-Only
>> Network' <draft-arkko-ipv6-only-experience-04.txt> as an
>> Informational RFC
>> 
>> The IESG plans to make a decision in the next few weeks, and
>> solicits final comments on this action. Please send substantive
>> comments to the [email-masked] mailing lists by 2012-01-06.
>> Exceptionally, comments may be sent to [email-masked] instead. In
>> either case, please retain the beginning of the Subject line to
>> allow automated sorting.
>> 
>> Abstract
>> 
>> 
>> This document discusses our experiences from moving a small number 
>> of users to an IPv6-only network, with access to the IPv4-only
>> parts of the Internet via a NAT64 device.  The document covers
>> practical experiences as well as road blocks and opportunities for
>> this type of a network setup.  The document also makes some
>> recommendations about where such networks are applicable and what
>> should be taken into account in the network design.  The document
>> also discusses further work that is needed to make IPv6-only
>> networking applicable in all environments.
>> 
>> 
>> 
>> 
>> _______________________________________________ IETF-Announce
>> mailing list [email-masked] 
> This E-mail and any of its attachments may contain Time Warner Cable
> proprietary information, which is privileged, confidential, or
> subject to copyright belonging to Time Warner Cable. This E-mail is
> intended solely for the use of the individual or entity to which it
> is addressed. If you are not the intended recipient of this E-mail,
> you are hereby notified that any dissemination, distribution,
> copying, or action taken in relation to the contents of and
> attachments to this E-mail is strictly prohibited and may be
> unlawful. If you have received this E-mail in error, please notify
> the sender immediately and permanently delete the original and any
> copy of this E-mail and any printout. 
> _______________________________________________ Ietf mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/ietf
>