Subject: Re: Last Call: <draft-weil-shared-transition-space-request-14.txt> (IANA Reserved IPv4 Prefix for Shared Address Space) to BCP

From: Chris Grundemann <[email-masked]>
Date: Mon, 30 Jan 2012 16:58:00 -0700

I still fully support this draft and encourage the IESG to move it forward.

Thanks,
~Chris

On Mon, Jan 30, 2012 at 16:03, The IESG <[email-masked]> wrote:
>
> The IESG has received a request from an individual submitter to consider the following document:
> - 'IANA Reserved IPv4 Prefix for Shared CGN Space'
>  <draft-weil-shared-transition-space-request-14.txt> as a BCP
>
> On its December 15, 2011 telechat, the IESG reviewed version 10 of this
> document and requested various changes. These changes are reflected in
> the draft version 14 and the IESG now solicits community input on the
> changed text only. Please send substantive comments to the [email-masked]
> mailing lists by 2012-02-16. Exceptionally, comments may be sent to
> [email-masked] instead. In either case, please retain the beginning of
> the Subject line to allow automated sorting.
>
> Abstract
>
>  This document requests the allocation of an IPv4 /10 address block to
>  be used as Shared Address Space to accommodate the needs of Carrier
>  Grade Network Address Translation (CGN) devices.  It is anticipated
>  that Service Providers will use this Shared Address Space to number
>  the interfaces that connect CGN devices to Customer Premise Equipment
>  (CPE).
>
>  Shared Address Space is distinct from RFC1918 private address space
>  because it is intended for use on Service Provider networks.
>  However, it may be used as RFC 1918 private address space in certain
>  circumstances.  Details are provided in the text of this document.
>
>  As this document proposes the allocation of an additional special-use
>  IPv4 address block, it updates RFC 5735.
>
> The following text captures the most salient change between version 10 and 14 of this document:
>
>  Shared Address Space is IPv4 address space designated for Service
>     Provider use with the purpose of facilitating CGN deployment.  Also,
>     Shared Address Space can be used as additional [RFC1918] space when
>     at least one of the following conditions is true:
>
>     o  Shared Address Space is not also used on the Service Provider side
>        of the CPE.
>
>     o  CPE routers behave correctly when using the same address block on
>        both the internal and external interfaces.
>
>
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-weil-shared-transition-space-request/
>
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-weil-shared-transition-space-request/
>
>
> No IPR declarations have been submitted directly on this I-D.
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

-- 
@ChrisGrundemann
weblog.chrisgrundemann.com
www.burningwiththebush.com
www.theIPv6experts.net
www.coisoc.org

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 31 Jan 2012 14:51:18 +1300

Hi,

>         both the internal and external interfaces.

I see that this change is in response to an IESG comment, but I think it's
a mistake. Encouraging sites to use yet more ambiguous address space based
on conditions that they may not even understand, or that may change when they
switch ISPs or replace CPEs, seems wrong.

    Brian

---

From: "George, Wes" <[email-masked]>
Date: Tue, 31 Jan 2012 12:19:44 -0500

I've been recommending this direction (that this is basically just more private space, no magic) for some time, so I support the change.

However, I strongly believe that the document should formally update RFC1918, not just 5735, especially now that it specifically says that in certain circumstances the space can be used as 1918 space. Having the linkage between the documents (from 1918 to this one, instead of just in the other direction) is quite important, IMO.

Wes George

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of The IESG
> Sent: Monday, January 30, 2012 6:04 PM
> To: IETF-Announce
> Subject: Last Call: <draft-weil-shared-transition-space-request-14.txt> (IANA
> Reserved IPv4 Prefix for Shared Address Space) to BCP
>
>

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.