Subject: Re: Last Call: <draft-ishikawa-yrpunl-ucode-urn-01.txt> (A URN Namespace For The ucode) to Informational RFC

From: Mykyta Yevstifeyev <[email-masked]>
Date: Tue, 17 Jan 2012 20:27:10 +0200

Hello,

Having reviewed this document, I think there is no problem with its
publication.  Several tiny comments:

1) "RFID" in the Introduction needs expanding at first use.

2)   ucode-value = 32hex-decimal
   hex-decimal = "0" / "1" / "2" / "3" / "4" / "5" / "6" / "7" /
                 "8" / "9" / "A" / "B" / "C" / "D" / "E" / "F"

may be changed to:

   ucode-value = 32HEXDIG

and that's RFC 5234 which defines <HEXDIG> so you may refer to it later.

3)

Rules for lexical equivalence:

   The entire UCODE-URN is case-sensitive.

This is at least wrong for the first three chars in URN (the URI
scheme name "urn"), that is case-insensitive as per RFC 3986.  What's
the reason for setting such regulation?

Mykyta Yevstifeyev

2012/1/17 The IESG <[email-masked]>:
>
> The IESG has received a request from an individual submitter to consider
> the following document:
> - 'A URN Namespace For The ucode'
>  <draft-ishikawa-yrpunl-ucode-urn-01.txt> as an Informational RFC
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2012-02-14. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
>
> Abstract
>
>
>   This document describes a URN (Uniform Resource Name) namespace for
>   ucode, an identifier system for objects and places,  used in various
>   applications for the ubiquitous computing or the Internet of Things.
>
>
>
>
>
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-ishikawa-yrpunl-ucode-urn/
>
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-ishikawa-yrpunl-ucode-urn/
>
>
> No IPR declarations have been submitted directly on this I-D.
>
>
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Julian Reschke <[email-masked]>
Date: Wed, 18 Jan 2012 15:25:25 +0100

On 2012-01-17 19:27, Mykyta Yevstifeyev wrote:
> and that's RFC 5234 which defines<HEXDIG>  so you may refer to it later.
>
> 3)
>
> ...

What's case-sensitive depends on context; for instance, when comparing 
XML namespace URIs or Atom IDs, everything is case-sensitive. See also 
<http://greenbytes.de/tech/webdav/rfc3986.html#rfc.section.6.2>.

Best regards, Julian