Subject: Re: Variable length internet addresses in TCP/IP: history

From: [email-masked] (Noel Chiappa)
Date: Fri, 17 Feb 2012 13:32:41 -0500 (EST)

> From: Bob Hinden <[email-masked]>

    > the other reason why we went with 128-bit address with a 64/64 split
    > as the common case and defining IIDs that indicate if they have
    > global uniqueness. This creates a framework that an ID/locator split
    > could be implemented. ... we have a framework that would allow it
    > without having to roll out another version of IP. 

Alas, the inclusion of _both halves_ of the IPv6 address in the TCP
checksum means the framework you speak of is basically useless for an
identity/location split.

	Noel

---

From: Bob Hinden <[email-masked]>
Date: Fri, 17 Feb 2012 11:10:55 -0800

Noel,

> checksum means the framework you speak of is basically useless for an

That's why I described it as a framework.  The TCP pseudo-checksum would have to change and likely the addition of some sort of authentication at connection establishment to associate an identifiers with a set of locators.  Not trivial, but doable.  

Bob

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 18 Feb 2012 08:41:22 +1300

> That's why I described it as a framework.  The TCP pseudo-checksum would have to change and likely the addition of some sort of authentication at connection establishment to associate an identifier…

Authentication is not just doable, but done, in shim6. However,
shim6 ducks the checksum issue by being a shim. ILNP deals with
it up front, but is a bigger change from vanilla IPv6. The
flexibility is there, but it's academic until we get IPv6 widely
deployed.

   Brian