Subject: Re: Another last call for draft-weil

From: Owen DeLong <[email-masked]>
Date: Mon, 13 Feb 2012 11:05:59 -0800

I support draft-weil as revised. There is a vital need for this to move forward and the IETF should stop standing in the way and let ARIN allocate the space already.

Owen

On Feb 13, 2012, at 10:09 AM, Chris Grundemann wrote:

> Fellow BDGKS Authors,
> 
> FYI: draft-weil is in another Last Call following an update that was requested by IESG Ads (on their December telechat, some ADs asked us to turn our request into a request for more 1918 space, but with a few caveats to home router manufacturers about not breaking when exposed to a CGN environment.). At this point we don't expect to change any minds. Basically everyone who is against the draft has spoken up. Now it is just a numbers game, we need to demonstrate significant support for the draft.
> 
> If you do support this I-D and the allocation of the /10 for shared CGN use, please consider posting a statement of support.  Something as simple as "I support this draft as updated" or "I think the updated draft is more flexible, and would satisfy additional use cases that don't work with RFC1918 space" would be very helpful.
> 
> You can respond to the "Last Call: <draft-weil-shared-transition-space-request-14.txt> (IANA Reserved IPv4 Prefix for Shared Address Space) to BCP" thread or post individually to  [email-masked]. Also, please feel free to encourage anyone else you know who supports the draft to make a similar post. Every statement we can gather is vital right now. Last call ends on Thursday, so reply's must be made before then. Thank you.
> 
> Cheers,
> ~Chris

---

From: Ross Callon <[email-masked]>
Date: Tue, 14 Feb 2012 13:25:05 -0500

+1.

Ross

From: [email-masked] [mailto:[email-masked]] On Behalf Of Owen DeLong
Sent: Monday, February 13, 2012 2:06 PM
To: [email-masked]
Cc: draft-bdgks-arin-shared-transition-space@tools. org
Subject: Re: Another last call for draft-weil

Owen

Fellow BDGKS Authors,

You can respond to the "Last Call: <draft-weil-shared-transition-space-request-14.txt> (IANA Reserved IPv4 Prefix for Shared Address Space) to BCP" thread or post individually to  [email-masked]<mailto:[email-masked]>. Also, please feel free to encourage anyone else you know who supports the draft to make a similar post. Every statement we can gather is vital right now. Last call ends on Thursday, so reply's must be made before then. Thank you.

Cheers,
~Chris

---

From: Scott O Bradner <[email-masked]>
Date: Tue, 14 Feb 2012 13:28:56 -0500

+1

On Feb 14, 2012, at 1:25 PM, Ross Callon wrote:

> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 15 Feb 2012 12:23:20 -0500

I agree.  This needs to be published by the IETF as an RFC. the current 
form is quite suitable for that.

Yours,
Joel

On 2/14/2012 1:28 PM, Scott O Bradner wrote:
>> *From:[email-masked]
>> <mailto:[email-masked]>[mailto:[email-masked]]*On Behalf
>> Of*Owen DeLong
>> *Sent:*Monday, February 13, 2012 2:06 PM
>> *To:[email-masked] <mailto:[email-masked]>
>> *Cc:*draft-bdgks-arin-shared-transition-space@tools. org
>> *Subject:*Re: Another last call for draft-weil
>> I support draft-weil as revised. There is a vital need for this to
>> move forward and the IETF should stop standing in the way and let ARIN
>> allocate the space already.
>> Owen
>> FYI: draft-weil is in another Last Call following an update that was
>> requested by IESG Ads (on their December telechat, some ADs asked us
>> to turn our request into a request for more 1918 space, but with a few
>> caveats to home router manufacturers about not breaking when exposed
>> to a CGN environment.). At this point we don't expect to change any
>> minds. Basically everyone who is against the draft has spoken up. Now
>> it is just a numbers game, we need to demonstrate significant support
>> for the draft.
>> If you do support this I-D and the allocation of the /10 for shared
>> CGN use, please consider posting a statement of support. Something as
>> simple as "I support this draft as updated" or "I think the updated
>> draft is more flexible, and would satisfy additional use cases that
>> don't work with RFC1918 space" would be very helpful.
>> You can respond to the "Last Call:
>> <draft-weil-shared-transition-space-request-14.txt> (IANA Reserved
>> IPv4 Prefix for Shared Address Space) to BCP" thread or post
>> individually to [email-masked] <mailto:[email-masked]>. Also, please
>> feel free to encourage anyone else you know who supports the draft to
>> make a similar post. Every statement we can gather is vital right now.
>> Last call ends on Thursday, so reply's must be made before then. Thank
>> you.
>> Cheers,
>> ~Chris
>> [email-masked] <mailto:[email-masked]>

---

From: John C Klensin <[email-masked]>
Date: Thu, 16 Feb 2012 09:04:03 -0500

A current Last Call has apparently brought on another of the
"please tell all your friends to send in supportive notes, even
if they don't say much of anything substantive" campaigns that
we see from time to time.  When those notes come from people who
do not routinely participate on IETF lists, they provide very
little real information unless we have suddenly taken up voting
or otherwise counting notes.  Whatever we might otherwise think
of company positions, a note that said "I work for <xyz> and we
need this and intend to implement and deploy it" would be real
information that the community could consider where "I am an
individual and +1" does not.   Sadly, such endorsements,
especially from people who are not active IETF participants, add
to the noise and might prevent someone who was still genuinely
trying to understand the pros and cons (presumably including all
of the IESG) from seeing a new and substantive argument, no
matter how well-grounded.

I note that there are some folks in the community who seem to
favor these campaigns when they like the cause and not if they
do not.

But I wonder whether, in the interest of noise reduction and/or
support of our "no voting, even by active participants"
position, there be any sympathy for a Godwin-like rule that the
first appearance of many no-information "I support this"
endorsements from people and constituencies who are not regular
participants on the IETF list should immediately trigger a state
in which all further statements from that "side" would be
ignored or would end the discussion entirely?

Yes, I see the difficulties in figuring out the details of such
a rule and implementing it and am mostly joking.   Mostly.

     john

---

From: Måns Nilsson <[email-masked]>
Date: Thu, 16 Feb 2012 15:09:17 +0100

Subject: IETF Last Calls and Godwin-like rules Date: Thu, Feb 16, 2012 at 09:04:03AM -0500 Quoting John C Klensin ([email-masked]):

...

> a rule and implementing it and am mostly joking.   Mostly.

I support this. 

-- 
Måns Nilsson     primary/secondary/besserwisser/machina
MN-1334-RIPE                             +46 705 989668
YOW!!  Everybody out of the GENETIC POOL!

---

From: Yoav Nir <[email-masked]>
Date: Thu, 16 Feb 2012 16:13:09 +0200

+1

---

From: Dave CROCKER <[email-masked]>
Date: Thu, 16 Feb 2012 06:23:54 -0800

>> a rule and implementing it and am mostly joking.   Mostly.

You support the joking?

Or is it that you support vague rules that are unenforceable and will generate 
more heat than light?

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Yoav Nir <[email-masked]>
Date: Thu, 16 Feb 2012 16:34:53 +0200

> a rule and implementing it and am mostly joking.   Mostly.

Because we don't vote, the show of support with all the +1s really doesn't amount to much. I don't think even promises to implement carry much weight at last call. By the time some proposal has gone to last call, especially IETF last call, the issue of whether this will be useful to someone should have already been settled.

I think that an endorsement like "I work for Cisco and we intend to implement this in every one of our products" is useful. But it's not nearly as useful as "this is a terrible idea, and doing this will prevent IPv6 from ever gaining traction". The objections raised in last call are really the point, not the endorsements.

Yoav

---

From: Roger Jørgensen <[email-masked]>
Date: Thu, 16 Feb 2012 15:48:30 +0100

On Thu, Feb 16, 2012 at 3:34 PM, Yoav Nir <[email-masked]> wrote:
<snip>
> I think that an endorsement like "I work for Cisco and we intend to implement this in every one of our products" is useful. But it's not nearly as useful as "this is a terrible idea, and doing this…

Think I've read somewhere that the ground of good engineering (the E
in IETF) are being able to argue against your own idea, search and
look for flaws in it, and all in the name of testing it to see how it
can be made even better, is it good enough? Or simple to consider the
bigger picture, can my idea hurt the rest no matter how good it is?
There are great and very good ideas out there that isolated are
fantastic, but considered in just a bit bigger picture are horrible,
they've ruin everything around them.

So, when lots of people are all for something without mention or
willing to discusse the bad sides... that's scary as I see it.

-- 

Roger Jorgensen           |
[email-masked]          | - IPv6 is The Key!
http://www.jorgensen.no   | [email-masked]

---

From: Yoav Nir <[email-masked]>
Date: Thu, 16 Feb 2012 17:12:01 +0200

> they've ruin everything around them.

I agree. IPv4 forever using CGNs may work for a lot of people and a lot of uses. If people remain double- or triple-natted it won't matter a bit to the big web sites. 

It's far more important to hear what is not going to work with this solution.

It's great if you can find such deficiencies in your own ideas, but we still need design reviews, code reviews, QA departments and IETF last calls so that others can get at your idea.

---

From: SM <[email-masked]>
Date: Thu, 16 Feb 2012 07:46:52 -0800

Hi John,
>little real information unless we have suddenly taken up voting

Letter-writing campaigns occur every now and then.  As there isn't 
any vote count, the effort can end up in a diluted form.

>matter how well-grounded.

Last year, someone discussed about how a "+1" could be read and some 
people were offended.   Maybe authors should be given the choice to 
have their proposal evaluated by counting the votes or to have the 
evaluation which is based on substantive comments.  Nobody would be 
offended then.

Regards,
-sm

---

From: Mark Andrews <[email-masked]>
Date: Fri, 17 Feb 2012 07:50:53 +1100

In message <[email-masked]>, Yoav Nir writes:
> 
> On Feb 16, 2012, at 4:48 PM, Roger J=F8rgensen wrote:
> 
> >> I think that an endorsement like "I work for Cisco and we intend to impl=
> ement this in every one of our products" is useful. But it's not nearly as =
> useful as "this is a terrible idea, and doing this will prevent IPv6 from e=
> ver gaining traction". The objections raised in last call are really the po=
> int, not the endorsements.
> > =
> 
> > =
> 
> I agree. IPv4 forever using CGNs may work for a lot of people and a lot of =
> uses. If people remain double- or triple-natted it won't matter a bit to th=
> e big web sites. =
> 
> 
> It's far more important to hear what is not going to work with this solutio=
> n.
> 
> It's great if you can find such deficiencies in your own ideas, but we stil=
> l need design reviews, code reviews, QA departments and IETF last calls so =
> that others can get at your idea.

To all of you saying that this only supports IPv4 only boxes.  How
do I connect up my Windows XP (with IPv6 enabled) or later box,
Linux box (from anywhere in the last decade), *BSD box (from anywhere
in the last decade), Apple box (from anywhere in the last decade)
and get both IPv4 and IPv6 without being handed a IPv4 address via
DHCP.  That list pretty much covers the home computer space of dual
stack computer space.

People keep saying IPv6 provides additional solutions, and it does,
however there is a enormous dual stack legacy device problem out
there and saying "go IPv6 only" just isn't a viable for those devices
yet.  They still need a IPv4 address via DHCP which has all the
issues a IPv4-only box has.

There are dual stack CPE routers today that won't provide IPv4
unless there is address space provided via DHCP.  I've got one and
at some point my ISP will need to go the CGN route for IPv4.  I
don't know if there will be a firmware update to support IPv4 over
IPv6 or if there is it will match the solution my ISP will choose.

Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: "George Willingmyre" <[email-masked]>
Date: Fri, 17 Feb 2012 11:40:54 -0500

potential "vote packers"  in voluntary consensus standards processes take heed of 1988 Supreme Court affirmation of lower court award of $3.8 million in damages (before trebling)  antitrust liability of  Allied Tube & Conduit Corp when packing NFPA process
http://www.gtwassociates.com/answers/Cases/AlliedTube.htm
Supreme Court  affirmed
In its complaint, plaintiff Indian Head, Inc. (Carlon) charged that defendant Allied Tube & Conduit Corp. had conspired to prevent inclusion of Carlon's product in industry standards. The jury found for Carlon, and awarded it $3.8 million in damages (before trebling).
Allied Tube v. Indian Head, Inc. - 486 U.S. 492 (1988)
Before the meeting was held, petitioner, the Nation's largest producer of steel conduit, members of the steel industry, other steel conduit manufacturers, and independent sales agents collectively agreed to exclude respondent's product from the 1981 Code by packing the annual meeting with new Association members whose only function was to vote against respondent's proposal.

George T. Willingmyre, P.E.
President, GTW Associates
Spencerville, MD USA 20868
301.421.4138
www.gtwassociates.com