Subject: Re: ITC copped out on UTC again

From: james woodyatt <[email-masked]>
Date: Tue, 07 Feb 2012 10:45:22 -0800

On Jan 23, 2012, at 10:03 , Marshall Eubanks wrote:
> 
> And, of course, this is also orthogonal to the problem at hand, as UTC, GPS time, TT, all  also experience from the same issues, and it has nothing to do with leap seconds.

A point in favor of deriving the Internet time scale directly from TAI is that it fairly effectively reduces UTC to just another time zone, one that covers the entire surface of the Earth, but a timezone nonetheless.

Just like every other time zone, its future divergence from TAI is unpredictable.  The principle reason is that time zones are under the control of-- and subject to change at any time by-- various sovereign and treaty bodies.  TAI has a fairly stable foundation in non-relativistic physics, which experience has shown to be somewhat resistant to the power of political bodies to modify at will, so it should be good enough for most running code on the Internet.

Shorter james: +1 for switching to TAI.

--
james woodyatt <[email-masked]>
member of technical staff, core os networking

---

From: Tony Finch <[email-masked]>
Date: Tue, 7 Feb 2012 19:03:43 +0000

james woodyatt <[email-masked]> wrote:
>
> TAI has a fairly stable foundation in non-relativistic physics, which
> experience has shown to be somewhat resistant to the power of political
> bodies to modify at will,

Actually TAI depends a lot on relativity as well as quantum physics. For
example, it is supposed to match the rate of the SI second on the geoid
(which is roughly mean sea level). NIST's lab in Colorado is about a mile
high, so they have to apply a general relativistic rate correction to
their atomic clocks because of their gravitational potential.

> so it should be good enough for most running code on the Internet.

Except where that code needs UTC.

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Viking, North Utsire: Southerly or southeasterly 5 to 7, occasionally gale 8
in Viking. Moderate or rough, becoming rough or very rough in Viking. Showers.
Good.

---

From: John C Klensin <[email-masked]>
Date: Tue, 07 Feb 2012 14:12:59 -0500

--On Tuesday, February 07, 2012 10:45 -0800 james woodyatt
<[email-masked]> wrote:

>...
> TAI has a fairly stable foundation in non-relativistic
> physics, which experience has shown to be somewhat resistant
> to the power of political bodies to modify at will, so it
> should be good enough for most running code on the Internet.

You obviously have not been in enough meetings in which
proposals were put forth, by political types with the best of
intentions, for regulations to improve the Internet...
regulations that would work really well if the speed of light
were adjusted upward by 10% or so and/or could be dialed up and
back by a bit to match regulatory convenience. :-(

What was that about a free lunch?

     john

---

From: Steven Bellovin <[email-masked]>
Date: Wed, 8 Feb 2012 16:41:35 -0500

> What was that about a free lunch?

Yes.  A line I heard recently (from someone else whom I think is
on this list) is that when you tell a politician that something
violates the laws of physics, that statement is taken as a negotiating
position.

		--Steve Bellovin, https://www.cs.columbia.edu/~smb

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 09 Feb 2012 11:46:55 +1300

> violates the laws of physics, that statement is taken as a negotiating

I don't see the problem. An experiment in Italy has observed
super-luminal neutrinos, and a somewhat unlikely violation of
the 2nd law of thermodynamics would allow pigs to fly and all
NTP servers to update themselves simultaneously. Clearly these
are matters that any self-respecting politician could use in
negotiation.

I am much more worried about
http://internetsociety.org/events/internet-society-events/world-conference-international-telecommunications
than about UTC.

     Brian

---

From: james woodyatt <[email-masked]>
Date: Thu, 09 Feb 2012 15:24:50 -0800

> their atomic clocks because of their gravitational potential.

I'm aware of that.  The point I was trying to make so clumsily is that, outside of the physical contexts where relativity and quantum effects are significant, TAI is a comparatively stable and predictable timescale next to the UTC and the NTP timescales.

It would be a perfectly good replacement as The Internet Timescale.

> Except where that code needs UTC.

...or awareness any other timezone, for that matter.

On Feb 7, 2012, at 11:12 , John C Klensin wrote:
> 
> You obviously have not been in enough meetings in which proposals were put forth, by political types with the best of intentions, for regulations to improve the Internet...

I said "somewhat resistant" not "impervious" didn't I?  [I'm not going to recount any of the stories I know about various famous technology sector executives and their unhappy encounters with the laws of physics.]