Subject: re: [core] Last Call: <draft-ietf-core-link-format-11.txt> (CoRE Link Format) to Proposed Standard

From: Don Sturek <[email-masked]>
Date: Wed, 15 Feb 2012 12:16:13 -0800

This is less a substantive comment but one more on processŠŠ..

Here is the history of WGLC:

http://www.ietf.org/mail-archive/web/core/current/msg02427.html

http://www.ietf.org/mail-archive/web/core/current/msg01414.html

Here is the history:

http://datatracker.ietf.org/doc/draft-ietf-core-link-format/history/

A couple of points:
1)  I work in a commercial group (ZigBee Alliance) using IETF standards for
commercial deployment.  We have several work groups interested in CoAP but
were waiting for a stable version to determine whether it was usable or not
for their application (things like home automation, commercial automation).
We had assumed that since the original WGLC (rev 02) and since there were
multiple iterations on the document (see the history) that the document was
not final.
2)  The second WGLC was only 1 week in duration and occurred over the US
Thanksgiving holiday.  I completely missed that.  Even so, there were 3 more
revisions after that so not sure it was obvious that this was actually the
final WGLC for the document.

I mention the above since I think it would be useful to actually have a full
1 month last call on this document.  I think there were several of us that
were surprised by the referral of the document to the IESG and who were
planning to do a final review at WGLC (which apparently we missedŠ.).

Also, is it normal to have so many revisions after WGLC?   Having WGLC in
Jan. 2011 on rev 02 and then the version referred to IESG as rev 12 a year
later seems strange.

Thanks for your consideration,

Don Sturek

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 16 Feb 2012 19:02:05 +0100

Hi Don,

thanks for the feedback.

link-format has been essentially stable for the better part of a year now (as the result of dispatching of the comments on the first WGLC in -03, IIRC).  It has been used in a number of informal interop events, and the feedback always was that it did its job and there were few, if any, problems.

Yes, there have been many minor revisions since, mostly on the editorial front.
There is a difference between a spec implementers close to the WG process can use and the one you want in the permanent record for everybody to use.
We also needed to get the ABNF right to cover some fringe cases.

When these small fixes were completed in response to the results of the second WGLC, I had briefly planned to do a third WGLC, but then I didn't really see a reason any more to do so.  (BTW, I'm not aware of a concept of "final WGLC", and I have never qualified a WGLC as such.  The "L" in WGLC already means "last", as in final.)

As a general observation on the IETF WG process: the increase of the number on the document does not mean there is substantial change.  In particular during what I'm referring to as the "ID-nits phase" when a document is getting dressed up for going forward, it may take a couple of small editorial rounds to get all the various classes of things crossed and dotted.  
Please do avail yourself of the tools pages to review the diffs to see whether there still is substantial change or just Brownian motion.  On a more general note, WGLC is not the only time WG members need to look at a document.

Putting WGLCs on top of distracting events like IETF meetings or important holidays is something most WG chairs actively try to avoid.  I already put in an allowance for the November IETF in the second WGLC, and I'm sorry if I forgot about adding more allowance for US Thanksgiving Day.  (There has been ample time since to submit any late feedback.)

All that said, we're in luck and have an IETF last call that follows the WG consensus process in the procedures, and this is a great opportunity for additional input.  
I'm certainly looking forward to yours.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 16 Feb 2012 20:43:20 +0100

On Feb 16, 2012, at 19:52, Don Sturek wrote:

> Hi Carsten,
> 
> Somehow, luck is not how I would have described the process.
> 
> I think if you thought it important enough to do a WGLC in November 2011,
> you maybe should have made it for longer than a week

I did.

> and avoided the US
> Thanksgiving holiday.

As I said, I didn't have that on the radar, so I didn't compensate for both the IETF and the US Thanksgiving Day.
Sorry about that.
Not including the winter holidays, there were two more months for making comments since.

> We had several groups interested in possibly using CoAP but I was holding
> off looking at the draft until WGLC.  I guess with the response below, the
> guidance will be to use what is there else find another solution

Wait a minute, maybe there is some underlying confusion here.

This last-call is about the CoRE link-format.  
The link-format spec and the CoAP protocol are rather loosely coupled, technically speaking.

CoAP is not even in first WGLC yet (but getting close).

If you do need some time beyond the usual two-week WGLC to review the CoAP documents, now probably would be a good time to start the review for

  "Constrained Application Protocol (CoAP)", 31-Oct-11, <draft-ietf-core-coap-08.txt>

  "Blockwise transfers in CoAP", 15-Feb-12, <draft-ietf-core-block-08.txt>

  "Observing Resources in CoAP", 14-Feb-12, <draft-ietf-core-observe-04.txt>

The core-coap spec hasn't been updated recently and therefore carries the bulk of the remaining open tickets (six); please review them at
	http://trac.tools.ietf.org/wg/core/trac/report
(I recommend the format of report 9.)
There are proposals for resolution of most of the remaining tickets, and we would love to receive your input so we can make good technical decisions even before the documents go to WGLC.

It is worth pointing out that the main technical substance of the documents has been stable since about March 2011 (core-coap) and since mid-2011 (-observe, -block).  Feedback from the multiple implementations has been quite positive, so this should all be stable enough for a thorough review. 

> (fortunately, the work you are doing can be replaced with other solutions
> if does not map to our commercial needs).

Why the sour grapes?

This WG has a history of being very open and supportive for all technical input received.
There is no take-it-or-leave-it at all.
But you do have to speak up, or you won't be heard.

The best way to contribute to IETF WG work is, indeed, taking part in the work before WGLC.

> I think I will have a look at the diffs.  I was on the reflector and seem
> to recall more than just editorials going in to the specification after
> the first WGLC (which I recall at the time being wildly premature with
> respect to the maturity of CoAP.....)

We did the link-format WGLC in January 2011 because the author thought it was ready and nobody in the WG spoke up to stop it.
The feedback was quite positive, and the changes resulting from the review were useful but small.
It probably was right to wait for November for the 2nd WGLC because CoAP was still stabilizing, but it turns out there was no impact.

I don't understand the comment about maturity, but maybe again you are referring to CoAP -- a WGLC for CoAP in January 2011 might have been rather early indeed.

But for now let's stick to the link-format document -- this is what's being last-called this month.
It is a short document, and it is mainly about making an existing RFC (RFC 5988) accessible to the CoRE space.

Grüße, Carsten

---

From: Don Sturek <[email-masked]>
Date: Thu, 16 Feb 2012 10:52:13 -0800

Hi Carsten,

I think if you thought it important enough to do a WGLC in November 2011,
you maybe should have made it for longer than a week and avoided the US
Thanksgiving holiday.

Don

On 2/16/12 10:02 AM, "Carsten Bormann" <[email-masked]> wrote:

>Hi Don,
>
>thanks for the feedback.
>
>link-format has been essentially stable for the better part of a year now
>(as the result of dispatching of the comments on the first WGLC in -03,
>IIRC).  It has been used in a number of informal interop events, and the
>feedback always was that it did its job and there were few, if any,
>problems.
>
>There is a difference between a spec implementers close to the WG process
>can use and the one you want in the permanent record for everybody to use.
>When these small fixes were completed in response to the results of the
>second WGLC, I had briefly planned to do a third WGLC, but then I didn't
>really see a reason any more to do so.  (BTW, I'm not aware of a concept
>of "final WGLC", and I have never qualified a WGLC as such.  The "L" in
>WGLC already means "last", as in final.)
>
>As a general observation on the IETF WG process: the increase of the
>number on the document does not mean there is substantial change.  In
>particular during what I'm referring to as the "ID-nits phase" when a
>document is getting dressed up for going forward, it may take a couple of
>small editorial rounds to get all the various classes of things crossed
>and dotted.  
>Please do avail yourself of the tools pages to review the diffs to see
>whether there still is substantial change or just Brownian motion.  On a
>more general note, WGLC is not the only time WG members need to look at a
>document.
>
>Putting WGLCs on top of distracting events like IETF meetings or
>important holidays is something most WG chairs actively try to avoid.  I
>already put in an allowance for the November IETF in the second WGLC, and
>I'm sorry if I forgot about adding more allowance for US Thanksgiving
>Day.  (There has been ample time since to submit any late feedback.)
>
>All that said, we're in luck and have an IETF last call that follows the
>WG consensus process in the procedures, and this is a great opportunity
>for additional input.