Subject: Re: [v6ops] Last Call: <draft-ietf-v6ops-v6-aaaa-whitelisting-implications-08.txt> (Considerations for Transitioning Content to IPv6) to Informational RFC

From: Erik Kline <[email-masked]>
Date: Fri, 3 Feb 2012 11:57:23 +0900

World IPv6 Launch changes the relevance of this document greatly, I
think.  Since this would be published after the announcement of World
IPv6 Launch, I think the document should be updated to discuss its own
applicability in a post- World IPv6 Launch Internet.

On 2 February 2012 00:09, The IESG <[email-masked]> wrote:
>
> The IESG has received a request from the IPv6 Operations WG (v6ops) to
> consider the following document:
> - 'Considerations for Transitioning Content to IPv6'
>  <draft-ietf-v6ops-v6-aaaa-whitelisting-implications-08.txt> as an
> Informational RFC
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2012-02-15. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
>
> Abstract
>
>
>   This document describes considerations for the transition of end user
>   content on the Internet to IPv6.  While this is tailored to address
>   end user content, which is typically web-based, many aspects of this
>   document may be more broadly applicable to the transition to IPv6 of
>   other applications and services.  This document explores the
>   challenges involved in the transition to IPv6, potential migration
>   tactics, possible migration phases, and other considerations.  The
>   audience for this document is the Internet community generally,
>   particularly IPv6 implementers.
>
>
>
>
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-ietf-v6ops-v6-aaaa-whitelisting-implications/
>
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-ietf-v6ops-v6-aaaa-whitelisting-implications/
>
>
> No IPR declarations have been submitted directly on this I-D.
>
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Tina TSOU <[email-masked]>
Date: Fri, 03 Feb 2012 04:56:08 +0000

I think that although the draft mainly discusses aaaa-whitelisting, it can be more specific in section 2 on issues impacting content delivery over ipv6.

Perhaps the biggest challenge in the IPv4-to-IPv6 transition is that the two protocols are not compatible; that is, IPv4-only systems cannot talk directly to IPv6-only systems. This means no one can turn off IPv4 support until every last device they want to reach has acquired IPv6 connectivity. Unfortunately, many existing devices — including PCs running older OSes, as well as older cable and DSL modems, wireless routers, and other business and consumer electronic devices—have either limited or no IPv6 support. In other words, companies will have to support both protocols for years to come, in a long and bumpy transition period. During that time, there will effectively be two Internets, an IPv4 one and an IPv6 one, loosely bound together into a hybrid Internet by various transition technologies.

Challenges of reaching IPv6 users from IPv4 sites
Many types of Web applications rely on an end-to-end connection, where each device, household, or entity is associated with a single IP address. CGN breaks this assumption — as it creates a situation where hundreds or thousands of end users — related only by their network provider — share the same IP address, and each user’s IP address may change with every new connection. Thus, CGN cripples functions like geo-location — using the user’s IP address to determine their location, in order to personalize content or to enforce licensing restrictions, for example, and abuse mitigation — IP blacklisting or whitelisting, in order to block spammers, trolls, or other abusive users.
CGN   breaks assumptions that many of today’s Web applications rely on. In particular it affects applications, such as peer-to-peer and VoIP, which rely in some way on a unique end user IP address. Troubleshooting the issues is extremely complex and costly, as it can’t be done without the NAT operator’s help.
In order to reach IPv4 sites, IPv6 end users need to go through a NAT64 gateway. Because there may be only one or two such gateways within a network, communications may be forced through long, indirect paths. In addition, these gateways quickly become congestion points within the network, as well as easily targeted points of failure, further affecting the performance and reliability.

Challenges of reaching IPv6 users from IPv6 sites
Because the IPv6 Internet is still sparsely connected, native IPv6 communications may require longer, less direct routes than their IPv4 counterparts, resulting in slower performance and higher packet loss. This is particularly troublesome for high throughput or low latency applications such as online gaming or streaming media. In addition, a significant portion of the IPv6 Internet currently relies on tunneling traffic over IPv4, creating additional performance degradation.

So I think that content providers and application providers are no longer pondering when to enable delivery over  IPv6 but are focused on how to manage this transition in a manner that is cost-effective and efficient in the short term but takes into account long-term needs and opportunities.

Sent from my iPad

On Feb 2, 2012, at 7:05 PM, "Erik Kline" <[email-masked]<mailto:[email-masked]>> wrote:

On 2 February 2012 00:09, The IESG <[email-masked]<mailto:[email-masked]>> wrote:

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action. Please send substantive comments to the
[email-masked]<mailto:[email-masked]> mailing lists by 2012-02-15. Exceptionally, comments may be
sent to [email-masked]<mailto:[email-masked]> instead. In either case, please retain the
beginning of the Subject line to allow automated sorting.

Abstract

_______________________________________________
v6ops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/v6ops
_______________________________________________
v6ops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Fred Baker <[email-masked]>
Date: Fri, 3 Feb 2012 08:35:36 -0800

> applicability in a post- World IPv6 Launch Internet.

With respect...

The document was originally discussed in v6ops, and you chose to not comment. It went through last call there in January 2011 and was sent to the IESG. IESG review took until April, and an updated draft was posted at the end of May 2011. At IETF 81 (Quebec City) we were able to have you, the author, and some others discuss it. The IESG again decided it needed a revised draft, and that draft - in large part, a rewrite - arrived in October. v6ops had a second WGLC, in which you again declined to comment, although you may have seen Lorenzo's comments, which were picked up in a November version of the draft. Ralph and Jari finally cleared their "discuss" ballots a couple of weeks ago, and we are having a second IETF last call.

I'd like to understand your objective here. I know that you don't care for the draft, and at least at one point took it as a somewhat-personal attack. Is your objective to prevent the draft's publication entirely, or do you think that there is value in publishing it given a productive response to this comment? At what point are you willing to either participate in the public dialog or choose to not comment at all?

> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Erik Kline <[email-masked]>
Date: Sat, 4 Feb 2012 10:43:19 +0900

> I'd like to understand your objective here. I know that you don't care for the draft, and at least at one point took it as a somewhat-personal attack. Is your objective to prevent the draft's publi…

With humblest apologies...

Having spent time rereading, I think W6L is clearly an implementation
of  sections 4.5 and 5.7, or 4.4 and 5.6, depending on the
implementer.

Additionally, in retrospect, there's probably no great reason to add a
reference to a future event.  It seems to me that the most meaningful
technical observation that can actually be offered would be its
scheduled calendar date.

There's no excuse for my failing to reread afresh before commenting.
Again, my apologies,
-Erik

---

From: Joel jaeggli <[email-masked]>
Date: Wed, 08 Feb 2012 07:36:54 -0800

On 2/8/12 05:54 , Lorenzo Colitti wrote:
> On Sat, Feb 4, 2012 at 01:35, Fred Baker <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     The IESG again decided it needed a revised draft, and that draft -
>     in large part, a rewrite - arrived in October. v6ops had a second
>     WGLC, in which you again declined to comment, although you may have
>     seen Lorenzo's comments, which were picked up in a November version
>     of the draft. Ralph and Jari finally cleared their "discuss" ballots
>     a couple of weeks ago, and we are having a second IETF last call.
> 
>     I'd like to understand your objective here. I know that you don't
>     care for the draft, and at least at one point took it as a
>     somewhat-personal attack. Is your objective to prevent the draft's
>     publication entirely, or do you think that there is value in
>     publishing it given a productive response to this comment? At what
>     point are you willing to either participate in the public dialog or
>     choose to not comment at all?
> 
> 
> Ok, let me see if I can rephrase Erik's objection.
> 
> The draft needs to take World IPv6 Launch into account, because it's a
> key piece of the puzzle.
> 
> We can't publish an RFC on how to transition content to IPv6 if the RFC
> ignores the event when 5 of the top 10 websites in the world (and
> probably many more) will permanently enable IPv6 for everyone.

Ops is not marketing.

If you're saying some flag day makes the contents of the document no
longer operationally relevant after a given date, I'll take the point
but disagree.

The document in it's present form has a wider audience than the
operators at 5 of the ton 10 websites.

> Cheers,
> Lorenzo

---

From: Fred Baker <[email-masked]>
Date: Wed, 8 Feb 2012 08:02:54 -0800

What specifically would you like changed in the draft? Can you suggest text? 

On Feb 8, 2012, at 5:54 AM, Lorenzo Colitti wrote:

> On Sat, Feb 4, 2012 at 01:35, Fred Baker <[email-masked]> wrote:
> The IESG again decided it needed a revised draft, and that draft - in large part, a rewrite - arrived in October. v6ops had a second WGLC, in which you again declined to comment, although you may have seen Lorenzo's comments, which were picked up in a November version of the draft. Ralph and Jari finally cleared their "discuss" ballots a couple of weeks ago, and we are having a second IETF last call.
> 
> The draft needs to take World IPv6 Launch into account, because it's a key piece of the puzzle.
> 
> We can't publish an RFC on how to transition content to IPv6 if the RFC ignores the event when 5 of the top 10 websites in the world (and probably many more) will permanently enable IPv6 for everyone.
> 
> Cheers,
> Lorenzo

---

From: Lorenzo Colitti <[email-masked]>
Date: Wed, 8 Feb 2012 22:54:31 +0900

On Sat, Feb 4, 2012 at 01:35, Fred Baker <[email-masked]> wrote:

> The IESG again decided it needed a revised draft, and that draft - in
> large part, a rewrite - arrived in October. v6ops had a second WGLC, in
> which you again declined to comment, although you may have seen Lorenzo's
> comments, which were picked up in a November version of the draft. Ralph
> and Jari finally cleared their "discuss" ballots a couple of weeks ago, and
> we are having a second IETF last call.
>
> I'd like to understand your objective here. I know that you don't care for
> the draft, and at least at one point took it as a somewhat-personal attack.
> Is your objective to prevent the draft's publication entirely, or do you
> think that there is value in publishing it given a productive response to
> this comment? At what point are you willing to either participate in the
> public dialog or choose to not comment at all?

The draft needs to take World IPv6 Launch into account, because it's a key
piece of the puzzle.

We can't publish an RFC on how to transition content to IPv6 if the RFC
ignores the event when 5 of the top 10 websites in the world (and probably
many more) will permanently enable IPv6 for everyone.

Cheers,
Lorenzo

---

From: Mark Andrews <[email-masked]>
Date: Thu, 09 Feb 2012 08:05:48 +1100

In message <[email-masked]>,
> many more) will permanently enable IPv6 for everyone.

World IPv6 day just means Google is at 5.5 now and will go to
5.6/5.7.  It really does not change anything.  The decision to
whitelist is a subjective one, not a objective one.  Similarly the
decision to stop whitelisting is also a subjective one.

While I, and I suspect most of the list, think that whitelisting
should no longer be needed that isn't our call to make.  All we can
do is encourage people to not whitelist by running dual stack
services without using whitelisting.

Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Lorenzo Colitti <[email-masked]>
Date: Thu, 9 Feb 2012 18:25:02 +0900

> Ops is not marketing.

And if I were looking for a marketing venue, a standards body that produces
ASCII text documents read by a handful of engineers would not be high on my
list. This is not about marketing.

> longer operationally relevant after a given date, I'll take the point

I think you're missing my point.

It seems to me that approximately 30% of the non-biolerplate text in this
draft discusses DNS whitelisting. (And in fact, in its original form the
draft entirely on DNS whitelisting - hence the filename. The rest was added
later.)

Whitelisting is a practice relevant to a few large websites (since nobody
else is using it). It so happens that the websites that employ this
practice are going to stop using it, all together. Given the cost and
implications, I'd say practice is unlikely to be resurrected.

So, you decide to tell the whole story, and talk about whitelisting *and*
World IPv6 Launch. Or you can decide that whitelisting will soon be
irrelevant, and not talk about either whitelisting or World IPv6
Launch. But you can't talk about whitelisting without talking about World
IPv6 Launch, because if you do, your document is missing the key piece "how
do you remove the whitelist", and that's a disservice to its readers.

To be more specific, at least section 5.5 ("it is unclear how implementers
will judge when the network conditions will have changed sufficiently to
justify turning off DNS Resolver Whitelisting and/or what the process and
timing will be for discontinuing this practice") is now incorrect. It *is*
clear, and it's what those implementers are doing as part of World IPv6
Launch.

Does that make more sense?

Cheers,
Lorenzo

---

From: Roger Jørgensen <[email-masked]>
Date: Thu, 9 Feb 2012 19:02:43 +0100

On Thu, Feb 9, 2012 at 10:25 AM, Lorenzo Colitti <[email-masked]> wrote:
<snip>
> else is using it). It so happens that the websites that employ this practice
> are going to stop using it, all together. Given the cost and implications,
> I'd say practice is unlikely to be resurrected.
>
> irrelevant, and not talk about either whitelisting or World IPv6 Launch. But
> you can't talk about whitelisting without talking about World IPv6 Launch,
> because if you do, your document is missing the key piece "how do you remove
> the whitelist", and that's a disservice to its readers.
>

Or, the way I read you, you tell us that this entire document isn't
relevant anymore.

It cover something called whitelisting that were in use for a short
periode of time for reason no one in a few year can understand as
relevant?

-- 

Roger Jorgensen           |
[email-masked]          | - IPv6 is The Key!
http://www.jorgensen.no   | [email-masked]

---

From: Doug Barton <[email-masked]>
Date: Thu, 09 Feb 2012 14:30:23 -0800

> periode of time for reason no one in a few year can understand as

+1

-- 

	It's always a long day; 86400 doesn't fit into a short.

	Breadth of IT experience, and depth of knowledge in the DNS.
	Yours for the right price.  :)  http://SupersetSolutions.com/

---

From: Joel jaeggli <[email-masked]>
Date: Sun, 12 Feb 2012 20:25:10 -0800

On 2/9/12 01:25 , Lorenzo Colitti wrote:
> On Thu, Feb 9, 2012 at 00:36, Joel jaeggli <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     Ops is not marketing.
> 
> 
> And if I were looking for a marketing venue, a standards body that
> produces ASCII text documents read by a handful of engineers would not
> be high on my list. This is not about marketing.
>

Sorry for being so droll, I found it hard to restrain myself.

> It seems to me that approximately 30% of the non-biolerplate text in
> this draft discusses DNS whitelisting. (And in fact, in its original
> form the draft entirely on DNS whitelisting - hence the filename. The
> rest was added later.)
> 
> Whitelisting is a practice relevant to a few large websites (since
> nobody else is using it). It so happens that the websites that employ
> this practice are going to stop using it, all together. Given the cost
> and implications, I'd say practice is unlikely to be resurrected.

I do not belive that the selective (inclusive) return of A or A + AAAA
records on the basis of source address is likely to end on a particular
day. It may well for you and some others, which is fine, or you may find
it necessary again, or it may become a list of exclusions rather than
inclusions. I belive you're on record indicating as much. In any event
others may find it necessary.

> So, you decide to tell the whole story, and talk about whitelisting
> *and* World IPv6 Launch. Or you can decide that whitelisting will soon
> be irrelevant, and not talk about either whitelisting or World IPv6
> Launch. But you can't talk about whitelisting without talking about
> World IPv6 Launch, because if you do, your document is missing the key
> piece "how do you remove the whitelist", and that's a disservice to its
> readers.
> 
> To be more specific, at least section 5.5 ("it is unclear
> how implementers will judge when the network conditions will have
> changed sufficiently to justify turning off DNS Resolver Whitelisting
> and/or what the process and timing will be for discontinuing this
> practice") is now incorrect. It *is* clear, and it's what those
> implementers are doing as part of World IPv6 Launch.

Invidual service operators like you and I are likely to make decisions
on the basis of our instrumentation, we may well alter their behavior on
a uni or multilateral basis, and some of us may do so for world ipv6
launch. ipv4/v6 Transition is not something with a flag day however, and
I do not believe that the concerns embedded in the draft will be
fundamentally altered on 6/6/12.

> Does that make more sense?

yes, that doesn't imply that we're in concert however.