Subject: Re: Last Call: <draft-weil-shared-transition-space-request-14.txt> (IANA Reserved IPv4 Prefix for Shared Address Space) to BCP

From: [email-masked] (Noel Chiappa)
Date: Mon, 13 Feb 2012 15:42:58 -0500 (EST)

> From: Doug Barton <[email-masked]>

    > If the RIRs do not deny these requests there is likely to be a revolt.

On what grounds? The ISPs will come along and say 'I have X new customers,
please give me more space for them'. The former being true, on what ground can
the RIRs refuse (modulo cases like RIPE)?

    > If the IETF rightly denies this request then the ISPs are going to
    > be forced to use the proper option, 1918 space.

How? The IETF has neither police, nor an army.

	Noel

---

From: Måns Nilsson <[email-masked]>
Date: Mon, 13 Feb 2012 23:17:08 +0100

> the RIRs refuse (modulo cases like RIPE)?

RIPE NCC is not unique; IIRC there has been extensive synchronisation between RIRen
on the subject of sunset allocations. 

I'd expect any RIR to more or less laugh at the request of a /10 (the
size of network we've been told (without any proof beyond handwaving)
is required to do CGN nicely) at this stage of address depletion.

APNIC: 

As of Friday, 15 April 2011, each new or existing APNIC account holder
is only eligible to request and receive delegations totalling a maximum
/22 worth of address space from the APNIC IPv4 address pool.

ARIN: 

Has 3-month consumption cap on allocations. Apparently not so low on
space as the others.

LACNIC: 

Has a /22 cap per LIR en route in its PDP. 

RIPE: 

Has a /22 rule, as discussed earlier. 

AFRINIC: 

I can't at the moment locate their policy, more than that they have
incorporated the "last five /8's" document as governing text in their
policy set. Pointers to text welcome. 

To sum things up, we are at the stage where a /10 is a laughable
proposition. The largest usable block (bar squatting on DOD space)
for CGN is 10/8. I'd suggest planning for it. That last /22 will probably
end up as P router addresses in MPLS core, since all vendors have dragged
their feet in implementing v6 MPLS.
 
> How? The IETF has neither police, nor an army.

It is either 10/8 or squat. No other alternatives exist. I'd expect
squatting on the "wrong" /8 to be punishable as a Homeland Security
Department -related crime, if one takes the US-centric view.

Folks, we've run out. 
-- 
Måns.

---

From: SM <[email-masked]>
Date: Mon, 13 Feb 2012 14:26:08 -0800

Hi Noel,
>the RIRs refuse (modulo cases like RIPE)?

If you have X new customers and you ask a RIR to 
give you more IPv4 space, I doubt that you would 
get more space as the evaluation might require 
more information ( e.g. 
http://www.ripe.net/lir-services/resource-management/contact/ipv4-evaluation-procedures 
).

Here's a comparison of RIR policies.  Please 
refer to the document from each RIR for authoritative information.

   RIR      Period
           (months)
  AfriNIC    12      Minimum /22, no maximum
                     Demonstrate 80% efficient 
utilization of last allocated space
                     or an immediate need that 
requires more IP addresses than are
                     available in the most recent allocation.

  APNIC      12      Minimum /24, up to a maximum 
/22 of the remaining available
                     space after 15 April 2011.
                     Demonstrate 80% efficient 
utilization of all prior allocated space.

  ARIN        3      Minimum /22 for multihomed, otherwise /20, no maximum.
                     Demonstrate efficient 
utilization of all previous allocations and
                     at least 80% of the most recent allocation.

  LACNIC     12      The policy for determining 
the size of additional allocations is
                     based on the efficient 
utilization of space within a time frame
                     of 12 months.
                     Demonstrate 80% efficient 
utilization of all prior allocated space.
                     The applicant must already 
have at least one IPv6 block assigned by
                     LACNIC or, if not, must 
simultaneously request an initial IPv6 block
                     in accordance with the 
corresponding applicable policy. If an
                     applicant has already been 
assigned an IPv6 block, they shall submit
                     to LACNIC a brief document 
describing their progress in the
                     implementation of IPv6.

  RIPE               Minimum /21, no maximum.
                     Demonstrate approximately 
80% efficient utilization of all prior
                     allocated space.

                     Until 1 July 2010, up to 12 
months.  Between 1 July 2010 – 31
                     December 2010, up to nine 
months Between 1 January 2011- 31 June
                     2011, up to six months  As 
of 1 July 2011, up to three months

According to the above, you can still get an 
allocation of IPv4 addresses.  The amount depends 
on the regional policy.  Whether a /10 allocation 
is possible from the above is an exercise left to the reader.

Regards,
-sm

---

From: David Conrad <[email-masked]>
Date: Mon, 13 Feb 2012 14:36:34 -0800

Mans,

> proposition.

Other than APNIC, I don't think this is correct.  Perhaps folks from the RIRs can confirm.

> Department -related crime, if one takes the US-centric view.

I doubt this, particularly since the use of the addresses we're talking about is entirely internal.

> Folks, we've run out. 

"I'm not dead yet!" (to misquote Monty Python)

Regards,
-drc

---

From: Måns Nilsson <[email-masked]>
Date: Mon, 13 Feb 2012 23:46:05 +0100

> Other than APNIC, I don't think this is correct.  Perhaps folks from the RIRs can confirm.

Reading from policy texts, it is. What is stuffed away in the RIR dungeons
might technically support such an allocation, of course. For some time still. 
 
> I doubt this, particularly since the use of the addresses we're talking about is entirely internal.

Internal schmernal. Stuff leaks. Either by people watching allocations
and going "Hey...." or by routing slip "Hey, this block ain't 1918,
let's route it...". 
 
> "I'm not dead yet!" (to misquote Monty Python)

The rumours are persistent, though. 

-- 
Måns.