Subject: Add a link to the HTML version in i-d-announce mails ?

From: Xavier Marjou <[email-masked]>
Date: Tue, 6 Mar 2012 14:41:32 +0100

As a subscriber of the [email-masked] list, I generally prefer
reading the HTML version of the draft rather than the TXT version.

I thus often need to manually rewrite the TXT link to fetch the HTML
version of the draft. I can not believe I'm the only one.

Hence, would it be possible to also include a link like
http://tools.ietf.org/html/draft-name in the mail of the announced
draft?

Cheers,
Xavier

---

From: Julian Reschke <[email-masked]>
Date: Tue, 06 Mar 2012 14:51:51 +0100

On 2012-03-06 14:41, Xavier Marjou wrote:
> ...

+1000

---

From: Simon Perreault <[email-masked]>
Date: Tue, 06 Mar 2012 08:53:51 -0500

>> http://tools.ietf.org/html/draft-name in the mail of the announced

+INT_MAX

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Yoav Nir <[email-masked]>
Date: Tue, 6 Mar 2012 15:56:29 +0200

Even better, also add the XML2RFC output if it's available at the same time:  http://tools.ietf.org/id/draft-name.html

for example, (just picking my own latest draft as an example): http://tools.ietf.org/id/draft-nir-websec-extended-origin-02.html

I don't know which drafts get this version (perhaps those submitted along with XML?), but they're sure easier to read than TXT.

Yoav

---

From: Riccardo Bernardini <[email-masked]>
Date: Tue, 6 Mar 2012 15:02:12 +0100

>>> http://tools.ietf.org/html/draft-name in the mail of the announced

+\aleph_0 :-)

Seriously, it would be really nice to have this feature.

> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Julian Reschke <[email-masked]>
Date: Tue, 06 Mar 2012 15:04:18 +0100

> for example, (just picking my own latest draft as an example): http://tools.ietf.org/id/draft-nir-websec-extended-origin-02.html

+1

> I don't know which drafts get this version (perhaps those submitted along with XML?), but they're sure easier to read than TXT.

Indeed I'd like to understand that as well. In particular, as this 
apparently runs an outdated version of rfc2629.xslt, and then mangles 
it's output (HTML tidy maybe?) causing what's served to be invalid HTML.

Best regards, Julian

---

From: Hector <[email-masked]>
Date: Tue, 06 Mar 2012 09:07:24 -0500

+1.  This will save a few typing and clicks.

---

From: Russ Housley <[email-masked]>
Date: Tue, 6 Mar 2012 09:12:54 -0500

I would be much happier with a link to the datatracker HTML version:
https://datatracker.ietf.org/doc/draft-name/

Would this meet your needs?

Russ

---

From: Randy Bush <[email-masked]>
Date: Tue, 06 Mar 2012 23:24:15 +0900

> Would this meet your needs?

then we can each have our cake and eat it too.  but i fear folk may just
want the bright shiny.

randy

---

From: Dave Crocker <[email-masked]>
Date: Tue, 06 Mar 2012 06:31:22 -0800

+1

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Riccardo Bernardini <[email-masked]>
Date: Tue, 6 Mar 2012 15:36:24 +0100

>> Would this meet your needs?

Yes, it would be fine.  From my point of view the two versions are
almost equivalent, this latter maybe is more flexible (at the expense
of one more click, which is negligible)

---

From: Tony Hansen <[email-masked]>
Date: Tue, 06 Mar 2012 09:44:07 -0500

It would be acceptable to me, especially since there's a link from there 
to the tools HTML version. (Look for the "html" link at the top.)

     Tony Hansen

---

From: Xavier Marjou <[email-masked]>
Date: Tue, 6 Mar 2012 16:11:06 +0100

With a link like https://datatracker.ietf.org/doc/draft-name/ (e.g.
https://datatracker.ietf.org/doc/draft-nir-websec-extended-origin/ ),
I will most often then click again on the html top right link. But I'm
fine with it too.

---

From: Yoav Nir <[email-masked]>
Date: Tue, 6 Mar 2012 17:26:50 +0200

The XML2RFC version is not linked from there. If that was added to the "Other versions" field, that would be great.

On Mar 6, 2012, at 5:11 PM, Xavier Marjou wrote:

> Scanned by Check Point Total Security Gateway.

---

From: Warren Kumari <[email-masked]>
Date: Tue, 6 Mar 2012 11:01:26 -0500

> version of the draft. I can not believe I'm the only one.

Yup, you are not the only one -- this annoyed me sufficiently that I finally gave in and wrote a Chrome extension to do this for me.
Basically it watches the address bard and looks for www.ietf.org/id/<foo> and, depending on the setting in the options page, will redirect to the Tools or Datatracker.

So, if I follow a link like http://www.ietf.org/id/draft-ietf-idr-as0-03.txt the extension will notice and rewrite it to http://tools.ietf.org/html/draft-ietf-idr-as0-03 (or https://datatracker.ietf.org/doc/draft-ietf-idr-as0/ ).

This is my first extension/ javascript, and it's not particularity polished, etc but if folk are interested it is on the tools page ( http://tools.ietf.org/ ) or, direct: https://chrome.google.com/webstore/detail/aiccdpabeagpjcebilebhlifplfkinao

Share and enjoy.
W

---

From: Barry Leiba <[email-masked]>
Date: Tue, 6 Mar 2012 12:44:45 -0500

> of one more click, which is negligible)

Re: one more click...

https://datatracker.ietf.org/cookies/

Note the third item.

Barry

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 6 Mar 2012 18:33:01 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Xavier Marjou
> Sent: Tuesday, March 06, 2012 5:42 AM
> To: IETF Discussion
> Subject: Add a link to the HTML version in i-d-announce mails ?
> 

...or a link to the datatracker page, which in turn has links to all available formats?

-MSK

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 6 Mar 2012 18:33:54 +0000

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Russ Housley
> Sent: Tuesday, March 06, 2012 6:13 AM
> To: Xavier Marjou
> Cc: IETF Discussion
> Subject: Re: Add a link to the HTML version in i-d-announce mails ?
> 

Serves me right for not reading the thread before replying.

+ULONG_MAX, so there.

-MSK

---

From: Julian Reschke <[email-masked]>
Date: Tue, 06 Mar 2012 22:44:29 +0100

> The XML2RFC version is not linked from there. If that was added to the "Other versions" field, that would be great.

Indeed. HTMLized plain text is progress over plain text, but properly 
generated HTML is better.

But I fear we're getting close to our beloved permathread.

Best regards, Julian

---

From: Yoav Nir <[email-masked]>
Date: Wed, 7 Mar 2012 00:02:03 +0200

> But I fear we're getting close to our beloved permathread.

Pictures in RFCs?

---

From: Russ Housley <[email-masked]>
Date: Tue, 6 Mar 2012 17:15:39 -0500

> Pictures in RFCs?

Come to the RFCFORM BOF to voice opinions on this topic.

Russ

---

From: Tim Bray <[email-masked]>
Date: Tue, 6 Mar 2012 15:31:52 -0800

Not that voicing opinions on this topic has ever done any good. -T

---

From: Barry Leiba <[email-masked]>
Date: Tue, 6 Mar 2012 19:43:37 -0500

> Yup, you are not the only one -- this annoyed me sufficiently that I finally gave
> in and wrote a Chrome extension to do this for me.
> Basically it watches the address bard and looks for www.ietf.org/id/<foo> and,
> depending on the setting in the options page, will redirect to the Tools or Datatracker.

Inspired by that, I wrote a completely trivial (one-line) Greasemonkey
script this afternoon, to do it for Firefox.  It's so short that I'll
just paste it below.  Works nicely.

Barry

--------------------------------------------------
// ==UserScript==
// @name           IETF draft html
// @namespace      ...whatever...
// @description    Redirect txt drafts to html
// @include        http://www.ietf.org/id/*
// @include        https://www.ietf.org/id/*
// ==/UserScript==

(function () {
    window.location = new
String(window.location).replace("www.ietf.org/id",
"tools.ietf.org/html").replace(".txt", "");
})();
--------------------------------------------------

---

From: Warren Kumari <[email-masked]>
Date: Tue, 6 Mar 2012 20:03:26 -0500

> just paste it below.  Works nicely.

Oooh, very cool….

W

--
Don't be impressed with unintelligible stuff said condescendingly.
    -- Radia Perlman.