Subject: Time in the Air

From: Mark Nottingham <[email-masked]>
Date: Fri, 31 May 2013 19:59:16 +1000

In an attempt to inject some data into the discussion, I wrote a bit of code that figures out how much time, given your home city, you would have spent in the air if you'd attended all IETF meetings since IETF74 (i.e., from 2009 onwards).

The first column is the "home" airport.

The second column is the great circle time between the home airport and the nearest large airport to the IETF meeting, hhh:mm. This doesn't count things like transit time, taxiing, takeoff and landing overhead, indirect routing, etc. As such, this is an ideal number; the only way to achieve anything close to it is to have a private jet (with exceptional range).

The third column is the time (hhh:mm) using the shortest-time routing on a travel booking engine. This is first-takeoff-to-last-landing time.

Both numbers assume round trip between "home" and the IETF airports.

SFO  204:10  282:04  // San Francisco
BOS  197:42  297:38  // Boston
ATL  205:44  297:28  // Atlanta
ANC  197:12  345:54  // Anchorage
LHR  198:02  249:44  // London
FRA  202:10  255:22  // Frankfurt
FCO  223:52  283:04  // Rome
SVO  211:28  287:14  // Moscow
TLV  264:12  334:22 // Israel
DXB  293:26  344:34 // Dubai
NRT  259:00  314:38  // Tokyo
HKG  296:38  359:22  // Hong Kong
BLR  332:28  448:24  // Bangalore
MEL  450:28  556:04  // Melbourne
AKL  442:24  569:04  // Auckland
JNB  414:30  498:22  // Johannesburg
EZE  411:10  522:56  // Buenos Aires
GIG  381:56  488:32  // Rio de Janeiro

Draw your own conclusions, of course. 

One observation is that there's a 3+ days-in-the-air per year variance if you're a full-time participant, depending on where you live. I.e., more than one day-per-meeting difference, on average. In the air alone.

Another is that, perhaps surprisingly, the "closest" homes to all meetings are in Europe, not the US (at least by shortest-time routing).

I can run other airports upon request, as well as make source available, but will do so conservatively, so as not to incur the ire of the services I'm (ab)using.

Regards,

P.S. The IETF airports chosen were:

  IETF_airports: [
    "ORL",
    "ATL",
    "YVR",
    "CDG",
    "TPE",
    "YQB",
    "PRG",
    "PEK",
    "AMS",
    "LAX",
    "HIJ",
    "ARN",
    "SFO"
  ],

--
Mark Nottingham   http://www.mnot.net/

---

From: Fernando Gont <[email-masked]>
Date: Fri, 31 May 2013 12:28:28 +0200

On 05/31/2013 11:59 AM, Mark Nottingham wrote:
> In an attempt to inject some data into the discussion, I wrote a bit
> of code that figures out how much time, given your home city, you
> would have spent in the air if you'd attended all IETF meetings since
> IETF74 (i.e., from 2009 onwards).
> 
> The second column is the great circle time between the home airport
> and the nearest large airport to the IETF meeting, hhh:mm. This
> doesn't count things like transit time, taxiing, takeoff and landing
> overhead, indirect routing, etc. As such, this is an ideal number;
> the only way to achieve anything close to it is to have a private jet
> (with exceptional range).

Could you please elaborate a bit more on the meaning of the second column?

Thanks!

-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 31 May 2013 21:01:58 +1000

> Could you please elaborate a bit more on the meaning of the second column?

It's the duration given by a reputable travel search engine for the end-to-end trip, from when the first plane takes off until when the last plane lands, including transit time, etc., and a fixed buffer for getting to the airport, etc. 

Still not really accurate, but it helps factor in indirect routing and the like. The shortest available current routing is chosen; that routing may not actually be available during the meeting, etc.

Cheers,

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 31 May 2013 14:38:49 +0200

Wow, that's real science at work...

Sorting by the relevant column (I don't own a private jet):

> LHR  249:44  // London
> FRA  255:22  // Frankfurt
> SFO  282:04  // San Francisco
> FCO  283:04  // Rome
> SVO  287:14  // Moscow
> ATL  297:28  // Atlanta
> BOS  297:38  // Boston
> NRT  314:38  // Tokyo
> TLV  334:22  // Israel
> DXB  344:34  // Dubai
> ANC  345:54  // Anchorage
> HKG  359:22  // Hong Kong
> BLR  448:24  // Bangalore
> GIG  488:32  // Rio de Janeiro
> JNB  498:22  // Johannesburg
> EZE  522:56  // Buenos Aires
> MEL  556:04  // Melbourne
> AKL  569:04  // Auckland

I'll use this list when planning my next relocation :-)

Of course, this doesn't include time-to-airport, so you can immediately discount London.

It's clear that you want to live in or near Frankfurt.

San Francisco, Rome, and Moscow (!) come in as a second cluster.
The fact that both SFO and SVO are in there (and Tokyo, Boston aren't half bad either) shows that we are getting close to properly covering the belt between ~30°N (Taipei @ 25°N) and ~50°N (the Stockholm IETF being the northernmost recent exception, I think).  It gets very thin to the south of that...

Grüße, Carsten

---

From: Dave Cridland <[email-masked]>
Date: Fri, 31 May 2013 13:55:14 +0100

> Of course, this doesn't include time-to-airport, so you can immediately

Well, you say that, but I now know why Alexey moved from Moscow to Kingston
(40 minutes to LHR on the X26).

Dave.

---

From: <[email-masked]>
Date: Fri, 31 May 2013 15:03:17 +0100

clearly, all IETF meetings should be in Cape Town, Wellington, or Perth, because more time in the air means more time without interruption where drafts can be read before the meeting.

quiet time on a plane can be productive time.

Lloyd Wood
http://sat-net.com/L.Wood/

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Mark Nottingham [[email-masked]]
Sent: 31 May 2013 10:59
To: ietf Discussion
Subject: Time in the Air

Regards,

  IETF_airports: [
    "ORL",
    "ATL",
    "YVR",
    "CDG",
    "TPE",
    "YQB",
    "PRG",
    "PEK",
    "AMS",
    "LAX",
    "HIJ",
    "ARN",
    "SFO"
  ],

---

From: Riccardo Bernardini <[email-masked]>
Date: Fri, 31 May 2013 16:18:45 +0200

> quiet time on a plane can be productive time.

Then I would suggest Antarctica as permanent location for future IETF
meetings.  :-) Maybe the only drawback is hotel availability, but
nothing that a handful of tents and sleeping bags cannot cure...
Also, penguins are cute :-)

---

From: Ted Lemon <[email-masked]>
Date: Fri, 31 May 2013 14:36:13 +0000

> Also, penguins are cute :-)

This would also eliminate the July IETF, since it's too cold to travel to Antarctica then.   So the savings in air travel time would no doubt be substantial.

---

From: Warren Kumari <[email-masked]>
Date: Fri, 31 May 2013 13:47:41 -0400

> quiet time on a plane can be productive time.

Until more airlines start offering in-flight Internets…

I treasure my time on a plane, as it mean I can actually write some draft, etc. Once there is Internet -- yes, I *could* always just turn off my Wifi / not sign up for the in-flight bits, but I'm not disciplined enough.
I end up deciding I quickly need to look up some reference and then: http://xkcd.com/214/

W 

> Subject: [IETF] Time in the Air
> 

-- 
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.  
    -- J.R.R. Tolkien

---

From: Scott Brim <[email-masked]>
Date: Fri, 31 May 2013 14:12:06 -0400

If people are interested, we could launch a new service: dirigible tours
with Internet access.  We'll have multiple airships, one for each set of
related meeting rooms.  Of course we'll have audio, jabber and all the
virtualization tools we have today.  We'll amble along at some moderate
speed, docking every night in order to take on supplies and allow people to
switch airships, and docking for a full week in some major city three times
each year.  The IETF will slowly work its way around the world, following
the winds and weather.

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Fri, 31 May 2013 15:13:27 -0300

We now live in a blessed, sort-of, time, where you perhaps have
in-flight Internet but no-one presumes you do, so you get the Internet
and its benefits without the constant distraction of other people
calling, emailing and expecting immediate answers and all that :D

Completely off-topic too, but since I live in the southernmost capital
city of the world, and certainly not the best served by airlines, I use
*a lot* the services of the Great Circle Mapper, http://gcmap.com in
order to estimate flight times and shortest routes.

To estimate flight times, you need to enter your speed. Completely
unscientific experimenting on my part yielded that for short flights
(less than 2.5 hours) you should use 750 km/h and for longer flights
either 800, 850 or even 900. This is good enough for getting quite
accurate results. This takes into account the low speeds phases of
flight (climb out and landing approach).

Oh... and your results are fully bookmark-able, so you don't need to
reenter data to revisit a previously analyzed route.

E.g. two possible routes for my next IETF trip:

http://www.gcmap.com/dist?P=MVD-CDG%2CCDG-TXL&DU=km&DM=&SG=850&SU=kph
http://www.gcmap.com/dist?DU=km&P=MVD-GRU,+GRU-FRA,+FRA-TXL&SG=850&SU=kph

( I haven't really checked whether the FRA-TXL flight actually exists,
just an example )

The guy is going to completely hate me for the traffic he is going to get :D

cheers!

~Carlos

---

From: Jorge Amodio <[email-masked]>
Date: Fri, 31 May 2013 13:24:41 -0500

> city of the world, and certainly not the best served by airlines

When you moved to NZ ?  ;-)

-J

---

From: Dave Crocker <[email-masked]>
Date: Fri, 31 May 2013 20:54:44 +0200

On 5/31/2013 8:12 PM, Scott Brim wrote:
> We'll have multiple airships, one for each set of related meeting rooms.

is dirigible a new term of endearment for an AD?

d/
-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Scott Brim <[email-masked]>
Date: Fri, 31 May 2013 15:18:46 -0400

> is dirigible a new term of endearment for an AD?

Obviously the ADs have a small helicopter so they can get between
dirigibles.

---

From: joel jaeggli <[email-masked]>
Date: Fri, 31 May 2013 12:25:26 -0700

> Obviously the ADs have a small helicopter so they can get between 
It's more like Icarus...

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Fri, 31 May 2013 16:56:49 -0300

You are right, Wellington is almost 7 degrees south of Montevideo,
although I hope it's better served by airlines :D

cheers!

~C.

---

From: Elwyn Davies <[email-masked]>
Date: Fri, 31 May 2013 21:32:11 +0100

> Obviously the ADs have a small helicopter so they can get between 
Don't they use the ADs (Area Drones) controlled from the IESG bunker?

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 1 Jun 2013 10:01:55 +1000

> GIG  381:56  488:32  // Rio de Janeiro

... and upon request:

PEK   249:56   308:40  // Beijing
LAX  209:30  284:42  // Los Angeles
JFK  199:04  272:14  // New York
ORD  194:08  277:26  // Chicago

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 1 Jun 2013 10:33:23 +1000

... and now, looking forward to our announced upcoming meeting locations (just the shortest route numbers, not great circle):

LHR  145:30  // London
JFK  150:20  // New York
SFO  155:54  // San Francisco
FRA  156:08  // Frankfurt
ATL  158:10  // Atlanta
BOS  159:34  // Boston
ANC  181:56  // Anchorage
FCO  183:18  // Rome
NRT  186:40  // Tokyo
SVO  188:00  // Moscow
PEK  205:34  // Beijing
TLV  223:20  // Israel
DXB  225:30 // Dubai
HKG  236:20  // Hong Kong
BLR  286:30 // Bangalore
GIG  286:32  // Rio de Janeiro
EZE  306:00  // Buenos Aires
JNB  322:38  // Johannesburg
AKL 323:58  // Auckland
MEL  326:06  // Melbourne

  IETF_airports: [
    "TXL",
    "YVR",
    "LHR",
    "YYZ",
    "HNL",
    "DFW",
    "PRG",
    "NRT"
  ]

Cheers,

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Sat, 1 Jun 2013 00:44:16 +0000

> clearly, all IETF meetings should be in Cape Town, Wellington, or Perth, because more time in the air means more time without interruption where drafts can be read before the meeting.

Heavens no. All meetings should be in Santa Barbara, so I don't have to board an airplane at all.

---

From: Randy Bush <[email-masked]>
Date: Fri, 31 May 2013 17:49:45 -0700

> to board an airplane at all.

i too, but tokyo.  induce.  answer, remote participation.  i hope that a
decade from now many of us will not need to fly.

randy

---

From: Ted Lemon <[email-masked]>
Date: Sat, 1 Jun 2013 02:10:09 +0000

On May 31, 2013, at 4:32 PM, Elwyn Davies <[email-masked]<mailto:[email-masked]>> wrote:
Don't they use the ADs (Area Drones) controlled from the IESG bunker?

Nope, ADs are autonomous.

---

From: Ted Lemon <[email-masked]>
Date: Sat, 1 Jun 2013 02:17:20 +0000

> decade from now many of us will not need to fly.

We could just always meet in Tokyo.   I'd be down with that...

:)