Subject: Issues in wider geographic participation

From: "John Levine" <[email-masked]>
Date: 27 May 2013 05:52:57 -0000

I think this is a summary of the issues people have mentioned that
discourage participation from LDCs, in rough order of importance.

* People aren't aware the IETF exists, or what it does, or that it has
an open participation model

* People don't read and write English well enough to be comfortable
participating

* People are unaccustomed to and perhaps uncomfortable expressing
overt disagreement

* People don't think they have anything to contribute to an organization
that is mostly people from rich countries

* People don't have adequate Internet access for mail, or to use the
remote participation tools

I have to say that I don't see one or two meetings in South America
addressing any of these.  Given that the incremental cost to the
participants, compared to meeting in North America, would likely be on
the order of a million dollars, it seems to me very likely that there
are better ways to spend the money.

For example, if language and net access is a problem, it might be
interesting to set up a remote participation center in B.A. during one
of the North American meetings (it's one time zone off from Toronto)
with screens and cameras, paid interpreters, and a few volunteers to
help explain what's going on.

R's,
John

---

From: Melinda Shore <[email-masked]>
Date: Sun, 26 May 2013 22:14:42 -0800

On 5/26/13 9:52 PM, John Levine wrote:
> addressing any of these. 

I don't, either.  However,

> Given that the incremental cost to the

It also seems unlikely to me that that million dollars is otherwise
available.

I like the idea of setting up a remote participation center (doubly-
so if one or more very experienced IETFers who spoke the local language
could be on-site) but it seems very unlikely to me that, say, a Frobnitz
Networks employee would be able to convinced Frobnitz Networks to send
the $400 saved by not going to Buenos Aires to such an undertaking.

Melinda

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 27 May 2013 12:54:23 +0200

Hi John,

I agree and I will add, that What makes that participant continue to
volunteer, or even witness/read the ietf work process? Making someone
interested to do something freely is not an easy task. The difficulty
is how to make that individual participate with value, he/she may need
help to notice that *IETF needs* their regional-participation.

Example, I got once a response that IETF or WG chair's jobs are not to
educate others, but who said that IETF is better educated or that WG
chairs are better educated than others. It always depends on the
relativity of education with the region needs, not only eduaction
related to the Internet technology.

I think we *need* in IETF to gain all best educated people of
world-regions into IETF (volunteering), so that we make the Internet
better for the WORLD, because technology SHOULD follow the
community-regional *needs*. Not that we need to gain best
standard/technology experts to make all regions follow the
technology-product requirements, because will may never be *used* that
way :-)

Comments below,

AB

> an open participation model

Also IMHO, the IETF is not aware of existance of Internet
community-regional *needs* for their better Internet technology
future,

> * People don't read and write English well enough to be comfortable

That is not an issue, well educated people around the world know
english reasonably, but the problem is that many of current IETF
participants like to read correct english, hope they change to adapt
to the World's English.
> * People are unaccustomed to and perhaps uncomfortable expressing

That is true, but mostly Chairs and editors are responsible to make
that continue or stop.
> that is mostly people from rich countries

This point is important, please read my addition above.
> remote participation tools

Yes that is true, but also we need people like old participants, or
98% of participants to get use to participating remotely at IETF
meetings. I don't want to see complains on journey expenses of money
but of spending-time is ok :Z
> are better ways to spend the money.

I don't care how much money spent, we SHOULD focus on how much time
gained by IETF and how much volunteer-time spent for IETF. Attendance
can spend the same time remotely, the World is well connected now,
> help explain what's going on.

I think the problem is contribution access to IETF. We need centers to
increase access to documents-produced per regions, centers to increase
participants per region, centers to increase remote users per regions,
etc.

---

From: Arturo Servin <[email-masked]>
Date: Mon, 27 May 2013 08:52:42 -0300

John,

	Good summary.

	I would add a "steep learning-curve" to start participating. It takes time to get conformable in participating in mailing list and reviewing drafts for I think two reasons. One is to get know how the IETF works, and another to catch-up in knowing the topic in relation with other WG participants.

	About the remote hub I think it would be good to give it a try.

Regards,
as

---

From: Dave Crocker <[email-masked]>
Date: Mon, 27 May 2013 14:07:57 +0200

> 	About the remote hub I think it would be good to give it a try.

I'm increasingly intrigued by this idea.  It could be interesting to try 
to formulate a serious proposal for this, with enough detail to qualify 
as a functional specification.  The easy part is specifying audio/video 
streams support.  More challenging is to get the personal and personnel 
support figured out.

And should it have some means of assisting discussions outside of the 
bof/wg/plenary sessions?

What else?

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Jari Arkko <[email-masked]>
Date: Mon, 27 May 2013 15:15:06 +0300

John,

> remote participation tools

Thanks for sending out a list of potential issues.

I think there may be one issue missing from the list. At the end of the day, what tends to drive people actual, concrete benefit to themselves or their organisations. A drive that is so big that it forces you to cross language and other barriers and make at least a time investment in participation. As an example, the number of Chinese participants has increased rapidly in the IETF. Why? We probably didn't suddenly get much better at welcoming new people at the IETF, but the new participants felt that work on the Internet is important to them personally, and their organisations felt that they need to be part of making Internet standards. This isn't very surprising, given, for instance, the rise of the Chinese technology industry to a very visible role in the world.

So I feel that the issue in many cases is simpler than the ones in the list: "What's in it for me"? This obviously has to do with the role of vendors in the IETF and the distribution of tech industry in the world. It may also have something to do with doing things that are important. I'm sure we could be working on topics that are even better aligned to what the world needs… if the people who need them were here to tell us :-)

The IETF can't change the distribution of industries in the world, but we can, for instance, focus on the vendors that are there or work more on topics that are interesting for the operational folks. The latter would be a good idea for the IETF, anyway. 

> of the North American meetings (it's one time zone off from Toronto)

We've been looking at setting up something like that (not for BA specifically).

Jari

---

From: Arturo Servin <[email-masked]>
Date: Mon, 27 May 2013 09:17:47 -0300

Translation?

	Also, it would be important that the "local" people/helpers could do an introduction to what it is the ietf, how to send comments in the remote participation, to the list, what's a WG etc. It may sound a bit bureaucratic, but if we want to have these remote people to start sending emails, comments, reviewing draft we need to break the "ice" somehow. It does not have to be extensive, a short intro could be enough.
	
	About a serious proposal, are you thinking in an I+D, wg or something coming from the IESG, IAOC?

/as

On 27 May 2013, at 09:07, Dave Crocker wrote:

> I'm increasingly intrigued by this idea.  It could be interesting to try to formulate a serious proposal for this, with enough detail to qualify as a functional specification.  The easy part is specifying audio/video streams support.  More challenging is to get the personal and personnel support figured out.
> 
> And should it have some means of assisting discussions outside of the bof/wg/plenary sessions?
> 
> What else?
> 
> d/
> 
> -- 
> Dave Crocker

---

From: Scott Brim <[email-masked]>
Date: Mon, 27 May 2013 08:22:34 -0400

Add: like many organizations around the world including the USA, they don't
think it's worth the huge effort to develop standards when they can rely on
others to do so well enough for their needs.

---

From: Nthabiseng Pule <[email-masked]>
Date: Mon, 27 May 2013 14:33:25 +0200

as,

I am new to the IETF.  I would like to contribute any way I can, but the learning curve seems steep indeed. I am from an LCD country.  I have the necessary resources but I just don't know where to start.

Some guidance would be welcome. I am reading on stuff and hope that one day I will be able to make some meaningful contribution.

Nthabiseng Pule

---

From: Rumbidzayi Gadhula <[email-masked]>
Date: Mon, 27 May 2013 14:55:49 +0200

Ditto.

On 27 May 2013 14:33, Nthabiseng Pule <[email-masked]> wrote:

> as,
>
> I am new to the IETF.  I would like to contribute any way I can, but the
> learning curve seems steep indeed. I am from an LCD country.  I have the
> necessary resources but I just don't know where to start.
>
> Some guidance would be welcome. I am reading on stuff and hope that one
> day I will be able to make some meaningful contribution.
>
>
> Nthabiseng Pule
>
>
>
> >    I would add a "steep learning-curve" to start participating. It takes
> time to get conformable in participating in mailing list and reviewing
> drafts for I think two reasons. One is to get know how the IETF works, and
> another to catch-up in knowing the topic in relation with other WG
> participants.
> >

---

From: Yoav Nir <[email-masked]>
Date: Mon, 27 May 2013 14:13:13 +0000

LCD?

Anyway, What I found most useful when I was starting out 9 years ago, was to look over the list of areas and working groups ( http://tools.ietf.org/area/ ) and find out which of them are working on something that is of interest to me. In my case it was mostly the security area, and the IPsec working group, since that is what I was working on in my day job. I subscribed to that list and some others that were also related to what I was working on (TLS, PKIX).

So the best thing is to subscribe to the mailing lists, both those that interest you personally and those that are of interest to your employer (if there are such groups). 

Step 2 is to lurk for a couple of weeks at least, and just read what others are posting. If they're talking about a particular draft, it's easy to find on one of the IETF sites and read it. So you read the drafts, and read what people are saying about the drafts. This teaches you both about what the group is working on, and the (for lack of a better term) "political" part - who are the participants and what are they like.  You might also want to read the Tao document, although different groups have varying dynamics. 

After a while, you've read the drafts, you've read what some people are saying, and you may have formed an opinion, either about the draft itself, or about one of the comments. That's a good time to speak up by sending a message to the list. Maybe the draft got something wrong. Maybe the comment is only correct in certain contexts, but doesn't describe some situation you're familiar with. Maybe in reading the draft you find it hard to figure out what an implementation should do in a certain case, and you present the case, and ask that it be clarified. Maybe the proposed protocol would require clients, servers, or middleboxes to allocate more memory than implementations that you know can afford. Such comments, and even better, proposed fixes are how you build a reputation in the IETF for knowing your stuff. You can also volunteer to review a whole document, or volunteer to write a missing section. That is how you build a reputation for being useful. Both are necessary for success in the IETF.

Step 4 is when you have an idea of your own, or you read someone else's idea and you want to participate. In that case you either write your own draft or join someone else in writing one. It's often not enough to just write it. You also have to get people to read it, post about it to the correct lists, and in general "sell" it and gather support. It is at about that time that you start to feel the need to attend meetings, but you can get some things done even without it.

Hope this helps

Yoav

---

From: Dave Crocker <[email-masked]>
Date: Mon, 27 May 2013 16:23:29 +0200

On 5/27/2013 4:13 PM, Yoav Nir wrote:
> Anyway, What I found most useful when I was starting out 9 years ago,

One might wish for a document that gives such guidance to folk who are 
new to the IETF.

And indeed...

      The Tao of IETF: A Novice's Guide to the Internet Engineering
      Task Force

      http://www.ietf.org/tao.html

If the content needs to be improved, let's do it!

d/

---

From: SM <[email-masked]>
Date: Mon, 27 May 2013 07:15:17 -0700

Hola Arturo,
At 05:17 27-05-2013, Arturo Servin wrote:
>         Also, it would be important that the "local" people/helpers 
> could do an introduction to what it is the ietf, how to send 
> comments in the remote participation, to the list, what's a WG etc. 
> It may sound a bit bureaucratic, but if we want to have these 
> remote people to start sending emails, comments, reviewing draft we 
> need to break the "ice" somehow. It does not have to be extensive, 
> a short intro could be enough.

I like what you said about breaking the ice.  As mentioned above, 
having local people would help.  There is a Newcomers tutorial which 
explains what is a working group, what is the IETF, etc.

Joel Jaeggli mentioned that a regional NOG is not fertile ground for 
new IETF participants.  Is LACNOG fertile ground for new IETF participants?

The "sending email, comments, reviewing draft" is the really 
difficult part.  My uneducated guess is that it would takes months of 
work.  It's not as negative as it sounds if you consider that 
overcoming the barrier of entry might usually take over a year.

Could you ask the people who attended the talk ( 
http://www.youtube.com/watch?v=L_zacX9DcZA ) to provide some feedback 
about it to edu-discuss mailing list?

Regards,
-sm

---

From: Michal Krsek <[email-masked]>
Date: Mon, 27 May 2013 17:14:55 +0200

Hi,

> I'm increasingly intrigued by this idea.  It could be interesting to 
> try to formulate a serious proposal for this, with enough detail to 
> qualify as a functional specification.  The easy part is specifying 
> audio/video streams support.  More challenging is to get the personal 
> and personnel support figured out.

I think most of research/university networks are facing same challenge. 
Remote class setup is exactly what we need (with support of back a/v 
channel). Not a rocket science, but can be expensive in case of support 
in number of parallel tracks.

There is also a question if IETF wants to cover only room-to-room setup 
or want to cover room-to-desktop scenario.

> And should it have some means of assisting discussions outside of the 

Having a mechanism for "voting" has also some value.

my $0.02

             Regards
                 Michal

---

From: Yoav Nir <[email-masked]>
Date: Mon, 27 May 2013 15:14:54 +0000

On May 27, 2013, at 5:23 PM, Dave Crocker <[email-masked]> wrote:

> One might wish for a document that gives such guidance to folk who are new to the IETF.
> 
> And indeed...
> 

Yes, and for extra credit you can read RFC 4144.

I find it hard to improve on the Tao, but I think that its target audience are people who are ready to plunge - review documents, attend meetings, write drafts. It took me over a year of mostly lurking and little discussion to get there. Others may be quicker. 

I've also found that it's hard to make generalizations about working groups and their associated mailing lists. Some are low-traffic, some have 50 messages a day. Some discuss protocols in abstract terms, while others take the "running code" part seriously. Some have dominant chairs that moderate the discussion such that all threads become dialogs with the chairs, while in others the chairs move out of the way to let the discussion flow. Some have dominant experts and everyone waits for their (final?) word on the subject, while at others not only everyone may speak, but almost everyone is listened to.

Regardless of what we would like groups to be like, I think it's important - particularly for a newcomer - to lurk for a while and get a "feel" for the working group. Otherwise you get into arguments with the local crank that everyone else knows to ignore (I've done this lots and lots of times).

Another think I've learned is that you don't necessarily end up being involved in the things you came into the IETF for. I came to the IETF to follow things that were important to my part of the company: IPsec, TLS, PKIX. I ended up contributing in MSec, and finally chairing the WebSec group, which is really far away from my day job. Interestingly, a lot of the same people show up in different working groups, so it works very well to do work in one group, while still following the groups that you came in for. IOW my ability to follow the groups that are related to my day job is enhanced by being active in other working groups. That was kind of surprising to me at first.

So like the Tao says, take the plunge. The more you're involved in something, the more you can do in other things. Much of being effective in the IETF is about knowing people and making yourself useful to them.

Yoav

---

From: Jorge Amodio <[email-masked]>
Date: Mon, 27 May 2013 10:41:56 -0500

Translation ?? This a very old discussion and moot point, people that have interest to participate in this type of international forums and processes SHOULD learn English.

-Jorge

---

From: "John R Levine" <[email-masked]>
Date: 27 May 2013 11:48:24 -0400

> LCD?

LDC, Less Developed Country, what used to be called the third world, now 
that the second has been bought by the first.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
"I dropped the toothpaste", said Tom, crestfallenly.

---

From: Andy Bierman <[email-masked]>
Date: Mon, 27 May 2013 09:10:11 -0700

Hi Jari,

On Mon, May 27, 2013 at 5:15 AM, Jari Arkko <[email-masked]> wrote:

> I think there may be one issue missing from the list. At the end of the
> day, what tends to drive people actual, concrete benefit to themselves or
> their organisations. A drive that is so big that it forces you to cross
> language and other barriers and make at least a time investment in
> participation. As an example, the number of Chinese participants has
> increased rapidly in the IETF. Why? We probably didn't suddenly get much
> better at welcoming new people at the IETF, but the new participants felt
> that work on the Internet is important to them personally, and their
> organisations felt that they need to be part of making Internet standards.
> This isn't very surprising, given, for instance, the rise of the Chinese
> technology industry to a very visible role in the world.
>
> So I feel that the issue in many cases is simpler than the ones in the
> list: "What's in it for me"? This obviously has to do with the role of
> vendors in the IETF and the distribution of tech industry in the world. It
> may also have something to do with doing things that are important. I'm
> sure we could be working on topics that are even better aligned to what the
> world needs… if the people who need them were here to tell us :-)
>
>

This is the most important factor and trumps all other combined.
If the standards work is relevant to your business or research then
the probability that you will participate in the IETF goes way up.

I think many people on this list forget how different doing engineering
in the IETF is from engineering for a private enterprise. Tasks that take
1 or 2 months in a private enterprise often take 1 or 2 years (or more!).
Competitors working on a standard have a completely different set
of incentives than employees working on a product, so agreement
on standards is much harder to achieve.

Newbies can have a hard time adjusting to these differences.

> The IETF can't change the distribution of industries in the world, but we
> can, for instance, focus on the vendors that are there or work more on
> topics that are interesting for the operational folks. The latter would be
> a good idea for the IETF, anyway.
>

Andy

---

From: Arturo Servin <[email-masked]>
Date: Mon, 27 May 2013 13:18:24 -0300

On 5/27/13 11:15 AM, SM wrote:
> 
> Joel Jaeggli mentioned that a regional NOG is not fertile ground for new
> IETF participants.  Is LACNOG fertile ground for new IETF participants?

	I guess so.

	We have doing some efforts in the past and we are planning to do more.
You will see some recurrent participants to both places (ietf and lacnog).

> 
> The "sending email, comments, reviewing draft" is the really difficult
> part.  My uneducated guess is that it would takes months of work.  It's
> not as negative as it sounds if you consider that overcoming the barrier
> of entry might usually take over a year.

	It is no negative in deed. It is just plain hard.

> about it to edu-discuss mailing list?

	Sure, I will do that.

Regards,
as

---

From: Arturo Servin <[email-masked]>
Date: Mon, 27 May 2013 13:24:09 -0300

> Translation ?? This a very old discussion and moot point, people that have interest to participate in this type of international forums and processes SHOULD learn English.

	Another barrier.

	Anyway we are talking about remote participation only.

.as

---

From: "John R Levine" <[email-masked]>
Date: 27 May 2013 12:30:24 -0400

>> Translation ?? This a very old discussion and moot point, people that 
>> have interest to participate in this type of international forums and 
>> processes SHOULD learn English.

> 	Anyway we are talking about remote participation only.

You guys would know better than us gringos, but how likely is it that 
having translation available for live sessions would encourage people to 
use their limited English to work through drafts and try some e-mail?

Regards,

---

From: Arturo Servin <[email-masked]>
Date: Mon, 27 May 2013 13:37:23 -0300

The idea that I had for this remote participation hub was to "break the
ice". I saw no problem to provide some facilities to newcomers are more
comfortable. Perhaps, later that would encourage them to improve their
English and participate.

	But these are just ideas.

.as

---

From: David Morris <[email-masked]>
Date: Mon, 27 May 2013 14:24:20 -0700 (PDT)

> the $400 saved by not going to Buenos Aires to such an undertaking.

Your are likely right, but the discussion hasn't included the negative
impression on Frobnitz management re. the added expense.

Just because the money can't be 'recovered' for other use, doesn't
make it rational to spend it.

---

From: Scott Brim <[email-masked]>
Date: Mon, 27 May 2013 17:26:03 -0400

I would prefer that people come to the IETF because they have a problem and
they are looking for ways to solve it ... as opposed to wanting to work
with the IETF for some reason and looking for something "the IETF" wants
them to work on.  The former feels like engineering, the latter like
professional standards going.  Therefore, if someone says they are looking
for a problem to work on, I ask them to bring a problem with them.

---

From: Rumbidzayi Gadhula <[email-masked]>
Date: Tue, 28 May 2013 10:26:01 +0200

Your experience and ideas on how to start-out are useful.

On 27 May 2013 16:13, Yoav Nir <[email-masked]> wrote:

> LCD?
>
> Anyway, What I found most useful when I was starting out 9 years ago, was
> to look over the list of areas and working groups (
> http://tools.ietf.org/area/ ) and find out which of them are working on
> something that is of interest to me. In my case it was mostly the security
> area, and the IPsec working group, since that is what I was working on in
> my day job. I subscribed to that list and some others that were also
> related to what I was working on (TLS, PKIX).
>
> So the best thing is to subscribe to the mailing lists, both those that
> interest you personally and those that are of interest to your employer (if
> there are such groups).
>
> Step 2 is to lurk for a couple of weeks at least, and just read what
> others are posting. If they're talking about a particular draft, it's easy
> to find on one of the IETF sites and read it. So you read the drafts, and
> read what people are saying about the drafts. This teaches you both about
> what the group is working on, and the (for lack of a better term)
> "political" part - who are the participants and what are they like.  You
> might also want to read the Tao document, although different groups have
> varying dynamics.
>
> After a while, you've read the drafts, you've read what some people are
> saying, and you may have formed an opinion, either about the draft itself,
> or about one of the comments. That's a good time to speak up by sending a
> message to the list. Maybe the draft got something wrong. Maybe the comment
> is only correct in certain contexts, but doesn't describe some situation
> you're familiar with. Maybe in reading the draft you find it hard to figure
> out what an implementation should do in a certain case, and you present the
> case, and ask that it be clarified. Maybe the proposed protocol would
> require clients, servers, or middleboxes to allocate more memory than
> implementations that you know can afford. Such comments, and even better,
> proposed fixes are how you build a reputation in the IETF for knowing your
> stuff. You can also volunteer to review a whole document, or volunteer to
> write a missing section. That is how you build a reputation for being
> useful. Both are necessary for success in the IETF.
>
> Step 4 is when you have an idea of your own, or you read someone else's
> idea and you want to participate. In that case you either write your own
> draft or join someone else in writing one. It's often not enough to just
> write it. You also have to get people to read it, post about it to the
> correct lists, and in general "sell" it and gather support. It is at about
> that time that you start to feel the need to attend meetings, but you can
> get some things done even without it.
>
> Hope this helps
>
> Yoav
>

---

From: Nthabiseng Pule <[email-masked]>
Date: Tue, 28 May 2013 11:46:12 +0200

Sorry, I meant LCD.

Nthabiseng Pule

On 27 May 2013, at 5:48 PM, "John R Levine" <[email-masked]> wrote:

> LDC, Less Developed Country, what used to be called the third world, now that the second has been bought by the first.
> 
> Regards,