Subject: Participation per Region of Authoring IETF documents vs Marketing

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 27 May 2013 12:10:38 +0200

Each IETF document mentions the authors place address (I may suggest
adding region, as a categorised by IETF), but not sure of history
statistics of how many IETF-documents produced by authors in South
America, Africa, or Asia, or others.

 I think it is a good marketing start for IETF to get more
Informational-RFCs input from regions by guiding their inputs.
Furthermore, if IETF helds a meeting in one region with very low
participation, then Why not that IETF encourages people to involve in
joining authors of interested documents to that region and interested
to IETF as well?

AB

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 27 May 2013 10:51:34 +0000

> America, Africa, or Asia, or others.

http://www.arkko.com/tools/stats/d-countrydistr.html and related pages

Lars

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 27 May 2013 15:31:19 +0200

> http://www.arkko.com/tools/stats/d-countrydistr.html and related pages

I read that before, but does not show documents/RFCs per region. It
shows drafts per countries. For example, does not show the drafts from
South America. Does not show all regions in sequence of the most
participated region.

AB

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 27 May 2013 15:46:35 +0000

> South America. Does not show all regions in sequence of the most

That's why I wrote *and related pages*.

Clicking around Jari's pages, you will easily find http://www.arkko.com/tools/rfcstats/d-contdistr.html as well as many more stats.

As for "most participated region", look at the reports from the IAOC: http://iaoc.ietf.org/reports.html

Lars

---

From: Arturo Servin <[email-masked]>
Date: Mon, 27 May 2013 13:12:15 -0300

But also remember, writing I+D is just part of the equation. We also
need reviewers and comments.

Regards,
as

---

From: Andrew Sullivan <[email-masked]>
Date: Mon, 27 May 2013 11:38:22 -0400

Rather than saying "someone should do this" on the list, you could, you know, do the work. 

A

-- 
Andrew Sullivan 
Please excuse my clumbsy thums.

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 28 May 2013 18:46:41 +0100

by looking into the statistics of I-Ds and RFCs, it is strange that we get
sometimes high rate in the I-D going in IETF from some regions but the
success rate of I-Ds to become RFCs is very low (5- 50). So the only region
that is producing RFCs with high rate (about 200 per year) is North America
even though there is a high rate of I-Ds created. No sure Why is that
result, or waste of efforts, or maybe I misunderstood the figures,

How many I-Ds per year of Asia-region are adopted by IETF WGs?
How many I-Ds per year of Europe-region are adopted by IETF WGs?

AB

On Mon, May 27, 2013 at 4:46 PM, Eggert, Lars <[email-masked]> wrote:

> >> On May 27, 2013, at 12:10, Abdussalam Baryun <
> [email-masked]>
> >> wrote:
> Clicking around Jari's pages, you will easily find
> http://www.arkko.com/tools/rfcstats/d-contdistr.html as well as many more
> stats.
>

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 29 May 2013 09:53:50 +0000

Hi,

On May 28, 2013, at 19:46, Abdussalam Baryun <[email-masked]> wrote:
> success rate of I-Ds to become RFCs is very low (5- 50).

which IDs and RFCs are you basing this statement on?

Thanks,
Lars

---

From: Jari Arkko <[email-masked]>
Date: Wed, 29 May 2013 18:20:47 +0300

>> success rate of I-Ds to become RFCs is very low (5- 50).

There seems to be a general pattern where new participants first participate and/or produce IDs but it takes some time to produce RFCs. For instance, for a while it was the case that there was a growing number of proposals and participants from China, but it is only more recently that the RFC statistics reflect this (see the bright green line in http://www.arkko.com/tools/rfcstats/countrydistrhist.html). The hypothesis is that first of all, it takes a while to produce RFCs :-) and that new participants take a while before they get up to speed on the process, find enough other parties that share similar needs for the specific technical work, etc.

Jari

---

From: John C Klensin <[email-masked]>
Date: Wed, 29 May 2013 11:35:18 -0400

--On Wednesday, May 29, 2013 18:20 +0300 Jari Arkko
<[email-masked]> wrote:

> There seems to be a general pattern where new participants
> first participate and/or produce IDs but it takes some time to
> produce RFCs. For instance, for a while it was the case that
> there was a growing number of proposals and participants from
> China, but it is only more recently that the RFC statistics
> reflect this (see the bright green line in
> http://www.arkko.com/tools/rfcstats/countrydistrhist.html).
> The hypothesis is that first of all, it takes a while to
> produce RFCs :-) and that new participants take a while before
> they get up to speed on the process, find enough other parties
> that share similar needs for the specific technical work, etc.

I would add to that list the observation that, when complete
newcomers come to the IETF in order to propose some pet idea or
personal invention and get it standardized, the first I-Ds that
they submit often don't go anywhere because they propose a
networking model that is outside IETF scope, have serious
technical flaws the authors did not identify,  just are not of
interest to other members of the community, or are generally off
the wall for some other reason (such as requiring changes to
laws of physics or axiomatic definitions of mathematics).
Certainly not every proposal with which a newcomer arrives falls
into those categories -- some have been useful -- but it is
important to remember that there are substantive reasons why
I-Ds submitted within the first months of someone's
participation often have a lower acceptance rate as RFCs than
ones that come from more experienced participants.

I think there are important questions as to whether we handle
such proposals in a way that maximizes the odds of future
participation by those individuals and suspect we could do
better in that area.  But those are separate issues.

   john

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 30 May 2013 02:39:39 +0200

Hi Lars,

It was for Asia region, I thought its rate is between (5 - 50)
rfc/year for last 3 years. Basing on; The first figure of RFCs is the
Comparison of countries over the year [1], the second, is the
Distribution of number of RFCs per continent [2], the third is
publication rate per year [3]. For the I-Ds going in IETF is seen from
the distribution of drafts according to the countries of their authors
[4] and [5]. All figures make together the below conclusions, even
though some of them need more details for readers to understand.

 As from Figure [1] always one region (North America) is doing about
200 rfc/year and the each of others may do between 5 - 50 rfc/year or
50-100, but all together other regions do 150 rfc/year, so total
ietf-participation can be about 350 rfc/year. The Figure [2] is not
reasonable, not showing of years or period of such numbers.

So my understanding is that for Europe-region and Asia-region, the
number of I-Ds rates are high compared to North America, but not the
rate of RFCs. I see that the total RFCs ietf-output rate (RFC/year) as
in Figure [3] for the last three years is about 350 rfc/year, so if
North America is having 200, the all others only will have about 150
rfc/year. The total RFCs produced per countries is in Figure [6] is
reasonable but if compared with Figure [2] I get lost.

>From Figure [5] (also [4]) the number of I-Ds (now currently 2013
outstanding) from Asia and Europe are about 600 and 1200 respectively
(let us add them up so =1800 ids), which I think only about 150 will
succeed (non-North America drafts). Furthermore, for North America the
I-Ds are 1500 ids and only 200 ids will succeed to become RFCs. I
think that Asia and Europe should have together about 250/year rfc not
150 rfc/year. If we do more MARKETING effort we can make that rfc-rate
of other regions increase, but we already tried to increase North
America rate but it is stable for about 200 rfc/years.

[1] http://www.arkko.com/tools/rfcstats/countrydistrhist.html
[2] http://www.arkko.com/tools/recrfcstats/d-contdistr.html
[3] http://arkko.com/tools/rfcstats/pubdistr.html
[4] http://www.arkko.com/tools/stats/d-countrydistr.html
[5] http://www.arkko.com/tools/stats/d-countryeudistr.html
[6] http://www.arkko.com/tools/rfcstats/d-countrydistr.html

 This lower participation from regions like Asia will continue because
most meeting are in North America, or most participants from North
America prefer to have face-face meeting locally, than to be remote to
other regions (not reasonable because they are writers in English very
well). Also other regions participants prefer to participate in
meetings not remotely (but that is reasonable because they are not
good in English Language Writting). It is also important that some
IETF management visit the other region participants for the progress
of their I-Ds.

Please note that I don't claim that my analysis is all correct, but
trying to discuss it and get others to analyse as well or comment on
the figures/statistics. If you disagree or have any comment please
reply/advise. Thanking you,

AB

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 30 May 2013 10:45:55 +1000

I would take those numbers with a HUGE grain of salt (as Jari documents).

For example, I've lived in Australia since 2006, and yet am only listed as producing RFCs in the USA.

Regards,

--
Mark Nottingham   http://www.mnot.net/

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 30 May 2013 03:16:06 +0200

On 5/29/13, Jari Arkko <[email-masked]> wrote:
> There seems to be a general pattern where new participants first participate
> and/or produce IDs but it takes some time to produce RFCs.

Yes that is right, so I think we can encourage thoes new participants
to join and continue, of speed up by our guidance, and also the IETF
may be guided by thoes new comers. It is a two way new-participation,
and even IETF is new to participate in other new sub-regions or
sub-communities.

>For instance, for
> a while it was the case that there was a growing number of proposals and
> participants from China,

Yes IETF needs China's participation, so the question is why is China
(as sub-region) having low rate of rfc/year? How can the IETF do
marketing/help to improve that?

> but it is only more recently that the RFC
> statistics reflect this (see the bright green line in
> http://www.arkko.com/tools/rfcstats/countrydistrhist.html). The hypothesis
> is that first of all, it takes a while to produce RFCs :-) and that new
> participants take a while before they get up to speed on the process, find
> enough other parties that share similar needs for the specific technical
> work, etc.

So if you agree that they need to find other parties to speed up or
increase rate of rfc/year, that meens it will be a good idea to have
one meeting of IETF per year in Asia region (IETF marketing in Asia
for participation).

Furthermore, IETF can have one meeting per year for each region
equally (for equal marketing opportunities), because North America
region's rate of rfc/year for many years shown to be stable not much
improving (about 200 rfc/year), and all participants in North America
have excellent English and writting skill to explain remotely in
meetings.

Some inputs on this IETF list (sub: IETF meeting in South America) say
that IETF meeting in South America will not increase participation, as
no result of such marketing (I disagree, their argument may be correct
only if South America are well English writers that can easily
remotely communicate). On the other hand, from their argument I
understand that it means there is no affect of IETF meeting for all
regions to increase or decrease participation including North America
(no results of marketing or de-marketing). Therefore, if we reduce the
number of meeting in North America (as not de-marketing because at
least there is a meeting per year) we will not face any decrease of
the 200 rfc/year (so we can give more space to other regions), because
they are mostly not-new-participants (as compared to hypothesis you
explain for China's rate and new-participate speed) and they are well
english/known writers/remote-participants.

AB
My thoughts on the subject and on South America meeting subject.

---

From: <[email-masked]>
Date: Thu, 30 May 2013 02:53:56 +0100

http://www.arkko.com/tools/recrfcstats/d-contdistr.html
(Jari, what time period is that across? Oceania doesn't rate a mention...)
11 RFCs (0.73%) have authors from South America.

http://www.arkko.com/tools/allstats/fernandogont.html
This author is in Argentina (as of 2013)
Fernando has the following 12 RFCs

This suggests that itr would be efficient for the IETF to fund travel and support for Fernando, who I've met at IETF meetings, rather  than fund an IETF meeting in Fernando's neighbourhood (consistently Haedo, Provincia de Buenos Aires - address is a better guide than affiliation).

Lloyd Wood
http://sat-net.com/L.Wood/

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Mark Nottingham [[email-masked]]
Sent: 30 May 2013 01:45
To: Abdussalam Baryun
Cc: ietf
Subject: Re: Participation per Region of Authoring IETF documents vs Marketing

Regards,

---

From: Jari Arkko <[email-masked]>
Date: Thu, 30 May 2013 09:55:47 +0300

Lloyd,

> (Jari, what time period is that across? Oceania doesn't rate a mention…)

"Recent RFCs" is anything from RFC 5400 onwards. An arbitrary definition.

And Oceania is listed under "Australia" per http://en.wikipedia.org/wiki/Continent...

> Fernando has the following 12 RFCs

I need to repeat the warning that someone gave - my statistics are very unreliable, particularly when it comes to small numbers. The tools parse natural language, and all I can say is that they sometimes guess right. But I also looked at this a while ago, and from what I could tell, Fernando is responsible for the RFCs from that continent :-) For now… see below.

> This suggests that itr would be efficient for the IETF to fund travel and support for Fernando, who I've met at IETF meetings, rather  than fund an IETF meeting in Fernando's neighbourhood (consist…

I think we need to look at this topic not with today's numbers but with what is possible within a few years. Today, I see several people who are making significant contributions to discussion, including some who clearly could/should be making RFCs. This will happen, and then there are all the other people who could be participating, but are not. Just as an anecdotal datapoint, some people at my day job at Ericsson have a very successful co-operation with a Brasilian university on IETF-like topics.

Jari

---

From: Jari Arkko <[email-masked]>
Date: Thu, 30 May 2013 10:06:01 +0300

> I would take those numbers with a HUGE grain of salt (as Jari documents).

Indeed

> For example, I've lived in Australia since 2006, and yet am only listed as producing RFCs in the USA.

My apologies. I added a data item to recognise you…

Jari

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 30 May 2013 17:06:28 +1000

Thanks :)

---

From: "Roque Gagliano (rogaglia)" <[email-masked]>
Date: Thu, 30 May 2013 11:15:45 +0000

> I would take those numbers with a HUGE grain of salt (as Jari documents).

I appreciate Jari's effort and use his page extensively. However, I agree taht geography data should be taken with a grain of salt.

In my case I created several document while living in South America but moved to Europe just before the RFC was published with my current european address. So, even if I worked on it for 3+ years from LATAM, those document show me as european. You also have to consider all the native people from one region that move to another one.

My proposal to the "diversity working group" was to add a request from the RFC editor to the authors to establish the geography they would like to be associated with and add that information to the document metadata at publication time.

If we want to tackle the cause of this problem and not the consequences, we need to look at the macro-economical issues mentioned by Joel. That said, I am optimistic that we will see improvements sooner than later thanks to new research/development centres been established in LATAM but these processes take time.

Referring to what the impact of hosting a meeting in LATAM would have on participation, we need to consider that IETF meetings are not conference but working meeting. We get there (or online) to get work done. Presentations last only around 5-10 mins they are not marketing-sexy and they normally start with "difference from last meeting". What I want to say is that engagement needs to happen much earlier and while having a meeting in a location will always have a positive effect on local participation (as stated by Michael), we need to set expectations right.

Personally, I believe we should spend more energies from now to that date working on mentoring and improving the fellowship program. I was involved in the first 3 years of the program and I recommended the creation of the "recurrent" fellows (initially fellows could only attend one meeting). Although I  am still in contact with my past mentees, I think there is still room for improvement and we could think on a long-distance volunteering program.  

Referring to the chosen location (Buenos Aires), I think it is an excellent choice from the point of view of our traditional requirements to get job done. However, the comments about the current exchange and import limitations are relevant and should be evaluated by the IAOC when establish the current risks or running the meeting there from an operational perspective. Typical business operations such as the possibility of charging local sponsorships or local attendees in USD, been able to wire the hotel IETF fees back to the US in USD (and at a reasonable exchange rate) or importing devices to run the meeting should not be taking for granted but should be discussed with our local contact. 

Roque