Subject: Re: Gather Profiles/Resumes [was Re: call for ideas: tail-heavy IETF process]

From: "Doug Ewell" <[email-masked]>
Date: Wed, 15 May 2013 14:28:29 -0700

John C Klensin <john dash ietf at jck dot com> wrote:

> I think it is all very well to ask for affiliations in principle
> and, also in principle, I agree that it is a good idea. But, in
> practice, I think there are a lot of clarifications and other
> changes that would be required and that might or might not be
> practical. 

I used the term "Consultant" in RFCs 4645 and 5645, instead of revealing
the name of my company (which was different each time, and neither of
which contributed any time or money to my WG effort). I did this because
the WG at the time included a malicious contributor who had already
contacted the HR department of another contributor's employer, asking
them to professionally discipline the employee, because he had supported
an RFC 3683 PR-action against the first contributor. Full disclosure can
be a dangerous thing.

--
Doug Ewell | Thornton, CO, USA
http://ewellic.org | @DougEwell

---

From: <[email-masked]>
Date: Wed, 15 May 2013 23:35:18 +0100

You want resumes? You've got linkedin for that.

The sort of thing Doug describes is actually quite common.

For example, I once had a group chair threaten to have me disciplined by the company
I worked for, for pointing out the technical failings of his pet protocol.

The IETF isn't a lovey-dovey bunch of hippies working in harmony for humanity.
The IETF is hardball.

Lloyd Wood
http://sat-net.com/L.Wood/

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Doug Ewell [[email-masked]]
Sent: 15 May 2013 22:28
To: [email-masked]
Subject: Re: Gather Profiles/Resumes [was Re: call for ideas: tail-heavy IETF   process]

---

From: John C Klensin <[email-masked]>
Date: Thu, 16 May 2013 01:08:30 -0400

--On Wednesday, May 15, 2013 14:28 -0700 Doug Ewell
<[email-masked]> wrote:

>...
> I did this because
> the WG at the time included a malicious contributor who had
> already contacted the HR department of another contributor's
> employer, asking them to professionally discipline the
> employee, because he had supported an RFC 3683 PR-action
> against the first contributor. Full disclosure can be a
> dangerous thing.

I know that sort of "contact the employer and ask them to chew
out the employee" stuff goes on because I've had it tried on me
at least twice although both involved technical issues and
choices, not, e.g., a PR-action.  In the first instance, the
employer said something about academic freedom and essentially
told the person complaining to kiss off.  In the second, the
employer laughed.  

I may have been luckier in my choices of employers (and clients)
and I know bad stuff happens sometimes, but the sort of case you
outline doesn't seem to me to be a good argument against
disclosure of affiliations.  It seems to me that, very rare edge
cases aside, either:

	(i) Your employer knows what you are doing and saying in
	the IETF, at least to the extent that they care, and
	will back you should such complaints arrive.
	
	(ii) You and your employer have an agreement that you
	participate in the IETF as an independent activity that
	they don't try to control.  Should a complaint arise,
	they presumably tell the complaining party that unless
	your IETF behavior is an embarrassment to the company,
	in which case (iii) applies.
	
	(iii) Your IETF behavior is, as far as your employer is
	concerned, that of a loose cannon.  You regularly work
	against company positions or the company's best
	interests and haven't laid the internal foundation for
	that to be acceptable.  A complaint associated with
	something you have disclosed could get you into big
	trouble, but complaints are equally likely from people
	who know where you are working, disclosure or no, such
	as fellow employees of the same organization.

So I suggest that, if your behavior is proper and above board,
disclosure will rarely create a problem.  If your behavior
isn't, then disclosure may be the least of your difficulties.  

In addition, the IETF may be in need of a mechanism for
documenting and disclosing the identities of anyone who thinks
that complaining to someone's employer about his or her
reasonable behavior at the IETF.  I imagine the community could
figure out appropriate and completely informal ways to
discourage that particular style of trying to influence IETF
decision-making.

best,
    john