Subject: Re: decentralization of Internet (was Re: Bruce Schneier's Proposal to dedicate November meeting to saving the Internet from the NSA

From: [email-masked] (Noel Chiappa)
Date: Fri, 6 Sep 2013 23:05:04 -0400 (EDT)

> From: Scott Brim <[email-masked]>

    > The encapsulation is not much of an obstacle to packet examination.

There was actually a proposal a couple of weeks back in the WG to encrypt all
traffic on the inter-xTR stage.

The win in doing it in the xTRs, of course, is that you don't have to go
change all the hosts, application by application: _all_ traffic, of any kind,
from that site to any/all other sites which are encryption-enabled, will get
a certain degree of confidentiality.

Does this count as something the IETF can do reasonably quickly that will
help somewhat? :-)

	Noel

---

From: Tim Chown <[email-masked]>
Date: Sat, 7 Sep 2013 10:23:46 +0100

> Does this count as something the IETF can do reasonably quickly that will

It certainly wouldn't hurt :)

Tim

---

From: Roger Jørgensen <[email-masked]>
Date: Sat, 7 Sep 2013 12:30:04 +0200

> Does this count as something the IETF can do reasonably quickly that will

One easy fix then would be to have a MUST encrypt traffic between
xTRs, and that the encryption used MUST be strong. Are LISP@WG up for
the challenge? :-)

The userbase and deployment are relative small atm so it's doable to
get fast deployment to.

-- 

Roger Jorgensen           | ROJO9-RIPE
[email-masked]          | - IPv6 is The Key!
http://www.jorgensen.no   | [email-masked]

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 07 Sep 2013 22:50:52 +0900

> traffic on the inter-xTR stage.

Making intermediate systems more intelligent is against
the end to end principle and assured to fail.

Considering that google, facebook, yahoo, etc., which are
end systems that many victims are relying upon, are socially
compromised by USG, it can not protect the victims.

Worse, considering that services of Microsoft, Apple, etc. are
socially compromised by USG, end systems manufactured by
Microsoft, Apple, etc.  are totally unsafe.

As for secure end systems, PCs with open source UNIX are much
safer, even though USG can still use a lot of approaches to
compromise them.

					Masataka Ohta