Subject: Gen-ART LC review of draft-ietf-mpls-tp-rosetta-stone-12

From: "Roni Even" <[email-masked]>
Date: Sun, 13 Oct 2013 11:00:46 +0300

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments you
may receive.

Document: draft-ietf-mpls-tp-rosetta-stone-12

Reviewer: Roni Even

Review Date:2013-10-12

IETF LC End Date: 2013-10-16

IESG Telechat date: 

Summary: This draft is ready for publication as an Informational RFC.

Major issues:

Minor issues:

Nits/editorial comments:

---

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 13 Oct 2013 11:39:33 +0200

The draft does not list ITU in abbreviation, there are many terminology not
clear but more general definition. I prefer specific defining. Also many
times refers to references to define without mentioning what was that
definition, is that defined only in ITU and IETF cannot define its
technology, or is it agreeing on a joint definition so IETF is just
following ITU in some terms.

AB

On Sunday, October 13, 2013, Roni Even wrote:

> Gen-ART, please see the FAQ at <
> http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.****
>
> may receive.****
> Document: draft-ietf-mpls-tp-rosetta-stone-12****
>
> Reviewer: Roni Even****
>
> Review Date:2013–10–12****
>
> IETF LC End Date: 2013-10–16****
>
> IESG Telechat date: ****
>
> ** **
>
> Summary: This draft is ready for publication as an Informational RFC.****
>
> ** **
>
> ** **
>
> Major issues:****
>
> Minor issues:****
>
> ** **
>
> Nits/editorial comments:****
>
> ** **
>
> ** **
>

---

From: Loa Andersson <[email-masked]>
Date: Sun, 13 Oct 2013 17:45:45 +0800

AB,

ITU and ITU-T are both in 
http://www.rfc-editor.org/rfc-style-guide/abbrev.expansion.txt listed as 
one of the well-known acronyms we
can use without expanding it; all the specific definition you need :) !

/Loa

On 2013-10-13 17:39, Abdussalam Baryun wrote:
> The draft does not list ITU in abbreviation, there are many terminology
> not clear but more general definition. I prefer specific defining. Also
> many times refers to references to define without mentioning what was
> that definition, is that defined only in ITU and IETF cannot define its
>     <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.____
>
>     Please resolve these comments along with any other Last Call
>     comments you may receive.____
>
>     Document: draft-ietf-mpls-tp-rosetta-stone-12____
>
>     Reviewer: Roni Even____
>
>     Review Date:2013–10–12____
>
>     IETF LC End Date: 2013-10–16____
>
>     IESG Telechat date: ____
>
>     __ __
>
>     Summary: This draft is ready for publication as an Informational
>     RFC.____
>
>     __ __
>
>     __ __
>
>     Major issues:____
>
>     Minor issues:____
>
>     __ __
>
>     Nits/editorial comments:____
>
>     __ __
>
>     __ __
>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 13 Oct 2013 14:06:31 +0100

Hi,

I am having sever difficulty parsing all of the information from your comment.
And currently cannot see anything actionable by the authors.

> The draft does not list ITU in abbreviation,

Loa has answered why this is not necessary.

> there are many terminology not clear but more general definition.  I 
> prefer specific defining. 

This comment gives us nothing to go on! Which terminology do you find not clear
but is a more general definition? And why is this a problem?

You cannot expect the authors to fix or even discuss something if you do not
show them what you are talking about.

> Also many times refers to references to define without mentioning
> what was that definition,

What do you mean? Can you give an example and say how you think it should be?

> is that defined only in ITU and IETF cannot define its technology, or
> is it agreeing on a joint definition so IETF is just following ITU in some
> terms.

*This* document is seeking IETF consensus. If that consensus is reached all
definitions will be IETF definitions. If those definitions originate in ITU-T
documents, they are also ITU-T definitions. If ITU-T documents make normative
reference to IETF documents that contain definitions, those definitions are
ITU-T definitions.

Maybe I have missed the point of your comment.

Adrian

---

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 13 Oct 2013 16:32:44 +0200

Yes, my comment meant that it is a reply to the review message that there
may be not clear definition from other participant point of view. Sorry
my review is still not complete, I will send it. Do you mean my reply is
not right, if I like to give a short comment before my full review.

AB

> Loa has answered why this is not necessary.

You mean that IETF agrees to do that as per a RFC xxxx passed or community
awareness.

> show them what you are talking about.

I am talking about the draft in overall, I will do my review if time is
available.

> What do you mean? Can you give an example and say how you think it should

Will be shown in a full review message, this was a comment message, but
thanks for your advise

> Maybe I have missed the point of your comment.

The point is why do we need other organisation definitions, or why did the
author use those definitions, my point is any definition should relate to
internet technology not references of other org, we may use other
definitions for ours.

---

From: joel jaeggli <[email-masked]>
Date: Sun, 13 Oct 2013 11:36:04 -0700

On Oct 13, 2013, at 7:32 AM, Abdussalam Baryun <[email-masked]> wrote:

> Yes, my comment meant that it is a reply to the review message that there may be not clear definition from other participant point of view. Sorry my review is still not complete, I will send it. Do you mean my reply is not right, if I like to give a short comment before my full review.
> 
> AB
> 
> You mean that IETF agrees to do that as per a RFC xxxx passed or community awareness. 
> 
> I am talking about the draft in overall, I will do my review if time is available.
> 

Insubstantial comments during the last call by someone who claims to have not reviewed the document are rather condescending. If you were the author what would you do with this "feedback"? 

Expectations of collegiality require a certain respect for common purpose, and the purpose of the last call is to surface remaining issues of substance, test for consensus and move on. (2418 section 8)

> Will be shown in a full review message, this was a comment message, but thanks for your advise 
> 
> The point is why do we need other organisation definitions, or why did the author use those definitions, my point is any definition should relate to internet technology not references of other org, we may use other definitions for ours.
> 
> Adrian
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 13 Oct 2013 22:00:51 +0200

A comment can be a discussion/opinion for the draft that is at the IETF
level, I did review but not completed writing the output. However, my
comment may influenced comments today at WG level (usually the draft passed
such review of WG LC) which did not send there comments  to the IETF list,
but the authors are gaining so far. I prefer that all comments should be at
the IETF list after the IETF LC to give chance for discussion if needed (as
a community DISCUSS position).

AB

On Sunday, October 13, 2013, joel jaeggli wrote:

> > Yes, my comment meant that it is a reply to the review message that
> there may be not clear definition from other participant point of view.
> Sorry my review is still not complete, I will send it. Do you mean my reply
> is not right, if I like to give a short comment before my full review.
> >
> > AB
> >
> Insubstantial comments during the last call by someone who claims to have
> not reviewed the document are rather condescending. If you were the author
> what would you do with this "feedback"?
>
> Expectations of collegiality require a certain respect for common purpose,
> and the purpose of the last call is to surface remaining issues of
> substance, test for consensus and move on. (2418 section 8)
>
> > The point is why do we need other organisation definitions, or why did
> the author use those definitions, my point is any definition should relate
> to internet technology not references of other org, we may use other
> definitions for ours.
> >
> > Adrian
> >
>
>

---

From: Huub van Helvoort <[email-masked]>
Date: Sun, 13 Oct 2013 23:23:57 +0200

AB,

You wrote:

> but the authors are gaining so far.

That may be your opinion.
But it is absolutely not my opinion.

As the author of this draft I have worked four years to
address all the comments received, and improve the quality
of the document.

So you had four years to review and comment.
Yet you wait until four days before the deadline set by IESG
to announce that you have substantial comments.

I am now completely lost, and have lost too.

/Huub.

-- 
*****************************************************************
               请记住，你是独一无二的，就像其他每一个人一样

---

From: Jari Arkko <[email-masked]>
Date: Thu, 24 Oct 2013 03:52:48 +0800

Roni: thank you very much for your review.

Jari