Subject: Re: Proper credit for work done -- on finding chairs (was CHANGE THE JOB)

From: Barry Leiba <[email-masked]>
Date: Thu, 17 Oct 2013 17:47:34 -0400

Ted says, with respect to "Quickly replace failing WG Chairs":
> You forgot "from a magical pool of better qualified WG chairs who
> have the time and inclination to take on the work."

Let me tell you about a conversation I had when I was trying to fill a
chair position: I asked someone I thought could and would do a good
job as chair.  She was also a proponent of the technology, and wanted
to be a document author.  In response to, "Why not be a chair, and
lead the effort?", part of her answer was something like this:

"I work for a small company.  Whatever work I do on this takes away
from what I do for them, and they want to see something tangible from
it.  If I'm (co-)author on a document, my name, and my company's is at
the top of the document.  I get credit for the work.  My company gets
credit for the work.

"If I'm a working group chair, I do more work, overall.  And, in the
end, I get no credit for it -- my name is not on any of the documents.
 And, significantly, my company gets no credit for it whatsoever, not
even listed in the datatracker.

"When I go to my boss and give him the alternatives, I know which he'll pick."

Barry

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 17 Oct 2013 23:59:21 +0200

> even listed in the datatracker.

This.

(Fortunately for me, in the WGs I have chaired, I actually did (co-)write some of the documents.
But it often was an uphill battle to get my name on them, because WG chairs are not supposed to do that.  Even when there are multiple chairs, who could very well watch each other.  Well, RFC 3095 had both chairs on the document... and 14 more authors.)

Other groups, such as IEEE, list the chairs of a group prominently (as such); they are worse in identifying the authors though.

Grüße, Carsten

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 17 Oct 2013 23:08:13 +0100

On 10/17/2013 10:59 PM, Carsten Bormann wrote:
>> "If I'm a working group chair, I do more work, overall.  And, in
>> the end, I get no credit for it -- my name is not on any of the
>> documents. And, significantly, my company gets no credit for it
>> whatsoever, not even listed in the datatracker.
> 
> This.
> 
> (Fortunately for me, in the WGs I have chaired, I actually did
> (co-)write some of the documents. But it often was an uphill battle
> to get my name on them, because WG chairs are not supposed to do
> that.  Even when there are multiple chairs, who could very well watch
> each other.  Well, RFC 3095 had both chairs on the document... and 14
> more authors.)
> 
> Other groups, such as IEEE, list the chairs of a group prominently
> (as such); they are worse in identifying the authors though.

Chairs, shepherds, wg secretaries etc etc. I don't think
attribution in RFCs is a great way to do that unless its
done as acks the authors decide themselves they want to
include.

And I also think chairs being authors is a bad plan for
any controlversial wg.

I do agree that some credit for chairs in particular would
be a fine thing if we could figure a way to do it though.

For example, I'd encourage authors to include acks as per
the above, in particular for cases of 'difficult' wgs.

Any other ideas?

S.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 18 Oct 2013 00:13:44 +0200

> Any other ideas?

Sure.  

Create memento pages for each chair that lists the RFCs that chair was responsible for.

Like Jari's authorstats.
(Probably even harder to mine from the data we have.)

Grüße, Carsten

---

From: <[email-masked]>
Date: Thu, 17 Oct 2013 23:15:27 +0100

Taking it a step further, as far as getting credit goes, being on the IESG is pretty much the same as not
participating in the IETF at all. But it's a lot more work. No-one gets credit for reviewing; that's why academia
leaves it to grad students.

Chairs being authors, and thus taking a detailed technical position, can often be very bad for workgroup output.

Lloyd Wood
http://sat-net.com/L.Wood/

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Stephen Farrell [[email-masked]]
Sent: 17 October 2013 23:08
To: Carsten Bormann; Barry Leiba
Cc: IETF Discuss
Subject: Re: Proper credit for work done -- on finding chairs (was CHANGE       THE JOB)

Any other ideas?

S.

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 17 Oct 2013 16:20:18 -0600

> the above, in particular for cases of 'difficult' wgs.

I've started acknowledging also the directorate reviewers, as well as
the chairs and AD. A few examples:

http://tools.ietf.org/html/rfc6120#appendix-E

http://tools.ietf.org/html/rfc6993#section-5

It's not that hard to add a few lines at the end of your document. (Yet
sometimes I still forget, so thanks for the reminder!)

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 18 Oct 2013 00:34:34 +0200

> Chairs being authors, and thus taking a detailed technical position, can often be very bad for workgroup output.

Chairs understanding the technology also can be very good for WG output.

If you understand the technology in a dynamic field, it is simply unnatural to abstain from writing documents.

(I'm not saying there is no problem with mixing chair and author roles, just that it is inappropriate to "solve" it with simplistic rules.)

Grüße, Carsten

---

From: John C Klensin <[email-masked]>
Date: Thu, 17 Oct 2013 18:52:11 -0400

I had promised I was through for today, but I just had a wild,
crazy, suggestion that follows on the retirement of the xx99 and
xx00 subseries of RFCs.

I wonder if we should be publishing, at regular intervals, RFCs
with explicit acknowledgements and maybe contact information for
Areas and ADs, WG Chairs, and, if appropriate, other IETF
functionaries, probably including document reviewers and Nomcom
members.  It would provide both a snapshot of what has been
going on and who has been contributing to keeping the process
working that is more permanent/ archival and accessible than a
collection of web pages.  It would also provide a type of
formally-published acknowledgement for those sorts of work to
which people and their organizations could point.

It might have rather high payoff in comparison to the cost of
the bits.  And I'd think that most of the data could be pulled
out of existing sources with a few tools and a little
secretariat effort (i.e., little or no additional work for ADs).

Or maybe I'm missing a serious downside.

best,
   john

---

From: Steve Crocker <[email-masked]>
Date: Fri, 18 Oct 2013 09:56:10 +1100

+1

Sent from my iPhone

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Thu, 17 Oct 2013 21:03:31 -0400

Interesting, although I'll counter the point that your company is not promoted.  

As a chair now, because there is a lot of interest in information sharing, I am asked to speak quite often either on panels or talks.  Through these activities, my company, the IETF, and the WG are all promoted.  This does add extra work, but if promoting your organization is important, it could be possible.

Best regards,
Kathleen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Barry Leiba
Sent: Thursday, October 17, 2013 5:48 PM
To: IETF Discuss
Subject: Re: Proper credit for work done -- on finding chairs (was CHANGE THE JOB)

Ted says, with respect to "Quickly replace failing WG Chairs":
> You forgot "from a magical pool of better qualified WG chairs who have 
> the time and inclination to take on the work."

Let me tell you about a conversation I had when I was trying to fill a chair position: I asked someone I thought could and would do a good job as chair.  She was also a proponent of the technology, and wanted to be a document author.  In response to, "Why not be a chair, and lead the effort?", part of her answer was something like this:

"I work for a small company.  Whatever work I do on this takes away from what I do for them, and they want to see something tangible from it.  If I'm (co-)author on a document, my name, and my company's is at the top of the document.  I get credit for the work.  My company gets credit for the work.

"If I'm a working group chair, I do more work, overall.  And, in the end, I get no credit for it -- my name is not on any of the documents.
 And, significantly, my company gets no credit for it whatsoever, not even listed in the datatracker.

Barry

---

From: "John Levine" <[email-masked]>
Date: 18 Oct 2013 01:33:46 -0000

>Areas and ADs, WG Chairs, and, if appropriate, other IETF ...

I don't think it would solve the problem.  If your boss, or your
tenure committee, or your salary review committee is inclined to count
IETF work, they're going to look at how many documents have your name
as author.  I very much doubt that explanations that being mentioned
in RFC9900 as a WG chair or reviewer is just as good, even if true,
will help much.

In areas of scientific research where large teams do the work, it's
common to have papers with 50 or more co-authors, probably for exactly
this reason.  I realize we have a tradition of only five authors on an
RFC, but I've never seen a reason beyond that the first page looks
ugly if there's a long author list.  If more author credit will help
people persuade the powers that be that spending time on IETF work
is worth it, we should give more author credit, no matter how ugly
those first pages look*, to anyone who provided signficant text or
othewise provided some significant part of the document's contents.

If the AD provides oversight and direction, that includes the AD. It's
no worse than listing a professor as a co-author of all of her
students' papers.

R's,
John

* - although I expect some twiddles to xml2rfc might help

---

From: Andrew Sullivan <[email-masked]>
Date: Fri, 18 Oct 2013 10:13:22 -0400

No hat.

On Thu, Oct 17, 2013 at 06:52:11PM -0400, John C Klensin wrote:
> members.

I'm not keen on adding this cruft to the RFC series.  I note that the
tools pages are now archived, so if you go to
http://tools.ietf.org/wg/dnsext you will find that it's concluded and
that Olafur and I were chair at the end.  What you _won't_ find is
the history of other chairs.  Maybe that's an issue?

On the other hand, isn't this what resumes are for?

A

-- 
Andrew Sullivan
[email-masked]

---

From: Allison Mankin <[email-masked]>
Date: Fri, 18 Oct 2013 10:43:32 -0400

Adding to Andrew's suggestion on this thread, there does now exist a
photo gallery of current WG chairs:

http://www.ietf.org/wg/chair-photos.html

I'd consider it useful and a nice thing if there were a corresponding
photo gallery of past chairs (maybe or maybe not to the beginning of
the IETF), and also if the information on the current WG chairs had a
bullet for previous chairships.  I put in a suggestion about this in
relation to Nomcom support this past week.

Yes, resumes are good too, but there's something to be said for our
institution keeping an easy way to see where we've been, who's been
working.

Nomcom hat on, though mine is far less cool than Matt Lepinski's from Orlando...

Allison

---

From: Ted Lemon <[email-masked]>
Date: Fri, 18 Oct 2013 11:10:17 -0400

The most useful comment I've heard on this thread is that it makes sense to credit the working group chairs as well as the authors of a document in the document at the same level of emphasis.   And possibly the ADs as well.   I don't know if this would make a difference, but it's interesting, and might be worth the experiment.

But really, the main thing to say about this conversation is that it's a classic example of why the AD's job is so time consuming.   We have to monitor these conversations, because otherwise we aren't doing the part of our job that involves listening to the IETF.   Having long bikeshed discussions about the woeful brokenness of the AD's job over and over again without any action proposed is expensive.

Most of what's been discussed here has been discussed by the ADs during the recent IESG retreat, and substantial action was taken as a result of the discussion at that retreat.   It might be interesting to see if any of what we discussed actually changes anything.

---

From: Michael Richardson <[email-masked]>
Date: Fri, 18 Oct 2013 11:52:46 -0400

The question of credit for WG chairs (and IESG AD members) has become
important for two reasons:

1) the Internet community has grown sufficiently that many significant
   people do not know many other significant people.
   A template acknowledgement section that mentions the chairs and AD
   would be useful.  Maybe the RFC-editor should simply put it in.
   (The orcid would be useful here)

2) the IETF has gotten younger as it has grown, and there has been
   attrition at the top.  Until very recently, most of the people occupying
   the roles of AD or even WG chair, were in the middle to end of careers
   that started in 1987.  The younger people need to have the
   credits for their next job.

I think that we should change things.  We have the data in the datatracker.

--
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: Mary Barnes <[email-masked]>
Date: Fri, 18 Oct 2013 11:13:05 -0500

On Fri, Oct 18, 2013 at 10:10 AM, Ted Lemon <[email-masked]> wrote:

> The most useful comment I've heard on this thread is that it makes sense
> to credit the working group chairs as well as the authors of a document in
> the document at the same level of emphasis.   And possibly the ADs as well.
>   I don't know if this would make a difference, but it's interesting, and
> might be worth the experiment.
>
> But really, the main thing to say about this conversation is that it's a
> classic example of why the AD's job is so time consuming.   We have to
> monitor these conversations, because otherwise we aren't doing the part of
> our job that involves listening to the IETF.   Having long bikeshed
> discussions about the woeful brokenness of the AD's job over and over again
> without any action proposed is expensive.
>
> Most of what's been discussed here has been discussed by the ADs during
> the recent IESG retreat, and substantial action was taken as a result of
> the discussion at that retreat.   It might be interesting to see if any of
> what we discussed actually changes anything.
>
> [MB] Can you clue us in as to what "substantial action" has been taken?
[/MB]

---

From: Ted Lemon <[email-masked]>
Date: Fri, 18 Oct 2013 12:38:00 -0400

On Oct 18, 2013, at 12:13 PM, Mary Barnes <[email-masked]> wrote:
> [MB] Can you clue us in as to what "substantial action" has been taken?   [/MB] 

I thought we sent something around about that.   ADs and WG chairs are encouraged to ask for directorate reviews for certain directorates (possibly all directorates, I can't remember) prior to working group last call.   This is in the form of an experiment, not a new policy; we'll see how it goes.

We've done a number of other things in the same vein—e.g., document shepherds are now being invited onto telechats, so that they can do the work of tracking action items for the authors rather than the AD doing it.

I think there were other items on the list, but I don't remember them off the top of my head.   The point is, if anybody thinks the IESG is a deer in the headlights on this issue, that's not the case—we are actively trying to do things to ameliorate the situation.

---

From: joel jaeggli <[email-masked]>
Date: Fri, 18 Oct 2013 09:45:03 -0700

> I think there were other items on the list, but I don't remember them off the top of my head.   The point is, if anybody thinks the IESG is a deer in the headlights on this issue, that's not the ca…

The revision of the qualifications provided to the nomcom was signficant.

experiments with narrative shepherds reports.

experiments with post-ietf working-group summaries performed by chairs.

---

From: Mary Barnes <[email-masked]>
Date: Fri, 18 Oct 2013 11:50:54 -0500

On Fri, Oct 18, 2013 at 11:38 AM, Ted Lemon <[email-masked]> wrote:

> I thought we sent something around about that.   ADs and WG chairs are
> encouraged to ask for directorate reviews for certain directorates
> (possibly all directorates, I can't remember) prior to working group last
> call.   This is in the form of an experiment, not a new policy; we'll see
> how it goes.
>
[MB]  Okay. I remember this one, but I thought that was more around
improving quality than reducing workload.  [ /MB]

>
> We've done a number of other things in the same vein—e.g., document
> shepherds are now being invited onto telechats, so that they can do the
> work of tracking action items for the authors rather than the AD doing it.
>
[MB] I'm assuming this is on a case by case basis as I've not been invited
to any telechats.  And, I'm not aware that the shepherds of my own
documents have been on telechats.  For my recent docs, I've been dealing
directly with the issues via email and the not shepherd or ADs.
Certainly, the past, I worked more closely with the AD on issues from the
telechat, but I had thought that was more working style than
intentional.[/MB]

>
> I think there were other items on the list, but I don't remember them off
> the top of my head.   The point is, if anybody thinks the IESG is a deer in
> the headlights on this issue, that's not the case—we are actively trying to
> do things to ameliorate the situation.

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Fri, 18 Oct 2013 13:44:31 -0400

How about implementation reports that are done by the chairs or one chair?  Content has to come from a mix of implementers.

-Kathleen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of joel jaeggli
Sent: Friday, October 18, 2013 12:45 PM
To: Ted Lemon
Cc: IETF Discussion
Subject: Re: Proper credit for work done -- on finding chairs (was CHANGE THE JOB)

On Oct 18, 2013, at 9:38 AM, Ted Lemon <[email-masked]> wrote:

> We've done a number of other things in the same vein-e.g., document shepherds are now being invited onto telechats, so that they can do the work of tracking action items for the authors rather than the AD doing it.
> 
> I think there were other items on the list, but I don't remember them off the top of my head.   The point is, if anybody thinks the IESG is a deer in the headlights on this issue, that's not the case-we are actively trying to do things to ameliorate the situation.

---

From: Ted Lemon <[email-masked]>
Date: Fri, 18 Oct 2013 13:54:00 -0400

> How about implementation reports that are done by the chairs or one chair?  Content has to come from a mix of implementers.

Implementation reports are certainly worth doing—they're absolutely the best form of review for basic completeness of a specification, although they don't catch cross-area issues, and can give people a false sense of confidence that what they have is the right solution.   But I don't see how they would play into the problem of reducing AD workload.

---

From: John C Klensin <[email-masked]>
Date: Fri, 18 Oct 2013 13:56:54 -0400

--On Friday, October 18, 2013 10:13 -0400 Andrew Sullivan
<[email-masked]> wrote:

>> I wonder if we should be publishing, at regular intervals,
>> RFCs with explicit acknowledgements and maybe contact
>> information for Areas and ADs, WG Chairs, and, if
>> appropriate, other IETF functionaries, probably including
>> document reviewers and Nomcom members.

Hi.

I'm not going to spend much energy defending that idea.  If it
seems useful, fine.  If not, drop it.  

So one comment-message and then I'll stop

> I'm not keen on adding this cruft to the RFC series.  I note
> that the tools pages are now archived, so if you go to
> http://tools.ietf.org/wg/dnsext you will find that it's
> concluded and that Olafur and I were chair at the end.  What
> you _won't_ find is the history of other chairs.  Maybe that's
> an issue?

> On the other hand, isn't this what resumes are for?

It depends on one's purpose.  If you put in your resume that you
chaired that WG, and some wants to verify that, the tools pages
are fine.  If Olaf does, he is probably in trouble and that is
one of several reasons why one might want a back trace (but
doesn't justify an RFC).  On the other hand, if someone wanted
to know which WGs you had chaired since you started
participating in the IETF, that had better be in your resume
because trying to find it from the tools pages (even with Chair
history as well as Charter history) would be a little tedious.
(I just noticed that information isn't in my CV; maybe it should
be.)

If I'm working for a company than is credit-happy, or if I have
a boss who wants to see my name in print to justify my job,
salary, or next meeting costs, I'm perhaps likely to prefer
something a little more solid and archival.

As far as academic, etc., credit is concerned, part of what
stimulated the idea was the practice in several journals of
publishing an annual list of reviewers, partially to give credit
while keeping the reviewer-article binding confidential.   The
analogy isn't terribly good, but...

Could we do the same job by making sure that WG Chairs,
Shepherds, ADs, and other folks who move the work along are
acknowledged?  I don't know, although I agree that being
somewhat better about those sorts of acknowledgements would be a
good idea (and I just modified the template I use to remind me
to do that).  Barry might go ask whomever raised the issue what
would or would not help.

As to simply listing everyone as a co-author or otherwise on the
front page, first of all, the reason for the "tradition" was a
strong conviction that the listed person should be a real
author, document consolidator/ editor, and/or what we sometimes
call the "holder of the pen" _and_ the primary contact
person(s).   For a given document, the number of those people is
rarely more than one or two.  In that context, "five" was a
concession and everyone else goes either into Acknowledgments or
a "Contributors" section (another concession).  Do we want to go
to listing everyone in sight, including people's managers, their
managers, and perhaps their kindergarten teachers, as authors?
I hope not, but that is just my personal bias.  If nothing else,
we are doing (largely) standards and protocol specifications
here, not scientific papers and the accountability issues are
entirely different.

Or maybe there is an entirely different problem.  I was vastly
amused by a recent posting in a different thread that suggested
that much of the IETF's leadership started their professional
careers around 1987.  I've got a couple of decades on that as
does Steve Crocker who was the first person who posted a note
endorsing the RFC idea.  If the IETF conclusion is that the idea
appeals only to elderly types who didn't grow up with the web
and other modern media, then drop it.  On the other hand, Steve
and I have a tad more experience dealing with these sorts of
issue at a senior management and promotion and budget
justification level than the IETF average, so maybe it is not
_just_ a geriatric reaction.

     john

---

From: Michael Richardson <[email-masked]>
Date: Fri, 18 Oct 2013 15:29:12 -0400

John C Klensin <[email-masked]> wrote:
    > Or maybe there is an entirely different problem.  I was vastly amused
    > by a recent posting in a different thread that suggested that much of
    > the IETF's leadership started their professional careers around 1987.

I have no scientific data to defend 1987 vs 1980 vs 1970.
I think that this is a reasonable guess at an *average* year.
An average with a nice distribution would have 50% before the average,
and 50% above.

---

From: Loa Andersson <[email-masked]>
Date: Sat, 19 Oct 2013 11:10:38 +0800

Ted,

> The most useful comment I've heard on this thread is that it makes sense to credit the working group chairs as well as the authors of a document in the document at the same level of emphasis.   And…

Would this be an implementation of what you say (example built on
one of our recent RFCs)

Internet Engineering Task Force (IETF)                           M. Chen
Request for Comments: 6829                  Huawei Technologies Co., Ltd
Updates: 4379                                                     P. Pan
Category: Standards Track                                       Infinera
ISSN: 2070-1721                                             C. Pignataro
Responsible AD: A. Farrel, Juniper                              R. Asati
WG Chair/Shepherd: L. Andersson, Huawei                            Cisco
                                                             January 2013

                    Label Switched Path (LSP) Ping for
  Pseudowire Forwarding Equivalence Classes (FECs) Advertised over IPv6

Note: This is not a suggestion, just a question for clarification. And
if we want to do it "this way" it is not a layout proposal. If we do it
like this we would have a second level effect in capturing the
shepeherds, wg chairs and responsible ADs addresses in separate section
following the Authors Addresses.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Ted Lemon <[email-masked]>
Date: Sat, 19 Oct 2013 00:16:49 -0400

> WG Chair/Shepherd: L. Andersson, Huawei                            Cisco

Something like that, yes.

---

From: Tim Chown <[email-masked]>
Date: Sat, 19 Oct 2013 12:19:21 +0100

> Something like that, yes.

Worth considering, perhaps as part of improving access to the provenance of RFCs in general.  The tools area is great for tracing back the evolutuion of the document, for example.

Tim

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 19 Oct 2013 12:37:58 +0100

I am struggling to see why name an AD on the front page.
There is already a way in the Data Tracker to find out which AD "responsible" at
the time of IESG approval.
I do not want or see value in being patted on the head for the publication of an
RFC.

What is the purpose?
What would be the implication?

Adrian

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 19 Oct 2013 13:41:58 +0200

> I am struggling to see why name an AD on the front page.

Yeah, sounds dangerous.  Will further increase the threshold for getting an RFC out :-)

Seriously: The discussion was about WG chairs, and there it might make more sense.

(But my original idea was not about changing the RFC process at all, but about adding accessible information to the IETF web site.)

Grüße, Carsten

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 19 Oct 2013 13:02:03 +0100

> the time of IESG approval.

Unless another AD reassigns it before AUTH48. But your general point is valid.

>>>> WG Chair/Shepherd: L. Andersson, Huawei                            Cisco

RFC Editor website already have web pages with supplementary information (obsoleted, errata, etc). Can this information be shown there?

---

From: Loa Andersson <[email-masked]>
Date: Sat, 19 Oct 2013 20:48:22 +0800

All,

Please misunderstand me correctly!

I'm not proposing adding AD's or wg chairs on the first page of RFCs,
just trying to figure out what Ted had in mind.

Don't say I that i succeeded in that. But Ted at least nodded slightly.
Ted and Carsten approached this from  a credit perspective; I guess that
is valid. I'm more thinking about from a public "right to know"
respective - "How was that lousy wg chair that let this through?"

I admit that there are other ways to this, but the most public product
we have are the RFCs.

I think it should be discussed from both perspectives. I know that my
ADs, myself and my co-chairs and others, put enough effort into an RFCs
from end of wglc to AUTH48 to be mentioned e.g. in Acknowledgement
section, but I want to keep this strictly at the authors leisure.

So the combination giving credit and making responsibility clearly
visible makes this at least worth to discuss,

On the other hand a less more public way would be to what IAB on
their RFCs, add a section "IAB Members at the Time of Approval"!
Maybe and Appendix "WG Chairs, Shepherd and responsible AD at the
time of the Approval".

Sorry for meandering, but I feel that there is something worth
capturing in that part of the discussion.

--

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 19 Oct 2013 14:59:04 +0100

> Maybe and Appendix "WG Chairs, Shepherd and responsible AD at the

Keep it informal - authors can do this now if they want. (And
we can stop discussing it:-)

Personallly, I'd encourage authors to not add ADs unless there's
a specific reason. Within an IETF context, ADs get enough ego
boosting already.

But WG chairs do deserve more acks than they're getting I think
so if authors ack'd them frequently that'd be good.

S.

---

From: "John Levine" <[email-masked]>
Date: 19 Oct 2013 16:51:46 -0000

>What would be the implication?

If you go back to my original message on this topic, the issue was
that in many organizations, for better or worse, they measure your
productivity by the amount of author credit you get, which is why we
see scientific papers with 50 or more co-authors.

So if more author credit to WG chairs and ADs would help them persuade
their management or tenure committee or whatever that they've been
doing work that is worth supporting, we should give more author
credit.

If we think this would help, my inclination would be to put them in
the author list, and if we have a big ugly author list that runs
halfway down the page, so what? 

R's,
John

PS: In case it's not obvious, the document format is a nit.  The issue
is what will help people get funding for key IETF jobs.

                                                                R. Asati
                                                                   Cisco
						          A. Farrel (AD)
							         Juniper
						      L. Andersson (WGC)
						                  Huawei

---

From: Melinda Shore <[email-masked]>
Date: Sat, 19 Oct 2013 08:55:28 -0800

> is what will help people get funding for key IETF jobs.

That seems unlikely to me in the extreme, but I don't see a real
downside to it.

Melinda

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 19 Oct 2013 17:55:27 +0100

> halfway down the page, so what?

Ack.
Presume that it is not an issue for existing ADs (else they wouldn't have got there).
Maybe anyone who was thinking of standing who would find this helpful could speak up?

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 19 Oct 2013 19:04:50 +0200

I don't think credit for assisting work should be out of acknowledge
section, and don't give credit in work for responsible duties given by
organisation in titles/position, preferred to give credit to full title
duties not per work/task. Preferred to give credit per work mostly to whom
made efforts without given titles but their only intention is better
document/work but still IESG may not acknowledge them or not understand the
vision :(

AB

On 10/19/13, Loa Andersson <[email-masked] <javascript:;>> wrote:
>> the document at the same level of emphasis.   And possibly the ADs as
>> well.   I don't know if this would make a difference, but it's
>> interesting, and might be worth the experiment.
>
>> discussions about the woeful brokenness of the AD's job over and over
>> again without any action proposed is expensive.
>>
> Loa Andersson                        email: [email-masked]<javascript:;>
> Senior MPLS Expert                          [email-masked] <javascript:;>

---

From: Melinda Shore <[email-masked]>
Date: Sat, 19 Oct 2013 09:05:40 -0800

> Maybe anyone who was thinking of standing who would find this helpful could speak up?

It's drifted back and forth across my radar for a number of years
and I have to say that it would make no difference whatsoever.  I
can't imagine that it would make any difference to academic
candidates, either, as it would not contribute to a tenure decision
(it's not that the document is only arguably refereed for
publication, but that the chair or AD isn't even an author.  Some
universities are quite picky about what counts and what doesn't
(refereed journal articles count, textbooks don't).  I did my
graduate work at the University of Chicago, where what were called
"How we do it good here" papers were held in very high disregard.

At any rate, no, it would make no difference to me.  Might to someone
else but I'm having a hard time imagining who (the issue when I was
with the networking behemoth was time taken away from what they
hired me for, not recognition or lack thereof).

But, as I just posted in another note, I don't see a real downside
to adding it, and as someone else pointed out it may be useful for
answering provenance-type questions.

Melinda

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sat, 19 Oct 2013 14:03:40 -0400

For what it is worth, I get consulting business because my name is on RFCs.
It is not a sufficient qualification of course but it one of the ways the
search firms find me.

I don't think that we need to worry too much about the inanities of the
academic publication game. Back in the 1980s the universities were the only
places that had the computing power. That isn't a constraint any more and
they don't pay a tenth of what consulting work pays.

That game is going to be very different in a decades time in any case. The
Web is only just starting to nibble the edges of the academic publishing
racket. It takes decades for major social changes to be felt but the
transitions can be swift. The Web will do for that game what Amazon did for
book of the month club and EBay for classified ads.

---

From: SM <[email-masked]>
Date: Sat, 19 Oct 2013 11:40:08 -0700

>crazy, suggestion that follows on the retirement of the xx99 and

I missed the above the first time I read the message.  Fortunately, I 
read the message again and I noticed "wild, crazy". :-)

RFC authors get credit in the IETF system.  Reviewers don't get much 
credit in the IETF system even though the system would not work 
without reviewers.  The American Physical Society has an Outstanding 
Referee program to express its appreciation to reviewers.  The 
reviewers are selected based on the quality, number, and timeliness 
of their reviews.

There was a comment from Loa Andersson: the public has a "right to 
know" who reviewed a document.  There are times when I wondered who 
let a draft through as I was not comfortable asking a person to 
review a draft if there hasn't been any effort to review it 
previously.  Some of that information may be available in the 
datatracker but it is freeform text.  Some changes would have to be 
done for the document shepherd to be able to add who reviewed a draft 
and a link to where the review was posted.

It may be possible to use the data (see previous paragraph) to 
identify outstanding reviewers by area.  The IETF can express its 
appreciation by publishing a yearly list or an xx99 list (see comment 
from John Klensin).

Regards,
-sm

---

From: Joe Abley <[email-masked]>
Date: Sat, 19 Oct 2013 15:17:29 -0400

> On Oct 19, 2013, at 15:04, SM <[email-masked]> wrote:
>
> RFC authors get credit in the IETF system.  Reviewers don't get much credit in the IETF system even though the system would not work without reviewers.

Not to contradict you at all (I like where you're going with this) but
I've noticed that the diligence with which authors maintain the
acknowledgements sections if their documents is quite variable.

I realise it's not structured data, but it's what we have; it would be
good, I think, if working group chairs, document shepherds and
responsible ADs asked specifically about the text in that section and
encouraged/reminded authors to make sure it is complete.

This does not get us where you infer we might be aiming, but I think
it would be a step in the right direction.

Joe

---

From: Brian Trammell <[email-masked]>
Date: Sat, 19 Oct 2013 21:35:58 +0200

hi SM, all,

In my previous message on the subject
(http://www.ietf.org/mail-archive/web/ietf/current/msg83204.html) I'd
considered using the datatracker to improve the "assignment" or at least
tracking the of coverage of reviews of documents. I'd thought of this
primarily as a method to reduce final review workload (in the context of
CHANGING THE JOB), but this would be another very good reason to add
reviewer information to the datatracker.

More inline.

SM wrote:
> credit in the IETF system even though the system would not work without
> reviewers.  The American Physical Society has an Outstanding Referee
> program to express its appreciation to reviewers.  The reviewers are
> selected based on the quality, number, and timeliness of their reviews.
> 
> There was a comment from Loa Andersson: the public has a "right to know"
> who reviewed a document. 

This is a very good point.

> There are times when I wondered who let a
> draft through as I was not comfortable asking a person to review a draft
> if there hasn't been any effort to review it previously.  Some of that
> information may be available in the datatracker but it is freeform
> text. 

This is a problem with any approach to review tracking using the
datatracker -- if it's not done consistently nobody will come to rely on
it. More automated tool support would help with consistency.

> Some changes would have to be done for the document shepherd to
> be able to add who reviewed a draft and a link to where the review was
> posted.

A first pass at this would simply note reviewer, date, document
revision, and sections covered, along with the content of the review
(which, if incoming references to mailing list archives are considered
to be stable, which they should, could in most cases simply be a URL).
That would be sufficient for identifying reviewers, and would probably
do a lot to support triage of well-reviewed from poorly-reviewed
documents before they get sent up to the IESG.

> It may be possible to use the data (see previous paragraph) to identify
> outstanding reviewers by area. 

Yep.

> The IETF can express its appreciation by
> publishing a yearly list or an xx99 list (see comment from John Klensin).

Regardless of how the recognition gets disseminated, there's a lot of
value in starting to collect the data.

Cheers,

Brian

---

From: Tim Chown <[email-masked]>
Date: Sat, 19 Oct 2013 20:37:02 +0100

> "How we do it good here" papers were held in very high disregard.

It's a bit different in the UK. Things are driven by the REF exercise every few years, and there it's the quality of your best publications and any impact case studies that are a large part of the contribution. The universities have to meet the REF requirements. See http://en.wikipedia.org/wiki/Research_Excellence_Framework.

RFCs can't be used for REF, as they are not considered as academic publications (though the rigour applied to many RFCs can be greater than many conference/journals!). I suppose it *might* be possible to include the work done from an AD position as part of an impact case study, but I know of noone who has done so - I think Mark and Jon served on the IAB not the IESG. 

And I expect many countries are different, e.g. not all countries have tenure for academics.

> hired me for, not recognition or lack thereof).

The reason I like naming the AD/WG chair on an RFC is not for their credit, but to make the document provenance more explicit. It's not a strong preference though.

> answering provenance-type questions.

The main problem remains the time (and cost) of taking on a 40-hour a week "job" if you accept and succeed in a nomination for an AD position, and what suffers in terms of teaching and research while you do so.  It seems less and less people can make that committment, even if their employers do support them.

Tim

---

From: SM <[email-masked]>
Date: Sat, 19 Oct 2013 13:38:05 -0700

>acknowledgements sections if their documents is quite variable.

Yes.

>encouraged/reminded authors to make sure it is complete.

Yes.

>it would be a step in the right direction.

I was not thinking of the Acknowledgements section.  There is a 
document shepherd write-up.  That write-up can contain information 
about a draft, and among things the depth or breadth of the 
reviews.  A document shepherd can include the names of some reviewers 
and what they did.

>reviewer information to the datatracker.

I read that message. :-)

>it. More automated tool support would help with consistency.

Yes.

I think that it is better to let people decide whether they want to 
use the feature or not.

>documents before they get sent up to the IESG.

I would keep it simple; I only need the email address and the link to 
the public message to generate a report.  The information is included 
for transparency reasons.  I did not mention sections covered to 
avoid complexity.

>value in starting to collect the data.

Yes.

Regards,
-sm

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 19 Oct 2013 21:19:20 -0400

I don't think it makes any difference in academia, but I see no problem with a one sentence addition in the acknowledgements section along the lines of "This document is a product of the FOO working group, chaired by Alice and Bob, within the BAR area, with Carol as the responsible area director.", with a suitable free-form recognition ("Only their periodic public floggings of the authors caused this document to be finished.") added as relevant. The working group is often mentioned already, as far as I can tell.

I personally think this would be a good social custom, just as the recognition of reviewers has become reasonably standard, without being governed by formal rules. Shepherds might ask or suggest, as needed.

In academia, WG chair and AD responsibilities would generally be recognized as "professional service and leadership", similar to chairing academic conferences, advisory committees and other service to professional societies. Most US institutions expect this type of leadership from faculty, and are flexible in what form it takes, but it is probably considered a secondary criterion in most places. It can, however, be used by writers of recommendation letters as evidence of community standing and that tends to have non-trivial weight. ("Alice served on the prestigious IESG that manages Internet standards, and in this role ...") At least in US tenure cases, peer letters tend to play a dominant role, rather than just paper or citation counting. While the industrial research landscape seems to be changing (less academic-like), this used to be the case in places like Bell Labs and IBM Research as well.

[I have served as a CS department chair, so this is based on personal experience.]

Henning

---

From: Loa Andersson <[email-masked]>
Date: Sun, 20 Oct 2013 10:34:49 +0800

Folks,

I like where Henning is taking this, much more appropriate than the
first page thing. Though I think the Shepherd should be mentioned
separately.

One thing I consider important is that the Acknowledgment is a place
where author might read what they want. However adding the type of text
Henning proposes does not change that.

Yes I've the experience that talking to people that for one or another
reason want to do business with me, my name on RFC and/or ID is
important. This is not only in the academic world.

/Loa

--

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 20 Oct 2013 14:03:33 +1100

> see scientific papers with 50 or more co-authors.

We're not publishing academic papers here, we're creating Internet Standards. If a spec doesn't have enough market demand to have someone pony up WG chair resources to help it through the process, maybe that should tell us something.

Playing devil's advocate, you understand.

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Loa Andersson <[email-masked]>
Date: Sun, 20 Oct 2013 11:19:23 +0800

mark,

I think you underestimate the wg chair effort even it there is a
market stallion, maybe especially if there is.

/loa

--

---

From: John R Levine <[email-masked]>
Date: Sat, 19 Oct 2013 23:24:29 -0400 (EDT)

> Playing devil's advocate, you understand.

The problem is that as things currently stand, we're dependent on large 
institutions to pay their employees to be ADs.  Even were someone to want 
me to be an AD (I'm not holding my breath), I'm self employed, I couldn't 
afford it unless some third party paid my bills.

That means that we're at the mercy of managers and tenure committes and 
such who don't necessarily know much about the IETF.  Whatever we can do 
to help them understand that a) it's a lot of work and 2) it's worth it 
seems worthwhile to me.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
"I dropped the toothpaste", said Tom, crestfallenly.

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Sun, 20 Oct 2013 05:40:44 +0000

Few random thoughts 

I understand the perspective of the person you mention below but it may not be a where the name goes issues. My boss wants to know if I am the person driving the direction of the industry or if I am the person that's managing a process. The first is far more interesting. 

I note that when I am working with conferences, they are often much more interested in having a chair of WG speak than any participant of the WG. That may be useful information for employers to consider when they are thinking of about having an employee chair something. 

I certainly hope all the people that substantial helped produce an RFC,  including the Chairs, get mentioned in the Acknowledgments in a way that allow the reader to correctly understand the scope and impact of their contribution. 

Discussing what we do for chairs seems sort of nuts given we do not even list all the authors that contributed substantial text on the front page, if there is a problem to solve one might start with making sure the authors get credit. 

Most the documents I have done have required far more effort than any WG I have chaired. (Perhaps I just am a really slow at documents, or perhaps I am a really bad chair, or perhaps both but FWIW, that's my experience). 

All that said, I am really in favor of all the folks that provide useful contributions getting proper credit, but making it look like the credits for star wars is just going to dilute it to the point no one gets any credit for it.

---

From: Yoav Nir <[email-masked]>
Date: Sun, 20 Oct 2013 05:52:06 +0000

> We're not publishing academic papers here, we're creating Internet Standards. If a spec doesn't have enough market demand to have someone pony up WG chair resources to help it through the process,…

Does it ever work that way? Did a manager ever tell you, "the market needs a re-write of the HTTP documents, and being the good corporate citizens that we are, go ahead and volunteer to chair httpbis" ?

Even for the actual writing of drafts, there's multiple examples of resources being found for documents that the market does not demand, and for documents that are useful and it's hard to find people willing to edit/contribute/review. Corporations would rationally prefer to wait for some other body to pony up their human resources. The only reason we have a relatively large pool of WG chairs is that the cost is low enough such that medium to large corporations can consider this "in the noise". Apparently the time allocation for an AD job is not that insignificant.

Yoav

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 20 Oct 2013 19:31:40 +1100

> Does it ever work that way? Did a manager ever tell you, "the market needs a re-write of the HTTP documents, and being the good corporate citizens that we are, go ahead and volunteer to chair httpb…

My manager was happy to support me when I brought it up, and both they and the chain above them has done so through three successive employers. Go figure.

> Even for the actual writing of drafts, there's multiple examples of resources being found for documents that the market does not demand, and for documents that are useful and it's hard to find peop…

Like I said, devil's advocate. However, I sometimes think starting new work is too easy. The trick is sorting the speculative stuff that's important (and likely to be successful) from that which isn't.

Cheers,

---

From: Jari Arkko <[email-masked]>
Date: Mon, 21 Oct 2013 02:12:19 +0800

> [MB] Can you clue us in as to what "substantial action" has been taken?   [/MB] 

I'd classify our action as a good start. Working towards substantial, but for that we need to get these efforts in bigger scale. Anyway, based on the retreat discussions we've started the early directorate review program, started inviting shepherds to calls, and started sending documents more easily back to the WGs.

The shepherds get invited to calls on a case by case basis, based on, e.g., perceived need to discuss. The number of shepherds on calls has varied from 0 to 2 on recent telechats. The individual ADs make the invitations, but feel free to suggest joining if you think there's a need for that. The ADs sometimes forget they can do this. If you have not been invited to the telechat it may mean that you've already dealt with the issues on e-mail. Not a bad thing, as such :-)

Jari

---

From: SM <[email-masked]>
Date: Sun, 20 Oct 2013 11:45:13 -0700

Hi Jari,
At 11:12 20-10-2013, Jari Arkko wrote:
>I'd classify our action as a good start. Working towards 
>substantial, but for that we need to get these efforts in bigger 
>scale. Anyway, based on the retreat discussions we've started the 
>early directorate review program, started inviting shepherds to 
>calls, and started sending documents more easily back to the WGs.

The following directorates are listed on the IETF web site:

   Applications Area Directorate
   General Area Review Team
   Smart Power Directorate
   DNS Directorate
   IP Directorate
   Ops Directorate
   MIB Doctors
   YANG Doctors
   AAA Doctors
   Performance Metrics Directorate
   DNS Directorate
   IP Directorate
   RAI Area Review Directorate
   SDP Directorate
   Routing Area Directorate
   Security Directorate
   RSVP Directorate
   Transport Area Directorate

How many reviews have each of the above directorates performed as 
part of the early directorate review program?

How is the effectiveness of the early directorate review program assessed?

Regards,
-sm

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 21 Oct 2013 08:52:04 +1300

How about simply posting a neutral, alphabetical list of "IETF Service Records"?

John Doe - Foobar WG Chair, 1986-1990
Jane Doe - Tiptop AD, 2003-2007
Jack Sprat - IAB Member, 1988-2008

etc.

Regards
   Brian

---

From: Benoit Claise <[email-masked]>
Date: Mon, 21 Oct 2013 12:01:25 +0200

> experiments with post-ietf working-group summaries performed by chairs.
See http://www.ietf.org/mail-archive/web/ietf/current/msg79194.html
Specifically the entry"Send more documents back to the WG to complete 
the necessary changes." should help in terms of AD load.

Regards, Beonit

---

From: Benoit Claise <[email-masked]>
Date: Mon, 21 Oct 2013 12:14:59 +0200

> a specific reason. Within an IETF context, ADs get enough ego
Agreed.
> so if authors ack'd them frequently that'd be good.
... as well as document shepherd, and directorate reviewers.
As Randy Presuhn mentioned somewhere in the conversion, MIB module 
reviews (by the MIB doctors) is a very ungrateful job. The job takes a 
lot of time, much discussions, sometimes many document iterations. Those 
MIB doctors will never appear on the author lists (sometimes they should 
when I see the huge job), or are rarely mentioned in the acknowledgment 
section.
No wonder I have some difficulties to find directorate reviewers.

I'm all in favor of properly acknowledging people.
However, having a formal set of rules would NOT be a good thing.

Regards, Benoit

---

From: Loa Andersson <[email-masked]>
Date: Mon, 21 Oct 2013 18:37:30 +0800

On 2013-10-21 18:14, Benoit Claise wrote:
<snip>
>> a specific reason. Within an IETF context, ADs get enough ego

Sigh, while I think most the folks speaking up here agree to that,
it seems almost impossible to get the other side of this through.
Mentioning ADs/WG chairs are not only to give them credit for a
particular document that has been published as an RFC.

It is also easily find whom you need to hold accountable, a couple of
ADs and a few IESG generations later.

his is why I'm reluctant to place this in the Ack section, and prefer
some place similar (read "new section".

/Loa

--

---

From: Benoit Claise <[email-masked]>
Date: Mon, 21 Oct 2013 12:59:47 +0200

> particular document that has been published as an RFC.
My statement above was only about AD, not WG chairs.
> ADs and a few IESG generations later.
Interesting statement about AD and WG charis being "accountable for"? My 
views are that the document authors, the WG, and the community are 
accountable for the document content.

Regards, Benoit