Subject: Re: Comments from the IAB on NIST SP 800-90A Proceeding

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 24 Oct 2013 06:39:07 +0100

Hi Russ

The comment has a statement which I am against;
IETF standards depend on NIST standards and the process by which they are
developed.

The statement contradicts the first, that IETF references also other
government algorithms.
Is this a specific or general dependence? And does IETF standards
really depend on NIST standard process and development? Is the
statement talking about all IETF security standards?

Best regards
Abdussalam

On Wednesday, October 23, 2013, IAB Chair wrote:

> Today, the IAB sent comments to the US National Institute for Standards
> and Technology (NIST) in the matter of the NIST Special Publication 800-90A
> (Recommendation for Random Number Generation Using Deterministic Random Bit
> Generators) review proceeding.  In the statement, the IAB supports
> re-opening of the comment period on NIST SP 800-90A, and the IAB also makes
> recommendations relating to the review process for cybersecurity and
> cryptographic standards to enhance transparency and openness.
>
> The full statement is available from the IAB website:
> http://www.iab.org/wp-content/IAB-uploads/2013/10/IAB-NIST-FINAL.pdf
>
> On behalf of the IAB,
>  Russ Housley
>  IAB Chair
>
>

---

From: Riccardo Bernardini <[email-masked]>
Date: Thu, 24 Oct 2013 09:28:45 +0200

> The statement contradicts the first, that IETF references also other

I do not see a contradiction. I think that the sentence is to be
interpreted as "SOME IETF standards depend on SOME NIST standard."
This is true and it does not rule out that some IETF standards can
depend on other standards (or any standard at all).

Clearly the concern is that if some NIST standard is considered
"suspect" because of a loss of transparency (e.g., the PRNG based on
elliptic curves), the same loss of trustfulness will taint any IETF
standard that uses it.  IETF standards that do not use NIST products
are clearly not affected by this.

> Is this a specific or general dependence? And does IETF standards really
> depend on NIST standard process and development? Is the statement talking
> about all IETF security standards?
>
> Best regards
> Abdussalam
>
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 24 Oct 2013 15:35:15 +0800

Abdussalam,

> IETF standards depend on NIST standards and the process by which they are developed.
> 
> The statement contradicts the first, that IETF references also other government algorithms.
> Is this a specific or general dependence? And does IETF standards really depend on NIST standard process and development? Is the statement talking about all IETF security standards?

The point was that some IETF standards do normatively refer to NIST standards. (Look for "NIST" in RFCs and you'll find many hits.)

Of course, IETF standards also depend on many other things, including algorithms developed by others :-)

Hope this clarifies,

Jari

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 24 Oct 2013 09:38:18 +0200

On 10/24/2013 09:28 AM, Riccardo Bernardini wrote:
> does IETF standards really

As I tried to explain in 
http://tools.ietf.org/html/draft-tschofenig-perpass-surveillance-00 the 
IETF is currently not in the business of developing cryptographic 
primitives. This work is done outside the IETF (to a large extend).

Of course, our security protocols have to use cryptographic primitives 
and there is the question where do these come from.

It turns out that there are not that many organizations in the world who 
have the necessary level of expertise. NIST is one of them.

Ciao
Hannes

---

From: Russ Housley <[email-masked]>
Date: Thu, 24 Oct 2013 12:31:39 -0400

> As I tried to explain in http://tools.ietf.org/html/draft-tschofenig-perpass-surveillance-00 the IETF is currently not in the business of developing cryptographic primitives. This work is done outside the IETF (to a large extend).
> 
> Of course, our security protocols have to use cryptographic primitives and there is the question where do these come from.
> 
> It turns out that there are not that many organizations in the world who have the necessary level of expertise. NIST is one of them.

Indeed.

Some IETF standards normatively reference NIST cryptographic standards, and many of them are the mandatory to implement algorithm.  So, these IETF standards do depend on the NIST standards, and indirectly on the process by which the NIST standards were developed.

The IETF has developed it own cryptographic mechanisms when there has been a void.  RFC 3217 is one example.  When that work was done by the S/MIME WG, the group went to great lengths to get cryptographers to participate.  This is not the preferred approach, but sometimes there is a void that needs to be filled.

Russ