Subject: RE: CHANGE THE JOB (was Re: NOMCOM - Time-Critical - Final Call for Nominations)

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 17 Oct 2013 20:36:31 +0100

Hello,

> > The IESG defines the job and the IESG 'operates' the model.  So yes,
> > formally the IESG controls this issue.

Mutter.
I suppose the seated IESG defines what it does.
Or more precisely, each member of the IESG decides what (sadly) he should do to
best serve in the role.

But don't see the "job requirements" put out by NomCom as the IESG placing
requirements. 
The NomCom asks the IESG what skills and tasks are needed in the view of the
current IESG.
The IESG serves up this information and NomCom can do with it as it likes.

More important, the community can and should tell the NomCom what it wants the
IESG to do and not do.

> > However...
> >
> > Nomcom can apply pretty much whatever criteria it wants to the selection
> > process and Nomcom has been know to have some private negotiations with
> > the IESG.  Nothing as profound as the change we are suggesting, but
> > still...

Exactly.

> > It would be better for the IESG to take the initiative here and formally
> > and publicly re-define the job, but it has so far ignored such requests.

Which cuts into what Peter says since from where I sit there are many calls on
the time of an AD and it would be useful to know which tasks the community would
like me to not do (I think that I and my chief sponsor would both be happy if I
spent more time working for them and less working as an AD).
 
> It might be helpful to talk about what could change, such as:
> 
> 1. Less/no time on document reviews.

Right. Ask:
Do the reviews currently done by ADs make a difference to the quality of
individual documents or the overall canon?
Would we be happy to publish RFCs with lower quality?
Are there other ways to reliably improve the quality (like, for example, the
community doing proper reviews of their own work)?
Could discussions of Discusses go more smoothly and take less effort?

Note:
I spend more time (factor of more than 2) reviewing I-Ds when publication is
requested (from a WG) than I do reviewing at IESG evaluation.

> 2. Less time managing working groups.

Right. Ask:
Does the management of working groups improve the output?
Would we be happy to allow WGs to "muddle through"?
Could WG chairs somehow (magically?) take more responsibility and get stuff done
(some chairs do)?

Note:
A few of my WGs/chairs take most of my management time.
I don't put a lot of time into managing WGs unless something goes badly wrong.

> 3. Fewer working groups to manage.

Right. Ask:
Should an AD close a WG with a small number of people doing productive work
slowly?
Should we refuse to open new WGs until we have finished other work?
Could we reduce the number of WGs per AD by increasing the number of ADs?

Note:
Even if management of the WG is not issue, each WG produces documents to be
managed, so reducing the number does have a direct impact.

> 4. Fewer "extra" tasks (e.g., interfacing with other SDOs).

Not sure that interfacing with SDOs is a big time drag.
But other things do eat into time.  These are mainly IETF management tasks.
Arguably this is what the IESG is for. If it isn't you had better tell us!

> 5. Less/no involvement with BoFs and other early-stage efforts.

Right. Ask:
Should BoF proponents be left to flounder or should an AD help them to get their
work going?
Is a BoF shepherd from the IAB enough?
Could other people from the community fill this role?

> 6. Less/no involvement with creating the schedule.

Frankly, with the new tooling, this doesn't take more than a few hours per IETF
meeting cycle.
And that does point up a good question to ask the IESG in general - what
additional tools could significantly reduce your work load?

> Perhaps some time and motion studies are in order to figure out how ADs
> spend their time. In my experience, document reviews required a major
> time commitment.

And, since I do track my time at quite a fine granularity...

Email takes up a large lump.
Got to skim the mailing lists for each of my WGs every week.
Got to skim the mailing lists for other WGs in my area every month.
Got to skim IETF-announce and IETF-disgust daily.
Another 15 or so IETF lists that I skim weekly.
A few related lists (such as NANOG) that I skim when I can.
Emails directed to me that need attention "at once".

Please don't assume we ADs want this to be full time work.
Please do tell us what you don't want us to do, and what you would like us to do
less.

Consider whether the "IETF management" could be separated from the "document
quality".

Cheers,
Adrian

---

From: John C Klensin <[email-masked]>
Date: Thu, 17 Oct 2013 16:20:05 -0400

--On Thursday, October 17, 2013 20:36 +0100 Adrian Farrel
<[email-masked]> wrote:

>...
> But don't see the "job requirements" put out by NomCom as the
> IESG placing requirements. 
> The NomCom asks the IESG what skills and tasks are needed in
> the view of the current IESG.
> More important, the community can and should tell the NomCom
> what it wants the IESG to do and not do.
>...

Adrian,

First, we fundamentally agree, especially about the community
needing to prioritize what it is willing to have not done.

But that is where the comment that Dave, myself, and others have
made about the fate of earlier proposals to trim the job have
come in.  For example, either of the following would, I believe
and your note implies, significantly reduce the workload:

* Many years ago, there were some proposals to limit the number
of WGs to what could be effectively managed without growing the
IESG or turning it into a full-time job.  Those proposals had
some differences in the decision-making process and way of
imposing limits, but the basic ideas involved a higher creation
threshold, a ceiling on numbers,  and a fairly brutal attitude
toward non-performing WGs.  My recollection is that the fate of
both proposals is that the IESG simply refused to consider them
(but I could be wrong -- it has been a long time)

* Somewhat more recently, there were some proposals to take the
formal approval role away from the IESG and assign it to some
other body.  That would have eliminated the "review every
document and vote" part of the job description and the small
conflict involved in an AD being expected to both advocate for a
WG to the rest of the IESG and be the technical evaluator its
work of its work, replacing it with much more of a WG
management, oversight, and steering role.  That change would
also significantly reduce the requirement (or preference) that
each IESG member have significant expertise in two or three
areas in addition to her own and permit a tad more emphasis on
IESG management skills.  At least for the one of those proposals
I remember best, the IESG simply refused to consider it.

If the IESG thought those proposals were interesting at this
stage, I think the old I-Ds could be dug out, updated and
polished slightly, and posted before Monday's cutoff (I can make
that commitment for the two or three that have my name on them;
can't speak for Dave or others, but the IPR policy would, in
principle, permit anyone to retrieve those drafts and repost
them).  That would, at least in principle, permit some
discussion (perhaps even during the plenary) early enough to do
the Nomcom some good if the community and IESG actually seemed
interested.

To save an extra note...

--On Thursday, October 17, 2013 15:46 -0400 Ted Lemon
<[email-masked]> wrote:

> On Oct 17, 2013, at 3:37 PM, Brian E Carpenter
> <[email-masked]> wrote:
>> 2B. Quickly replace failing WG Chairs.
> 
> You forgot "from a magical pool of better qualified WG chairs
> who have the time and inclination to take on the work."   This
> is actually very similar to the AD acquisition problem.

Actually, it isn't.  If the Nomcom can't find a satisfactory
person to serve as AD, we have a constitutional crisis of some
flavor.   If there isn't a candidate (or, if necessary two) who
is able to satisfactorily lead and manage a WG, that is, at
least IMO, _extremely_ strong evidence that there isn't
sufficient community interest in the WG and its work.    Lack of
available leadership is actually an easier criterion for
deciding to cut off a WG than considerations about milestones or
other differences between expectations about progress and
delivery.  I don't know how much work it would get rid of in
today's environment, but it would be a very effective way of
getting rid of situations in which the AD basically had to fill
in for disfunctional WG leadership.

In addition, at least as things are now formulated, an AD is
required to have the knowledge and interest to review documents
across areas and to manage multiple groups with different tasks
and objectives (more like departmental management skills than
project management ones) as well as to make commitments in
two-year units.  WG Chairs don't have any of those requirements:
unless the WG has been permitted to explode into a many-task,
many-document, virtual subarea, they should be able to finish a
set of closely related tasks and move on.

best,
   john

---

From: Ted Lemon <[email-masked]>
Date: Thu, 17 Oct 2013 16:48:42 -0400

On Oct 17, 2013, at 4:20 PM, John C Klensin <[email-masked]> wrote:
> If there isn't a candidate (or, if necessary two) who
> sufficient community interest in the WG and its work.  

No, it's extremely weak evidence.   Being a good working group chair is a very different problem than being a technology proponent.   You might have a hundred technology proponents for a particular working group, none of whom would do a really good job as chair.   Or you might have five proponents, one of whom would be a fantastic chair.

Working group chairs are not raw material.   They are the result of growing in the organization, and they are an extremely valuable part of the organization.   Growing more working group chairs should be a serious priority of the IETF, and our failure to do this well is very much part of the AD overwork problem.

---

From: S Moonesamy <[email-masked]>
Date: Thu, 17 Oct 2013 15:14:05 -0700

>individual documents or the overall canon?

The short answer is yes.  It also ends up as more work for the Area Director.

>Would we be happy to publish RFCs with lower quality?

Yes.

>community doing proper reviews of their own work)?

Yes, there is a DISCUSS position which can be invoked. :-)

>Could discussions of Discusses go more smoothly and take less effort?

Yes.  A discussion of a DISCUSS should not generate more mail to iesg@.

>Could WG chairs somehow (magically?) take more responsibility and 

If I was a working group chair under your responsibility and you did 
not expect me to get stuff done, I don't have any reason to get stuff done.

>A few of my WGs/chairs take most of my management time.

There was a very good WG secretary in your area.  If it was my call I 
would have him doing an EDU tutorial.

>Should an AD close a WG with a small number of people doing productive work

Yes.

>Should we refuse to open new WGs until we have finished other work?

Yes, as it affects scheduling.

>Could we reduce the number of WGs per AD by increasing the number of ADs?

No, that would generate too many DISCUSSes. :-)

>Should BoF proponents be left to flounder or should an AD help them 

Somebody would have to help them.  It does not have to be an Area Director.

>Is a BoF shepherd from the IAB enough?

No, see above.

>Could other people from the community fill this role?

Yes.  Note that taking the same people and giving them more work is a 
good reason not to volunteer.

>Please do tell us what you don't want us to do, and what you would 

I would like you to work 20 hours a week instead of 80 hours a 
week.  If you ask me whether you can work 21 hours a week because the 
fate of the free world depends on it, my answer would be "no".

At 12:46 17-10-2013, Ted Lemon wrote:
>workload).   We'd like document shepherds to take on more 
>responsibility at the start, in the middle, and during the review 
>process.   Sometimes we see glimmerings of this happening.

Area Directors can do something about the above. :-)

At 13:21 17-10-2013, Olafur Gudmundsson wrote:
>For example last years Nomcom had hard time to find a Transport AD,
>why do all area's have to have 2 other than balance?

There is a wide breath of technologies for an area.  There is a low 
probability that a person can have the area-wide expertise.  Having 
two persons also means that if one person misses the issue the other 
person might catch it.

At 13:48 17-10-2013, Ted Lemon wrote:
>Working group chairs are not raw material.   They are the result of 
>growing in the organization, and they are an extremely valuable part 
>of the organization.   Growing more working group chairs should be a 
>serious priority of the IETF, and our failure to do this well is 
>very much part of the AD overwork problem.

Yes.  It is not possible to grow people overnight.  The educational 
efforts would benefit from a serious review.

Regards,
S. Moonesamy

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 17 Oct 2013 16:55:11 -0700

On 10/17/2013 03:14 PM, S Moonesamy wrote:
>> Right. Ask: Do the reviews currently done by ADs make a difference to the
>> quality of individual documents or the overall canon?
> 

As someone who implements RFCs and regularly find problems in them: No.

- -- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
Profile: http://www.linkedin.com/in/petithug

---

From: Scott Brim <[email-masked]>
Date: Fri, 18 Oct 2013 05:59:24 -0400

On Oct 17, 2013 4:20 PM, "John C Klensin" <[email-masked]> wrote:
> IESG or turning it into a full-time job.

Fyi for historical perspective: the idea of limiting the number of working
groups arose within hours of the idea of working groups itself.

There has never been an accepted way to decide whose work should be denied
except popularity, and as the IETF 's popularity swelled it became possible
to get enough people to work on almost anything.

It would be great if the IETF had a _strategy_ under which priorities and
action items could be determined.

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 18 Oct 2013 11:03:04 +0100

> More important, the community can and should tell the NomCom what it wants

How can the community know what is happening on the table of NomCom or on
the table of IESG. They need to announce information of such requirements,
opportunities, questions, decisions,

I don't know what I want IESG/NomCom to do or not to do if I don't know
(i.e. receive announcements) why they are doing things in such way and why
they are not doing things in such way. We need good statistics information
of the past history (community discussions and IESG decisions and reasons),
we have a week history documentations but still we have old participants
discussing and can be good advisers (will take longer time in process than
documenting issues) today but not  sure of tomorrow. The General Area has
no WG, that means the IETF is weak in documentations of its decisions
reason history.

> spent more time working for them and less working as an AD).

I don't think I want to distroy few tasks of ADs, it is better to know what
makes them do what they are doing, did the past community ask them to do it
or it is the need of the job nature. We should be careful if we start to
think to reduce tasks, because there may be many consequences, I prefer
delegating tasks and AD just reviews and signs outputs,

> individual documents or the overall canon?

Yes, IMHO, the ADs review is a MUST in the process.

> Would we be happy to publish RFCs with lower quality?

NO, any low quality output means low number of users/trusts, which will
distroy the IETF future,

> community doing proper reviews of their own work)?

This is true, the community SHOULD do more work, but don't forget that we
need more leaders, to direct the community which means we need more
diversity and quality.

> Could discussions of Discusses go more smoothly and take less effort?

Yes, but if every one respects each other, and if each WG chair never
ignores inputs to meetings/WG-list, and if ADs never ignore comments on
documents.

> requested (from a WG) than I do reviewing at IESG evaluation.

That is the key of IETF good quality and quality of Area outputs, so each
AD reviews all related Area documents.

> Does the management of working groups improve the output?
Yes, they SHOULD be responsible, as does the AD select the Chairs and can
fire them,

> Would we be happy to allow WGs to "muddle through"?
The WG is already responsible, so they should always comment on related
issues. I was always commenting in MANET WG, but some day I got a message
from the Chair saying that my messages on the list are very high and it is
disturbing the WG, which I think is reducing efforts and discouraging me to
add value. Some Lists in IETF still have personal response and some WG
documents are not acknowledging efforts, because their editors still think
the document is theirs not owned by WG.

> Could WG chairs somehow (magically?) take more responsibility and get

I think there should be more chairs if possible, but that depends on the
AD strategy or management,

> I don't put a lot of time into managing WGs unless something goes badly

Things go wrong when the manager/Chair responsible ignores issues, and
leaves things for the future,

> Should an AD close a WG with a small number of people doing productive work

No, but a warning is good to encourage them to bring more people into the
WG. There is not person that cannot bring more interests in the IETF,
because IETF is a friendly environment and accepts remote participants, not
only f2f participants. Please note I understood that you mean small number
of all participants not only f2f participants.

> Should we refuse to open new WGs until we have finished other work?

No we never SHOULD discourage work for the Internet community, but
recharters of old WGs SHOULD not happen often, I prefer changing old names
and making joints between WGs when the time of charter expiry comes. I
prefer reducing numbers of individual documents not WGs, because don't
forget if you stop new WGs you may get many individual work into IETF.

> Could we reduce the number of WGs per AD by increasing the number of ADs?

Yes that might be but needs a good reason, this depends on IESG decisions.
I prefer creating assistant ADs and leaving only two ADs per Area.

> managed, so reducing the number does have a direct impact.
Agree

> additional tools could significantly reduce your work load?
Agree

> Emails directed to me that need attention "at once".
That is a good list of tasks, and I encourage not only ADs to do that but
ALL participants to do that,

> Please do tell us what you don't want us to do, and what you would like us

The AD SHOULD do less job in managing WGs, because WGs should not fight in
arguments, but they should be responsible to find the way without
directions from an AD. All participants should behave like the Chair in the
WG, this make the AD happy.

> Consider whether the "IETF management" could be separated from the

That will be great if it is possible, but still the IETF SHOULD work harder
on its mentoring and marketing to get to that stage. Having participants
acting working hard like ADs will make WG quality which will make that
separation true ( separate of managment quality from document quality).

AB

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 18 Oct 2013 14:06:16 +0100

John,

> At least for the one of those proposals

One of the benefits of the way the IESG turns over is that tomorrow's IESG is
not today's.

On the other hand, the IESG serves the community as well as providing a modicum
of leadership.

If the community is insistent on some point, the IESG had better wake up. In
other words, if you can build a rough consensus in the community for some change
whether technical or procedural, what the IESG thinks is not significant beyond
pointing out flaws and providing polish. 

I am not convinced by "the IESG refused to consider."  Change the IESG to one
that will consider, or better yet, bring fully formed consensus for change to
the IESG and have it happen.

Adrian (optimist today - medication must be working)

---

From: Andy Bierman <[email-masked]>
Date: Fri, 18 Oct 2013 06:45:00 -0700

Hi Adrian,

I have asked you and other ADs several times if Assistant ADs would help.
The answer I got was "not really, but a well run directorate really helps.".

I think the IESG does an excellent job of reviewing documents.
I would not want to increase throughput by simply reducing quality.
But I know ADs who have said they wish the job was only 40 hours/week,
because it can be more than that.

Staffing critical-path full-time positions with the best people
in the industry for free isn't as easy at it used to be.

Why not double the number of ADs in each area and instead of
every AD reviewing every draft, have 2 ADs from each area
review each draft? (Cut the AD hours in half somehow)

Andy

---

From: t.p. <[email-masked]>
Date: Fri, 18 Oct 2013 15:23:03 +0100

----- Original Message -----
From: "Adrian Farrel" <[email-masked]>
To: "'Peter Saint-Andre'" <[email-masked]>; <[email-masked]>
Cc: "'John C Klensin'" <[email-masked]>; "'IETF Discuss'"
<[email-masked]>
Sent: Thursday, October 17, 2013 8:36 PM

Adrian

Depends on the AD!  I do not know if you are aware of it but yours do; I
think that what you have done on the MPLS list has improved the quality
almost beyond measure but of the lists I track, you do stand out as a
shining beacon (so much so that I do worry sometimes that you will be
unable to keep it up).  On other lists, the AD review is less, sometimes
much less; perhaps they looked and found the I-D already to
be of good quality but then IETF Last Call comes along and the I-D
is found wanting.

I think that as a general engineering rule, the earlier things are got
right, the lower the overall cost, however the last is measured, so
could the comments you make have been made earlier, e.g. prior to WGLC,
by someone else, then I think that the IETF would be in a stronger place
(but how to do that I do not know).

Tom Petch

><snip>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 18 Oct 2013 10:10:54 -0500

Andy, thank you for posting something I think I know how to reply to :-)

> review each draft? (Cut the AD hours in half somehow)

Speaking as a TSV AD, and we all know what that means :-)

What I said pretty openly in the Orlando TSVAREA discussions about ways to
make the AD responsibilities more manageable, and what I told last year's
Nomcom privately, was that I really want to try SOMETHING, rather than just
keep doing what we've always done.

Let me be clear that I've talked about this with Martin, and with other
ADs, but I'm only speaking for mysel, and I'm not proposing that this
year's Nomcom do anything differently - I'm thinking about next year, when
we'll also be reviewing the leadership positions.

The suggestion to add ADs is one that's plausible to me (unless one really
believes that no matter how many WGs are in an area, and no matter how many
docs they produce, "2" is always the perfect number, except for GEN).

The devil is in the details, of course. Let's start with whether you could
do that when the Nomcom process to add an AD because of a workload spike
takes the better part of nine months, but there áre other devilish details
that even I can think of.

What I would ask, is that people who care about this start by cataloging
proposals that have been made previously, so we don't start from ground
zero. I'm remembering, off the top of my head, a proposal to two-level the
IESG (add ADs until the task is manageable in each area, but only one AD
sits in the telechats), and a proposal to separate the charter and
management responsibilities from the document approval responsibilities
(so, something like a formal cross-area review steering group that Nomcom
would likely be in charge of staffing). I'm sure there were others.

I'm seeing many folks expressing interest in this who I didn't notice
during previous discussions, and think level-setting would be helpful.

To be clear, I'm very conscious that I'm still learning my job, and I don't
think I'm competent to evaluate what WOULD be helpful yet. But I'm also
optimistic(*) that SOMEthing would be helpful.

My plane is boarding, but best wishes as you think about suggestions.

Spencer

(*) happily, my medication is working as well as Adrian's. Perhaps we
should add "being appropriately medicated" to the position descriptions we
send to Nomcom :-)

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 18 Oct 2013 16:33:18 +0100

> The answer I got was "not really, but a well run directorate really helps.".

OK. Doesn't sound like refusing to consider. Sounds like answering your
question.

So let's take it to the next step because it may be that the current IESG cannot
conceive of how an assistant AD would work.

Can you put up a strawman of the job tasks of an assistant AD that we can work
with to discuss whether this has legs? 
Would assistant ADs be appointed and work for sitting ADs, or would they be
NomCom appointments?
Can't an AD already delegate anything they want (except the responsibility)?

> review each draft? (Cut the AD hours in half somehow)

There is mileage in that. I don't think every AD reviews every document. Some
pairs of ADs consciously split the load. Some ADs don't do detailed reviews of
documents in other areas or just focus on specific topics.

But we must get off the idea that document review is the whole of the AD load. I
think it is only around 15-20%. Maybe that rises with pursuit of Discusses
(moral: don't raise Discusses). That doesn't mean that other parts of the load
couldn't be shifted.

Cheers,
Adrian

---

From: Michael Richardson <[email-masked]>
Date: Fri, 18 Oct 2013 11:34:13 -0400

Ted Lemon <[email-masked]> wrote:
    > growing in the organization, and they are an extremely valuable part of
    > the organization.  Growing more working group chairs should be a
    > serious priority of the IETF, and our failure to do this well is very
    > much part of the AD overwork problem.

Ironically, having fewer working groups would mean having fewer working group
chairs, which would mean a smaller pool of people from which to pick ADs.

A reason we need more slots in the WG page for names (such as secretary,
key document author, issue triage expert, minutes tzar, etc.) is so that
  a) people can be recognized
  b) and the "re" (again) part of recognized means that they can be found
     again and their expertize leveraged.

--
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: Ted Lemon <[email-masked]>
Date: Fri, 18 Oct 2013 11:45:27 -0400

> review each draft? (Cut the AD hours in half somehow)

I don't review every draft (you can see which ones I didn't review on the record because I don't state a position if I didn't review the draft).   But there's a limit to how useful this is—e.g., Brian Haberman has a very different history and set of experiences in the IETF than I do, so it's not necessarily the case that we would see the same things in reading the same document (and, indeed, we usually don't).

So I base my decision to review on more of a triage approach: I review the ones that I think are most important and most likely to be understandable to me first, and then branch out from there; if I have time to read them all, I do, but if I don't, I don't guilt trip about it.   I will almost certainly miss something important at some point, but that would be true even if I reviewed every document.

So the problem is that increasing the number of ADs per area might help, but I don't think it would be linear, so it's an expensive approach.

---

From: Scott Brim <[email-masked]>
Date: Fri, 18 Oct 2013 12:15:29 -0400

> The answer I got was "not really, but a well run directorate really
helps.".

I don't see much difference between an assistant AD and a good member of a
good directorate.

> review each draft? (Cut the AD hours in half somehow)

The problem is you don't know where cross-area insight is going to come
from.

Scott

---

From: Andy Bierman <[email-masked]>
Date: Fri, 18 Oct 2013 10:39:34 -0700

Hi,

I don't think the Assistant AD job would be easy to define
or even the right approach.  IMO doubling the number of ADs
would probably work better, although at an increased cost
wrt/ managing the review process. I do not agree that
every AD needs to review every draft. The review
and WG management tasks should be shared by 4 people
instead of 2 people.

The problem I see is that few people are both qualified
and able to do full-time volunteer work for the IESG.
There is a disconnect between the official job requirements
and the real job requirements that is being ignored here.

Perhaps if the AD job really was only 20 hours a week
there would be a lot more people willing and able to
accept a nomination.

Andy

---

From: joel jaeggli <[email-masked]>
Date: Fri, 18 Oct 2013 11:07:17 -0700

> there would be a lot more people willing and able to

For better or worse I told the nomcom that I only have 2 hours a day (7 days a  week) for this… They took me anyway. The load is unevenly distributed. The internet and routing and Apps ADs appear to have more  drafts to process and more complex working group interactions, then does the ops side of ops and management.

That said, this is not a not a full time job for me and I am not compensated for doing it. If my level of available commitment isn't adequate, I guess we'll find out between now and the 2 year mark.  My contribution to the things that bring me to the IETF as on operator have dropped off because I don't have time for them.

joel

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 18 Oct 2013 20:22:58 +0100

I support that any assistant to the AD should be assigned and supervised by
that AD, in this way we create experience and may be train a new AD for
future.

The AD is free to assign/delegate tasks to those announced in the area site
or he/she free to do tasks all alone, we may call it AD team or group
(similar to design team work for WG but team has no authority). I always
work thinking that I am assistant to AD and WG within IETF, because we all
share volunteering and team work.

We don't have to name the assistant position as assistant AD, it is the job
what matters which reduces AD time of input, but that assistant should not
have AD authorities or even partial, this way many people will like to do
without responsibility pressure, and gain experience with AD task(s) and
working under AD management/ team.

AB

> On Fri, Oct 18, 2013 at 8:33 AM, Adrian Farrel <[email-masked]<javascript:;>>
> wrote:

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 19 Oct 2013 08:47:55 +1300

> with to discuss whether this has legs? 

This was discussed quite a bit within the IESG in ~2005 and there was some
discussion of Assistant Area Managers in ~2003. In practice, the result
was the strengthening of various directorates and review teams.

> Would assistant ADs be appointed and work for sitting ADs, or would they be

Definitely not NomCom, for a whole raft of reasons.

> Can't an AD already delegate anything they want (except the responsibility)?

Yes. Just try to find a willing assistant. We'll be looking in the same
pool as we do for WG Chairs and ADs, so it can't just be a matter of
delegating scut work.

> There is mileage in that. 

I don't think so. Adding ADs was another approach we discussed
in the 2005/7 timeframe. The problem is that it's hard enough to keep
a 15 member IESG cohesive. I can't imagine how a 29 member IESG
would "steer" anything. Frankly, I think you'd get squabbling.
(As Scott Brim said, we need a strategy. You won't get that from a
group of 29 people.)

> I don't think every AD reviews every document. Some

Reviewing *in itself* may or may not be the dominant load, but it
generates other work, such as arbitration between the reviewing AD
and the authors - which is definitely not always undertaken by the
shepherd. That's why pushing reviewing back to the WG would tend to
reduce the IESG's overall workload (IMNSHO).

I rather like Brian Trammell's suggestion to formalise the reviewer
role more and to improve the tools. If I was an AD today, I'd be delighted
if the tracker pointed me to various reviews (and the author's
responses).

   Brian

---

From: Andy Bierman <[email-masked]>
Date: Fri, 18 Oct 2013 13:57:19 -0700

Hi,

...

But we must get off the idea that document review is the whole of the AD
> load. I
I meant to add that the number of WGs managed would be cut in
half too -- that seems easier than splitting reviews. The number of ADs
has not really scaled to the number of WGs in recent years. I would
rather try adding ADs than shutting down WGs.

IMO it is an implementation detail how the IETG divides its work.
I agree with Brian that just delegating the undesrable work
to an assistant volunteer is not a real plan.  But if NOMCOM thinks there
is a critical shortage of IESG candidates, then the IESG better fix it,
or perhaps the NOMCOM should mandate a solution.

Cheers,
Andy

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 19 Oct 2013 11:48:06 +1300

I just rooted out a graph of IESG size over a number of years
that I created for a similar discussion 7 years ago.
As far as I know, today's numbers are identical to 2006, since
no Areas have been created or deleted and we have two ADs/Area.

http://www.cs.auckland.ac.nz/~brian/IESGsize.pdf

At that time about 125 WGs were chartered. Today we still have
about 125 WGs.

Regards
   Brian

---

From: Andy Bierman <[email-masked]>
Date: Fri, 18 Oct 2013 15:59:20 -0700

> At that time about 125 WGs were chartered. Today we still have
Hmm,  very interesting data.  So perhaps there is
no process problem at all. Perhaps economic conditions
are just reducing the candidate pool.

What if project and WG management administrative tasks
could be off-loaded to paid assistants? There must be some
tasks done by ADs that can be delegated or assisted.  The IETF
pays for RFC Editor services.  Perhaps professional project management
services would help (a ton!)

Regards

Andy

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 18 Oct 2013 17:29:53 -0700

Hi -

> From: "Brian E Carpenter" <[email-masked]>
> To: "'IETF Discuss'" <[email-masked]>
> Sent: Friday, October 18, 2013 3:48 PM
> Subject: Size of IESG, Number of Areas (Was: CHANGE THE JOB)
>
...

I wonder whether in this discussion we've been neglecting
a significant aspect of how the workload has changed.  In
reviewing and DISCUSSing work, the ADs (and directorates)
need to take into account a corpus of work (not just RFCs)
which grows ever larger.  For example, a MIB review seems
to be a lot more work now than it was twenty years ago, in
large part because there is a much larger body of established
practice to be checked for potential conflicts.

If indeed a large time sink is the time needed to DISCUSS
work, increasing the size of the IESG won't help.  Having
multiple IESGs might give better scalability.  Even splitting
the current IESG into two (one AD from each area into each
IESG) might provide better parallelism.  Of course, doing
this would require us to finally disabuse ourselves of any
notions that "the" IESG really understands everything or is
in total control of anything.

Just a thought.

Randy

---

From: Loa Andersson <[email-masked]>
Date: Sat, 19 Oct 2013 11:19:53 +0800

Folks,

I should probably keep my mouth shat about this :) ! Looking tot he RTG
area don't we have an Assistant AD, only that we call it the
RTG Directorate Chair? A very proper place to delegate work and assign
responsibility.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Ted Lemon <[email-masked]>
Date: Sat, 19 Oct 2013 00:07:45 -0400

On Oct 18, 2013, at 6:59 PM, Andy Bierman <[email-masked]> wrote:
> There must be some

Having a skilled personal secretary would make my life a lot easier, but in principle the things I'd want that person to do are things that we're asking document shepherds to do.   They just aren't generally doing them.

---

From: Ted Lemon <[email-masked]>
Date: Sat, 19 Oct 2013 00:23:47 -0400

> Having a skilled personal secretary would make my life a lot easier, but in principle the things I'd want that person to do are things that we're asking document shepherds to do.   They just aren't…

(To be clear, this has more to do with me not having gotten my act together to formally ask them to do these things than that they have been shirking—sorry to any of my document shepherds who may have read this and felt ill done by!)

---

From: John C Klensin <[email-masked]>
Date: Sat, 19 Oct 2013 03:39:44 -0400

> in total control of anything.

Whether on this hypothesis or most others, it seems to me that
splitting up the IESG horizontally (each Area represented in
each IETF) or vertically (half the Areas to one, half to the
other), with or without a significant increase in the number of
total IESG members, would almost certainly create several new
problems (some of these have been mentioned by others):

* The ability for the IESG to work as a team (and, fwiw, to be
held accountable as a team) would be much reduced.  For that
purpose, the IESG is probably very close to the maximum size.
Doubling it would fundamentally change the nature of the
process, with or without horizontal or vertical splits.  As two
obvious examples, its size is probably already above the maximum
for real conversations with the community in plenaries. Now
imagine something over 32 people on the stage in a plenary and,
if there were either split, figure out whether we need one IESG
Chair or two, which IESG the IAB Chair participates in, and so
on.  Or perhaps we should have three plenaries instead of two?

* Cross-area review would probably be weakened. It is rare for
even two ADs in an Area to have the same perspectives and
knowledge.  When they do, it is, IMO, a failure elsewhere in the
system -- diversity of perspectives, even within an Area, is a
strength.  A vertical split would mean little contact between
top and bottom layer ADs and some "interesting" questions about
what to do about, e.g., Security.

* A horizontal split would make ADs in an Area filling in for
each other in the event of illness or overload and moving WGs
back and forth to compensate for changes in load much more
difficult.  

* Any split (or even a significant growth in size) would create
(or enhance) a management nightmare around the issues that the
IESG really needs to reach agreement on as a group.  We probably
don't want different review or "voting" policies based on
semi-random decisions about where a WG or Area falls.  The issue
of what to do about Chairs and Liaisons is mentioned above.

In addition, shifting more review burden and responsibility to
directorates, etc., rather that having those reviews be advisory
to relevant ADs about issues to which they need to pay special
attention blows up accountability because decision-making
authority would effectively shift from people selected by the
Nomcom to self-selected community members.  That could easily
lead to more appeals (appeals are usually an incredibly
time-consuming process) or having the IETF in a very difficult
position if there were ever a claim of impropriety in the
decision-making about at standard.

If a split is wanted, there is another way to do it, one that
would introduce a different set of new or more complex issues
than the above and address the scaling problem differently.  See
https://datatracker.ietf.org/doc/draft-klensin-stds-review-panel/
for an example of one such proposal.  Disclaimer: I haven't
looked at that document in years and don't know whether I would
still support it,

best,
    john

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 19 Oct 2013 10:01:47 +0200

Thanks for this important graph information (it should be listed in
one of the IETF web pages), I think it should be documented in a I-D
for General Area works, still our IETF General Area outputs is weak in
my opinion which makes our/my decisions/ideas not final of what
happend and what should happen, I would blame management of not
encouraging WGs in the General Area for this problem.

However, IMHO, the number of WGs is not the important cause of problem
for AD, it is the WGs' behavior, performance, re-chartering,
milestones/output (i.e. are they in the authorised milestones) and
management, that makes the larger input-time problem for any AD or
even any IETF participant. Some IETF WGs still need more efficiency to
do their job independently on time.

AB

---

From: John C Klensin <[email-masked]>
Date: Sat, 19 Oct 2013 04:37:30 -0400

--On Friday, October 18, 2013 13:57 -0700 Andy Bierman
<[email-masked]> wrote:

>...
> IMO it is an implementation detail how the IETG divides its
> work. I agree with Brian that just delegating the undesrable
> work to an assistant volunteer is not a real plan.  But if
> NOMCOM thinks there is a critical shortage of IESG candidates,
> then the IESG better fix it, or perhaps the NOMCOM should
> mandate a solution.

In practical terms, I don't understand this paragraph.  You have
suggested increasing the number of ADs.  But, if there were a
critical shortage of IESG candidates (and it is clear that has
been the case in some areas in the recent past), then increasing
the number of slots to be filled can't solve that problem
(indeed can only make it worse), even if it held out the
possibility of a lower workload in the long run.   I'd also like
to understand what solutions you propose the Nomcom might
"mandate" and how.  As far as I can tell, they can do only three
things.  Of those, the second is unclear because it has been
much-discussed, never actually attempted, and whether or not it
is possible depends on interpretations of an edge case in the
relevant procedures.

	(1) Fill a position.  In theory and in the absence of
	other candidates, they could fill a position with a dead
	body or someone's pet rock, but I assume the IAB would
	find those candidates unqualified.
	
	(2) Decide to not fill a position.  Whatever that would
	accomplish, it would _increase_ the workload on the
	surviving AD in the area (if any) and/or paralyze the
	area.   I assume the Transport area got an adequate
	preview of that effect earlier this year.
	
	(3) Make recommendations that might or might not be
	acted on and that certainly cannot affect the current
	year's slots or candidates.

So what would you propose they "mandate" and how?

    john

---

From: Andy Bierman <[email-masked]>
Date: Sat, 19 Oct 2013 04:27:28 -0700

Hi,

I guess I don't know (or care) too much the proper chain of command to
fix this problem.  It seems that there is a job position to
be filled.  If there are not enough candidates for that job, then what?
Does the IETF adapt the job so there are more people
interested in doing it? Is this just an internal IESG decision?

If the current management structure is already optimal
and the workload is only 14 hours a week then it should be easy
to find people willing to accept IESG nominations.

Andy

---

From: Roger Jørgensen <[email-masked]>
Date: Sun, 20 Oct 2013 15:05:37 +0200

> That said, this is not a not a full time job for me and I am not compensated for doing it. If my level of available commitment isn't adequate, I guess we'll find out between now and the 2 year mark…

You're mail gave me two thoughts

1.) are our current Internet and the interconnects of thing too
complex for our current structure? Are IETF doing more than they
should in one area or another?

2.) normaly there are two reason why people stop doing things, or
don't have time for it, the normal change of interest is one thing.
The other one are probably what you're going at, no time left for
doing that.

Both of these really tell me we need to consider our structure, not
just shifting jobs or workload around. I mean, it's not the workload
alone that is causing us problems right now.
And no, I don't have any ideas right now either because I do believe
our current structure is a strength that make the quality on what we
produce to be quite high. We should not give up that quality, or lower
it...

-- 

Roger Jorgensen           | ROJO9-RIPE
[email-masked]          | - IPv6 is The Key!
http://www.jorgensen.no   | [email-masked]

---

From: Benoit Claise <[email-masked]>
Date: Mon, 21 Oct 2013 14:49:23 +0200

On 18/10/2013 17:33, Adrian Farrel wrote:
> think it is only around 15-20%.

For me, it's 3 days of reviewing documents and WG charters for the IESG formal telechat. Sometimes 4.
So 3/10 to 4/10 = 30 to 40%
To be fair, the more experienced an AD is, the less time it takes.

Then, there are documents from the WG, on which I spend a lot of time.

Regards, Benoit

> Maybe that rises with pursuit of Discusses
> .