Subject: Improving the ISOC Fellowship programme to attract people from under-represented regions into the IETF

From: S Moonesamy <[email-masked]>
Date: Thu, 10 Oct 2013 11:10:47 -0700

Hi Jari,

Here's is a draft about improving the ISOC Fellowship programme to 
attract people from under-represented regions into the IETF.  The 
draft builds upon the ISOC work, proposing adjustments and additional 
efforts, with the goal of enabling more sustained and active 
participation by contributors from under-represented regions.

In a blog article ( http://www.ietf.org/blog/2013/04/diversity/ ), it 
is mentioned that:

  "The design team will present their recommendations to the community,
   and engage in the discussion.  Recommendations with community support
   will be taken forward."

The draft only makes suggestions instead of recommendations.  I am 
copying this message to [email-masked] so that the community can 
comment about the draft.

Regards,
S. Moonesamy

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 11 Oct 2013 07:40:02 +0000

Hi,

I'm part of the design team. SM has written this document to begin a discussion with the broader IETF.

The document does not have the consensus of the design team, and it is therefore obviously not a recommendation by the design team.

Lars

On Oct 10, 2013, at 20:10, S Moonesamy <[email-masked]> wrote:
> Hi Jari,
> 
> Here's is a draft about improving the ISOC Fellowship programme to attract people from under-represented regions into the IETF.  The draft builds upon the ISOC work, proposing adjustments and additional efforts, with the goal of enabling more sustained and active participation by contributors from under-represented regions.
> 
> In a blog article ( http://www.ietf.org/blog/2013/04/diversity/ ), it is mentioned that:
> 
> The draft only makes suggestions instead of recommendations.  I am copying this message to [email-masked] so that the community can comment about the draft.
> 
> Regards,
> S. Moonesamy<draft-ddt-fellowship-03.txt>

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 11 Oct 2013 09:41:47 +0100

I am part of the community design team as well because I participate with
community more than the private hidden groups. I think that the draft is a
true work open to IETF. I still did not get a reply to my request to know
what is the DT authority, very strange name without any procedure in IETF,
please explain,

AB

On Fri, Oct 11, 2013 at 8:40 AM, Eggert, Lars <[email-masked]> wrote:

> The document does not have the consensus of the design team, and it is
> therefore obviously not a recommendation by the design team.
>
> Lars
>
> attract people from under-represented regions into the IETF.  The draft
> builds upon the ISOC work, proposing adjustments and additional efforts,
> with the goal of enabling more sustained and active participation by
> contributors from under-represented regions.
> >
> copying this message to [email-masked] so that the community can comment
> about the draft.
> >
> > Regards,

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 11 Oct 2013 09:07:03 +0000

Hi,

On Oct 11, 2013, at 10:41, Abdussalam Baryun <[email-masked]> wrote:
> true work open to IETF.

I haven't said that anything to the contrary. I am simply pointing out that the draft is not a recommendation by the design team (which we will still make at some point in the near future, hopefully.)

> I still did not get a reply to my request to know

Jari formed the design team in order to collect the issues that people have raised, organize them and then propose a few recommendations to the broader community. The design team has no authority, all we will do is propose some actions to the broader community, which will then need to get consensus there. Nothing is stopping anyone outside the design team from also thinking about these issues and making proposals.

Also, the IETF has a long history of using design teams in working groups. We also use small, focused groups for other purposes, such as BOF planning. Whatever these groups still needs to get consensus in the broader community.

Lars

---

From: <[email-masked]>
Date: Fri, 11 Oct 2013 12:11:22 +0100

> I am part of the community design team as well

... as being the coauthor of a MANET RFC!

Lloyd Wood
http://sat-net.com/L.Wood/

---

From: Jari Arkko <[email-masked]>
Date: Fri, 11 Oct 2013 15:43:07 +0300

First, lets keep the discussion on topic and not at personal level. Thank you. (This isn't addressed to you SM or Lars; it is a general comment based on some of the mails that I see.)

Secondly, this is an interesting and important topic, thank you SM for writing a draft. I do agree with at least the recommendation that for returning fellows their participation and contribution in the IETF is a key objective. I have some question marks about some of the other ones; not sure ADs in general have time to evaluate (even more) drafts, for instance. But then again I think the quality of the work is likely fairly apparent to anyone looking more closely, so not sure ADs are needed.

I do have a question for Lars though. What are your opinions on this? (You said that there is no consensus, but I'd like to hear also your thoughts.)

Jari

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 11 Oct 2013 13:22:57 +0000

Hi,

> I do have a question for Lars though. What are your opinions on this? (You said that there is no consensus, but I'd like to hear also your thoughts.)

so one key question is what influence the IETF actually has on an ISOC program. We can certainly state our wishes, but my belief is that it's ISOC's program in the end, and they can basically chose to run it as they see fit. That doesn't come out in the draft at all.

Another issue I have with the the draft is written with the implied understanding that the program should fund the repeated attendance of residents of under-represented regions who are actively participating in some sort of way. It's not clear to me that this is really what would be best in terms of increasing organizational diversity over time. I wouldn't want to fund the same people over and over; I'd much rather bring in new people all the time in the hopes of spreading the word about the IETF widely and hoping that some folks will end up in roles where they can occasionally attend on their own dime. I'd like to be able to bring in other under-represented groups (students, academics, women, etc.) We can certainly have a discussion about what is best; my point is that the draft has already decided that one approach is the way to go.

I also have a few issues with the suggestions it makes:

Section 4.1 requires that an applicant needs to already have been a participant in the IETF. That seems excessive. For returning fellows, some sort of engagement in the IETF after a while would be nice, but I can see valid cases for supporting someone's repeated attendance who isn't contributing in a very visible role. Also, I question the possibility to quantify and compare someone's impact of IETF involvement. And again, there are others than "resident of a country in an under-represented region" who we might want to bring in, and we probably don't need to fund the attendance of employees of large vendors who happen to be residents of under-represented regions.

The evaluation panel in Section 4.2 is therefore also problematic. And I wouldn't want to blindly "prioritize people who have been contributing over time to real IETF work" - we need to keep the flexibility of bringing in someone new who has high potential even if it means that someone who has been funded to attend in the past isn't going to be covered.

But my main issue is that the draft sounds like its trying to take over and redefine an ISOC program, which I don't think the IETF can or should do. The ISOC program has a purpose, a history and at least from my perspective is working pretty well with the budget it has available. I'm not sure we can actually improve it much.

Lars

---

From: Jari Arkko <[email-masked]>
Date: Fri, 11 Oct 2013 16:38:16 +0300

> we need to keep the flexibility of bringing in someone new 

agree

> But my main issue is that the draft sounds like its trying to take over and redefine an ISOC program, which I don't think the IETF can or should do. The ISOC program has a purpose, a history and at…

agree, of course. at best we can provide input. but it really is an ISOC program.

Jari

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 11 Oct 2013 17:28:36 +0100

I did not like the change of the title which was suggested in diversity
list. the first title was related to IETF, because we need to attract more
other regions in IETF or to facilitate the improve of other region's
participation. The draft's solution was to recommend fellowship (should not
be the only marketing way), which made it distract its real value. I
suggest to see how this fellowship is coordinated with IETF and how much it
attracts (real results needed), this will help the program managers to know
how IETF sees the program from the community point of view (not management
of ietf or management of the program).

AB

On Friday, October 11, 2013, Jari Arkko wrote:

> > But my main issue is that the draft sounds like its trying to take over
> and redefine an ISOC program, which I don't think the IETF can or should
> do. The ISOC program has a purpose, a history and at least from my
> perspective is working pretty well with the budget it has available. I'm
> not sure we can actually improve it much.
>

---

From: Alejandro Acosta <[email-masked]>
Date: Wed, 16 Oct 2013 20:17:46 -0430

Hello,
  I just read the new version of the draft, it's nice to see that most
suggestion/comments were added to the draft.
  First, I would like to say I do support your draft.
  Second, I noticed you changed the title of your draft from:
  "Improving the ISOC Fellowship programme to Attracting people from
under-represented regions into
the IETF"

  to

  "Improving the ISOC Fellowship programme to attract people from
under-represented regions into the IETF"

  IMHO opinion -and not being native English speaker- you improved it a
little bit but I think the previous comments suggested even something
more generic, like just improving the ISOC fellowship programme and not
only "attack" people to the IETF. I mean, it's very true you mention
several other things in your draft besides attracting people.

Thanks,

Alejandro,

---

From: Alejandro Acosta <[email-masked]>
Date: Wed, 16 Oct 2013 20:21:18 -0430

Hi

> Another issue I have with the the draft is written with the implied understanding that the program should fund the repeated attendance of residents of under-represented regions who are actively par…

I wonder if the draft should mention % of new & returning fellows.
Should it be a fixed %?.

---

From: Arturo Servin <[email-masked]>
Date: Thu, 17 Oct 2013 11:23:17 -0200

I suggested the change in the DT-list because I think that the draft
was to focused in the ISOC program to give a clear guidance in how to
attract more people to the IETF.

	In order to provide a broader guiadance we need to consider much more
things that are not yet in the draft. Also, some sections would need to
be re-written.

/as

---

From: John C Klensin <[email-masked]>
Date: Thu, 17 Oct 2013 09:49:08 -0400

--On Friday, October 11, 2013 13:22 +0000 "Eggert, Lars"
<[email-masked]> wrote:

>> I do have a question for Lars though. What are your opinions
>> on this? (You said that there is no consensus, but I'd like
>> to hear also your thoughts.)
> 
> so one key question is what influence the IETF actually has on
> an ISOC program. We can certainly state our wishes, but my
> belief is that it's ISOC's program in the end, and they can
> basically chose to run it as they see fit. That doesn't come
> out in the draft at all.

Yes.  But discussion of an I-D may help understand what the IETF
thinks would help.  Perhaps someone should propose a meeting in
Vancouver with the relevant ISOC people to exchange views about
their agenda and "ours".  Such discussions in the past (on a
completely informal, rather than "IETF position" basis, have
contributed to the evolution of the program to be more friendly
to people who are likely to actually do work in the IETF and to
some of the "returning fellows" arrangements.

> Another issue I have with the the draft is written with the
> implied understanding that the program should fund the
> repeated attendance of residents of under-represented regions
> who are actively participating in some sort of way. It's not
> clear to me that this is really what would be best in terms of
> increasing organizational diversity over time. I wouldn't want
> to fund the same people over and over; I'd much rather bring
> in new people all the time in the hopes of spreading the word
> about the IETF widely and hoping that some folks will end up
> in roles where they can occasionally attend on their own dime.

This is, to me, the essential tension in the program (or, now,
pair of programs that we often don't think of as separate).  One
can optimize it for any of at least three different categories:

(i) Bringing people in to see what the IETF is all about in the
hope that will be beneficial in other ways.  While there may be
happy exceptions, the assumption behind this category is that,
while people brought in this way may help with the IETF's role
in  various policy contexts, actual contributions to the IETF
are not expected.

(ii) Bringing people in with the hope they will participate in
and contribute to the IETF, but with no realistic expectation
that they will ever show up at a meeting again unless it it
local to them.  IMO, this is just wishful thinking unless we
really clean up our acts about remote participation, including
both full remote participation in training activities and
educational materials about IETF participation and procedures
tailored to remote participants, probably to the degree that
people who are almost entirely remote can realistically take on
leadership and WG editorial roles.  I don't believe it strikes
the right balance, but Subramanian's draft about Nomcom
participation identifies many of those issues. 

(iii) Bringing people in whom we expect to turn into active
participants, with some expectation of support for additional
meetings when that is appropriate for some reason.  If nothing
else, it is at least somewhat more realistic in the absence of
significant changes in the IETF to make it much more remote
participant-friendly (and less dependent on personal
relationships and hallway chats).

The current draft seems to be mostly focused on extending and
enhancing the third category.  I don't see it as addressing, or
calling for the elimination of, the other two.

> I'd like to be able to bring in other under-represented groups
> (students, academics, women, etc.) We can certainly have a
> discussion about what is best; my point is that the draft has
> already decided that one approach is the way to go.

Although I think the draft would benefit from clarification, I
read it differently, as noted above.  Of course, one of the
questions becomes resources -- both budgetary and mentoring and
other types of education and support.  Given that they are not
unlimited, there may ultimately have to be choices between
bringing in more likely participants and bringing in a wider
range of people to look around and understand what we do,
perhaps with the possibility that they might show up at
convenient subsequent meetings on other funding.

By the way, while I've never actively participated in an IRTF
RG, I suspect that effective mostly-remote participation there
would be a lot more practical than it is today in the IETF.

> Section 4.1 requires that an applicant needs to already have
> been a participant in the IETF. That seems excessive. For
> returning fellows, some sort of engagement in the IETF after a
> while would be nice, but I can see valid cases for supporting
> someone's repeated attendance who isn't contributing in a very
> visible role. Also, I question the possibility to quantify and
> compare someone's impact of IETF involvement. And again, there
> are others than "resident of a country in an under-represented
> region" who we might want to bring in, and we probably don't
> need to fund the attendance of employees of large vendors who
> happen to be residents of under-represented regions.
>...

I think that may generalize into "we have never been good at
developing over-specific rules that don't end up being
constraints when something obviously reasonable needs to be
done".

> But my main issue is that the draft sounds like its trying to
> take over and redefine an ISOC program, which I don't think
> the IETF can or should do. The ISOC program has a purpose, a
> history and at least from my perspective is working pretty
> well with the budget it has available. I'm not sure we can
> actually improve it much.

See above, even though we might disagree about the possibility
of improvements.

best,
     john