Subject: Sergeant at arms: please deal with [email-masked]

From: Brian E Carpenter <[email-masked]>
Date: Sun, 20 Oct 2013 10:37:25 +1300

Hi Jordi,

We seem to have a new troll using the address [email-masked]

Can you deal with it appropriately, please?

Thanks

    Brian

---

From: Techno CAT <[email-masked]>
Date: Mon, 21 Oct 2013 13:04:28 -0500

"Calling someone a troll is an ad hominem. We aren't supposed to do that in
the IETF. At least, not publicly."[1]

"It is rude.
It is bullying." [2]

HARASSMENT by Brian E Carpenter has been noted for the Legal Record

http://www.cs.auckland.ac.nz/~brian/
"Network Geeks - How They Built the Internet"

===========================

HARASSMENT by Stephane Bortzmeyer <bortzmeyer at
nic.fr<[email-masked]>>
has been noted for the Legal Record
http://www.ietf.org/mail-archive/web/ietf/current/msg83330.html

===========================

http://www.ietf.org/mail-archive/web/ietf/current/msg83360.html
"judgment needs to be applied by the ombudsperson & the rest of the IETF
management

[1] http://www.ietf.org/mail-archive/web/ietf/current/msg83364.html
[2] http://www.ietf.org/mail-archive/web/ietf/current/msg83362.html

"you are encouraged to raise your concern in confidence with one of
the Ombudspersons"
http://www.intgovforum.org
http://990s.foundationcenter.org/990_pdf_archive/541/541650477/541650477_201112_990.pdf

-- 

@Techno_CAT_r
http://Twitter.com/Techno_CAT_r

---

From: Donald Eastlake <[email-masked]>
Date: Mon, 21 Oct 2013 15:02:48 -0400

And we see below a perfect illustration of the difficulties that can
be caused by codification.

Three orthogonal points:

- We should be very careful to have only "guidelines" such that it is
clear any action based on those guidelines is only taken as a
judgement call by an authorized person or group and their is no
guarantee any action at all will be taken. Having "rules" or anything
that appears to guarantee enforcement and you may find people suing
you for failure to take immediate action when the infraction was the
most minor or arguable thing.

- I am very suspicious of the word "professional". Who knows what the
hell it means? Is the previous sentence "unprofessionally" worded? If
you think so, good. I typically see "unprofesional" used as a cudgel
against the strong expression of opinions the critic does not like
when they have no real counter argument to those opinions. Is the
April 1st RFC series something a professional group would do? I think
not. I don't know that a choice is necessary but I would prefer for
the IETF to call itself an "amateur" organization rather than a
"professional" organization.

- Generally, people should be allowed to comment causticly on others
actions but not on their motivations. If I say an action is
"obstructive" or whatever, well, that could be a matter of opinion but
at least in the open IETF process, people can see the action and might
or might not agree with me. If I say an action is "intended to be
obstructive", then, unless I am commenting on my own actions or the
actor has so stated, I am claiming the ability to mind-read...

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Mon, Oct 21, 2013 at 2:04 PM, Techno CAT <[email-masked]> wrote:
> HARASSMENT by Stephane Bortzmeyer <bortzmeyer at nic.fr> has been noted for
> the Legal Record
> "you are encouraged to raise your concern in confidence with one of the
> Ombudspersons"
>
> On Sat, Oct 19, 2013 at 4:37 PM, Brian E Carpenter
> <[email-masked]> wrote:
>>
>> Hi Jordi,
>>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 22 Oct 2013 08:05:47 +1300

Personal opinion:

1. We shouldn't tolerate anonymous postings in any case.

2. ISOC salaries are utterly irrelevant to any IETF discussion.
It's just way out of line.

Beyond that, our sergeant at arms is responsible for judging
misuse of the list.

Regards
   Brian

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 21 Oct 2013 21:45:06 +0200

Hi,

As Sergeant-at-arms, I agree with other previous postings and believe that
anonymous posting is not tolerable in the IETF mail exploders. Moreover, I
also believe that this the content of your emails are off-topic to the
IETF, even ISOC is the IETF umbrella, ISOC tax declaration and other
details is irrelevant to this list as well.

This is the reason why I've yesterday, instructed the secretariat to avoid
further postings from you.

If you decide to identify yourself, as the rest of the posters, and be
on-topic, you will be allowed to post again.

Meanwhile, refrain to use other anonymous emails, as the secretariat will
automatically keep banning you.

Regards,
Jordi

-----Mensaje original-----
De: Techno CAT <[email-masked]>
Responder a: <[email-masked]>
Fecha: lunes, 21 de octubre de 2013 20:04
Para: Brian E Carpenter <[email-masked]>
CC: Jordi Palet Martinez <[email-masked]>, <[email-masked]>,
<[email-masked]>, Jari Arkko <[email-masked]>
Asunto: Re: Sergeant at arms: please deal with [email-masked]

>"Calling someone a troll is an ad hominem.  We aren't supposed to do that
>in the IETF.  At least, not publicly."[1]
>
>"It is rude. 
>It is bullying." [2]
>
>HARASSMENT by Stephane Bortzmeyer <bortzmeyer at nic.fr
><mailto:[email-masked]>> has been noted for the Legal Record

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: SM <[email-masked]>
Date: Mon, 21 Oct 2013 13:18:07 -0700

>1. We shouldn't tolerate anonymous postings in any case.

There is a thread at 
http://www.ietf.org/mail-archive/web/dane/current/msg05855.html and 
one at http://www.ietf.org/mail-archive/web/ietf/current/msg81133.html

It is better to focus on the content instead of the messenger.

Regards,
-sm

---

From: <[email-masked]>
Date: Mon, 21 Oct 2013 22:37:51 +0100

You say that, "Brian". You respond, "SM".

A persistent identifier is helpful in sustained shared multiparty conversation; whether it represents a "real" person or not does not matter.

And who are "we"?

"L."

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of SM [[email-masked]]
Sent: 21 October 2013 21:18
To: Brian E Carpenter
Cc: [email-masked]
Subject: Anonymous postings

There is a thread at

Regards,
-sm

---

From: Melinda Shore <[email-masked]>
Date: Mon, 21 Oct 2013 13:57:29 -0800

On 10/21/13 1:37 PM, [email-masked] wrote:
> A persistent identifier is helpful in sustained shared multiparty
> conversation; whether it represents a "real" person or not does not
> matter.

Right, this is clearly a problem as stated, but there's a long
history of people posting from and participating from those
addresses, while the other is some individual whose only posts
were ad hominem.  So what's of interest here probably isn't
anon-/pseudonymity, but some sort of reputation or track record.

Melinda

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 22 Oct 2013 13:27:55 +1300

> anon-/pseudonymity, but some sort of reputation or track record.

I agree, but in this case the email address was obscure, the
content was irrelevant, and the tone was, at least to my eyes,
highly provocative. It was the sum of those three aspects that
set me off.

If someone sends well argued technical comments, or comments
on IETF procedural questions, using a pseudonym, that would
be a different matter. I can certainly imagine circumstances
in which somebody might prefer to do that.

    Brian

---

From: Melinda Shore <[email-masked]>
Date: Mon, 21 Oct 2013 16:31:11 -0800

> highly provocative. It was the sum of those three aspects that

Right, but the point (for me) is the problem isn't anonymity
or pseudonymity per se, it's that the address was completely
unfamiliar.  This was someone who was not a "regular" IETF
participant and with no track record of technical participation
who immediately popped off with some ad hominem posts.

Melinda

---

From: SM <[email-masked]>
Date: Mon, 21 Oct 2013 17:28:02 -0700

At 14:37 21-10-2013, [email-masked] wrote:
>conversation; whether it represents a "real" person or not does not matter.

Yes.

>And who are "we"?

I read the message [1] as personal opinion.

Regards,
-sm

1. msg-id: CAK41CSRKhD9W5WWm3xBJeb4U8Q6TbfG1EHnY_0BN7fC1QvO=[email-masked]

---

From: Randy Bush <[email-masked]>
Date: Tue, 22 Oct 2013 13:06:03 +0200

>    It's just way out of line.

anonymity is sometimes useful

as the ietf is legally f(isoc), isoc salaries will be relevant to those
folk inclined to spend their tine on process, organization, and
omphaloskepsis.

and to judge by the message counts on this list, far more folk are
interested in process, organization, and omphaloskepsis than in
techhical subects.

randy

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 22 Oct 2013 09:11:53 -0400

> when they have no real counter argument to those opinions.

+1

There is a technique known as 'agenda denial' in which the way a
proposition that can't be answered is addressed is to reject attempts to
raise it.

One of the examples used in the literature has to do with water rights in
parts of Texas. There are existing homes without potable water and
developers wanting to build new homes. The only way the politicians can
achieve their desired outcome is to divide up the two questions so that
these are never seen as alternatives.

So it will never be the right day to talk about water rights for the
existing residents. They will never raise the issue in precisely the
correct form.

I frequently see someone raise an issue repeatedly in the 'professional'
way only to be dismissed or ignored or promised that something will get
done when someone has time. Then they raise the same issue in a more
aggressive way and are in effect told 'because you have behaved
unprofessionally we are never going to address it'.

Which is of course a catch 22 situation.

The salaries of ISOC staff are a completely legit topic as far as I am
concerned. It is a not for profit company and it is paying a very very
large sum to the person in charge.

Who is that person accountable to? Well, I was rather under the impression
it was us.

There are reasons to make anonymous postings and reasons to call ISOC staff
to account. But there are no good reasons to make an anonymous call for
accountability of a named person.

On Mon, Oct 21, 2013 at 2:04 PM, Techno CAT <[email-masked]>
> wrote:

No, it is not ad hominem. Ad hominem is an argument of the form 'Hitler was
a vegetarian, therefore vegetarians are NAZIs'

This is an argument of the form 'Hitler was a NAZI' which is a completely
valid statement of fact.

> > HARASSMENT by Brian E Carpenter has been noted for the Legal Record

That looks like a threat to me. Threats of legal action are certainly
harassment.

-- 
Website: http://hallambaker.com/

---

From: Barry Leiba <[email-masked]>
Date: Tue, 22 Oct 2013 10:06:34 -0400

> a vegetarian, therefore vegetarians are NAZIs'

No, that's not true at all.  Your example is a different logical fallacy.

"Hitler was a vegetarian.  His idea is, therefore, wrong, because
vegetarians don't have good ideas," is an ad hominem argument --
attacking the person, rather than the content.

"This person is a troll, so we should pay no attention to what he
says," is, absolutely, an ad hominem argument.  Whether or not we
absolutely prohibit ad hominem arguments is something I'll dodge for
right now.  But let's be sure we understand the difference between
these:

1. "I don't like you, and your argument is wrong because [response
that addresses the issues]."  This might include an inappropriate
personal attack, but it's not an ad hominem argument.

2. "I don't like you, so your argument is not worth listening to."
This *is* an ad hominem argument, whether or not it includes name
calling or other unflattering characterizations.

Barry

---

From: Dave Crocker <[email-masked]>
Date: Tue, 22 Oct 2013 13:23:48 -0400

On 10/22/2013 7:06 AM, Randy Bush wrote:
> as the ietf is legally f(isoc),

The IETF is not legally ISOC.

They are two, independent organizations, with a collection of 
collaborative arrangements.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Randy Bush <[email-masked]>
Date: Tue, 22 Oct 2013 19:50:15 +0200

> The IETF is not legally ISOC.

you are correct.  legally, it is a function of isoc.  sorry about the
notational shortening.

randy

---

From: Melinda Shore <[email-masked]>
Date: Tue, 22 Oct 2013 10:41:14 -0800

The more I've been thinking about this the less comfortable
I am with how this was executed.  I have no disagreement
whatsoever with removing this person's posting privileges.
But, I have a huge problem with Jordi's statement:

  "As Sergeant-at-arms, I agree with other previous
  postings and believe that anonymous posting is not
  tolerable in the IETF mail exploders."

Clearly, there are non-trivial problems around making decisions
on the basis of something sort of like identity in unauthenticated
email.  We don't *really* know who other people are - we tend to
assume that they are who they say they are and evaluate their
credibility (or not) on things like content, reputation, past
performance, etc.  The problem with [email-masked]
isn't that he (and since we're pretty sure we know who this is,
we'll stick with masculine pronouns) has an email address
that doesn't look like a name (although his name could have
been Mars Techno Cat, as unlikely as that is).  The problem
is that he had no prior history of posting -as that name-
and posted nothing but off-topic rants and personal attacks.
I would hope that the attacks would be sufficient to have his
posting privileges revoked and that having an unfamiliar
email address would not be sufficient.

Additionally, let me suggest that finding anonymous posts
"not tolerable" is inconsistent with the perpass discussions
and concerns expressed *here* about privacy.
We want accountability in our documents and that means knowing
that the people who contribute to our work 1) have technical
substance, and 2) are having their comments and text evaluated
by other people of technical substance.  It does not necessarily
mean knowing their names or identities.  In many discussions
about privacy and about whether or not various cryptographic
technologies have been deliberately weakened by some US
government agency, there have been repeated assertion that
open processes and aggressive review provide protection
against that sort of problem.  That ought to apply here, as
well.

Anonymity is not a problem.  Behaving badly is a problem.
I really never want to see someone's ejection justified on
the basis of their putative "anonymity" again.  I am not
arguing that [email-masked] ought to be allowed
anywhere near an IETF mailing list but that the reason that
was given for throwing him off was not correct.  We should
be working to protect anonymity and privacy, not punishing it.

Melinda

---

From: Dave Crocker <[email-masked]>
Date: Tue, 22 Oct 2013 14:42:11 -0400

> you are correct.  legally, it is a function of isoc.  sorry about the

No, that's also wrong.  For example, the IETF is not a 'subsidiary' or 
'department' of ISOC.

Legally the IETF is an unincorporated, independent organization, or 
'voluntary association'[1].

ISOC is a separate corporation that provides administrative, legal and 
financial services to the IETF.

The IETF existed before ISOC.  If ISOC ceased to exist, the IETF would 
still exist, albeit with a number of administrative, legal and financial 
holes it would have to scramble to fill.

If the IETF ceased to exist, ISOC would still exist and still have a 
wide range of on-going activities, albeit a bit of a public relations 
task for filling a hole in its "story" and a financial scramble for 
finding a new recipient of a large chunk of cash.

None of this disparages either organization, but is meant to clarify the 
nature and independence of each, because folk regularly misunderstand 
the reality of the two organizations.

d/

[1] http://en.wikipedia.org/wiki/Voluntary_association
-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: John C Klensin <[email-masked]>
Date: Tue, 22 Oct 2013 14:50:03 -0400

Although I usually object to doing this, +1.  Well stated and I
strongly concur.

    john

--On Tuesday, October 22, 2013 10:41 -0800 Melinda Shore
<[email-masked]> wrote:

> on the basis of something sort of like identity in
> unauthenticated email.  We don't *really* know who other
> people are - we tend to assume that they are who they say they
> are and evaluate their credibility (or not) on things like
> content, reputation, past performance, etc.  The problem with
> [email-masked] isn't that he (and since we're
> pretty sure we know who this is, we'll stick with masculine
> pronouns) has an email address that doesn't look like a name
> (although his name could have been Mars Techno Cat, as
> unlikely as that is).  The problem is that he had no prior
> history of posting -as that name- and posted nothing but
> off-topic rants and personal attacks. I would hope that the
> attacks would be sufficient to have his posting privileges
> revoked and that having an unfamiliar email address would not
> be sufficient.
> 
> by other people of technical substance.  It does not
> necessarily mean knowing their names or identities.  In many
> discussions about privacy and about whether or not various
> cryptographic technologies have been deliberately weakened by
> some US government agency, there have been repeated assertion
> that open processes and aggressive review provide protection

---

From: Randy Bush <[email-masked]>
Date: Tue, 22 Oct 2013 20:56:05 +0200

> be working to protect anonymity and privacy, not punishing it.

<aol>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 23 Oct 2013 08:14:04 +1300

Strangely enough, I concur too.

If you look at my original complaint to Jordi, anonymity was not mentioned.
I only raised it when asked  why I requested action. And I agree: anonymity
in itself is not a problem.

Anonymity + irrelevance is a problem, in my opinion.

Regards
   Brian

---

From: Scott Brim <[email-masked]>
Date: Tue, 22 Oct 2013 15:26:12 -0400

> Anonymity + irrelevance is a problem, in my opinion.

Anonymity plus disruption.  If we can ignore it it's not a problem worth
pursuing... But note that even when identified, disruption is the central
problem with almost the same solutions.  Anonymity isn't a central issue.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 22 Oct 2013 19:36:56 +0000

On Oct 22, 2013, at 3:26 PM, Scott Brim <[email-masked]> wrote:
> Anonymity plus disruption.  If we can ignore it it's not a problem worth pursuing... But note that even when identified, disruption is the central problem with almost the same solutions.  Anonymity isn't a central issue. 

Yup.   I think when the first email message we see from a particular source is obviously disruptive and off-topic, we do not need to wait for a larger statistical sample before acting. If the disruptiveness was the result of a misunderstanding, we can correct that when we receive the apology.

I think Jordi misspoke, and we should not make a policy of doing what he said in his answer to Brian.   But I haven't seen anything thus far to suggest to me that the action taken was the wrong one.

---

From: SM <[email-masked]>
Date: Tue, 22 Oct 2013 12:45:01 -0700

Hi Melinda,
>   tolerable in the IETF mail exploders."

As a matter of individual opinion I would not remove the person's 
posting privileges.  The reason is because it can be argued that 
there is bias.  The statement could have considered the issue instead 
of what other people are saying.

>performance, etc.  The problem with [censored]

Yes.

>and concerns expressed *here* about privacy.

Agreed.

>technologies have been deliberately weakened by some [censored]

Yes.

>Anonymity is not a problem.  Behaving badly is a problem.

The above is well-said.

Regards,
-sm

---

From: Jari Arkko <[email-masked]>
Date: Wed, 23 Oct 2013 03:46:51 +0800

> Strangely enough, I concur too.

Agree here as well.

FWIW and in full disclosure, I was in agreement with the suggestion that the mail was problematic, and told Brian and Jordi about my opinion. I still think so, but in retrospect I should have specified why I believed there was a problem (NOT due to anonymity). Had I done that, I'm sure Jordi's e-mail would have had a different text, even if the outcome would have been the same. Sorry. We'll improve communication in the future.

I have another observation from this case that we might try to learn from. If people have an issue with a posting, should they contact the sergeant-at-arms in public or in private?

Jari

---

From: Melinda Shore <[email-masked]>
Date: Tue, 22 Oct 2013 12:00:02 -0800

On 10/22/13 11:46 AM, Jari Arkko wrote:
> I have another observation from this case that we might try to learn
> from. If people have an issue with a posting, should they contact the
> sergeant-at-arms in public or in private?

I think that either is fine, although in the interest of transparency
and the ability to file appeals, actions should be public.

Melinda

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 22 Oct 2013 21:40:03 +0100

As I noticed that f2f meetings should present their name before talking so
it is good no anonymous talks. I think there is a hidden problem in
anonymous posting, how can I network with someone I cannot trust because
he/she does not trust participants by sharing identity. I post with a
known name but get some participants discredits me with that name (a reason
why some people hide real names), so they taking things to personal or
trying to make poster become change to anonymous or become with no trust of
the IETF system.

All should respect others, so we can work together with more trust. I am
against IETF allowing workers becoming anonymous because no one will trust
it or even follow it. I started to be afraid that most IETF management or
participants or authors may have registered without their real name.

An anonymous poster should go through a process with a known participant to
proof that he/she is not attacking the system. That participant may sponsor
the anonymous poster to enable the continue of anonymous remote
participation.

AB

---

From: Melinda Shore <[email-masked]>
Date: Tue, 22 Oct 2013 12:49:57 -0800

On 10/22/13 11:36 AM, Ted Lemon wrote:
> I think Jordi misspoke, and we should not make a policy of doing what
> he said in his answer to Brian.  

Right, but as a matter of public record,

really should not be allowed to stand.

Melinda

---

From: Randy Bush <[email-masked]>
Date: Tue, 22 Oct 2013 22:55:20 +0200

> sergeant-at-arms in public or in private?

if i, as a normal citizen, have an incident with someone's egregious
action in a public place, should i contact the executioner in public or
private?

wrong question, at least in the culture in which i was raised.  we pay
lip service to the concept that there should be a bit of 'due process'
between a complaint and the executioner (and then spy on you and bomb
you into democracy).

From: Ted Lemon <[email-masked]>
> I think when the first email message we see from a particular source
> is obviously disruptive and off-topic, we do not need to wait for a
> larger statistical sample before acting.

i am a bit taken aback by the vigilantism.  

it was just an email message, and a factual one at that.  the usual
example is _falsely_ shouting "fire" specifically because it can cause
*actual* *physical* *harm*.  get a delete key.  get procmail.  get a
grip.

randy

---

From: Thomas Narten <[email-masked]>
Date: Tue, 22 Oct 2013 17:11:57 -0400

>  from. If people have an issue with a posting, should they contact
>  the sergeant-at-arms in public or in private?

In private please, first. And maybe also cc a small number of
relevant/interested folk so there can be a private discussion.

Not every action we do should start in public. 

For starters, it's human nature 101 that resolving matters in private
is generally easier than resolving them after the stakes have been
raised. Being public about some things is by its very nature an
escalation.

There is a time for doing things in public, but we shouldn't always
start there.

Thomas

---

From: Ted Lemon <[email-masked]>
Date: Tue, 22 Oct 2013 21:13:32 +0000

> really should not be allowed to stand.

Let's give Jordi some time to respond.   I don't think he reads the list more than once a day, so he's probably innocently wondering why his ears are burning.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 22 Oct 2013 21:21:49 +0000

> *actual* *physical* *harm*.  get a delete key.  get procmail.  get a

Right, that's not the policy.   If that were the policy, a number of notorious abusers of the mailing list would still have posting privileges.

If the first message had been the beginning of a conversation, I would have taken it a lot differently, but the way it was dropped on the list with no discussion, it just looked like an attempt to start a massive flame war.   That's exactly the sort of thing that the sergeant-at-arms is supposed to deal with.

---

From: John C Klensin <[email-masked]>
Date: Tue, 22 Oct 2013 17:48:02 -0400

--On Tuesday, October 22, 2013 21:21 +0000 Ted Lemon
<[email-masked]> wrote:

>> it was just an email message, and a factual one at that.  the
>> usual example is _falsely_ shouting "fire" specifically
>> because it can cause *actual* *physical* *harm*.  get a
>> delete key.  get procmail.  get a grip.
> 
> Right, that's not the policy.   If that were the policy, a
> number of notorious abusers of the mailing list would still
> have posting privileges.
> 
> If the first message had been the beginning of a conversation,
> I would have taken it a lot differently, but the way it was
> dropped on the list with no discussion, it just looked like an
> attempt to start a massive flame war.   That's exactly the
> sort of thing that the sergeant-at-arms is supposed to deal
> with.

Ted, that is, IMO, an entirely reasonable comment about
inappropriate content, but, even then, our normal practice is
for the sergeant-at-arms or some other appropriate parties to
discuss and warn (usually and preferably in private first), not
take preemptive action.  "Discuss and warn first" may be a
first-order approximation to Randy's observation about due
process, or at least part of it.

The other thing that may make this situation special is that
several people are convinced that, despite the new address, the
person who made the posting is a serial (or, in your terms,
"notorious") abuser who has been banned from IETF lists before.
If that is actually the case, then preemptive action to prevent
further postings is appropriate, possibly including initiating
the RFC 3683 procedure and being done with this.

But none of that has anything to do with anonymity.  

I think it is reasonable to expect that, if the sergeant-at-arms
concludes that public action is necessary, that action and the
reasoning for it be carefully and precisely explained and even
adjusted for the record after the fact if the explanation wasn't
quite right.  If nothing else, getting the right documentation
in place is very important should anyone ever decide to
initiation a 3683-style global posting rights action.

I do not intend to criticize Jordi in any of this.  We
(fortunately) rarely have the provocation and need to do this.
We need to rely on good judgment rather than collections of
specific-seeming rules that would, themselves, be likely sources
of controversy and his judgment has generally been good.  We
should, however, all try to learn from experience, including
this one.

And, fwiw, I think we should try to see what can be learned that
might apply to harassment complaints.  By their nature, IMO,
those complaints are much more likely to be subjective and
difficult than whether someone has abused or improperly used a
mailing list.

   best,
   john

---

From: <[email-masked]>
Date: Tue, 22 Oct 2013 23:00:01 +0100

"Jordi" (if that is indeed your real name)

> anonymous posting is not tolerable in the IETF mail exploders.

Is that IETF policy?

As sergeant-at-arms, you should be implementing previously agreed consensus IETF policy, not taking the results of an opinion poll on the hoof.

You're entitled to have a personal opinion and belief on this, but you can't then express that opinion as "sergeant-at-arms". It's a personal belief, under a different hat. Therefore, wherever you say "I believe" I read "my personal opinion can be disregarded in and is entirely separate to previous consensus that my role as sergeant-at-arms enforces"

By "avoid" you mean "ban" or "censor", no?

And that blanket ban on anonymous emails suggested by your last paragraph raises policy concerns. Just picking an example, "[email-masked]" seems quite anonymous to me. I have no idea who that person is. I would therefore request that that person be banned from the IETF list under your terms, except by what you say that address is now banned automatically, along with all other email addresses that person attempts to use? And how does this automatic identification and banning of anonymous mail addresses work, anyway?

Lloyd Wood
http://sat-net.com/L.Wood/

thinks any discussion of ISOC is entirely appropriate for the IETF main list. Yay, transparency!

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of JORDI PALET MARTINEZ [[email-masked]]
Sent: 21 October 2013 20:45
To: [email-masked]; IETF Secretariat
Cc: [email-masked]
Subject: Re: Sergeant at arms: please deal with [email-masked]

Hi,

Regards,
Jordi

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 23 Oct 2013 00:01:46 +0200

I may have worded out too quickly my email, and actually looks like it was
more important for my decision the anonymity issue vs the off-top
question, but is still my opinion that this address must be banned.

We could take a decision on future anonymous postings, if required, I'm
always pro-privacy, but I don't think this is applicable in IETF works,
and this include exploders. Again this is my personal point of view.

Regards,
Jordi

-----Mensaje original-----
De: Ted Lemon <[email-masked]>
Responder a: <[email-masked]>
Fecha: martes, 22 de octubre de 2013 23:13
Para: Melinda Shore <[email-masked]>
CC: "<[email-masked]>" <[email-masked]>
Asunto: Re: Sergeant at arms: please deal with [email-masked]

>Let's give Jordi some time to respond.   I don't think he reads the list
>more than once a day, so he's probably innocently wondering why his ears
>are burning.
>

---

From: Christian Huitema <[email-masked]>
Date: Tue, 22 Oct 2013 22:28:24 +0000

> The other thing that may make this situation special is that several people are convinced that, 
> despite the new address, the person who made the posting is a serial (or, in your terms, "notorious") 
> abuser who has been banned from IETF lists before.

Whoever that was, they certainly succeeded in creating a lot of noise on the IETF list.

-- Christian Huitema

---

From: Masataka Ohta <[email-masked]>
Date: Wed, 23 Oct 2013 09:01:24 +0900

JORDI PALET MARTINEZ wrote:

> We could take a decision on future anonymous postings, if required,

That no formal identification is required to join IETF mailing
lists nor face to face meetings means that we all are considered
to be anonymous, except that we can identify each other by one's
mail address, for which, "[email-masked]" is good
enough.

Or, do you think that "[email-masked]" is fine but
"[email-masked]" is not?

						Masataka Ohta

---

From: joel jaeggli <[email-masked]>
Date: Tue, 22 Oct 2013 17:39:27 -0700

> process, or at least part of it.

Weirdly on last weeks' iesg informal, the issue of do we need to revisit the seargent at arms approach/methodology came up. RFC 3005 is a while ago and it not something that has had a lot of attention in the interim. 

I'm not personally interested in being highly proscriptive and in the end these things are going to come down to judgement calls with the potential for an appeals process. The infrequency with which they are applied I think says that in the general case they're not the first order tools for managing list discourse, but it also means when they are applied either the ducks really have to be in a row, or questions about the application will ensue.

---

From: Melinda Shore <[email-masked]>
Date: Tue, 22 Oct 2013 16:45:27 -0800

> and this include exploders. Again this is my personal point of view.

Is this your personal point of view of what the IETF
has agreed to, or is this your personal point of view
of what the IETF policy ought to be?

We had that discussion of anonymity vs. pseudonymity several months
ago and I don't think that any specific policy came out of it.
Several areas of concern were identified, most notably that
there may be some IPR issues which are masked by not identifying
yourself sufficiently to be able to determine institutional
affiliation/employment.  That doesn't seem to apply here.  It
may be case that we need to establish more explicit policies
around pseudonymity in IETF participation.  I hope that's not
the case but I'd like to make sure that we aren't making a
stand for anonymity and privacy in theory while not making
one in practice.

Melinda

---

From: SM <[email-masked]>
Date: Tue, 22 Oct 2013 22:37:20 -0700

Hi Jordi,
>and this include exploders. Again this is my personal point of view.

There was a decision to ban (see above) an email address because of 
two messages sent to the mailing list.  I read the mailing list 
archive and did not find any warning.  The advice given was:

   "If you decide to identify yourself, as the rest of the posters, and be
    on-topic, you will be allowed to post again."

I read the quoted text (see above).  I cannot tell which part of it 
is a personal opinion and which part is the opinion of the 
sergeant-at-arms.  The decision comes out as "I don't like what you 
said.  The explanation for my decision might not be that good but I 
already made up my mind".  The rest of the posters do not identify 
themselves unless a person considers that [local-part]@gmail.com 
conveys any meaningful information.

Regards,
-sm

---

From: Jorge Amodio <[email-masked]>
Date: Wed, 23 Oct 2013 05:04:36 -0500

What part of this endless amplification of noise contributes to "make the Internet work better" ?

-Jorge

---

From: Scott Brim <[email-masked]>
Date: Wed, 23 Oct 2013 09:35:50 -0400

On Tue, Oct 22, 2013 at 5:21 PM, Ted Lemon <[email-masked]> wrote:

> If the first message had been the beginning of a conversation, I would
> have taken it a lot differently, but the way it was dropped on the list
> with no discussion, it just looked like an attempt to start a massive flame
> war.   That's exactly the sort of thing that the sergeant-at-arms is
> supposed to deal with.
>

I didn't mind the mail, but I didn't mind the request for suspension either
because he/she had been sprinkling silliness across multiple lists, and
content was becoming more disruptive.

---

From: "Richard Shockey" <[email-masked]>
Date: Wed, 23 Oct 2013 10:36:58 -0400

IN line below..

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Melinda Shore
Sent: Tuesday, October 22, 2013 2:41 PM
To: [email-masked]
Subject: Re: Sergeant at arms: please deal with [email-masked]

The more I've been thinking about this the less comfortable I am with how
this was executed.  I have no disagreement whatsoever with removing this
person's posting privileges.
But, I have a huge problem with Jordi's statement:

Clearly, there are non-trivial problems around making decisions on the basis
of something sort of like identity in unauthenticated email.  We don't
*really* know who other people are - we tend to assume that they are who
they say they are and evaluate their credibility (or not) on things like
content, reputation, past performance, etc.  The problem with
[email-masked] isn't that he (and since we're pretty sure we know
who this is, we'll stick with masculine pronouns) has an email address that
doesn't look like a name (although his name could have been Mars Techno Cat,
as unlikely as that is).  The problem is that he had no prior history of
posting -as that name- and posted nothing but off-topic rants and personal
attacks.
I would hope that the attacks would be sufficient to have his posting
privileges revoked and that having an unfamiliar email address would not be
sufficient.

Additionally, let me suggest that finding anonymous posts "not tolerable" is
inconsistent with the perpass discussions and concerns expressed *here*
about privacy.
We want accountability in our documents and that means knowing that the
people who contribute to our work 1) have technical substance, and 2) are
having their comments and text evaluated by other people of technical
substance.  It does not necessarily mean knowing their names or identities.
In many discussions about privacy and about whether or not various
cryptographic technologies have been deliberately weakened by some US
government agency, there have been repeated assertion that open processes
and aggressive review provide protection against that sort of problem.  That
ought to apply here, as well.

[RS> ]  That is the central issue.  Anonymity cannot be used as a shield to
protect abusive or criminal behavior.  That is an issue some of us are
struggling with in the RAI area with STIR and the global voice
communications network.  The right to privacy is also in part a "right to be
left alone".  

I really never want to see someone's ejection justified on the basis of
their putative "anonymity" again.  I am not arguing that
[email-masked] ought to be allowed anywhere near an IETF mailing
list but that the reason that was given for throwing him off was not
correct.  We should be working to protect anonymity and privacy, not
punishing it.

[RS> ] With exceptions.  Nothing is absolute here.  There are exceptions
where various actors, state or otherwise, have to be able to break the cloak
of anonymity in order to protect the safety and health of others.  Sometimes
..sometimes the needs of the many outweigh the desires of the few. 

Melinda

---

From: Ted Lemon <[email-masked]>
Date: Wed, 23 Oct 2013 15:17:34 +0000

On Oct 23, 2013, at 9:35 AM, Scott Brim <[email-masked]> wrote:
> I didn't mind the mail, but I didn't mind the request for suspension either because he/she had been sprinkling silliness across multiple lists, and content was becoming more disruptive. 

Seeing all the pushback from my earlier comment, I realize that there's a distinction here that we aren't making explicit, but that I think is important.   It's inappropriate to spam IETF mailing lists.   Spamming IETF mailing lists isn't covered under the warn first, sanction later model, because what you want with spam is for it to stop now, not later.

To me, what's being described here is similar to situations we've seen in the past where someone subscribes to all the IETF mailing lists and starts posting conference invites on them.   People have tended to be pretty patient about this, because it's not so utterly far off topic that it looks just like pill spam.   But it really is spam—it's unsolicited, unwelcome, not contributing to a meaningful dialog.

Randy says we should just delete it ourselves rather than blocking it.   Given that people can't post without subscribing or being moderated, that's not completely unreasonable—the usual vector for spam is an unmoderated mailing list, and we don't have that particular problem.   But we have in the past blocked people who post conference spam, and I thought that made sense at the time.   I still think it makes sense.   But I agree that in theory it doesn't match the warn-first policy.

There are three ways we can deal with this, I think:

  - Keep the existing policy unchanged: in this case we should have sent a warning.
  - Add an AUP on subscription, and count that as a warning in the case of spam.
  - Change the policy to specifically say that spammers will be blocked without warning.

My personal feeling is that the email that triggered this debate was a deliberate troll, and that trolls have the potential to be really disruptive.   And so I think we _should_ block first and ask questions later, as a deliberate policy.   We have appeals, and we have debates like this one, so I think that the harm of blocking too actively is minimal.   But the various people who have argued that this is a new policy are right, and I think it's worth being clear on that.

---

From: Randy Bush <[email-masked]>
Date: Wed, 23 Oct 2013 17:43:02 +0200

the chilling effect of vigilateism is far worse than spam or trolls.
we've been dealing with the latter for decades, and there is little
actual real harm if any.  the chilling effect of vigilanteism causes
actual harm and reduces the rich diversity of opinion, culture, and
viewpoint.

randy

---

From: Dave Crocker <[email-masked]>
Date: Wed, 23 Oct 2013 11:46:41 -0400

On 10/23/2013 11:43 AM, Randy Bush wrote:
> actual real harm if any.

That's quite simply and observably wrong.

When a list is subject to high noise levels, legitimate participants 
leave.  It's true for this general IETF discussion list and it's true 
for working group lists.  And it happens regularly.

d/

---

From: Douglas Otis <[email-masked]>
Date: Wed, 23 Oct 2013 11:37:14 -0700

> actual harm and reduces the rich diversity of opinion, culture, and

Dear Randy,

I agree. It seems some think greater progress is made by ignoring any definition of fair treatment.  

Regards,
Douglas Otis

---

From: [email-masked]
Date: Fri, 25 Oct 2013 09:53:34 -0700 (PDT)

> actual harm and reduces the rich diversity of opinion, culture, and

I could not agree more. By condoning such measures people are damaging the
diversity they are supposedly trying to support.

				Ned

---

From: "John Levine" <[email-masked]>
Date: 26 Oct 2013 02:40:04 -0000

>> the chilling effect of vigilateism is far worse than spam or trolls. ...

>diversity they are supposedly trying to support.

I could not disagree more.  The spam and trolling create an unpleasant
environment that drives people away.  Anyone who's run mailing lists
for a while has seen this pattern over and over, in which a tiny group
(sometimes just one) of obnoxious subscribers ruins a list and most of
the useful members leave.  The ones who remain are thick skinned or
socially oblivious, and are disproportionately middle aged North
American white guys who acted like this when they were undergrads.  We
are all big boys and girls here.  It should be entirely within our
abilities to be reasonably polite and relevant in our correspondence.

In this particular case, the execution was clumsy, but the action was
entirely appropriate.  We saw messages that were utterly irrelevant,
from an address that had never sent anything else, in a style that
strongly suggested it was a sock for a chronic troublemaker.  Why
should we put up with that kind of nonsense?

I also have to laugh at "vigilanteism."  There is no government
process that vigilantes are circumventing; the sergeant at arms
kicking people off the list IS the process.

A useful kind of vigilanteism is private messages to people
encouraging them not to engage with trolls, or to back off when
they're getting too abrasive.  I have received both, and I appreciate
that people have taken the effort to give me a nudge.

R's,
John

---

From: Jorge Amodio <[email-masked]>
Date: Fri, 25 Oct 2013 21:52:54 -0500

Amen

-Jorge

> On Oct 23, 2013, at 10:43 AM, Randy Bush <[email-masked]> wrote:
>

---

From: Jorge Amodio <[email-masked]>
Date: Fri, 25 Oct 2013 21:54:05 -0500

Feed the trolls and they will keep growing, ignore them and they will dry and die

-Jorge

---

From: Melinda Shore <[email-masked]>
Date: Fri, 25 Oct 2013 19:20:21 -0800

>> actual harm and reduces the rich diversity of opinion, culture, and

I think John's point - that this wasn't vigilantism, it was the
agreed-upon process - is not a minor one.  I think that the lack
of clarity around Jordi's reasons for booting someone call
that into question, but we've got a process for dealing with
posters who are disruptive and not much more and that process
was invoked.

I'm still bothered by the possibility that our Sergeant-at-
Arms booted someone off the list because of his personal antipathy
towards anonymity, and I hope this is being dealt with by somebody,
somewhere.

Melinda

---

From: David Conrad <[email-masked]>
Date: Sat, 26 Oct 2013 00:18:54 -0400

Jorge,

> Feed the trolls and they will keep growing, ignore them and they will dry and die

In this particular case, the troll in question doesn't need responses to be fed -- he doesn't appear to care if anyone responds to his notes.  In the past 20+ years he's been spewing oddly capitalized nonsense to various lists and websites until he's been banned, ignoring him hasn't caused him to dry and/or die.  

In most social situations where an individual is being a bore, most folks I'm aware of simply walk away. In the context of mailing lists, this usually translates to just unsubscribing. I'll admit being unsure that sacrificing potentially useful contributors just so a known disruptive individual can continue posting irrelevant drivel is an appropriate course of action.

If you have a commons and one of the users of the commons is peeing all over the grass so that the sheep won't eat, do you continue to allow that user entry into the commons?

Regards,
-drc

---

From: Roger Jørgensen <[email-masked]>
Date: Sat, 26 Oct 2013 09:57:42 +0200

On Sat, Oct 26, 2013 at 4:40 AM, John Levine <[email-masked]> wrote:
<snip>
> should we put up with that kind of nonsense?

+1 to that.

I've keept quiet in this case because it was such an obvious case of
troublemaker that showed up.

Can we let it go and move on since it seems like we actual agree but
just need something to discuss?

-- 

Roger Jorgensen           | ROJO9-RIPE
[email-masked]          | - IPv6 is The Key!
http://www.jorgensen.no   | [email-masked]

---

From: Jorge Amodio <[email-masked]>
Date: Sat, 26 Oct 2013 20:29:36 -0500

> If you have a commons and one of the users of the commons is peeing all
> over the grass so that the sheep won't eat, do you continue to allow that
> user entry into the commons?
>

I'll get rid of the sheep :-)

Regards,
-J

---

From: Olaf Kolkman <[email-masked]>
Date: Mon, 28 Oct 2013 08:42:22 +0100

> Anonymity + irrelevance is a problem, in my opinion.

I’ve raised this before, but Brian’s mail triggered me to bring it up again:

IMHO, anonymity and technical contributions in the IETF are a problem too. The IETF policy on IPR breaks down if you do not know who to go after if contributions made by anonymous persons turn out to be tainted after standardization.  

Anonymity in a debate that doesn’t lead or influences a standard action is not a problem (the merit of the argument counts).

—Olaf

---

From: Douglas Otis <[email-masked]>
Date: Tue, 29 Oct 2013 15:38:02 -0700

> diversity they are supposedly trying to support.

Agreed.  Not all interests will be met but each should have a voice within an open and transparent process.  It would be a pity to allow censorship or political propriety to place this process behind hidden barriers.

Regards,
Douglas Otis

---

From: "Dan Harkins" <[email-masked]>
Date: Wed, 30 Oct 2013 01:00:42 -0700 (PDT)

On Fri, October 25, 2013 9:18 pm, David Conrad wrote:
[snip]
> user entry into the commons?

  If you don't they're not "commons" anymore. Perhaps the commons are
improved if the sheep don't eat the grass and peeing on it is the easiest way
to ensure the well-being of the commons. Regardless, this is a piss-poor
analogy. The posts in question did not amount to some kind of denial
of service attack in the way that peeing on grass resulted in the sheep
refusing to eat. And just who are the sheep here anyway? What's up with
this chattel arrangement?

  Dan.

---

From: TSG - personal <[email-masked]>
Date: Wed, 30 Oct 2013 14:26:56 -0700

On 10/29/2013 03:38 PM, Douglas Otis wrote:

The real issue is how after the fact you would disprove digital 
tampering with the participation process... i.e. that censorship filters 
were not installed into the mailing process to

1)    Separate any voice setup to be isolated
2)     Send that person mail to make it look like they are still 
participating...
3)    Edit their commentary back in to the history file to complete the 
covering up of the fraud.

You would have to have multiple addresses for a number of lists right?

Todd

---

From: Ted Lemon <[email-masked]>
Date: Wed, 30 Oct 2013 22:11:49 +0000

On Oct 30, 2013, at 5:26 PM, TSG - personal <[email-masked]> wrote:
> 2)     Send that person mail to make it look like they are still participating...
> 3)    Edit their commentary back in to the history file to complete the covering up of the fraud.

In point of fact, I get the strong impression that plenty of participants in IETF mailing lists block email from other specific participants, which presents a small version of the same effect.   However, in practice the tampering you are theorizing about would actually be trivial to detect—just set up two email addresses with no obvious connection between them, and subscribe them both to the same mailing list.   Send mail from one address; if the other address doesn't receive it, cry foul.

Let's not be so paranoid that we all wind up crawling into our tortoise shells.