Subject: NIST documents

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 3 Oct 2013 11:02:33 +0000

One draft I'm working on references some standard NIST cryptographic documents. (RFCs don't include everything we need.)  I need to check some details therein. Unfortunately the current US government shutdown has taken NIST's website, including those documents, offline. And (not considering this possibility) I didn't download copies of them.

Any link to where copies of such documents are kept would be useful. (Of course I haven't been able to check the copyright on them to know if that's legal, so there may be no appropriate site.)

Otherwise, consider the above an observation.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Ralph Droms <[email-masked]>
Date: Thu, 3 Oct 2013 07:11:09 -0400

Try Wayback, http://archive.org

- Ralph

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 3 Oct 2013 11:21:41 +0000

Good call, thanks Ralph.

Should it be useful to anyone else, the relevant link for what I was after is
http://web.archive.org/web/20130907062401/http://csrc.nist.gov/publications/PubsFIPS.html

(The first link I've tried works.)

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]] 
Sent: 03 October 2013 12:11
To: Dearlove, Christopher (UK)
Cc: [email-masked] list
Subject: Re: NIST documents

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

- Ralph

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 03 Oct 2013 13:34:35 +0200

Le 03/10/2013 13:02, Dearlove, Christopher (UK) a écrit :
> One draft I'm working on references some standard NIST cryptographic
>  documents. (RFCs don't include everything we need.)  I need to check
>  some details therein. Unfortunately the current US government
> shutdown has taken NIST's website, including those documents,
> offline. And (not considering this possibility) I didn't download
> copies of them.
>
> Any link to where copies of such documents are kept would be useful.
>  (Of course I haven't been able to check the copyright on them to
> know if that's legal, so there may be no appropriate site.)
>

Same here - I have problems accessing documents at NASA about IP network
mobility.

The error message says:
"Due to the lapse in federal government funding, this website is not
available. We sincerely regret this inconvenience. For information about
available government services, visit USA.gov."

(roland.grc.nasa.gov/ redirects to notice.usa.gov/)

Whereas I could find the document in Google's cache, I am dubious
about this situation.

I would have not imagined that documents in a US gov website would
become unavailable - for political reasons?  I would imagine engineering
problems like routing system failures, Internet meltdown...

Alex

---

From: Ralph Droms <[email-masked]>
Date: Thu, 3 Oct 2013 07:42:34 -0400

> problems like routing system failures, Internet meltdown...

OK, so I'm not going to take a stand about the politics involved.  Trying to avoid wearing out my delete key, can we agree that the situation is a bummer, there's nothing we can do about it and we have a way to route around the damage.  Nothing more to contribute here, please move along...

Thanks and this will be my last post in this thread...

- Ralph

---

From: Thierry Moreau <[email-masked]>
Date: Fri, 04 Oct 2013 08:35:37 -0400

Dearlove, Christopher (UK) wrote:
> One draft I'm working on [...]
> 
> (Of course I haven't been able to check the copyright on [NIST documents ...)
> 

As a author of IT-related documents, you should be aware that, by its 
constitution plus long lasting tradition, the US government "works of 
authorship" have no copyright claims on them. The principle being that 
"we, the people" paid for a civil servant to make a write-up, nobody can 
claim intellectual property. Maybe the openness of the Internet owes a 
lot to this tradition.

So, NIST documents can be used as if in the public domain.

Bizarrely, the RSA and early public key crypto patents were filed 
precisely because US government funding was involved, but that's part of 
a longer story.

Regards,

-- 
- Thierry Moreau

CONNOTECH Experts-conseils inc.
9130 Place de Montgolfier
Montreal, QC, Canada H2M 2A1

Tel. +1-514-385-5691

---

From: Steve Crocker <[email-masked]>
Date: Fri, 4 Oct 2013 10:43:21 -0400

In reference to

> Maybe the openness of the Internet owes a lot to this tradition.

let me offer a comment regarding the RFCs.  There might be a general connection, but there wasn't an explicit connection.  The decision that RFCs would be freely available and without restriction regarding use came primarily from me.  I was part of the team at UCLA, which together with our counterparts at SRI, UCSB and Utah developed the initial set of ideas about the Arpanet protocols.  When we started to write down our ideas, we wanted to remove all barriers for publication and use.  A participant from one of the institutions involved in the next round of connections, i.e., not one of the first four, expressed concern that his institution would require pre-publication review and approval, so we declared RFCs not to be "publications."

There was no directive from DARPA or anyone else in the government nor was there even discussion about this policy.  It was a pragmatic decision aimed at facilitating maximum communication with minimum overhead and minimum delay.  We implicitly assumed there would be formal processes for the "real" documents later, and, of course, the RFCs were just a temporary expedient intended to last just a few months…

I suppose if the course we set had been antithetical to the U.S. Government's wishes, we might have gotten some guidance to do something different, but I don't recall the subject ever coming up.  We not only wanted the rules to be as unrestrictive as possible, we also wanted to spend as little time as possible discussing the rules.

Steve

On Oct 4, 2013, at 8:35 AM, Thierry Moreau <[email-masked]> wrote:

> As a author of IT-related documents, you should be aware that, by its constitution plus long lasting tradition, the US government "works of authorship" have no copyright claims on them. The principle being that "we, the people" paid for a civil servant to make a write-up, nobody can claim intellectual property. Maybe the openness of the Internet owes a lot to this tradition.
> 
> Bizarrely, the RSA and early public key crypto patents were filed precisely because US government funding was involved, but that's part of a longer story.
> 
> Regards,
> 
> -- 
> - Thierry Moreau
>

---

From: Daniel Karrenberg <[email-masked]>
Date: Fri, 4 Oct 2013 22:21:43 +0200

----------
Sent from a hand held device.

> On 04.10.2013, at 16:43, Steve Crocker <[email-masked]> wrote:
> ...
> We not only wanted the rules to be as unrestrictive as possible, we also wanted to spend as little time as possible discussing the rules.

... and by doing so you (plural) made a very significant difference in our little  Internet corner of the great scheme of things. I empathise withe the siprit you evoke. I am grateful for what you (plural) did and  I hope we did half as well in the little corner across the pond.  

Take care ( both proverbially and literally: "ICANN" eats people) 

Daniel

---

From: "GTW" <[email-masked]>
Date: Fri, 4 Oct 2013 18:29:56 -0400

except see for example 
http://www.cendi.gov/publications/04-8copyright.html#317

3.1.7  Does the Government have copyright protection in U.S. Government 
works in other countries?

Yes, the copyright exclusion for works of the U.S. Government is not 
intended to have any impact on protection of these works abroad (S. REP. NO. 
473, 94th Cong., 2d Sess. 56 (1976)). Therefore, the U.S. Government may 
obtain protection in other countries depending on the treatment of 
government works by the national copyright law of the particular country. 
Copyright is sometimes asserted by U.S. Government agencies outside the 
United States.

best to be careful

George T. Willingmyre, P.E.
President GTW Associates

-----Original Message----- 
From: Thierry Moreau
Sent: Friday, October 04, 2013 8:35 AM
To: Dearlove, Christopher (UK)
Cc: [email-masked]
Subject: Re: NIST documents

Regards,

-- 
- Thierry Moreau

Tel. +1-514-385-5691