Subject: Re: Last Call: <draft-ietf-roll-trickle-mcast-05.txt> (Multicast Protocol for Low power and Lossy Networks (MPL)) to Proposed Standard

From: Ralph Droms <[email-masked]>
Date: Fri, 11 Oct 2013 13:09:27 -0400

draft-ietf-roll-trickle-mcast-05 and draft-ietf-6man-multicast-scopes-00 are in conflict with each other.

From draft-ietf-roll-trickle-mcast-05:

   When
   used with MPL, Realm-Local scope is administratively defined and used
   to define the boundaries of multicast message dissemination by MPL.

From draft-ietf-6man-multicast-scopes-00:

   Realm-Local scope is the largest scope that is automatically
   configured, i.e., automatically derived from physical
   connectivity or other, non-multicast-related configuration.

Specifically, "administratively defined" seems to me to be in direct
conflict with "automatically configured". 

I suggest fixing the problem with two updates.  First, the definition
of "scop 3" in an IP-over-IEEE802.15.4 needs to be published, based on
this text from draft-ietf-6man-multicast-scopes-00: 

   The definition of any Realm-Local scope for a particular network
   technology should be published in an RFC.

I suggest:

   When used in an IP-over-IEEE802.15.4 network, "scop 3" is defined
   to include all interfaces sharing a PAN ID.

This text could be added to draft-ietf-roll-trickle-mcast-05, or to
draft-ietf-6man-multicast-scopes-00 or published separately in yet
another "world's shortest RFC".

Second, draft-ietf-roll-trickle-mcast-05 should be changed to read:

   When used with MPL, Realm-local scope is defined according to the
   underlying network technology; for example, [cite the
   IP-over-IEEE802.15.4 definition].

As a further refinement, I suggest text be added to
draft-ietf-roll-trickle-mcast-05 to the effect of:

   "scop 4" can also be used with MPL to cover deployments that use
   administratively defined scopes that cover, for example, subnets
   based on different underlying network technologies.

- Ralph

PS I originally posted about this issue to the rool WG mailing list:
http://www.ietf.org/mail-archive/web/roll/current/msg08188.html.
After a discussion with Kerry Lynn, I made a change to the definition
of scop 3 for IEEE802.15.4.

---

From: "Ralph Droms (rdroms)" <[email-masked]>
Date: Fri, 25 Oct 2013 19:56:42 +0000

There was a long discussion about this issue on the [email-masked] mailing list:

  When

I think I've read consensus in the various discussion threads to make the following change to draft-ietf-roll-trickle-mcast-05:

OLD:

   When

NEW:

   When
   used with MPL, Realm-Local scope is defined according to the
   underlying network technology; for example, [cite the
   IP-over-IEEE802.15.4 definition].

where "the IP-over-IEEE802.15.4 definition" is text to be published elsewhere (perhaps draft-ietf-6man-multicast-scopes) that defines scop 3 for IEEE802.15.4 mesh networks.

I read less strong consensus (less discussion) of the following proposed changes:

NEW (to be added immediately following text describing the use of Realm-Local scope):

  Admin-Local scope (scop value 4) can also be used with MPL
  in deployments that use administratively defined scopes that
  cover, for example, multiple subnets based on different
  underlying network technologies.

As a side note, there is a related discussion about draft-ietf-6man-multicast-scopes on the [email-masked] mailing list.  The term "Realm-Local scope" may change (should be changed for consistency with) the final published version of draft-ietf-6man-multicast-scopes.

- Ralph