Subject: future of identifiers

From: Jari Arkko <[email-masked]>
Date: Tue, 29 Oct 2013 16:38:22 +0200

For background, when I visited the ICANN meeting last summer, they were about to launch a set of panels to advice themselves about key topics in coming years. I promised to join one of them, on identifier technology innovation (along with a few other IETFers). The topic for this effort is future evolution of DNS and other identifiers, including relevant security and management aspects. The viewpoint is primarily to look at this from ICANN’s angle, but of course the matter is interesting to us others as well. 

And perhaps we at the IETF should also understand the same things. Hence this e-mail.

I have some ideas on what some of these trends might be. But what do the rest of you think? Where is identifier technology going, and what new things are on the horizon? What do we need to do with IDNs? DNSSEC? What will DANE lead to, and how will id-locator split techniques evolve & be deployed? How will applications or users think about identifiers in the future?

More information at http://www.ietf.org/blog/2013/10/future-identifiers/

Jari

---

From: Jorge Amodio <[email-masked]>
Date: Tue, 29 Oct 2013 09:53:00 -0500

Just think how many URLs you type on your smartphone or tablet and with wearable technologies like Google Glass, plus the common use of URL shorteners, in a very near future the actual string will become irrelevant, which will among other reasons make the new GTLD program useless and the DNS will stop being abused as a billboard where everybody fights for the best spot and the gold rush of domain names will be over.

IETF should take the lead in the development of innovative ways to identify resources, if not the ITU will fill the gap.

My .02

-Jorge

> On Oct 29, 2013, at 9:38 AM, Jari Arkko <[email-masked]> wrote:
>

---

From: Juliao Braga <[email-masked]>
Date: Tue, 29 Oct 2013 13:16:07 -0200

Jari,

I think this issue also involves the application of Semantic Web
(specifically, Linked Data and ontologies). I do not know exactly how,
just now, but my feelings are that this is a path to the future. But, in
my graduate program I am studying these issues, where the IETF
repositories and associates are the main focuses. Questions such as
vocabularies, metadata, knowledge, ownership, and other relationships
are a concern in the research.

It would be interesting to other people interested in the Semantic Web
applications on the infrastructure of the Internet, came in contact to
begin a team.

Julião

---

From: manning bill <[email-masked]>
Date: Tue, 29 Oct 2013 08:30:56 -0700

I talked to Lars in Berlin about the possibility of hosting a BOF about this topic, but it seems to have become OBE, at least for
YVR.   This has potential for work in the IRTF.

/bill

---

From: Patrik Fältström <[email-masked]>
Date: Tue, 29 Oct 2013 12:03:43 -0400

> More information at http://www.ietf.org/blog/2013/10/future-identifiers/

I think it is important to not restart discussions already held regarding different requirements on identifiers, requirements that in turn lead to various alternatives on how they are allocated, managed and resolved. I do not think one can have one identifier that fits all. Instead multiple kind of identifiers are needed. Because of requirements on uniqueness (absolute, low risk of collisions or not needed at all), persistence, human readable/understandable, whether allocation and resolution should be designed for read (lookups) or write (allocation), what the identifier is to be used for (see id/loc discussions).

    Patrik

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 29 Oct 2013 09:16:57 -0700

> I think it is important to not restart discussions already held regarding different requirements on identifiers, requirements that in turn lead to various alternatives on how they are allocated, ma…

Having sat through many of those discussions with Patrik 15 years ago: +1

If ICANN wants to create and control some additional identifier spaces, let them spend/waste their resources on all those questions.

--Paul Hoffman

---

From: Eliot Lear <[email-masked]>
Date: Tue, 29 Oct 2013 17:23:10 +0100

> Having sat through many of those discussions with Patrik 15 years ago: +1

And having chaired NSRG, + 1/2.  That is- it's always fair to look at
new developments, but let's at least be aware of what was covered by
others and build on their success (or avoid their failures).

Eliot

---

From: Patrik Fältström <[email-masked]>
Date: Tue, 29 Oct 2013 12:30:36 -0400

> others and build on their success (or avoid their failures).

Just to make my point clear. I absolutely do believe more thinking is needed. What was done 15 years ago never finished. I claim partly because we did not know the answers to all questions.

My only point is that I think it would be sad to restart the discussion from zero. We both good and bad experience if we look back in history. We made mistakes then, but we also have successes. I here talk about URI-related discussions, whois++ (etc), Dublin Core, OID and what not.

Same with the 10+(?) years of ID/Loc split discussions. Lots and lots of experience. 

And of course the experience enterprises like Facebook, Twitter etc have from their what I would call private namespaces.

   Patrik

---

From: manning bill <[email-masked]>
Date: Tue, 29 Oct 2013 09:44:05 -0700

> And of course the experience enterprises like Facebook, Twitter etc have from their what I would call private namespaces.
	lets not forget x500 and quipu & giant tortoise…

/bill

---

From: Christian de Larrinaga <[email-masked]>
Date: Tue, 29 Oct 2013 17:39:28 +0000

Maybe I've misunderstood but if this discussion (which I think is valid
to do) is framed for ICANN it is likely to miss or ignore current work
stimulated because of perceived blockages in the ICANN hierarchical model.

Just saying.

C

> Patrik Fältström <mailto:[email-masked]>
> 29 October 2013 16:30
>
> Just to make my point clear. I absolutely do believe more thinking is
> needed. What was done 15 years ago never finished. I claim partly
> because we did not know the answers to all questions.
>
> My only point is that I think it would be sad to restart the
> discussion from zero. We both good and bad experience if we look back
> in history. We made mistakes then, but we also have successes. I here
> talk about URI-related discussions, whois++ (etc), Dublin Core, OID
> and what not.
>
> And of course the experience enterprises like Facebook, Twitter etc
> have from their what I would call private namespaces.
>
> Patrik
>
> Eliot Lear <mailto:[email-masked]>
> 29 October 2013 16:23
>
> Jari Arkko <mailto:[email-masked]>
> 29 October 2013 14:38
> For background, when I visited the ICANN meeting last summer, they
> were about to launch a set of panels to advice themselves about key
> topics in coming years. I promised to join one of them, on identifier
> technology innovation (along with a few other IETFers). The topic for
> this effort is future evolution of DNS and other identifiers,
> including relevant security and management aspects. The viewpoint is
> primarily to look at this from ICANN’s angle, but of course the matter
> is interesting to us others as well.
>
> I have some ideas on what some of these trends might be. But what do
> the rest of you think? Where is identifier technology going, and what
> new things are on the horizon? What do we need to do with IDNs?
> DNSSEC? What will DANE lead to, and how will id-locator split
> techniques evolve & be deployed? How will applications or users think
> about identifiers in the future?
>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 30 Oct 2013 08:37:14 +1300

> Just to make my point clear. I absolutely do believe more thinking is needed. What was done 15 years ago never finished. I claim partly because we did not know the answers to all questions.

Indeed. I have some half-baked thoughts about some aspects at
http://www.cs.auckland.ac.nz/~brian/IPAddressesConsideredHarmful.pdf

   Brian

---

From: Randy Bush <[email-masked]>
Date: Tue, 29 Oct 2013 14:07:03 -0700

> I think it is important to not restart discussions already held
> regarding different requirements on identifiers, requirements that in
> turn lead to various alternatives on how they are allocated, managed
> and resolved. I do not think one can have one identifier that fits
> all. Instead multiple kind of identifiers are needed. Because of
> requirements on uniqueness (absolute, low risk of collisions or not
> needed at all), persistence, human readable/understandable, whether
> allocation and resolution should be designed for read (lookups) or
> write (allocation), what the identifier is to be used for (see id/loc
> discussions).

i did not keep the tee shirts as they did not have pockets.

but i can't wait to see icann do to addressing what they did to name
strings.  real or imaginary ip addresses could be a real moneymaker
for them.

randy

---

From: Jorge Amodio <[email-masked]>
Date: Tue, 29 Oct 2013 18:09:30 -0500

Hey why not ? 

We can add another three more paid vacations to exotic places per year  !!

-Jorge

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 29 Oct 2013 23:44:14 -0400

Lets fix email addresses.

http://tools.ietf.org/html/draft-hallambaker-prismproof-key-00

A Strong email address combines an address with a security policy
indication and an optional public key identifier.

The key identifier is a hash of the publicKeyInfo block for the key (or a
PGP key fingerprint for backwards compatibility).

   KeyIdentifier: ACAIEA-FONPAC-5AC6LFA-K4ACHC-EAJWAHN-VPAM4A-COYPAO-VAA

      [email-masked]
         Send email to Alice using encryption if and only if an
         encryption key for Alice can be found and Alice has published
         the email encryption policy 'encryption preferred' or stronger.

      ?[email-masked]
         Send email to Alice using encryption if and only if an
         encryption key for Alice can be found, otherwise report an
         error.

      ACAIEA-FONPAC-5AC6LFA-K4ACHC-EAJWAHN-VPAM4A-COYPAO-
         VAA?[email-masked]
         Send email to Alice using encryption if and only if an
         encryption key for Alice can be found that is directly endorsed
         under the specified key, otherwise report an error.

Using strong email addresses allows us to address a wide range of
urgent commercial use cases. For example:

Doctor sending an email to a nurse with patient information in it

Lawyer sending a message about a client

Financial adviser sending a message to a client

Company sending a bill to a customer.

These are all valuable commercial use cases that enable paper
processes to be replaced with cheaper and more convenient electronic
processes.

I can add my strong email address to my linked in profile.

An infrastructure is required to resolve key identifiers to keys but
it can be a very simple well-known service lookup or a vcard.

We have 95% of an encrypted email solution today. This proposal adds
the missing 5%. It is a scheme that can be understood by ordinary
people.

Under the covers, the normal S/MIME and PGP can take place. But people
don't need to look under the covers.

I might need to trust a CA to find me a strong email address for a
recipient. But once I have found a strong address I don't need to do
that again.

I do have a business model etc. but its not the dopey idea of expiring
keys every year and having to pay to reissue them.

On Tue, Oct 29, 2013 at 10:38 AM, Jari Arkko <[email-masked]> wrote:

> For background, when I visited the ICANN meeting last summer, they were
> about to launch a set of panels to advice themselves about key topics in
> coming years. I promised to join one of them, on identifier technology
> innovation (along with a few other IETFers). The topic for this effort is
> future evolution of DNS and other identifiers, including relevant security
> and management aspects. The viewpoint is primarily to look at this from
> ICANN’s angle, but of course the matter is interesting to us others as well.
>
> I have some ideas on what some of these trends might be. But what do the
> rest of you think? Where is identifier technology going, and what new
> things are on the horizon? What do we need to do with IDNs? DNSSEC? What
> will DANE lead to, and how will id-locator split techniques evolve & be
> deployed? How will applications or users think about identifiers in the
> future?
>

-- 
Website: http://hallambaker.com/

---

From: Avri Doria <[email-masked]>
Date: Tue, 29 Oct 2013 21:37:57 -0400

On 29 Oct 2013, at 10:53, Jorge Amodio wrote:

> IETF should take the lead in the development of innovative ways to identify resources,

Indeed this has been the case for a while

But IETF does create innovative way, e.g. the range of potentials in URIs that were never really exploited with other schema and authorities.

avri

---

From: Jari Arkko <[email-masked]>
Date: Thu, 31 Oct 2013 09:06:47 +0200

Patrik,

> I think it is important to not restart discussions already held regarding different requirements on identifiers, requirements that in turn lead to various alternatives on how they are allocated, managed and resolved.

Understood. Thanks.

> I do not think one can have one identifier that fits all. Instead multiple kind of identifiers are needed. Because of requirements on uniqueness (absolute, low risk of collisions or not needed at all), persistence, human readable/understandable, whether allocation and resolution should be designed for read (lookups) or write (allocation), what the identifier is to be used for (see id/loc discussions).

Agreed.

Jari