Subject: Revision to Note Well

From: Richard Barnes <[email-masked]>
Date: Thu, 6 Feb 2014 14:12:08 -0500

The IESG would like to put forward a revision to the proposed new Note
Well, after some discussion both on the IETF list [1] and within the IESG.

The revised text can be found on the IESG wiki:
<http://trac.tools.ietf.org/group/iesg/trac/wiki/DraftNoteWellSummary>

The only change is the following:
OLD: "..., you must disclose that fact"
NEW: "..., you must disclose that fact, *or not participate in the
discussion*"

This is intended to reflect that BCP 79's requirements for disclosure apply
to "Any individual participating in an IETF discussion", as opposed to all
IETF participants.

If you have any further comments on this text, please reply in this thread.

Thanks,
--Richard

[1] <http://www.ietf.org/mail-archive/web/ietf/current/msg85658.html>
[2] <http://tools.ietf.org/html/bcp79#section-6.1.2>

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Thu, 6 Feb 2014 19:18:27 +0000

This looks excellent and address my concern. I would be very happy with this change. 

On Feb 6, 2014, at 12:12 PM, Richard Barnes <[email-masked]> wrote:

> The IESG would like to put forward a revision to the proposed new Note Well, after some discussion both on the IETF list [1] and within the IESG.
> 
> NEW: "..., you must disclose that fact, or not participate in the discussion"
> 
> This is intended to reflect that BCP 79's requirements for disclosure apply to "Any individual participating in an IETF discussion", as opposed to all IETF participants.
>

---

From: [email-masked]
Date: Thu, 06 Feb 2014 11:22:17 -0800 (PST)

This new text doesn't fix the main problem, which is the failure to distinguish
between your/your employer's IP and third party IP. As such, it's still wrong
and needs further work.

				Ned

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 6 Feb 2014 19:30:22 +0000

Hi,

>NEW: "..., you must disclose that fact, or not participate in the discussion"

The bullet text now says:

"•If you are aware that any contribution (something written, said, or discussed in any IETF context) is covered by patents or patent applications, you must disclose that fact, or not participate in the discussion."

What discussion??? 

Should the text say "contribution (something written, said, or discussed in any IETF context) TO A DISCUSSION is covered"

Regards,

Christer

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 07 Feb 2014 08:35:18 +1300

> to "Any individual participating in an IETF discussion", as opposed to all

"If you are aware that any contribution (something written, said, or discussed in any IETF context) is covered by patents or
patent applications, you must disclose that fact, or not participate in the discussion."

That is still wrong, because it doesn't distinguish the case of 3rd party
disclosures, which are optional, from 1st party disclosures, which are
mandatory. This would be more accurate, by excluding the 3rd party case:

"If you are aware that any contribution (something written, said, or discussed in any IETF context) is covered by patents or
patent applications by you or your employer or sponsor, you must disclose that fact, or not participate in the discussion."

If you want to include the third party case, you'd need an extra sentence.

I still *much* prefer the old version. Summarising complex legal rules
is a dangerous game and I'm certain that a clever litigator could
exploit subtle differences between the summary and the full text.

    Brian

---

From: [email-masked]
Date: Thu, 06 Feb 2014 11:42:48 -0800 (PST)

> exploit subtle differences between the summary and the full text.

+1

				Ned

---

From: Salvatore Loreto <[email-masked]>
Date: Thu, 6 Feb 2014 19:56:38 +0000

works for me

/Sal

On Feb 6, 2014, at 9:12 PM, Richard Barnes <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
--Richard

---

From: Dave Crocker <[email-masked]>
Date: Thu, 06 Feb 2014 12:09:10 -0800

On 2/6/2014 11:22 AM, [email-masked] wrote:
> This new text doesn't fix the main problem,

A number of people have have raised very specific and and very serious 
concerns with current and proposed Note Well text.

These concerns need to get direct, public, expert responses before the 
IESG imposes any further changes.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Thu, 06 Feb 2014 21:18:34 +0100

><http://trac.tools.ietf.org/group/iesg/trac/wiki/DraftNoteWellSummary>

I like http://www.ietf.org/about/note-well.html better by an order of
magnitude or so. I would suggest taking the old version and adding the
parentheticals like in "BCP 79 (on patents covering IETF documents)",
though perhaps as "(on patents and patent disclosure obligations)".

As an example,

  A participant in any IETF activity acknowledges that written, audio
  and video records of meetings may be made and may be available to 
  the public.

versus

  You understand that meetings might be recorded or broadcast (audio
  or video), photographed, and publicly archived.

The current version makes me think about whether I want to give my per-
mission, while the latter just informs me of an obvious possibility.

(As an aside, 'summary "Note Well"' does not make it clear if this is
supposed to be a replacement of the "Note Well", or a summary of it.)
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Mary Barnes <[email-masked]>
Date: Thu, 6 Feb 2014 14:27:59 -0600

I also do not believe that this change addresses the concerns that have
been raised.  As I said previously, I never totally understood why we
needed a new note well summary was even needed.   I believe the previous
version was more than adequate and certainly more correct.

Mary.

On Thu, Feb 6, 2014 at 1:35 PM, Brian E Carpenter <
[email-masked]> wrote:

> "If you are aware that any contribution (something written, said, or
> discussed in any IETF context) is covered by patents or
> "If you are aware that any contribution (something written, said, or
> discussed in any IETF context) is covered by patents or
> patent applications by you or your employer or sponsor, you must disclose
> that fact, or not participate in the discussion."
>

---

From: Pete Resnick <[email-masked]>
Date: Thu, 6 Feb 2014 14:52:55 -0600

Speaking as me, not as AD (except insofar as some of this makes my life 
as an AD a pain).

On 2/6/14 1:35 PM, Brian E Carpenter wrote:
> I still*much*  prefer the old version.

Let's first separate what goes on the web site (and importantly, the 
registration page) from what gets put on a slide in the room. I have no 
quarrel with legalese appearing on the registration page; it's not 
particularly useful to the participants, but it's legal 
rear-end-covering, for whatever that's worth. It's really between you 
and your corporate attorney what to make of it.

But the old (currently posted) version on a slide in the room is, 
pragmatically speaking, content-free and useless to the IETF and to the 
participants. It gives no notice whatsoever that what is contained in 
the referenced documents has anything to do with intellectual property. 
And really, we know that almost nobody reads the Note Well in the room, 
and we have ample evidence (in the form of late disclosures and bogus 
disclosures) that many people don't know what it means. Unlike on the 
registration page, the point of making the statement in the room is to 
avoid late surprises for the WG in their work.

So, I really do not find the current Note Well useful on a slide in the 
room at all.

But I do see a point in having the chair say (or display) in the room, 
"Just in case you didn't actually read what is posted on the web page[1] 
that you acknowledged when you registered, please note: You've got IPR 
disclosure responsibilities if you participate in this discussion at all 
(including writing, speaking, singing or otherwise). If you or your 
employer has IPR on this stuff, get with it!"

If we're not going to have simple text available in the room, let's at 
least stop with the charade that posting the Note Well is meaningful, 
and the chairs and shepherds and the IESG will simply have to continue 
to deal with the regular stream of late disclosures.

pr

[1] "...just like you ignore every other EULA that you click through on 
the Interwebs..."

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 6 Feb 2014 13:04:22 -0800

On Feb 6, 2014, at 12:52 PM, Pete Resnick <[email-masked]> wrote:

> Let's first separate what goes on the web site (and importantly, the registration page) from what gets put on a slide in the room.

That's good; that's now what was sent in this thread.

> I have no quarrel with legalese appearing on the registration page; it's not particularly useful to the participants, but it's legal rear-end-covering, for whatever that's worth. It's really between you and your corporate attorney what to make of it.

No, it's more than that. It is also a way of saying "here's what we really mean".

> But the old (currently posted) version on a slide in the room is, pragmatically speaking, content-free and useless to the IETF and to the participants. It gives no notice whatsoever that what is contained in the referenced documents has anything to do with intellectual property. And really, we know that almost nobody reads the Note Well in the room, and we have ample evidence (in the form of late disclosures and bogus disclosures) that many people don't know what it means.

All true. So instead of making the engineering mistake of "let's optimize and everything will be fine", maybe make the different engineering mistake of "let's use a level of indirection and assume it will get dereferenced". That is, the note in the room is "you already agreed to the Note Well when you registered; it said important things for this meeting".

> Unlike on the registration page, the point of making the statement in the room is to avoid late surprises for the WG in their work.

That is one of the main points for both the registration and in the room.

> So, I really do not find the current Note Well useful on a slide in the room at all.

Fully agree. Replacing it with a worse one is not the answer.

> But I do see a point in having the chair say (or display) in the room, "Just in case you didn't actually read what is posted on the web page[1] that you acknowledged when you registered, please note: You've got IPR disclosure responsibilities if you participate in this discussion at all (including writing, speaking, singing or otherwise). If you or your employer has IPR on this stuff, get with it!"

Or: "Just in case you didn't actually read what is posted on the web page[1] that you acknowledged when you registered, please note: You've got IPR disclosure responsibilities if you participate in this discussion at all (including writing, speaking, singing or otherwise). It is in everyone's best interest, including yours and your companies, if everyone has read it." Your last sentence above is legal advice from a chair who is likely to be below average among chairs at communication skills and below average among chairs at understanding IETF procedures.

> If we're not going to have simple text available in the room, let's at least stop with the charade that posting the Note Well is meaningful, and the chairs and shepherds and the IESG will simply have to continue to deal with the regular stream of late disclosures.

Works for me.

--Paul Hoffman

---

From: Andrew Sullivan <[email-masked]>
Date: Thu, 6 Feb 2014 16:06:49 -0500

On Thu, Feb 06, 2014 at 02:52:55PM -0600, Pete Resnick wrote:
> But I do see a point in having the chair say (or display) in the
> room, "Just in case you didn't actually read what is posted on the
> web page[1] that you acknowledged when you registered, please note:
> You've got IPR disclosure responsibilities if you participate in
> this discussion at all (including writing, speaking, singing or
> otherwise). If you or your employer has IPR on this stuff, get with
> it!"

So use _that_.  The complaint that several people seemed to have about
the new proposal was that it tried to summarize, and did so badly.
The above text doesn't do that. 

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: "GTW" <[email-masked]>
Date: Thu, 6 Feb 2014 16:43:56 -0500

I agree with those who have stated the problem with the proposed text such as expressed below.

Mary has asked a good question that I tried to ask before:  What is the problem we are striving to solve?

Is IETF experiencing issues of non-disclosure of IP that our rules indicate should have been disclosed? 

If so it would be helpful to better understand any such instances in order that we can propose responsive solutions.

My experience is that the vast majority of current “problems” related to IP in standards has to do with disagreements over meaning of license assurances made as a part of disclosure.  I am not aware of current problems about “non-disclosure”

George T. Willingmyre, P.E.
President GTW Associates

From: Mary Barnes 
Sent: Thursday, February 06, 2014 3:27 PM
To: Brian E Carpenter 
Cc: [email-masked] 
Subject: Re: Revision to Note Well

I also do not believe that this change addresses the concerns that have been raised.  As I said previously, I never totally understood why we needed a new note well summary was even needed.   I believe the previous version was more than adequate and certainly more correct.  

Mary. 

On Thu, Feb 6, 2014 at 1:35 PM, Brian E Carpenter <[email-masked]> wrote:

      Brian

---

From: [email-masked]
Date: Thu, 06 Feb 2014 13:52:44 -0800 (PST)

> employer has IPR on this stuff, get with it!"

Then why not use this text or something equivalent to it? As opposed to what
started this discussion, or the update the IESG has now proposed that fails to
address the issues people have raised?

The fact that you can write this demonstrates it is possible to come up with
something that is both accurate and meets your additional criteria of being
simple and direct.

> to deal with the regular stream of late disclosures.

... and this is nothing but a strawman. I strongly doubt anyone objecting here
is opposed to "simple" text as long as said text doesn't misstate what our IP
rules are.

				Ned

---

From: Warren Kumari <[email-masked]>
Date: Thu, 6 Feb 2014 20:11:05 -0500

Oh gods, I was desperately trying to stay out of this conversation...

Seeing as I'm still unclear on what the actual *problem* is, this may or
may not be a reasonable suggestion.

I liked the old Note Well, but I get that not everyone reads it when it is
flashed up on a slide. I also get that the summarized versions miss some
subtleties / edge cases...

So, how about we simply present *both*.
"Here is an incomplete summary of our IPR stuff, but it should give you an
overview. <click> This is the longer, more detailed and correct version. It
is also posted online and you agreed to it when signing up. IANAL. If you
have any concerns / don't understand what this says, go talk to *your*
lawyer. <click> Now, agenda bashing..."
I just timed this - takes < 15 seconds to say (or <4 if you are EKR ;-)).

W

---

From: George Michaelson <[email-masked]>
Date: Fri, 7 Feb 2014 11:20:01 +1000

+1. formalisms have to be done for legal reasons. the actual information is
what we already do, plus "read the detals" warnings. thats one extra slide,
maybe one extra line on the current one slide teaser.

---

From: Scott Brim <[email-masked]>
Date: Thu, 6 Feb 2014 20:37:40 -0500

On Feb 6, 2014 8:11 PM, "Warren Kumari" <[email-masked]> wrote:
> "Here is an incomplete summary of our IPR stuff, but it should give you
an overview. <click> This is the longer, more detailed and correct version.
It is also posted online and you agreed to it when signing up.

I was thinking this is exactly what I would do.

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 7 Feb 2014 08:05:39 +0000

On 2014-2-6, at 20:35, Brian E Carpenter <[email-masked]> wrote:
> mandatory.

Exactly. The new text does not address the issue.

Lars

PS: I'll again point to the IRTF statement, which does: http://irtf.org/ipr. We'll make it available to the IETF for the low, low price of a round of beers for the IRSG :-)

---

From: Dave Crocker <[email-masked]>
Date: Fri, 07 Feb 2014 07:16:21 -0800

On 2/7/2014 12:05 AM, Eggert, Lars wrote:
> PS: I'll again point to the IRTF statement, which does:http://irtf.org/ipr. We'll make it available to the IETF for the low, low price of a round of beers for the IRSG:-)

1. Has the text been vetted by the IETF's attorney?

2. How does this 'summary' avoid the danger that has been cited, of 
providing a potential ambiguity argument through exploitation of any 
differences between the summary source text?

3. How does any of this resolve the much deeper problem that this 
lengthy thread has served to demonstrate that we very clearly have 
extensive community confusion about on what the current IPR rules are or 
mean?

d/

---

From: Paul Wouters <[email-masked]>
Date: Thu, 6 Feb 2014 14:15:22 -0500 (EST)

On Thu, 6 Feb 2014, Richard Barnes wrote:

> This is intended to reflect that BCP 79's requirements for disclosure apply to "Any individual participating in an IETF
> discussion", as opposed to all IETF participants.

Does sitting inside a meeting room and being quiet count as "participate
in the discussion"?

Paul

---

From: Scott Brim <[email-masked]>
Date: Fri, 7 Feb 2014 12:12:57 -0500

> Does sitting inside a meeting room and being quiet count as "participate

Do you stomp around and roll your eyes while facing other people?

---

From: "Scott O. Bradner" <[email-masked]>
Date: Fri, 7 Feb 2014 12:17:24 -0500

maybe the IESG has too strong a NIH phobia to do the simple thing and adopt what the IRTF did 

in any case the question of “participation” was debated long and hard in two IPR BOFs and on the IPR working list
with the result was to replace the idea participation with "any activity that was intended to affect the IETF Standards Process”

see draft-bradner-rfc3979bis-06.txt

Scott

---

From: Pete Resnick <[email-masked]>
Date: Fri, 7 Feb 2014 11:28:34 -0600

On 2/7/14 2:05 AM, Eggert, Lars wrote:
> I'll again point to the IRTF statement, which does:http://irtf.org/ipr. We'll make it available to the IETF for the low, low price of a round of beers for the IRSG:-)
>    

FWIW, I like the IRTF statement and think it would be a fine 
addition/replacement *for what's on the web site*. It's not short enough 
IMO for the face-to-face in-room reminder, particularly if a chair were 
going to actually *say* it, but maybe if something of this nature 
appeared on the web site, the in-room reminder wouldn't be as necessary.

(And to answer an earlier question, yes, we've had a bunch of late 
disclosures. They seem to come in waves. That's what motivated some of 
us to push for some kind of "plain language" thing that could be grasped 
easily in f2f meetings. But again, maybe if we had something along the 
lines of the IRTF statement plastered everywhere, people would start to 
"get it" and we wouldn't need a one-liner to get people sitting in a f2f 
meeting to notice.)

pr

---

From: S Moonesamy <[email-masked]>
Date: Fri, 07 Feb 2014 09:56:01 -0800

Hi Paul,
>Does sitting inside a meeting room and being quiet count as "participate

No.

Regards,
S. Moonesamy

---

From: John C Klensin <[email-masked]>
Date: Fri, 07 Feb 2014 13:09:28 -0500

--On Friday, February 07, 2014 11:28 -0600 Pete Resnick
<[email-masked]> wrote:

>> I'll again point to the IRTF statement, which
>> does:http://irtf.org/ipr. We'll make it available to the IETF
>> for the low, low price of a round of beers for the IRSG:-)
>>    
> 
> addition/replacement *for what's on the web site*. It's not
> short enough IMO for the face-to-face in-room reminder,
> particularly if a chair were going to actually *say* it, but
> maybe if something of this nature appeared on the web site,
> the in-room reminder wouldn't be as necessary.

Pete, 

As others have suggested, if you want to raise a "please pay
attention to things you have presumably read" flag in meetings
and especially if you think the current version is too long or
complicated, just do that with one of many versions of the "if
you or your organization have IPR in this topic you had best
either understand the BCP provisions or leave" statement, with
or without a second "if know of someone else's, you should be
paying attention to the BCPs too" remark. 

Don't try to summarize.  You can't get it right in a sentence or
four and will just create risks without improving understanding
or, most likely, compliance.

> (And to answer an earlier question, yes, we've had a bunch of
> late disclosures. They seem to come in waves.
>...

Let me then suggest a small bit of research.  You know who the
responsible parties are.  Have you asked them whether additional
notices would have made any difference and, if so, of what sort
and where?  Obviously some will be unwilling (or unable) to
respond accurately.  But it would be nice to have at least a
shred of evidence that more investment in fine-tuning
announcements would actually improve the rate of timely
disclosures.

In addition, there is a more interesting question than "have
their been late disclosures".  It is "how many of the late
disclosures were defended on the basis of ignorance about the
rules?".  If the number of those is non-zero, it would also be
interesting to know whether (and how often) that claim has been
made under oath in an actual proceeding rather than informal
remarks to the IESG.
  
Unless there have been serious claims that the reason for
non-disclosure is ignorance of the rules or our failure to have
enough notices, I'm not sure what problem you are trying to
solve that is important enough to justify the costs of this
discussion.

best,
     john

---

From: Scott Brim <[email-masked]>
Date: Fri, 7 Feb 2014 13:39:11 -0500

I'm concerned that any abbreviated form will inadequately represent
the nuances of the full policy, and that if we create a single uniform
abbreviated version that must be shown at f2f meetings, that opens
loopholes. For example, possibly: "Well, yes I agreed to the Note
Well, but then in the meeting they showed a different version that
didn't cover X. I thought that took precedence."

There are many ways the full Note Well is dealt with at this time,
most of them good. I don't think you'll get more attention paid to the
IPR policy by showing an abbreviated form.

Scott

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 08 Feb 2014 08:21:19 +1300

> IPR policy by showing an abbreviated form.

Indeed, I suspect that many IETF participants simply shut down
their ears as soon as the subject of IPR is mentioned, and click
through the Note Well (and through this thread) without reading.
For them, the form of words is irrelevant. For the ones who take
notice, the form of words is probably irrelevant too, since all
forms ultimately lead to the BCP and that's what counts.

So if there is a basic problem, it's getting people to pay attention
to the topic at all.

I would theorise that the people who ignore the topic actually
find it rather unpleasant and want it to go away.

   Brian

---

From: John C Klensin <[email-masked]>
Date: Fri, 07 Feb 2014 14:21:33 -0500

--On Friday, February 07, 2014 13:39 -0500 Scott Brim
<[email-masked]> wrote:

> I'm concerned that any abbreviated form will inadequately
> represent the nuances of the full policy, and that if we
> create a single uniform abbreviated version that must be shown
> at f2f meetings, that opens loopholes. For example, possibly:
> "Well, yes I agreed to the Note Well, but then in the meeting
> they showed a different version that didn't cover X. I thought
> that took precedence."

I think we are in violent agreement.  That is precisely why I'm
more in favor of a cautionary pointer to the actual rules than
to any "abbreviated form" or "summary".  If we are not in
agreement, I'd really appreciate any hints that would improve my
understanding.

> There are many ways the full Note Well is dealt with at this
> time, most of them good. I don't think you'll get more
> attention paid to the IPR policy by showing an abbreviated
> form.

I think I agree but note that someone who "conforms to" the Note
Well rather than the relevant BCPs is likely to either get
themselves in trouble or discover loopholes that permit them to
claim that they followed the rules as they understood them.  The
"full" Note Well is lots better in that regard than the proposed
simplified replacements.  But the reality is that any summary
statements that go very far beyond "the IETF has IPR policies,
they apply, or may apply, to you if any of these conditions (and
maybe some others) are applicable, and, by sitting here and/or
opening your mouth, you have agreed that you are bound by them
and better understand what you are committed to" is likely to be
problematic.  What is notable about that sort of statement is
that it does not try to explain, in summary, abbreviated, or
other form, what those policies are.  It just announces that
there are policies, that they are binding on those who
participate, and, preferably, provides a pointer.

best,
   john

---

From: Spencer Dawkins <[email-masked]>
Date: Fri, 07 Feb 2014 13:25:55 -0600

On 02/07/2014 02:05 AM, Eggert, Lars wrote:
>   PS: I'll again point to the IRTF statement, which does: 
> http://irtf.org/ipr. We'll make it available to the IETF for the low, 
> low price of a round of beers for the IRSG :-) 

Just so people have full information for this discussion, at least one 
member of the IRSG doesn't drink beer, so Lars's suggested price is 
cheaper than you think from looking at http://irtf.org/irsg ...

---

From: "Scott O. Bradner" <[email-masked]>
Date: Fri, 7 Feb 2014 14:43:37 -0500

something that is being missed in this discussion

the old “Note Well” does not do, nor was it intended to do, what people have assumed it did

the Note Well was developed, starting in about April 2000, to provide classification
on what should be considered a “contribution” to the IETF - at the time there
was a lot of confusion - some people thought the 2026 IPR rules only applied to
Internet Draft submission and others thought it covered mailing list and 
microphone statements - the Note Well was developed by me and the then IETF lawyer,
Geoff Stewart, with the help of Steve Coya and initially discussed at an IESG retreat.

a common feature of the proposed revisions (the IERTF one as well as the IESG ones)
is to expand the mission of the Note Well to actually say what you should DO if you
have IPR that an IETF working group would be better off knowing about

note well that the above is a history lesson for context and should not discus the
current discussion thread other than to perhaps forestall a return to the good old
Note Well that was not, by itself, actionable

Scott

---

From: "Scott O. Bradner" <[email-masked]>
Date: Fri, 7 Feb 2014 14:46:17 -0500

oops - reviewing my logs, it was Jorge Contreras not Geoff Stewart, and John Klensin was part of
the initial (to blame) group

Scott

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 7 Feb 2014 20:57:40 +0000

Hi,

> 1. Has the text been vetted by the IETF's attorney?

yes.

> 2. How does this 'summary' avoid the danger that has been cited, of providing a potential ambiguity argument through exploitation of any differences between the summary source text?

Not sure how to answer that, other than saying that Jorge was OK with it? (It does point at the BCP for the detailed rules.)

> 3. How does any of this resolve the much deeper problem that this lengthy thread has served to demonstrate that we very clearly have extensive community confusion about on what the current IPR rules are or mean?

It doesn't - that's a much broader question, which I agree we need to somehow tackle.

Lars

---

From: Dave Crocker <[email-masked]>
Date: Fri, 07 Feb 2014 15:32:49 -0800

On 2/7/2014 10:39 AM, Scott Brim wrote:
> loopholes.

Exactly.  Any form of redundancy -- like a 'summary' -- creates an 
opportunity for misunderstanding.

Also let's be careful about the nature of the problem here.  Some folks 
want to find an excuse to avoid the responsibility the IETF is imposing. 
  Such folk will not be satisfied, no matter what we do.

Some other folk really do need legitimate guidance.  While I'd argue 
that anyone who misunderstands the basic nature of IETF policy, after 
seeing/hearing the existing Note Well, is probably working at that 
misunderstanding.

Still, we could make things both simpler and stronger.

Here's what I suggest:

                            NOTE WELL

      PARTICIPATION IN THE IETF CARRIES ESSENTIAL OBLIGATIONS.

      IT IS YOUR RESPONSIBILITY TO BECOME FAMILIAR WITH THE DETAILS OF
      THOSE OBLIGATIONS AND TO ENSURE THAT YOU SATISFY THEM:

      *  IETF IPR Disclosures Policy, as specified in BCP 79

      *  IETF Anti-harassment Policy, as specified in
         ietf.org/iesg/statement/ietf-anti-harassment-policy.html

In each case these need to be a single pointer to to a single document.

Of course, Jorge needs to vet this, but I believe this accomplishes only 
and exactly the stated goal, with none of the problems created by 
current or other proposed text.

d/

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 7 Feb 2014 23:42:05 +0000

Hi,

I think the text that Dave suggests looks good.

However, it's probably good to have a link to where the meaning of "Participation" is defined, because that discussion also comes up every now and then...

Regards,

Christer

________________________________________
From: ietf [[email-masked]] on behalf of Dave Crocker [[email-masked]]
Sent: Saturday, 08 February 2014 1:32 AM
To: IETF discussion list
Subject: Re: Revision to Note Well

Here's what I suggest:

                            NOTE WELL

d/

---

From: Jorge Contreras <[email-masked]>
Date: Fri, 7 Feb 2014 22:34:41 -0600

This is essentially a repeat of a discussion that has happened every few
years since the late 1990s.  The original idea for the Note Well (at least
*my* original idea) was that it should simply be a pointer to the IETF IPR
policy, which has many pages of explanation and answers most of the
questions that people have been raising on this thread.  It should be
obvious, I think, that a complex process like the IETF's IPR disclosure
procedure can't be fully explained in a couple of sentences.  Any such
attempt is bound to be incomplete.

This being said, there has been a strong desire by many to have a summary
statement that also serves as a pointer to the real policy.  That's what
the current Note Well is supposed to be.  It is NOT a statement of the
IETF's IPR rules.  Those are contained in BCP 78/79, and anyone who is
responsible for his/her company's IPR and/or compliance needs to read those
and not rely on the summary statement/pointer contained in Note Well.

Jorge

On Fri, Feb 7, 2014 at 1:46 PM, Scott O. Bradner <[email-masked]> wrote:

> > the old "Note Well" does not do, nor was it intended to do, what people
> have assumed it did
> >
> > on what should be considered a "contribution" to the IETF - at the time
> there

---

From: John C Klensin <[email-masked]>
Date: Sat, 08 Feb 2014 01:48:12 -0500

--On Friday, February 07, 2014 22:34 -0600 Jorge Contreras
<[email-masked]> wrote:

> This is essentially a repeat of a discussion that has happened
> every few years since the late 1990s.  The original idea for
> the Note Well (at least *my* original idea) was that it should
> simply be a pointer to the IETF IPR policy, which has many
> pages of explanation and answers most of the questions that
> people have been raising on this thread.  It should be
> obvious, I think, that a complex process like the IETF's IPR
> disclosure procedure can't be fully explained in a couple of
> sentences.  Any such attempt is bound to be incomplete.

And that, of course, reprises most of the late 1990s (or
thereabouts) discussion to which Scott refers.  We also
discussed two other things that have come up on this most recent
thread in slightly different form:

* The enforceability risks inherent in what we referred to in
that conversation as a "shrink wrap" license, i.e., a "you are
sitting here and hence you have agreed" situation.   My
recollection is that these various notices and reminders
scattered around the registration process, mailing lists, etc.,
arose from that part of the conversation and were attempts to be
able to get a slightly stronger and more defensible agreement.

* The question of whether, if we provided a superficial summary,
someone could argue that it was the "real" agreement or that it
was all they had agreed to, thereby creating loopholes in an
otherwise complex, but carefully explained, policy.

> This being said, there has been a strong desire by many to
> have a summary statement that also serves as a pointer to the
> real policy.  That's what the current Note Well is supposed to
> be.  It is NOT a statement of the IETF's IPR rules.  Those are
> contained in BCP 78/79, and anyone who is responsible for
> his/her company's IPR and/or compliance needs to read those

But, again, that is a reprise of a very old discussion and,
based in large measure on that discussion, represents a tradeoff
between the desire for and advantages of such a summary and the
risks of someone being able to successfully claim that, despite
our intentions, the summary really is the policy.  It seems to
me --from a public policy perspective, not a legal one-- that
the more the summary departs from or exaggerates the actual
rules, the greater that risk becomes.  The latter was, IMO, the
main objection to the IESG's proposed change (and to Pete's "ask
for more than the policy actually requires" formulation in
particular) this time, but it seems to me that trimming things
back to a different summary still doesn't solve the potential
problem even if it might improve the risk-benefit ratio.

    john

---

From: Dave Crocker <[email-masked]>
Date: Sat, 08 Feb 2014 07:21:16 -0800

On 2/7/2014 8:34 PM, Jorge Contreras wrote:
> The original idea for the Note Well (at least *my* original idea)
> wasthat it should simply be a pointer to the IETF IPR policy
...
> This being said, there has been a strong desire by many to have a
> summary statement that also serves as a pointer to the real policy.
>   That's what the current Note Well is supposed to be.  It is NOT a
> statement of the IETF's IPR rules.

Jorge,

You might have noticed that there is currently also quite a strong
concern by many that the approach that has been taken by the Note Well
invites confusion or, at least, arguments of confusion.

I believe that that line of concern leads to exactly what you originally
proposed.

That's why I just circulated some text that says nothing about the
substance of IETF IPR, but makes strong statements about participant
obligations.

d/

---

From: Richard Barnes <[email-masked]>
Date: Sat, 8 Feb 2014 13:47:37 -0500

How about, "IF YOU ARE SEEING THIS TEXT, THEN YOU ARE A PARTICIPANT" :)

--Richard

On Fri, Feb 7, 2014 at 6:42 PM, Christer Holmberg <
[email-masked]> wrote:

> However, it's probably good to have a link to where the meaning of
> "Participation" is defined, because that discussion also comes up every now
> and then...
>
> Regards,
>
> Christer
>

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 8 Feb 2014 19:58:03 +0000

I thought it applies also to e-mail participants :)

Regards,

Christer
________________________________________
From: Richard Barnes [[email-masked]]
Sent: Saturday, 08 February 2014 8:47 PM
To: Christer Holmberg
Cc: [email-masked]; IETF discussion list
Subject: Re: Revision to Note Well

--Richard

On Fri, Feb 7, 2014 at 6:42 PM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Regards,

Christer

________________________________________
From: ietf [[email-masked]<mailto:[email-masked]>] on behalf of Dave Crocker [[email-masked]<mailto:[email-masked]>]
Sent: Saturday, 08 February 2014 1:32 AM
To: IETF discussion list
Subject: Re: Revision to Note Well

Here's what I suggest:

                            NOTE WELL

      *  IETF Anti-harassment Policy, as specified in
         ietf.org/iesg/statement/ietf-anti-harassment-policy.html<http://ietf.org/iesg/statement/ietf-anti-harassment-policy.html>

d/
--
Dave Crocker
Brandenburg InternetWorking
bbiw.net<http://bbiw.net>

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 8 Feb 2014 14:03:06 -0800

> How about, "IF YOU ARE SEEING THIS TEXT, THEN YOU ARE A PARTICIPANT" :)

Is that true? I don't get that sense from the BCPs.

Your smiley is not terribly helpful here: it's not clear if it means "this is clever, yes?" or "what I just said is obviously a joke".

--Paul Hoffman

---

From: Sandy Wills <[email-masked]>
Date: Sat, 08 Feb 2014 17:05:54 -0500

IF YOU SEE THIS, WHETHER IN A PRESENTATION OR IN A DOCUMENT, YOU ARE.....

I am minded of Jeff Foxworthy's wisdom here.

-Sandy Wills

-- 
Unable to locate coffee.
Operator halted.

---

From: Jorge Contreras <[email-masked]>
Date: Mon, 10 Feb 2014 09:13:48 -0500

This is a healthy discussion.  However, if you really care about these
issues (i.e., what constitutes "participation" in an IETF discussion for
purposes of triggering an IPR disclosure) then debating it in the context
of the "Note Well" language is, to put it mildly, a waste of time.  The
actual "rules" that govern this issue are contained in BCP79, which is in
the process of being revised right now.  This exact issue has been
discussed repeatedly in the IPR WG and the rules in BCP79 are being amended
*right now* to deal with concerns that were raised.  If you care and want
to discuss in some way that may actually affect the IETF rules, rather than
a non-substantive pointer to the rules (i.e., "Note Well"), please take a
look at the latest I-D implementing these rules and comment on it:

https://datatracker.ietf.org/doc/draft-bradner-rfc3979bis/

The relevant Sections are 1.c ("Contribution") and 1.k, which actually
defines "Participating in an IETF Discussion or Activity".

Enjoy!

Jorge

---

From: "John Levine" <[email-masked]>
Date: 10 Feb 2014 16:26:21 -0000

>actual "rules" that govern this issue are contained in BCP79, ...

I leared a long time ago that it is futile to try to make people pay
attention when they don't want to.  (Any parent of a teenager or of a
toddler can confirm this.)  So I don't see much point in a notice
beyond something like this:

		       This is an IETF meeting.

     The rules you agreed to when you registered, including those
      about conduct and about intellectual property apply here.

R's,
John

---

From: Dave Crocker <[email-masked]>
Date: Mon, 10 Feb 2014 08:49:13 -0800

On 2/10/2014 8:26 AM, John Levine wrote:
> attention when they don't want to.
...
>        about conduct and about intellectual property apply here.

This has nothing to do with 'want'.  The folks who don't 'want' to be 
responsible and play according to the rules won't, and they will find 
excuses to justify it.

The issue here is about doing proper due diligence that conforms to the 
the ability of average, well-intentioned folk to read and process a 
slide in real-time.  The limitations to that exercise are human 
cognition and attention, not free will.

And it is about the dangers of creating alternate versions of 
information, thereby inviting disparity in the message.

That's why I suggested a slide that is somewhat more informative than 
you offer, mostly by giving explicit pointers:

                              NOTE WELL

d/

---

From: Jari Arkko <[email-masked]>
Date: Tue, 11 Feb 2014 10:40:59 -0500

What Jorge said. You can discuss on the IPR list at https://www.ietf.org/mailman/listinfo/ipr-wg

Jari

On Feb 10, 2014, at 9:13 AM, Jorge Contreras <[email-masked]> wrote:

> This is a healthy discussion.  However, if you really care about these issues (i.e., what constitutes "participation" in an IETF discussion for purposes of triggering an IPR disclosure) then debating it in the context of the "Note Well" language is, to put it mildly, a waste of time.  The actual "rules" that govern this issue are contained in BCP79, which is in the process of being revised right now.  This exact issue has been discussed repeatedly in the IPR WG and the rules in BCP79 are being amended *right now* to deal with concerns that were raised.  If you care and want to discuss in some way that may actually affect the IETF rules, rather than a non-substantive pointer to the rules (i.e., "Note Well"), please take a look at the latest I-D implementing these rules and comment on it:
> 
> The relevant Sections are 1.c ("Contribution") and 1.k, which actually defines "Participating in an IETF Discussion or Activity".
> 
> Enjoy!
> 
> Jorge