Subject: Reviving watersprings.org.

From: Warren Kumari <[email-masked]>
Date: Wed, 2 Jul 2014 14:09:02 -0400

Hi there all,

A number of years ago there was a site called watersprings.org which
archived Internet Drafts and RFCs and provided some interesting
linking between them.
I never used it, but apparently a number of folk really liked the
interface / etc.

The site was hosted in Japan and the creator shut it down to conserve
power after the 2011 tsunami. I provided him a VM (on a machine that
nLayer / Richard Steenbergen hosts for me), and we started migrating
over to it. Unfortunately, he no longer has the time / resources to
run the site, and we never finished the migration / the scripts
haven't run since then.

Anyway, I've offered to take over maintaining the VM, try figure out
how it all works, upgrade it, finish the migration, etc.
Before spending the time on this though, I figured I should check if
folk still want it / think that it will be a useful resource. The time
investment will be fairly significnat, but happy to do it if folk will
use it...

W

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 2 Jul 2014 19:15:13 +0100

Interesting, Warren.

I used to use waterspring and still have an annoying bookmark that autocompletes when I start to type www.wat...

At the time that waterspring was set up we didn't archive old versions of I-Ds and once an I-D had expired it disappeared (related issues, but separately annoying). That is no longer the case, so the (UI aside) the main residual value would be retrieving the archive of old I-Ds and I am not so sure how useful that is, but archivists and IPR lawyers might comment).

Adrian

> -----Original Message-----
> From: ietf [mailto:[email-masked]] On Behalf Of Warren Kumari
> Sent: 02 July 2014 19:09
> To: [email-masked] Disgust
> Subject: Reviving watersprings.org.
> 
> Hi there all,
>

---

From: Dave Crocker <[email-masked]>
Date: Wed, 02 Jul 2014 11:18:38 -0700

On 7/2/2014 11:15 AM, Adrian Farrel wrote:
> expired it disappeared (related issues, but separately annoying). That is no longer the case, so the (UI aside) the main residual value would be retrieving the archive of old I-Ds and I am not so sure how useful that is, but archivists and IPR lawyers might comment).

hmmm. I was always told that the IETF actually did retain all the
original I-Ds.  So what changed was making it easier to get at them.

Methinks the problem is that the older ones -- pre-easy access -- were
never transitioned to the new access model?  That is, I suspect they are
sitting somewhere in an obscure archive that we haven't integrated in.

As for the UI, is it worth considering for the IETF to adopt on its web
site?

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 2 Jul 2014 14:29:19 -0400

I also used to use watersprings, but I have to admit to not having any
particular recollection of the UI other than the ability to search for
particular drafts by a subset of the filename.

Cheers,
Andy

On Wed, Jul 2, 2014 at 2:18 PM, Dave Crocker <[email-masked]> wrote:

> > expired it disappeared (related issues, but separately annoying). That
> is no longer the case, so the (UI aside) the main residual value would be
> retrieving the archive of old I-Ds and I am not so sure how useful that is,
> but archivists and IPR lawyers might comment).
>
>

---

From: Elwyn Davies <[email-masked]>
Date: Wed, 02 Jul 2014 20:13:28 +0100

Hi.

I also quite liked the watersprings interface and was saddened by its
demise.  However, Henrik's draft searching scheme does most of what I
need and the interface at tools.ietf.org/html/draft... gives you the
access to all the versions and output renderings.

The only thing lacking is the ability to have a nicely formatted and
resonably compact list of all the drafts ever made starting with a given
letter.  Useful for idle browsing and finding drafts you can't quite
remember the title or authors of.

Warren: If you have time and enthusiasm I'd be inclined to see if a
couple of extra screens could be added to what we have already rather
than reimplementating a separate Watersprings clone since the back end
is already in place.

I don't think that putting back what Watersprings had exactly would give
you any more ancient history.  I seem to remember that it didn't have
drafts earlier than about 1995, but it's a long time since I checked
that ;-). I did when I was looking for Nimrod routing history and other
stuff for the routing history RFC.

The current tool has a smattering of moderately ancient history already:

Some of the suggestions for IPng are there:
http://tools.ietf.org/html/draft-crocker-ip-encaps-01
http://tools.ietf.org/html/draft-deering-sip-00
(The REAL SIP!)

but I suspect the list is incomplete - however unless the file archives 
are lurking in some server, I don't know how we would know (did
ietf-announce exist in those days and would it help?)

Regards,
Elwyn

---

From: manning bill <[email-masked]>
Date: Wed, 2 Jul 2014 12:35:18 -0700

not that ancient history matters much, but when I worked for Postel, the I-D directory was regularly scrubbed of expired materials.
the notation that drafts were -EXPECTED- to be ephemeral was taken seriously.   I am even aware of some legal challenges to public
archives of materials that were supposed to be expunged.  (which is why the water springs archive was incomplete).
  
All in all, kind of like violating a corporate document retention policy.

/bill

> As for the UI, is it worth considering for the IETF to adopt on its web

/bill
Neca eos omnes.  Deus suos agnoscet.

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 2 Jul 2014 19:50:35 +0000

> At the time that waterspring was set up we didn't archive old versions of I-Ds and once an I-D had expired it disappeared (related issues, but separately annoying). That is no longer the case, so t…

Do we have a place I can download that from? Watersprings lets you download any given draft that it has that you want, but to my knowledge doesn’t allow for a block download/rsync. The IETF used to have such a place, and deleted it. I discovered that by accident when I deleted my mirror with a view to recovering from the IETF. Oops.

I have something I got from Scott Bradner, which is probably complete or mostly complete, but which I have found holes in and filled. My problem is that I don’t know what I don’t know.

---

From: Dan Wing <[email-masked]>
Date: Wed, 2 Jul 2014 19:17:30 -0700

On Jul 2, 2014, at 12:50 PM, Fred Baker (fred) <[email-masked]> wrote:

> Do we have a place I can download that from?

Yes, https://tools.ietf.org says:
"• Unpurged IETF drafts repository:
To list the content, do:
  rsync rsync.tools.ietf.org::tools.id
To sync the content, do:
  rsync -avz rsync.tools.ietf.org::tools.id ./id"

It contains more stuff than Watersprings (back when Watersprings was running) and I have been rsync'ing with it for a couple of years.  It's about 4.5GB of content.

> Watersprings lets you download any given draft that it has that you want, but to my knowledge doesn’t allow for a block download/rsync. The IETF used to have such a place, and deleted it. I discovered that by accident when I deleted my mirror with a view to recovering from the IETF. Oops.
> 

-d

---

From: Warren Kumari <[email-masked]>
Date: Wed, 16 Jul 2014 14:05:24 -0400

> remember the title or authors of.

Well, I finally had a chance to poke at this -- I moved everything
over to a new VM and fixed it there (instead of poking at the existing
one). I never really used the original one, so I'm not sure if I fixed
/ reimplemented all the features.

I also updated some things - the original one was doing some fancy FTP
parsing, which I couldn't really see the point of, so I replaced it
with rsync. Oh, this also didn't update since ~2011, will see if I can
backfill sometime...

Anyway, if folk would like to see the new version, it is at
http://watersprings.snozzages.com -- once if finished futzing with it
I'll change the DNS.

> than reimplementating a separate Watersprings clone since the back end

This was easier, although it did mean relearning Perl -- will look at
reimplementing on the IETF site sometime.

W

---

From: Dean Willis <[email-masked]>
Date: Wed, 16 Jul 2014 21:30:35 -0500

> At the time that waterspring was set up we didn't archive old versions of I-Ds and once an I-D had expired it disappeared (related issues, but separately annoying). That is no longer the case, so t…

Yes, actually I was just about to post a note calling for helping finding some list archives from 1996-2000 that appear to be mostly missing from the IETF site.

The same thing applies to lots of old I-D. These can be critically useful in knocking out nuisance patents. We need them very, very much.

—
Dean

---

From: manning bill <[email-masked]>
Date: Wed, 16 Jul 2014 20:08:26 -0700

just a heads up.   if any of my expired drafts show up that predate IETF copyright, expect a takedown notice.
i am pretty sure you will get the same type of response from Joe Touch.

/bill
PO Box 12317
Marina del Rey, CA 90295
310.322.8102

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 17 Jul 2014 15:59:45 +1200

> just a heads up.   if any of my expired drafts show up that predate IETF copyright, expect a takedown notice.

I hope you're aware that ISOC ceded its rights to the IETF Trust,
so drafts carrying the ISOC copyright wording should belong to the IETF too.

   Brian

---

From: manning bill <[email-masked]>
Date: Wed, 16 Jul 2014 21:15:31 -0700

yes, yes… 

however there are more than a decades worth of IDs that carry no ISOC/IETF copyright.  For those, the rights exist only with the authors.
As a condition of publication was the fact that they were intended/expected to be ephemeral and the IETF right to publish expired six months
after initial publication.   

It would be a real shame to have the IETF and its participants knowingly violate others rights by republication of their works without explicit 
written permission.  This is not the first time this has come up in an IETF context and is certainly discoverable as evidence of willful intent to steal  
intellectual property of others.

so Warren, it might be wise to consider the scope of your efforts and if you choose to go after early materials,   consider the prudence of getting
prior, written permission before making blanket presumptions of propriety or legality.

/bill

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 17 Jul 2014 16:36:12 +1200

fwiw I hereby give permission for any of my drafts, however old
and embarassing, to be placed on line.

I can't speak for my various employers but I suspect that they
really, really do not care.

Regards
   Brian Carpenter

---

From: Randy Bush <[email-masked]>
Date: Thu, 17 Jul 2014 18:13:39 +0900

> just a heads up.   if any of my expired drafts show up that predate
> IETF copyright, expect a takedown notice. 

cool!  i'll add to my collection

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Thu, 17 Jul 2014 13:16:16 +0000

Thanks.

BTW, it turns out that the IETF *has* a comparable rsync site. One syncs
	rsync -avz rsync.tools.ietf.org::tools.id ./id
rather than
	rsync -avz [—delete] ietf.org::internet-drafts
I had been using the latter.

http://trac.tools.ietf.org/group/tools/trac/wiki/DataSources

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Thu, 17 Jul 2014 13:21:30 +0000

The oldest draft on rsync.tools.ietf.org, draft-ietf-mpsnmp-overipx-00.txt, contains no ISOC *or* IETF copyright boilerplate.

---

From: [email-masked] (Martin Rex)
Date: Thu, 17 Jul 2014 20:41:27 +0200 (CEST)

manning bill wrote:
> 
> however there are more than a decades worth of IDs that carry no
> ISOC/IETF copyright.  For those, the rights exist only with the authors.
> As a condition of publication was the fact that they were
> intended/expected to be ephemeral and the IETF right to publish
> expired six months after initial publication.   

You might want to recheck the applicable copyright law terms.

A "publication" has a significant impact of the amount of control 
the copyright holder has on what happens to a copyrighted works.

In Germany, the legal term is "Erschöpfungsgrundsatz", in the US,
a vaguely similar legal concept seems to exist under the name
"first sale doctrine".

-Martin

---

From: Joe Touch <[email-masked]>
Date: Thu, 17 Jul 2014 13:25:12 -0700

> i am pretty sure you will get the same type of response from Joe Touch.

+1

---

From: "John Levine" <[email-masked]>
Date: 18 Jul 2014 01:11:37 -0000

>a vaguely similar legal concept seems to exist under the name

Having spent way too much time dealing with US copyright law (see,
for example, http://en.wikipedia.org/wiki/Field_v._Google ) I can
say with great confidence that the first sale doctrine is completely
irrelevant here.

Bill could certainly send DMCA takedown notices for drafts for which
he has not assigned the copyright, and whoever was hosting the drafts
would have to respond, perhaps by taking them down, perhaps not.

I also happen to think that there is a very strong chance that a court
would find a non-commercial archive of historic IETF documents to be
protected by fair use.  And I know that for documents that have not
had their copyright registered with the US Copyright office, the most
one could recover were one to win such a suit is actual damages which
in this case would be zero, so he'd have to pay the full cost of a
lawsuit in Federal court, out of pocket.  Draw your own conclusions.

R's,
John