Subject: Re: If I may inquire, what exactly does the IETF Organization stand for? Acronym aside. What is the goal? Who are you people?

From: Donald Eastlake <[email-masked]>
Date: Fri, 25 Jul 2014 01:18:47 -0400

At the upper left of the ietf.org web page there is a Mission link:
http://www.ietf.org/about/mission.html
Or you could see http://www.rfc-editor.org/rfc/rfc3935.txt

Donald

On Fri, Jul 25, 2014 at 1:03 AM,  <[email-masked]> wrote:

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 25 Jul 2014 14:40:01 +0200

On Fri, Jul 25, 2014 at 01:18:47AM -0400,
 Donald Eastlake <[email-masked]> wrote 

> Or you could see http://www.rfc-editor.org/rfc/rfc3935.txt

If you want to join, there is also a page for newcomers:

http://www.ietf.org/newcomers.html

---

From: Yoav Nir <[email-masked]>
Date: Fri, 25 Jul 2014 10:33:32 -0400

As one former AD summed it up once: “to make the Internet work better”.

Yoav