Subject: Re: Last Call: <draft-dawkins-iesg-one-or-more-04.txt> (Increasing the Number of Area Directors in an IETF Area) to Best Current Practice

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 18 Dec 2014 16:47:45 -0600

There's really nothing as awesome as sending Last Call comments on your own
draft. You should try it some time ... or not.

But please see below.

On Mon, Dec 8, 2014 at 5:53 PM, The IESG <[email-masked]> wrote:
>
>
> The IESG has received a request from an individual submitter to consider
> the following document:
> - 'Increasing the Number of Area Directors in an IETF Area'
>   <draft-dawkins-iesg-one-or-more-04.txt> as Best Current Practice
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2015-01-05. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.

I had a chat with Scott Bradner today, and Scott asked me to explain some
history in a different way. The text he questioned was this:

OLD

   In the distant past, all IETF Areas had a single Area Director.  The
   movement from single Area Directors in an Area to pairs of Area
   Directors in most Areas happened over a period of years (for
   reference, see http://www.ietf.org/iesg/past-members.html), as part
   of the IESG organizing itself to do the work the IESG is chartered to
   do.

END

Scott said that changes in the number of Area Directors assigned to a given
Area during "the modern era", post Kobe, wasn't quite the linear
progression I described, and suggested (my words, trying to capture his
thoughts), something more like this:

NEW

While it's true that recent IESGs have had two Area Directors in each Area
except for the General Area, the number of Area Directors in each Area has
varied since https://www.ietf.org/rfc/rfc1396.txt (for reference, see
http://www.ietf.org/iesg/past-members.html).

This variation was due to a number of factors, including workload and
personal preferences, and happened as a natural part of the IESG organizing
itself to do the work the IESG is chartered to do.

At one point, the IESG placed three Area Directors in a single Area (Scott
Bradner, Deirdre Kostick, and Michael O'Dell, in the Operational &
Management Requirements Area, between IETF 36 and IETF 37 in 1996).

END

I wouldn't mind hearing people's opinions about making this change as part
of Last Call, and I don't think the rest of the IESG would mind, either ...

Thanks!
Spencer

Abstract
>
>
>    This document removes a limit on the number of Area Directors who
>    manage an Area in the definition of "IETF Area".  This document
>    updates RFC 2026 (BCP 9) and RFC 2418 (BCP 25).
>
>
>
>
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-dawkins-iesg-one-or-more/
>
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-dawkins-iesg-one-or-more/ballot/
>
>
> No IPR declarations have been submitted directly on this I-D.
>
>
>

---

From: Michael StJohns <[email-masked]>
Date: Thu, 18 Dec 2014 19:02:49 -0500

At 05:47 PM 12/18/2014, Spencer Dawkins at IETF wrote:

>NEW
>
>While it's true that recent IESGs have had two Area Directors in each Area except for the General Area, the number of Area Directors in each Area has varied since <https://www.ietf.org/rfc/rfc1396.txt>https://www.ietf.org/rfc/rfc1396.txt (for reference, see <http://www.ietf.org/iesg/past-members.html>http://www.ietf.org/iesg/past-members.html).Â 
>
>This variation was due to a number of factors, including workload and personal preferences, and happened as a natural part of the IESG organizing itself to do the work the IESG is chartered to do.Â 
>
>At one point, the IESG placed three Area Directors in a single Area (Scott Bradner, Deirdre Kostick, and Michael O'Dell, in the Operational & Management Requirements Area, between IETF 36 and IETF 37 in 1996).

I don't think I have any real problems with the original language.

The particular case that Scott cites though was due to the combining of two different areas - Operations (which had 2 ADs) and Network Management (which had 1).  That happened midway through the cycle and not (AIRC) as part of the Nomcom placing three people as ADs for Ops and Management.

So it was transitional, and reflected in the next Nomcom results which brought the O&M AD count down to two.   Operationally, I don't think it affected which groups the ADs had had before the merge.

Mike

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 18 Dec 2014 18:10:16 -0600

On Dec 18, 2014 6:02 PM, "Michael StJohns" <[email-masked]> wrote:
>> While it's true that recent IESGs have had two Area Directors in each
Area except for the General Area, the number of Area Directors in each Area
has varied since https://www.ietf.org/rfc/rfc1396.txt (for reference, see
http://www.ietf.org/iesg/past-members.html).Â
personal preferences, and happened as a natural part of the IESG organizing
itself to do the work the IESG is chartered to do.Â
>>
>> At one point, the IESG placed three Area Directors in a single Area
(Scott Bradner, Deirdre Kostick, and Michael O'Dell, in the Operational &
Management Requirements Area, between IETF 36 and IETF 37 in 1996).
> The particular case that Scott cites though was due to the combining of
two different areas - Operations (which had 2 ADs) and Network Management
(which had 1).  That happened midway through the cycle and not (AIRC) as
part of the Nomcom placing three people as ADs for Ops and Management.
>
> So it was transitional, and reflected in the next Nomcom results which
brought the O&M AD count down to two.   Operationally, I don't think it
affected which groups the ADs had had before the merge.
> Mike

Hi, Mike,

Right - that's what I think I'm pointing to - that there's not a natural
law that says all areas are exactly two ADs wide, and things can move
around, and IESGs can work out specifics with Nomcoms.

Thanks for the extra background - it's helpful.

Spencer

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 18 Dec 2014 20:58:34 -0500

On Thu, Dec 18, 2014 at 5:47 PM, Spencer Dawkins at IETF
<[email-masked]> wrote:
> ...
> Area during "the modern era", post Kobe, wasn't quite the linear progression
> I described, and suggested (my words, trying to capture his thoughts),
> something more like this:
>
> NEW
>

I think it is a good change to the text. It grounds the change to the
limit on the number of ADs in real events.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

>>...

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 19 Dec 2014 10:50:10 +0000

I agree with the principle of this draft and agree that the IESG should
have the flexibility to structure the size of areas and the set the number
of ADs per area at an appropriate level.

I do have a concern that when the number of ADs falls to one as there
can be issues of conflict of interest that need technical expertise to
resolve. There is also the issue of there being no natural AD for IETF
participants to turn to in such circumstances. It would be useful if
the proposed BCP gave a little guidance to cover such circumstances
such as considering the, perhaps temporary, merging of areas so
that there were three responsible ADs rather than just one.

- Stewart

---

From: John Leslie <[email-masked]>
Date: Fri, 19 Dec 2014 10:20:48 -0500

> that there were three responsible ADs rather than just one.

   I suspect what you mean is that individual WGs could have their
Responsible AD temporarily assigned from another Area (or perhaps
their backup AD temporarily assigned).

   That probably would have helped when Martin was stuck as sole AD
in the Trasnport area.

   And it would be good to allow the IESG leeway to do that. But I'm
not sure it belongs in this document...

--
John Leslie <[email-masked]>

---

From: Dave Crocker <[email-masked]>
Date: Fri, 19 Dec 2014 08:14:00 -0800

On 12/19/2014 2:50 AM, Stewart Bryant wrote:
> It would be useful if

Although you said "such as", there is an underling challenge of figuring
out meaningful and appropriate handling choices.  And the example you
gave is in fact the one being offered by the IESG.  And there are no
alternatives to that being discussed.

The premise of 'areas' is that the subjects are different.  The base of
knowledge for one area is different from another area.

How does merging disparate subjects provide cover for the one lacking an
alternative AD?

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Jari Arkko <[email-masked]>
Date: Sun, 21 Dec 2014 22:26:18 +0200

Stewart,

> of ADs per area at an appropriate level.

Thanks.

> that there were three responsible ADs rather than just one.

You mention one factor, but there are others, such as having someone to talk to, ability to deal with events like someone being sick or on vacation, and so on. Yet we’ve had one AD areas. And most ADs tend to have multiple areas of expertise from what I can see, even if their primary expertise is on one area. I think the IETF and the IESG are generally aware of these tradeoffs and issues. Anyway, we are not considering the creation of additional single-AD areas at this time :-)

Jari

---

From: "Stewart Bryant (stbryant)" <[email-masked]>
Date: Mon, 22 Dec 2014 07:25:56 +0000

Sent from my iPad

> On 21 Dec 2014, at 20:26, Jari Arkko <[email-masked]> wrote:
> 
> 
> Stewart,
> 

Jari

Yes, there are so many good reasons why it is useful for there to be at least 2 ADs to an area.

Regarding the creation of additional single-AD areas, I am puzzled because your recent public message to Nomcom stated that you wished to reduce APPs to a single AD. Has this position changed?

Stewart

---

From: Jari Arkko <[email-masked]>
Date: Mon, 22 Dec 2014 12:56:29 +0200

Stewart,

> Regarding the creation of additional single-AD areas, I am puzzled because your recent public message to Nomcom stated that you wished to reduce APPs to a single AD. Has this position changed?

It is a question of a temporary situation vs. long term goal. Stay tuned - we will have more information soon…

Jari