Subject: Gen-ART LC review for draft-ietf-l3vpn-end-system-04

From: "Peter Yee" <[email-masked]>
Date: Tue, 9 Dec 2014 00:08:41 -0800

I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>

Please resolve these comments along with any other Last Call comments you may receive.

Document: draft-ietf-l3vpn-end-system-04
Reviewer: Peter Yee
Review Date: Dec-8-2014
IETF LC End Date: Dec-8-2014
IESG Telechat date: TBD

Summary: This draft is basically ready for publication as a Standards Track RFC, but has some nits that should be fixed before publication. [Ready with nits.]

This draft documents a novel means of using XMPP to signal VPN route information between VPN Forwarders and End-System Route Servers for use with BGP IP VPNs.  It discussed the requirements on each entity using the scheme.

Major issues:

Minor issues: 

Nits:

General: Use a comma after i.e. and e.g.

General: Data center doesn't require a hyphen.  Neither does virtual machine.  Wi-Fi does, however.

Page 3, definition of End-System, 1st sentence: change "which" to "whose".

Page 4, 4th paragraph, last sentence: replace "recur to" with "rely upon".

Page 6, 3rd paragraph, 1st sentence: delete "then".

Page 10, 1st paragraph, 1st sentence: delete redundant "the".

Page 10, 1st paragraph, 2nd sentence: change "mac-" to "MAC ".  Change "a IEEE" to "an IEEE".

Page 11, figure: this figure needs a caption with a figure number.  That will force an increment of all of the following figure numbers as well.

Page 16, 1st paragraph after XML, last sentence: change "convinience" to "convenience".

Page 16, 2nd paragraph, 3rd sentence: replace the period with a comma and change the following "Even" to lower case to join the following clause to the sentence.

Page 17, 4th paragraph, 2nd sentence: replace "detemined" with "determined".  Replace "an" with "a".

Page 17, 5th paragraph, 2nd sentence: replace "mapps" with "maps".

Page 18, Section 8, 4th paragraph, 1st sentence: change "a XMPP" to "an XMPP".

Page 19, 1st paragraph, 2nd sentence: change "attachement" to "attachment".

Page 20, 1st full paragraph, 1st sentence: I'm not certain, but would inserting "the" before "host" help?  Or how about a host number after "host"?

Page 20, 7th paragraph, 2nd sentence: change "Assuming" to "Assume".

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 9 Dec 2014 12:51:54 -0000

Thanks for the nits, Peter.

We'll be sure to look at them if the document is open again before being passed to the RFC editor.

Adrian

> -----Original Message-----
> From: ietf [mailto:[email-masked]] On Behalf Of Peter Yee
> Sent: 09 December 2014 08:09
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Gen-ART LC review for draft-ietf-l3vpn-end-system-04
> 
> I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART,
> please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>
> 
> Summary: This draft is basically ready for publication as a Standards Track RFC, but
> has some nits that should be fixed before publication. [Ready with nits.]
> 
> This draft documents a novel means of using XMPP to signal VPN route
> information between VPN Forwarders and End-System Route Servers for use
> with BGP IP VPNs.  It discussed the requirements on each entity using the
> scheme.
> 
> Major issues:
> 
> Minor issues:
> 
> Nits:
> 
> Page 11, figure: this figure needs a caption with a figure number.  That will force
> an increment of all of the following figure numbers as well.
> 
> Page 16, 2nd paragraph, 3rd sentence: replace the period with a comma and
> change the following "Even" to lower case to join the following clause to the
> sentence.
> 
> Page 20, 1st full paragraph, 1st sentence: I'm not certain, but would inserting
> "the" before "host" help?  Or how about a host number after "host"?
>