Subject: Community Input on change to the Trust Legal Provisions to accommodate the inclusion of RFC Templates

From: Tobias Gondrom <[email-masked]>
Date: Tue, 27 Jan 2015 14:23:12 +0000

Dear IETFers,

The IETF Trust has been requested by the IESG and RFC Editor to provide 
a license in cases
where RFCs contain Templates. The Trustees propose modifying the Trust 
Legal Provisions
(TLP) based upon a need to extract and fill in text from RFCs that 
contain Templates.  E.g.
the Internet-Draft draft-ietf-sidr-cps-04 contains a Template for others 
to copy and modify.
Under the normal TLP provisions this would be considered a derivative 
work and not permitted.

The current TLP is here: 
<http://trustee.ietf.org/license-info/IETF-TLP-4.pdf>.

The Trustees’ response is a proposed change to the TLP that addresses 
the issue for this and
future RFCs.  The change enables specific text in an RFC that is 
designated as a Template to be
subject to a new provision in the TLP that says that extraction and 
modification are authorized.

The Trustees are considering the following language changes to the TLP 
to permit the modification
of RFC Templates:

9.  Template Text

a.  Certain RFCs may contain text designated as “Template Text” by the 
inclusion of the following
legend in the introduction to the RFC:

     “This RFC contains text intended for use as a template as 
designated below by the markers
<BEGIN TEMPLATE TEXT> and <END TEMPLATE TEXT> or other clear 
designation.  Such
Template Text is subject to the provisions of Section 9(b) of the Trust 
Legal Provisions.”

b.   In addition to the other rights granted under the TLP with respect 
to each RFC, the Trust grants
to all interested persons a non-exclusive, royalty-free, worldwide, 
perpetual right and license under
all copyrights and rights of authors to make, reproduce, publish and 
distribute modifications of the
Template Text (e.g., to insert specific information in place of blanks 
or place-holders), and reproduce,
modify and distribute such modified Template Text.

We would like hear your thoughts on changing the Trust Legal Provisions 
to accommodate the inclusion
of RFC Templates. Comments will be considered that are received through 
25th February.

Thank you for your assistance.

Tobias Gondrom
Chair, IETF Trust

---

From: John C Klensin <[email-masked]>
Date: Tue, 27 Jan 2015 09:56:46 -0500

--On Tuesday, January 27, 2015 14:23 +0000 Tobias Gondrom
<[email-masked]> wrote:

> The IETF Trust has been requested by the IESG and RFC Editor
> to provide a license in cases
> where RFCs contain Templates. The Trustees propose modifying
> the Trust Legal Provisions
> (TLP) based upon a need to extract and fill in text from RFCs
> that contain Templates.  E.g.
>...
> The Trustees' response is a proposed change to the TLP that
> addresses the issue for this and
> future RFCs.  The change enables specific text in an RFC that
> is designated as a Template to be
> subject to a new provision in the TLP that says that
> extraction and modification are authorized.
>...
> We would like hear your thoughts on changing the Trust Legal
> Provisions to accommodate the inclusion
> of RFC Templates. Comments will be considered that are
> received through 25th February.

Tobias,

IANAL (other disclaimers incorporated by hand-waving), but a
plain-English reading of this indicated that the text gives
permission to modify the text of the template itself.  That
raises all of the issues that caused us to try to make
enforceable copyright claims on the RFC series in the first
place-- someone could use such derived text (maliciously or not)
to mislead others about IETF statements, intent, and
requirements.

I'll leave it to the Trustees and Counsel to determine whether
that threat is worth worrying about, but it seems to me it would
be easy, if desired, to allow copying but restrict it, either by
intended use or by not allowing the template text to be
modified, only that the template be filled in and used as
specified, or both.

     john

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 27 Jan 2015 10:43:15 -0500

That seems like a good idea.
Thank you.
Joel

---

From: Sam Hartman <[email-masked]>
Date: Tue, 27 Jan 2015 10:37:16 -0500

>>>>> "John" == John C Klensin <[email-masked]> writes:

    John> Tobias,

    John> IANAL (other disclaimers incorporated by hand-waving), but a
    John> plain-English reading of this indicated that the text gives
    John> permission to modify the text of the template itself.  That
    John> raises all of the issues that caused us to try to make
    John> enforceable copyright claims on the RFC series in the first
    John> place-- someone could use such derived text (maliciously or
    John> not) to mislead others about IETF statements, intent, and
    John> requirements.

I'd like to specifically disagree with John and say that I'd like to see
the trust be very liberal in grating license exceptions when the IETF
purposes are served.
There are significant  costs to asking the trust to be more liberal when
we discover that our needs are not  met by our licensing.
I have always disagreed that there is significant harm that will happen
if people modify IETF documents  especially if those modifications are
labeled.

Especially when the IETF's purposes are served by allowing people to
modify and fill in templates I hope that  we can choose to be liberal.

Examples of things that might require modification of templates:

* Turning a template into an HTML web form

* Turning a template into some sort of wizard to  collect the
  information

* Including a template in an open-source product that requires a liberal
  license.

I believe the IETF's purposes are typically served by all of the above,
so I believ it is important to be very liberal in our licensing here.

--Sam

---

From: Alia Atlas <[email-masked]>
Date: Tue, 27 Jan 2015 13:08:37 -0500

This looks very useful to me.

Thank you,
Alia

On Tue, Jan 27, 2015 at 9:23 AM, Tobias Gondrom <[email-masked]>
wrote:

> Dear IETFers,
>
> The IETF Trust has been requested by the IESG and RFC Editor to provide a
> license in cases
> (TLP) based upon a need to extract and fill in text from RFCs that contain
> Templates.  E.g.
> Under the normal TLP provisions this would be considered a derivative work
> and not permitted.
>
> The current TLP is here: <http://trustee.ietf.org/
> license-info/IETF-TLP-4.pdf>.
>
> The Trustees’ response is a proposed change to the TLP that addresses the
> issue for this and
> The Trustees are considering the following language changes to the TLP to
> permit the modification
> of RFC Templates:
>
> 9.  Template Text
>
>     “This RFC contains text intended for use as a template as designated
> below by the markers
> <BEGIN TEMPLATE TEXT> and <END TEMPLATE TEXT> or other clear designation.
> Such
> b.   In addition to the other rights granted under the TLP with respect to
> each RFC, the Trust grants
> Template Text (e.g., to insert specific information in place of blanks or
> place-holders), and reproduce,
> We would like hear your thoughts on changing the Trust Legal Provisions to
> accommodate the inclusion

---

From: Eric Gray <[email-masked]>
Date: Tue, 27 Jan 2015 18:48:52 +0000

+1

From: ietf [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Tuesday, January 27, 2015 1:09 PM
To: IETF Discussion Mailing List
Cc: [email-masked]
Subject: Re: Community Input on change to the Trust Legal Provisions to accommodate the inclusion of RFC Templates

Thank you,
Alia

On Tue, Jan 27, 2015 at 9:23 AM, Tobias Gondrom <[email-masked]<mailto:[email-masked]>> wrote:
Dear IETFers,

The IETF Trust has been requested by the IESG and RFC Editor to provide a license in cases
where RFCs contain Templates. The Trustees propose modifying the Trust Legal Provisions
(TLP) based upon a need to extract and fill in text from RFCs that contain Templates.  E.g.
the Internet-Draft draft-ietf-sidr-cps-04 contains a Template for others to copy and modify.
Under the normal TLP provisions this would be considered a derivative work and not permitted.

The current TLP is here: <http://trustee.ietf.org/license-info/IETF-TLP-4.pdf>.

The Trustees’ response is a proposed change to the TLP that addresses the issue for this and
future RFCs.  The change enables specific text in an RFC that is designated as a Template to be
subject to a new provision in the TLP that says that extraction and modification are authorized.

The Trustees are considering the following language changes to the TLP to permit the modification
of RFC Templates:

9.  Template Text

a.  Certain RFCs may contain text designated as “Template Text” by the inclusion of the following
legend in the introduction to the RFC:

    “This RFC contains text intended for use as a template as designated below by the markers
<BEGIN TEMPLATE TEXT> and <END TEMPLATE TEXT> or other clear designation.  Such
Template Text is subject to the provisions of Section 9(b) of the Trust Legal Provisions.”

b.   In addition to the other rights granted under the TLP with respect to each RFC, the Trust grants
to all interested persons a non-exclusive, royalty-free, worldwide, perpetual right and license under
all copyrights and rights of authors to make, reproduce, publish and distribute modifications of the
Template Text (e.g., to insert specific information in place of blanks or place-holders), and reproduce,
modify and distribute such modified Template Text.

We would like hear your thoughts on changing the Trust Legal Provisions to accommodate the inclusion
of RFC Templates. Comments will be considered that are received through 25th February.

Tobias Gondrom
Chair, IETF Trust

---

From: Stephan Wenger <[email-masked]>
Date: Tue, 27 Jan 2015 20:35:54 +0000

Hi,

Question: have you guys considered this scenario? There are a number of
pre-5378 RFCs that appear to include templates (just search the
datatracker for the word ³template²--and there may be more).  If one of
these templates gets updated in an I-D and RFC, the trust may lack the
rights to provide a license to change or fill in the template.

A similar situation is covered in the TLP 4.0 by section 6.c.iii.
However, the situation is more severe here, because a template¹s main (or
only?) purpose is to be modified (by being filled in).

I think it may be worthwhile to document that the proposed language and
mechanism below is incompatible with updates of pre 5378 templates, unless
the necessary rights for the pre-5378 template I-D were obtained by the
trust.  In other words, the language and mechanism proposed below MUST NOT
be used for templates based on templates published in pre-05378 RFCs,
unless the trust has obtain a license under the necessary rights from the
relevant right holders (authors of pre-RFC5378 RFCs or, in some cases,
their employers).

Stephan

On 1/27/15, 06:23, "Tobias Gondrom" <[email-masked]> wrote:

>The Trustees¹ response is a proposed change to the TLP that addresses
>the issue for this and
>a.  Certain RFCs may contain text designated as ³Template Text² by the
>     ³This RFC contains text intended for use as a template as
>Legal Provisions.²

---

From: "John Levine" <[email-masked]>
Date: 28 Jan 2015 03:16:39 -0000

>permission to modify the text of the template itself.

It does, but I don't see what practical problem this causes.

Templates are functional, so the copyrights on them are pretty thin in
the first place, and once extracted from the RFC without the rest of
the RFC text, what do we care?  We've allowed modified versions of
code components for quite a while, and as far as I know that hasn't
caused any problems for the IETF.

The proposed language looks OK to me.  I have no strong opinion
on the effect on RFCs derived from old RFCs but the chances of this
causing a problem in practice seem vanishingly small.

R's,
John

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 28 Jan 2015 17:22:59 +1300

> caused any problems for the IETF.

I agree, and in fact my first reaction was to wonder why we don't just
lump templates in with code.

    Brian

---

From: Sean Turner <[email-masked]>
Date: Thu, 29 Jan 2015 15:21:28 -0500

+1

spt

On Jan 27, 2015, at 13:48, Eric Gray <[email-masked]> wrote:

> On Tue, Jan 27, 2015 at 9:23 AM, Tobias Gondrom <[email-masked]> wrote:
> Dear IETFers,
>

---

From: Matthew Lepinski <[email-masked]>
Date: Fri, 30 Jan 2015 11:21:58 -0500

It would be good to be able to support templates in the RFC series.

The proposed text from Tobias looks quite reasonable.

---

From: John C Klensin <[email-masked]>
Date: Sat, 31 Jan 2015 08:56:31 -0500

--On Tuesday, January 27, 2015 10:37 -0500 Sam Hartman
<[email-masked]> wrote:

>     John> IANAL (other disclaimers incorporated by
> hand-waving), but a     John> plain-English reading of this
> indicated that the text gives     John> permission to modify
> the text of the template itself.  That     John> raises all of
> the issues that caused us to try to make     John> enforceable
> copyright claims on the RFC series in the first     John>
> place-- someone could use such derived text (maliciously or
> I'd like to specifically disagree with John and say that I'd
> like to see the trust be very liberal in grating license
> exceptions when the IETF purposes are served.
> There are significant  costs to asking the trust to be more
> liberal when we discover that our needs are not  met by our
> licensing. I have always disagreed that there is significant
> harm that will happen if people modify IETF documents
> especially if those modifications are labeled.
>...

Just to close the loop, my hope was that the trust would
consider the advantages and disadvantages of a policy broad
enough to allow people to reproduce _and_ modify the templates
in non-IETF / non-IANA contexts.  Sam has explained (thoroughly
and well, IMO) the advantages.

However, when I combine his position with several of the other
comments that have been made, I wonder whether the right policy
would be to take us back to just about where were were long
before we started making strong copyright claims about RFCs and
certainly before several IPR WG efforts and the IETF Trust came
into being and started making very specific policies.  That
ancient policy was, in essence, "do what you like with RFCs but
please acknowledge and, if you making excerpts and/or changes,
be very clear about what you have done and how it relates to the
original in your acknowledgments".

I have _very_ mixed feelings whether that policy or the current
"need to ask permission except for a list of exception cases
that keeps getting longer and more complicated" policy (noting
the comments about why the "template" policy needs to be
different from the "code" policy) is the better one, but I hope
that the IETF Trust is asking that question again each time a
requirement for a new, and time consuming, policy tweak comes
up.  Part of that question, which I'm sure the Trust has
considered but on which it has not briefed the community, is how
egregious or harmful a violation would have to be before
presumably-limited resources were spent trying to mount an
enforcement action.

    john