Subject: Re: last call and IESG processing summary for draft-ietf-ianaplan-icg-response

From: Jari Arkko <[email-masked]>
Date: Tue, 6 Jan 2015 11:57:47 +0200

This is an updated and final summary of the last call and conclusion from the IESG processing of this draft. Two minor editorial changes are being made in a -09 that will be posted shortly, and the approval announcement comes out after that.

This document has attained rough consensus of the IETF Working Group and of the IETF community as a whole, as judged first by the working group chairs and then by the sponsoring Area Director, and then by the IESG in accordance with RFC 2026 in the December 18 IESG telechat. The IESG has approved the draft, and as noted the formal approval announcement is due as soon as the new version is uploaded.

Over the course of the development of the document, several suggestions were raised that did not enjoy sufficient support to be included. Two main ones worth mentioning include

	• A suggestion for a stronger statement over what terms the IAOC should negotiate.  

	• A suggestion that "iana.org" and other associated marks be transferred to the IETF trust.

At the end of the working group process, although there was not unanimous support for the results, the working group chairs concluded that rough consensus existed in the working group. The document shepherd’s summary of the WG consensus for this document can be found here: 

 https://datatracker.ietf.org/doc/draft-ietf-ianaplan-icg-response/shepherdwriteup/

During IETF last call, additional people voiced support for the document. There were several editorial comments that resulted in changes, as well as some discussion of more substantial comments some of which resulted in text changes. There was some discussion of comments already discussed earlier in the process, and but no new objections were raised during the IETF last call. A summary of the last call comments can be found from the end of this e-mail.

New draft versions had been prepared by the editors per discussions on the mailing list and with the sponsoring AD. The new versions and associated changes can be found here:

  https://tools.ietf.org/html/draft-ietf-ianaplan-icg-response-07 (primary changes after last call)
  https://tools.ietf.org/html/draft-ietf-ianaplan-icg-response-08 (text from the IAB, description of the level of consensus)
  https://tools.ietf.org/html/draft-ietf-ianaplan-icg-response-09 (two editorial corrections)
  http://www.ietf.org/rfcdiff?url1=draft-ietf-ianaplan-icg-response-06&url2=draft-ietf-ianaplan-icg-response-09 (all changes)

During the IETF last call and IESG evaluation, the following points were made:

	• Positive evaluation from Christer Holmberg, Melinda Shore, Alissa Cooper, Richard Barnes, and Ted Lemon. Currently, there is a Yes position from 12 Area Directors.

	• Editorial comments from Brian Carpenter, Sean Turner, Pete Resnick, Adrian Farrell, Spencer Dawkins, Alissa Cooper, Alia Atlas, Richard Barnes, and Christer Holmberg. These have resulted in text changes.

	• A comment from Pete Resnick around the use of full text from IETF mission statement RFC. This has resulted in a text change.

	• A comment from Sean Turner about some missing parts in the response. This has resulted in text changes.

	• Agreement with the general message, but a question and a concern from John Levine around roles in policy disputes, and contracts in case of changes in who is the IANA operator. These were resolved through discussion with Eliot Leor, Brian Carpenter, and Jari Arkko. This resulted in text changes.

	• Discussion on the availability of text for Section 5 and how that can be handled process-wise, started by Adrian Farrell. Suggested resolution is to use the text that IAB wants to indicate, "The IAB supports the response in this document". The text is now out in the working group list, which it was not before. A new document version is needed to add this text.

	• Discussion on the role of the document after IESG approval, and whether the goal was to get IESG review or approval. The sponsoring AD believes that it is important to use our normal approval process, and ensure that the IESG agrees with the consensus assessments in this case. Whether the document gets published as an RFC or not is somewhat immaterial, because the main purpose of providing an IETF view on the matter is to collect several views together from different organisations to gather a complete transition proposal.

	• Discussion of the rationale for concluding rough consensus from Richard Hill (responses from Marc Blanchet, Andrew Sullivan, Milton Mueller, Jari Arkko, Brian Carpenter, John Curran, and Jefsey). Richard was requesting a justification (beyond information already available) for why the conclusion was what it was, and deferring the IESG decision.

	• Recommendation to the IAOC to create stronger supplemental or replacement agreements between the IETF and ICANN, by Milton Mueller and the Internet Governance Project. The recommendation recognises the rough consensus behind the current proposal that specifies requirements but does not call out explicit agreement mechanisms, but suggests that the stronger agreements would be extremely significant. The recommendation goes on to "provide information to the IETF's leadership regarding what the unresolved issues were, why it is important to resolve them, and how it might respond to them with supplemental agreements". The recommendation also states that the advocated actions are in line with the current IANAPLAN draft. The IAOC has taken this input for consideration. It should be noted that these recommendations were discussed as part of the WG deliberations, however. The WG consensus did not agree with the recommendations.

	• Jefsey has noted that he intends to file a future appeal on this topic, around the responsibilities of the IETF and RFC 6852. Jefsey notes "My point will not be to change it, but to make sure that the IESG, and IAB, and ISOC, fully and publicly declare that they understand, accept and decide that this is what they mean." It is not clear that there is anything to do about this at the moment, particularly when at least the sponsoring AD does not understand the provided feedback; this is an IETF document that will, as it gains approval, will have been processed by the IESG and will explicitly note that the IAB supports the described transition. Response by Andrew Sullivan on December 15 indicates that he does not believe any changes to the document or the summaries produced by the WG officials were necessary.

	• The IAOC has indicated that they are comfortable with the direction the document gives for the IAOC.

Jari Arkko, the sponsoring Area Director for draft-ietf-ianaplan-icg-response

---

From: Jari Arkko <[email-masked]>
Date: Wed, 7 Jan 2015 02:01:41 +0200

Milton:

>> -----Original Message-----
>> goes on to "provide information to the IETF's leadership regarding what the
>> unresolved issues were, why it is important to resolve them, and how it
>> might respond to them with supplemental agreements". The
>> recommendation also states that the advocated actions are in line with the
>> current IANAPLAN draft. The IAOC has taken this input for consideration. It
>> should be noted that these recommendations were discussed as part of the
>> WG deliberations, however. The WG consensus did not agree with the
>> recommendations.
> 
> I am afraid this is incorrect. The WG consensus said that it was not necessary to specify the exact supplemental agreements to be negotiated - that this should be left to the IAOC. My understanding of the document, and my basis for agreeing to rough consensus, was that the IAOC could pursue these or not, as it saw fit. 

I think we may be trying to say the same thing. The document discusses what needs to be achieved. The WG’s opinion of what is necessary for the transition. But the WG did not want to put into the document (a) detailed contractual language as that is an IAOC task or (b) additional requests beyond the ones listed in the document. However, the IAOC certainly is in charge of all specific contract language already, and will be also in this case. They will also consider any additional elements that they think will be useful or needed, as they will always.

Hope this helps,

Jari

---

From: Milton L Mueller <[email-masked]>
Date: Tue, 6 Jan 2015 21:16:19 +0000

---

From: Milton L Mueller <[email-masked]>
Date: Wed, 7 Jan 2015 18:05:26 +0000

> > I am afraid this is incorrect. The WG consensus said that it was not
> necessary to specify the exact supplemental agreements to be negotiated -
> that this should be left to the IAOC. My understanding of the document, and
> my basis for agreeing to rough consensus, was that the IAOC could pursue
> these or not, as it saw fit.
> 
> I think we may be trying to say the same thing. The document discusses what
> needs to be achieved. The WG's opinion of what is necessary for the
> transition. But the WG did not want to put into the document (a) detailed
> contractual language as that is an IAOC task or (b) additional requests
> beyond the ones listed in the document. However, the IAOC certainly is in
> charge of all specific contract language already, and will be also in this case.
> They will also consider any additional elements that they think will be useful
> or needed, as they will always.

Great, this is my understanding, too. So you should modify the assessment of my comments because they say "The recommendation also states that the advocated actions are in line with the current IANAPLAN draft. The IAOC has taken this input for consideration. It should be noted that these recommendations were discussed as part of the WG deliberations, however. The WG consensus did not agree with the recommendations."

That's the part that is not correct. 

The WG consensus was that there should not be detailed contractual language in the document, as you say. It did not, however, foreclose or negate the suggestions I made for future IAOC requests, it simply said that they should not be specified or required by the IANAPlan document. The IAOC retains the ability to request them if it thinks it appropriate in the near term negotiations. 

I hope you understand the distinction. It was crucial to achieving rough consensus.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 08 Jan 2015 08:32:35 +1300

Try "The WG consensus did not agree with including the recommendations."

Regards
   Brian

On 08/01/2015 07:05, Milton L Mueller wrote:
> _______________________________________________
> Ianaplan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ianaplan
>

---

From: Jari Arkko <[email-masked]>
Date: Wed, 7 Jan 2015 21:41:47 +0200

> Try "The WG consensus did not agree with including the recommendations.”

I’m happy with Brian’s formulation. Thanks.

Jari

---

From: Seun Ojedeji <[email-masked]>
Date: Thu, 8 Jan 2015 05:12:59 +0100

Sounds like double positive since consensus is a form of agreement.

How about:

"The WG achieved consensus not to include the recommendations."

Cheers!
sent from Google nexus 4
kindly excuse brevity and typos.
On 7 Jan 2015 20:32, "Brian E Carpenter" <[email-masked]>
wrote:

> > Great, this is my understanding, too. So you should modify the
> assessment of my comments because they say "The recommendation also states
> that the advocated actions are in line with the current IANAPLAN draft. The
> IAOC has taken this input for consideration. It should be noted that these
> recommendations were discussed as part of the WG deliberations, however.
> The WG consensus did not agree with the recommendations."
> >
> > The WG consensus was that there should not be detailed contractual
> language in the document, as you say. It did not, however, foreclose or
> negate the suggestions I made for future IAOC requests, it simply said that
> they should not be specified or required by the IANAPlan document. The IAOC
> retains the ability to request them if it thinks it appropriate in the near
> term negotiations.
> >

---

From: Milton L Mueller <[email-masked]>
Date: Thu, 8 Jan 2015 12:41:40 +0000

I would accept "The WG consensus did not agree with including the recommendations in the ICG response but this does not preclude the IAOC from pursuing them."

> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Wednesday, January 7, 2015 2:33 PM
> To: Milton L Mueller; Jari Arkko
> Cc: Ianaplan@Ietf. Org; [email-masked]; draft-ietf-ianaplan-icg-
> [email-masked]; IETF-Discussion list
> Subject: Re: [Ianaplan] last call and IESG processing summary for draft-ietf-
> ianaplan-icg-response
> 
> Try "
> 
> Regards
>    Brian
> 
> >> necessary to specify the exact supplemental agreements to be
> >> negotiated - that this should be left to the IAOC. My understanding
> >> of the document, and my basis for agreeing to rough consensus, was
> >> that the IAOC could pursue these or not, as it saw fit.
> >>
> >> I think we may be trying to say the same thing. The document
> >> discusses what needs to be achieved. The WG's opinion of what is
> >> necessary for the transition. But the WG did not want to put into the
> >> document (a) detailed contractual language as that is an IAOC task or
> >> (b) additional requests beyond the ones listed in the document.
> >> However, the IAOC certainly is in charge of all specific contract language
> already, and will be also in this case.
> >> They will also consider any additional elements that they think will
> >> be useful or needed, as they will always.
> >
> > Great, this is my understanding, too. So you should modify the assessment
> of my comments because they say "The recommendation also states that the
> advocated actions are in line with the current IANAPLAN draft. The IAOC has
> taken this input for consideration. It should be noted that these
> they should not be specified or required by the IANAPlan document. The
> IAOC retains the ability to request them if it thinks it appropriate in the near
> term negotiations.
> >

---

From: Jari Arkko <[email-masked]>
Date: Fri, 9 Jan 2015 19:12:37 +0100

> I would accept "The WG consensus did not agree with including the recommendations in the ICG response but this does not preclude the IAOC from pursuing them.”

I think that is fine too (speaking as one IAOC member). Moving on...

Jari